[Ffmpeg-devel-irc] ffmpeg.log.20120221

burek burek021 at gmail.com
Wed Feb 22 02:05:02 CET 2012

[01:12] <lucas^> ffmpeg says this file has 50356 video frames
[01:12] <lucas^> comskip says it has 59258
[01:12] <lucas^> which do I trust?
[03:12] <AdamWorld> Hi!
[03:14] <AdamWorld> I run ffserver in CentOS and ffmpeg in windows like ffmpeg -i disney.avi but in ffmpeg "Operation not permitted" error occurrd. In localhost It succeeds. What wrong with me?
[03:15] <AdamWorld> The correct err is " Operation not permitted". Help me.
[03:53] <AdamWorld> no one anwers...
[03:56] <grepper> gee, one minute and no one answers :)
[09:04] <AdamWorld> Hi! I run "ffserver.exe" in CentOS with command:"./ffserver -f doc/ffserver.conf" and "ffmpeg.exe" in windows like "ffmpeg -i 1.avi" but " Operation not permitted" occurred. What's wrong with me?
[10:38] <elkng> are "ffmpeg" and "mencoder" competitors same way as "vim" and "emacs" or "linux" and "windows" ?
[10:40] <dirtycookie> hello people, back in november last year i tried to install ffmpeg from source onto my ubuntu, and i get this message:"ffmpeg: relocation error: /usr/local/lib/libswresample.so.0: symbol av_opt_set_int, version LIBAVUTIL_51 not defined in file libavutil.so.51 with link time reference"
[10:40] <dirtycookie> i left it because i didnt have the time to fix it. i wanted to ask howto uninstall it
[10:41] <ubitux> elkng: mukashi mukashi, there was mplayer+mencoder, then ffmpeg spawned, and was meant to replace mencoder. mencoder isn't maintain much anymore for years, and all dev is meant to be done on ffmpeg (even/especially from a mplayer point of view)
[10:42] <ubitux> dirtycookie: make uninstall from the source directory?
[10:42] <dirtycookie> ubitux: i would if i only had the folder
[10:43] <ubitux> do you still have your ./configure in mind?
[10:43] <ubitux> mind/history
[10:43] <cbreak-work> elkng: ffmpeg is a subset of mplayer
[10:44] <cbreak-work> (not organisational but in code, because mplayer uses ffmpeg as library)
[10:44] <ubitux> cbreak-work: mmh, better say ffmpeg provides libraries used in mplayer
[10:44] <cbreak-work> the last time I checked, ffmpeg was added as subrepository to mplayer
[10:45] <ubitux> ton simplifies things, but using the term "subset" is a bit confusion imo, since the goal aren't really the same
[10:46] <ubitux> s/ton/to/
[10:46] <ubitux> but well, whatever :)
[11:23] <dirtycookie> ubitux: history couldn't give me something useful to work wit
[11:23] <dirtycookie> h
[11:24] <ubitux> where is it installed?
[11:24] <ubitux> /usr/local?
[11:30] <dirtycookie> ubitus:/usr/bin /usr/local/bin /usr/local/share usr/share
[11:31] <ubitux> you have two installs then
[11:31] <ubitux> one with --prefix=/usr and another one with --prefix=/usr/local (the default)
[11:32] <ubitux> you may check out the repository, ./configure --prefix=... and then make uninstall
[12:18] <kriegerod> ubitux, could you tell me personally, how should i pull AVFrame with audio data from AVFilterBufferRef?
[12:23] <ArmandoDolce> hi at all
[12:23] <ArmandoDolce> can i use ffmpeg to convert wma to mp3 ?
[12:23] <ArmandoDolce> or i must use LAME ?
[12:24] <Mavrik> ArmandoDolce: you can use FFMPEG with libmp3lame :)
[12:27] <ArmandoDolce> but lame convert only wav to mp3
[12:27] <ArmandoDolce> lame don't convert wma to mo3
[12:27] <ArmandoDolce> lame don't convert wma to mp3
[12:27] <ArmandoDolce> is it right ?
[12:28] <Mavrik> ArmandoDolce: wouldn't know about that
[12:28] <Mavrik> but ffmpeg with libmp3lame can do those conversions
[12:28] <ArmandoDolce> ok
[12:28] <ArmandoDolce> listen
[12:28] <ArmandoDolce> what options i must use to have low format ?
[12:28] <Mavrik> low format?
[12:28] <ArmandoDolce> example 22050 hertz
[12:28] <Mavrik> something like
[12:29] <Mavrik> ffmpeg -i <input_file> -acodec libmp3lame -ar 22050 output.mp3
[12:29] <Mavrik> -ab 128k to set bitrate
[12:29] <Mavrik> -ac 2 to set channels
[12:55] <ubitux> kriegerod: you don't "pull" an avframe given a avfilterbufferef
[12:55] <ubitux> you create an avframe, and then fill it with the settings
[12:55] <ubitux> look at encode_audio_frame() in ffmpeg.c
[12:56] <kriegerod> but is there an analog to avfilter_fill_frame_from_video_buffer_ref()?
[13:00] <ubitux> no but i have one locally
[13:00] <ubitux> http://pastie.org/3426550
[13:00] <ubitux> which do this
[13:00] <ubitux> you can inline something similar
[13:01] <kriegerod> could you please post it to devel ml? it is good to have in API
[13:01] <ubitux> it will be part of the -af patchset
[13:01] <ubitux> i'm working on it
[13:01] <kriegerod> great, when do you feel the patchset to be ready?
[13:02] <ubitux> i have one major issue, so i don't know
[13:03] <kriegerod> what is the issue? do you have your changes in some public git fork, so someone can contribute?
[13:03] <ubitux> it's a local WIP, there is no need to contribute; i just need to figure out the best way to fix a bug
[13:05] <ubitux> the issue is that it doesn't deal with a change in number of channels
[13:06] <kriegerod> ok. thanks again for your WIP, i guess it must simplify ffmpeg.c a lot, because resampling and so on can be moved into audio filtering
[13:06] <ubitux> well, ideally yes, but at the moment no :)
[13:06] <ubitux> it actually complicates things a lot
[13:06] <ubitux> for instance if you yes -af ... and then -ac
[13:06] <ubitux> and -ar
[13:07] <ubitux> also, the audio compensation code in ffmpeg.c is still needed
[13:07] <ubitux> and that's the hard part
[13:07] <ubitux> s/yes/have/ (dafuck.)
[13:08] <ubitux> well anyway, better continue this discussion on #ffmpeg-devel
[13:41] <spacepluk> hi, is it possible to filter arbitrary sections from an mpegts using libavformat?  I've seen some code to add sectionfilters but I'm not sure if/how it can be used from an application
[14:01] <kriegerod> spacepluk: possible, but tricky. i can sell you the code that does that (apply video filters to certain time interval, remuxing without re-encoding as much as possible)
[14:05] <kriegerod> spacepluk: if you want to just cut specific piece of video, then you could say it simpler and i'd answer you to use -ss and -t options
[14:06] <kriegerod> spacepluk: or, from API, to seek the input AVFormatContext to needed place, then remux all frames to output until end of time interval is reached
[14:36] <spacepluk> kriegerod: I meant sections as in DVB-SI tables
[14:37] <kriegerod> i don't know what's this at all
[14:37] <kriegerod> maybe you mean you have multi-program MPEG TS?
[14:39] <spacepluk> yes, I'd like to be able to fetch sections from arbitrary tables like EIT not just PAT/PMT and then parse the tables on my application
[14:42] <spacepluk> I guess that's not possible
[14:44] <kriegerod> sorry, i don't understand that in terms of tables, i can say that you can manage to read only the program you need by looking AVFormatContext.programs[], and figuring out which AVStreams belong to needed program
[14:47] <spacepluk> I'm not interested in AV data here, only Service Information tables embedded in the transport stream
[14:49] <spacepluk> mpegts_open_section_filter in libavformat/mpegts.c seems to be what I want, but I'm not sure if I can access that functionality from the application
[14:49] <kriegerod> sure can't - its internal, static function
[14:49] <kriegerod> did you look at libdvbpsi?
[14:51] <spacepluk> yes, but I think I still need a way to fetch the sections
[14:52] <kriegerod> example apps in libdvbpsi distribution show how to open the stream and feed it to analyzing functions
[14:53] <kriegerod> then, as i recall, it'll trigger some callback func you provide, when it finds particular table
[14:54] <spacepluk> oh, I've looked at libdvbsi++ which is a different library I'll check this one, thank you very much
[15:28] <littlebit> hi im trying to resize a 720 mp4 file to 480 with ffmpeg, but I get the error message "Unsopported codec for output stream #0.1", how can i enable x264. I'm  using debian in a vbox.
[18:03] <grepper> what is stream 0.1 ?  Check the output of ffmpeg -i FILE
[19:35] <slackyman> hi
[19:36] <sacarasc> Hi.
[19:36] <slackyman> I'm cross compiling ffmpeg with libass
[19:36] <slackyman> I get an error regarding fribidi
[19:36] <slackyman> I compiled fribidi, fontconfig and libxml2
[19:37] <slackyman> all went fine
[19:37] <slackyman> but when I compile ffmpeg I got "libass.a(ass_shaper.o):ass_shaper.c:(.text+0x140): undefined reference to `__imp__fribidi_get_joining_types'
[19:37] <slackyman> "
[19:38] <slackyman> I moved all the private libs in libs in every *.pc pkg-config file
[19:44] <mgeary> hi folks
[19:44] <mgeary> i'm struggling with pixel formats
[19:46] <mgeary> i've got a video that is 720x480 with pixel format rgb24. I'm trying to shrink it to 480x320, but when i try using -s 480x320 or -vf scale=480:320, the result is 432x320
[19:46] <mgeary> ffmpeg output follows
[19:47] <mgeary> http://dpaste.com/706453/ <-- i suspect at least one issue is the warning, "Incompatible pixel format 'rgb24' for codec 'libx264', auto-selecting format 'yuv420p'"
[19:47] <mgeary> but i'm not sure where to go from here
[19:51] <GA-Flix> Hi everyone :)
[19:51] <GA-Flix> I was in here a few days ago and asked whether i'm allowed to include ffmpeg.exe into my project.
[19:51] <GA-Flix> I'm still not sure whether i am or not, so i ask you again, this time with screenshots:
[19:51] <GA-Flix>
[19:51] <GA-Flix>
[19:51] <GA-Flix> Maybe someone has a little bit time for my problem :)
[19:51] <GA-Flix> Thanks
[19:56] <GA-Flix> (additional info: the project is freeware)
[20:05] <slackyman> GA-Flix: is the source of your project distribuited or is your software provided with a "written offer" for the source?
[20:06] <GA-Flix> i don't know the difference (my english is not the best)
[20:06] <GA-Flix> i will not publish the code :)
[20:07] <hugogee> greets all
[20:08] <slackyman> it's not so easy, GA-Flix
[20:08] <GA-Flix> ouh :(
[20:08] <slackyman> ffmpeg is gpl-ed
[20:08] <hugogee> why would converting flac to wav cause the sound to repeat 4-6 timex?
[20:08] <slackyman> but..
[20:08] <slackyman> wait
[20:08] <hugogee> drivin me mad!
[20:09] <slackyman> http://www.gnu.org/licenses/gpl-2.0.html
[20:11] <GA-Flix> slackyman, isn't that like only for people who publish a modified ffmpeg.exe file?
[20:11] <GA-Flix> (my ffmpeg.exe is original)
[20:11] <slackyman> read the point #10
[20:12] <GA-Flix> slackyman, so i need to contact the owner of ffmpeg.org and ask for permission? :)
[20:12] <slackyman> read also the last sentence
[20:12] <slackyman> This General Public License does not permit incorporating your program into proprietary programs. If your program is a subroutine library, you may consider it more useful to permit linking proprietary applications with the library. If this is what you want to do, use the GNU Lesser General Public License instead of this License.
[20:13] <slackyman> so
[20:13] <slackyman> LGPL is applyed to libraries
[20:13] <slackyman> like libavcodec
[20:14] <slackyman> you can make a program linking that library
[20:14] <slackyman> it's a difficult question
[20:14] <GA-Flix> but i don't use the library (ffmpeg.dll), do i? ô.0
[20:14] <slackyman> yep
[20:14] <slackyman> you are not using that
[20:14] <slackyman> but you can do something
[20:14] <slackyman> like...
[20:15] <slackyman> your program can be distribuited WITHOUT ffmpeg
[20:15] <slackyman> but at first launch it download ffmpeg.exe
[20:15] <slackyman> :)
[20:15] <GA-Flix> uuh, nice
[20:15] <slackyman> so you are not DISTRIBUTING a copy of ffmpeg
[20:15] <slackyman> and you are gpl-free
[20:16] <slackyman> or... I think so
[20:16] <slackyman> :)
[20:16] <GA-Flix> okay :) that's really good news for me ^^ thank you very very much :)
[20:16] <slackyman> maybe you can email someone here at ffmpeg to know something more
[20:17] <slackyman> I think that asking is always the best way
[20:17] <slackyman> or maybe you can contact fss
[20:17] <slackyman> free software foundation
[20:18] <GA-Flix> ehm ^^ okay ^^
[20:18] <GA-Flix> i think i'll contact a ffmpeg member
[20:18] <GA-Flix> cuz i don't know whether there's a german "free software foundation" ^^
[20:19] <slackyman> I think there's a european section
[20:19] <slackyman> GA-Flix: but why are you thinking not to distribute the code?
[20:19] <slackyman> which language are you using?
[20:20] <GA-Flix> C#
[20:20] <slackyman> omg
[20:20] <slackyman> O.o
[20:21] <slackyman> I'm italian, by the way :)
[20:21] <GA-Flix> i know that everyone who wants can easily decompile my file, but i don't want all the unskilled guys who just use copy&paste do get it ^^
[20:21] <hugogee> what is the best codec to convert form flac to wav?
[20:21] <GA-Flix> ah, ok ^^
[20:21] <slackyman> GA-Flix: you're missing the advantages of free softwaer with open source
[20:21] <GA-Flix> sounds interesting ^^
[20:22] <slackyman> hugogee: I think libflac
[20:22] <GA-Flix> slackyman, can u tell me more (or do you have a link?)
[20:22] <hugogee> ty slackyman
[20:22] <slackyman> as decoder
[20:22] <Bisqwit> I used to do "ffmpeg -t 200 -loop_input -i <jpegfilename> -vcodec mpeg2video -qscale 1 -g 600 -r ntsc -f mp2 output.mpg" to convert a static image into video using ffmpeg. Nowadays, it complains that -loop_input is deprecated and one should use -loop. I replaced "-loop_input" with "-loop 1", but I get "Output file #0 does not contain any stream" error. Any remedy?
[20:22] <hugogee> slackyman, is that what is used by default?
[20:23] <slackyman> GA-Flix: if you publish the source maybe someone can steal your project, but some other people can find bugs and fix them
[20:23] <hugogee> pcm_s16le is causing echos is there a bug?
[20:24] <slackyman> hugogee: you can download flac.exe somewhere
[20:24] <GA-Flix> slackyman, the program was created as quick-'n'-dirty program for a few people
[20:25] <GA-Flix> i don't think that bugs are that hard in this case ^^
[20:25] <hugogee> i am on linux
[20:25] <slackyman> GA-Flix: I know the case, but you can publish it on the web (even if there's a billion of youtube-downloader) and make money by donations or banners or ads
[20:25] <Bisqwit> I found solution. Insert "-map 0:0" and it works. I wonder why it did not do that by default.
[20:26] <slackyman> hugogee: you can get flac binary
[20:26] <hugogee> i wrote a script to convert a bunch of files and some just echo. WTF so i tried to convert a single file from cli. same.
[20:26] <slackyman> hugogee: http://flac.sourceforge.net/download.html
[20:26] <slackyman> download flac
[20:27] <slackyman> flac can convert flac files to waves
[20:27] <hugogee> Is there something wrong with this??? ffmpeg -i one.flac -acodec pcm_s16le -ac 1 -ab 64k -ar 8000 one.wav
[20:27] <slackyman> hugogee: my mistake :) FLAC is used to convert TO flac
[20:27] <hugogee> ok i will get flac, just annoyed this is happening. :D
[20:28] <hugogee> doh
[20:28] <slackyman> hugogee: try  ffmpeg -i one.flac -ab 64k one.wav
[20:28] <hugogee> k
[20:29] <Freakshow> hmm... -loop_input seems intriguing... does that actually work on static input files (e.g. .flv or mp4)?
[20:29] <mgeary> does the pixel format have anything to do with pixel aspect ratio?
[20:29] <hugogee> same sheeit. i guess it must be the files, although i recorded them on the same system, same time, same app.?!
[20:30] <slackyman> hugogee: give me a moment: I make a try
[20:30] <hugogee> slackyman: can i send you the file?
[20:31] <slackyman> hugogee: ok
[20:31] <slackyman> I just tried to convert a flac file to a wav one without problems
[20:34] <Freakshow> looks like -loop_input is deprecated... and I don't see any additional info in the docs for -loop
[20:34] <Freakshow> any clues?
[20:34] <Bisqwit> "-loop 1" is apparently what it's replaced with. I don't know what else it can be
[20:35] <Freakshow> that's what I'm going to assume as well
[20:35] <Freakshow> now, what's a supported format?
[20:35] <Freakshow> :P
[20:35] <Bisqwit> It only works on image2 inputs
[20:36] <Freakshow> ah... boooo
[20:44] <GA-Flix> bb slackyman and thank you very much :)
[20:46] <slackyman> by GA-Flix
[20:47] <slackyman> I cannot cross compile ffmpeg with libass
[20:48] <slackyman> it keeps giving me error about fribidi
[21:47] <mgeary> so, about these pixel aspect ratios....
[21:53] <pasteeater> mgeary: i see no mention of 432 in your paste. i assume you mean some player is resizing it.
[21:55] <mgeary> pasteeater: sorry. here is the command that generated that output: ffmpeg -i in.mov -s 480x320 out.mp4
[21:56] <mgeary> and yes, when i view the result in Quicktime, it reports it as 432x320
[21:56] <pasteeater> i had a feeling it was quicktime
[21:56] <mgeary> but you are correct that ffmpeg -i out.mp4 does report an apparent size of 480x320 :S
[21:57] <mgeary> i'm also confused by this "Incompatible pixel format" message
[21:57] <nextime> hello all
[21:58] <nextime> is there a way to get a network stream and dump audio and video to two separate pipes concurrently?
[22:00] <pasteeater> mgeary: ignore that message. the libx264 encoder doesn't support rgb, so it converts to yuv420p (the libx264rbg encoder does support rgb, but you probably want yuv420p anyway)
[22:00] <mgeary> pasteeater: aha, okay. cool
[22:01] <pasteeater> and most players only support YUV anyway
[22:01] <pasteeater> AFAIK
[22:02] <mgeary> works for me. i just was gathering from the output message that it wasn't using H.264, but i do see now that it is
[22:02] <mgeary> so if i could just get it to play back at the expected size, i'd be set
[22:05] <pasteeater> does ffplay look as you would expect?
[22:07] <mgeary> i don't have ffplay on my machine (Mac). Lemme try in VLC...
[22:10] <mgeary> well, VLC reports it as 480x320, but it is actually displaying at ~480x355 :S
[22:13] <pasteeater> you can force a desired aspect with Video > Aspect Ratio
[22:13] <pasteeater> in VLC
[22:15] <mgeary> but clearly something is unusual (to me), presumably in my source media, because this kind of thing doesn't usually happen (in Quicktime). If i specify or change the PAR, would that make it work the way i expect?
[22:42] <Franz> hi everyone
[22:42] <mgeary> bongiorno Franz
[22:44] <Franz> i need your help... I'm trying to convert a .mp4 (H.264 with AAC) file to avi format, so i can play the video on my moviestation... But right now, nothing has worked... Can you please help me?
[22:44] <Franz> thank you and sorry for my bad english
[22:45] <mgeary> Franz: do you get an error when you try to use ffmpeg to do this?
[22:46] <Franz> mgeary: nope, i've tried thing like: ffmpeg -i file.mp4 -ab 128k -ar 48000 -acodec libmp3lame -vb 866k -async 1 -vtag XVID file.avi
[22:47] <Franz> no errors, wmp play it well, but my moviestation wont read it
[22:48] <mgeary> ah. i'm afraid i'm neither an ffmpeg expert, nor do i know anything about moviestation. Sorry. Maybe someone else here can help
[22:49] <Franz> ah ok, thanks anyway mgeary!
[23:22] <Freakshow> btw, thanks kriegerod for that assist with the multi output, works nicely
[23:23] <kriegerod> Np
[23:26] <Freakshow> I'm curious if there's a way to split the log output per output stream
[23:28] <Freakshow> because I can't define the first output rtsp://blah.foo.com/output/stream 2> log -b:500k -bt 500k so on and so forth
[23:28] <Freakshow> as it decides it's done and just starts the first output only
[23:29] <Freakshow> meanwhile the log complains that -b is an unknown command
[23:29] <Freakshow> :P
[23:38] <kriegerod> Try newer ffmpeg
[23:41] <bove> Anyone know how coeficients are decided when converting rgb to yuv?
[23:48] <Freakshow> :P 0.9.1 isn't new enough?
[23:55] <vadim__> hi everyone
[23:56] <vadim__> how can "circular_buffer: OVERRUN" error be solved?..
[23:59] <nextime> #2 try: is there a way to say to ffmpeg to dump audio and video on two separate pipes in output? i know about -an and -vn, but i need to work in realtime on a network stream, so, i can't do it in two passes
[00:00] --- Wed Feb 22 2012

More information about the Ffmpeg-devel-irc mailing list