[Ffmpeg-devel-irc] ffmpeg.log.20131203

burek burek021 at gmail.com
Wed Dec 4 02:05:01 CET 2013

[00:00] <ian_m> since x11grab may not be able to provide exactly 30 fps
[00:07] <ian_m> I gave you the full command above. Do you want me to post the output with -r 30?
[00:08] <llogan> both commands in separate pasebin links
[00:09] <ian_m> ok, I used the sections feature from pastie. I will make seperate pasties for them.
[00:10] <ian_m> llogan: only x11grab http://pastie.org/8524075
[00:10] <llogan> sorry, i see you already provided the overlay link earlier
[00:10] <llogan> there is no console output in this last link you provided
[00:11] <ian_m> right, I thought you wanted only the command in its own link
[00:11] <ian_m> or something
[00:11] <ian_m> it's the same as the first link...
[00:14] <ian_m> OK, here they are one more time. command+output for only x11grab: http://pastie.org/8524085 and for x11grab+video4linux2: http://pastie.org/8524055
[00:14] <llogan> thanks
[00:14] <ian_m> no problem
[00:27] <llogan> ian_m: do you know if this used to be faster with a previous ffmpeg version?
[00:28] <ian_m> llogan: no, but I can try with an older version
[00:30] <llogan> ian_m: does it perform differently if you replace the -framerate for x11gram with -r?
[00:30] <llogan> *x11grab
[00:30] <ian_m> llogan: yes
[00:30] <llogan> ah, you mentioned that before
[00:30] <ian_m> right
[00:31] <ian_m> I don't want to destroy the timestamps from x11grab though
[00:35] <llogan> ian_m: i'm not sure why it's so slow... you might want to try the ffmpeg-user mailing list.
[00:35] <ian_m> ok
[00:35] <llogan> sorry
[00:35] <ian_m> no problem, thanks for looking at it
[01:35] <z1lt0id> Hi guys just wondering what type of deinterlacer the default ffmpeg one is
[01:35] <z1lt0id> is it a field deinterlacer
[01:35] <z1lt0id> or a smart one like yadif
[01:50] <llogan> z1lt0id: you mean -deinterlace?
[02:08] <gamax92> Hello. Just a quick question on why ffmpeg is dropping frames when converting a series of images to a video.
[02:08] <gamax92> http://pastebin.com/57uMhnqJ Here is my command and output log.
[02:09] <llogan> gamax92: probably because your input frames are changing pixel formats
[02:10] <gamax92> Hmm, do you know how to get them all in the same format then? The images were created from imagemagick.
[02:12] <llogan> you could probably use convert or mogrify to make them all the same
[02:16] <gamax92> Ahh, changing the format from png to something like bmp worked.
[02:17] <gamax92> thanks llogan
[02:18] <gamax92> oh one more thing, the quality I get from the resulting video is very bad.
[02:18] <gamax92> How can I improved it
[02:19] <klaxa> use different encoding settings
[02:19] <klaxa> are you aiming for a specific device?
[02:19] <gamax92> youtube.
[02:19] <klaxa> or is "just an up-to-date encode" what you want
[02:19] <klaxa> ah
[02:20] <klaxa> just use the extension .mkv instead of .avi, ffmpeg will probably choose rather well suited codecs
[02:20] <klaxa> youtube knows how to handle mkv
[02:20] <gamax92> ooh thats much better.
[02:20] <klaxa> if you want more specific settings see the x264 encoding guide: https://trac.ffmpeg.org/wiki/x264EncodingGuide
[02:20] <gamax92> thanks
[02:21] <gamax92> Now to just make my C application record more than 10 seconds of video before crashing, lol.
[02:22] <klaxa> heh
[02:22] <llogan> gamax92: odd. it will skip frames if you use -r as an input option, even -r 25 (which is the default), but not if you omit -r or use -framerate
[02:23] <gamax92> well, when i didn't put the input framerate the video was 24 seconds instead of 10.
[02:23] <llogan> yes. so use -framerate instead
[02:23] <gamax92> for input or output?
[02:23] <llogan> input
[02:28] <gamax92> oh right
[02:29] <gamax92> would it be possible to read the frames in their raw state? The program dumps the frames as a RGB-640x480 raw data.
[02:29] <llogan> i believe so. or you could pipe directly from your program to ffmpeg
[02:29] <gamax92> wouldn't that involve writing binary data to the program's output?
[02:32] <llogan> i don't know anything about your program. as for raw input, something like: ffmpeg -f rawvideo -s 1280x720 -pix_fmt rgb24 -i
[02:33] <llogan> untested. you may have to monkey with it
[02:33] <gamax92> alright, I'll try that.
[02:50] <SirCmpwn> how do I include man pages when compiling and installing ffmpeg from source
[03:17] <llogan> SirCmpwn: they should automatcially be generated
[03:17] <SirCmpwn> yeah, I fixed my problem
[03:17] <SirCmpwn> sorry for the trouble
[03:17] <llogan> what was the problem and how did you fix it?
[03:17] <SirCmpwn> the problem was that I was building it from fish, not bash
[03:18] <SirCmpwn> and I hadn't sourced /etc/profile.d/perlbin.sh
[03:18] <SirCmpwn> I fixed it by building it from bash after sourcing that
[03:18] <llogan> oh
[03:20] <llogan> SirCmpwn: how do you like fish?
[03:20] <SirCmpwn> I'm not sure how I feel about fish
[03:20] <SirCmpwn> I think it's really nice, but I miss things like !!
[03:20] <SirCmpwn> if they could get off their high horse and add support for it, fish'd be amazing
[03:22] <z1lt0id> Interesting when I compile FFMPEG i get freetype2 not found but it is installed.
[03:22] <z1lt0id> is there a reason why this would be happening?
[03:23] <llogan> use pastebin to show the head and tail (or at least the first and last ~50 lines) of config.log
[03:24] <z1lt0id> okidoki
[03:54] <z1lt0id> http://pastebin.com/B9xCBqSM
[03:54] <z1lt0id> sorry for the delay
[03:54] <z1lt0id> my freetype.h is located in /usr/include/freetype2
[03:54] <z1lt0id> hope that helps llogan :)
[04:01] <drv> it looks like it should be in a freetype dir (i believe that is how the official freetype make install places it)
[04:02] <drv> mine is in /usr/include/freetype2/freetype/freetype.h for maximum redundancy ;)
[04:05] <z1lt0id> ahhh
[04:07] <z1lt0id> testing that now
[04:07] <z1lt0id> yeah i was using the infinality freetype2 patches
[04:11] <z1lt0id> indeed i copied it a freetype dir and it worked
[04:11] <z1lt0id> i informed the packager maintainer of the infinality fonts on arch
[04:11] <z1lt0id> thank you :)
[05:10] <SirCmpwn> any solution for dithering problems with h264->gif?
[05:44] <LithosLaptop> dithering problems?
[06:36] <Evil_J0k3r> hey, I'm trying to grab my X screen with x11grab. the higher i set the input size the worse my performance gets. is this normal behaviour? I'm trying to set up some script that always records the last minutes of a game (like the new consoles). I'm not sure if this is normal behaviour or a bug in xorg or r600g.
[06:36] <Evil_J0k3r> command: 'nice -n 19 ffmpeg -f x11grab -r 25 -s 1920x1080 -i :0 -c:v rawvideo -f null -y /dev/null'
[06:41] <relaxed> of course it is
[06:43] <Evil_J0k3r> relaxed: why is that so? i guess it's related to buffer copy?
[06:43] <Evil_J0k3r> and is there some way to get better perfomance?
[06:46] <relaxed> larger frames require more resources
[06:48] <Evil_J0k3r> y, but I'm not doing anything with the frames, i jsut grab them and discard them
[06:48] <Evil_J0k3r> this shouldnt have such a high impact
[06:49] <Evil_J0k3r> the most computational power is normally used for encoding
[06:58] <relaxed> you're interfacing with X11 too
[07:38] <SirCmpwn> LithosLaptop: ffmpeg -i whatever foo.gif -> foo.gif has dithering artifacts all over it, every time
[07:39] <LithosLaptop> I don't get it. It is supposed to dither
[12:13] <mrmr> is it possible to record skype conversations? like input and output audio?
[13:22] <Floh79> Hi, I'm trying to play rtmp stream with avplay (even tried with ffplay). But nothing happens. How can I find out why nothing happens?
[13:23] <Floh79> http://pastebin.com/rhQN2SG1
[15:24] <Digitalis> hi
[15:25] <Digitalis> i am using ffmpeg with a input from vlc (rtp connexion) and transcode it to h264 then send it to a wowza server
[15:26] <Digitalis> everything is fine but when vlc plays the next video of the playlist i get the error "PES packet size mismatch" then ffmpeg seems to be frozen
[15:26] <Digitalis> any idea is welcome
[16:27] <Digitalis_> any idea for my problem ?
[18:48] <Digit_> hi again
[18:49] <Digit_> trying to use ffmpeg with an rtp input from vlc and i get a lot of different errors
[18:50] <Digit_> PES packet size mismatch ,error while decoding MB 0 15, bytestream (-5), Failed to update header with correct duration.ra Failed to update header with correct filesize., Error while decoding stream #0:0: Invalid data found when processing input
[18:51] <Digit_> i am getting image and sound in the output streaming but with artifacts and something like lag
[18:57] <Digit_> any idea ?
[19:41] <bacon1989> Hello peeps
[19:42] <bacon1989> I'm a little new to ffmpeg, and i've been looking to how I could use it to find out more media information on a given file
[19:43] <bacon1989> i've been looking at ffprobe, and i'm wondering if the statically compiled ffmpeg.exe includes ffprobe in it?
[19:43] <blez> I want to input a stream in stdin and ouput in stdout, how to do that?
[19:44] <blez> "ffmpeg -i - -acodec libmp3lame -" ?
[19:44] <blez> (I'm on Windows)
[19:50] <Digit_> what do you mean by stdin ?
[19:51] <blez> ok, let's say it's not stdin. I have the line: ffmpeg -i http://asd/some.ogg and I want to convert it to mp3 and stream it to stdout
[19:51] <blez> how?
[19:52] <Digit_> well i don't know what you mean with stdout ...
[19:52] <blez> "ffmpeg -i http://asd/some.ogg -acodec libmp3lame -" says: Unable to find a suitable output format for 'pipe:'
[19:52] <Digit_> oh pipes....
[19:52] <Digit_> i never used ffmpeg with pipes
[19:53] <cbsrobot> blez: specify the format with -f
[19:53] <cbsrobot> f.ex -f pcm_s16le
[19:53] <blez> WORKS
[19:54] <blez> yey, thanks.
[19:54] <Digit_> any idea for my problem ?
[19:57] <blez> cbsrobot with -f mp3 what quality it the output?
[19:58] <blez> kbps/hz?
[19:58] <cbsrobot> blez: are you sure you want to pipe mp3 ?
[19:58] <blez> why not
[19:59] <cbsrobot> then I guess it would be something like -f libmp3lame -b:a 128k -ac 2 -r:a 44100
[20:00] <blez> with -f mp3 does it pipe the same quality as the input?
[20:00] <cbsrobot> blez: just make sure the receiving end can handle it ....
[20:00] <cbsrobot> what is same qulaity when you go from ogg -> mp3 ?
[20:01] <blez> I mean, is there a way to encode ogg -> mp3 without changing the quality?
[20:01] <blez> or channels or whatever
[20:02] <cbsrobot> blez: there are some default settings when you don't specify anything
[20:02] <cbsrobot> but if you want to make sure it keeps some values I suggest you specify them
[20:02] <blez> so would -f mp3 be the same as the input?
[20:03] <cbsrobot> s/some/the same/
[20:04] <cbsrobot> blez: no idea what your input values are, so  I suggest you specify them
[20:05] <blez> the input is a web radio, so it will vary
[20:06] <cbsrobot> use ffprobe to grep the values and use them in your script
[20:07] <blez> yes, that would work
[20:07] <cbsrobot> blez: what exactly are you trying to do ?
[20:08] <cbsrobot> webradio -> ffmpeg (transcode to mp3) --> ???
[20:09] <blez> webradio ripper
[20:09] <blez> which rips everything to mp3
[20:10] <Digit_> http://pastebin.com/nUfxyhEs
[20:16] <cbsrobot> Digit_: if you record it to a file - is the file playable ?
[20:16] <Digit_> no it's send to wowza server
[20:16] <Digit_> sent
[20:16] <Digit_> oh if i do ... gulp
[20:17] <wm4> someone remind me how to pass multiple flags to a fucking flags option?
[20:17] <cbsrobot> wm4: -flags +onething+otherthing-thatone
[20:18] <wm4> cbsrobot: doesn't work, I'm trying ffplay -vf phase=mode=+t+p
[20:18] <cbsrobot> ah wait - in a filter ....
[20:18] <wm4> which fails with [phase @ 0xade780a0] [Eval @ 0xb0ffbb2c] Undefined constant or missing '(' in 't'
[20:18] <cbsrobot> try: phase=mode=\+t\+p
[20:18] <wm4> wat
[20:18] <wm4> are you serious
[20:19] <cbsrobot> just guessing
[20:19] <wm4> well it doesn't work either
[20:19] <cbsrobot> had it lately and \ helped
[20:19] <wm4> Error initializing filter 'phase' with args 'mode=+t+p'
[20:19] <wm4> also this filter doesn't even give an example https://ffmpeg.org/ffmpeg-filters.html#phase
[20:23] <Digit_> how do i pm someone
[20:24] <llogan> /msg llogan greetings crgrat. are your intersted in sendings monies to my cousin in Tanzania?
[20:25] <llogan> Digit_: ^
[20:25] <wm4> hm  -vf noise=allf=+t+u somehow works
[20:25] <Digit_> the file is playable but i get a lot of artifacts like frames are missing and when vlc plays the next file it's freezing
[20:26] <Digit_> i get the same error than when i am sending to the server
[20:26] <Digit_> the only difference is that the sound is desync on the server
[20:26] <Digit_> i can't understand why it makes so many error reading the input
[20:28] <llogan> bacon1989: from zeranoe? "Static builds provide one self-contained .exe file for each program (ffmpeg, ffprobe, ffplay)."
[20:28] <Digit_> ho thanks llogan
[20:30] <llogan> blez: going from vorbis to mp3 will not be the same quality (but if you do it good enough you may not notice)
[20:31] <blez> llogan what should I do? -b:a -b:c ?
[20:31] <llogan> i've never seen -b:c before
[20:31] <blez> I mean -ac
[20:32] <llogan> use -q:a or -b:a to mess with quality/bitrate
[20:32] <llogan> https://trac.ffmpeg.org/wiki/Encoding%20VBR%20%28Variable%20Bit%20Rate%29%20mp3%20audio
[20:32] <llogan> i need to CamelCase those links...
[20:33] <llogan> blez: you probably don't need to mess with -ac
[20:39] <Digit_> i tried with udp, it's not better
[20:43] <Digit_> how could be the stream coming from vlc not compatible with ffmpeg ? i mean rtp is rtp ... isn't it
[22:25] <bb0x> hi guys ... how can i check if the ffmpeg binary is compiled using frei0r or not ?
[22:26] <bb0x> I'm having problems building frei0r-plugins-devel on centos 5
[22:45] <re-G> bb0x: just run ffmpeg binary and check configuration line
[00:00] --- Wed Dec  4 2013

More information about the Ffmpeg-devel-irc mailing list