[Ffmpeg-devel-irc] ffmpeg.log.20131205

burek burek021 at gmail.com
Fri Dec 6 02:05:01 CET 2013

[00:05] <DelphiWorld> thank guys all
[00:05] <DelphiWorld> nighty
[00:05] <DelphiWorld> see ya llogan
[01:35] <Rick27> Hi! I'm wondering if the zero latency option in x264 is useful if I just want to grab my screen without further external processing. Will the end result (recorded screen -> file, no live streaming) differ if I enable zero latency?
[01:35] <grkblood> how is stdout of ffmpeg encoded?
[01:35] <grkblood> is it utf8?
[02:08] <Zeranoe> Does the mjpeg encoder allow for a b:v setting? It seems to ignore whatever I set
[04:56] <trunk> hi,all,i have a problem with using ffmpeg. i use ffmpeg  2.1.1 to  transcode a mp4 file,but it isn't played in andriod 4.4
[04:57] <trunk> i use handbreak to  transcode same  mp4 file, it works in andriod 4.4
[05:36] <Zeranoe> trunk: How are you encoding the video
[05:37] <trunk> @<Zeranoe>   ffmpeg  -i  8.mp4    -f mp4     8_12.mp4
[05:38] <trunk> i foung ffmpeg metadata like this: major_brand     : isom     minor_version   : 512     compatible_brands: isomiso2avc1mp41
[05:39] <trunk> but handbreak like this   major_brand     : mp42     minor_version   : 0     compatible_brands: mp42isomavc1
[05:44] <Zeranoe> trunk: You might want to use more options: ffmpeg -i 8.mp4 -c:v libx264 -crf 20 -preset slow -tune film -strict experimental -c:a aac -b:a 128k 8_12.mp4
[05:45] <Zeranoe> trunk: Also, you should find out what AVC your phone can play, some have different capabilities
[05:59] <myxomop> hellO!
[05:59] <trunk> i try it
[05:59] <myxomop> i'm attempting to find an m3u8 url by using the firefox dev console on the following page http://watch.opb.org/video/2365119019/
[05:59] <myxomop> but am having some issues
[06:00] <myxomop> have read online that this is the way to capture videos which are packaged as lots of small mp2t files
[06:04] <myxomop> wondering if ffmpeg has a way of simplifying this
[06:06] <Zeranoe> myxomop: Looks like possibly brightcove stuff
[06:07] <Zeranoe> looks like .ts fragments
[06:07] <myxomop> aye
[06:07] <myxomop> VideoDownloader plugin sees them as mp2t files
[06:07] <myxomop> but the dev console sees .ts fragments
[06:07] <myxomop> either way it's all split
[06:09] <myxomop> i read here: http://forum.videohelp.com/threads/348180-Download-Youtube-video-with-multiple-audio-tracks
[06:09] <myxomop> that finding the m3u8 file is required before ffmpeg can process the file
[06:09] <myxomop> the stream. rather
[06:09] <myxomop> but i can't find the url
[06:11] <myxomop> Zeranoe, how unsnatchable is Brightcove media?
[06:11] <Zeranoe> myxomop: Well, if that's all you need: http://ga.video.cdn.pbs.org/cove2.0/oregon-field-guide/b13ba1c4-2782-48f7-bfe7-9096f6083bfe/2013-11-13-174700/hd-mezzanine-16x9/orfg2506hdba1_03_cove_mezzanine-16x9-hls-64-800k.m3u8 I've never done this before though
[06:14] <myxomop> i will try that with the syntax suggested on the help page and see what happens
[06:14] <myxomop> thanks
[06:14] <myxomop> how did you find it, out of curiosity?
[06:17] <Zeranoe> myxomop: Use this one btw: http://ga.video.cdn.pbs.org/cove2.0/oregon-field-guide/b13ba1c4-2782-48f7-bfe7-9096f6083bfe/2013-11-13-174700/hd-mezzanine-16x9/orfg2506hdba1_03_cove_mezzanine-16x9-hls-800k.m3u8 It's the highest quality. Wireshark
[06:21] <Zeranoe> myxomop: ffplay http://ga.video.cdn.pbs.org/cove2.0/oregon-field-guide/b13ba1c4-2782-48f7-bfe7-9096f6083bfe/2013-11-13-174700/hd-mezzanine-16x9/orfg2506hdba1_03_cove_mezzanine-16x9-hls-800k.m3u8 works for me. Just feed it into FFmpeg with -i http://ga.video.cdn.pbs.org/cove2.0/oregon-field-guide/b13ba1c4-2782-48f7-bfe7-9096f6083bfe/2013-11-13-174700/hd-mezzanine-16x9/orfg2506hdba1_03_cove_mezzanine-16x9-hls-800k.m3u8
[06:21] <Zeranoe> myxomop: -c:v copy -c:a copy out.ts should do it
[06:23] <myxomop> how long should it take?  i entered the first string from that help page a whole minute ago and it's still chugging
[06:24] <myxomop> i'll try yours next
[06:25] <Zeranoe> myxomop: Well the video is 10 minutes, so your fps should tell you. ffmpeg -i http://ga.video.cdn.pbs.org/cove2.0/oregon-field-guide/b13ba1c4-2782-48f7-bfe7-9096f6083bfe/2013-11-13-174700/hd-mezzanine-16x9/orfg2506hdba1_03_cove_mezzanine-16x9-hls-800k.m3u8 -c:v copy -c:a copy out.mp4
[06:25] <myxomop> fps?
[06:26] <Zeranoe> frames per second. Mine just finished with that command, I was averaging 100fps
[06:27] <Zeranoe> sorry, output needs to be out.ts, not mp4. You'll get a bitstream error
[06:27] <myxomop> i don't see anything telling me the rate of capture in the cmd window
[06:27] <myxomop> it's just sort of stalled
[06:27] <myxomop> since you mention mp4, how would I go about changing filetypes?
[06:30] <Zeranoe> myxomop: ffmpeg -i "http://ga.video.cdn.pbs.org/cove2.0/oregon-field-guide/b13ba1c4-2782-48f7-bfe7-9096f6083bfe/2013-11-13-174700/hd-mezzanine-16x9/orfg2506hdba1_03_cove_mezzanine-16x9-hls-800k.m3u8" -c:v copy -bsf:a aac_adtstoasc out.mp4
[06:32] Last message repeated 1 time(s).
[06:35] <myxomop> trying that now
[06:35] <myxomop> thanks
[06:46] <Zeranoe> myxomop: Did it work?
[06:48] <myxomop> still chugging
[06:48] <myxomop> the .mp4 output strign is
[06:48] <myxomop> the other one finished
[06:48] <myxomop> output folder is same as the ffmpeg .exe, yes?
[06:49] <Zeranoe> yes
[06:49] <Zeranoe> well, out.mp4 will be saved to where ever you cmd is open
[06:49] <trunk_> i use  "ffmpeg -i 8.mp4 -c:v libx264 -crf 20 -preset slow -tune film -strict experimental -c:a aac -b:a 128k 8_12.mp4"  ,but  the mp4 file does't play in andriod 4.4
[06:49] <trunk_> @<Zeranoe>
[06:50] <myxomop> the out.ts works in vlc
[06:50] <myxomop> what would be a simple string to convert this to .mp4?
[06:50] <myxomop> perhaps something that doesn't require the original stream, but can work with the local file
[06:52] <Zeranoe> myxomop: ffmpeg -i out.ts -c:v copy -bsf:a aac_adtstoasc out.mp4
[06:52] <Zeranoe> trunk_: what player are you using
[06:53] <trunk_> <Zeranoe>  andriod  chrome
[06:54] <myxomop> complete success.  thank you so much, Zeranoe
[06:55] <Zeranoe> trunk_: does it say if it's the video or audio thats an issue?
[06:58] <trunk_> ffmpeg -i 8.mp4 -c:v libx264 -crf 20 -preset slow -tune film -strict experimental -an  -y  8_12.mp4   ,it works , is it audio error?
[06:59] <Zeranoe> trunk_: It must be. Do you have more than one channel?
[06:59] <Zeranoe> trunk_: *two
[07:00] <Zeranoe> I know the internal AAC encoder isn't LC, but Android should be backward compatible...
[07:02] <Zeranoe> Actually, looks like it is LC
[07:04] <trunk_> ffmpeg -i 8.mp4 -c:v libx264 -crf 20 -preset slow -tune film -strict experimental -c:a aac -b:a 128k  -ac 2  -y   8_12.mp4 
[07:04] <trunk_> it does't work
[07:05] <trunk_> can't play
[07:08] <Zeranoe> trunk_: Can you try another player, other than chrome
[07:11] <trunk_> chrome  firefox  opera all can't
[07:12] <Zeranoe> trunk_: How about with an actual media player?
[07:12] <LithosLaptop> what OS?
[07:12] <trunk_> os is ok
[07:13] <LithosLaptop> Firefox can only play H.264 on Windows or opertating systems exposing H.264 decoders
[07:13] <LithosLaptop> ok
[07:14] <trunk_> andriod 4.3 can play
[07:14] <Zeranoe> Again, can you try it with an actual media player?
[07:15] <trunk_> andriod 4.3 can play,but andiod 4.4 can't
[07:15] <trunk_> vlc ok
[07:17] <LithosLaptop> tried baseline profile?
[07:17] <LithosLaptop> -profile:v baseline -level 3.0
[07:18] <LithosLaptop> also check the resolution and framerate
[07:18] <Zeranoe> LithosLaptop: Video is fine
[07:18] <Zeranoe> it worked with an
[07:18] <trunk_> same mp4  file   andriod 4.3 can play,but andiod 4.4 can't
[07:19] <LithosLaptop> ohh only the audio,,
[07:19] <LithosLaptop> tried libmp3lame? MP3 can be muxed into MP4 container
[07:20] <LithosLaptop> not sure what players support it
[07:20] <LithosLaptop> will also give better quality than the internal aac encoder
[07:21] <LithosLaptop> the internal aac only starts sounding transparent >= 256Kbps so it isn't recommended to use it at 128Kbps like above
[07:21] <LithosLaptop> libmp3lame should be fine at 128Kbps
[07:21] <trunk_> the mp4 file  encodeed by handbreak can work
[07:22] <Zeranoe> trunk_: paste the settings used for handbreak. I need to go, good luck
[07:24] <trunk_> i use handbreak ui in windows
[07:25] <trunk_> no more settings
[07:58] <monokrome> Hey, all.
[07:59] <monokrome> Trying to figure out if there's a way to losslessly compress an MOV file?
[08:06] <mark4o> monokrome: you have a MOV file with uncompressed data?
[08:17] <monokrome> yes
[08:17] <monokrome> I assume it's uncompressed. It's huge. Maybe I'm wrong.
[08:18] <mark4o> ffmpeg or ffprobe should show the codec it is using
[08:26] <mark4o> monokrome: if your video really is uncompressed (codec is rawvideo) then you can compress it with -c:v libx264 -crf 0 or another lossless codec
[08:27] <mark4o> if it is already compressed then you probably won't be able to make it any smaller losslessly
[08:33] <kcm1700> regarding sws_scale, is there a way to prevent writing out of image? if width=88, stride = 128, sws_scale writes 96 bytes per line, but I want to constrain the region.
[12:04] <tvkamara> greetings, i'm trying to encode my desktop to html5 video (mp4, x264) with ffmpeg (output to stdout) and pipe it with node.js to http response
[12:05] <tvkamara> everything works fluently if i use -g 0 (every frame is an i-frame) but for everything else the stream becomes choppy
[12:06] <tvkamara> if i pipe the output to a file, i can see that the file size grows sort of in bursts, in a similar way that it "lags" in the browser
[12:08] <tvkamara> with -g 0 the file size seems to grow more "real time" and that's probably why i can also stream it fluently in a browser
[12:10] <tvkamara> the problem is that with these settings the bandwidth used is around 50MB :), i'm wondering if there are some sort of buffers when using ffmpeg with higher i-frame options or is the burstiness explained by mp4 file format..
[13:20] <coalado> hey there
[13:21] <coalado> I'd like to distribute ffmpeg together with my application to mux/demux . But to avoid license/patent problems, I'd like to use a version that cannot be used to encode/decode  (e.g. h246).
[13:22] <coalado> does anybody know about static builds that have this option disabled?
[13:49] <Mavrik> building yourself with licensing restrictions you need is going to be noticably easier than finding a static build by your liking
[14:42] <radu_> hey, I have the following issue running /usr/local/bin/ffmpeg -i rtmp://{...}.com/chat/mp4:10000096.mp4 -q:v 0.6 -r 10 -s 160x120 /home/site/public/mobile-stream/frames/10000096_data/frame-%06d.jpg
[14:43] <radu_> the files are not written immediately
[14:43] <radu_> instead they are buffered somehow
[14:43] <radu_> and written after a while
[14:43] <radu_> if I look in the dir after 10 minutes I see all 10k files written in a 10 second interval
[14:44] <radu_> frame-001530.jpg frame-001531.jpg ...
[14:46] <radu_> and after that it starts writing properly (10/second)
[15:26] <Whiskey> Hay everyone :)
[15:27] <coalado> hi
[15:28] <Whiskey> i are using php, and select a movie from an mysql database, is it possible to conver it whit exec direct in someway or do i need to save it somewhere before i can convert it
[15:38] <stonie_> hi all.. im trying to encode a .rec file (which is ts) from a hd recorder into mpeg2 .. but it stops after a few moments with the following: http://pastebin.com/x32bYeC9
[16:17] <stonie_> hiho
[16:50] <deodamus> Hi I'm having a trouble to install ffmpeg to Centos 5.9 can anyone help me on this? Here's my pastebin url : http://pastebin.com/B1AV2jzT
[16:53] <JEEB> the problem is that you're trying to link an ffmpeg to x264, and it seems like a lot of its dependencies are shared, but they're not linked in :P Now, for building libx264 for ffmpeg you can just not try and do such a full x264 (cli tool) build
[16:53] <JEEB> --disable-cli
[16:53] <JEEB> (for x264's compilation)
[16:54] <JEEB> (remember to clean first)
[17:17] <Whiskey> How do i convert some fileformat to h264 lossless?
[17:18] <Whiskey> i did try to do "ffmpeg -strict -i ils-lfls11-sample.avi -vcodec mpeg4 -acodec aac output.mk" then it ask to overwrite orginal file why? when i will create a new one
[17:19] <ubitux> because -i is considered an argument of -strict
[17:19] <ubitux> use -strict experimental for instance
[17:19] <ubitux> and as output option btw
[17:19] <Whiskey> don´t get it
[17:19] <saste> ubitux, you gonna review aeval?
[17:20] <saste> anyway wait still i'm still working on it
[17:20] <ubitux> Whiskey: "-strict -i"  "-i" is passed as argument to "-strict" in your cmd line
[17:20] <Whiskey> aha
[17:20] <ubitux> -strict takes an argument
[17:20] <ubitux> hence the "-strict experimental" suggestion
[17:20] <ubitux> also move it to output option
[17:21] <ubitux> saste: maybe :p
[17:21] <ubitux> saste: i sure can wait to review :)
[17:22] <Whiskey> but then i cant use it right?
[17:23] <ubitux> Whiskey?
[17:23] <Whiskey> yeh
[17:24] <ubitux> explain what you don't understand
[17:27] <Whiskey> everything
[17:27] <Whiskey> why does it overwrite the orginal file
[17:29] <ubitux> i told you twice
[17:30] <Whiskey> yeh and i still did not get it
[17:30] <Whiskey> and if i try to create a flv
[17:30] <Whiskey> Error while opening encoder for output stream #0.1 - maybe incorrect parameters such as bit_rate, rate, width or height i get that
[17:31] <Whiskey> it was 48000Hz i guss thats the error
[17:31] <ubitux> "-i" is passed as an argument to "-strict" because you didn't specify any argument
[17:31] <ubitux> so your input file is not prefixed by an "-i"
[17:31] <ubitux> and thus is considered an output file
[17:31] <Whiskey> hmm so then i need to qoute it maybe?
[17:32] <ubitux> ...
[17:32] <ubitux> no you need to add an argument to "-strict"
[17:32] <ubitux> such as "experimental"
[17:32] <Whiskey> yeh even if i add that its will overwrite orginal file
[17:33] <ubitux> what's your command line?
[17:33] <Whiskey> "ffmpeg -strict experimental ils-lfls11-sample.avi ils-lfls11-sample.mp4"
[17:33] <ubitux> why did you remove the -i?
[17:33] <Whiskey> whit it i get "-strict: No such file or directory"
[17:34] <Whiskey> whit it after strict it works almost
[17:34] <Whiskey> encoder 'aac' is experimental and might produce bad results.
[17:34] <Whiskey> Add '-strict experimental' if you want to use it.
[17:34] <Whiskey> is what i get then
[17:35] <ubitux> you removed the -i
[17:35] <ubitux> i told you maybe 4x to just add a parameter to -strict
[17:36] <ubitux> why did you remove the -i?
[17:36] <Whiskey> you don´t listen
[17:36] <Whiskey> if i have it before -strict
[17:36] <Whiskey> i get error
[17:36] <Whiskey> if i use it after -strict experimental i get error
[17:36] <ubitux> oh please some explain it to him i'm fed up
[17:37] <Whiskey> sudo /usr/bin/ffmpeg -strict experimental -i ils-lfls11-sample.avi ils-lfls11-sample.mp4 <-- its there
[17:37] <ubitux> right, now move it as output option
[17:37] <ubitux> ffmpeg -i INPUT -strict experimental OUTPUT
[17:37] <Whiskey> ooo
[17:37] <stonie_> hi all.. im trying to encode a .rec file (which is ts) from a hd recorder into mpeg2 .. but it stops after a few moments with the following: http://pastebin.com/x32bYeC9
[17:38] <JEEBsv> before -i means you want to set it for input, decoding
[17:39] <Whiskey> one last question, can you get it whitout lose any or almost nothing of the quality
[17:39] <Whiskey> as its real blurry when i open it, and then mp4 alot higher standard then old avi
[19:22] <Whiskey> hmm not mutch life here
[20:06] <deodamus> hi folks, is there a precompiled ffmpeg with x264 that I can install on a centos 5.9 box? I'm running in to roadblocks when I try to compile both x264 and ffmpeg with x264
[20:06] <sacarasc> What kernel are you using?
[20:06] <sacarasc> You might be able to use one of them...
[20:06] <deodamus> sacarasc: 2.6.18-274.3.1.e15
[20:07] <sacarasc> Ah.
[20:08] <deodamus> and static builds for older kernels out there?
[20:09] <sacarasc> I wouldn't think so, as 2.6.32 is the latest long term support kernel out there.
[20:10] <deodamus> rabble. :\
[20:13] <deodamus> sacarasc: for x264 support, ffmpeg MUST be compiled with x264, is that correct?
[20:13] <sacarasc> Yes.
[20:14] <sacarasc> x264 is just for encoding, for decoding, you don't need x264.
[20:14] <deodamus> yea I do because I'll be encoding with it
[20:22] <llogan> deodamus: what are the compiling problems you are experiencing?
[20:24] <deodamus> llogan: the latest I got when compiling ffmpeg is "relocation R_X86_64_32S against 'a local symbol' can not be used when making a shared object; recompile with -fPIC
[20:24] <llogan> how did you configure x264 and ffmpeg?
[20:25] <deodamus> well because I wasn't sure what was causing problems the latest compile of ffmpeg that I tried was ./configure --prefix=/usr/local --enable-libx264 --enable-gpl
[20:25] <deodamus> just to get down to the simplest compile with x264
[20:26] <llogan> what about x264?
[20:26] <llogan> i mean, what configure options did you use for x264?
[20:27] <deodamus> i tried a bunch of options but if i'm correct the last one i tried to attempt was ./configure --enable-pthread --enable-mp4-output -enabled-shared
[20:27] <llogan> why shared?
[20:27] <llogan> pthread is default
[20:28] <deodamus> i've been following guides that i've found across the web so that was just a borrowed config
[20:28] <llogan> https://trac.ffmpeg.org/wiki/CentosCompilationGuide
[20:29] <deodamus> I think I have tried this one, let me try it again and I'll get you the error from 'make'
[20:30] <deodamus> it's compiling now, but note that it ignored the --disable-shared option
[20:31] <llogan> what ignored --disable-shared?
[20:31] <Whiskey> try to build ffmpeg now to get that x264 code
[20:31] <Whiskey> try to build ffmpeg now to get that x264 codec
[20:31] <deodamus> when i configured it, it said --disable-shared was unknown
[20:32] <llogan> i don't see --disable-shared listed for x264 or ffmpeg on that guide
[20:32] <deodamus> oh that's my fault
[20:32] <deodamus> i misread
[20:32] <deodamus> apologies
[20:32] <deodamus> lemme try that again
[20:33] <deodamus> compiling now, i'll let you know what it says
[20:37] <deodamus> ok so the error I got on this compile is a bunch of undefined references to 'vpx_codec'
[20:37] <deodamus> I can pastebin if you guys want to read the entire thing
[20:38] <deodamus> http://pastebin.com/hJCmeyX1
[20:38] <deodamus> seems to be trying to reference a couple other codecs
[20:43] <llogan> do you have more than one set of the header files for each library installed?
[20:43] <deodamus> i'm not sure of that. how would I check for that?
[20:49] <llogan> deodamus: i guess you can try "sudo updatedb && locate lame.h"
[20:49] <llogan> or use find, or manually root around for it
[20:51] <deodamus> llogan: can only find one header file at /usr/local/include/lame/lame.h
[20:52] <llogan> maybe it's a PKG_CONFIG issue, but i'm not sure
[20:54] <Whiskey> can´t get x264 shit to work
[20:55] <llogan> --enable-laxitive
[20:55] <deodamus> har
[20:56] <llogan> deodamus: i don't know why it does that, but if you don't plan on encoding with libmpelame or libvpx you can omit those...doesn't solve the problem though
[20:57] <deodamus> llogan: i don't plan on using those, just need x264... how do i omit them?
[20:59] <llogan> "cd ~/ffmpeg_sources/ffmpeg && make distclean" then run the ffmpeg configure line without --enable-libmp3lame and --enable-libvpx and remove whatever else you don't want
[21:00] <llogan> you'll probably want libfdk_aac though
[21:01] <deodamus> this is the x264 configure
[21:02] <deodamus> and i just realized where it's referencing these encoders, the path doesn't exist
[21:02] <viric> I'm failing to get afade working, for t=in
[21:02] <viric> it does nothing
[21:02] <deodamus> the path /var/www/ffmpeg-source doesn't exist
[21:02] <juesor> so i posted this question earlier about a bug that was brought up https://trac.ffmpeg.org/ticket/1778  it's been 14 months and i was curious if there is any change on this
[21:03] <viric> is there any constraint for afade to work?
[21:03] <juesor> i did not submit that ticket but it would fix the problem i am having
[21:03] <llogan> viric: i guess you want to play "20 questions" because I don't see a pastebin link
[21:03] <viric> llogan: right
[21:04] <viric> http://sprunge.us/CJCU
[21:04] <viric> llogan: well, I tried 'out' there. 'out' mutes all the audio. 'in' does nothing.
[21:05] <llogan> juesor: you could mention in that ticket that you're willing to pay a bounty for it to be fixed
[21:05] <llogan> or provide a patch
[21:07] <juesor> at this point i would be willing
[21:08] <viric> llogan: for the samples: [Parsed_ashowinfo_3 @ 0x1922f80] n:0 pts:0 pts_time:0 pos:129038 fmt:fltp channels:2 chlayout:stereo rate:48000 nb_samples:1536 checksum:5B057CB3 plane_checksums: [ C58EC1A8 C501BAFC ]
[21:08] <llogan> was that your complete console output?
[21:11] <llogan> viric: start time in afade is st, not ss
[21:12] <llogan> ah, i missed ss is start_sample
[21:18] <llogan> viric: when do you want the fade in to start, and how long should the fade operation last?
[21:27] <viric> llogan: fadein, from 0 to 5 would be fine
[21:29] <viric> but anything I test, results in no fade.
[21:30] <viric> llogan: looking at frame checksums before and after afade, I see that it's applied at the first moment. Maybe it's a pts thing?
[21:31] <viric> llogan: aha. d=500 does a fadein for about 2seconds
[21:38] <llogan> viric: i wonder why it does that
[21:38] <viric> no idea.
[21:39] <viric> I never got near the code of ffmpeg... I'm learning how to use it :)
[21:40] <viric> Is there any filter that will scale the video just to SAR 1:1 ?
[21:42] <llogan> there is setdar and setsar, but i'm not really clear what you're asking or what you're trying to do
[21:44] <viric> I have: 720x576 [SAR 64:45 DAR 16:9]
[21:44] <viric> and I want something 'similar' but with SAR 1:1  :)
[21:45] <viric> scale=1024x768 seems ok
[21:58] <viric> mhm I fail to understand how can I 'fade' video, in a way that one stream is *delayed* in the timeline. That is:
[21:58] <viric> a cover video goes from second 0 to 5.
[21:59] <viric> the long play video (input 0 to 2h) should go from second 4 to 2h4s. And I'd use 1s of fade in/out.
[21:59] <viric> But I don't know how to make one stream not "start" at time 0. How can I make the long play video start from second 4?
[22:01] <viric> a black color src of 4 seconds, and concat with the long play?
[22:12] <llogan> viric: wouldn't 1024x768 give a sar of 4:3? you wanted 1:1?
[22:12] <llogan> "scale=iw*(sar):ih"
[22:12] <viric> did I write that? I meant 1024x576
[22:13] <llogan> that example may calculate it for you
[22:13] <viric> ah great
[22:13] <viric> thank you!
[22:18] <viric> I always have lots of troubles with drawtext to draw a '
[22:19] <viric> drawtext=text=L\\\\\'origen de l\\\\\'excessiva
[22:19] <viric> why 5 slashes? no idea.
[22:19] <viric> less, doesn't work. doesn't print the '
[22:29] <llogan> http://www.ffmpeg.org/ffmpeg-utils.html#Quoting-and-escaping
[22:30] <llogan> http://ffmpeg.org/ffmpeg-filters.html#Text-expansion
[22:34] <viric> llogan: hm somehow that quoting/escaping doesn't match either my experience or my understanding :)
[22:40] <llogan> yeah, it can be confusing
[22:40] <viric> My experience tells me: 5 backslashes
[22:44] <viric> do you have any idea about what I said about 'delaying' the start of a stream?
[22:46] <viric> and do you know any way to encode *fast* video and audio, for tests? I just want to check that things appear on time
[22:48] <llogan> i didn't get to the delaying yet. you want to encode quickly?
[22:48] <viric> both things are unrelated, but yes.
[22:49] <viric> I see x264 has ultrafast... but my computer may be really slow :)
[22:49] <viric> (I don't need x264 specifically, but this has the ultrafast thing)
[22:49] <llogan> did you try it?
[22:49] <viric> I don't get even 25fps :D
[22:50] <llogan> filtering can introduce slowness too
[22:50] <viric> aha. maybe it's that.
[22:50] <llogan> you could also use ffplay to preview filtering
[22:51] <stonie_> hi all.. im trying to encode a .rec file (which is ts) from a hd recorder into mpeg2 .. but it stops after a few moments with the following: http://pastebin.com/x32bYeC9
[22:51] <llogan> except i'm not sure if it works with filter_complex. you may have to use movie and amovie multimedia source filters
[22:51] <llogan> stonie_: what's avconv?
[22:51] <viric> but with ffplay at most I get realtime
[22:52] <viric> I want to check if an overlay is placed for 10s at 1h point. How can I check that, without encoding 1h?
[22:52] <llogan> -t option
[22:52] <llogan> -t 12, -t 00:00:12, etc
[22:52] <viric> hm that will make it encode only 12 seconds
[22:53] <llogan> isn't that what you wanted?
[22:53] <viric> but I want to check what happens between 1h and 1h10s
[22:53] <stonie_> llogan, isnt that ffmpeg ?
[22:53] <llogan> oh. i am reading badly today
[22:53] <stonie_> under new name?
[22:53] <llogan> no
[22:53] <llogan> stonie_: that's what they want you to think
[22:54] <stonie_> llogan, ye i c.. but within debian ffmpeg seems to be depreciated :-(((
[22:54] <llogan> so you'll either have to get real ffmpeg to get help here, since we obviously can't support junk we don't make, or get help from the fork
[22:54] <llogan> that's not our ffmpeg. that's the fake ffmpeg. please read the link i just gave you
[22:54] <stonie_> thats shit .. ye ill do that
[22:55] <stonie_> why did debian remove ffmpeg
[22:55] <llogan> or http://trac.ffmpeg.org/wiki/UbuntuCompilationGuide
[22:55] <stonie_> id like to have it back in the repository
[22:56] <llogan> because when the fork forked the guy that maintained the ffmpeg package in debian joined the fork side, and then switched to the fork on his own account.
[22:56] <llogan> then made the "ffmpeg is not developed anymore" and "deprecated" messages; referring to the fork's temporary, so-called ffmpeg version.
[22:57] Action: llogan is a broken record
[22:57] <llogan> or a parrot
[22:57] <llogan> resulting in users assuming they are referring to FFmpeg
[22:58] <llogan> of course this was a nice side effect for them
[22:58] <stonie_> hate it when this happens in the open source community
[22:58] <stonie_> and ye, i can assume that you told that likt 10.000 times
[22:59] <stonie_> but thanks from my side for the info
[23:00] <llogan> i suppose you could mention you support the packaging of real ffmpeg at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=729203
[23:01] <viric> I've a stream called [x]
[23:02] <viric> is there any filter line I can do, to copy it to another name?
[23:02] <viric> [x] nothing [v]
[23:03] <viric> ah, copy! :)
[23:20] <viric> llogan: I have a new amovie stream in the filter, and in it, afade works fine
[23:21] <viric> but with the main video, it has that weird 'seconds' units
[23:30] <viric> I don't really understand when I want -vf or when I want -filter_complex
[23:40] <relaxed> -filter_complex is for multiple inputs
[23:42] <viric> [png @ 0xa2b61c0] get_buffer() failed
[23:42] <viric> [png @ 0xa2b61c0] thread_get_buffer() failed
[23:42] <viric> what can this be?
[23:42] <viric> relaxed: ah ok!
[23:48] <viric> I've "the same" ffmpeg 2.1.1 in two machines, one i686 and the other x86_64. My command works in x86_64, fails in the other (get_buffer failed9
[23:48] <viric> )
[23:50] <viric> auhm. failing mallocs. grrr
[23:52] <viric> it takes far more virtual mem in i686 than x86_64... weird
[00:00] --- Fri Dec  6 2013

More information about the Ffmpeg-devel-irc mailing list