[Ffmpeg-devel-irc] ffmpeg.log.20131210

burek burek021 at gmail.com
Wed Dec 11 02:05:01 CET 2013

[00:06] <gazarsgo> figured it out, i was putting the pix_fmt on the input instead of the output& positional command line args are hard :)
[00:15] <SirCmpwn> https://www.mediacru.sh/uIKKxpsXo0Nq.png
[00:15] <SirCmpwn> I'm having this weird playback problem on mobile devices
[00:16] <SirCmpwn> link, includes the videos: https://mediacru.sh/k-Em-UAO06Lg
[00:16] <SirCmpwn> it's offering mp4, webm, and ogv, and both webm and mp4 display the problem (haven't tried ogv)
[00:16] <SirCmpwn> ffmpeg is invoked like so: https://github.com/MediaCrush/MediaCrush/blob/master/mediacrush/worker.py#L56
[00:17] <klaxa> looks like the hardware decoder is b0rked
[00:18] <SirCmpwn> this doesn't occur on all videos, and is reproducable on several phones, so it's my problem
[00:18] <llogan> you should show your actual ffmpeg command and the complete ffmpeg console output instead of just a script
[00:19] <klaxa> it looks like that for me too on my phone though
[00:19] <SirCmpwn> https://gist.github.com/SirCmpwn/7ac9577c6ac17057c236/raw/48242082f6fedae506c389a3c8eb0844d0ba077f/gistfile1.txt
[00:19] <SirCmpwn> full output and original command
[00:21] <llogan> are these devices supposed to support High profile, level 3.1?
[00:21] <SirCmpwn> hmm, I can only reproduce on chrome for android, it works on firefox
[00:21] <SirCmpwn> presumably because firefox is selecting the webm instead? I thought the webm had that problem, too
[00:21] <klaxa> does firefox have access to hardware decoding? does firefox even us mp4?
[00:21] <klaxa> *use
[00:22] <SirCmpwn> llogan: how can I use a different one? I can re-encode it and test real quick
[00:22] <SirCmpwn> -profile main? -profile baseline?
[00:22] <llogan> "-profile:v baseline"
[00:22] <SirCmpwn> alrighty
[00:23] <llogan> but i guess you should confirm which is giving you The Troubles: the mp4 and/or the webm file
[00:25] <SirCmpwn> switching to the baseline profile seems to have fixed the problem on chrome for android
[00:25] <SirCmpwn> let me re-enable webm and disable mp4 and see if they also have the issue
[00:26] <llogan> try "-profile:v main" too.
[00:26] <SirCmpwn> yep, webm also has the problme
[00:26] <SirCmpwn> llogan: on mp4 or on webm
[00:26] Action: llogan knows nothing of VP*
[00:26] <llogan> the mp4
[00:26] <SirCmpwn> fair enough
[00:26] <SirCmpwn> okay, but I want to fix webm before I try that
[00:28] <SirCmpwn> https://gist.github.com/SirCmpwn/718b62d9c616694cb639/raw/6adc628f1b0b6c74e3baaf707a1a3b547c5fee92/gistfile1.txt
[00:28] <klaxa> are there even vp8 hardware decoders?
[00:29] <SirCmpwn> I'm not sure, but I doubt it
[00:29] <SirCmpwn> how do I view all the options for a particular codec again?
[00:31] <klaxa> ffmpeg --help encoder=libx264 for example
[00:32] <SirCmpwn> thanks
[00:38] <SirCmpwn> how can I set vp8 passes with ffmpeg?
[00:38] <SirCmpwn> there's an option for it with vpxenc, but I can't figure out how to convince ffmpeg to pass it down
[00:38] <SirCmpwn> I want to try using 2 passes
[00:41] <llogan> -pass 1, -pass 2?
[00:42] <llogan> http://trac.ffmpeg.org/wiki/vpxEncodingGuide may be useful for you
[00:42] <SirCmpwn> thanks
[00:50] <SirCmpwn> is there a generic way to pass an option down to the video encoder?
[00:51] <SirCmpwn> I want to try adjusting the arnr settings on vpxenc
[00:55] <SirCmpwn> ah, you can just use -arnr_strength and such
[00:56] <SirCmpwn> didn't help anything :(
[00:57] <llogan> did you try main yet for the mp4 output?
[00:58] <Cloudstrike> Hello i have a problem with some video files, if i try to encode video files, most files work but some encode for longer then 20 minutes (by some files 1 hour or longer). A normal file would be 200 MB but these files get up to 1.8 GB (source was under 200 - 300 MB) Here i have the information about the input: http://pastebin.com/u7EKv3mi
[00:58] <SirCmpwn> llogan: no, I'll give that a try now
[00:58] <SirCmpwn> llogan: mp4 doesn't work well on all devices, so I also need webm working
[01:00] <Cloudstrike> here what i use to encode it: ffmpeg -i wjq11iq9fub6.mp4 -y -acodec aac -strict experimental -ab 192 -ac 2 -s $size -vcodec libx264 -vpre fast -g 60 -crf 24 -threads 0 {upload_dir}/wjq11iq9fub6.mp4
[01:09] <Cloudstrike> ok
[01:56] <Zeranoe> I have two videos, encoded from different formats into the same format. ffprobe reports everything the same for the two files, except the bit rate is different. The issue is that only one of the files will play on with some special hardware. What hidden differences could be effecting this
[02:01] <sacarasc> If it's H264, then profile and level could be the difference.
[02:02] <Zeranoe> sacarasc: But if the files are going through the same encoding command, shouldn't that be wiped away?
[02:02] <gazarsgo> so& many& encoders& compiling
[02:04] <gazarsgo> do the instructions here include opencl support ? http://trac.ffmpeg.org/wiki/UbuntuCompilationGuide
[02:05] <sacarasc> Zeranoe: Try using mediainfo to get all the specs.
[02:05] <llogan> gazarsgo: you mean for the few filters that use it?
[02:06] <gazarsgo> is there a list of which filters support opencl ?
[02:06] <llogan> or for x264?
[02:07] <gazarsgo> is rtmp backed by x264 ?
[02:09] <llogan> unsharp and deshake, AFAIK
[02:10] <gazarsgo> arrrg i have to recompile x264 with opencl and then ffmpeg ? heh
[02:11] <elfMobile> trying to turn a bunch of pictures into a timelapse.  I have pictures in different directories (a directory for each day).  I can create a timelapse for each day but having trouble combining them.  This is my command....
[02:11] <elfMobile> ffmpeg -r 60 -i ../1/out_%05d.jpg -r 60 -i ./out_%05d.jpg -c:v libx264 -r 60 1and2.mp4
[02:11] <elfMobile> I'm in directory 2.  Trying to combine pictures from day 1 and day 2 into a single movie
[02:12] <llogan> gazarsgo: i doubt it's worth it
[02:12] <gazarsgo> what would make it worth it ?
[02:13] <gazarsgo> i have 1536 core GPU ...
[02:14] <llogan> if your hardware supports it and if you need to encode x amount of videos in n amount of time, and if the supposed decrease in encoding time with opencl is goodnuff to offset the time you're taking to implement and test it
[02:14] <gazarsgo> have to have a benchmark to determine if it's worth it :)
[02:14] <llogan> note that i've never actually tried it
[02:19] <llogan> elfMobile: ffmpeg -r 60 -i dir0/out_%05d.jpg -r 60 -i dir1/out_%05d.jpg -filter_complex "[0:v][1:v]concat=n=2:v=1:a=0,format=yuv420p[out]" -map "[out]" -c:v libx264 output.mp4
[02:20] <elfMobile> llogan, I think the command I ran actually just destroyed all the .jpg files I had in my 2nd directory
[02:21] <elfMobile> ... either that one or another command I ran.  I think it took pictures from dir1 and put them in dir2
[02:21] <llogan> the one you showed doesn't look like it would do such a thing
[02:23] <elfMobile> http://pastebin.com/fzVCsg27
[02:23] <elfMobile> llogan, ^^ histtory | grep ffmpeg | pastebinit
[02:23] <llogan> you forgot the -i for your second directory in command 509
[02:24] <elfMobile> yeah... so what would that command even do?  Replace all the files in the current directory?
[02:24] <llogan> unfortunaely the image2 muxer does not appear to ask for confirmation for overwrite
[02:25] <elfMobile> llogan, not a huge loss... but lesson learned
[02:25] <llogan> it would re-encode the files from the input and dump them into your output
[02:25] <llogan> don't feel bad. i overwrote a video myself today.
[02:26] <elfMobile> this was a timelapse of my son sleeping with his infrared baby camera
[02:26] <llogan> there are plenty of other kids out there to spy on if he's too old now
[02:27] <elfMobile> its only 1 day older today... it was from last night ;-)
[03:53] <Cloudstrike> Can somebody help me with this problem? http://pastebin.com/ZKbLKf8j
[03:53] <germanstudent> I try to find the exact ffmpeg (h264) parameters for youtube recommended encoding settings. I think I have most of it, someone interested in checking/completing? https://docs.google.com/spreadsheet/ccc?key=0AgT_7K9gOQjrdGRROVh1V0xWa01YNXJRcVFoTjBZTlE&usp=sharing
[04:04] <Cloudstrike> the problem what i have is that this file encodes for longer then normaly. So i need help because of this problem the whole queue got stuck:/
[04:04] <Cloudstrike> and the output file will be 1.5 GB (normal it have to be 200 MB ~ 300 MB)
[04:19] <grepper> Cloudstrike: that's not released by ffmpeg, try #libav. I'm sure they will tell you to get a recent version :)
[04:29] <grepper> should be -ab 192k by the way, as the output shows
[04:53] <Cloudstrike> grepper: http://pastebin.com/tQdxAnTp
[04:53] <Cloudstrike> it is finished
[04:53] <Cloudstrike> but the filesize is too big
[04:55] <SirCmpwn> ffprobe appears to depend on file extensions for formats like bmp or png
[04:55] <SirCmpwn> is there a way to make it ignore the extension?
[04:55] <SirCmpwn> for example, ffprobe with foo.png and foo.whatever fails on the latter even when both are the same file
[05:00] <drv> image formats (with the image2 demuxer) are detected only based on extension, there's no probe function for image formats currently
[05:00] <SirCmpwn> alright, I'll fallback to imagemagick
[05:07] <relaxed> SirCmpwn: yes, ffmpeg -f image2 -vcodec png -i blah.ext
[05:07] <SirCmpwn> hahaha
[05:07] <SirCmpwn> I'm trying to detect the filetype of arbituary files, relaxed
[05:08] <relaxed> file blah.ext
[05:08] <SirCmpwn> yeah, but a little more complicated than that
[05:08] <SirCmpwn> I want to also take apart containers and examine the streams present
[05:08] <SirCmpwn> hence, ffprobe
[05:10] <Dirkson> Hey all. Converting to webm only uses one out of my eight cores. Any way I could make it chew up a bit more cpu?
[05:10] <SirCmpwn> -threads 7
[05:10] <SirCmpwn> vp8 suggests using actual_cores - 1
[05:11] <relaxed> SirCmpwn: tried mediainfo?
[05:12] <Dirkson> SirCmpwn: Doesn't affect cpu usage. Still hovers right around 1 core's worth of usage.
[05:12] <SirCmpwn> relaxed: hmm, I prefer ffprobe's output
[05:13] <SirCmpwn> Dirkson: can you show your full ffmpeg invocation?
[05:13] <Dirkson> SirCmpwn: Just a tick
[05:13] <SirCmpwn> in a pastebin or something, not directly here
[05:13] <Dirkson> SirCmpwn: It's small: ffmpeg -threads 7 -i "$1" -preset veryslow -pix_fmt yuv420p -map 0:0 -map 0:a:0 "$2".webm
[05:14] <Dirkson> SirCmpwn: $1 is the input file, $2 the output
[05:14] <SirCmpwn> I dunno if this'll help anything, but try explicitly declaring the vcodec and setting -threads after that
[05:14] <SirCmpwn> -vcodec libvpx
[05:14] <relaxed> it belongs after the input
[05:14] <Dirkson> *tinker*
[05:14] <SirCmpwn> relaxed: I've had -threads work as the first argument sometimes
[05:14] Action: SirCmpwn shrugs
[05:14] <relaxed> before the input means you want to decode the input using N threads
[05:15] <Dirkson> Hey, that's better! Now it's up to using a whole 4 cores : )
[05:19] <Dirkson> Get best results with 8 cores, turns out. There it edges up to nearly 5 cores of actual usage.
[05:19] <Dirkson> Must be talking a lot between the threads.
[05:20] <Dirkson> Still, that'll save a ton of time. Thanks relaxed, SirCmpwn
[05:21] <SirCmpwn> happy to help, Dirkson
[05:35] Action: Cloudstrike slaps grepper around a bit with a large trout
[05:35] <SirCmpwn> is there any codec that would theoretically be dangerous to decode user-supplied input from
[05:35] <SirCmpwn> codecs that can run arbituary code for some reason, or maybe take up a ridiuclous amount of time/cpu/memory
[05:35] <SirCmpwn> where "user" is not trusted
[05:37] <Cloudstrike> since i dont understand why ffmpeg arent able to encode my mp4 file i dont know how to fix that because i have the problem on many files, as i hosting my videos on a streaming server and serve it with jwplayer i need to solve this. I have to much problems by now on some files who encode for 1 hour instead of 20 minutes lol
[05:44] <Dirkson> SirCmpwn: *reads between the lines* I too am setting up a video site : )
[05:44] <SirCmpwn> Dirkson: I already have, I'm just making it better
[05:44] <SirCmpwn> https://mediacru.sh
[05:48] <Dirkson> SirCmpwn: Cool. I like this ^^
[05:49] <Dirkson> SirCmpwn: Like the default https and partial SPDY implementation : )
[05:49] <SirCmpwn> thanks Dirkson
[05:49] <SirCmpwn> it's open source: https://github.com/MediaCrush/MediaCrush
[05:50] <Dirkson> SirCmpwn: Now that's an interesting idea. It goes down - So what? The software is still available. Next guy can pick it up and run with it.
[05:50] <SirCmpwn> yup.
[05:50] <SirCmpwn> you can also run private instances for yourself, it's well documented if you don't want to use the public instance
[05:51] <Dirkson> SirCmpwn: Neat : )
[05:52] <Dirkson> SirCmpwn: Unsolicted advice: Be sure to document the installation procedure well too. Video's a bear to set up properly.
[05:52] <SirCmpwn> that's very well documented
[05:52] <SirCmpwn> have a look through the README
[05:53] <SirCmpwn> it has step by step instructions to go from fresh ubuntu or arch linux install to mediacrush server in about 5 minutes
[05:53] <Dirkson> Excellent
[05:55] <Dirkson> SirCmpwn: I've been sort of down this past week or so, realizing how quickly people have turned away from a somewhat open and reasonable platform (desktop computing) to closed walled-garden systems (Android/iphone/ipad/etc). Stuff like this gives me hope that people are still pulling for open standards : )
[05:55] <SirCmpwn> Dirkson: :)
[05:55] <SirCmpwn> Dirkson: you might want to hang out in #mediacrush here on freenode, if you're interested
[05:56] <Dirkson> Might could do : )
[05:56] <SirCmpwn> anyway, here's what I've been doing with ffprobe: https://gist.github.com/SirCmpwn/38c97f87cb758d8c0803
[07:08] <anshul> guys i have 5 image and want to convert mp4
[07:08] <anshul> I was able to successssfully convet it to mp4
[07:08] <anshul> but my problem comes when it drop the frames
[07:09] <anshul> my video already have very low frames, even single drop is not bearable to me
[07:12] <anshul> my command ffmpeg -y -loglevel 'debug'  -f concat -i /tmp/tmpk7FXmb  -vsync 1 -pix_fmt yuv420p -s 640x480 -r 1/5 "output/Great_Lakes_region_timeshare_camp.mp4"
[07:15] <anshul> nither this work ffmpeg -y -loglevel 'debug'  -r 1/5 -f concat -i /tmp/tmpk7FXmb  -vsync 1 -pix_fmt yuv420p -s 640x480  "output/Great_Lakes_region_timeshare_camp.mp4" 2> log.txt
[08:13] <IamTrying> Which AMR-WB decoder is stable please? ffdec_amrwb or amrwbdec ?
[08:21] <IamTrying> Is FFmpeg ARM-WB decoder based on this or the the common standards please? http://sourceforge.net/projects/opencore-amr/
[08:21] <relaxed> IamTrying: ffmpeg has native decoders
[08:26] <IamTrying> relaxed, i had 1 year of nightmare with audio encoder/decoders stability, i have been using faac/faad but they are broken not reliable. Now for this new year i am planning to change the faac/faad and use AMR-WB as default cause its most reliable and stable for long term. But i am getting confused i have two decoders:
[08:26] <IamTrying> relaxed, 1) http://paste.ubuntu.com/6549829/   - not ffmpeg decoder
[08:26] <sjuxax> Hello. I have a file muxed as mpegts that contains DV video and PCM audio. ffmpeg refuses to play, transcode, or remux this claiming "unknown codec". How do I get ffmpeg to remux the file into an appropriate container?
[08:26] <IamTrying> relaxed, 2) ffmpeg decoder: http://paste.ubuntu.com/6549834/
[08:26] <IamTrying> relaxed, any idea which decoder is native and original not modified (want to go for less risk for unstability)
[08:31] <relaxed> the latter is ffmpeg's native decoder
[08:32] <relaxed> I would use ffmpeg's
[08:33] <IamTrying> relaxed, Sony is using AMR-WB and its very stable reliable, but i am in puzzle if they used the FFMpeg's or the other one, cause its horrible when the problem starts while using with echo cancel and noise reduction algorithms
[08:35] <IamTrying> When i used Echo cancel and noise reduction algorithm with Faac/Faad encoder/decoder it never worked because the audio become un-natural speech like human voice is in machine voice
[08:35] <IamTrying> Then when i compared for research Sony, Polycom with same echo cancel/noise reduction algorithm they works perfects
[08:36] <IamTrying> Which means that encoder and decoder is causing the echo cancel/noise reduction to be failure. Therefore i need to go for the most native and original AMR-WB
[08:41] <relaxed> IamTrying: can't you test both and see which works the best?
[08:43] <IamTrying> OK - relaxed thank you
[08:44] <relaxed> IamTrying: my static build has both http://johnvansickle.com/ffmpeg/
[09:22] <viric> if I have two outputs, 0:0 and 0:1... and I get "100 buffers queued in output stream 0:1, something may be wrong.", can this mean that 0:0 stopped having pictures?
[10:30] <radu_> can anyone explain me what exactly this means: [flv @ 0x23f2940] Non-increasing DTS in stream 0: packet 9470 with DTS 467931, packet 9471 with DTS 467931
[12:14] <bencc2> when using image2pipe do I have to define the frame rate or can I just send frames in arbitrary times and let ffmpeg timestamp them?
[12:55] <relaxed> bencc2: the default is 25 I think
[12:58] <bencc2> relaxed: anyway to use timestamps without a constant fps?
[13:35] <SirCmpwn> so I'm trying to use x11grab to record my screen
[13:35] <SirCmpwn> and the performance is abysmal
[13:35] <SirCmpwn> suggestions?
[13:39] <Mavrik> get a super computer
[13:39] <Mavrik> that's all you can get without actually giving information
[13:40] <bencc2> I'm creating mp4 from images with "/ffmpeg -y -c:v png -f image2pipe -r 10 -i - -c:v libx264 -movflags +faststart test.mp4"
[13:41] <bencc2> but FF and Chrome can't play it (VLC can).
[13:41] <bencc2> do I have something wrong in my params?
[13:41] <SirCmpwn> ffmpeg -video_size 1920x1080 -framerate 32 -f x11grab -i :0.0+1920,0 foobar.mp4
[13:42] <SirCmpwn> the resulting video file is choppy and bad
[13:42] <bencc2> SirCmpwn: you mean that I should try with your params?
[13:42] <SirCmpwn> no, I'm elaborating on my own problems, bencc2
[13:42] <bencc2> ok. sorry
[13:44] <SirCmpwn> maybe I should set the mp4 to encode in real time
[13:44] <SirCmpwn> or choose a codec better suited for that purpose
[13:44] <SirCmpwn> and convert it later
[13:44] <SirCmpwn> can anyone suggest a codec with an emphasis on fast encoding?
[13:46] <DeadSix27> i always used veryfast/superfast on x264 when i needed fast encoding
[13:46] <SirCmpwn> I'll give that a shot, then
[13:46] <DeadSix27> also, those are presets
[13:46] <SirCmpwn> right
[13:46] <DeadSix27> (-preset veryfast)
[13:47] <JEEB> bencc2, can you pastebin a log of that?
[13:50] <bencc2> JEEB: http://dpaste.com/1498953/
[13:51] <bencc2> JEEB: I can send you the video if needed
[13:51] <JEEB> no need
[13:51] <JEEB> it's pretty obvious why you have low compatibility
[13:51] <JEEB> look for the Output #0 part
[13:51] <JEEB> look at the Stream #0:0 part
[13:52] <JEEB> then look at the colorspace in that (yuvXXX)
[13:52] <JEEB> then remind yourself that most end user decoders can only handle 4:2:0
[13:52] <bencc2> so what setting do I need to change? yuv?
[13:53] <JEEB> you need to tell libavcodec that you want to have a specific pix_fmt
[13:53] <bencc2> "ffmpeg -r 1/5 -i img%03d.png -c:v libx264 -r 30 -pix_fmt yuv420p out.mp4" ?
[13:53] <JEEB> after -i
[13:53] <JEEB> yes
[13:53] <JEEB> that should do it
[13:53] <bencc2> tried it. still same result
[13:53] <JEEB> even with -pix_fmt yuv420p?
[13:53] <bencc2> I'll try it again and paste the result
[13:55] <bencc2> JEEB: this is the output http://dpaste.com/1498954/
[13:55] <bencc2> trying to play in a browser
[13:56] <bencc2> FF on linux works
[13:56] <bencc2> Chrome and FF on windows don't work
[13:56] <JEEB> you're on Vista+ on windows, right?
[13:57] <bencc2> Windows 7
[13:57] <JEEB> and you have the media foundation stuff installed in it?
[13:57] <bencc2> no. I didn't install windows media player
[13:58] <bencc2> I thought that the browser have the codec builtin
[13:58] <JEEB> Firefox uses the MS components because it doesn't want to distro decoders :P
[13:58] <bencc2> I don't have a problem watching html5 vieos
[13:58] <bencc2> I can watch HTML5 youtube videos
[13:59] <JEEB> youtube generally gives you VPx :P
[13:59] <JEEB> http://fushizen.eu/u/jeeb/derp/HidamariHoneycombED.mp4 <- you can test with this, if you can get it to play you have the components :P
[14:00] <JEEB> if it doesn't then your firefox is either too old, or you just don't have the components :P
[14:01] <bencc2> yes. it plays in FF and Chrome
[14:01] <JEEB> also don't forget -movflags +faststart if you want to make sure the file can be played without loading the whole file :P
[14:03] <bencc2> first I want to make it work :)
[14:03] <JEEB> uhh
[14:03] <JEEB> I have no idea if the browsers want that or not, thus just keep it there
[14:03] <bencc2> ok. trying with +faststart
[14:04] <DeadSix27> anyone know how to disbale chapter files ?
[14:05] <DeadSix27> i mean, when converting a mkv to another mkv, how to not include chapters
[14:05] <DeadSix27> in the resulting mkv container
[14:06] <bencc2> JEEB: faststart doesn't help
[14:07] <JEEB> ok, so it's something else
[14:07] <JEEB> the video stream seems OK if you've kept the -pix_fmt yuv420p there
[14:09] <bencc2> JEEB: http://dpaste.com/1498967/
[14:10] <bencc2> it's easy to reproduce the result with phantomjs if it can help
[14:10] <bencc2> I'm getting "pipe:: Input/output error" in the last step every time
[14:10] <bencc2> not sure if that's related
[14:12] <bencc2> JEEB: if I'm converting the mp4 to mp4 with VLC I can see the video in FF
[14:12] <bencc2> maybe it's curropted because of the "pipe: Input/output error" ?
[14:12] <SirCmpwn> DeadSix27: -preset veryfast did the trick, thanks
[14:13] <JEEB> bencc2, if you want to remux you should be using things that /only/ do that
[14:13] <JEEB> to make sure nothing gets re-encoded in there :P
[14:13] <JEEB> GPAC's mp4box, L-SMASH's remuxer, or ffmpeg itself
[14:13] <JEEB> if it gets fixed by just remuxing, then it's a problem in ffmpeg's muxer
[14:14] <JEEB> (and with ffmpeg to remux you set -c to copy)
[14:14] <bencc2> JEEB: not sure I understand :)
[14:15] <JEEB> basically too many variables in "if I'm converting the mp4 to mp4 with VLC"
[14:15] <JEEB> use one of those things I mentioned to see if it is the mux
[14:15] <bencc2> ok
[14:16] <JEEB> if it's not, then compare the profiles of VLC's output and your output (profile is a standard thing that's noted and followed in a H.264 stream, you can just do `ffmpeg -i welp.mp4` to get that info)
[14:16] <DeadSix27> SirCmpwn: read the x264 documenation about what all that is btw
[14:16] <JEEB> although as far as I know high profile should be just fine
[14:16] <SirCmpwn> yeah, I know how it all works
[14:17] <SirCmpwn> I just didn't realize that the encoding might be the bottleneck, I thought it was an x11grab problem
[14:27] <stonie_> hi all .. how can i produce the best quality mpeg2 9mbit 720x576 out of a mpeg2 15mbit hd 1920x1080? ... right now i use "ffmpeg -report -i infile.mpg  -threads 8 -aspect 16:9 -vcodec mpeg2video -b:v 9500k -flags +ilme+ildct -top 1 -s 720x576 -ac 2 -y -r 25 outfile.mpg" - which is quiet good "but not perfect"
[14:28] <JEEB> have fun diving into the encoder's code and seeing the options
[14:28] <JEEB> pretty much everything except for libx264 doesn't have any kind of preset system
[14:31] <stonie_> ...
[14:32] <JEEB> and since everything but libx264 is pretty much very unoften used...
[14:32] <JEEB> you can guess the interest of people to create those presets :)
[14:32] <JEEB> many of the options are shared between the mpegX encoders tho
[14:38] <JEEB> stonie_, there are some settings noted over at http://x264dev.multimedia.cx/archives/102 , which is a relatively old (by now) test of animation encoding. See the "ffmpeg mpeg2" part, but do note that some of those settings _will_ make the stream incompatible with DVD if that's what you're encoding for
[14:43] <stonie_> ok ill read thru thanks!
[14:43] <stonie_> what is "-dc" exactly for
[14:44] <stonie_> duration calculation?
[14:45] <JEEB> most probably not :P
[14:47] <JEEB> it even has an "explanation" @ http://ffmpeg.org/ffmpeg.html
[14:47] <JEEB> and the dc most probably has something to do with discrete cosine (transform)
[15:04] <bencc2> JEEB: maybe when piping images from phantomjs to ffmpeg it sends something bad at the end which cause ffmpeg to create corrupted mp4?
[15:06] <bencc2> JEEB: this fixes the video for me "ffmpeg -i input.mp4 -c copy output.mp4"
[15:07] <JEEB> bencc2, yeah -- then it's the muxing
[15:08] <JEEB> make it possible to reproduce and add an issue on the trac
[15:08] <JEEB> and you will either get told what you're doing wrong
[15:08] <JEEB> or the bug will get found
[15:09] <bencc2> JEEB: I'll add an issue
[15:09] <bencc2> JEEB: what is the correct way to stop a pipe?
[15:09] <bencc2> in phantomjs I'm calling phantom.exit() but maybe it's wrong
[15:09] <JEEB> I've no idea
[15:09] <bencc2> ok
[15:10] <JEEB> but yes, that's a possible error
[15:11] <bencc2> ok
[15:23] <iMath> which position should -y put to in this cmd
[15:23] <iMath> ffmpeg -f concat -i listfile.txt -c copy a.flv
[15:23] <iMath> ?
[15:26] <bencc2> I think it can be right after ffmpeg (not sure)
[15:28] <iMath> doesn't work
[15:36] <iMath> oh,my bad,u r right
[15:38] <stonie_> JEEB, ok ty.. was busy sry
[16:23] <gazarsgo> i'm trying to configure ffmpeg with --enable-opencl but it's bombing out ? i'm on master from git ...
[16:26] <DeadSix27> can you add ignored tags to ffmpeg?
[16:26] <DeadSix27> for example: -ignorethis "myString"
[17:26] <DelphiWorld> hey
[17:26] <DelphiWorld> how to compile FFMPEG with fPIC?
[17:28] <JEEB> --enable-pic
[17:28] <JEEB> mostly if you get an error it is related to your dependencies, not ffmpeg itself
[17:29] <viric> if the error is at ffmpeg build time.
[17:30] <DelphiWorld> thank JEEB
[17:41] <ThomasSeilund> Hi All, how do I seek and cut out a video sequence and keep same container (mpegts), vcodec (x264) and acodec (mp3) without loosing A/V sync. I have been trying for days but I cant find the right ffmpeg command to use!
[19:52] <grkblood13> pcm_s16le is supposed to have a data range from -32767 to +32768 correct?
[20:06] <klaxa> -32768 to 32767 probably
[20:07] <klaxa> negative numbers are one more because 0 is considered positive
[20:07] <klaxa> and it makes math easier
[20:41] <Mista_D> Can any filter be used to automagically fix botched file and drop out duplicate frames? Decimate doesn't seem to remove out of order ones. I have a case of video-stupidity: 24p got telecined, then bob deinterlaced to 60p. Trying to bring it back to its original state.  Problem is that duplicate frames are out of order e.g. "3322432232" probably due to bad telicine/Bob deinterlace filter used
[20:41] <Mista_D> prior or bad video to begin with.
[20:44] <JEEB> ffmpeg has field matching and decimation filters
[20:45] <JEEB> ported from myrsloik's rewrite of the famous TIVTC filter
[21:07] <DeadSix27> amazing
[21:07] <DeadSix27> i just for the fun and boredom.. used ffmpeg to turn a midi into mp3
[21:07] <DeadSix27> and it uses the old 56k modem-ringing sounds as instruments
[21:08] <DeadSix27> now i have Erik satie's gym.1 in modem sounds.
[21:19] <gazarsgo> hmmm 15 fps through x264 at 1024x768 seems low ?
[21:40] <klaxa> gazarsgo, depends
[21:40] <gazarsgo> well turns out i'm not using my fancy gpu at all
[21:40] <gazarsgo> stupid xvfb :(
[21:48] <klaxa> err...
[23:35] <gazarsgo> how can i make ffmpeg scale the input to the output size rather than add pixels ?
[23:39] <llogan> gazarsgo: use the scale filter
[23:40] <gazarsgo> i'm reading about it, what if i have a nonlinear scaling factor to apply ?
[23:43] <llogan> gazarsgo: what do you mean?
[23:43] <gazarsgo> like my input is 960x507
[23:44] <gazarsgo> but i want to output 1024x768
[23:44] <klaxa> -vf "scale=1024:768" ?
[23:46] <beastd> gazarsgo: what do you want to achieve? people looking thinner?
[23:46] Action: llogan doesn't know what is being asked.
[23:50] <gazarsgo> i guess centering would fine instead of scaling
[00:00] --- Wed Dec 11 2013

More information about the Ffmpeg-devel-irc mailing list