[Ffmpeg-devel-irc] ffmpeg.log.20131215

burek burek021 at gmail.com
Mon Dec 16 02:05:01 CET 2013

[02:12] <DeadSix27> waiting 2 hrs, realise you forgot that you left the start param in the encode, feel annoyed.
[02:13] <DeadSix27> i bet alot people here can relate.
[02:58] <klaxa> most of the time i encode stuff while i'm asleep
[03:03] <DeadSix27> ye same
[03:04] <DeadSix27> but right now im still awake.. and had nothing much to do
[03:49] <SLAYBoz> how much better is h265 over h264
[04:07] <Compn> its +1 better
[04:07] <Compn> damn parker already said it
[04:31] <SLAYBoz> is .ts a valid container?
[04:38] <Compn> valid for what
[04:39] <SLAYBoz> meaning is it container like  .mkv/mp4/flv/asf
[04:40] <Compn> yes, mostly used by commercial products and not pirates
[04:40] <Compn> not as widely supported in editing applications
[04:41] <SLAYBoz> how come i rarely see it even on commercial
[04:42] <Compn> its usually used in set top boxes , where you dont have access to it
[04:43] <SLAYBoz> i see
[04:43] <SLAYBoz> i have only seen it on bluray and my HD camera
[04:44] <SLAYBoz> does ffmpeg support .ts
[04:47] <Compn> you think bluray is rare ?
[04:48] <SLAYBoz> sorry i said that wrong, i rarely see them on commercial website
[04:48] <SLAYBoz> does ffmpeg support .ts
[04:49] <sacarasc> Yes.
[04:50] <SLAYBoz> how come people don't use it as much as mkv/mp4
[04:50] <relaxed> you would be hard pressed to find a format that ffmpeg doesn't support
[04:50] <SLAYBoz> relaxed it doesn't support .asf
[04:50] <relaxed> wrong
[04:51] <SLAYBoz> i can convert mkv video to .asf video?
[04:51] <SLAYBoz> using ffmpeg
[04:51] <relaxed> yes
[04:51] <SLAYBoz> let me try
[04:51] <relaxed> ffmpeg -formats 2>&1|grep asf
[04:52] <relaxed> you need to do more research before you flood this channel with incomplete sentences and silly questions.
[04:55] <SLAYBoz> it does support asf but not .ts
[04:55] <relaxed> ffmpeg -formats 2>&1|grep mpegts
[04:56] <SLAYBoz> it shows up
[04:56] <SLAYBoz> what am i doing wrong then
[04:56] <SLAYBoz> ffmpeg -i R:\b.mp4 -vcodec copy -acodec copy b.ts
[04:57] <relaxed> You can't copy any stream into any container.
[04:58] <SLAYBoz> b.flv and b.asf worked
[04:59] <relaxed> Some containers only support certain A/V codecs. I expect you to google for more info.
[04:59] <SLAYBoz> i know ts supports  avc
[05:01] <SLAYBoz> i guess that explains ts are rare
[05:01] <SLAYBoz> but i don't get it
[05:02] <relaxed> google until you do get it.
[10:13] <rager> hi - I lost that video player example someon linked me a while back - can someone link me one for current ffmepg release? I'm trying to get some bindings to work, still
[10:38] <rager> it was a relatively short c script that opened and played a video files
[11:21] <zap0> rager, videolan libVLC?
[13:07] <pyBlob> I've created a video, now when a scene change happens, I want to extract the first frame of the new scene, is there a good way to do that?
[13:12] <zap0> py google `scene change ffmpeg`
[13:13] <zap0> there are many "scripts" out there
[13:13] <zap0> on the interwebs
[13:13] <pyBlob> everything depends on the order you type it xD
[13:20] <benbro1> I have img1.png, img2.png... instead of img001.png...
[13:20] <benbro1> what can I use instead of img%03d.png ?
[13:20] <pyBlob> try img%3d.png
[13:23] <benbro1> doesn't work
[13:23] <pyBlob> :/
[13:23] <benbro1> Could find no file with path 'frame%3d.png' and index in the range 0-4
[13:23] <pyBlob> img%d.png ?
[13:23] <benbro1> seems to work :)
[13:24] <benbro1> thanks
[14:37] <padawanc> Hi everybody
[14:37] <padawanc> Doesn't anyone know how to audio and video without capturing microphone?
[14:38] <padawanc> I'm capturing some video lessons from a website, but when I speak or something the audio is put in the recorder too.
[14:39] <padawanc> My paste http://pastebin.com/LgAzEwNq
[14:39] <padawanc> how to capture audio and video*
[14:46] <padawanc> To be more simple, I don't want to record my voice, just the sound that comes from the default output.
[19:15] <mrmargolis> I am trying to extract information from a file that is on S3.  ffmpeg/ffprobe do a great job of streaming part of the file to get the headers, but I am not getting particularly great throughput.  Does anyone know if there is configuration that might help speed up http/https streaming?
[19:16] <klaxa> try to improve the network?
[19:17] <mrmargolis> I have run it on really fast connections, still takes longer than I was hoping
[19:17] <mrmargolis> The command I am running is http://pastebin.com/K9j8DNjX
[19:17] <mrmargolis> I know that S3 throttles individual connections, I doubt that ffprobe supports threaded download of the file... but that would likely help
[19:19] <mrmargolis> I need to grab a handful of frames to make a guess at interlaced vs progressive, so I am reading more than just the headers, but not the whole file.
[19:22] <klaxa> i doubt ffprobe/ffmpeg support that
[19:22] <klaxa> however, maybe there is a project that uses multiple connections to download a file and output it in the right order via stdout
[19:22] <klaxa> you could pipe that to ffprobe/ffmpeg
[19:23] <mrmargolis> that's a good idea
[20:23] <femtocoin> hi
[20:23] <femtocoin> I am trying to concatenate mp4 video files and i get this message
[20:24] <femtocoin> http://pastebin.com/b6AsGdPY
[20:26] <femtocoin> ok ok cool
[20:26] <femtocoin> wait a minute while i do proper pastebin
[20:40] <femtocoin> Hi
[20:40] <femtocoin> I posted the problem here
[20:40] <femtocoin> http://pastebin.com/T3gUeB1H
[20:40] <femtocoin> its about concating mp4 files
[20:41] <femtocoin> i get weird warnings although the final mp4 "kindof works"...but trying to fastforward to a certain position breaks my player (VLC),.., maybe navigational information (fastforward in time etc) is lacking or broken?
[20:41] <femtocoin> if anyone can look into it, i would appreceate it
[20:51] <femtocoin> oh shit, i am playing that video and it broke
[20:51] <femtocoin> lol
[20:51] <klaxa> lol
[20:53] <klaxa> you could try putting all the files into mpeg ts, just concat them in your shell and then put it back into mp4
[20:59] <viric> can mpeg ts be concatted?
[20:59] <viric> with success, I mean
[21:02] <re-G> i think yes
[21:02] <femtocoin> klaxa
[21:03] <femtocoin> what do you mean?
[21:03] <femtocoin> mpeg ts,?? what is that how do i do that?
[21:03] <femtocoin> i posted my commandline in paste bin
[21:03] <femtocoin> http://pastebin.com/T3gUeB1H
[21:04] <femtocoin> i use only mp4 files
[21:04] <femtocoin> your sentence doesnt make any sense to me
[21:04] <femtocoin> "just concat them in your shell and then put it back into mp4"
[21:05] <femtocoin> i concat them and the result is an mp4 file, so what is that "putting it back into mp4"?? mean
[21:06] <klaxa> see the concat protocol part in the docs (https://trac.ffmpeg.org/wiki/How%20to%20concatenate%20%28join,%20merge%29%20media%20files)
[21:06] <klaxa> and with shell i mean: cat file1.ts file2.ts file3.ts > all_files.ts
[21:21] <femtocoin> what? Klaxa as you can see my command line i dont use *.ts files
[21:21] <femtocoin> how do i create them?
[21:21] <klaxa> ffmpeg -i some_file.mp4 -c copy -f mpegts some_file.ts
[21:22] <klaxa> you can concat mpeg ts without having to worry about headers and such, you can't do that with mp4
[21:22] <klaxa> you then put it back to mp4 with: ffmpeg -i all_files.ts -c copy all_files.mp4
[21:22] <femtocoin> aha
[21:23] <femtocoin> i am on windows, i need to binary copy then i think
[21:23] <femtocoin> no 'cat' here)
[21:23] <viric> copy /b
[21:25] <femtocoin> if i have a long list of files must i do every time ffmpeg -i some_file.mp4 -c copy -f mpegts some_file.ts?
[21:25] <femtocoin> cant i use a file list?
[21:28] <viric> write a script
[21:28] <femtocoin> Hi, i tried for one file and i get this error
[21:28] <femtocoin> [mpegts @ 029ad380] H.264 bitstream malformed, no startcode found, use the h264_mp4toannexb bitstream filter (-bsf h264_mp4toannexb)
[21:28] <femtocoin> av_interleaved_write_frame(): Invalid argument
[21:29] <femtocoin> ok adding bitstream filter to command line as specified by error message, see what happens
[21:31] <femtocoin> works
[21:31] <femtocoin> i have all the timestamp *.ts files
[21:31] <femtocoin> now i do concat
[21:46] <femtocoin> ok klaxa
[21:46] <femtocoin> i got it working but weird shit let me explain
[21:47] <femtocoin> ffmpeg -i all_files.ts -c copy all_files.mp4  n<< didnt work i get an AAC [mp4 @ 03bf2020] Malformed AAC bitstream detected: use audio bitstream filter 'aac_adtstoasc' to fix it ('-bsf:a aac_adtstoasc' option with ffmpeg
[21:47] <femtocoin> av_interleaved_write_frame(): Operation not permitted
[21:48] <JEEB> that's because you use different types of AAC bit streams for mpeg-ts and mp4
[21:49] <JEEB> add that bsf:a command and it should work
[21:49] <JEEB> (after -i)
[21:49] <femtocoin> ok, i created the *.ts files from *.mp4 files
[21:49] <femtocoin> so when creating the ts files i add this filter? ok
[21:50] <JEEB> eh?
[21:50] <JEEB> you just said you got that error when creating mp4 from the ts?
[21:50] <JEEB> ffmpeg -i all_files.ts -c copy all_files.mp4 <- this clearly has ts as input, and mp4 as output
[21:50] <femtocoin> klaxa posted ffmpeg -i some_file.mp4 -c copy -f mpegts some_file.ts?
[21:50] <femtocoin> ok JEEB
[21:50] <femtocoin> i have 8 mp4 files
[21:50] <femtocoin> i want to concatenate them
[21:51] <femtocoin> the standard command line i got from the manual is not cutting it
[21:51] <femtocoin> i get all kinds of timestamp errors
[21:51] <femtocoin> so i did this
[21:51] <femtocoin> ffmpeg -i some_file.mp4 -c copy -f mpegts some_file.ts
[21:51] <femtocoin> for all 8 files, then do cat file1.ts file2.ts ... > final.ts
[21:51] <femtocoin> then create mp4 from the final.ts file
[21:51] <JEEB> yes?
[21:52] <femtocoin> but when doing the last part i get that crazy error
[21:52] <JEEB> and you get the error at the last point, right?
[21:52] <femtocoin> aac
[21:52] <femtocoin> yes
[21:52] <JEEB> yes, then I thought correctly
[21:52] <femtocoin> ok ok
[21:52] <JEEB> and you should heed the goddamn errorr
[21:52] <JEEB> it tells you how to fix it!
[21:52] <JEEB> when creating the final mp4
[21:52] <femtocoin> sure i add the filter
[21:52] <femtocoin> but not working))
[21:52] <JEEB> ok, then there's something else
[21:52] <JEEB> post the command and terminal output on a pastebin
[21:52] <JEEB> link here
[21:53] <femtocoin> no problem
[21:53] <femtocoin> moment
[21:57] <femtocoin> http://pastebin.com/QwJHeMFT
[21:58] <femtocoin> highlighted the error messages
[21:58] <JEEB> ugh
[21:58] <JEEB> -c -bsf:a aac_adtstoasc copy
[21:58] <JEEB> guess what is wrong here
[21:58] <femtocoin> ooh
[21:58] <femtocoin> ok
[21:58] <JEEB> -bsf:a is not a setting for -c :P
[21:59] <JEEB> -c copy -bsf:a aac_adtstoasc
[21:59] <femtocoin> LOOOL
[21:59] <femtocoin> ok
[21:59] <femtocoin> oopsy
[22:00] <femtocoin> works like a charm
[22:00] <femtocoin> oh by the way, when i select final file to be *,mpeg i dont have to add the filter, why is that?
[22:01] <JEEB> because you're remuxing into a format that doesn't have a different bit stream format for AAC
[22:01] <JEEB> ADTS is generally used in MPEG-TS and similar formats, ASC is used in MP4
[22:01] <femtocoin> okidoki
[22:04] <femtocoin> JEEB, (and everyone who was helpfull, i freaken love you guys, it works like a charm)
[23:14] <farsheed> Question: Any available sites for latest non-free ffmpeg binaries for linux64 with x11-grab?
[00:00] --- Mon Dec 16 2013

More information about the Ffmpeg-devel-irc mailing list