[Ffmpeg-devel-irc] ffmpeg.log.20131219

burek burek021 at gmail.com
Fri Dec 20 02:05:01 CET 2013

[01:04] <FunkyELF> are you not supposed to use id3 tags on mp4 files?
[01:04] <FunkyELF> I have a bunch of aac audio in mp4 files.  When I run id3tag on them they no longer play in mplayer
[01:16] <bencc> is it possible to combine 25 video streams in real time?
[01:17] <bencc> all with the same resolution, size, bit-rate, fps
[02:42] <bencc> the following command just hangs ./ffmpeg -i test.webm test.mp4
[02:43] <bencc> do I have a syntax error?
[04:17] <jesseg> Hey I think I found a bug in ffplay - when laying an audio file, with the hystogram thing showing, if I resize the window to vertically zero height, it crashes. Anyone else notice that?
[10:11] <bencc> how can I convert webm to mp4 that can be played in browsers?
[10:11] <bencc> ./ffmpeg -i vid.webm vid.mp4
[10:11] <bencc> this just hangs
[10:19] <brontosaurusrex> bencc, full output
[10:25] <bencc> brontosaurusrex:  http://dpaste.com/1512547/
[10:26] <viric> webm is the one that can be played in browsers
[10:26] <bencc> viric: not in IE
[10:26] <bencc> maybe the webm is corrupted
[10:26] <bencc> can I fix it instead of encoding?
[10:27] <brontosaurusrex> bencc, check mkvtoolnix, maybe there is way to remux it to new webm or mkv
[10:27] <brontosaurusrex> does that video.webm play in firefox well?
[10:28] <bencc> the webm palys in firefox but not in chrome
[10:28] <TheSchaf> ie does not support webm out of the box
[10:28] <TheSchaf> atleast not ie9, not sure about newer ies
[10:30] <brontosaurusrex> chrome should play webm stuff afaik
[10:31] <brontosaurusrex> bencc, a test http://video.webmfiles.org/big-buck-bunny_trailer.webm
[10:32] <bencc> the bunny plays both on Chrome and FF
[10:32] <bencc> I've created the webm with virtualbox video capture
[10:32] <bencc> maybe it creates bad index or something
[10:33] <bencc> how can I use mkvtoolnix to remux?
[10:33] <bencc> with mkvmerge?
[10:33] <TheSchaf> so what is you goal again? to play in ff and chrome?
[10:34] <viric> talking about IE
[10:34] <viric> I cannot find how to get into an https site whose cert is untrusted.
[10:34] <TheSchaf> ie11 doesnt play the bunny video for me
[10:34] <TheSchaf> maybe ie doesnt support webm at all
[10:34] <brontosaurusrex> bencc> with mkvmerge? < yes
[10:34] <bencc> play on Chrome, FF and IE
[10:34] <viric> I only get a page with "certificate error" and a button "close this webpage". No way to get in. Anyone knows?
[10:34] <bencc> IE doesn't support webm
[10:35] <brontosaurusrex> TheSchaf, this https://tools.google.com/dlpage/webmmf ?
[10:35] <TheSchaf> looks like there is no format that is supported by all 3 browsers
[10:35] <TheSchaf> well, mp4
[10:36] <TheSchaf> if yu have ff > 21
[10:36] <brontosaurusrex> TheSchaf, so mozilla is allready using that cisco thingy?
[10:36] <TheSchaf> http://www.w3schools.com/html/html5_video.asp
[10:36] <TheSchaf> according to that mp4 can run on chrome, ie and ff
[10:36] <TheSchaf> webm only chrome and ff
[10:38] <brontosaurusrex> i'd use AVC/mp4 and give insulting error messages to people running firefox without avc decoder, done.
[10:38] <lkiesow> TheSchaf: Afaik both mp4 and webm run in ie with the appropriate codecs installed, don't they?
[10:39] <TheSchaf> lkiesow: but mp4 runs out of th ebox, webm requires a third party plugin
[10:40] <brontosaurusrex> + ban ie users
[10:40] <lkiesow> Afaik. not with old Windows versions :)
[10:41] <lkiesow> Safest way would be to create both a WebM and a mp4
[10:42] <brontosaurusrex> <lkiesow> the encoders are not comparable, x264 is easier to use and much faster and much better and
[10:42] <brontosaurusrex> ...
[10:43] <TheSchaf> well i mean
[10:43] <TheSchaf> http://www.w3schools.com/browsers/browsers_stats.asp
[10:44] <TheSchaf> almost possible to ignore IE these days
[10:44] <brontosaurusrex> TheSchaf, give them flash player and same mp4/AVC file If you really must
[10:44] <viric> anyone knows how to get into this URL, bypassing the cert, in IE?
[10:44] <viric>
[10:45] <viric> IE here offers only "close this website"
[10:45] <brontosaurusrex> viric, ask site owner and/or microsoft?
[10:45] <TheSchaf> my ie offers me "continue loading this page (not recommended)"
[10:46] <viric> TheSchaf: really? not mine.
[10:46] <viric> brontosaurusrex: I'm the site owner :)
[10:46] <TheSchaf> i have 11.0.1
[10:46] <viric> 11.0.9600 here
[10:46] <TheSchaf> as in http://support.microsoft.com/kb/2888505 that version
[10:46] <brontosaurusrex> viric, home made certificat?
[10:47] <TheSchaf> wait
[10:47] <TheSchaf> when i navigate to the page in a new window
[10:47] <TheSchaf> i get the continue option
[10:47] <TheSchaf> when i navigate from some other page, it doesnt give me continue
[10:47] <viric> brontosaurusrex: yes
[10:48] <brontosaurusrex> TheSchaf, ie has only 11% lately
[10:48] <brontosaurusrex> TheSchaf, so actually banning them would be no big deal.
[10:48] <TheSchaf> actually i think ie 11 is pretty good
[10:48] <TheSchaf> but i guess ie has just a really bad rep.
[10:48] <viric> TheSchaf: what is "navigate from some other page"?
[10:49] <brontosaurusrex> they had like 15 years to fix their c***, so ....
[10:49] <TheSchaf> viric, when i open a new ie and paste the url and hit enter i get the "continue" thing
[10:49] <TheSchaf> when i go to google.com then paste the url i only get "close htis page"
[10:49] <TheSchaf> so it differs if you want to go there directly or you are maybe "redirected"
[10:49] <viric> you paste the url in the google search box?
[10:49] <TheSchaf> no
[10:49] <TheSchaf> close all IE windows
[10:49] <TheSchaf> open new ie window
[10:49] <TheSchaf> enter url
[10:50] <TheSchaf> press enter
[10:50] <TheSchaf> then you should get continue
[10:50] <TheSchaf> then hit reload (navigate from "another page" to the evil page)
[10:50] <TheSchaf> and you wont get the continue
[10:50] <viric> hm no. I never get the continue option
[10:51] <TheSchaf> weird
[10:51] <viric> yes.
[10:56] <viric> TheSchaf: can you so download 'prova.sh' with IE, clicking that button?
[10:57] <TheSchaf> no it displays it
[10:57] <TheSchaf> some weird letters
[10:58] <TheSchaf> but i mean you can just use http instead of https? :D
[10:58] <viric> TheSchaf: weird letters? don't you see a short 'sh' script?
[10:59] <viric> DIED=0, ... ?
[11:00] <viric> this IE doesn't work at all. Maybe it's because "the site owner" forced ECDHE key negotiation, and IE doesn't support it? mh
[11:00] <TheSchaf> 
[11:00] <TheSchaf> it shows chars like that
[11:00] <TheSchaf> no valid sh script
[11:00] <viric> it doesn't work at all for you then. Try with firefox :)
[11:01] <TheSchaf> same with ff
[11:01] <viric> Are you sure you typed https?
[11:01] <viric> and not http
[11:01] <TheSchaf> yeah
[11:02] <viric> ok then your browser situation is even worse than mine ;)
[11:03] <brontosaurusrex> viric, something is wrong http://paste.debian.net/plain/71740
[11:04] <brontosaurusrex> and it has to do with ssh/cert/something
[11:07] <viric> brontosaurusrex: wget --no-check-certificate ? can you try it?
[11:08] <viric> gnutls is not very verbose
[11:10] <brontosaurusrex> ok
[11:11] <brontosaurusrex> viric, same error
[11:17] <viric> auhm. Maybe you have an old gnutls/wget?
[11:17] <viric> gnutls 3.1.12 wget 1.14 work fine.
[11:19] <brontosaurusrex> GNU Wget 1.13.4
[11:19] <viric> maybe IE uses a old gnutls ;)
[11:19] <brontosaurusrex> haha, yeah
[13:23] <Jellicent> 2~
[13:23] <Jellicent> That was not supposed to happen
[13:24] <Jellicent> Hey guys, I'm aiming to stream (twitch.tv) but I'm having a little sound problem. I'm using alsa and the sound is awfully low. Has anything like this been reported? Couldn't find anything like this. Microphone works fine, just not the ingame recorded sound (what I hear basically).
[13:26] <Compn> Jellicent : probably have to adjust volume in amixer or whatnot
[13:26] <Compn> e.g. make speaker volume quieter and system volume louder
[13:26] <Jellicent> System volume is on 100%
[13:27] <Jellicent> That's the fancy part about it.
[13:27] <Jellicent> Everything's as high as it gets..
[13:29] <Jellicent> Compn: Would it be on any help if I pasted the script I'm using?
[15:37] <bencc> how can I fix a corrupted webm file?
[15:37] <bencc> it can be played in some browsers but not all
[17:19] <DelphiWorld> hi ffmpegifiers
[17:19] <DelphiWorld> this rtmp stream is giving me error evean i compiled with librtmp...
[17:19] <DelphiWorld> rtmp://radio.gmo.ps/live/livestream
[17:20] <DelphiWorld> giving me handcheck error
[17:26] <DelphiWorld> HandShake: client signature does not match
[17:28] <mootsadog> does anybody know if it's possible to force ffmpeg to finish encapsulating the output from a broken input file?
[17:29] <mootsadog> i have input from a hard drive camera's mpegTS that the camera recognized as "corrupted" and i believe i've hit that file because i'm getting "av_interleaved_write_frame()" input/output error" and unusable output
[17:31] <mootsadog> the input file plays fine in VLC. though you know what & it's possible this is happening because the server it's writing to is crapping out. sorry.
[17:42] <Compn> mootsadog : dang, thats bad luck, failing media and failing server
[17:43] <mootsadog> Hahah what else, right? ;) netatalk is giving me so many headaches.
[18:29] <DelphiWorld> ANYONE have a rtmp stream to try? (audio)
[18:29] <Compn> DelphiWorld : theres a list on http://wiki.multimedia.cx
[18:29] <CountryfiedLinux> I tried to install ffmpeg and it says no installation candidate
[18:30] <CountryfiedLinux> any suggestions? thanks in advance
[18:30] <Compn> what distro CountryfiedLinux :
[18:30] <DelphiWorld> Compn: what should i search?
[18:30] <Compn> rtmp ?
[18:30] <CountryfiedLinux> Compn, debian
[18:30] <Compn> DelphiWorld : http://wiki.multimedia.cx/index.php?title=RTMP
[18:30] <DelphiWorld> Compn: see that: rtmp://radio.gmo.ps/live/livestream
[18:31] <DelphiWorld> Compn: see if you can ffplay or ffprobe it
[18:31] <Compn> CountryfiedLinux : debian removed ffmpeg package
[18:31] <Compn> DelphiWorld : probably you are missing the swfurl or flashver parameters to access the stream
[18:31] <CountryfiedLinux> Compn, So is there a repository for it?
[18:31] <Compn> DelphiWorld : its rare you can play an rtmp stream without all the other referers
[18:31] <DelphiWorld> no need, its work perfectly in VLC
[18:31] <Compn> ok
[18:32] <DelphiWorld> CountryfiedLinux: bro, use git, you can compile it issueless
[18:32] <Compn> CountryfiedLinux : deb-multimedia repo has ffmpeg for apt get yes
[18:32] <Compn> or whatever its called now
[18:32] <bencoh> DelphiWorld: seems to ffprobe well here (both ffmpeg 1.1.5 and 2.1.1à
[18:32] <CountryfiedLinux> Compn, How do I install the multimedia repo?
[18:32] <Compn> CountryfiedLinux : http://www.deb-multimedia.org/
[18:32] <Compn> instructions there.
[18:33] <DelphiWorld> bencc: mmmmmmmmm, i'm using latest git ffmpeg and it's failing, are you using librtmp?
[18:33] <bencoh> not on this build no
[18:33] <DelphiWorld> bencoh: are you using git or pre-built?
[18:34] <Compn> fails in my nightly git build N-58288-g80e5859 built on Nov 19 2013
[18:34] <Compn> that rtmp url
[18:34] <DelphiWorld> Compn: also this one will fail: rtmp://sony.flash.internapcdn.net/sony_vitalstream_com/_definst_/mp4:NAB2009-Video/Sony_Professional_Media.f4v
[18:34] <bencoh> DelphiWorld: n2.1.1 tag from git
[18:35] <DelphiWorld> bencoh: would you tel me how to switch to it?
[18:35] <bencoh> from git ? git checkout n2.1.1
[18:36] <DelphiWorld> let's have some adventure
[18:36] <bencoh> DelphiWorld: http://pastebin.notk.org/pastebin.php?show=d62066243
[18:36] <DelphiWorld> LOL notk... crazy name:)
[18:39] <DelphiWorld> bencoh, the stream that worked for me is: rtmpe://wbads.fcod.llnwd.net/a2383/o25/mp4:thewb/video/thegeorgecarlinshow/01/thegeorgecarlinshow_01_01_700kbps.mp4
[18:40] <saste> DelphiWorld, did you ever use ffserver?
[18:40] <DelphiWorld> saste: yes, i did and wrote a tutorial on using it;)
[18:40] <saste> DelphiWorld, where is the tutorial?
[18:40] <DelphiWorld> sec, saste
[18:41] <saste> i'm having a weird TCP issue with ffserver: http://thread.gmane.org/gmane.comp.video.ffmpeg.user/49400
[18:42] <DelphiWorld> saste, https://github.com/braice/MuMuDVB/blob/master/doc/TRANSCODE_EXTERNAL.txt
[18:43] <bencc> DelphiWorld: no. I'm talking about webm
[18:43] <DelphiWorld> sory bencohbut could you please give me the git cmd again?
[18:43] <DelphiWorld> bencc: lol, sory but my msg was to bencoh :-P
[18:47] <DelphiWorld> saste: isnt you're a ffmpeg dev?
[18:50] <Compn> DelphiWorld : this is also where ffmpeg devs ask for help
[18:50] <Compn> ffmpeg devs dont know the whole codebase, just like linus torvalds doesnt know all of linux :)
[18:50] <DelphiWorld> Compn: yeah i know, to get improvement offcource, but i just asked;)
[18:50] <Compn> ah
[18:50] <DelphiWorld> HEHEHE
[18:51] <DelphiWorld> i wish ffserver get some improvement and stability, it's fully buggy right now
[18:51] <DelphiWorld> also i dont like to fetch streams using ffmpeg and push to ffserver, it's better to let ffserver do the trick itself (without any external process
[18:52] <DelphiWorld> bencc2: did you get my pm?
[18:53] <CountryfiedLinux> missed part of the instructions I see now sorry brb
[18:54] <odedo> I'm having trouble converting Hebrew SRT subtitles to ASS: http://bpaste.net/show/160259/\
[18:56] <ubitux> it's an input option
[18:56] <spaam> try putting -sub_charenc  before -i
[18:56] <spaam> and what ubitux said :D
[18:57] <DelphiWorld> spaam: you lighttpd developer?
[18:57] <ubitux> "enc" (encoding) is related to the "char" (character), not "encoding" in the sense of ffmpeg
[18:57] <ubitux> it's an input option used to specify the character encoding of the input
[18:57] <ubitux> so you put it before the -i as spaam said
[18:58] <spaam> DelphiWorld: you like my host? :)
[18:58] <DelphiWorld> spaam: seriously are you lighttpd dev?
[18:58] <spaam> DelphiWorld: yeah you can say that :)
[18:58] <odedo> Thanks ubitux and spaam, it's working
[18:59] <spaam> odedo: great :)
[18:59] <DelphiWorld> spaam: did lighttpd get any streaming functionality like nginx?
[18:59] <CountryfiedLinux> still says no installation candidate
[18:59] <DelphiWorld> odedo: where you live in IL?
[18:59] <spaam> DelphiWorld: "streaming functionality" ?
[18:59] <DelphiWorld> CountryfiedLinux: did you apt-get update? did you install deb-multimedia-keyring?
[19:00] <odedo> DelphiWorld, Tel Aviv, and you? ;o
[19:00] <DelphiWorld> spaam: push live http stream to   lighttpd, push / get rtmp, hls...
[19:00] <saste> DelphiWorld, to me it looks more like a TCP buffering or network issue
[19:00] <DelphiWorld> odedo: i'm algerian, but comming there soon:)
[19:00] <CountryfiedLinux> DelphiWorld, Yes I did.
[19:01] <DelphiWorld> saste, would you describ your setup?
[19:01] <saste> since i'm relatively new with using ffserver, you may have already encountered the problem
[19:01] <DelphiWorld> odedo: i will come to Telaviv to buy a audio encoder:)
[19:01] <saste> DelphiWorld, i did in the post i linked
[19:01] <DelphiWorld> saste: show me please again
[19:01] <spaam> DelphiWorld: no.  never heard of it .
[19:01] <DelphiWorld> spaam: nginx do rtmp...
[19:01] <saste> basically it's a one stream ffserver instance, streaming a synthetic video, nothing fancy
[19:01] <odedo> DelphiWorld, I hope you'll have a nice time :) I wouldn't hurry though, it's kind of really cold for the time being (although middle-eastern cold)
[19:02] <saste> http://thread.gmane.org/gmane.comp.video.ffmpeg.user/49400
[19:02] <spaam> DelphiWorld: i guess you are talking about https://github.com/arut/nginx-rtmp-module ?
[19:02] <DelphiWorld> spaam: YUP  YUP
[19:02] <DelphiWorld> odedo: yeah i know, maybe i'lle be there in february
[19:03] <CountryfiedLinux> Here's my source list http://pastebin.com/45ZS9KHH
[19:03] <CountryfiedLinux> DelphiWorld, ^
[19:04] <DelphiWorld> CountryfiedLinux: using wheezy?
[19:04] <CountryfiedLinux> DelphiWorld, no
[19:04] <CountryfiedLinux> DelphiWorld, Should I pin that one?
[19:04] <spaam> DelphiWorld:  anyway. it wont happen in lighttpd 1.4.x  maybe if someone add it to lighttpd 2.0
[19:04] <DelphiWorld> what version?
[19:04] <CountryfiedLinux> DelphiWorld, Testing
[19:04] <acovrig> I am encoding a stream from a v4l device, to a m4p (libx264, libfdk_aac).  I know the issue with no moov atom for streaming, but is there any way for me to see what it is getting in?
[19:04] <DelphiWorld> spaam: want me to help you to compile it ?
[19:07] <DelphiWorld> bencoh: thank dude, work in 2.0
[19:08] <DelphiWorld> bencoh: do you have librtmp enabled in your build?
[19:09] <Compn> acovrig : nope. mp4 cannot be played incomplete, unless you build some kind of custom player with custom moov headers
[19:09] <Compn> or reindex the file with qt_faststart
[19:09] <Compn> (after its done being madE)
[19:11] <acovrig> Compn: what format/codecs do you recommend that can be played partially through, and is the most compatible?
[19:15] <CountryfiedLinux> Is it  normal for ffmpeg to not be able to be installed in Debian Testing?
[19:16] <sacarasc> ffmpeg isn't in Debian any more.
[19:17] <CountryfiedLinux> sacarasc, not even the multimedia repository?
[19:17] <sacarasc> It got replaced by libav.
[19:18] <CountryfiedLinux> thanks
[19:18] <ubitux> Compn: stop recommending qt-faststart if the user is muxing the file, we have -movflags +faststart now
[19:18] <ubitux> qt-faststart is a hack
[19:19] <DelphiWorld> ubitux: :)
[19:19] <ubitux> qt-faststart is basically doing a memsearch for the chunk offset list
[19:19] <ubitux> which can easily break
[19:20] <DelphiWorld> ubu2.0 solved my rtmp issue
[19:21] <DelphiWorld> but now i'm enabling librtmp, to  see if the issue cam through latest git or issue is in librtmp
[19:32] <DelphiWorld> ok, my conclusion:
[19:32] <DelphiWorld> librtmp cant  play the stream...
[19:37] <Jellicent> Anyone using ALSA having the problem that the sound is super low (and barely hearable)? My system volume's on 100%, can't go past that.
[19:39] <viric> I don't have that problem
[19:39] <viric> but check *all* volume bars.
[19:40] <viric> "the system volume" may not map well to hardware mixers
[19:42] <Jellicent> You mean master? That's on 100%, too.
[19:42] <Jellicent> My sound is fine when I'm listening to it, I can regulate it on my headphones, that's why I have it on 100% in ALSA.
[19:43] <Jellicent> When I'd pull it all the way up on my headphones my ears would bleed.
[19:43] <Jellicent> And the sound would still be barely hearable when recorded.
[19:43] <Jellicent> Which is so weird.
[19:43] <viric> recorded?
[19:43] <Jellicent> Well, not recorded, but. Uh, I'm bad with words in this.
[19:44] <Jellicent> See, I'm trying to stream to twitch, maybe that helps. And when I watch the actual broadcast the sound is super low, 1/10 as loud as I heard it when streaming for example.
[19:44] <Jellicent> And I can't find out why.
[19:45] <Jellicent> Someone just suggested I boost my mic. But would that really help? I'm not recording through a physical microphone. I have never streamed on linux, so I have no idea if there's a mic entry for that.
[19:47] <viric> if you don't record, no idea what do you stream.
[19:48] <Jellicent> I planned on streaming StarCraft II on twitch.tv.
[19:48] <viric> ok, I might be the one who knows least about that.
[19:59] <DelphiWorld> bencoh: here?
[20:05] <Jellicent> viric: Okay. But well, if I was just going to stream my music, as a stupid example, it still wouldn't be any better.
[20:34] <Compn> ubitux : then put that +faststart in a message whenever anyone encodes to mp4
[20:34] <Compn> :)
[00:00] --- Fri Dec 20 2013

More information about the Ffmpeg-devel-irc mailing list