[Ffmpeg-devel-irc] ffmpeg.log.20131222

burek burek021 at gmail.com
Mon Dec 23 02:05:01 CET 2013

[02:12] <llogan> giby: "error oprning alias". is that a mov renamed as avi?
[02:13] <giby> non, taken with my camera
[02:13] <llogan> try "-use_absolute_path 1" as an input option
[02:15] <giby> still the same bug :(
[02:20] <llogan> giby: do you have a sample file?
[02:21] <llogan> actually i should go...i recommend sending a message to the ffmpeg-user mailing list.
[02:23] <giby> I have a file
[02:23] <giby> I can open it in iphoto or iMovie
[02:38] <SLAYBoz> how come when i use aac as audio encoder,  on final video. i cannot see what audio-bitrate i used
[04:22] <hendry> hi i havea a 1920x1080 12GB wedding video I want to make available via mp4 for Iphone users via HTML video http://s.natalian.org/2013-12-22/krfeature.txt
[04:22] <hendry> I can't find a decent preset, can anyone help or recommend something?
[05:56] <SLAYBoz> how come when i use aac as audio encoder,  on final video. i cannot see what audio-bitrate i used
[05:58] <relaxed> if you specify a bitrate why do you need to see it?
[06:00] <SLAYBoz> relaxed i might want to see it later
[06:01] <relaxed> mediainfo will give you the size- divide that by time
[06:09] <SLAYBoz> it doesn't
[06:09] <SLAYBoz> with mp3-audio it does
[06:10] <SLAYBoz> with mp3-audio or ac3-audio it does
[07:54] <Zeranoe> Can FFmpeg handle an flv file that has a different frame size mid way through?
[09:04] <DeadSix27> can anyone explain what this means: Application provided invalid, non monotonically increasing dts to muxer in stream 0: 8030805 >= 8029920
[12:27] <Looney> trying to build ffmpeg with ssl for android using ndk
[12:28] <Looney> following https://github.com/yixia/FFmpeg-Android/blob/master/FFmpeg-Android.sh
[12:28] <Looney> but build failing with following message
[12:28] <Looney> arm-linux-androideabi-gcc is unable to create an executable file.
[12:28] <Looney> C compiler test failed
[13:35] <vivienschilis> Hi, I was wondering if ffmpeg is deinterlacing automaticaly videos
[13:35] <vivienschilis> I made a simple ffmpeg conversion without using yadif
[13:35] <vivienschilis> and the result was progressive
[13:36] <vivienschilis> (using the idet filter on the output file i could see that all frame were progressive)
[13:37] <vivienschilis> michaelni: could you highlight me on this?
[13:37] <JEEB> no, ffmpeg doesn't deint but depending on the encoder you might be encoding interlaced pictures as progressive :P
[13:37] <JEEB> unless ffmpeg auto-inserts yadif in the middle, which I kind of don't believe to be what's happening
[13:39] <vivienschilis> JEEB: thanks! it would lead to some async if one field is considered as one frame no?
[13:41] <vivienschilis> is it safe to always apply yadif ?
[13:44] <JEEB> vivienschilis, basically two fields interleaved and encoded as a frame would be my guess :P
[13:45] <JEEB> you can check the encoded file and see if it has combing
[13:45] <JEEB> (in places where the original interlaced content had them when interleaved)
[13:45] <JEEB> and no, it's not always safe afaik, unless yadif nowadays only works with frames marked interlaced
[13:53] <relaxed> that's an option
[13:54] <relaxed> deint=1  "only deinterlace frames marked as interlaced"
[13:57] <JEEB> ok then
[14:08] <jnvsor> I don't really use IRC, have I got it working properly?
[14:12] <jnvsor> When recording from a stream with lower framerate than the output stream ffmpeg skips frames and uses timestamps. Blender doesn't read timestamps. Is there any way to force frame duplication?
[14:17] <Mavrik> jnvsor, use fps video filter
[14:22] <jnvsor> Well it's doing something but while ffmpeg says frame=2999 when I stopped it, blender is looking at 1503 frames
[14:31] <jnvsor> Blender probably just doesn't load files over 60fps properly. Thanks for the help!
[14:32] <vivienschilis> JEEB: relaxed thanks for your help
[14:53] <stockholm> hi
[14:58] <stockholm> http://pastebin.com/wgNhtKHG
[14:58] <stockholm> i used to have quality issues when reencoding the video
[14:58] <stockholm> i want to play it on my dvd player
[14:58] <stockholm> which does not speak mp4
[14:59] <stockholm> this current encoding however, is not accepted by my dvd player
[14:59] <stockholm> furthermore, the sound seems to have been lost
[14:59] <jnvsor> Well first off that's the libav ffmpeg (long story) not the ffmpeg ffmpeg
[15:00] <stockholm> how do i fix both the sound and get my dvd player to accept the encoding of the video?
[15:00] <stockholm> yes, i use debian
[15:00] <jnvsor> As for audio, you have no audio codec in the command, add `-acodec copy` to the end
[15:00] <stockholm> this is the one that comes with debian.
[15:00] <stockholm> thanks
[15:01] <stockholm> jnvsor: so why does my dvd player not acept the encoding?
[15:01] <relaxed> you command is using the mpeg1 container
[15:01] <relaxed> your*
[15:01] <jnvsor> Not a clue - which formats does your dvd accept?
[15:01] <relaxed> also, half the option you use don't pertain to mpeg2video
[15:01] <stockholm> it does eat avi files i download from the net
[15:02] <stockholm> i am not sure how to find out what my dvd accepts
[15:02] <relaxed> ffmpeg -i /tmp/input.mp4 -vcodec mpeg4 -vtag XVID -qscale 3 -acodec libmp3lame -ab 160k output.avi
[15:02] <jnvsor> A manual would probably have that (or google)
[15:03] <stockholm> i went for a conservative encoding (mpeg-2, i hope, i dont really know a whole lot about video encoding)
[15:04] <jnvsor> maybe libx264 would work too
[15:04] <stockholm> jnvsor: i have been googling for some days, and encoded perhaps 20 test snipplets to get around the coars block videos i got before
[15:04] <relaxed> stockholm: try the command I pasted ^^
[15:04] <stockholm> will do
[15:04] <jnvsor> No I meant google your dvd player to see which formats it accepts :P
[15:05] <stockholm> jnvsor: ah, right :-)
[15:05] <stockholm> jnvsor: i really should
[15:15] <stockholm> i keep running up and down the stairs here, since my dvd player is downstairs... an other roundtrip!
[15:15] <stockholm> relaxed: it said: resolution not supported.
[15:16] <stockholm> relaxed: can i just add a -s 720x... ?
[15:17] <stockholm> trying that...
[15:20] <tsjiller> 15:18:01 < rage\> fiska torsk
[15:20] <tsjiller> 15:18:27 < rage\> NiteLite: hvordan får jeg hentet ut den infoen fra min crapple telefon?
[15:20] <tsjiller> sorry
[15:20] <tsjiller> uhm
[15:24] <relaxed> ffmpeg -i /tmp/input.mp4 -vcodec mpeg4 -vf scale=720:-1 -vtag XVID -qscale 3 -acodec libmp3lame -ab 160k output.avi
[15:24] <stockholm> with -s 640x480 it produced a playable video!!!
[15:25] <stockholm> but yours is actually better, because it preserves the aspect ratio
[15:26] <jnvsor> you can use something like `-filter:v 'scale=w=-1:h=480'` to scale it down if that's what you want
[15:26] <stockholm> so when i re-encode a real big video (1.3 gig in mp4) down to that above, it becomes time consuming... what codec is the fastest to use?
[15:26] <relaxed> is ffmpeg is too old for that command, and I beat you to it.
[15:27] <stockholm> lol
[15:27] <jnvsor> ah nuts, didn't read xD
[15:27] <jnvsor> well he's not using ffmpeg
[15:28] <jnvsor> he's using the Libav version
[15:29] <relaxed> semantics
[15:29] <jnvsor> I doubt they've updated the "Deprecated" thing since the fork however many years ago
[15:30] <JEEB> yes, the cli interface in libav's ffmpeg binary is kind of withered, since the rewritten parts didn't get there. ffmpeg's ffmpeg has those changes merged in :)
[15:30] <JEEB> so if using libav, avconv is preferred, if using ffmpeg ffmpeg is preferred
[15:31] <stockholm> right
[15:33] <JEEB> anyways, what relaxed has been saying will work on both :)
[15:33] <JEEB> just that the newer binary in both projects will then accept the new settings etc.
[15:34] <stockholm> http://pastebin.com/Smy6HTug
[15:34] <stockholm> it didnt work, here is the error
[15:35] <JEEB> [mpeg4 @ 0x11d0120] Invalid pixel aspect ratio 901/900, limit is 255/255
[15:35] <stockholm> yeah
[15:36] <JEEB> try with avconv and see if it supports a setting called -setdar (if I recall correctly)
[15:36] <JEEB> ah, it's a video filter
[15:37] <JEEB> so after the scale you could add setdar or setsar
[15:37] <JEEB> probably setsar is simpler since you want 1:1 SAR?
[15:38] <stockholm> yes, preferably
[15:39] <JEEB> setsar=1/1
[15:39] <JEEB> not sure how you added it after the scale
[15:40] <jnvsor> if width/height isn't even the encoder will squeal, I use -filter:v `scale=w=trunc(in_w/2)*2:h=trunc(in_h/2)*2` to round it off
[15:41] <stockholm> that looks advanced...
[15:46] <stockholm> jnvsor: like this? http://pastebin.com/XXSkPSDW
[15:46] <stockholm> breaks...
[15:48] <jnvsor> you should put the filter after the vcodec
[15:50] <stockholm> jnvsor: directly? or after the mpeg4?
[15:51] <stockholm> neither works.
[16:03] <stockholm> jnvsor: can you help me with the syntax? this fails: -vcodec mpeg4 -filter:v `scale=w=trunc(in_w/2)*2:h=trunc(in_h/2)*2`
[16:03] <stockholm> jnvsor: with "Unable to find a suitable output format for 'XVID'
[16:03] <stockholm> full paste?
[16:04] <jnvsor> did you give it the extension xvid?
[16:09] <stockholm> the full command line is
[16:09] <stockholm> ....paste
[16:10] <stockholm> http://pastebin.com/tSSLvkC4
[16:10] <stockholm> jnvsor: ^
[16:13] <jnvsor> Remove the xvid vtag part?
[16:13] <jnvsor> I'm just guessing and semi-afk atm :/
[16:14] <stockholm> isnt that important?
[16:14] <stockholm> its cascading...
[16:14] <stockholm> now it complains about the next option/parameter pair:
[16:14] <stockholm> Unable to find a suitable output format for '3'
[16:15] <stockholm> which is from the qscale option
[16:16] <JEEB> uhh
[16:16] <JEEB> you have no output file name >_>
[16:16] <stockholm> something is fundamentally broken with the format...
[16:16] <JEEB> for xvid stuff I will guess you want out.avi at the end >_>
[16:16] <stockholm> no, hte output file name is coming last
[16:16] <JEEB> oh
[16:17] <stockholm> look at the paste :-)
[16:17] <JEEB> yes, I didn't notice it getting cut
[16:17] <JEEB> the first line that is
[16:17] <JEEB> (it spans multiple lines here when viewing it)
[16:17] <stockholm> i am going through all the options and remove one by one and it all comes back with errors
[16:17] <stockholm> yes, here too
[16:21] <JEEB> vcodec is correct, although now that you're using avconv you could switch to the newer way of setting it - -c:v , not sure about the filtering part's correctness, but I will guess it's correct? -qscale should work, but you could use -q:v , -acodec could be switched to -c:a and -ab to -b:a . -threads auto shouldn't be needed, -t and -ss should be correct?
[16:21] <stockholm> lets try that
[16:24] <jnvsor> stockholm: try this? avconv -i input.mp4 -vcodec mpeg4 -acodec libmp3lame -t 4106 -ss 112 /tmp/output.avi
[16:24] <jnvsor> if that doesn't work something wierd is going on
[16:24] <stockholm> http://pastebin.com/EywgwRPT
[16:25] <JEEB> yeah, and he can use the -c:v -c:a instead of -vcodec and -acodec
[16:25] <stockholm> ok, trying your simplified version
[16:25] <JEEB> uhh
[16:25] <JEEB> -c:v `scale=w=trunc(in_w/2)*2:h=trunc(in_h/2)*2` <-wut
[16:25] <JEEB> trying to set video encoder to something funky :P
[16:25] <jnvsor> that's a scale filter not a codec ^^
[16:26] <JEEB> now try either with -vf or without the filtering at all
[16:26] <jnvsor> try the simple version first, we can scale it once we know it's working :P
[16:26] <stockholm> avconv -i /tmp/input.mp4 -c:v mpeg4 -c:a libmp3lame -t 4106 -ss 112 /tmp/output.avi       <=works!!!
[16:27] <jnvsor> gotcha
[16:27] <jnvsor> do you want to scale it down?
[16:27] <stockholm> i guess i need to. the resolution is humongours in the original :-)
[16:28] <jnvsor> from 720p to 480p?
[16:28] <stockholm> input is 1500xsomething
[16:29] <jnvsor> avconv -i /tmp/input.mp4 -c:v mpeg4 -filter:v "scale=w=-1:h=480,scale=w=trunc(in_w/2)*2:h=trunc(in_h/2)*2" -c:a libmp3lame -t 4106 -ss 112 /tmp/output.avi
[16:29] <stockholm> my dvd player does accept 720xsomething as input
[16:29] <jnvsor> that will scale to 480 high then round it off so there are no uneven dimensions
[16:29] <stockholm> nice
[16:29] <stockholm> thanks
[16:30] <stockholm> http://pastebin.com/xRPaBQLw
[16:30] <stockholm> nix!
[16:31] <stockholm> ah, because in_h?
[16:31] <stockholm> no...
[16:31] <jnvsor> the error is in the initial downscale
[16:31] <jnvsor> very wierd, maybe you have a really old version, (Oh yeah you said you were on debian right? :P)
[16:32] <jnvsor> avconv -i /tmp/input.mp4 -c:v mpeg4 -filter:v  "scale=-1:480,scale=trunc(in_w/2)*2:trunc(in_h/2)*2" -c:a libmp3lame -t 4106 -ss 112  /tmp/output.avi
[16:32] <jnvsor> try that
[16:32] <jnvsor> should work on older versions
[16:32] <stockholm> i really like debian...
[16:32] <jnvsor> So do I, but I use sid :P
[16:33] <stockholm> i used to when i was an active developer.
[16:33] <stockholm> that works!
[16:33] <stockholm> but it uses only 2 (of 4) cores
[16:33] <stockholm> now i will try threads
[16:33] <jnvsor> 2? Last I checked the default was 1 :O
[16:34] <stockholm> no
[16:34] <stockholm> top says 190% cpu
[16:34] <stockholm> but i saw it use 390% already (aka 4)
[16:35] <stockholm> but not now
[16:35] <jnvsor> Oh right, default is "auto"
[16:35] <stockholm> even if i say -threads 4
[16:35] <JEEB> there are official PPAs for libav for certain versions
[16:35] <stockholm> PPAs?
[16:35] <stockholm> can i eat those?
[16:35] <JEEB> repositories
[16:35] <stockholm> ah
[16:35] <JEEB> https://launchpad.net/~motumedia
[16:35] <jnvsor> Or just add an override for libav-utils to use the unstable repo :)
[16:35] <JEEB> oh, it's debian?
[16:35] <stockholm> yes
[16:35] <JEEB> then yeah
[16:36] <JEEB> testing/unstable
[16:36] <jnvsor> Or just compile the real ffmpeg by hand
[16:36] <JEEB> for libav and friends
[16:36] <ubitux> if you're going to upgrade, why not upgrade to ffmpeg?
[16:36] <JEEB> and yes, that's of course an alternative :)
[16:36] <JEEB> there are static builds available too
[16:36] <stockholm> yes, is there a repository for debian for that?
[16:36] <ubitux> deb-multimedia probably
[16:36] <JEEB> isn't deb-multimedia kind of old?
[16:36] <stockholm> nix, that does not exist anymore
[16:37] <JEEB> because it would have to keep API compat.
[16:37] <stockholm> it was sold and does different stuff nowadays
[16:37] <JEEB> no repo, but there are static binaries of current git HEAD available
[16:37] <ubitux> http://www.deb-multimedia.org/dists/unstable/main/binary-amd64/package/ffmpeg
[16:37] <ubitux> 2.1.1
[16:37] <ubitux> sounds enough up-to-date
[16:37] <JEEB> hmm
[16:37] <stockholm> oh yes
[16:38] <JEEB> or I guess they could update after debian got its stuff updated to libav9
[16:38] <JEEB> because older APIs became unneeded
[16:38] <JEEB> yeah, unstable/sid
[16:39] <jnvsor> http://stackoverflow.com/questions/512906/debian-how-can-i-pull-a-single-package-with-dependencies-from-another-repositor
[16:39] <jnvsor> You can add the unstable or testing repo then pin it to low priority and install the newer libav from usntable manually
[17:44] <jnvsor> compiling ffmpeg doesn't give libx264 presets, what would be the equivillant of 'lossless_ultrafast'? Is libvpx better? (All the new presets are for libvpx)
[17:46] <viric> jnvsor: libx264 has its own system of presets
[17:48] <jnvsor> How do you mean? If I move the ffpreset file I get: "Preset lossless_ultrafast specified for stream 0:0, but could not be opened."
[17:55] <BeWilled> will this count as 200 seconds? "00:00:300:00 ?
[17:56] <BeWilled> :*200
[17:57] <ubitux> "200" should be fine
[17:57] <ubitux> last sep needs to be a '.' iirc
[18:25] <BeWilled> ubitux:hey I'm getting Invalid duration specification for ss: 00:00:200.00
[18:25] <ubitux> remove "00:00:"
[18:25] <ubitux> and ".00"
[18:29] <BeWilled> It worked, now it's time to paste them all together! thanks
[18:33] <nse_> hi peopeeeee!
[18:34] <nse_> i was looking how to "rip" audio from a video file I have!
[18:34] <nse_> it's WAY difficult! someone could help me????
[18:35] <jnvsor> ffmpeg -i video.avi -c:a libmp3lame out.mp3
[18:35] <LithosLaptop> that transacodes
[18:36] <nse_> jnvsor: but i need to select the audio channel
[18:36] <nse_> jnvsor: my file has 2 ac3 audio channels
[18:36] <jnvsor> in `ffmpeg -i video.avi` it should show you track IDs
[18:36] <jnvsor> once you know the track ID run:
[18:37] <jnvsor> ffmpeg -i video.avi -map {id} -c:a libmp3lame out.mp3
[18:37] <LithosLaptop> ffmpeg -i video.avi -map {id} -c:a copy out.ac3
[18:37] <jnvsor> Right, didn't notice ac3 :)
[18:40] <nse_> jeez, you're just too good at it
[18:40] <nse_> i managed to get it to work. THANKS!!!
[18:40] <nse_> my command line: ffmpeg -i \[a4e\]Sentou_Yousei_Yukikaze_05\[h.264-ac3\].mkv -map 0:2 -c:a libmp3lame out.ac3
[18:41] <jnvsor> I'm surprised that worked, you put an mp3 stream into an ac3 container :O
[18:41] <nse_> that's what i'm reading in man ffmpeg right now
[18:42] <nse_> i think the "libmp3lame" is not well suited
[18:42] <jnvsor> Yes, just copy the stream like lithos said
[18:42] <jnvsor> replace "libmp3lame" with "copy" and it will work fine
[18:43] <nse_> jnvsor: i wanted to "dump" the whole audio in a raw format maybe
[18:43] <jnvsor> Yes, copy doesn't transcode, it simply copies the stream verbatim
[18:43] <jnvsor> since it's ac3 audio an ac3 container seems good
[18:43] <nse_> jnvsor: so i could encode it to mp3 using "lame"... is that a good way?
[18:43] <jnvsor> You could, but litho's method copies the stream verbatim - no transcoding so no lost data
[18:44] <jnvsor> it's as raw a copy of the original audio as you can get
[18:44] <nse_> jnvsor: that's what i'm looking for =D
[18:46] <nse_> aaah i get it. the format is still ac3. i just "copied" the original ac3 data from my video input strem.
[18:46] <nse_> thanks for the tips.
[19:20] <jnvsor>  Hmm, does anyone else get no response from SIGINT when using a `-f pulse` input?
[20:50] <jnvsor> How long does a trac verification email usually take to send?
[20:53] <funyun> hi. can anyone help me with this error? http://pastebin.com/7F1Gimp2
[20:54] <jnvsor> get rid of the parentheses
[20:54] <jnvsor> Oh right, escape the parentheses :P
[20:54] <jnvsor> http://pastebin.com/hkEyr5PS
[21:01] <funyun> jnvsor: that just puts me into something with this ">"
[21:02] <funyun> i don't really know how to explain it
[21:02] <funyun> but i have to do ctrl+c to get out of it
[21:04] <brontosaurusrex> try -vf "pad=1280:720:(ow-iw)/2:(oh-ih)/2"
[21:05] <brontosaurusrex> funyun, ^
[21:06] <funyun> brontosaurusrex: same result. i get >
[21:09] <jnvsor> That's wierd, just pasted it into my terminal and I'm seeing it too
[21:10] <jnvsor> Ah yes, moving the quote to the start of pad fixes it here
[21:10] <jnvsor> http://pastebin.com/bzF1ZQdc
[21:10] <funyun> jnvsor: brontosaurusrex's suggestion works for you?
[21:12] <funyun> ah okay now it's working
[21:12] <funyun> jnvsor, brontosaurusrex: thanks for your help. :)
[21:19] <Sling> trying to convert some folders containing .VOB files into single mediafiles, preferably with the same size/quality as the 'original'
[21:19] <Sling> ive used some different avconv options but I'm not really getting the proper settings I think, is there a standard way of doing this?
[21:19] <Sling> ideally I would also want to automatically concatenate the .vob files
[21:22] <jnvsor> Well I'm not sure on the specifics of the vob container/codecs but there's an article on the wiki which should help
[21:22] <jnvsor> http://bit.ly/J7uV9B
[21:23] <Sling> thanks, Ill search on from there
[21:23] <Sling> can't imagine I'm the first to try this :)
[21:23] <jnvsor> The article looks like it has a copy-paste solution :)
[21:24] <Sling> yea the ffmpeg / concat=XXX one
[21:48] <Sling> I'm using this now: ffmpeg -i concat:"VTS_01_1.VOB|VTS_01_2.VOB|VTS_01_3.VOB|VTS_01_4.VOB" -vcodec copy -acodec copy -map 0:0 -map 0:1 out.mkv
[21:48] <Sling> but getting: [matroska @ 0x1f7f580] Can't write packet with unknown timestamp
[21:49] <Sling> setting -fflags genpts had no effect
[21:49] <jnvsor> That doesn't look like what was in the guide - did you try using a file with them in a list?
[21:49] <Sling> it works without the copy stuff
[21:50] <Sling> but I suppose I could try the list version
[21:51] <Sling> that just goves me 'Unknown input format: 'concat''
[21:52] <jnvsor> what version of ffmpeg are you using?
[21:52] <Sling> 0.8.9-6:0.8.9-0ubuntu0.13.10.1
[21:53] <viric> 2.1.1 is the latest released
[21:55] <Sling> its telling me to use avconv though, which seemingly has the same options and same issues for me
[21:56] <jnvsor> Then you're not using ffmpeg, avconv has an old copy of ffmpeg for compatability
[21:57] <jnvsor> http://bit.ly/1kx0MPb
[22:00] <Sling> yeah thats not working, same issue with the timestamp
[22:02] <Sling> meh and with other settings it just mangles the whole thing
[22:02] <Sling> artifacts and interlacing all over the place
[22:02] <Sling> why is video so hard :)
[22:02] <Sling> spend a whole evening just trying to fix one movie
[22:04] <viric> Sling: -vf setpts=PTS-STARTPTS    ?
[22:04] <viric> I don't know if it's about pts
[22:04] <Sling> I doubt it is, it doesnt fix the timestamp error
[22:05] <Sling> the original is mpeg2video and ac3 audio
[22:05] <Sling> apparently it cant just copy that to a mkv container
[22:05] <viric> maybe you need the same for audio.   asetpts
[22:05] <Sling> hm nop
[22:07] <Sling> mp4 output seems to work
[22:07] <Sling> its complaining about pts not having a value but at least its producing something
[22:08] <viric> -vf setpts=PTS-STARTPTS -af asetpts=PTS-STARTPTS together?
[22:11] <Sling> ah this intermediate mp4 worked
[22:11] <Sling> no encoding done so video/audio is all well
[22:12] <Sling> step 1: avconv -i concat:"VTS_01_1.VOB|VTS_01_2.VOB|VTS_01_3.VOB|VTS_01_4.VOB" -c:v copy -c:a copy -map 0:0 -map 0:1 temp.mp4
[22:12] <Sling> step 2: avconv -i temp.mp4 -c copy output.mkv
[22:18] <saste> we only support ffmpeg here
[22:18] <Sling> yeah sorry, in this case I blame Ubuntu
[22:21] <saste> Sling, why the double step?
[22:21] <saste> mp4 -> mkv?
[22:21] <saste> probably you should try with the concat demuxer, it will automatically fix timestamps (no transcoding involved)
[22:34] <Sling> saste: I think this version of ffmpeg doesn't have that
[22:34] <Sling> and yes the double step is to avoid the timestamp errors I was getting
[22:34] <saste> Sling, i don't think it will fix anything
[22:34] <saste> indeed it will probably make things worse
[22:35] <Sling> well, the resulting file does what I want
[22:35] <Sling> which is have the same quality as the original and play in my player :)
[22:35] <saste> unless you're overusing muxer glitches
[23:30] <brontosaurusrex> Sling, you could use mkvtoolnix (I don't know if ac3 or dts will work fine with mp4)
[23:30] <brontosaurusrex> if mkv is good enough for you that is
[23:31] <JEEBsv> ac3 is officially spec'd in MP4 methinks
[23:32] <JEEBsv> DTS has an unofficial spec by the DTS corp
[23:32] <brontosaurusrex> ok then
[23:40] <klaxa> either i'm stupid now or the latest ffmpeg doesn't parse arguments correctly: https://gist.github.com/klaxa/8089277
[23:40] <klaxa> >Applying option vf (set video filters) with argument subtitles=filename=[WhyNot] SaintYoung Men The Movie [BD 720p AAC][12DEEE77].ass.
[23:40] <klaxa> >...
[23:40] <klaxa> >[Parsed_subtitles_0 @ 0x33e2440] Setting 'filename' to value ''
[23:43] <JEEBsv> klaxa: if you need hardsubbing I'd poke you towards mpv's encoding thingy. #mpv-player
[23:44] <JEEBsv> uses libavformat/libavcodec behind the scenes and supports segment linking as well
[23:44] <klaxa> alright, thanks
[23:44] <klaxa> oh does this mean i have to compile mpv on my headless machine? :S
[23:45] <JEEBsv> should be doable since you don't need any of the fancy video renderers and such
[23:45] <klaxa> hmm true
[23:45] <klaxa> i'll do that first, i guess i can use libx264 with it?
[23:45] <JEEBsv> naturally
[23:46] <klaxa> everything else would be stuipd
[00:00] --- Mon Dec 23 2013

More information about the Ffmpeg-devel-irc mailing list