[Ffmpeg-devel-irc] ffmpeg.log.20131224

burek burek021 at gmail.com
Wed Dec 25 02:05:01 CET 2013

[11:05] <viric> can ffmpeg create a picture from a audio wave?
[11:06] <viric> maybe I should use sox
[11:06] <viric> not a sprectrogram
[11:06] <ubitux> yes it can
[11:06] <ubitux> see showwaves and showspectrum multimedia filters
[11:06] <viric> I mean a picture like what audacity generaets
[11:07] <viric> aha, I'll see
[11:07] <viric> hm but it creates *video*. Not a picture.
[11:08] <ubitux> -frames:v 1
[11:08] <ubitux> and it will create one picture
[11:08] <ubitux> of course it might be tricky to have the whole spectrogram
[11:08] <viric> right.
[11:09] <viric> In fact I'd like one png per every 2 seconds of audio
[11:09] <viric> in waveform
[11:10] <viric> so that concatted pngs show the proper concatted waveform
[12:05] <jnvsor> Hi, swscaler is giving me deprecated pixel format errors, how do I remove them? http://pastebin.com/uAsBiCRK
[15:46] <zafu> hi, can I losslessly cut a mpeg4 video with ffmpeg? (along group of pictures boundaries)
[15:54] <DeadSix27> JEEB: took me 1,5 days.. but the build succeeded.
[15:57] <DeadSix27> (the build didnt take 1,5days though
[16:01] <saste> zafu, segment
[16:02] <zafu> saste: where can I find it?
[16:03] <saste> zafu, segment muxer, ffmpeg-formats(1)
[16:04] <zafu> thanks
[16:05] <zafu> is it better than "-acodec copy -vcodec copy" ?
[16:44] <DeadSix27> how exactly can i output raw video?
[16:44] <DeadSix27> i mean, probably via -c:v rawvideo
[16:44] <DeadSix27> but do i have to use a specific container?
[16:44] <DeadSix27> (or should i just use .yuv as extension?)
[18:02] <DeadSix27> now i see why you guys say libfdk produces way better AAC
[18:27] <odie5533> http://ffmpeg.org/ffmpeg-filters.html#concat says the default value for a (number of audio streams) is 0, but when I use -filter_complex "concat" I do get concatenated audio output. Am I missing something here?
[18:29] <Hejkki> hello, how do i concat 2 videofiles? I tried this already: avconv -i concat:MVI_2774.MOV\|MVI_2775.MOV -c copy kakka.MOV
[18:29] <Hejkki> but the result gives me the first video only
[18:29] <odie5533> Hejkki: https://trac.ffmpeg.org/wiki/How%20to%20concatenate%20%28join,%20merge%29%20media%20files
[18:31] <Hejkki> Page How to concatenate (join, merge) med not found
[18:31] <odie5533> Hejkki: You need a better IRC client. Try Googling "How to concatenate (join, merge) media files" and click the first link
[18:32] <Hejkki> better than irssi?
[18:32] <odie5533> Apparently.
[18:33] <odie5533> It chopped off the last characters of the url
[18:34] <jnvsor> My irssi works fine - could be the terminal emulator?
[18:38] <Hejkki> odie5533: i tried that also, same result
[18:38] <odie5533> Hejkki: what did you try?
[18:39] <Hejkki> ffmpeg -i "concat:file1.mov|file2.mov" -c copy output.mov
[18:40] <odie5533> That only works for "the concat protocol works at the file level. Certain files (mpg and mpeg transport streams, possibly others) can be concatenated. [...] In general, the demuxer is the better option."
[18:40] <odie5533> So you should probably try the demuxer instead.
[18:41] <Hejkki> ok
[18:42] <Hejkki> but isn't demuxing same as separating audio and video?
[18:43] <odie5533> It is. I think it separates the streams, concatenates them, then outputs them
[18:44] <bencoh> (remux them before outputting)
[18:44] <odie5533> Whereas the concat protocol (command you were trying to use) just concatenates the files at a file-level. I don't think mov supports that kind of operation
[18:46] <Hejkki> ok
[18:47] <viric> ls
[18:47] <viric> oops
[18:47] <odie5533> No files found.
[18:48] <Hejkki> ok, somehow i managed to get the video concatinated to one .ts file
[18:48] <Hejkki> now the same for audio
[18:48] <Hejkki> the -ts has only video, no audio
[18:48] <Hejkki> .ts even
[18:48] <odie5533> Hejkki: Are you following the first part of that page where it says "Concat demuxer" "Instructions"
[18:49] <odie5533> Because the only mention of ts files on that page is for using them as an intermediate with the Concat Protocol, not the Concat Demuxer.
[18:51] <Hejkki> i got the command from somewhere else, and lost the command and page since my battery went off :(
[18:51] <Hejkki> laptop
[18:51] <Hejkki> but i do have the .ts file anyhow
[18:54] <odie5533> Hejkki: https://trac.ffmpeg.org/wiki/How%20to%20concatenate%20%28join,%20merge%29%20media%20files
[18:54] <odie5533> there's the page again
[18:54] <odie5533> I'm not sure having a ts file is really going to help you.... but maybe. Who knows!
[19:01] <Hejkki> odie5533: it helps because i got the video concatinated. now i also have concatinated audio, but separate files... and the laptop is now remuxing them
[19:02] <Hejkki> ok, works, thanks !!
[19:16] <DelphiWorld> Hi People
[19:16] <DelphiWorld> ffmpeg -re -i rtmp://radio.gmo.ps/live/livestream -vn -acodec libfdk_aac -ar 44100 -ac 48k -f flv rtmp://
[19:16] <DelphiWorld> is suposed to supress the video stream, and push audio only stream to rtmp server
[19:16] <DelphiWorld> but is not supressing the video
[19:17] <DelphiWorld> Any CLUE?
[19:20] <DelphiWorld> can someone tel me how to supress video?
[19:21] <DelphiWorld> ffmpeg -re -i rtmp://radio.gmo.ps/live/livestream -acodec libfdk_aac -ar 44100 -ab 48k -ac 2 -vn -f mp3 rtmp://
[19:35] <LithosLaptop> maybe try the map option?
[19:35] <LithosLaptop> https://trac.ffmpeg.org/wiki/How%20to%20use%20-map%20option
[19:38] <LithosLaptop> btw for 48Kbit/s I would add -profile:a aac_he_v2
[19:51] <jnvsor> Anyone know how to get rid of the swscaler warning here: http://pastebin.com/uAsBiCRK ?
[19:55] <DelphiWorld> LithosLaptop: explain for aac?
[20:16] <DelphiWorld> hi saste the saster:)
[20:31] <jnvsor> Do you think #ffmpeg-devel would know more about the swscaler warning?
[20:41] <jnvsor> Can someone explain the src/dst_format/range options here in more detail? : http://www.ffmpeg.org/ffmpeg-scaler.html
[20:47] <JEEBsv_> picture format for input/output and the value range (TV or PC) for input/output. Generally with YCbCr TV range isusual, and with RGB PC range is usual
[20:47] <JEEBsv_> picture format is probably one of the PIX_FMT values defined in swscale's headers
[20:48] <jnvsor> It says src_format should be an integer, I presume the enum in libavutil/pixfmt.h
[20:48] <jnvsor> But when I add random integers nothing changes so I can't really tell if I have it working
[20:48] <JEEBsv_> never used that interface so I have no idea :P
[20:49] <jnvsor> Well it's giving me a warning when I try to scale something. This warning is all over the internet with no instructions on how to remove it. I hate warnings xD
[20:51] <JEEBsv_> never seen that myself personally... I wonder if it's using the J PIX_FMT inside?
[20:51] <JEEBsv_> no idea \o/
[20:52] <jnvsor> :(
[20:52] <relaxed> the scaler filter has flags= and `man ffmpeg-scaler` mentions dst_format
[20:53] <jnvsor> Yeah, that html page is just the man page
[20:53] <relaxed> "Set destination pixel format (must be expressed as an integer)."  <- wtf?
[20:53] <jnvsor> Yep. Not helpful :)
[20:53] <jnvsor> Wierd thing is if I set range
[20:53] <jnvsor> for instance to "3": Value 3.000000 for parameter 'src_range' out of range [0 - 1]
[20:53] <jnvsor> I thought the point was to set the range :O
[20:54] <relaxed> they're really trying to kitchen-sink us with all these options.
[20:55] <jnvsor> kitchen sink is good, but methinks the plumbing is broken
[20:55] <relaxed> libav has nice plumbing, but not so many sinks
[20:55] <relaxed> pick your posion
[20:56] <relaxed> er, poison
[20:57] <jnvsor> avconv is broken for my usage scenario, still I hate seeing error messages even if the command needs to be verbose
[20:57] <relaxed> I'm curious about what's broken
[20:57] <jnvsor> x11grab device
[20:58] <jnvsor> `-framerate` option does nothing
[20:58] <jnvsor> So avconv is useless for screencapture since video desyncs if there's a dropped frame
[20:58] <relaxed> so it just does 25 fps?
[20:58] <jnvsor> yep, no matter what I set it to
[20:58] <relaxed> tried -r 25?
[20:59] <jnvsor> Yes but that makes it worse - that says "The input will come in at 25fps" so if there's a freeze for instance it will just plop the next frame down without writing the intermediates
[21:00] <jnvsor> ffmpeg works fine, I just want to get rid of all the warnings and this one is taunting me :(
[21:01] <nycat> Is there any way outside of a while loop to have ffmpeg keep rebroadcasting an asf stream when it changes media?
[21:26] <PowerCC> question, to burn-in subtitles -vf subtitles=path what would i have to do if I want to burn-in hebrew .srt? is it more of an X11 font issue?
[21:26] <PowerCC> xQuartz (OS X) project suppose to support hebrew/latin
[21:27] <jnvsor> I'd start by making sure the srt file is utf8
[21:28] <PowerCC> iconv
[21:28] <PowerCC> done
[21:28] <jnvsor> And then I wouldn't know what to do and I'd come here and ask for help :)
[21:29] <PowerCC> ha
[21:29] <PowerCC> thx
[21:30] <PowerCC> it's most likely an x11 issue, xQuartz with so little apple backing anymore.
[21:32] <PowerCC> jnvsor: what do you use ffmpeg mostly for?
[21:33] <jnvsor> screencasting, converting files, and of course I use it indirectly through vlc etc etc
[21:33] <PowerCC> lib.x264
[21:33] <PowerCC> it's too bad OpenCL can't be used for more than lookahead
[21:33] <PowerCC> my cpu gets so taxed.
[21:33] <jnvsor> `-threads 4` :)
[21:34] <PowerCC> always -threads 4 although last night i forgot to indicate and it ran as 6 threads woke up to a nice and warm room ;)
[21:36] <PowerCC> pm'ed instead of pastebin
[21:37] <relaxed> PowerCC: https://trac.ffmpeg.org/wiki/How%20to%20burn%20subtitles%20into%20the%20video
[21:37] <jnvsor> I think it's an i##n issue relaxed
[21:37] <PowerCC> thx relaxed it's where i started
[21:37] <relaxed> oh, ok
[21:38] <PowerCC> do you recall what -data_partitioning 1 does
[21:38] <jnvsor> Perhaps you need to compile an ffmpeg with extra options for multilingual or something
[21:38] <PowerCC> used to always use it.
[21:38] <PowerCC> i don't believe it's an ffmpeg issue
[21:38] <PowerCC> i strongly believe it's within font_cnfig
[21:39] <jnvsor> Got any other programs using font_config that don't show up right? (Try the video + sub in vlc, it's based on ffmpeg)
[21:39] <PowerCC> ok, good idea.
[21:39] <PowerCC> sec
[21:40] <PowerCC> i did have to do: export FONTCONFIG_PATH=/opt/X11/lib/X11/fontconfig
[21:40] <PowerCC> yesterday to get it to even take.
[21:41] <PowerCC> shall i add /library/font? so it will be force to substitute?
[21:43] <PowerCC> shows up fine in VLC ;(
[21:45] <jnvsor> try `ldd /usr/bin/vlc`
[21:45] <jnvsor> probably won't have fontconfig in it
[21:45] <PowerCC> just edited font.config
[21:45] <PowerCC> added another library
[21:46] <PowerCC> k
[21:51] <PowerCC> [AVFilterGraph @ 0x101d044a0] Error initializing filter 'subtitles' with args 'hebrew_test.srt'
[21:51] <PowerCC> [Parsed_subtitles_0 @ 0x101d04120] Error decoding: Invalid data found when processing input (ignored)
[21:51] <PowerCC> -bash: syntax error near unexpected token `('
[21:52] <jnvsor> sounds like a quote problem somewhere
[21:52] <jnvsor> msg me the line again
[21:52] <PowerCC> maybe i can try -sub_charenc option
[21:57] <PowerCC> pm
[21:59] <jnvsor> Looks like irssi doesn't support UTF8 unless what you pmed at the end was supposed to be random chars :P
[21:59] <relaxed> of course it does
[22:00] <PowerCC> paste that by mistake
[22:00] <PowerCC> part of the .srt
[22:00] <PowerCC> IRC won't support that
[22:02] <jnvsor> Yeah idk - I steer clear of anything more complicated than ascii - it's probably a library somewhere. Maybe fontconfig. Try recompiling ffmpeg without fontconfig and see if it works or not.
[22:02] <jnvsor> If it doesn't, try compiling fontconfig manually to see what happens
[22:03] <PowerCC> thx
[22:07] <PowerCC> bingo
[22:07] <PowerCC> correct source encoding for hebrew is Windows-1255
[22:11] <PowerCC> not sure why wouldn't work with ISO-8859-8
[22:11] <PowerCC> which is hebrew
[22:12] <PowerCC> but Windows-1255 did the trick with iconv
[22:19] <PowerCC> thx jnvsor for all your efforts.
[22:19] <PowerCC> happy xmas!
[23:21] <sim590> anything wrong with that command http://ix.io/9ve ?
[23:22] <sim590> considering that `arecord -l ` outputs that: http://ix.io/9vf
[23:22] <sim590> There's something wrong with the audio part.
[23:23] <sim590> I get this http://ix.io/9vg
[23:31] <sim590> I changed the container format and it works.. but now I have a buffer underflow error..
[23:32] <jnvsor> Well first, change `-r` into `-framerate` so x11grab handles dropped frames for you
[23:33] <sim590> yeah.. I just dropped -r and -s and it works but video quality is bad.
[23:35] <sim590> ok.. now that's better.. but now I want a better resolution
[23:35] <sim590> jnvsor: here's what I got now : `ffmpeg -f x11grab -y -framerate $FRAMERATE -i :0.0 -f alsa -ac 1 -i hw:1 -sample_fmt s16 ./out.mpg`
[23:35] <sim590> and what container should I use ? Do you have an idea ?
[23:35] <sim590> and why ?
[23:36] <jnvsor> Codec is more important than container
[23:36] <jnvsor> `-c:v libx264 -preset "ultrafast" -qp 0` is the fastest lossless you'll ever see
[23:36] <sim590> is that good -vcodec ffvhuff ?
[23:36] <jnvsor> IIRC ffvhuff is just raw footage - HUGE filesize
[23:37] <sim590> okok
[23:37] <jnvsor> as for container, it's secondary to codec - libx264 should work with mkv, avi, wmv, mp4
[23:39] <sim590> okk, now I get that libx264 is unknown :\
[23:39] <jnvsor> hmm, what's your configure line? (ffmpeg -v 9 -loglevel 99)
[23:40] <sim590> ffmpeg -f x11grab -c:v libx264 -preset "ultrafast" -qp 0 -y -framerate $FRAMERATE -i :0.0 -f alsa -ac 1 -i hw:1 -sample_fmt s16 ./out.mpg
[23:40] <sim590> http://ix.io/9vi
[23:41] <jnvsor> Ooh you have your inputs and outputs mixed up there, let me rewrite that for you
[23:42] <sim590> ok I have juste rewrite it. I get what you say
[23:42] <sim590> but it only records audio now
[23:42] <sim590> ffmpeg -f x11grab -y -framerate $FRAMERATE -i :0.0 -f alsa -ac 1 -i hw:1 -sample_fmt s16 -c:v libx264 -preset "ultrafast" -qp 0 ./out.mpg
[23:44] <jnvsor> http://pastebin.com/4RaryQ6p
[23:46] <sim590> jnvsor: works, but when I do mplayer ./out.mpg, I get only audio
[23:47] <sim590> Video: no video
[23:47] <jnvsor> what is the output of `ffmpeg -i out.mpg`
[23:47] <sim590> if I change mpg to mkv, it has video !
[23:48] <sim590> jnvsor: http://ix.io/9vj
[23:54] <jnvsor> Yeah: http://en.wikipedia.org/wiki/Comparison_of_container_formats
[23:54] <jnvsor> mpg only supports mpeg1 and mpeg2 video
[23:55] <jnvsor> yeah divx, mpg, mpeg and webm are the only containers that don't support h264 :)
[23:56] <sim590> so mkv seems like a pretty good container
[23:56] <sim590> it says it supports "virtually anything"
[23:57] <jnvsor> So does avi
[23:57] <sim590> yeah
[23:57] <jnvsor> container really doesn't matter - as long as it supports your codecs it's fine :)
[23:59] <sim590> it seems like it ! ;) But I heard ogg is free.. so that's a good choice for free software.
[23:59] <sim590> I don't know about mkv
[23:59] <sim590> http://en.wikipedia.org/wiki/Matroska seems like it's free too ! :D
[00:00] <jnvsor> libx264 is *so* much faster than ogg
[00:00] --- Wed Dec 25 2013

More information about the Ffmpeg-devel-irc mailing list