[Ffmpeg-devel-irc] ffmpeg.log.20131225

burek burek021 at gmail.com
Thu Dec 26 02:05:01 CET 2013

[00:00] <jnvsor> And vpx for that matter
[00:00] <sim590> ogg is a codec too ?
[00:00] <jnvsor> It's rediculous
[00:00] <jnvsor> Yeah, ogg theora
[00:00] <sim590> I thought about ogg as a container
[00:01] <jnvsor> Yeah, but it's mainly used for theora video and vorbis audio
[00:01] <jnvsor> But again - not even close to libx264
[00:01] <sim590> ;)
[00:02] <sim590> I tried to add -s 1920x1080 but it seems to much for my little ASUS PC1015px. It screen is only 1024x600 but I have another 1920x1080 monitor plugged on it
[00:03] <sim590> do you think I can tweak something in order to be able to record 1920x1080 ?
[00:04] <jnvsor> Hmm maybe - on my system I downscale the video to save disk space
[00:04] <jnvsor> Not sure if that would help a CPU bottleneck though
[00:04] <sim590> does it have to do with the graphic card too ?
[00:04] <jnvsor> No, it's almost all CPU
[00:05] <sim590> is it possible to ask GPU to do some computing ? It seems pretty much like a graphical computing.. But, Idk
[00:06] <jnvsor> In theory yes, in practice I've got no idea how to do that and it would probably be a pain :P
[00:06] <jnvsor> Try this - it downscales the video before encoding it
[00:06] <jnvsor> http://pastebin.com/FubazTyW
[00:06] <jnvsor> change it to mkv before you run of course xD
[00:11] <sim590> jnvsor: video outputs correctly.. it seems but audio is just really compressed and goes really fast
[00:11] <sim590> it's not synced
[00:20] <sim590> jnvsor: I'll just stick to recording my little 1024x600 screen
[00:20] <sim590> jnvsor: thanks for all the help !
[00:33] <jnvsor> sim590: Compressed and goes really fast?
[00:34] <jnvsor> Do you use pulseaudio?
[00:40] <sim590> alsa
[00:42] <jnvsor> So you have no pulseaudio on your system at all?
[00:43] <sim590> noe
[00:44] <sim590> I got libpulse package though
[00:44] <jnvsor> Yeah if you don't have a pulse server there's not much point
[00:44] <sim590> description: A featureful, general-purpose sound server (client library)
[00:44] <sim590> oh
[00:45] <sim590> on archlinux, pacman says: Required By    : chromium  ffmpeg  fluidsynth  gst-plugins-good  mplayer  mumble  phonon-qt4  speech-dispatcher
[00:46] <jnvsor> Well anyway, audio... There are options to change things about it like frequency `-ar`
[00:46] <jnvsor> But I haven't used alsa in so long I don't know how to diagnose that issue :P
[00:47] <sim590> jnvsor: thanks ! I'll try to play around with the -ar option
[06:04] <i336_> Hi everyone. I'm attempting to capture my speaker audio output as it leaves the soundcard - as in, capture data going from software to the soundcard - so I can stream it over the network. This is not the fastest system so I don't have JACK or PulseAudio installed, and would rather not install it if I can avoid it. So far I've managed to get faint audio if I turn my microphone up all the way and record from ALSA hw:0,0, but that's pro
[06:04] <i336_> (...probably just the mic lines getting interference from the speaker out :P)
[06:04] Action: i336_ stabs irssi for the 23450982nd time
[06:05] <i336_> Is it possible to "sniff" the audio data as it goes through ALSA...?
[06:05] Action: i336_ gets an idea
[06:05] Action: i336_ asks #alsa too :P
[06:56] <i336_> I figured it out :P google ftw! and "capture device" settings ftw too :>
[11:59] <dwirc> Hi folks.
[11:59] <dwirc> Happy xmas for those who celebrate it.
[12:00] <dwirc> Have a question regarding FFMPEG and h.264 streams (over RTSP)... tried default avconv from Ubuntu 13.10, ffmpeg from CentOS 6, and a fresh build on 12/24.  Same results all 3 ways.
[12:01] <dwirc> I've got a camera (hardware H.264 encoding with audio).  What I want to ultimately do is pull the H.264 stream via RTSP (only method available from the camera), and restream that to an RTMP server.
[12:04] <dwirc> Baby steps though... When I use FFMPEG, I set the input, tell it to copy the video codec, switch the audio codec to mp3, it gets about 30 seconds in, then hangs, every time.  I've let it sit for hours there, and it never continues.
[12:05] <dwirc> cmd line: ffmpeg -i rtsp://camip:554/12 -acodec libmp3lame -ar 22050 -f flv test.flv
[12:06] <dwirc> Doesn't matter what I specify for the output paramters seemingly (-vcodec copy, or specifically x264...)... it always hangs about 30 seconds in.
[12:06] <dwirc> ANyone seen this behavior with surveillance cams before?  I searched, but didn't find anything similar in the past year or so.
[13:39] <relaxed> dwirc: maybe -re before the input would help?
[13:39] <relaxed> are you using a recent version?
[20:32] <killer> hey , I m trying ffmpef -i file.mp4 | grep "Duration" but it is not filtering and giving me same result as ffmpeg -i file.mp4
[20:33] <sacarasc> killer: Try using ffprobe instead.
[20:34] <DeadSix27> not much of a linux user
[20:34] <DeadSix27> but didnt, "ffmpeg -i file.mp4 2>&1", work?
[20:34] <DeadSix27> and then greping duration i mean.
[20:37] <killer> I have been trying it for some time but it didn't worked but it seems to work now , I was forgetting the mp4 input after -i
[20:37] <killer> oops
[20:37] <kirbir> Marry Christmas to All! Help me please, is there a way to crop video as circle. Like here http://www.youtube.com/watch?v=S6C0aL8FpYo ? Google can't help me. Thank you.
[21:03] <killer> ffmpeg -i file.mp4 -y file.mp3 2>&1 | grep "time="   (to get the time duration of the converted video continously) but it seems grep only shows after ffmpeg has completed converted
[21:33] <DeadSix27> in ffplay, how do the filters work? (For example ass)
[21:33] <DeadSix27> I tried to run ffplay by using: ffplay -i test.mkv -vf "ass=test2.ass"
[21:34] <DeadSix27> but it doesnt open a video player/viewe thing.
[21:35] <DeadSix27> in case you want the output: http://pastie.org/private/c8bjt686dpapo6ooamggw
[21:41] <DeadSix27> Oh my fault.. it actually does play.. but i thought ffplay and ffmpeg share the same font ache
[00:00] --- Thu Dec 26 2013

More information about the Ffmpeg-devel-irc mailing list