[Ffmpeg-devel-irc] ffmpeg.log.20140502

burek burek021 at gmail.com
Sat May 3 02:05:01 CEST 2014

[00:00] <blippyp> but it's light-weight which is a huge selling-point for me
[00:00] <blippyp> and open-source so I dont' worry about botnet issues
[00:01] <blippyp> plus it's in lua (which I'm struggling to learn) because I also use awesome which is heavy on lua, and my ircBot has lua embedded into it as well...
[00:01] <manolo> i'm feeling really comfy with chrome
[00:01] <manolo> but I trust less and less comfy with google
[00:01] <blippyp> nothing wrong with that - if you're happy with something there's no reason to change...  ;)
[00:01] <blippyp> yeah - I know the feeling...
[00:02] <blippyp> I use to LOVE google and still do - but I don't trust them at all anymore
[00:03] <blippyp> I don't care if they track my searches and all that crap - but it seems like everywhere you turn these days someone is putting some kind of malware into their software...
[00:03] <blippyp> even ubuntu went nuts with it - and systemd scares the ever-loving shit out of me....  but that's a topic for another thread
[00:06] <manolo> and what about android?.. pfff
[00:07] <manolo> I'm sure they know even the color of my s**t
[00:07] <blippyp> wouldn't know - I still use one of those old pay-as-you-go flip-phones and you'll have to pry it out of my dead hand.... ; )
[00:08] <blippyp> hell, I don't even want that phone - but my fiance insists that I have one
[00:08] <Mavrik> ibisr, your question does not compute :)
[00:09] <blippyp> it's just another annoying gadget that drives me nuts - I don't like phones - all I want is my netbook for portability, will never want an ipad or a phone or google glass or whatever else they come up with...  just my little netbook and I'm happy
[00:09] <blippyp> it's a complicated subject - google b frame and you'll get introduced to a world of hurt
[00:10] <manolo> I really like thinks like whatsapp and telegram I connects u to ppl
[00:10] <blippyp> it's basically why ffmpeg has fast search and accurate search
[00:10] <manolo> and make u save tons of money
[00:11] <blippyp> wouldn't know - as 'tech' savy as I am - I've gotten behind the times as far as phones have come - I feel no need for the monthly bills for what my $20/month phone bill is - and they can only 'attempt' to do what even my crappy netbook already does - so I don't pay attention to them....  ;)
[00:12] <manolo> yup but u can take your netbook with u everywhere
[00:12] <blippyp> sure I can - I always do
[00:12] <manolo> and a smarphone is way cheaper
[00:12] <manolo> hhahahaha
[00:12] <manolo> such a geek, with all due respect
[00:12] <blippyp> it's small - smaller than some i pads
[00:12] <blippyp> yup - even have a backpack for it an everything...  ;)
[00:13] <blippyp> and I'm an old fart (well - getting there - 38)
[00:13] <manolo> Mavrik, may I take some patience from u?
[00:13] <manolo> hahahaha u r 10 years ahead from me
[00:14] <blippyp> yeah - I'm kind of lost on this myself - not getting anywhere and I noticed that after a while - switching from http to udp stopped working with mplayer (must have been a cached file I was connecting to instead or something)
[00:14] <blippyp> as in your 48?
[00:14] <blippyp> you're
[00:14] <manolo> all the way around
[00:14] <blippyp> or 28?
[00:14] <manolo> 18
[00:14] <manolo> 28
[00:14] <blippyp> enjoy it - I remember it like it was yesterday...
[00:15] <Mavrik> manolo, ?
[00:15] <manolo> yup here!
[00:15] <blippyp> we need an actual example
[00:15] <blippyp> this ain't working
[00:15] <manolo> mmm I have you webm more or less working
[00:15] <blippyp> we've even followed your webm example
[00:15] <Mavrik> that is an actual example.
[00:15] <blippyp> it's working for you?
[00:15] <Mavrik> maybe you could start by actually using ffmpeg
[00:15] <Mavrik> not libav
[00:15] <manolo> local comp: ffmpeg -f video4linux2 -i /dev/video0 -f alsa -i plughw:CARD=Intel,DEV=0 -r 30 -g 0 -vcodec h264 -acodec libmp3lame -tune zerolatency -preset ultrafast -f mpegts udp://ip:port
[00:15] <blippyp> I would agree with that as well...  ;)
[00:15] <Mavrik> avconv, avserver, etc. support is on #libav
[00:16] <manolo> remote (with your ffserver.conf): avconv -v verbose -i udp://localhost:110 udp://localhost:8080/feed1.ffm
[00:16] <manolo> my gosh xD
[00:17] <manolo> u think I should download, compile and install the last ffmpeg?
[00:17] <blippyp> yeah
[00:17] <blippyp> I would
[00:17] <manolo> ok,
[00:17] <manolo> let's go for it
[00:17] <Mavrik> manolo, why aren't you streaming directly to the ffserver from the machine with camera?
[00:17] <Mavrik> and why
[00:17] <manolo> mm
[00:18] <Mavrik> are you passing udp instead of http for ffserver target?
[00:18] <manolo> just a type
[00:18] <manolo> typo
[00:18] <Mavrik> note that using ffserver is different than just transporting video over udp
[00:19] <blippyp> why can't I connect to a udp with mplayer?
[00:19] <manolo> avconv -v verbose -i udp://localhost:110 http://localhost:8080/feed1.ffm
[00:19] <manolo> that's the correct one
[00:19] <manolo> I see
[00:19] <blippyp> it works with ffplay - but not mplayer?
[00:19] <manolo> it's a remote comp so no chance to try
[00:20] <manolo> what I get is the http://IP:8080/test.webm
[00:20] <manolo> with an embedded player
[00:20] <manolo> that does not play the cam content
[00:21] <manolo> Mavrik, how would I stream directly to the ffserver from the machine with cam?
[00:23] <Mavrik> blippyp, you don't connect to UDP, you listen to it
[00:23] <blippyp> but mplayer has an option for udp?
[00:23] <Mavrik> yes.
[00:23] <blippyp> ffplay will play it
[00:24] <Mavrik> it might require udp://@<address> specification
[00:24] <Mavrik> but it does have it.
[00:24] <Mavrik> at least mplayer2 or whats the latest fork called
[00:24] <Mavrik> manolo, by passing address of ffserver to ffmpeg that streams
[00:24] <blippyp> but it doesn't work
[00:24] <Mavrik> manolo, I really don't get which part is unclear
[00:25] <manolo> ohh
[00:25] <manolo> so the ffserver is a socket
[00:26] <manolo> so I set up a ffserver in the local machine, the one with the webcam attached
[00:26] <Mavrik> [ffserver] <--- network --- [ffmpeg]
[00:26] <Mavrik> no.
[00:26] <manolo> I see you point
[00:26] <Mavrik> ffserver is the video server.
[00:26] <Mavrik> it duplicates and serves video to your clients
[00:26] <Mavrik> ffmpeg is the one grabbing the video
[00:27] <Mavrik> doing the encoding and passing data to ffserver
[00:27] <manolo> that's what I though i was doing
[00:27] <Mavrik> note that ffserver isn't good enough to stream to all possible clients - it'll only work on desktop chrome and firefox
[00:27] <Mavrik> manolo, well
[00:27] <Mavrik> why are you passing localhost as address of ffserver ?
[00:27] <manolo> chrome and firefox is ok
[00:28] <manolo> avconv -v verbose -i udp://localhost:110 http://localhost:8080/feed1.ffm
[00:28] <manolo> in this command, right?
[00:28] <Mavrik> that makes absolutely no sense.
[00:28] <blippyp> yeah, mavriks' right
[00:29] <manolo> so, ok
[00:29] <manolo> back to the webcam comp
[00:29] <Mavrik> you're trying to read UDP packets addressed to "", port 110
[00:29] <Mavrik> and then encode whatever is there and pass it on to ffmpeg
[00:29] <manolo> I see
[00:29] <Mavrik> so that command makes no sense
[00:30] <manolo> I see how I capture and send it to the server
[00:30] <Mavrik> all you have to do
[00:30] <Mavrik> is to setup ffserver on your streaming machine
[00:30] <Mavrik> and run ffmpeg with camera grab parameters pointing to http://yourffserver/feed.ffm address
[00:30] <Mavrik> 2 processes
[00:30] <Mavrik> on two machines
[00:30] <Mavrik> with network inbetween
[00:30] <Mavrik> that's it
[00:30] <manolo> I cannot do that since I cannot open ports in the firewall, where the cam computer is
[00:31] <manolo> the computer with the webcam is behind a firewall I cannot set up
[00:31] <Mavrik> so how exactly
[00:31] <Mavrik> do you expect for that machine to send data anywhere
[00:31] <Mavrik> didn't you say you only have INBOUND closed_
[00:32] <manolo> yup I cannot set up NAT/DNAT
[00:32] <Mavrik> and which part of this arrow
[00:32] <Mavrik> [00:26:26]  <Mavrik>	 [ffserver] <--- network --- [ffmpeg]
[00:32] <Mavrik> shows TO the machine with ffmpeg/camera?
[00:32] <Mavrik> it doesn't.
[00:32] <Mavrik> because camera machine
[00:32] <Mavrik> SEEEENDS data to the ffserver machine
[00:32] <Mavrik> doh!
[00:32] <Mavrik> camera
[00:32] <manolo> hahahahaha
[00:32] <manolo> ook
[00:33] <Mavrik> :)
[00:33] <Mavrik> I think it's a little bit late ;)
[00:33] <manolo> so the sending was right
[00:33] <Mavrik> I don't think I can explain this in more simple terms
[00:33] <Mavrik> machine with camera - run ffmpeg
[00:33] <Mavrik> machine which serves video - ffserver
[00:33] <manolo> aja so far so good
[00:33] <Mavrik> that's it.
[00:33] <manolo> yup
[00:33] <Mavrik> ffmpeg --> ffserver.
[00:33] <manolo> that is already happening
[00:34] <manolo> the ffmpeg in the remote comp was useless
[00:34] <manolo> I understood
[00:35] <manolo> now, easy
[00:35] <manolo> i'm sending from the webcam comp to the server the video stream
[00:35] <manolo> udp://remote.server:110
[00:35] <manolo> who is waiting in the port 110?
[00:35] <manolo> the server
[00:35] <manolo> ffserver
[00:36] <manolo> when did I told ffserver to wait in what port?
[00:36] <manolo> ffserver.conf?
[00:37] <manolo> I told it to be in the port 8080
[00:37] <manolo> but that is for serving or receving?
[00:58] <blippyp> maverik: any idea why my ffmpeg always stops sending video after like frame 35???
[01:00] <manolo> this guys is going to end up fed up of we both xD
[01:01] <manolo> blippyp, the server is set in the port 8080, so I have to send the udp stream to that port, right?
[01:01] <manolo> there's no other xD
[01:02] <blippyp> that's my guess - and using udp is the only way I can get it to go past 35 frames - but then I can't view it at all except with ffplay, but then the videos is all screwed up
[01:03] <blippyp> I don't know what the problem is - I know I'm doing this right, it shouldn't be any different then working with swf or mjpeg - but it just doesn't work
[01:04] <blippyp> maverik: what version of ffmpeg did you do this on?
[01:06] <blippyp> maverik: you said that this only works with ie and chrome - have you tried connecting to it with mplayer like I have?
[01:06] <blippyp> have=am?
[01:38] <blippyp> manolo: i don't know what the problem is (for me anyways) - but it seems to be wrapped around a alsa buffer xrun error - I think it's screwing up my video feed...
[01:38] <manolo> i'm working around the avserver
[01:38] <blippyp> but like I said the swf format works great - you should go back to trying that again....
[01:38] <manolo> adding more and more streams
[01:39] <manolo> would you send me the stream samples page?
[01:39] <manolo> i'll go with that swf again
[01:39] <blippyp> stream samples page? you mean that link I sent you earlier?
[01:39] <blippyp> I would - it works
[01:39] <manolo> yup
[01:40] <blippyp> this page: https://www.ffmpeg.org/sample.html
[01:40] <blippyp> luckily I still had it open
[01:40] <blippyp> I gotta go now for a bit though - best of luck - hopefully I'll catch you again later.... if not - leave a message for me if you get it working - I won't be logging off
[01:41] <manolo> blippyp got it
[01:41] <manolo> fount it! thx
[01:41] <blippyp> found what?
[01:41] <blippyp> you mean it's working with swf?
[01:42] <manolo> nope
[01:42] <manolo> I found the samples page xD
[01:42] <blippyp> oh
[01:42] <blippyp> alright - well good luck :)
[02:59] <Ofekmeister> can someone please explain how to merge these files properly? it seems b/c the ac3 are different bitrates or slightly different formats the output time is incorrect         http://pastebin.com/aPNvDHWs
[03:19] <brontosaurusrex> Ofekmeister, possibly mediainfo wrong calculus
[03:20] <Ofekmeister> brontosaurusrex, all players yield wrong time too
[03:20] <brontosaurusrex> Ofekmeister, dunno then
[03:44] <SirCmpwn> can I record my system audio with ffmpeg?
[03:44] <SirCmpwn> I use pulse
[03:49] <klaxa> yes
[03:49] <klaxa> ffmpeg -f alsa -i pulse out.ogg
[03:49] <klaxa> use pavucontrol or the command line stuff (pacmd, pactl) to set the correct input device
[03:50] <klaxa> should be something like monitor of analog-stereo
[03:50] <klaxa> SirCmpwn: ^
[03:50] <SirCmpwn> thanks!
[04:32] <blippyp> manolo: you still plugging away at it?
[04:40] <kcynice> how to compile libpostproc? i hasnot set --disable-postproc option when configuring, but, libpostproc still can't be compiled
[04:42] <blippyp> I specifically added --enable-postproc to my compiling, and it works just fine - maybe you need to specifically enable it?
[04:44] <kcynice> which version you used? after several tries, i found add --enable-gpl can make that libpostproc re-enable. waiting the compiling result
[04:44] <blippyp> I compiled mine last week some time - from the git
[04:45] <kcynice> oh. my version is almost 2 months older than yours
[04:46] <blippyp> here is my exact configure command: http://sprunge.us/GBaB
[04:46] <kcynice> and, do you know how to use the new feature about ff_xv_muxer? I can't find any information about that, i use it as the normal muxer object,
[04:46] <kcynice> it works ok, but display nothing window
[04:46] <blippyp> no idea, wasn't aware of it...
[04:48] <kcynice> but, how do you display a video frame?
[04:49] <blippyp> what do you mean?
[04:49] <kcynice> use sdl? or any other options?
[04:49] <kcynice> when a video frame wad decoded, how to display on a window?
[04:49] <blippyp> are you talking about programming?
[04:49] <kcynice> yeah
[04:50] <blippyp> no idea, only use ffmpeg and ffserver, haven't tried coding with it yet - sorry, I'm no help for you
[04:50] <kcynice> ah, you a welcome
[04:51] <blippyp> just wait, some of the people here do I'm sure - someone might know the answer for you
[04:51] <blippyp> I'm bored though - so I'll try to find it as well...  ;)
[04:52] <kcynice> why you compile it by your hands?
[04:53] <blippyp> I wanted frei0r
[04:53] <blippyp> why don't you look at the code for ffplay?
[04:53] <blippyp> I'm sure your answer will be in there
[04:54] <blippyp> ffmpeg isn't really for 'viewing' - I think it uses mplayer (or a good chunk of it's code) for ffplay to do that...
[04:54] <kcynice> yes, i know it, but i don't want to use the render ffplay used.
[04:54] <blippyp> why? what's wrong with it?
[04:55] <kcynice> i want to insert much more window elements for a player, btw, im just starting ffmpeg, i want to write my own player for practice
[04:56] <blippyp> what do you need ffmpeg for if you want to make a video player?
[04:57] <blippyp> it converts codecs and builds videos, it's not for viewing...
[04:57] <blippyp> you should look into the mplayer code - I think you'll find more of what you want...
[05:02] <kcynice> might be, but mplayer was so so complex
[05:03] <blippyp> you're not attempting to do a simple thing...  ;)
[05:04] <blippyp> whatever your reasons are for digging into ffmpeg, and based on the questions you've already asked, my guess it that you want to learn both quite well...
[05:04] <blippyp> or at least start digging into some tutorial on how to make a video editor
[05:04] <kcynice> i have a glance to mplayer, it use sdl too.
[05:05] <blippyp> you should use something like lazarus - it's simple to make a video play using that
[05:05] <blippyp> you can do it with just a few drag and drops and a few lines of code
[05:05] <kcynice> In fact i can display a decoded video frame ok, but, its too slow
[05:06] <blippyp> how are you doing that? pastebin your code?
[05:06] <blippyp> if you don't mind - I'm curious....  ;)
[05:06] <blippyp> you don't have to paste it all, just the relevant part(s)...
[05:07] <kcynice> lazarus is just a compiler
[05:07] <blippyp> no - it's a graphical ide
[05:07] <blippyp> which uses free pascal
[05:07] <blippyp> basically delphi but for linux
[05:08] <kcynice> my code is simple, i just create a new rgb buffer, when a video frame was decoded, i convert to RGB24, and then copy to the rgb buffer
[05:08] <blippyp> trust me it's simple - I'm a pretty good delphi programmer and I've made simple video editors with it
[05:08] <kcynice> and then create a bmp object and draw it on my play window
[05:09] <kcynice> introduce a new language,  i only use c/c++, know nothing about pascal
[05:09] <blippyp> then pascal will be simple for you
[05:09] <blippyp> I think you can code c++ with it as well
[05:09] <kcynice> but i know delphi, its perfect
[05:09] <blippyp> than you know lazarus
[05:10] <blippyp> lazarus IS delphi
[05:10] <kcynice> its my first know lazarus
[05:10] <blippyp> *reborn
[05:10] <kcynice> delphi use pascal language, i know
[05:10] <blippyp> just not quite as solid - I miss delphi so much
[05:10] <kcynice> you meant, delphi dead
[05:11] <blippyp> been for years - that's why they made lazarus
[05:11] <blippyp> i was so excited when I found it - but it's not quite the same...
[05:11] <blippyp> including new packages is just retarded
[05:11] <blippyp> it was so seamless and easy with delphi - it's what made it so powerful
[05:11] <blippyp> I loved making packages
[05:11] <kcynice> delphi was defeat by .NET
[05:12] <blippyp> and turning them into components
[05:12] <blippyp> is that what you're using - .NET?
[05:12] <blippyp> I would imagine it has tons of libraries all ready to go for video editing (never used it myself)
[05:13] <blippyp> I really need to take a good look at it though - I think I have a copy around here somewhere...
[05:13] <kcynice> no, i know little about that, i only like asm/c/c++ language
[05:13] <blippyp> do you use g++ or ms visual c++, something else?
[05:13] <kcynice> i don't need a video editor, just a playback method
[05:14] <kcynice> i use g++&vim
[05:14] <kcynice> i think it perfect
[05:14] <blippyp> then you don't need ffmpeg... I'm not understanding why you're digging into the ffmpeg code...
[05:14] <kcynice> although i had use visual studio for some years
[05:14] <blippyp> that's what I'm using these days too - just started digging back into it a week or so ago - been working on an irc bot
[05:15] <blippyp> I was very good at c/c++ in college - too bad I got moved away from it - but delphi was a very good experience for me.
[05:15] <blippyp> we sound a lot alike...  ;)
[05:15] <kcynice> ah, i need ffmpeg's library, not the executable program named ffmpeg
[05:16] <kcynice> yes, dephi is a perfect toolkit
[05:16] <blippyp> I think you want the libraries for x264, and libvpx, etc.. etc.. not really ffmpeg itself...
[05:16] <blippyp> you don't even need those really - it's all automatically done for you in lazarus/dephi/whatever...
[05:16] <blippyp> it really is simple
[05:17] <kcynice> but, ffmpeg provides a uniform interface for media format, decoding, coding,demuxing...etc
[05:17] <blippyp> just drop teh video component and point a file at it and watch it go
[05:17] <kcynice> that what i want. Im just a library user, but not a library developer
[05:17] <blippyp> then USE ffmpeg to do your muxing/demuxing until you figure it out...
[05:17] <blippyp> ffmpeg works great as a swiss-army knife
[05:17] <kcynice> yeah
[05:18] <blippyp> so make your video player and then once you're happy with that - then dig into the ffmpeg libraries and figure out how to 'incorporate' it into your software, until then, just USE ffmpeg itself...
[05:18] <blippyp> that's what I would do anyways...  ;)
[05:19] <blippyp> I don't think you're taking on a small project, by any means... but if you break it apart into chunks you'll get somewhere useful with it quickly...
[05:19] <kcynice> infact, my main aim was build a audioplayer for myself, because Im working for a embedded system about video muxing and demuxing,
[05:20] <kcynice> so i want to add video play for my player too, although i had not implement audio playing functions
[05:20] <blippyp> I would just ffmpeg itself - I think you're taking on way more than you can chew at this point - get the interface working the way you want first....
[05:20] <blippyp> video/audio it's all basically the same thing from a gui perspective...  ;)
[05:21] <kcynice> i don't think its a big project. for now, I use examples code in ffmpeg source code to do the file parsing, decoding...
[05:21] <kcynice> yes, im blocked at GUI
[05:22] <blippyp> me too - always blocked at gui when it comes to c++
[05:22] <blippyp> you should go into a c++ channel
[05:22] <blippyp> talk to some guys there - I'm sure they'll give you the answers you need
[05:22] <blippyp> you need to dig int gtk or qt or something like that
[05:23] <kcynice> this is the only channel i found
[05:23] <blippyp> just type in /join #C++
[05:23] <blippyp> there's a channel for damn near anything on freenode
[05:23] <kcynice> you mean, this channel is only for whom use ffmpeg executable program?
[05:23] <blippyp> no - I think it's for the programming aspects of ffmpeg as well
[05:23] <blippyp> but you don't have that kind of question
[05:23] <kcynice> oh, im not being learning programming language
[05:24] <blippyp> you're looking for something else - you seem to understand the programming aspects of ffmpeg already
[05:24] <blippyp> huh?
[05:24] <blippyp> your not beign learning? - rephrase that....
[05:25] <kcynice> i meant, im not beginner for C++
[05:25] <blippyp> no - clearly you're not
[05:25] <kcynice> just a beginner for ffmpeg, lol
[05:25] <blippyp> you probably know much more than me
[05:25] <blippyp> but you want to know how to use gtk ot qt or some other gui library for c++
[05:25] <kcynice> i know gui too
[05:26] <blippyp> very few people on this channel probabl even know where to begin - that's why I suggested that you go to #C++ or something similar instead - they can help you much more
[05:26] <kcynice> but i don't know how to connect the video output to gui effectively
[05:26] <blippyp> or #gtk or #qt - I'm sure there's channels like those as well
[05:26] <blippyp> qt is both windows and linux - you might want to dig into that
[05:26] <blippyp> (at least I think it is)
[05:27] <kcynice> yes, i use an alternative gui toolkit named wxWidgets
[05:27] <kcynice> you said, you are blocked at GUI?
[05:27] <kcynice> what did you mean?
[05:27] <blippyp> those libraries will show you how - they probably do it pretty easily...
[05:27] <blippyp> then look into wxWidgets - it must have a library for interfacing with the video - no?
[05:27] <blippyp> I've just never coded a GUI with c++
[05:27] <blippyp> always libraries or console
[05:28] <blippyp> basically learned ALL the basics for C/C++ - understood them very well - better than anyone I knew at the time - but then got moved into delphi due to work and haven't looked back again until a week or so ago...
[05:28] <blippyp> kind of like starting from scratch again, but not really...
[05:29] <blippyp> in Delphi I made lots of GUI applications with databases - I was scared of making NOTHING basically...
[05:29] <blippyp> so I understand the concepts required, but have never implemented them with C++ - Which is a bit more of a daunting task than using Delphi - Delphi is just simple
[05:29] <kcynice> yes. delphi is easier
[05:29] <kcynice> more and more easier
[05:30] <blippyp> yet very powerful - it gave you the ability to really dig in when needed - and it is just as fast as c basically
[05:30] <blippyp> delphi is awesome - like I said, I REALLY miss it
[05:30] <kcynice> and, what you working for?
[05:30] <blippyp> I don't understand what you mean?
[05:31] <kcynice> ah, im sorry for my poor english
[05:31] <blippyp> that's okay - I noticed...  ;)
[05:31] <kcynice> i meant, did you use delphi for developing?
[05:31] <blippyp> yes
[05:32] <blippyp> for a manufacturing company - I designed all of their internal software applications
[05:32] <blippyp> but I haven't worked in the field in years really
[05:32] <kcynice> but why?
[05:32] <blippyp> because I learned delphi and lost track of C++ / never learned .net
[05:33] <kcynice> i think such company need more function about database
[05:33] <blippyp> I became 'unemployable' bascially and now need educational 'upgrading'
[05:33] <kcynice> you want to dig into c++ and .net?
[05:33] <blippyp> no - I want delphi to come back... ;)
[05:33] <blippyp> haha
[05:33] <kcynice> windows or other platforms?
[05:33] <blippyp> I still can't understand for the life of me why it disappeared...
[05:34] <blippyp> windows - but with delphi you could code for anything - basically like .net as far as I understand it
[05:34] <kcynice> that's for everybody
[05:34] <blippyp> plus you could code in C++ if you preferred
[05:34] <kcynice> oh\
[05:35] <blippyp> the interface was just beautiful - I loved the components and it was so simple to make your own components if you didn't like the ones you were using
[05:35] <kcynice> might be i should post my questions on a forum
[05:35] <blippyp> go to C++ - seriously
[05:36] <kcynice> c++ can do it too
[05:36] <blippyp> I just joined there - there's like hundreds of people in the channel
[05:38] <blippyp> or go on github - I bet you can find something on there you can fork or at least download and check out the code to get an idea of what you're looking for - there's so much freely available code out there.... you have specific wants/needs - it shouldn't be hard to find your answer
[05:39] <kcynice> i think too
[05:39] <kcynice> thank your and all your hints
[05:40] <blippyp> np - it was nice meeting someone who has such a similiar background as me... ;)
[05:40] <kcynice> cool and keep in touch.
[05:40] <blippyp> I'll try - ;) (i'm very forgetful with names...)  :(
[05:41] <blippyp> I'm usually in this channel though
[05:42] <kcynice> ok
[05:45] <kcynice> i have to offline now, have lunch
[05:45] <kcynice> see u next time.
[08:56] <John_Loki> I want to use libavcodec api for H.264 decoding, I am interested in particular frames of interest? Question is, does libavcodec provides NAL details and other H.264 syntax elements
[08:59] <blippyp> https://ffmpeg.org/doxygen/trunk/h264__parser_8c.html
[08:59] <blippyp> is that what you're looking for?
[09:02] <John_Loki> @blippyp yup seems like, I am going to look into the details of what it can provide
[09:02] <John_Loki> generally speaking, still couldn't find an open src stream analyzer for H.264
[09:03] <blippyp> no idea - I just did a google for ya...  ;)
[09:04] <John_Loki> thanks
[09:04] <blippyp> I was on the doxygen earlier today helping out another guy and figured it would have your answers....
[09:04] <blippyp> np
[10:34] <John_Loki> hi, any link to some tutorial or api usage guide for libavcodec?
[10:35] <John_Loki> trying to figure out what's wrong with the example libavcodec usage at https://www.ffmpeg.org/doxygen/0.6/api-example_8c-source.html
[10:36] <John_Loki> any ideas guys ?
[11:18] <Shubham__> Hi i am trying to make the FFMPEG for android which can be run as process like command ffmpeg -i inputfile outputfile but i am unable to make it due to changes in toolchains of NDK and latest version i have tried guardian project etc.. but nothing successfull till now is there any tutorial in details description for making the ffmpeg
[12:55] <Mavrik> ShadowJK_, make a standalone NDK toolchain
[12:55] <Mavrik> and use that GCC to compile ffmpeg
[12:56] <JEEB> did something change recently'ish in NDK?
[12:56] <JEEB> because I remember grabbing it a couple of months ago
[12:56] <JEEB> and the only problem I had was that I had to define the sysroot
[12:56] <JEEB> because it had multiple for multiple android SDK levels
[12:58] <John_Loki> is api_example.c missing in latest builds or I'm just unable to find it? anybody please
[14:02] <usrnix> Hi, trying to select an english subtitle track in a .ass file which i extracted from an mkv to hardsub into the webm I'm wanted to convert the mkv to; what flag/options do I need to add to select the (0.0) track? (I've tried a few things and I keep on not getting english)
[14:13] <rhz_> I have a movie with two audio tracks. How do I extract each audio track separately with ffmpeg?
[14:15] <c_14> ffmpeg -i input -map 0:a:0 -c:a copy output1 -map 0:a:1 -c:a copy output2
[14:15] <c_14> should do the trick
[14:15] <c_14> Assuming you want the first and the second audio stream.
[14:17] <rhz_> cool, thanks a lot
[16:07] <Bombo> i'm trying to encode a dvd.vob including subs, but i get "Unsupported codec with id 1145979222 for input stream 0" and i don't see a sub stream in ffprobe/ffmpeg -i
[16:08] <Bombo> (the sub is selectable in vlc, mediainfo shows RLE)
[16:11] <Bombo> c_14: http://pastebin.com/ZHYFuwEc
[16:14] <c_14> Is VTS_02_0.VOB your source or output?
[16:14] <Bombo> Input stream
[16:19] <Bombo> hmm ok subs are available in vlc not from the beginning
[16:19] <Bombo> there is an intro first that doesn't have subs
[16:20] <Bombo> so subs are added to the stream after the intro
[16:21] <c_14> If you use ffplay to play the file, do you see the subtitles?
[16:28] <Bombo> c_14: checked, nope
[16:32] <c_14> Check your ffmpeg -codecs output if there is a line like this:  ..D... dvd_nav_packet       DVD Nav packet
[16:36] <Bombo> i tried now 'ffmpeg -i the.vob -c copy out.vob'
[16:36] <Bombo> should cp everything
[16:36] <Bombo> i get
[16:36] <Bombo> [mpeg @ 0000000002b50760] New subtitle stream 0:3 at pos:296396814 and DTS:309.48s
[16:36] <Bombo> so it detects the sub
[16:36] <Bombo> but won't copy it
[16:37] <c_14> It might be that the subtitle is only in the stream after a specific point and ffprobe doesn't probe that far.
[16:37] <c_14> try adding -map 0
[16:38] <Bombo> 'ffmpeg -i the.vob -c copy -map 0 out.vob' -> 'incorrect codec parameters'
[16:39] <c_14> The command without the -map 0, did the output have 2 or 3 streams?
[16:41] <Bombo> 3, see pastebin
[16:41] <Bombo> then there are 2 more streams starting at 309 secs
[16:41] <Bombo> 0:3 + 0:4
[16:42] <Bombo> 'ffmpeg -ss 00:05:00 -i the.vob -c copy -map 0:3 out.vob' -> 'Stream map '0:3' matches no streams.'
[16:43] <Bombo> so i skip to 5min, where the sub streams 0:3 and 0:4 are, but doesn't copy them
[16:44] <c_14> try putting the -ss after the.vob
[16:46] <Bombo> c_14: same
[16:46] <Bombo> ff detects the subs, not copying them
[16:51] <c_14> So -map 0 errors out due to incorrect codec parameters?
[16:54] <Bombo> yes because its dvd nav
[16:54] <Bombo> 0:1 is the video stream
[16:54] <Bombo> 0:2 audio
[16:55] <Bombo> after 5mins there appears 0:3 sub1 and 0:4 sub2
[16:55] <c_14> maybe try: ffmpeg -i the.vob -c copy -map 0 -map -0:0 out.vob
[16:55] <c_14> To tell ffmpeg not to try coping the dvd nav stream?
[16:55] <Bombo> thats not the prob
[16:56] <Bombo> prob is it doesn't copy the subs
[16:56] <c_14> Ye, that's hopefully what the -map 0 is for.
[16:56] <c_14> If I'm understanding this right, -map 0 didn't work last time because ffmpeg couldn't copy the dvd nav stream.
[16:58] <Bombo> right, ... which i don't want or need anyway (do i?)
[16:59] <c_14> I don't think you need it, but i have no idea what it contains.
[17:01] <Bombo> it's probably crap ;)
[17:31] <samidarko> Hi everybody
[17:31] <samidarko> I'm trying to code with libav an encoder from pcm/wav to aac but I'm very confused by the documentation
[17:33] <samidarko> I tried to compile the example given in the documentation but difficult to compile without modifications because some functions were deprecated
[17:34] <samidarko> the documentation I'm using is from the doc package "libav-doc"
[17:34] <samidarko> everything is installed from my package manager (apt) and I'm using Linux Mint
[17:35] <samidarko> Can anybody give me a good website/documentation I could use for my purpose? Thx :)
[17:57] <blippyp> John_Loki: Look in your doc/examples folder, you'll see a file called avcodec.h - I thinki it's basically the same file
[17:57] <blippyp> oops avcodec.c I mean
[18:33] <samidarko> @John_Loki: thanks but there is a gap between the example and the lib. If I can't compile this code without modifying it. It said some functions are deprecated
[18:34] <samidarko> @John_Loki: no worries, I got to go. Cheers
[19:43] <lxer> if I want to upgrade a server to do some serious ffmpeg processing (tenthousands of small files), what should be the first thing to look at, cpu or memory? or is even gpu processing possible?
[19:49] <JEEB> lxer, look at CPU first and foremost
[19:49] <JEEB> GPU is only going to be an expensive heater
[19:49] <JEEB> RAM is OK as long as you have enough of it
[19:50] <lxer> ok. thanks
[19:56] <cortman> I have a bash script running ffmpeg automatically, converting .wma files to .mp3
[19:56] <cortman> It's giving me this message "Application provided invalid, non monotonically increasing dts to muxer in stream 0: 33010 >= 31084
[19:56] <cortman> "
[19:57] <cortman> But it continues to work and it seems like it's converting fine.
[19:57] <cortman> Is this something I should be worried about/look into?
[20:00] <blippyp> this might help you:https://trac.ffmpeg.org/ticket/2212
[20:01] <blippyp> I only took a quick peek - but it looks like you might have conflicting timestamps in the subtitles...???
[20:02] <cortman> Thanks, I did see that page, but as my program did not exit with an error I didn't know if it was applicable. What exactly are the subtitles?
[20:05] <cortman> Do you mean video subtitles? Because these are just audio files.
[20:06] <blippyp> oh yeah eh... didn't notice you say that - there seems to be lots of results with google for this error
[20:06] <blippyp> are you using avconv or ffmpeg?
[20:06] <cortman> ffmpeg, latest version- I compiled it
[20:07] <blippyp> k, so the last page I read probably won't help you either... (there was bug for this issue that was fixed apparently) - I don't think it's an uncommon one - but the fact that you're working with just audio might make it easier to find out why it's happening...
[20:08] <cortman> Great- I should also add that this always appeared directly before that error- "[libmp3lame @ 0x9bc29e0] Queue input is backward in time
[20:08] <cortman> "
[20:08] <blippyp> yeah - I'm searching specifically for mp3 now
[20:13] <cortman> Thanks.
[20:13] <cortman> Like I said, the files *appear* to have converted fine, and playback is fine in VLC- maybe I should try them in a more picky player
[20:15] <blippyp> yeah - I would try that...
[20:17] <cortman> They work fine with Windows Media Player, so I guess maybe all's well that ends well. *shrugs?
[20:17] <blippyp> http://stackoverflow.com/questions/17379971/html5-video-chrome-ffmpeg-mp4-working-in-all-but-chrome
[20:17] <blippyp> this guy was getting the same erros (different file types though) and he couldn't get compatibility with all devices afterwards - so it might be an issue....
[20:18] <blippyp> can you pastebin your script?
[20:18] <blippyp> or at least the ffmpeg command part...
[20:19] <cortman> Sure, just a minute
[20:20] <cortman> http://pastebin.com/esPFsa8q
[20:25] <blippyp> what's with the < /dev/null at the end? shouldn't that be > /dev/null (or add -logleve quiet) to the command?
[20:28] <blippyp> try getting rid of that and see if the error is still there....
[20:33] <cortman> Now I'm a little confused. That was to direct stdin to /dev/null.
[20:33] <cortman> Do I have the symbols mixed up?
[20:33] <cortman> I want ffmpeg to read from while, not stdin- that was to fix a problem I had earlier.
[20:33] <blippyp> don't you mean stdout to /dev/null
[20:33] <blippyp> as in to prevent displaying the output?
[20:34] <cortman> No.
[20:35] <blippyp> k - then maybe I'm not understanding why it's there...
[20:35] <blippyp> either way - remove the redirection and see if the error is still there
[20:35] <cortman> Here's the link that figured that one out for me. http://stackoverflow.com/questions/23084551/ffmpeg-script-skips-files
[20:35] <cortman> Wihtout that redirection it ffmpeg cuts off part of the filename of the next file to convert, resulting in "no such file or directory" error.
[20:37] <blippyp> then modify the variable before the ffmpeg command - or try it by hand without the script without the null - point being - get rid of it and see if it's affecting ffmpeg in a bad way
[20:37] <cortman> Ok, sure. I'll give that a try here.
[20:38] <blippyp> maybe I'm not seeing it - but I'm not seeing a redirection like that in the example page you just posted....??
[20:39] <cortman> In the only answer, second sentence- "Just redirect stdin for ffmpeg by adding < /dev/null"
[20:39] <blippyp> oh - didn't see that - was only looking at the code - my bad
[20:40] <cortman> No problem! :)
[20:40] <cortman> And it looks like I get the same messages when I run *just* the ffmpeg command manually on one file
[20:40] <blippyp> okay - sorry it just looked odd to me....
[20:41] <cortman> no problem, it wasn't obvious to me either lol
[20:41] <blippyp> does it happen with every file you convert or is it more speratic?
[20:42] <cortman> Every file.
[20:44] <blippyp> I just ran the command with an mp4 and didn't get the error - are all your source files .wma files?
[20:44] <cortman> I believe so. I might have some others lyinga bout
[20:46] <blippyp> can you post one somewhere so I can download one of them?
[20:48] <blippyp> I think you can easily send it to sendspace.com
[20:49] <cortman> OK let me see here.
[20:51] <cortman> http://www.sendspace.com/file/fcskyr
[20:51] <cortman> I did find some .m4a files and tried converting them just now- they don't produce any of that output.
[20:51] <cortman> So it would seem to be .wma specific
[20:54] <blippyp> okay - yeah, now I'm getting the error
[20:54] <blippyp> I'm guessing it does have something to do with the conversion from wma to mp3 (or just wma)
[20:56] <cortman> hm, ok. I guess I'll just figure nothing's really wrong, I don't know
[20:57] <blippyp> yeah if I try to convert it to another format other than mp3 I still get the same error
[21:01] <cortman> Ok, well thanks for the help!
[21:03] <blippyp> sorry I couldn't help more - but it does seem to be something specific about your wmav2 files
[21:03] <blippyp> (or just wma in general)
[21:05] <cortman> Sure. Thanks!
[21:55] <wildfier> Hi
[21:56] <wildfier> If there is anyone here able to answer a dev question,
[21:57] <wildfier> I'm trying to write a module like x11grab
[21:57] <wildfier> but using xcb
[21:57] <wildfier> I want to add window grabbing, so
[21:58] <wildfier> I was wondering if I can update the stream format (for instance when the captured window is resized) during the recording
[22:01] <JEEB> wildfier, a "decoder" can just fine switch resolution
[22:01] <JEEB> there are multiple decoders that already can do that
[22:01] <JEEB> like MPEG-2 or H.264 or HEVC
[22:05] <wildfier_> nice
[22:05] <wildfier_> thx
[22:11] <wildfier_> to do that do I just need to update the width, height and bit_rate of the codec field of the corresponding stream or is there anything else ?
[22:18] <ergZay> michaelni: nice work on the spacex videos, question, I notice during those reconstructions that the video doesn't "line up" left to right
[22:19] <ergZay> you can see the "shadow" in the motion estimation of the legs deployed and it scans up and down and left and right
[22:19] <ergZay> is that a symptom of the errors and is there a way to force the video to line up?
[22:19] <JEEB> wildfier_, either that or setting the information in the frame you output
[22:21] <wildfier_> ok even simpler, thanks
[22:23] <michaelni> ergZay, errors can cause macroblocks to be lost, like for example if 2 MBs get decoded as one or the other way around inserting MBs, in these cases the stuff would shift right/left
[22:25] <michaelni> it also might be that a packet has been lost and that causes the shift
[22:25] <ergZay> michaelni: is there a way to correct for that?
[22:25] <ergZay> pad with empty data to make things line up?
[22:26] <michaelni> that might work
[22:26] <ergZay> michaelni: also can you upload the source for your varients of ffmpeg?
[22:26] <ergZay> i was asking about the line up thing, as it appears in the original videos that it does line up
[22:26] <ergZay> and then your modifications cause that to stop
[22:27] <wildfier_> :w
[22:33] <michaelni> ergZay, https://github.com/michaelni/FFmpeg/tree/spacexdebug1 (and command line options like  -ec 0 -debug nomc -err_detect ignore_err)
[22:35] <ergZay> michaelni: thx
[22:35] <ergZay> michaelni: if you can continue to stop by the forum and answer questions for people that'd be awesome, your knowledge is greatly appreciated (even better if you keep working on things)
[22:36] <ergZay> thank you much
[22:36] <michaelni> ill try to look at the forum from tie to time, also dont hesitate to ping me if theres some question that i could know the awnser for
[00:00] --- Sat May  3 2014

More information about the Ffmpeg-devel-irc mailing list