[Ffmpeg-devel-irc] ffmpeg.log.20140503

burek burek021 at gmail.com
Sun May 4 02:05:01 CEST 2014

[02:14] <USA_NO_1> what is latest version of flac
[02:14] <USA_NO_1> encoder
[02:19] <sacarasc> USA_NO_1: https://xiph.org/flac/ will tell you!
[02:20] <USA_NO_1> it says 1.3 but i only see flac.121.exe
[02:21] Action: sacarasc shrugs.
[02:21] <sacarasc> ffmpeg doesn't use it, anyway. :D
[02:21] <USA_NO_1> ffmpeg doesn't support flac?
[02:21] <sacarasc> No, ffmpeg has its own FLAC encoder and decoder.
[02:22] <USA_NO_1> what version
[02:22] <relaxed> why do you think you need a specific version?
[02:22] <sacarasc> It's got NOTHING to do with the xiph FLAC version.
[02:26] <USA_NO_1> when i see all my flac files, it says it's using libflac1.2.1
[02:30] <relaxed> ok, but why does this matter to you?
[02:31] <USA_NO_1> just curious
[02:31] <sacarasc> 1.2.1 is the last one that they compiled themselves, so that's what most programmes bundle.
[02:31] <sacarasc> And so it's what most pirates rip with.
[02:32] <USA_NO_1> i just want to know if there is a higher version of libflac
[02:33] <sacarasc> Yes, but not from the official FLAC site for Windows.
[02:33] <USA_NO_1> then why can't i get for windows
[02:33] <sacarasc> Because no one has compiled it and uploaded it.
[02:33] <relaxed> last time I test ffmpeg's flac encoder provided better compression
[02:33] <relaxed> tested*
[02:34] <sacarasc> You're free to compile it yourself, though. :D
[02:34] <USA_NO_1> relaxed which libflac version does ffmpeg use
[02:34] <klaxa> none
[02:34] <sacarasc> It doesn't.
[02:34] <klaxa> do you even read?
[02:34] <sacarasc> It uses its own one made from scratch.
[02:34] <USA_NO_1> i see, then what version # would it show up as
[02:35] <sacarasc> None.
[02:35] <USA_NO_1> let me test it
[02:35] <USA_NO_1> and see if you are not lying to me
[02:35] <relaxed> well, look at "ffmpeg -h encoder=flac" first
[02:36] <sacarasc> In `mediainfo` it will say something like: Writing library                          : Lavf55.37.102
[02:36] <USA_NO_1> what is command to convert  test.wav to test.flac
[02:36] <sacarasc> ffmpeg -i test.wav test.flac
[02:38] <USA_NO_1> wow you guys are right
[02:38] <USA_NO_1> i apologize
[02:38] <USA_NO_1> it shows up as lavf55.37.102 though
[02:38] <USA_NO_1> whatever that means
[02:39] <USA_NO_1> sacarasc wow, you are right,  i didn't even see that until now
[02:40] <sacarasc> It means LibAVFormat 55.37.102
[02:40] <relaxed> FFMPEG_NO_1
[02:40] <USA_NO_1> why doesn't ffmpeg follow the  libflac version
[02:41] <relaxed> because it's not libflac
[02:41] <relaxed> they wrote their own compliant version
[02:41] <relaxed> there's more than one way to skin a flac
[02:42] <USA_NO_1> is latest version of libflc  1.3 ?
[02:43] <sacarasc> Yes.
[02:43] <sacarasc> But no one has made it on Windows.
[02:43] <USA_NO_1> i see
[02:43] <USA_NO_1> should i bother converting 1.2.1 to 1.3
[02:44] <sacarasc> No.
[02:44] <USA_NO_1> why not
[02:44] <sacarasc> Because first you'd have to transfer to a system on which you have 1.3.0, or compile it yourself.
[02:44] <sacarasc> Then you'd have to convert them all, or script it.
[02:45] <USA_NO_1> is it that hard to compile 1.3 to windows platform?
[02:45] <iive> yes
[02:45] <USA_NO_1> wow really?
[02:45] <iive> get mingw64 and see for yourself.
[02:46] <iive> also... somebody said that ff_flac is better than libflac
[02:46] <iive> ff=ffmpeg
[02:46] <iive> anyway, at the end you are most likely going to save about 5MB total.
[02:46] <USA_NO_1> if that is true, why don't libflac copy  ff_flac
[02:47] <iive> who knows... maybe they like it that way.
[02:47] <sacarasc> Giving up and admitting defeat is often hard to do.
[02:49] <iive> and your mileage may vary.
[02:49] <USA_NO_1> sacarasc i see
[03:00] <USA_NO_1> why is it that so many players cannot play .ape properly
[03:01] <klaxa> because they lie about freedom
[03:01] <klaxa> >Free  Monkeys Audio is completely free!
[03:02] <sacarasc> Not many people use it, so not many people want to support it.
[03:06] <USA_NO_1> does vlc use ffplay to playback
[03:07] <USA_NO_1> i see  http://www.saunalahti.fi/~cse/temp/flac-1.3.0-win32.zip  . is this legit
[03:08] <sacarasc> Dunno, get it, test it for viruses and then try it. :p
[03:09] <CapsAdmin> how can i flip a frame?
[03:09] <CapsAdmin> with the sws library
[03:09] <USA_NO_1> it looks legit
[03:09] <CapsAdmin> (programatically)
[03:09] <azk> So, I set up an ffserver webm livestream and was testing it out on different browsers. The stream works fine on Chromium but Firefox has no audio. I'm using vorbis with a 64k abr.
[03:10] <USA_NO_1> isn't wma more closed than .ape
[03:10] <azk> Anyone come across this? I tried the firefox community but nobody seemed to have had this problem before.
[03:10] <Plorkyeran> just copying the lines in reverse order is almost certainly going to be less effort and faster than using swscale
[03:10] <Plorkyeran> or just negate the stride if the thing consuming the frame supports that
[03:14] <iive> negative stride and move the plane pointer so it points to the last line (that now would be the first).
[03:14] <Plorkyeran> ah yes, that part is important too
[03:14] <iive> stride (linesize) is used to calculate the address to the next line, by adding it to the plane pointer. as it is negative it would move backwards.
[03:15] Action: sacarasc waves at Plorkyeran.
[03:32] <USA_NO_1> is ffmpeg.exe able to use multiple core/processor
[03:34] <CapsAdmin> i have a question regarding cores
[03:34] <CapsAdmin> when i enable log level 10 it says "detected 7988098 logical cores"
[03:34] <CapsAdmin> "[ffmpeg] detected 15725884 logical cores"
[03:34] <sacarasc> USA_NO_1: Yes. But if you want to do multiple files at once, you'd have to do multiple copies at once.
[03:35] <USA_NO_1> sacarasc huh?
[03:35] <sacarasc> Multi-threading in ffmpeg is for speeding up single file encodes, not doing multiple encodes at once.
[03:36] <USA_NO_1> i just tried, it doesn't
[03:36] <USA_NO_1> it only use 1 core
[03:36] <sacarasc> What are you encoding?
[03:36] <USA_NO_1> flac
[03:37] <sacarasc> Audio is so quick that you don't need multiple threads.
[03:38] <CapsAdmin> make multiple instances of ffmpeg encoding different files
[03:38] <USA_NO_1> sacarasc it shouldn't matter
[03:38] <USA_NO_1> sacarasc what if i am encoding 5 hour audio
[03:38] <CapsAdmin> ah
[03:39] <sacarasc> Then it should be done in 5 minutes anyway. :D
[03:39] <USA_NO_1> why not just support multiple cores
[03:39] <USA_NO_1> instead of excuses
[03:39] <sacarasc> Too much effort for not enough pay off.
[03:40] <USA_NO_1> it's that hard?
[04:44] <kcynice> hi blippyp, are you still there?
[07:09] <Waraqa> Hi, Is it possible to apply concat filter and atempo filter in the same command?
[07:11] <Waraqa> When I do that it fails with this error: Filtergraph 'atempo=1.0006' was specified through the -vf/-af/-filter option for output stream 0:1, which is fed from a complex filtergraph.
[07:11] <Waraqa> -vf/-af/-filter and -filter_complex cannot be used together for the same stream.
[07:40] <blippyp> Waraqa: paste your entire command and output to pastebin or similar site
[07:43] <Waraqa> blippyp: http://pastebin.com/WTrQtbpk
[07:45] <blippyp> you have two filters in your command
[07:45] <blippyp> remove the -filter:a one
[07:46] <blippyp> you've already specified that anyways
[07:46] <blippyp> also I think you're missing a , between the atempo filter and the concat filter
[07:47] <blippyp> ffmpeg -t 16.45 -i MVI_0022.MOV -ss 16.45 -i MVI_0022.MOV -i LS101274.WAV -filter_complex '[0:0] [0:1] [1:0] [2:0] atempo=1.0006, concat=n=2:v=1:a=1 [v] [a]' -map '[v]' -map '[a]' -c:v libx264 -c:a libfdk_aac -movflags faststart -threads 2 -preset ultrafast output3.mp4
[07:47] <blippyp> try that
[07:48] <Waraqa> blippyp: It doesn't work
[07:48] <Waraqa> [AVFilterGraph @ 0xb0d4c00] Too many inputs specified for the "atempo" filter.
[07:48] <blippyp> k - let me read that filter - hold on
[07:50] <blippyp> pastebin a the output for ffmpeg -i MVI_0022.MOV
[07:51] <blippyp> so I can see your streams
[07:51] <blippyp> oh wait - they're in the output
[07:51] <Waraqa> ok
[07:52] <blippyp> just give me a minute to try and figure out what you're trying to do
[07:53] <blippyp> okay - so you're trying to copy two video and two audio streams right?
[07:53] <blippyp> you want to join the video+audio of 0:0 and 0:1 with the video and audio of 1:0 and 2:0 right?
[07:54] <Waraqa> Right
[07:54] <blippyp> so what's with the atemp filter?
[07:54] <blippyp> atempo
[07:55] <blippyp> you're trying to speed up the audio?
[07:55] <Waraqa> the audio from 2:0 has different speed
[07:55] <blippyp> for both concatenations?
[07:55] <blippyp> however you're suppose to phrase that...  ;)
[07:55] <Waraqa> No, for only the second audio stream
[07:55] <blippyp> k
[07:56] <kcynice> hello, blippyp, i have tested, ffmpeg can display perfectly, just no pts, fast playing
[07:57] <blippyp> ffmpeg -t 16.35 -i MVI_0022.MOV -ss 16.45 -i MVI_0022.MOV -i LS101274.WAV -filter_complex '[0:v] [0:a] [vid1]; [1:v] [2:a] atempo=1.0006 [vid2]; [vid1][vid2] concat" -c:v libx264 -c:a libfdk_aac -movflags faststart -threads 2 -preset ultrafast output3.mp4
[07:58] <blippyp> try that
[07:58] <blippyp> hi kcynice - I remember your name, but I apologize I don't remember what we spoke about last.... ???  can you refresh my mind? Also - paste a copy of your command and output for me...  ;)
[07:59] <blippyp> I'm sorry - I have a horrible memory for people...  :(
[07:59] <kcynice> oh, i just want to output decoded video frame into xvideo
[08:00] <blippyp> oh yeah.... the delphi guy right?
[08:00] <Waraqa> blippyp: There are some open quotes
[08:00] <kcynice> i found ffmpeg command also can play a video, just frames one by one, as quickly as possible
[08:00] <blippyp> oh - i used  a double quote - you were using single quotes - change on of them to match
[08:00] <Waraqa> ok
[08:01] <blippyp> kcynice: that's cool - so it's working for you now?
[08:01] <blippyp> but you still can't set the PTS for 'speed play'????
[08:01] <kcynice> in fact, i had tried gstreamer, but i found its too complex for that
[08:02] <Waraqa> blippyp: [AVFilterGraph @ 0x9e75520] No such filter: ''
[08:02] <Waraqa> Error configuring filters.
[08:02] <blippyp> there's probably a function for that in the ffmpeg libraries...
[08:02] <blippyp> Waraqa - how big is your MOV file?
[08:02] <kcynice> might because the original file with no pts in it.
[08:02] <Waraqa> blippyp: 1.6 Gb
[08:03] <blippyp> k - forget that - give me a second to duplicate your streams so I can get the command working better for you...
[08:03] <blippyp> brb
[08:05] <kcynice> i just forgot the command, i will take another try, and i think i got the hint to output video via xvideo device
[08:09] <kcynice> i tested, it can play any video if it recognised it: ffmpeg -i test.avi -vcodec rawvideo -f xv o
[08:11] <blippyp> Waraqa: in your command you specified that you wanted to record 16:45 worth of time starting at 16:45 is that right?
[08:12] <blippyp> or did you make a mistake and meant for the first -t to be a -ss for a quick jump to that point?
[08:13] <Waraqa> I just want to sync MVI_0022.MOV video with LS101274.WAV audio
[08:13] <blippyp> duh - I just realized you were working with three seperate files... I'm such a dumb ass...
[08:14] <Waraqa> the first and second input are same
[08:14] <blippyp> but for the first file you specified that you wanted to 'fast forward' to 16mins and 45 seconds and then record 16mins and 45s of video/audio - is that correct?
[08:14] <Waraqa> it is 16.45 seconds
[08:15] <blippyp> just making sure - cause it just seems like a weird coincidence...
[08:15] <Waraqa> I want the audio stream from LS101274.WAV to start after 16.45 second
[08:15] <Waraqa> In fact, I'm sure the command is working perfectly If I remove the atempo filter
[08:16] <Waraqa> but since LS101274.WAV is recorded by a voice recorder which I always need to apply atempo=1.0006 to sync with camera input MVI_0022.MOV
[08:16] <blippyp> k, give a sec to try it
[08:19] <blippyp> no - it doesn't like it without the atempo either...
[08:19] <blippyp> let me try to re-work it
[08:20] <kcynice> to eat now, see u
[08:20] <kcynice> bye
[08:20] <Waraqa> blippyp: This is working for me ffmpeg -t 16.45 -i MVI_0022.MOV -ss 16.45 -i MVI_0022.MOV -i LS101274.WAV -filter_complex '[0:0] [0:1] [1:0] [2:0] concat=n=2:v=1:a=1 [v] [a]' -map '[v]' -map '[a]' -filter:a 'atempo=1.0006' -c:v libx264 -c:a libfdk_aac -movflags faststart -threads 2 -preset ultrafast output3.mp4
[08:20] <Waraqa> sorry
[08:20] <blippyp> so you're good?
[08:20] <Waraqa> ffmpeg -t 16.45 -i MVI_0022.MOV -ss 16.45 -i MVI_0022.MOV -i LS101274.WAV -filter_complex '[0:0] [0:1] [1:0] [2:0] concat=n=2:v=1:a=1 [v] [a]' -map '[v]' -map '[a]' -c:v libx264 -c:a libfdk_aac -movflags faststart -threads 2 -preset ultrafast output3.mp4
[08:21] <Waraqa> No, I need to a way to apply to atempo
[08:21] <Waraqa> Or I will reencode the audio file first
[08:23] <Waraqa> blippyp: If it will cause hassle to you, I will reencode the audio first to apply atempo
[08:23] <blippyp> that could be an easy fix - why don't you do that, while I try my way
[08:23] <Waraqa> Ok
[08:23] <blippyp> no - definitely - by all means...  ;)
[08:30] <blippyp> I think I got it - it's encoding now
[08:31] <blippyp> ffmpeg -i src.mkv -i src.mkv -i got.mp3 -lavfi '[0:0][0:1][1:0][2:0] concat=n=2:v=1:a=1 [v][audio]; [audio] atempo=1.0006 [a2]' -map '[v]' -map '[a2]' -c:v libx264 -preset ultrafast -c:a ac3 output3.mp4
[08:31] <blippyp> try that
[08:32] <blippyp> oops - but place your times in it... forget to re-work it for you...
[08:32] <Waraqa> no problem i'll do it
[08:32] <blippyp> k
[08:32] <blippyp> all you need is the filter anyways
[08:33] <blippyp> whether this will do what you want or not - I don't know - but it copied my streams right and in the right order....
[08:33] <blippyp> oh geez - I just realized something...
[08:34] <blippyp> you only wanted the audio of the wav file to have a temp change right?
[08:34] <Waraqa> yes
[08:35] <Waraqa> But it will be ok if it's applied to the whole audio since the begining is only 16 seconds
[08:35] <blippyp> up to you - It's not hard to change I don't think
[08:35] <blippyp> I'm doing now
[08:35] <Waraqa> Ok
[08:36] <blippyp> should be something like this:
[08:36] <blippyp> ffmpeg -i src.mkv -i src.mkv -i got.mp3 -lavfi '[2:0] atempo=1.0006 [a2]; [0:0][0:1][1:0][a2] concat=n=2:v=1:a=1 [v][a2]' -map '[v]' -map '[a2]' -c:v libx264 -preset ultrafast -c:a ac3 output3.mp4
[08:36] <blippyp> yeah I think that will work
[08:36] <blippyp> mine's encoding
[08:36] <Waraqa> I'll try now
[08:36] <blippyp> k
[08:37] <blippyp> if you leave the -preset ultrafast in, it will encode it really fast for you
[08:37] <Waraqa> I'll change it later
[08:37] <blippyp> you'll want to re-do it again after you know it's right - but you should probably leave that in
[08:38] <Waraqa> I agree
[08:40] <blippyp> oh - i just notice that I lef the a2 as a2 - not sure if that will cause any issues, it encoded for me without complaints but I'd change that just to be sure...
[08:40] <blippyp> like this:
[08:40] <blippyp> ffmpeg -i src.mkv -i src.mkv -i got.mp3 -lavfi '[2:0] atempo=1.0006 [a1]; [0:0][0:1][1:0][a1] concat=n=2:v=1:a=1 [v][a2]' -map '[v]' -map '[a2]' -c:v libx264 -preset ultrafast -c:a ac3 output3.mp4
[08:42] <Waraqa> I always get this error: [AVFilterGraph @ 0x9cc4c00] No such filter: ''
[08:42] <blippyp> did you copy and paste the filter?
[08:43] <blippyp> check at the end of the filter just before the ' or " - is there a semi colon on the end of the [a2]?
[08:43] <Waraqa> no I change my original command
[08:43] <blippyp> if there is remove it
[08:43] <blippyp> that's usually what that error means for me
[08:43] <blippyp> if not - paste you command into irc so I can see it
[08:44] <Waraqa> right :)
[08:44] <Waraqa> It is now encoding
[08:44] <blippyp> cool - did you change two of the a2's? like i said?
[08:44] <Waraqa> yes
[08:44] <blippyp> cool
[08:44] <blippyp> not sure if it would actually make a difference though - like I said mine didn't error...
[08:45] <blippyp> I always rename the streams as I go...
[08:45] <blippyp> much easier to follow...  ;)
[08:49] <Waraqa> blippyp: Thank you
[08:49] <blippyp> cool works?
[08:50] <Waraqa> Yes
[08:50] <blippyp> awesome :)
[08:50] <blippyp> np
[08:52] <Waraqa> blippyp: Are you an ffmpeg developer?
[08:54] <blippyp> no - just a hobbyist  ;)
[08:54] <Waraqa> You are so kind to spend this trying to help
[08:55] <blippyp> thx, but I enjoy it - and I learn tons from it... ;)
[08:55] <blippyp> it's not completely selfless... haha
[19:37] <SpecialEd> Hey guys, I transcode a lot of flash video files to x264/mp4 and I've been plagued with my terminal shell getting spammed with the following output:
[19:37] <SpecialEd> [h264 @ 0x39b2500] missing picture in access unit with size 40
[19:37] <SpecialEd> [h264 @ 0x39b2500] AVC: nal size 21102622
[19:38] <SpecialEd> The videos transcode just fine so I was wondering if there is any way I can quiet ffmpeg down a bit? I use Ubuntu 14.04LTS Server 64bit if that helps..
[19:39] <SpecialEd> also, what makes it even stranger is that its not on every single flash video I transcode to mp4, only like half of them and theres no rhyme or reason for it as far as I can tell...
[19:40] <klaxa> if you installed ffmpeg via your package management, you are in fact using avconv. see #libav
[19:40] <SpecialEd> nope :) I compile manually
[19:44] <klaxa> so far so good, you can adjust the -loglevel parameter to change verbosity
[19:44] <klaxa> see -loglevel under http://ffmpeg.org/ffmpeg.html#Generic-options
[19:49] <SpecialEd> bingo that did it thank you so much!
[20:27] <__odie> i'm trying to stream webm over udp like this: http://pastebin.com/qtCC6SR0
[20:27] <__odie> but i cant get it to work (like in the pastebin)
[21:35] <blippyp>  % getmetatable("").tostring = tostring; getmetatable("").print = print; setmetatable(_G,{__mode="v"}) collectgarbage("collect") return debug
[21:35] <blippyp> % print "hi"
[21:36] <blippyp> oops  ;0
[23:34] <diesel420> hi
[23:34] <sacarasc> Hey, diesel420. :D
[23:35] <diesel420> it isnt possible to cut videos at exact frames via ffmpeg, right?
[23:36] <diesel420> hey sacarasc
[23:43] <c_14> diesel420: I don't think you can give exact frames, but you can go down to the millisecond which is usually enough.
[23:45] <diesel420> alright, thanks
[23:47] <diesel420> for x264 videos i have to cut at i-frames, iirc
[23:50] <c_14> Only if you use -ss as an input option or use -codec copy
[23:55] <Hello71> !xy
[00:00] --- Sun May  4 2014

More information about the Ffmpeg-devel-irc mailing list