[Ffmpeg-devel-irc] ffmpeg.log.20140506

burek burek021 at gmail.com
Wed May 7 02:05:01 CEST 2014

[02:20] <storrgie> I want to capture audio playing in flash (firefox on fedora) is there a way to attach to the pulse playback?
[02:21] <klaxa> ffmpeg -f alsa -i pulse out.ogg
[02:21] <klaxa> then open pavucontrol to select the correct recording device for ffmpeg in the recording tab
[02:21] <klaxa> change it to the monitor device of your soundcard
[02:22] <storrgie> pavucontrol? is that the gnome default sound manager?
[02:23] <storrgie> it appears to be listening on my microphone
[02:26] <klaxa> yes now with the volume control of pulse (pavucontrol) you can change the input for ffmpeg
[02:26] <storrgie> thanks klaxa
[02:26] <storrgie> that actually is really awesome
[02:26] <storrgie> I'm super impressed
[02:27] <storrgie> I love you
[06:43] <sony> Hi.
[06:43] <Guest72492> Is there a way to use Ffmpeg to use an analog TV tuner as the input?
[07:02] <kode54> does the Apple Intermediate Codec decoder support interlaced video?
[07:02] <kode54> I tried using it to decode some interlaced video a month ago or so, and it had horrible ghosting artifacts around things
[07:23] <kode54> nm
[07:23] <kode54> maybe I used the wrong settings when I was deinterlacing this last time
[07:24] <kode54> I made the mistake of trying to compress it to huffyuv, and apparently the huffyuv version is incompatible with whatever the mac version of avidemux bundles
[07:27] <kode54> huh
[07:27] <kode54> the white text in this video still seems to have dark shadows around it
[07:49] <kode54> and it has some sort of banding effect every 8 scanlines or so
[07:53] <kode54> I'll just upload the video so someone here can poke and prod it :D
[08:03] <alsu> trying to transcode, I get "Unable to parse option value (null) as sample format"
[08:03] <alsu> transcoding just the video (by passing -na) lets it work properly
[08:05] <alsu> is there a way to get ffmpeg to just conitinue? liek by forcing the sample format, or telling it to just drop the audio, or whatever
[08:05] <alsu> *continue
[11:03] <kolizer> hello people
[11:04] <kolizer> I need help
[11:05] <kolizer> how overlay image on video?
[11:05] <AGSPhoenix_> it might be possible with the overlay filter: https://ffmpeg.org/ffmpeg-filters.html#overlay-1
[11:06] <AGSPhoenix_> I don't know how though
[11:22] <Mavrik> yes, overlay filter is used to make overlays :)
[11:34] <kolizer> ok
[11:36] <Caterpillar> I use FFMPEG on Fedora 20. Why in video streaming using a computer with a AMD Phenom II X4 965, FFMPEG uses SSE2 cpu capabilities instead of SSE4a provided by cpu? Could it be caused by compilation flags used in making the ffmpeg package?
[12:01] <JEEB> Caterpillar, if you mean the stats that x264 outputs when you initialize it, those list human-written optimized code paths, so either there is no fitting code paths, or the CPU is noted as one where the optimized code path is not faster than the SSE2 code path, or it's a bug :)
[12:04] <Caterpillar> JEEB: yes I meant the x264 output
[12:23] <anshul> what does -of xml option mean
[12:27] <ubitux> it's for ffprobe
[12:27] <ubitux> and it allows dumping the infornmation in xml
[12:27] <ubitux> it stands for "output format"
[12:29] <anshul> thanks ubitux
[12:39] <anshul> In one of report its written "regression since 29b9aee4", is this number represent commit number
[12:42] <anshul> are they first 8 digit or last 8 digit of commit
[12:48] <anshul> I got one matching commit with first 8 digit matching with that number,i am compiling code with that commit and with code previous to that commit
[12:48] <kolizer> -vf "movie=logo.gif [logo];[in][logo] overlay=10:10 [out]"
[12:48] <kolizer> what gif no movie?
[13:09] <kolizer> as overlay gif on video?
[13:19] <rsdrsdrsd> What is the best method to create a correct aspect ratio screenshot of a video
[13:19] <rsdrsdrsd> I have different aspect ratio videos, with different par, sar and dar. Now I need a command so that it always outputs a correct screenshot with a fixed height
[13:20] <rsdrsdrsd> I tried scale = ceil(height*dar):height:-1 but it seems that this doesn't always is good
[13:21] <sunny_>  hello sir
[13:21] <sunny_> i want to run ffmpeg library at online server
[13:21] <sunny_> how can i do it
[13:21] <sunny_> at hostgator
[13:22] <anshul> my guess was correct "regression since 29b9aee4" means first 8 byte of commit
[13:24] <sunny_> Is there anyone help me regarding ffmpeg php running on hostgator
[13:24] <anshul> sunny_, start with  compiling ffmpeg for your server
[13:35] <sunny_> how can i do it??
[13:36] <AGSPhoenix_> It's probably just be easier to download a precompiled binary
[13:36] <AGSPhoenix_> It'd*
[13:37] <AGSPhoenix_> http://ffmpeg.gusari.org/static/64bit/ffmpeg.static.64bit.latest.tar.gz
[13:38] <sunny_> it will work?
[13:38] <AGSPhoenix_> Probably
[13:45] <sunny_> i'm not able to do that
[13:45] <sunny_>  is there any another
[13:45] <sunny_> or guideline
[13:45] <AGSPhoenix_> Why does it not work?
[13:45] <AGSPhoenix_> That should be the easiest way
[13:46] <sunny_> i dnt knw
[13:47] <sunny_> it will work on the online server
[13:48] <anshul> your server have linux or windows
[13:48] <sunny_> linux
[13:48] <sunny_> server
[13:49] <anshul> 64 bit or 32 bit
[13:49] <sunny_> 32
[13:51] <anshul> is your kernel 3.2.x+,
[13:51] <anshul> to check uname -a
[13:52] <sunny_> 3.2.45
[13:52] <sunny_> linux kernel 3.2.45
[13:52] <AGSPhoenix_> oh, I linked him the 64 bit version
[13:52] <AGSPhoenix_> sorry
[13:52] <sunny_> Architecture	x86_64
[13:52] <AGSPhoenix_> so, it is 64 bit?
[13:53] <sunny_> its a 32 i guess
[13:53] <sunny_> its architecture x86_64
[13:55] <anshul> how do you guess? for 32 bit my uname show  Linux daku_daddy 3.7.10-1.28-pae #1 SMP Mon Feb 3 14:11:15 UTC 2014 (c9a2c6c) i686 i686 i386 GNU/Linux :)
[13:58] <sunny_> its x86_64
[13:59] <sunny_> ok may be i'm wrong now what i have to do
[14:09] <anshul> have u downloaded binary file AGSPhoenix_ asked
[14:10] <sunny_> yes i do
[14:10] <anshul> if yes then run that the executable using ./ffmpeg
[14:10] <anshul> why cany you do that
[14:14] <sunny_> where i have to run?
[14:51] <anshul> where you run uname -a
[14:53] <anshul> you need to get in the directory where ffmpeg is there
[14:53] <anshul> I think this is not the irc to teach linux, please ask help on linux question or type what you need on google
[15:47] <ale345354> Hello. I upgraded Ubuntu from 13.10 to 14.04 (maybe I should have not). Couldn't find ffmpeg so I found your guide in /http://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu/. I followed it 'till the end and all was ok, I converted some files perfectly. Now, after a couple of hours, I'm trying to do another conversion but it says again "Command not found". Why? Here's my pastebin log: http://pastebin.com/R48JJtKG
[15:48] <ale345354> Notice I did nothing, not even restarted the system or gnome session.
[15:51] <JEEB> probably your ffmpeg binary isn't in your PATH
[15:51] <JEEB> also you generally shouldn't have to set threads with x264
[15:52] <JEEB> and no, the components in 14.04 are better than in 13.10, so that upgrade is fine by itself :P
[15:53] <JEEB> and the reason it doesn't have ffmpeg by itself is because back in '11 or so it switched to libav from ffmpeg, and libav no longer has an ffmpeg binary. avconv is the binary that comes with libav
[15:53] <JEEB> the ffmpeg you had up to 13.10 was so old anyways, you would've not wanted to use it :)
[15:56] <ale345354> Hello JEEB and thanks for answerring me so quickly. What should I do to simply open a terminal, browse to the folder where ai have a file I want to convert it with ffmpeg and run a ffmpeg command?
[15:56] <JEEB> where's your binary?
[15:57] <JEEB> compare where your binary is against what `echo $PATH` (without the `s) tells you
[15:58] <ale345354> I think this is the real problem: after I followed your guide and converted some files on my desktop, I deleted the folders the installation created on my desktop (they are still in my bin), one of those is ffmpeg-git-20140506-64bit-static
[15:58] <JEEB> as long as you have the binary, that should be fine :P
[15:58] <JEEB> just compare where the ffmpeg binary is
[15:58] <JEEB> against your PATH
[15:58] <JEEB> if it's not in PATH, you can open the dot-bashrc file in your home directory with a text editor
[15:59] <JEEB> and add "export PATH=/where/your/ffmpeg/binary/is:${PATH}" to the end of it :P
[15:59] <ale345354> wait a second, I'm not that good but I think the solution is at my hand. I wrote echo $PATH in my terminal and it said /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games
[16:00] <JEEB> yeah, that's your PATH
[16:00] <JEEB> and I guess the directory that has your ffmpeg binary is not in it, right?
[16:00] <JEEB> time to modify your dot-bashrc to add it to it :)
[16:00] <ale345354> yes because it is on my desktop, inside the folder ffmpeg-git-20140506-64bit-static
[16:01] <JEEB> and then open a new terminal, and the new PATH should be set
[16:02] <ale345354> ok, I think I'll move the folder where my ffmpeg binaries are, into my /home
[16:04] <ale345354> and now I'm adding "export PATH=/home/ale/ffmpeg-git-20140506-64-bit-static:${PATH}" without the " 's at the end of my .bashrc file which is in my /home
[16:04] <ale345354> right?
[16:06] <JEEB> yes, dot-bashrc
[16:06] <JEEB> it shows up in the directory browser if you enable "show hidden files"
[16:06] <JEEB> essentially stuff that starts with a dot is "hidden"
[16:07] <ale345354> Ah-aaahhhh IT WORKS :DDDDDDDDDD
[16:07] <ale345354> Thank you so so so so much JEEB
[16:07] <JEEB> np
[16:07] <JEEB> basics on all systems :) If something is not in your PATH, it has to be called with the full path to the binary
[16:08] <JEEB> (or relative path, yes)
[16:08] <ale345354> time to do some conversions :) thanks again and have a nice day
[16:41] <damorrison> Hi
[16:41] <damorrison> Anyone know a way of using an output files variables (i.e. height, width etc) in the output file name?
[16:45] <Hello71> call ffprobe
[16:50] <damorrison> thanks - I'll take a look
[16:55] <watsonkp> Im having a problem transcoding to H.264 in mp4 programmatically. The resulting file will play properly in Chrome and VLC, but refuses to open in Safari/Quicktime. Ive tried to use the transcoding.c and remuxing.c examples, but the problem persists.
[16:55] <watsonkp> Ive parsed out the atom structure of the resulting file and compared it to a functioning file from ffmpeg. The difference seems to be the avcc atom, particularly the SPS fields.
[16:55] <watsonkp> This atom seems to be written with ff_isom_write_avcc during the av_write_trailer call, but I have so far failed to determine where the data it is writing is coming from, and how Im getting that wrong.
[17:40] <f0lder> how do i mux h264 video in a mp4 container with aac audio in another mp4 container to a mp4 container?
[17:41] <f0lder> i tried "ffmpeg -i audio.mp4 -i video.mp4 -acodec copy -vcodec copy mux.mp4" but its async
[17:52] <c_14> Statically async, or dynamically async?
[17:53] <c_14> If it's static, try -itsoffset
[17:57] <f0lder> hard to say, the difference is huge and throughout the video
[17:59] <f0lder> looks like the reason for that is the source vid being too fast however that happened
[18:15] <c_14> How big is huge?
[18:19] <another> c_14: very big
[18:49] <Voicu> hello, I see that av_open_input_stream is not usable any more. What is the alternative? I'm trying to read a stream of in memory data
[18:51] <Voicu> never mind
[19:01] <JEEB> Voicu, you probably noticed how you create your own io context and the read/seek functions :)
[19:01] <Voicu> yes yes :D
[19:02] <JEEB> funny enough the first thing I coded with lavf/lavc contained just that
[19:02] <JEEB> mapping Windows IStreams so that they can be read with lavf :D
[19:03] <Voicu> yeah, there are tutorials for just that
[19:03] <Voicu> my thing is more convoluted
[19:30] <f0lder> just re-encoded the video with another encoder, that fixed the issue c_14
[19:30] <f0lder> thanks anyway
[21:08] <RoyK> hi all. anyone that knows how I can use ffmpeg/avconv to garble audio files for (somehow) anonymizing them?
[21:14] <RenatoCRON> RoyK, why can't just crypt and keep the file name equals? or I don't understand what you want to do.
[21:15] <aphirst> Hi there, I just mentioned this to #archlinux and they thought it would be worth mentioning here too. Since updating to 2.2.2, some videos using FLAC audio (i.e. which use high CPU amounts) have audio skipping and popping. [continued]
[21:16] <aphirst> I thought it was just an ffmpeg bug, because it worked again when I downgraded to 2.2.1; BUT if I build 2.2.1 from source I get the same problematic behaviour. [continued]
[21:16] <sacarasc> RenatoCRON: I think they want to do voice distortion.
[21:16] <aphirst> I believe the issue is in fact due to being compiled with GCC 4.9.0, which hit the main Arch repos recently.
[21:17] <JEEB> aphirst, gcc 4.9.0 is broken
[21:17] <RenatoCRON> sacarasc, oh! now it make sense!
[21:17] <aphirst> But I'm in the sticky situation of not having one single person to blame.
[21:17] <RoyK> RenatoCRON: not likely. I want to distort voice so that the file can be stored for later use without the person being identified again
[21:17] <JEEB> blame your distro for switching to it
[21:17] <aphirst> JEEB, yeah, I read that a lot of things didn't compile properly with 4.9.0
[21:17] <JEEB> yeah, but this was poked at gcc
[21:17] <JEEB> and this doesn't seem to be a case of bad code
[21:17] <aphirst> JEEB, Oh, have others mentioned this already?
[21:17] <aphirst> (or something analogous)
[21:17] <JEEB> yeah, when 4.9.0 was released @ GCC
[21:18] <aphirst> specifically ffmpeg having issues?
[21:18] <JEEB> yes, ffmpeg's flac gets miscompiled
[21:18] <JEEB> gcc fixed it
[21:18] <JEEB> but of course they don't fix their releases out of release schedule :P
[21:18] <alsu> heaven forbid things work for the duration
[21:18] <JEEB> ffmpeg has broken many times because of bad coding practices; this seems to be one of the few cases where the compiler side says they're wrong
[21:19] <sacarasc> Isn't just about every x.x.0 GCC broken?
[21:19] <JEEB> sacarasc, yeah -- they're pretty much betas
[21:19] <JEEB> and any distro that uses a .0 release is bound to have trouble
[21:19] <aphirst> GCC fixed it you say? So I "just" have to wait for a point release?
[21:19] <JEEB> aphirst, or make your distro merge that patch :P
[21:19] <JEEB> for the gcc package
[21:19] <JEEB> http://gcc.gnu.org/bugzilla/show_bug.cgi?id=60902#c25
[21:20] <JY`_> don't you have a gcc-config for switching compiler ?
[21:20] <JEEB> found the gcc ticket
[21:21] <RenatoCRON> RoyK, I never used ffmpeg to do anything with audio, but I guess that you can get the audio, speed-up a little bit (like 1.4x),but keep the time the same, then run again, slowing the voice the same amount.
[21:21] <aphirst> JEEB, I'll just downgrade ffmpeg from the repo for now, then
[21:21] <JEEB> yeah
[21:22] <JEEB> never update to .0 releases with GCC if only possible
[21:22] <JEEB> both projects and GCC itself usually have problems
[21:22] <JY`_> my teacher used to say "bad tool, bad worker"
[21:22] <RoyK> RenatoCRON: that won't garble it. it's reversable
[21:22] <RenatoCRON> when you speed up, save, the voice will be more 'thin, high voice', so you just need back to normal speed, and the voice will be disfigured.
[21:22] <RenatoCRON> hmm, =/
[21:23] <iive> RoyK: you may want to try audacity
[21:23] <JEEB> but yeah... kind of surprising that this time it was GCC that was to blame, generally you just find lulzy code where GCC starts breaking things, and you fix your code :)
[21:23] <RoyK> iive: know any plugins there that can do it?
[21:23] <aphirst> JEEB, well, Arch updates almost everything, my impression is that (outside of specific project's developers) a lot of the people finding early bugs are Arch or Gentoo users
[21:24] <aphirst> so I suppose there's some utility in there being early adopters
[21:24] <RenatoCRON> i vote to audacity too, even dunno what you need to do to really annoyn it.
[21:24] <JEEB> true, but you should do that knowingly
[21:24] <JEEB> so you don't end up with broken software :)
[21:25] <iive> RoyK: audacity comes with lots of different plugins, give them a try.
[21:26] <RoyK> just wanted to know if you knew which one could do it :P
[21:26] <aphirst> JEEB, "knowingly"
[21:26] <JEEB> aphirst, as in, if you updated to a .0 release of gcc, you must note that something will most probably break
[21:27] <aphirst> JEEB, I did note it, which is why I'm not spazzing the fuck out :P
[21:27] <JEEB> :)
[21:27] <aphirst> I just thought I would report what I saw
[21:27] <JEEB> also, #ffmpeg-devel is generally a better channel to poke regarding things like that
[21:27] <JEEB> just for future reference
[21:27] <aphirst> fair, without (slowly) loading channel lists its not always obvious that there's a -devel channel too
[21:28] <JY`_> gentoo is still un 4.7 stable and 4.8 unstable btw
[21:28] <RenatoCRON> RoyK, https://whyweprotest.net/community/threads/how-to-make-your-own-voice-filter.45272/ and http://wiki.audacityteam.org/wiki/Automation
[21:28] <iive> maybe we should add gcc x.y.0 check in the configure?
[21:28] <JEEB> JY`_, and that on the other hand is taking it way too seriously :D
[21:29] <aphirst> I was generally quite looking forward to 4.9 since a couple of Fortran bugs which were irritating me were fixes
[21:29] <aphirst> *d
[21:29] <JEEB> I think I moved to 4.8 either during 4.8.1 or 4.8.2
[21:29] <JEEB> not sure
[21:30] <JY`_> last 4.8 is even masked
[21:30] <aphirst> 4.8.2 felt like it was around for *ages*
[21:31] <JY`_> well multislot gcc installation is useful
[21:31] <JEEB> JY`_, well gentoo's "stable" definitions are often rather loaded :)
[21:31] <JEEB> heavy preference or just no-one caring
[21:32] <RoyK> RenatoCRON: the intonation isn't changed. it's identifiable
[21:33] <RoyK> RenatoCRON: that's what makes anonyfying audio so hard
[21:33] <RenatoCRON> RoyK, well, so I dunno what to do! I will be grade to know how you solve this when you're done!
[21:33] <JEEB> did you mean: anonymizing
[21:34] <RenatoCRON> just for knowledge!
[21:34] <RoyK> RenatoCRON: will post if I make it
[21:34] <RoyK> it's so much in speech that's identifiable, it's almost impossible
[21:34] <RoyK> you have the accent/dialect, the tone of voice, the intonation, the changes of level
[21:35] <RoyK> et cetera
[21:35] <RoyK> et cetera et cetera ad infinitum :P
[21:39] <RenatoCRON> RoyK, now i'm only thinking and taking pity for the people who were on TV talking ~anonymously~, sitting back in a dimly lit room.
[21:39] <pisto> how do I negate a condition in -filter select?
[21:40] <RoyK> RenatoCRON: so do I
[21:52] <tclarke> trying to mux 2 h.264 annex b streams into a single mpegts and I'm getting "first pts value must be set"
[21:53] <tclarke> command line: ffmpeg -i stream1.h264 -i stream2.h264 -vcodec copy -an -map 0:v -vcodec copy -an -map 1:v -f mpegts -fflags +genpts out.ts
[21:53] <kolizer> how to create news ticker and overlay him on video ?
[21:56] <tclarke> kolizer: you could create an srt file and add it as a subtitle stream
[21:57] <tclarke> also look here: http://trac.ffmpeg.org/wiki/HowToBurnSubtitlesIntoVideo
[21:57] <kolizer> cool info
[22:12] <kolizer> tclarke: it works) thanks
[22:28] <kolizer> a how overlay gif on video?
[22:32] <kolizer> help
[22:37] <Caterpillar> http://superuser.com/questions/750519/ffmpeg-webcam-stream-to-youtube-drops-frames
[22:37] <Caterpillar> if you have some suggestions..
[22:39] <sacarasc> Can you record from webcam to file?
[22:40] <kolizer> a how overlay gif on video?
[22:41] <sacarasc> You need to use the overlay filter, I think, kolizer. Which is beyond my understanding. http://trac.ffmpeg.org/wiki/FilteringGuide might be able to help you.
[22:44] <kolizer> sacarasc: no(
[22:45] <alsu> during transcoding, I get [abuffer @ 0x7fef0ac13080] Unable to parse option value "(null)" as sample format
[22:46] <alsu> is there a way to force the sample format, or simply discard the audio when (and only when) this happens?
[22:46] <alsu> the file does correctly transcode with -na, but I only want to do that if the sample format detection has failed
[22:54] <kolizer> People help! how overlay gif on video?
[22:58] <kolizer> -vf "movie=logo.gif [logo]; [in][logo] overlay=main_w-overlay_w:main_h-overlay_h [out]"
[22:59] <kolizer> NO WORKS~!
[23:02] <kolizer> Sorry it works! IT WORKS!!!!!!! AAAAAAAAA
[23:07] <BlackBishop> for libx264 what does a -preset slower ofer ? ( compared with fast for example ) in terms of quality and filesize ?
[23:08] <JEEB> everything slower than medium enables step by step various functionality that enables for better compression
[23:09] <JEEB> you should generally just pick the slowest preset that still is fast enough for your use
[23:10] <BlackBishop> so .. everything < medium is better compression .. that means lower file size and (same or good) quality, right ?
[23:10] <BlackBishop> (same or better)*
[23:10] <JEEB> well, one of those things, yes. I will just have to note that the same CRF value only means the same thing with the same settings
[23:11] <JEEB> so you can't compare the results with the same CRF value across presets
[23:11] <BlackBishop> I didn't set any crf :)
[23:11] <JEEB> if you didn't set any rate control option, the default is crf 23
[23:12] <JEEB> which is the libx264 default
[23:12] <JEEB> if you set some rate control option(s), the last of those gets used :P
[23:13] <BlackBishop> nope, only set preset (medium) acodec vcodec and that's about it
[23:13] <JEEB> then it's crf 23
[23:19] <BlackBishop> oh well, since it's a mpeg2 iso .. the source isn't so great at visual quality ..
[23:19] <sacarasc> MPEG2 iso? So a DVD?
[23:19] <BlackBishop> yeah
[23:28] <BlackBishop> oh well, from 1.9G iso to 520M mkv much better .. with the normal preset .. and it didn't seem to loose much detail .. ( or at all infact )
[23:28] <BlackBishop> I'm trying the "slower" preset now see how that goes
[23:28] <JEEBsv> well, just don't expect slower presets automagically giving you smaller file sizes
[23:29] <JEEBsv> because the definition of the CRF value changes with settings used
[23:29] <BlackBishop> ok
[23:44] <kevix> newbie here: is this a place to ask about rtmpdump issues? or not, where?
[23:44] <kevix> "ERROR: HandleCtrl: SWFVerification Type 2 request not supported! Patches welcome...
[23:44] <kevix> "
[23:45] <sacarasc> It is quite obvious, that type of verification isn't supported.
[23:46] <kevix> I dont know if it might be related to a missing dependency or its code that is not yet written
[23:47] <kevix> I was using get-flash-videos before with Hulu and it now gives this.
[23:48] <sacarasc> Try #mplayer, as I think rtmpdump is an MPlayer side project.
[23:48] <kevix> ok thanks
[00:00] --- Wed May  7 2014

More information about the Ffmpeg-devel-irc mailing list