[Ffmpeg-devel-irc] ffmpeg.log.20140507

burek burek021 at gmail.com
Thu May 8 02:05:01 CEST 2014

[02:44] <Na_Klar> why does a convert to dpx rgb48le image sequence fails with "Video encoding failed"? (ffmpeg 0.7.6-4:0.7.6-0ubuntu0.11.10.3)
[02:51] <iive> it is probably libav fork and it is very old.
[02:52] <afflicto> Hello everyone. How can I instruct ffmpeg to record a pulseaudio null-sink?
[02:53] <afflicto> Right now I do "-i hw:0,0" to grab the default input device.
[02:55] <Na_Klar> iive, would you be kind enough to check your ffmpeg version for dpx rgb48le encoding?
[02:55] <iive> what is your command line?
[02:56] <Na_Klar> ffmpeg -i test.mov -an -vcodec dpx -r 24 -pix_fmt rbg48le -f image2 ./%04d.dpx
[02:58] <iive> ffmpeg -pix_fmts |grep rgb48le
[02:58] <iive> IO... rgb48le
[02:58] <Na_Klar> i have that too
[02:58] <Na_Klar> rgb
[02:58] <Na_Klar> yeah, typo (here not in my cli)
[03:00] <iive> Unknown pixel format requested: rbg48le
[03:00] <iive> let me take a look.
[03:00] <iive> rgb ?
[03:00] <Na_Klar> yeah it's rgb .. not rbg .. that was a type (here in the iirc, not in my cli)
[03:00] <iive> rgb48le works
[03:00] <Na_Klar> really?
[03:01] <Na_Klar> that's good to know .. then it's my ffmpeg version .. fine
[03:01] <Na_Klar> ty
[03:01] <iive> well, mine is 2.2.0 yours is 0.7.6
[03:02] <Na_Klar> it's actually a bit newer .. ubuntu has some weird versioning for its ffmpeg forks ..
[03:02] <Na_Klar> but older that 2.2 obivously
[03:03] <iive> libav 9.13
[03:03] <iive> seems to be the latest fork release.
[03:04] <iive> i guess, they dropped the leading zero
[03:05] <Na_Klar> yeah, so i have 7.6 here ..
[03:06] <Na_Klar> besides ubuntu moved to avconv since 12.04
[03:06] <sacarasc> It's only since (0.)9.x that they've done that. You've got good old 0.7.6...
[03:06] <sacarasc> That's the fork iive's been talking about.
[03:07] <Na_Klar> ic
[03:07] <iive> btw, try avconv, they (libav) keep an older ffmpeg build and update their renamed program instead.
[03:07] <afflicto> I need some help with audio glitches, I'm streaming it here: http://twitch.tv/dreamvoid - here's the ffmpeg command I use: http://pastebin.com/Wh6tdnmC
[03:11] <bencc> what are the settings I need for converting raw video to be played on html5 on ios and android?
[03:11] <Na_Klar> iive, yeah, i'll try. btw, is there a pix_fmt to convert to a plain 10bit per channel dpx? rgb48 are 16bits per channel.
[03:11] <bencc> this should work?
[03:12] <iive> afflicto:  this is quite interesting glitch.
[03:12] <bencc> ffmpeg.exe -ss 00:04:00 -t 1:44:55 -i output.mkv -c:v libx264 -preset medium -crf 23 -vf crop=iw:ih-120:y=0,format=yuv420p -vf scale=1024:672 -c:a aac -strict experimental -b:a 96k -movflags +faststart output.mp4
[03:12] <afflicto> iive: mhm. I believe it works fine if I just stream hw:0,0
[03:13] <iive> afflicto: then it is most likely pulse audio bug. I blame it for every audio related problem, until proved otherwise :|
[03:13] <afflicto> iive: hm :\
[03:13] <Na_Klar> bencc, to have a playable html video file for all (the most major) systems, you'll need a mp4, ogg and webm file. mp4 profile 4.1 is fine for the most. webm with vp8, ogg as usual.
[03:13] <iive> I was going to eliminate the variables.
[03:14] <sacarasc> bencc: Does that not work?
[03:14] <iive> e.g. try to capture without video. try to save directly to pcm file .
[03:14] <afflicto> iive: Audio works fine using SimpleScreenRecorder though
[03:14] <bencc> mp4 works for me. I don't know what resolution I need
[03:15] <bencc> and if I also need to mess with the mp4 profile
[03:15] <afflicto> iive: what a dilemma. audio is glitchy with ffmpeg and video is glitchy with simplescreenrecorder :(
[03:16] <bencc> sacarasc: when I tried 1280x840 it didn't play on iphone 4S.
[03:16] <Na_Klar> bencc, for you means not for everybody .. but whatever. The resoloution is irrelvant for the playability.
[03:16] <iive> just try to isolate the problem.
[03:16] <sacarasc> bencc: http://developer.android.com/guide/appendix/media-formats.html https://developer.apple.com/library/ios/documentation/miscellaneous/conceptual/iphoneostechoverview/MediaLayer/MediaLayer.html
[03:16] <bencc> Na_Klar: are you sure that iphone 4S can play 1280x840? it didn't work in iphone and galaxy 3
[03:17] <Na_Klar> bencc, my samsung galaxy s4 can play 1920x540 mp4 h264 profile >=5
[03:17] <Na_Klar> s/1920x540/1920x810/
[03:17] <bencc> Na_Klar: so resolution does matter. you said 810 height but I tried 840
[03:17] <bencc> so is there a safe resolution I can use?
[03:18] <bencc> sacarasc: not sure how to translate this info to ffmpeg parameters
[03:18] <Na_Klar> bencc, in principal it's irrelevant. but if you want to go sure use factor of 16 or 4 or at least 2 for x and y
[03:19] <bencc> Na_Klar: what do you mean?
[03:19] <bencc> does 1024x672 supposed to work?
[03:19] <sacarasc> H.264 video, up to 1.5 Mbps, 640 by 480 pixels, 30 frames per second, Low-Complexity version of the H.264 Baseline Profile with AAC-LC audio up to 160 Kbps, 48 kHz, stereo audio in .m4v, .mp4, and .mov file formats
[03:19] <sacarasc> That's the highest Apple say works.
[03:20] <bencc> ok. so I need to encode in much lower resolution. I'll try it now
[03:21] <bencc> sacarasc: I need baseline profile?
[03:21] <sacarasc> That's what Apple says.
[03:21] <bencc> "Low-Complexity version of the H.264 Baseline Profile"
[03:21] <bencc> how do I enforce it with ffmpeg?
[03:21] <Na_Klar> bencc, it's devideable by 4. but - honestly - it should work anyways. resoloution is irrelevant.
[03:22] <Na_Klar> [apple is sh*t anyways .. just saying]
[03:22] <klaxa> bencc: you can enforce it in ffmpeg by using: -profile:v baseline
[03:22] <bencc> https://trac.ffmpeg.org/wiki/x264EncodingGuide#Compatibility
[03:23] <bencc> this says iPhone 4 supports main 3.1
[03:23] <bencc> but apple's docs says baseline profile. what should I believe?
[03:23] <bencc> what is the default profile ffmpeg use?
[03:26] <sacarasc> bencc: It depends how far back you want compatibility, I guess.
[03:27] <Na_Klar> 3.1 .. gosh .. that's far back
[03:28] <klaxa> 3.1 is level, not profile, right?
[03:28] <Na_Klar> right
[03:28] <sacarasc> Yes.
[03:28] <Na_Klar> profiles are like slow, very-slow, placebo ...
[03:28] <klaxa> no
[03:28] <klaxa> those are presets
[03:28] <Na_Klar> ups
[03:28] <Na_Klar> my fault
[03:28] <klaxa> profiles are baseline, main, high, high10, high444
[03:28] <Na_Klar> right
[03:29] <bencc> this sets the correct resolution but doesn't crop
[03:29] <iive> afflicto: seems fixed now
[03:29] <bencc> ffmpeg.exe -ss 00:04:00 -t 1:44:55 -i output.mkv -c:v libx264 -preset medium -crf 23 -vf crop=iw:ih-120:y=0,format=yuv420p -vf scale=1024:672 -c:a aac -strict experimental -b:a 96k -movflags +faststart output.mp4
[03:29] <afflicto> iive: it is? =D
[03:29] <afflicto> iive: YESS ;D
[03:29] <iive> no
[03:29] <bencc> is it wrong to use -vf crop... -vf scale ?
[03:29] <afflicto> iive: nope. it's not :(
[03:29] <klaxa> probably? put it in one -vf argument
[03:29] <iive> it goes fine for a while, then distorts.
[03:29] <klaxa> just do: -vf crop=iw:ih-120:y=0,format=yuv420p,scale=1024:672
[03:29] <bencc> klaxa: how
[03:30] <bencc> trying
[03:30] <afflicto> iive: yeah :\
[03:30] <iive> have you tried renice on pulse sound deamons?
[03:31] <iive> something else. try without -ar 44100
[03:31] <afflicto> renice?
[03:31] <afflicto> I can try without the -ar 44100 I guess
[03:32] <azk> Does FFserver check for X-Forwarded-For headers?
[03:33] <afflicto> iive: without the "-ar 44100" part, I get an error "incorrect codec parameters?"
[03:33] <iive> try with 48000
[03:34] <afflicto> iive: I get: Could not write header for output file #0 (incorrect codec parameters ?)
[03:34] <afflicto> iive: with 48000
[03:34] <iive> just a moment.
[03:35] <iive> try with -af aresample=44100
[03:36] <iive> most ac97 cards work at 48kHz, if you request 44,1kHz someone should resample the pcm.
[03:37] <iive> if pulse resample is buggy, or worse, it doesn't resample, then it might just drop samples.
[03:37] <afflicto> iive: I see
[03:38] <afflicto> so I replace "-ar 48000- with "-af aresample=44100" ?
[03:38] <iive> yes, try it.
[03:39] <afflicto> iive: unrecognized option 'af'
[03:40] <iive> hum, -af stands for audio filter...
[03:40] <iive> you might have old ffmpeg, or worse.
[03:40] <afflicto> iive: hm
[03:41] <iive> latest is 2.2.2 (or 9.13 in case of the fork)
[03:41] <iive> do you have avconv ?
[03:42] <afflicto> I dno
[03:42] <afflicto> yes
[03:42] <iive> just type it in the terminal.
[03:42] <afflicto> afflicto at afflicto-linux:~$ avconv
[03:42] <afflicto> ffmpeg version 0.10.9-7:0.10.9-1~raring1
[03:43] <iive> the libav fork provides old ffmpeg version that is not updated, instead they update their avconv utility. try replacing the ffmpeg with avconv in the script.
[03:44] <afflicto> ok
[03:44] <iive> I do recommend you to use latest real ffmpeg, but that might be quite a headache.
[03:44] <afflicto> It still won't recognize the -af option
[03:45] <iive> try with the old command.
[03:45] <afflicto> k
[03:46] <iive> so far so good.
[03:46] <afflicto> iive: I think it works =D
[03:46] <afflicto> iive: so what's this avconv thing? another version?
[03:46] <iive> nope.
[03:46] <afflicto> iive: oh god no :(
[03:46] <iive> it works for a few seconds.
[03:47] <afflicto> iive: yea :(
[03:47] <iive> try without threads 4
[03:47] <iive> x264 would use threads by default.
[03:47] <afflicto> k
[03:48] <iive> libav is fork of ffmpeg. they renamed the programs, aka ffmpeg-> avconv, ffplay->avplay etc..
[03:48] <afflicto> ok
[03:49] <afflicto> still glitchy
[03:49] <iive> but they left original ffmpeg in the package... that they don't develop or update.
[03:49] <afflicto> huh ok
[03:50] <iive> try -filter:a aresample=44100
[03:50] <afflicto> where should I put it? :P
[03:50] <iive> before mp3lame
[03:51] <afflicto> ok and remove -ar 44100 or?
[03:51] <iive> i mean, before -acodec
[03:51] <iive> yes, remove it.
[03:52] <afflicto> so like this: -filter:a aresample=44100 -acodec libmp3lame
[03:52] <iive> parameter position matters, maybe if you move -ar right after -i pulse. but let's test this later.
[03:52] <afflicto> It says "flv does not support that sample rate" >.<
[03:53] <iive> :O
[03:53] <afflicto> it continues: "flv does not support that sample rate"
[03:54] <afflicto> Oops, I mean "choose from (44100, 22050, 11025)
[03:55] <iive> strange, it does work for me :O
[03:55] <klaxa> try using a static build?
[03:55] <klaxa> or are you using x11grab?
[03:55] <afflicto> I am using x11grab yes
[03:56] <klaxa> yet another avconv bug?
[03:56] <iive> there is sound distortion.
[03:57] <iive> and pulse audio is involved.
[03:57] <iive> afflicto: put the -ar back and keep the aresample command.
[03:58] <iive> i mean, option...
[03:58] <afflicto> ok that works
[03:59] <iive> so far so good....
[03:59] <iive> nope...
[04:00] <iive> sorry, I got to go.
[04:00] <afflicto> ok
[04:00] <afflicto> well thanks for helping anyway!
[04:00] <iive> i hope somebody would be able to help you.
[04:01] <afflicto> I would guess someone has a solution.. somewhere
[04:02] <iive> try to capture just the audio, without encoding it and streaming it.
[04:02] <iive> just to make sure the input part is working.
[04:02] <iive> n8 ppl.
[04:23] <bencc> sacarasc: Na_Klar: lower resoultion works on the iPhone. thanks
[04:27] <allengreen> how to pass "continuity counter" when I muxing mpeg2 ts file?
[04:29] <allengreen> I am using av_write_frame and avio_open
[05:03] <allengreen> hey, fellows!
[07:42] <anshul> in nb_streams what does nb mean
[07:43] <anshul> got answer, didnt knew wherther it is user or developer
[07:43] <anshul> its number of
[07:54] <procfile> Hello all
[07:55] <procfile> I have a very high definition [probably 1080p] .mkv file sized at 1.5GB, I'd like to lower its quality to about 720p, and convert it to .ogg file, may I get some pointers for that?
[08:30] <relaxed> procfile: ffmpeg -i input -vf scale=1280:-1 -c:v libtheora -b:v 2000k -c:a libvorbis -ac 2 -b:a 128k output.ogg
[08:30] <procfile> I'll try that out, thanks!
[08:33] <procfile> relaxed: btw, does the above command work with .avi files too?
[08:34] <relaxed> change libtheora -> mpeg4 and libvorbis -> libmp3lame
[08:34] <procfile> No no, I meant from .avi to .ogg.
[08:34] <relaxed> oh, then yes
[08:35] <procfile> Ok
[09:55] <allengreen> hi
[09:57] <allengreen> crystalhd.c:746: undefined reference to `DtsProcOutputNoCopy'
[10:53] <allengreen> http://www.pasteall.org/47301
[11:06] <BlackBishop> Trying to convert from a .iso ( mpeg dvd ) to a mkv .. I did this http://pastebin.com/py5wSCvs .. but the audio gets left behind... any ideas on what I did wrong ?
[11:12] <relaxed> BlackBishop: install a recent version of ffmpeg
[11:14] <BlackBishop> hmm, relaxed http://packages.gentoo.org/package/media-video/ffmpeg says that's the latest stable in their mind .. which one do you recommend ?
[11:15] <relaxed> ffmpeg.org says the latest stable is 2.2.2
[11:16] <JEEB> welcome to distro issues
[11:16] <relaxed> gentoo shouldn't have this issue
[11:17] <JEEB> new ffmpeg is most likely not yet installed by default because some packages just never get updated to new APIs
[11:17] <JEEB> no, gentoo is /not/ free of issues
[11:17] <JEEB> it makes some things simpler, but you still can't fix some shit that just hasn't gotten updated
[11:17] <relaxed> BlackBishop: Try this http://johnvansickle.com/ffmpeg/
[11:17] <JEEB> plus gentoo has some weird shit going on with the default 'stable' setup
[11:18] <JEEB> a lot of "By all means stable" stuff is not marked as such mostly because of "just because"
[11:18] <JEEB> I mostly saw it a few years ago with firefox
[11:18] <JEEB> they would just keep current - X version as stable
[11:27] <JEEB> BlackBishop, basically update your ffmpeg and see if the package management tells you that anything breaks
[11:27] <JEEB> I'd guess in most cases it shouldn't break anything
[11:27] <JEEB> unless you have some package that depends on the old lavc/lavf APIs
[11:29] <relaxed> BlackBishop: it could be because you're using an iso as input.
[11:33] <BlackBishop> relaxed: well, the content are video_ts/*.VOB and IFO and BUPs
[11:34] <BlackBishop> I'm trying with the one in the link you gave me now ..
[11:37] <relaxed> dump the stream with, mplayer -dvd-device input.iso -dumpstream -dumpfile output.vob
[11:37] <relaxed> then encode that with ffmpeg
[11:37] <relaxed> er,  mplayer -dvd-device input.iso dvd://1 -dumpstream -dumpfile output.vob
[11:38] <relaxed> or use some other dvd ripper
[11:38] <BlackBishop> dump: 12288 bytes written to 'output.vob'.
[11:39] <relaxed> try just dvd://
[11:41] <BlackBishop> one sec .. I'l try with the vobs in the video_ts folder .. just the ones I need/want
[11:41] <BlackBishop> The others are menus and stuff
[11:50] <BlackBishop> alot better
[11:57] <clever> i use cpdvd to copy a dvd, simple
[14:18] <plepere> if I want to transcode a H.264 video to HEVC, should I simply use : ffmpeg -i input.mp4 -vcodec hevc output.mp4 ?
[14:45] <spaam> plepere: replace -vcodec hevc with -c libx265
[14:45] <spaam> if you have support for libx265
[14:46] <plepere> isn't it in the main branch ?
[14:47] <spaam> plepere: yes. but did you enable it when you built ffmpeg ?
[14:48] <klaxa|work> maybe there is --enable-libx265?
[14:49] <plepere> didn't do that.
[14:49] <plepere> Thank you
[14:50] <plepere> I usually just stick with the default configure.
[14:51] <klaxa|work> the "default" configure doesn't enable any shared libraries afaik
[14:51] <klaxa|work> s/shared/external/
[14:55] <plepere> is there a simple command to grab libx265 in there or should I find it myself ?
[14:56] <klaxa|work> where is "in there"?
[14:57] <klaxa|work> your distribution should offer a package called x265 which should include the libraries needed to build ffmpeg against them
[14:57] <plepere> I've got a "x265 not found" error, so I guess I need to manually put x265 in shared/external
[15:02] <BlackBishop> should ffmpeg -i vts_08_1.vob -i vts_08_2.vob -i vts_08_3.vob -vcodec libx264 -acodec ac3 -sn -preset slower Test.mkv create an mkv with all 3 vobs ?
[15:03] <spaam> BlackBishop: concat ?
[15:05] <spaam> BlackBishop: ffmpeg -i concat:"intermediate1.mpg|intermediate2.mpg" ....
[15:05] <BlackBishop> ow
[15:05] <BlackBishop> ok
[15:22] <plepere> ok, I've got libx265. Compiled it, installed it, put the .so in usr/lib. in my ffmpeg folder, I did a make dist-clean, configure --enable-gpl --enable-libx265. and I've got a invalid encoder tpye 'libx265'
[15:23] <plepere> what did I miss ?
[15:23] <JEEB> I will have to guess that the configuration step went through well, and then you compiled
[15:23] <plepere> (I did do a make -j after the configure)
[15:23] <JEEB> did the configure script actually finish successfully :P
[15:23] <JEEB> and did the compilation finish successfully?
[15:23] <JEEB> if they did, then check if you're running the correct binary
[15:24] <plepere> the configure didn't say anything bad at me
[15:24] <JEEB> and the configure script did output libx265 as an encoder?
[15:25] <plepere> in the x265 build/linux folder, I have .a, .so and the x265 executable
[15:26] <plepere> should I put them all in the external/shared ?
[15:27] <JEEB> ...
[15:27] <JEEB> did you get the encoder listed in configure script's output?
[15:27] <plepere> it's in the external libraries lis
[15:27] <plepere> list
[15:28] <plepere> oh, might have forgotten --enable-encoder=x265 ?
[15:29] <Milos_SD> Hello... I pulled ffmpeg from git just now, and tried compiling it, but it fails with this error: libavutil/opencl.c:329:12: error: no previous prototype for init_opencl_mtx [-Werror=missing-prototypes]
[15:29] <Milos_SD>  inline int init_opencl_mtx(void)
[15:29] <Milos_SD> what can be the problem here?
[15:29] <JEEB> plepere, no -- that's OK
[15:29] <JEEB> --enable-libx265 should be enough
[15:29] <JEEB> if it's successfully listed in the enabled libs listing
[15:29] <plepere> JEEB, yes, libx265 is in the enabled encoders list
[15:29] <JEEB> ok
[15:29] <JEEB> now check if compilation finished correctly
[15:29] <JEEB> if all went fine
[15:30] <JEEB> if yes, then you are just running the wrong binary :P
[15:30] <plepere> even after doing a make distclean ?
[15:31] <plepere> ok, compiling done
[15:31] <JEEB> now you can run the just compiled thing with dot-slash-ffmpeg
[15:31] <JEEB> from the same directory
[15:32] <JEEB> otherwise it's up to how you install the binary and if you install it at all
[15:32] <JEEB> have fun
[15:32] <plepere> same
[15:33] <plepere> ./ffmpeg -i input.mkv -c libx265 output.mkv
[15:33] <plepere> invalid encoder type 'libx265'
[15:34] <JEEB> pastebin full ffmpeg output
[15:34] <JEEB> and link here
[15:34] <plepere> http://pastebin.com/r7kgQN7J
[15:34] <smo_> hi who knwo how to compile a full libffmpegsumo.so for chromium with all latests codecs (xvid/avi,opus/h264/ac3/vp9...) ?
[15:35] <JEEB> plepere, what about -c:v libx265 :P
[15:35] <plepere> better.
[15:35] <plepere> :D
[15:36] <plepere> 5.7fps. not bad
[15:36] <JEEB> yeah, libx265 is after all a video encoder
[15:36] <JEEB> yeah, x265 is not slow with the defaults, too bad it just plain sucks :P
[15:36] <plepere> what do you mean ?
[15:36] <JEEB> quality-wise
[15:36] <JEEB> you'll have to use preset placebo and max out refs and bframes to get some performance out of it
[15:37] <JEEB> and even so, as soon as you leave the "so low bit rate that both kind of suck" area
[15:37] <JEEB> x264 actually can start winning in some cases :P
[15:37] <JEEB> in PSNR and SSIM x265 will most probably win, though
[15:37] <plepere> isn't it possible to choose the wanted bitrate ?
[15:38] <JEEB> yes, but I don't recommend 1pass ABR
[15:38] <JEEB> the best quality rate control mode that is ABR is currently CRF with x265
[15:38] <JEEB> 1pass bitrate based ABR just sucks
[15:38] <JEEB> and x265 has no 2pass
[15:39] <plepere> ok
[15:40] <JEEB> the last time I did testing was --preset placebo --crf 32 and then I maxed both refs and bframes to 16. Then I matched x264 by the resulting bit rate
[15:40] <JEEB> for whatever reason preset placebo didn't max out those two
[15:40] <plepere> and subjective quality, was HEVC better ?
[15:41] <JEEB> the result was ~415kbps with 720p24, and they both more or less sucked. But yes, at very low bit rates x265 beats x264, but is also ~10x slower (than preset placebo)
[15:42] <JEEB> Also there's no question about HEVC being better in the end, it's a newer format. What I'm trying to say is that unfortunately the use cases for HEVC encoders _right_now_ is rather small
[15:42] <plepere> x264 has the benefit of having much more iterations for quality and performance optimizations.
[15:42] <JEEB> naturally
[15:42] <JEEB> x265 will probably always be more slow, though, since it is after all a more complex format (while the specification is simpler than AVC's in many places)
[15:43] <plepere> well I'm working on just HEVC decoding, so it's not much of my problem. :) I've got the easy part.
[15:43] <JEEB> yeh
[16:08] <Voicu> what could be the reason for a stream not having a proper codec after I open it?
[16:09] <Voicu> i.e. I'm following the tutorial here http://www.codeproject.com/Tips/489450/Creating-Custom-FFmpeg-IO-Context and I managed to get the stream open but the context doesn't have the codec setup (it's NULL)
[16:09] <Voicu> reading packets works
[16:11] <Voicu> they get proper DTS and PTS and probe_format produces the proper format
[16:11] <Voicu> so I don't know why the codec itself is NULL
[16:16] <Voicu> here's the code: http://pastebin.com/rEi01vdp
[16:56] <Voicu> no idea from anyone?
[16:57] <Voicu> I've been working on this streaming thing for almost a month
[17:24] <BtbN> Is there a recommended ppa to get a recent ffmpeg version(>=2.1) to ubuntu?
[17:30] <sacarasc> I think that's what's usually recommended, BtbN.
[17:30] <BtbN> those are not debian packages
[17:31] <sacarasc> Either that or compiling yourself, because of all the things that use libav as dependencies, it would be a lot of trouble to do it. :p
[17:31] <BtbN> i need them as dependency in my ppa
[17:31] <BtbN> there are ffmpeg ppas out there, a lot of them.
[18:07] <tlhonmey> Hello, I'm trying to recover some video data where the header information was stored in one set of files and the actual stream data was stored elsewhere.  The headers have since been lost, so I'm looking for a way to figure it out from the stream.  Before I start on a script to just apply brute-force to it, I figured I'd ask if anyone here knows of any good analysis software.
[18:07] <tlhonmey> Google is kind of failing me as there's far too much noise in every search I've been able to think of.
[19:20] <I_can_FLY> I am trying to set up a livestream with ffserver and ffmpeg. The problem is I am trying to use webm, and I need to bun in subtitles, which are located in a mkv. I am not quite sure how to do this, but here is my attmept at it: https://gist.github.com/FLY-chan/2379a35023a424dd2538 and here is my output: https://gist.github.com/FLY-chan/2f0a25e2b967c28399af
[19:21] <I_can_FLY> If someone could help, that would be great.
[19:49] <smo_> is it possible to just build a ffmpegsumo.so from ffmpeg src ?
[19:49] <smo_> (for node-webkit/chromium/chrome)
[20:42] <Maverick|MSG> is there a master list of all pixel_formats that'll work with ffmpeg?
[20:49] <Mavrik> Maverick|MSG, ffmpeg -pix_fmts will list them
[20:49] <Maverick|MSG> thanks
[20:49] <Mavrik> of course, each codec has it's own list of formats it supports
[20:55] <Maverick|MSG> trying to follow the instructions here https://trac.ffmpeg.org/ticket/3614
[20:55] <Maverick|MSG> but having a hard time following what ceyoyos said in the last few replies
[21:12] <Maverick|MSG> is he saying I should use -f image2pipe -vcodec rawvideo ?
[23:10] <Maverick|MSG> anyone know how to calculate a frame_size based on the width and height of an image?
[00:00] --- Thu May  8 2014

More information about the Ffmpeg-devel-irc mailing list