[Ffmpeg-devel-irc] ffmpeg.log.20140515

burek burek021 at gmail.com
Fri May 16 02:05:01 CEST 2014

[00:16] <aarobc> So I have freetype2 installed, but it's complaining that it isn't...
[00:17] <sacarasc> Did you install the dev files?
[00:18] <aarobc> pkg-config --modversion freetype2 outputs 17.1.11 so it's definitely there
[00:18] <sacarasc> What does the config.log say?
[00:19] <aarobc> reading it right now...
[00:21] <aarobc> sacarasc: https://gist.github.com/aarobc/671a3e716710655944ef
[00:22] <aarobc> well that's the end  of it.
[00:26] <aarobc> Okay, might be something with the configure arguments, because trying it with the arguements in the tutorial and it works fine
[00:28] <jedir0x> how long is ffmpeg.org going to be down
[00:31] <aarobc> well I guess the problem was it didn't like the idea of being static.
[00:31] <sacarasc> IIRC, to link statically, you have to have static libraries.
[01:56] <aarobc> ha ha! adding -j <cores> makes make go so much faster
[08:03] <kode54> wtf
[08:04] <kode54> I tried encoding with libvpx-vp9
[08:04] <kode54> and I got the error "Illegal instruction: 4"
[09:10] <mungustas> hi
[09:10] <mungustas> I want to make a gif from youtube video
[09:11] <mungustas> scratching my head how do I achieve these settings
[09:11] <mungustas> first 5 seconds, with total of 5 frames at final gif (for size)
[09:28] <ParkerR> mungustas, mplayer -vo gif89a -endpos 00:00:05 vid.mp4
[09:29] <ParkerR> http://stackoverflow.com/questions/6079150/how-to-generate-gif-from-avi-using-ffmpeg
[09:30] <ParkerR> -ss 00:00:00 -to 00:00:05 if using ffmpeg
[09:36] <mungustas> hmm :)
[10:41] <mungustas> hm ParkerR mplayer produces horribly looking gif from .flv
[10:57] <pzich> try using a combination of ffmpeg and imagemagik http://superuser.com/a/730389
[12:16] <anton02> im using this to go from mkv to mp4. The audio track is DTS. What additional stuff should i throw in there to go from dts to a more widely supported format? ffmpeg -i 777.mkv -c: copy blah.mp4
[12:23] <relaxed> anton02: aac or ac3
[12:23] <anton02> relaxed: ac3 i guess
[12:24] <relaxed> No, I meant mp4 supports ac3 and aac
[12:25] <anton02> relaxed: how do i reencode the audio track to ac3?
[12:25] <anton02> ill append the necessary flag to ffmpeg -i 777.mkv -c: copy blah.mp4
[12:25] <relaxed> add -c:a ac3
[12:26] <anton02> so -c: copy -c:a ac3
[12:26] <anton02> to indicate the copying of the video track
[12:26] <relaxed> -c:v copy -c:a ac3
[12:26] <anton02> thanks
[13:01] <mungustas> ParkerR: pzich: what I came with is this
[13:02] <mungustas> ffmpeg -i chelsea.flv -vf scale=540:-1 -r 1 -t 20 frames/ffout%03d.png   makes 20 png's
[13:02] <mungustas> convert -delay 80 -loop 0 frames/ffout001.png frames/ffout005.png frames/ffout009.png frames/ffout017.png output.gif
[13:03] <mungustas> stitches together some of those png's for result
[16:13] <Mathieu_Du> Hey folks !
[16:15] <Mathieu_Du> In gstreamer, the "lowres" option is exposed for h264 decoding, however the corresponding context attribute is deprecated and useless, and the recommandation is to use "decoder private options"
[16:15] <Mathieu_Du> I couldn't find out options allowing for downscaling in the H264Context, any ideas ?
[16:15] <Mathieu_Du> (not sure if that's doable either)
[16:16] <Mathieu_Du> I don't mind losing quality, the purpose is to provide a preview, and we don't need full HD samples to be rendered at their actual resolution
[16:23] <ePirat> Hello, I am trying to use ffmpeg's segment muxer, it works fine but I cannot specify a base url
[16:23] <ePirat> ffmpeg -i ~/Downloads/intro.mp4 -hls_time 5 -hls_list_size 0 -hls_base_url "http://epirat.rsync.at/Files/stream/" out.m3u8
[16:23] <ePirat> results in Unrecognized option 'hls_base_url'.
[16:28] <ePirat> Here full output https://gist.github.com/ePirat/00710e09e36ef9fee85a
[16:44] <t4nk100> hello
[16:45] <t4nk100> a simply dude, can I mix video&audio file and audio file in one concrete moment? for example have a 10 minutes audio& video file and need put other extra sound in minute 5
[17:26] <DeadSix27> anyone an iea what "Unable to parse option value "(null)" as sample format"
[17:26] <DeadSix27> means when converting flash videos?
[17:29] <DeadSix27> ye well
[17:29] <DeadSix27> sec
[17:30] <DeadSix27> c_14 http://pastie.org/private/dx9jexpiaxh3ofmtlyzpka
[17:30] <DeadSix27> i assume i just have to define one
[17:32] <c_14> ye, normally the sample format is taken from the input file, but ffmpeg couldn't find one in the input file so you'll probably have to define one.
[17:35] <DeadSix27> c_14: by using -sample_fmt i assume?
[17:35] <c_14> ye
[17:35] <DeadSix27> according to the message: Could not find codec parameters for stream 0 (Audio: pcm_u8, 5512 Hz, mono, 44 kb/s): unspecified sample format
[17:36] <DeadSix27> it says pcm_u8, isnt that the sample rate u8
[17:36] <DeadSix27> i mean what else could it be.
[17:36] <c_14> pcm_u8 is the codec
[17:36] <c_14> unsigned 8bit pcm
[17:37] <c_14> It is however, also the sample format (probably).
[17:38] <DeadSix27> never used -sample_fmt, using -sample_fmt u8 doesnt fix it, so i assume i have to specify the stream? and according to the message its stream 0:0 so i tried -sample_fmt:0:0 u8
[17:38] <DeadSix27> doesnt work either
[17:39] <c_14> Same error? As an input or output option?
[17:40] <DeadSix27> same error
[17:40] <DeadSix27> oh wait
[17:40] <DeadSix27> right
[17:40] <DeadSix27> keep forgetting that
[17:41] <DeadSix27> well same error on input option and same on output
[17:42] <c_14> Can you play the swf with ffplay?
[17:43] <DeadSix27> sec
[17:43] <DeadSix27> nopeyes
[17:43] <DeadSix27> yes**
[17:43] <DeadSix27> nope was from another chat window, ignore it
[17:43] <DeadSix27> plays fine.
[17:44] <DeadSix27> even though it gives the same warning
[17:44] <c_14> Which audio stream do you want?
[17:44] <c_14> The pcm stream, the mp3 stream or both?
[17:44] <DeadSix27> both preferred muxed into mkv as seperate streams
[17:44] <DeadSix27> but mp3 has more priority
[17:45] <DeadSix27> in fact i would be happy if i get atleast the mp3 to work
[17:45] <c_14> If you want both, you'll have to add a -map 0:a to the output. But just to test, can you add -map 0:2 as an output option?
[17:45] <c_14> I just want to test if it works if we ignore the pcm stream for now.
[17:53] <DeadSix27> c_14, yep ill try it out
[17:53] <aleb> If I convert with "ffmpeg -i x.MTS -acodec copy -vcodec copy -sn x.MKV", do I loose anything besides the "s" channel?
[17:54] <c_14> That depends on how many streams the input has. ffmpeg by default only copies one audio and one video stream. Other than that, you shouldn't lose anything.
[17:55] <DeadSix27> c_14 how would i even handle non /2 width's ?
[17:56] <aleb> I see it only has one video and one audio stream - ok, thanks!
[17:56] <DeadSix27> (also using -map 0:2 worked (audio only)
[17:56] <c_14> sec, I did that yesterday. Let me search my history.
[17:57] <c_14> -vf scale="trunc(iw/2)*2:trunc(ih/2)*2"
[17:57] <DeadSix27> answer to me or aleb?
[17:57] <c_14> That'll round down to the nearest even width/hight.
[17:57] <c_14> to you DeadSix27
[17:57] <DeadSix27> ah thamks
[17:57] <DeadSix27> n*
[17:58] <DeadSix27> oh i have to mention, the video in the flash is looped to the length of the audio
[17:59] <DeadSix27> so in fact the resulting video has to be the length of the audio
[17:59] <DeadSix27> and keep the video looped
[17:59] <DeadSix27> (thats pure assumption)
[17:59] <DeadSix27> because the resulting video was only 1 frame (even though original is longer)
[18:04] <DeadSix27> c_14 using only the video stream works btw.
[18:06] <DeadSix27> c_14 is it even possible to loop a stream?
[18:06] <DeadSix27> e.g something like -loop -map 0:1
[18:06] <c_14> You can try reading the audio stream from the input file and then using the movie filter to read the video stream from the swf and use :loop=0 and -shortest to cut to the length of the audio stream, but iirc that currently just gets ffmpeg caught in an infinite loop: https://trac.ffmpeg.org/ticket/1799
[18:07] <DeadSix27> hm
[18:07] <c_14> If you know exactly how often you want to loop the video you can use :loop=x, and that _should_ work, but I've never tested it successfully.
[18:08] <c_14> There is a -loop option, but that works only as an input option for static images and as an output option for formats like gif where you can set a loop count.
[18:10] <DeadSix27> ill try out that movie filter combination first
[18:10] <DeadSix27> never used that before
[18:12] <DeadSix27> c_14 using the movie filter results in a corrupted video
[18:12] <DeadSix27> its deformed etc.
[18:13] <DeadSix27> hm lets try something else
[18:19] <c_14> If you know how often you want to loop the video, you can use the concat filter, I've done that before. It _is_ rather tedious, but I don't know a better way of doing it with ffmpeg.
[18:20] <DeadSix27> in fact i dont know how often i want to loop it
[18:20] <DeadSix27> theres prob a way to calculate it: e.g (length of audio)/(len of video)
[18:20] <pkug> hi there, i'm trying to figure out how to run ffmpeg to record rtsp stream for the last hour (only video of the last hour or other specified amount of time should be kept in the recorded file), can anyone help ?
[18:20] <DeadSix27> but i doubt you can do that in the same command line
[18:21] <pkug> ..and to do it efficiently with fair encoding so that resulting video is not gigs of raw data
[18:24] <c_14> DeadSix27: Yeah, I don't think you could do it in the same command line. You'd have to get the length of the audio stream, the length of the video stream and then calculate how often you want to loop the video.
[18:24] <DeadSix27> c_14 in fact using the movie filter i get just tons of dropped frames
[18:24] <c_14> Hmm, that shouldn't be happening.
[18:24] <DeadSix27> also c_14
[18:25] <DeadSix27> i have the resulting video as h264 stream, and the audio as aac
[18:25] <DeadSix27> from there on there must be a easier way to just loop the h264 stream
[18:25] <DeadSix27> (theY're both seperated files)
[18:25] <DeadSix27> thats theo nly way i yet got it working hm
[18:25] <DeadSix27> (which is now a 2 line command line :|)
[18:26] <DeadSix27> going from a 200char command line to a 2line++ python script is annoying step :p
[18:27] <c_14> pkug: Recording the rtsp stream and encoding it to a file is relatively easy, the problem is that you (if I'm reading you correctly) want only one hour's worth of video in the file and then want to delete any output older than an hour. You _could_ use the nice properties of ts streams to capture one hour of video and then remove x minutes of video from the beginning every x minutes, but that would get rather
[18:27] <c_14> complicated really fast. You might want to wait and see if someone else has a better idea.
[18:28] <c_14> DeadSix27: At this point you can just use the concat filter to concat the video stream n times and mux that with the audio stream.
[18:28] <DeadSix27> ye
[18:28] <DeadSix27> was about to say
[18:29] <DeadSix27> guess ill just write a concat file
[18:29] <c_14> Since loop doesn't do what you want/doesn't work that is probably the best option.
[18:29] <pkug> c_14, hmm, current solution i have now is to record files into separate segments by date and "rotate" them with another daemon/service (sort of like logrotate but for video files) but it requires two components :\
[18:32] <c_14> pkug: You're probably going to need 2 components in either case unless you write something yourself. Your solution has the same base as mine, just that you're using multiple files and I'm using a single ts file and then just cutting blocks out of it every now and then. Your solution is also easier to implement.
[18:35] <DeadSix27> c_14 thanks anyway, using concat i got it fully working.
[18:36] <DeadSix27> c_14 requires a python script, but the result is worth it
[18:36] <c_14> If at first you don't succeed, try scripting it.
[18:36] <DeadSix27> im also highly suprised how that 2xx*something tiny video
[18:37] <DeadSix27> can be upscaled to my 2k hd screen
[18:37] <DeadSix27> and look rather nice
[18:37] <DeadSix27> i mean going by the original size
[18:37] <DeadSix27> thats kinda awesome
[18:37] <DeadSix27> sure is blurry, but not thaat muc
[18:47] <pkug> c_14, thanks though. One lame question: what sort of video encoding would be the most efficient for CCTV records (good quality not needed) ?
[18:48] <c_14> I'd probably just go with h264 with a low crf and -preset faster
[18:49] <c_14> s/low/high
[18:49] <pkug> thanks, i'm currently using it, will try those additional options
[20:02] <AndrzejL> guys my laptop is powering down while using ffmpeg due to the critical temperature. Its a kernel / acpi bug. Can I use something to force cpu to not to use 100%? Would using nice help or something? I want to use ffmpeg just restrict how much cpu can it use...
[20:05] <AndrzejL> forgot to add - cpu is clean / fan is clean / fresh cooling grease arctic mx-4 applied less then 2 weeks ago...
[20:08] <AndrzejL> I would need to acpi=off it but then bluetooth isnt working and no fn keys and no touchpad... No biggie since I use mouse and rarely use bluetooth and the vol up keys but its an annoyance
[20:11] <aarobc> Why would an older version of ffmpeg compiled with libfaac transcode m4p audio faster than the newest version using the superior libfdk-aac?
[20:12] <pzich> quality takes time
[20:12] <Reventlov> still nobody to review that ? https://trac.ffmpeg.org/ticket/3630
[20:15] <dloo> hi
[20:16] <dloo> i'm tring to record from v4l2i, but the -vc 1 is not working :-/
[20:38] <fajung> how can I do to record my desktop with sound from the speakers (ubuntu 14.04?)
[21:02] <aarobc> stupid question: how do I send something from ffmpeg to sout?
[21:03] <pzich> aarobc: use a '-' instead of an output filename
[21:04] <aarobc> ffmpeg -i hot.m4a -ab 128k -v 0 -f mp3 - ?
[21:04] <sacarasc> You'll also need -f something
[21:04] <sacarasc> To force a format.
[21:05] <pzich> aarobc: that looks about right, having problems?
[21:05] <aarobc> pzich: well I'm testing this locally because I'm having an issue on my subsonic server on the new version of ffmpeg
[21:06] <aarobc> so I'm testing it by trying to pipe standard output into vlc just to make sure the basics are working
[21:06] <aarobc> ffmpeg -i hot.m4a -ab 128k -v 0 -f mp3 - | vlc doesn't work
[21:06] <pzich> is there a reason you need to pipe it into vlc instead of creating the file and then opening it?
[21:06] <aarobc> pzich: because I want transcoding to happen as fast as possible
[21:07] <aarobc> So I want the file to be able to start playing before waiting for the transcode to finish
[21:08] <pzich> I'm not sure if piping will change that, you may need other flags that optimize for streaming
[21:09] <aarobc> Indeed, that's what I'm wondering, but I have to at least get the basic concept working so I have somewhere to start from
[21:09] <pzich> can you paste a link with the output?
[21:10] <relaxed> aarobc: you need "| vlc -"
[21:10] <pzich> ah
[21:10] <pzich> makes sense
[21:10] Action: pzich has not piped things into vlc before
[21:11] <aarobc> https://gist.github.com/aarobc/7750d2ef12cbeaba427e
[21:11] <relaxed> well, I tested with mpv
[21:11] <relaxed> but the same logic aplies
[21:11] <relaxed> applies*
[21:11] <sacarasc> Haha, video players and logic.
[21:11] Action: relaxed pipes sacarasc to /dev/null
[21:12] <sacarasc> :(
[21:12] <aarobc> relaxed: no worky, see link
[21:12] <relaxed> try, ffmpeg -i hot.m4a -ab 128k -v 0 -f mp3 - 2>/dev/null| vlc -
[21:13] <aarobc> main stream error: cannot pre fill buffer
[21:13] <aarobc> relaxed: same err
[21:14] <relaxed> use mplayer, mplayer2, or mpv
[21:14] <relaxed> that's whait also works with ffplay
[21:14] <relaxed> er, it also works with ffplay
[21:15] <aarobc> relaxed: okay, mplayer actually makes sound
[21:16] <relaxed> mplayer is king
[21:16] <aarobc> kinda skips the first 20 seconds though
[21:16] <aarobc> but it's at least a place to start from
[21:17] <relaxed> why do you need this on the fly?
[21:18] <relaxed> fg sacarasc
[21:20] <aarobc> relaxed: using this software, trying to acomidate more codecs though and the precompiled version included with it doesn't handle opus http://www.subsonic.org/pages/transcoding.jsp
[21:25] <aarobc> okay
[21:25] <aarobc> confirmed
[21:26] <aarobc> I copied the ffmpeg binary to my local machine, ran the command to pipe it into mplayer and it started playing INSTANTLY
[21:27] <aarobc> the thing is I've compiled newer versions of ffmpeg using the exact same libraries and it's still buggy and laggy
[21:27] <aarobc> but the older version works much faster and I have no idea why
[21:28] <aarobc> relaxed: any idea why this would happen?
[21:37] <relaxed> No, I'm using the latest from git master and it works fine.
[21:44] <aarobc> ugh. I dread the idea of cloning that repo, so freaking huge
[21:46] <aarobc> relaxed: you're telling me you can run this command 'ffmpeg -i hot.m4a -ab 128k -v 0 -f mp3 - | mplayer -' and it plays instantly and correctly with an m4a file?
[22:08] <aarobc> ...
[22:09] <aarobc> relaxed: ping
[22:41] <aarobc> Okay, just compiled from the git repo and still having the same issue
[22:42] <aarobc> however when I'm running from an older version that I didn't compile it works instantly
[22:44] <aarobc> in fact the older version I can run this and it works perfectly: "./ffmpeg -i song.m4a -ab 128k -v 0 -f mp3 - | cvlc -"
[22:50] <aarobc> was ffmpeg forked?
[22:51] <sacarasc> Yes.
[22:52] Action: aarobc punches a baby
[22:52] Action: sacarasc waves at Rincewind.
[22:57] <aarobc> Okay, the problem comes down to not being able to send to standard output. getting error "main stream error: cannot pre fill buffer"
[22:57] <aarobc> version compiled in 2011 works, version compiled just now from git repo doesn't
[23:04] <aarobc> someone willing to test this on an m4a file (aac) "ffmpeg -i song.m4a -ab 128k -v 0 -f mp3 - | cvlc -"
[23:06] <ubitux> aarobc: if you find a regression please open a ticket
[23:06] <ubitux> https://trac.ffmpeg.org/
[23:09] <ubitux> ffmpeg -f lavfi -i 'aevalsrc=sin(440*2*PI*t)' -ab 128k -v 0 -f mp3 - | mpv -
[23:09] <ubitux> this works for me
[23:09] <ubitux> works with cvlc as well
[23:09] <ubitux> aarobc: can you confirm that it works for you with the above cmd line?
[23:10] <aarobc> ubitux: testing...
[23:11] <aarobc> don't have mpv installed, using mplayer...
[23:12] <ubitux> replace with cvlc
[23:12] <ubitux> it works as well
[23:13] <aarobc> ubitux: that does work with the version I just compiled
[23:13] <aarobc> assuming it's supposed to make a tone
[23:13] <ubitux> yes
[23:13] <ubitux> but it doesn't with your m4a?
[23:14] <ubitux> can you share that m4a?
[23:14] <aarobc> ubitux: sure. one sec
[23:15] <aarobc> ubitux: aarobc.com/hot.m4a
[23:16] <ubitux> seems to work here
[23:16] <ubitux> what's the issue?
[23:17] <aarobc> ubitux: so you run that string using cvlc and it plays?
[23:17] <ubitux> mmh nothing happens with vlc, but it works with mpv and mplayer
[23:18] <aarobc> ubitux: try just vlc then. should still work
[23:18] <ubitux> it doesn't
[23:18] <ubitux> nothing happens
[23:19] <aarobc> ubitux: you're getting the "cannot pre fill buffer" error?
[23:19] <ubitux> no
[23:19] <ubitux> i'm not getting anything
[23:19] <aarobc> ubitux: when did you compile your current ffmpeg?
[23:19] <ubitux> current HEAD
[23:20] <ubitux> i tried 2.2.2 as well
[23:21] <aarobc> ubitux: what did you use when compiling? Any chance you could post the binary somewhere?
[23:22] <aarobc> Or did you download a precompiled one?
[23:22] <ubitux> no option in particular
[23:22] <aarobc> ubitux: what do you see when you just run 'ffmpeg'?
[23:22] <ubitux> tell me what you want to know exactly
[23:23] <ubitux> because it's probable the mismatch is on vlc side here
[23:23] <ubitux> i'm using 2.1.4, built with ffmpeg
[23:23] <ubitux> (ffmpeg 2.2.2)
[23:24] <aarobc> but no additional libraries when you compiled it?
[23:26] <aarobc> ubitux: post the output when you run 'ffmpeg' somewhere
[23:27] <ubitux> well i have libmp3lame ofc
[23:27] <ubitux> why do you think this would affect the test?
[23:27] <aarobc> ubitux: because I really can't think of anything else why it wouldn't work
[23:27] <ubitux> well
[23:28] <ubitux> does it work for you with mplayer?
[23:28] <aarobc> ubitux: not with the current one that I just compiled
[23:29] <ubitux> ffmpeg 2.2.2, lame 3.99.5, vlc 2.1.4, mplayer 37051
[23:29] <ubitux> this is what i'm using
[23:30] <aarobc> maybe my sintax is off for mplayer. should I jjust be able to substitute 'mplayer' for 'cvlc' in the string?
[23:31] <ubitux> that's what i did yes
[23:32] <aarobc> okay. am going to try downloading latest binary, maybe that will work :-p
[23:33] <aarobc> same problem
[23:36] <aarobc> ubitux: what distro are you on?
[23:36] <ubitux> arch
[23:37] <aarobc> could that possibly be the issue?!
[23:37] <aarobc> I'm on ubuntu
[23:37] <ubitux> ubuntu uses the fork for every app
[23:37] <ubitux> every multimedia* app
[23:38] <ubitux> that's a completely different setup anyway
[23:44] <aarobc> but I compiled my own ffmpeg!
[23:45] <aarobc> why does the universe hate me
[23:49] <goulard> how does ffmpeg interleave audio and video when muxing ts?
[23:49] <goulard> does it doing it based on pts values?
[00:00] --- Fri May 16 2014

More information about the Ffmpeg-devel-irc mailing list