[Ffmpeg-devel-irc] ffmpeg.log.20140516

burek burek021 at gmail.com
Sat May 17 02:05:01 CEST 2014

[02:11] <AaronB_> Hey, is there anyone around that can spend a few minutes with me to help me understand differences in formats and codecs, and how to compile ffmpeg with support for as many as possible? This is for a debian system.
[02:12] <satanist> you can try this repo git://anonscm.debian.org/collab-maint/ffmpeg.git
[02:14] <AaronB_> Is there a site that links to that repo with compile instructions? I'm not really familiar with compiling, im a web dev
[02:14] <satanist> git-buildpackage -us -uc -S
[02:15] <AaronB_> I have already followed this but it doesnt support everything https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu
[02:17] <satanist> you can see the config options in the debian/rules file
[02:19] <AaronB_> Anything that needs changed in the one you linked?
[02:20] <satanist> yes in the debian/*-ffmpeg-dev.install you have to rename the pc-files form *.pc to *-ffmpeg.pc
[02:23] <AaronB_> Ok, im firing up a VM now to start playing with it, will you be around for awhile to ask questions if needed?
[02:24] <satanist> no, I will go sleep now
[02:24] <satanist> sorry
[02:24] <AaronB_> Alright, later mate
[02:24] <AaronB_> Thanks
[05:52] <hendry> i want to make a video of a long time series I captured. Basically I want each frame to be used as a video. so 24 captures = 1 sec of video. How do I do that? All the examples I see have a duration of 5 secs per frame
[06:22] <musashi1> Hello, I used ffmpeg to create a video which doesn't seem to want to play in a browser. Could anyone reccomend a course of action to determine why it isn't playing?
[06:56] <decci> I am trying to follow https://trac.ffmpeg.org/wiki/CompilationGuide/Centos
[06:56] <decci> I encounter this error while running ./configure --prefix="$HOME/ffmpeg_build" --extra-cflags="-I$HOME/ffmpeg_build/include" --extra-ldflags="-L$HOME/ffmpeg_build/lib" --bindir="$HOME/bin" --extra-libs=-ldl --enable-gpl --enable-nonfree --enable-libfdk_aac --enable-libmp3lame --enable-libopus --enable-libvorbis --enable-libvpx --enable-libx264
[06:56] <decci> Unable to create and execute files in /tmp.  Set the TMPDIR environment variable to another directory and make sure that it is not mounted noexec. Sanity test failed.  If you think configure made a mistake, make sure you are using the latest version from Git.  If the latest version fails, report the problem to the ffmpeg-user at ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net. Include the log file "config.log" produced by confi
[06:57] <decci> Any idea what could be the issue
[06:57] <decci> http://paste.ubuntu.com/7471297/
[06:58] <decci> http://paste.ubuntu.com/7471298/
[09:04] <bencc> is it reasonable to do real time video transcoding on a 20$ VPS? (linode)
[09:05] <another> depends on the resolution and such
[09:06] <bencc> 1000 X 560
[09:06] <bencc> VP8 to h264
[11:37] <supernoob> hi
[11:38] <supernoob> How do I concatenate mov files with different bitrates?
[11:39] <supernoob> I've tried http://trac.ffmpeg.org/wiki/How%20to%20concatenate%20(join,%20merge)%20media%20files but it is not working for me
[11:43] <supernoob> here's my Media Info Video 1
[11:44] <supernoob> Format                                   : MPEG-4 Format profile                           : QuickTime Codec ID                                 : qt   File size                                : 165 MiB Duration                                 : 12mn 12s Overall bit rate                         : 1 892 Kbps Writing application                      : Lavf55.25.101  Video ID                                       : 1 Format           
[12:03] <dloo> hello
[12:04] <dloo> how can i, in the ffmpeg cli, indicate that i want the 2nd input of my video card to record?
[12:05] <dloo> (i got a black screen when recording on v4l2 -i /dev/video0 -vc1
[12:06] <anshul> dloo, can you pastebin ls /dev/video*
[12:31] <dloo> ls /dev/video0
[12:31] <dloo> /dev/video0
[12:32] <dloo> right card, but not right video input
[12:34] <anshul> dloo, have you tried same with any other player like vlc
[13:07] <dloo> anshul: yes, and it is working; with ffplay too
[13:13] <mrskman> Hi, is it bug or feature that this command never stops encoding? http://pastebin.com/dJpuiZND I guess that even with -shortest option it cannot detect end of input stream when there is an overlay?
[13:17] <decci> I need a help regarding ffmpeg
[13:18] <decci> I have a PHP script which uploads a media file and convert it to different format through ffmpeg. I installed ffmpeg under /root/bin/ffmpeg.
[13:18] <decci>
[13:19] <decci> While you upload any media, it tries to find out ffmpeg as shown ame => MOV06754.AVI type => video/avi tmp_name => /chroot/tmp/phpAtmHIR error => 0 size => 830900 Temp File: /chroot/tmp/phpAtmHIR exists. Uploaded File: /home/upeoapp2/public_html/ffmpegtest/video/upload/retrer.AVI -i /home/upeoapp2/public_html/ffmpegtest/video/upload/retrer.AVI -vcodec libx264 -maxrate 1024k -bufsize 1024k -f mp4 -strict -2 -y /home/upeoapp2/public_ht
[13:19] <decci> The problem is it doesnt detect ffmpeg
[13:19] <decci> I used this tutorial https://trac.ffmpeg.org/wiki/CentosCompilationGuide
[13:19] <sacarasc> Well, /root is usually root readable only.
[13:20] <sacarasc> And HTTPds most often don't run as root.
[13:21] <decci> sacarasc: can you elaborate
[13:21] <decci> sacarasc: Where shall I install ffmpeg
[13:21] <decci> sacarasc: to make it run
[13:22] <decci> sacarasc: "type -P ffmpeg" doesn't return where ffmpeg is [4:41:01 PM] Suman Ghosh: $ffmpeg = trim(shell_exec('type -P ffmpeg')); $conversion_command = $ffmpeg;
[13:22] <sacarasc> /usr/local is usually a good place for your prefix. But whereever you put it, make sure the httpd's user has it in their $PATH.
[13:22] <decci> How to ensure about that httpd user has its access
[13:23] <sacarasc> Or, you could edit the script to use the full path, instead.
[13:25] <mrskman> $ffmpeg = '/root/bin/ffmpeg'; doesn't help?
[13:27] <decci> mrskman: No  ffmpeg is not available from under /home/upeoapp2/public_html/ffmpegtest/
[13:28] <decci> mrskman: My script is not able to find ffmepg
[13:28] <decci> ffmpeg
[13:31] <sacarasc> mrskman is saying to edit the script, change trim() to just '/root/bin/ffmpeg'
[13:31] <sacarasc> And then realise that you shouldn't install things in /root.
[13:38] <Hello71> ... if you have access to /root
[13:38] <Hello71> you can write *anywhere on the system*
[13:38] <Hello71> what the hell are you doing
[13:45] <decci> Hello71: Hi
[13:45] <decci> Hello71: What u suggest
[13:45] <decci> Hello71: Moving it to /home directory or /usr/local
[13:45] <Hello71> read fhs
[13:46] <decci> Hello71: If I install a new ffmpeg under /usr/local , how its going to take from that location
[13:46] <decci> Hello71: Do I need to specify it
[13:51] <decci> ?
[13:55] <sacarasc> Hello71: httpds don't run as /root, though, and that's the user which is doing it.
[14:11] <danylevskyi> Hi guys! I am trying to record my screen with avconv. It's great! But my audio has some arbitrary gaps. When I'm recording only audio it records fine. Where can be the problem?
[14:43] <c_14> danylevskyi: avconv is part of libav, see #libav for support or install ffmpeg
[16:15] <hendry> everytime i try convert images to a mp4, ffmpeg gets killed... any ideas? http://ix.io/cmF
[16:19] <c_14> Do you have enough free ram? Tried checking syslog at the time it breaks?
[16:39] <danylevskyi> Folks, I'd like to thank you for great ffmpeg tool!
[16:40] <danylevskyi> Installed ffmpeg and all problems with sound have gone. avconv is really buggy.
[18:07] <mrskman> Hi, is it bug or feature that this command never stops encoding? http://pastebin.com/dJpuiZND I guess that even with -shortest option it cannot detect end of input stream when there is an overlay?
[18:22] <t4nk761> anybody tried coding the librtmp + avcodec?
[18:23] <abhilashswe> i am writing a rtmp publish app using avcodec + librtmp
[18:23] <abhilashswe> i request some  help to start the coding
[18:26] <abhilashswe> if anybody is interested in freelancing we can hire
[18:33] <haspor> who knows how to loop atrac3p correctly with ffmpeg ?
[18:34] <JEEB> what do you mean with that exactly?
[18:34] <haspor> i mean that, how do i know when to make it seek back to loop point and how to get the loop point
[18:35] <JEEB> that sounds like stuff that isn't in the actual audio stream
[18:35] <JEEB> but in the container if even there
[18:35] <JEEB> I wouldn't be surprised if it was in an unrelated thing that the app playing it would know :P
[18:37] <haspor> i have figured out the offset in the header where the looppoint is but since i cant find any related documents and ffmpeg is not able to do the looping itself, i wanted to ask you guys
[18:37] <haspor> sorry for being a bit confusing
[18:37] <haspor> i tried various hacks but there is always something that is not ok
[18:41] <JEEB> haspor, well libav* will not do that for you (it only does A->B stuff unless you seek yourself), so you'll have to seek to the looping part's start and start decoding from there again
[18:42] <haspor> yep, thats what i do
[18:43] <c_14> mrskman: overlay=y=70:eof_action=endall seems to do the trick.
[18:44] <haspor> but there is always a tiny hiccup before the loop starts again cos sometimes those at3 files have nearly empty data at the end, so im not sure should i skip it always or only for specific files
[18:46] <JEEB> compare to a reference decoder I guess, unless the file contains info? or if it's leftovers in some buffer, you could try to poke to that stuff out :P
[18:47] <abhilashswe> hi JEEB
[18:49] <haspor> it would help if i could know what those bytes mean in every packet header
[18:55] <mrskman> c_14: thanks :-)
[19:05] <dloo> hello
[19:05] <dloo> did someone can help me to open my pinnacle card in ffmpeg, using the second input? (composite)
[19:19] <brixon> gm
[19:20] <brixon> can i send query params when publishing using rtmp using ffmpeg?
[19:20] <brixon> for instance rtmp://myserver:1935/MyApp/small?param=1&param=2
[19:20] <brixon> ?
[19:20] <dloo> what is the param to change the video input in v4l2 /dev/video0?
[19:20] <brixon> it doesn't seem to work
[19:35] <JEEB> haspor, you can look at http://wiki.multimedia.cx/index.php?title=ATRAC3plus
[19:36] <JEEB> if there's not enough info feel free to add what additional things you know (either in the format's page or the container's)
[19:36] <haspor> jeeb, thanks but checked that already
[19:36] <haspor> :(
[19:37] <AaronB_> Hey, is anyone able to make custom build scripts for debian with support for all codecs and formats? I can pay for the script or your time helping me do it.
[19:38] <JEEB> AaronB_, personally I'd say that enabling all the things isn't exactly that useful. It's better to just set up something that fits all of your use cases since generally it's the input side that needs to be wider, and 99% of all input things are in lavf/lavc itself (and thus don't need anything extra)
[19:39] <AaronB_> Agreed, input is most important, i mean "all" losely as i realize a lot of outdated or not used
[19:39] <dloo> ffmpeg  -f v4l2 -vc 2 -tvstd SECAM -s 768x576 -i /dev/video0 -ac 2 -ar 48000 -f alsa -i hw:0,0 -acodec ac3 -qmax 1 -y test.mov -t 4000 -vcodec libx264
[19:40] <AaronB_> JEEB ive already followed this guide https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu
[19:40] <AaronB_> and added h265
[19:40] <dloo> why this does not record my  composite input on /dev/video0? get the sound from alsa but a black screen :-/
[19:40] <JEEB> AaronB_, then I recommend you check what things you need that you need to actually enable
[19:41] <AaronB_> JEEB, I don't actually know what people will want to give me to be honest, I need to support anything that comes my way without fail
[19:41] <JEEB> if it's files then you've pretty much got it all :P
[19:42] <AaronB_> Does that guide contain libavformat? I dont see it anywhere
[19:42] <AaronB_> JEEB this is my supported formats, it looks lacking http://codep.in/6G
[19:42] <AaronB_> I expect D & E for every single one
[19:42] <JEEB> uhh, that won't happen
[19:43] <JEEB> I mean, there's plenty of formats like game stuff, that will never get a muxer
[19:43] <JEEB> that looks completely normal to be honest :P
[19:43] <AaronB_> Ok maybe not every one, but it still feels lacking
[19:43] <AaronB_> like 3gp is only E
[19:44] <AaronB_> I should be able to decode it too right?
[19:44] <JEEB> 3gp is a special case of mov
[19:44] <AaronB_> So it is supported?
[19:44] <JEEB> and yes, muxer only because the mov demuxer handles it
[19:45] <JEEB> basically you will gain pretty much zero demuxers with any external libraries, and I'm not even sure if you gain any by even doing --enable-gpl
[19:45] <JEEB> so yeah
[19:46] <JEEB> unless you specifically disabled something, you should have it all
[19:46] <AaronB_> hmm ok then, i did have some issues in my initial testing though
[19:46] <AaronB_> actually let me setup my test again so i can tell you accurate information, will you be around for a bit JEEB?
[19:53] <AaronB_> I get an error: [Error: format mkv not available] when supplying mkv as the imput format of my video, I realize the extension does not = format, but what is the best way to get the format of my file to correctly pass it to my command?
[19:53] <JEEB> by not passing it to the command?
[19:53] <JEEB> unless your input has no file name or descriptor of any sort
[19:53] <JEEB> (there's also byte-based probing)
[19:54] <JEEB> if all that fails, /then/ you set your input format
[19:54] <AaronB_> So passing it is never needed generally?
[19:54] <JEEB> yup
[19:54] <AaronB_> What about output format?
[19:54] <JEEB> do you have an output file name?
[19:54] <JEEB> or descriptor with an extension?
[19:54] <AaronB_> say test.mp4
[19:54] <JEEB> then no
[19:55] <AaronB_> That could be h264 or h265
[19:55] <AaronB_> sorry those are different things, ignore that..
[19:55] <JEEB> well, yeah... "format" in the context of ffmpeg is generally a container
[19:55] <JEEB> (or well, whatever a video/audio/multiple streams gets written into)
[19:56] <AaronB_> so its safe to not pass either input or output format?
[19:56] <JEEB> if you have a file name, yes. and even if you don't have a file name there's a high probability that you will have it work
[19:57] <AaronB_> Ok, in that case, is there a way to show supported output extensions?
[19:58] <JEEB> no easy way, no
[19:59] <AaronB_> what about supplying a filename without an extension to output too and giving it an output format, will it set the extension for me?
[19:59] <JEEB> no
[19:59] <JEEB> output file name is the output file name
[20:00] <JEEB> if you do -f nut i_hate_chicken you will have a NUT file with exactly that name
[20:01] <AaronB_> hmm so there is no easy way to go about making sure something is outputted correctly
[20:01] <JEEB> just name it correctly
[20:01] <JEEB> if ffmpeg doesn't know the extension, it will error
[20:01] <AaronB_> Im giving control to clients that dont know what their doing lol
[20:06] <AaronB_> Is this a big enough list of expected formats to support: mp4, ogg, webm, avi, mov?
[20:06] <JEEB> sounds good to me
[20:06] <JEEB> just collect some commonly used formats in those and limit the users to sane things with them, too
[20:07] <JEEB> i mean video/audio formats
[20:07] <JEEB> not the ffmpeg formats >_>
[20:08] <AaronB_> is wmv supported?
[20:08] <JEEB> yes, the real name of that container is ASF
[20:08] <JEEB> and extension can be wmv
[20:08] <JEEB> but I shall warn you, the encoders for WMV/WMA are /bad/
[20:08] <JEEB> not libavcodec vorbis bad
[20:09] <JEEB> but bad
[20:09] <AaronB_> Yea i read that supplying bitrate helps at least
[20:09] <AaronB_> I wouldnt use it but i gotta support the case of someone doing it ><
[20:09] <JEEB> yeah, just make the bit rates crazy high for ti
[20:09] <JEEB> *it
[20:10] <AaronB_> .webm is the correct extension for a vp8 video right?
[20:11] <JEEB> ye
[20:11] <AaronB_> Alrighty, this logic is going to be ridiculous to make sure this stuff works >< haha
[20:12] <AaronB_> thanks for the help, lets see how far I get with this..
[20:13] <AaronB_> Oo last question, audio. so far I'm supporting aac,ogg,mp3, any more I can expect?
[20:14] <JEEB> that should fit most use cases
[20:14] <JEEB> also with ogg you mean vorbis
[20:14] <JEEB> because ogg is the container thingamabob
[20:14] <AaronB_> is ogg the extension?
[20:14] <AaronB_> and what about an aac file, whats the extension on taht?
[20:14] <dloo> someone can help me with my input v4l2 problem?
[20:15] <JEEB> if you want audio-only AAC that most things that support AAC can play, I'd say mp4, but because some players are stupid just set it to m4a
[20:15] <JEEB> same mov-based thing, but apple's extension for "audio-only such files"
[20:16] <AaronB_> Let me test that real quick, I remember that not working for me..
[20:19] <AaronB_> hmm I lied, maybe I was supplying the output format = extension when that was failing
[20:20] <AaronB_> Ok well this helps me a lot, thanks JEEB
[20:21] <dloo> what -vc option is supposed to do?
[20:21] <AaronB_> dloo sets video codec I believe
[20:21] <AaronB_> I think it should be -c:v though
[20:22] <dloo> hmm
[20:22] <AaronB_> either might work
[20:22] <dloo> what isthe optionto change the video channel input? (composite/svideo/tv)
[20:26] <AaronB_> this should help dloo https://trac.ffmpeg.org/wiki/How%20to%20use%20-map%20option
[20:47] <AaronB_> What are the video profiles available to h265? h264 supported baseline, main, and high (AFAIK)
[20:47] <AaronB_> And levels also?
[20:49] <JEEB> main and main10 profiles are currently standardized, and you don't really get the latter unless you code 10bit H.265 :P
[20:50] <JEEB> main10 does support 8bit HEVC, but no-one marks 8bit stuff as main 10 profile
[20:50] <JEEB> for ObviousReasons
[20:50] <JEEB> levels you can check from the spec :P
[20:50] <AaronB_> is baseline supported? or just main?
[20:50] <AaronB_> baseline is best for greater cross device support right?
[20:51] <JEEB> > implying that there is a baseline profile in HEVC
[20:51] <JEEB> HEVC is main, main 10, main still
[20:51] <JEEB> and all kinds of 4:2:2/4:4:4 profiles and >10bit profiles coming when the range extensions get ratified
[20:52] <AaronB_> il just stick with main :)
[20:52] <JEEB> and usually when you need to set a level, you are adhering to some hardware thingamabob's limitations. And those thingamabobs aren't on the market yet :)
[20:53] <AaronB_> gotcha, so no need to set that?
[20:53] <JEEB> basically just keep the output 8bit and you will get main profile, and let libx265 set the level
[20:53] <AaronB_> ok
[20:54] <JEEB> many people seem to think that there is a "high profile" in HEVC, but you're the first one who thought about baseline
[20:54] <JEEB> (high profile was a thing that was added two years down the line in order to improve higher resolution content compression with AVC)
[20:55] <AaronB_> wiki seems to think a high does exist too
[20:55] <JEEB> AVC, yes
[20:55] <JEEB> HEVC nope
[20:55] <JEEB> HEVC is just main, main 10 and main still profiles
[20:55] <AaronB_> grr too many options lol
[20:56] <AaronB_> I could spend years just writing validation for this haha
[20:56] <AaronB_> Screw it, contact support if you break it :P
[20:57] <dloo> -map is not the right thing :(
[20:59] <AaronB_> hmm i think i have libvorbis and libtheora mixed up..
[20:59] <AaronB_> vorbis = ogg, theora is?
[20:59] <Plorkyeran> ogg = container
[20:59] <Plorkyeran> vorbis = audio codec
[20:59] <Plorkyeran> theora = video codec
[21:00] <JEEB> <JEEB> also with ogg you mean vorbis
[21:00] <JEEB> <JEEB> because ogg is the container thingamabob
[21:00] <JEEB> :D
[21:00] <AaronB_> gotcha, is ogg the common container for those?
[21:00] <JEEB> yes
[21:00] <JEEB> xiph formats generally go into OGG
[21:00] <JEEB> one way or another
[21:01] <AaronB_> hmm ok, lets see if i have these correct, i feel like im mixing up codecs and formats too much
[21:02] <AaronB_> these are my supported video codecs that ive listed so far: "h265","h264","vpx","xvid","mpeg4","theora"
[21:02] <AaronB_> ive shortend them for ease of use for the user, i convert them later
[21:02] <JEEB> the name for the first one is hevc in libavcoec
[21:02] <JEEB> *libavcodec
[21:02] <AaronB_> not libh265?
[21:03] <AaronB_> i think im going to leave it as that for the user to enter
[21:03] <JEEB> libx265 is x265's library's name
[21:03] <JEEB> just like libx264 is x264's
[21:03] <AaronB_> when i use -c:v, libxh265 if correct for that value?
[21:03] <JEEB> yes, for the encoder
[21:03] <AaronB_> ok
[21:03] <JEEB> although probably hevc would work too?
[21:04] <JEEB> because nowadays ffmpeg can map the video format's name into an encoder for it in many cases
[21:04] <JEEB> just like doing -c:v h264 for an encoder nowadays might get you libx264
[21:04] <JEEB> it's a weird world nowadays
[21:06] <Venti> there is a high tier in hevc, but that relates to profile level restrictions
[21:06] <AaronB_> should i have the user enter theora? i dont commonly hear that word.. i feel like entering ogg for that format would be better
[21:06] <JEEB> yes, tiers are tiers
[21:06] <AaronB_> though incorrect i know
[21:06] <JEEB> AaronB_, if someone wants theora they probably know that name
[21:06] <AaronB_> true
[21:06] <JEEB> because only freetards do want it at times
[21:06] <AaronB_> hah
[21:06] <JEEB> the less knowledge'able freetards use vp8
[21:07] <JEEB> (because it got publicity more lately)
[21:07] <AaronB_> should i leave it as vpx or set it to vp8?
[21:07] <JEEB> libvpx is the encoder, so for that it's correct
[21:07] <AaronB_> ok, audio codecs i have so far: "aac","vorbis","mp3"
[21:08] <AaronB_> i dont like that vorbis is longer than the rest lol
[21:08] <JEEB> you want to use fdk-aac for aac, libvorbis (preferably aotuv's fork) for vorbis and libmp3lame for mp3
[21:08] <AaronB_> thats what i convert those too
[21:08] <AaronB_> for the user are those ok?
[21:09] <JEEB> although the actual decoder (and thus the actual audio format names) names might be mappable to the "best" encoder for that format when encoding
[21:09] <JEEB> and yes, those are OK
[21:11] <AaronB_> does webm have its own audio format or is it just aac?
[21:11] <JEEB> webm is a limited subset of matroska
[21:11] <JEEB> and it means vp8 and vp9 for video, and vorbis and opus for audio
[21:11] <AaronB_> Sorry, vpx
[21:12] <JEEB> latter ones aren't yet on the spec pages so YMMV (although they are used by some)
[21:12] <AaronB_> what container is opus in generally?
[21:12] <AaronB_> that isnt one ive added yet, though its in my build
[21:12] <JEEB> ogg, matroska
[21:13] <AaronB_> clear
[21:13] <AaronB_> oops lol
[21:13] <AaronB_> you arent my terminal
[21:14] <AaronB_> crap, h265 didnt work D:
[21:14] <JEEB> yes, h265 is called hevc in ffmpeg space :P
[21:15] <JEEB> because that's what the devs of the decoder liked and thus it became the name of the format in lavc
[21:15] <AaronB_> sorry i mean it didnt compile
[21:15] <JEEB> and ITU-T can suck their unpronounce'able eich-two-six-five
[21:15] <AaronB_> and my ffmpeg is broke ;(
[21:15] <JEEB> oh, wait. eich-dot-two-six-five
[21:15] <JEEB> sorry ITU-T
[21:16] <AaronB_> ./ffmpeg: error while loading shared libraries: libx265.so.18: cannot open shared object file: No such file or directory
[21:16] <JEEB> you didn't do the ldconfig dance
[21:17] <JEEB> and/or you decided to use shared libraries with stuff that doesn't get installed into LD_LIBRARY_PATH
[21:17] <JEEB> in which case you can blame yourself
[21:17] <AaronB_> Well yea i expected user error was the issue :P
[21:17] <AaronB_> hm
[21:18] <AaronB_> I did this http://codep.in/6H
[21:18] <AaronB_> it built and installed correctly
[21:19] <JEEB> well, run ldconfig as root and hope you set a prefix so that LD_LIBRARY_PATH actually grabs them
[21:20] <JEEB> otherwise just re-compile x265 with a static library only, and link against it
[21:21] <JEEB> basically linux only "notices" a shared library after it has been "indexed", which is what ldconfig does. Except that only works when that shared library is in a prefix that gets automagically checked for
[21:21] <AaronB_> after ldconfig do i rebuild ffmpeg or should it work now?
[21:21] <JEEB> if you had installed it into a prefix that is auto-checked, it should work
[21:22] <AaronB_> yay looks like that did it
[21:50] <AaronB_> Are speed presets (like veryfast, fast, normal, etc) available for all codecs or just h264?
[21:50] <AaronB_> and are those available in h265 as well?
[21:51] <JEEB> speed presets are something that the encoder library provides, they are not in ffmpeg itself
[21:51] <JEEB> and yes, libx264 tries to implement something similar
[21:52] <AaronB_> How do i find out which encoders support it?
[21:52] <AaronB_> only x264 guide on ffmpeg site has those options
[21:53] <JEEB> -preset is used by two encoders so far
[21:53] <JEEB> libx264 and libx265
[21:53] <AaronB_> gotcha
[22:08] <sacarasc> JEEB: Only 2 *video* encoders. IIRC, one of the AAC ones uses it to?
[22:08] <JEEB> it does? I've only seen audio encoders use -profile
[22:09] <sacarasc> Wait, I misread because I am half dead.
[22:09] <sacarasc> Sorry.
[22:09] <sacarasc> Ignore me.
[22:09] Action: sacarasc slinks off into the pit of unworn glasses.
[22:48] <AaronB_> I get this error when encoding an mkv to an h264 mp4: Non-monotonous DTS in output stream 0:1; previous: 1633624, current: 1633344; changing to 1633625. This may result in incorrect timestamps in the output file.
[22:48] <AaronB_> is that a problem with my command or the video file, and can i fix it?
[22:49] <AaronB_> Audio is off like 4 seconds
[00:00] --- Sat May 17 2014

More information about the Ffmpeg-devel-irc mailing list