[Ffmpeg-devel-irc] ffmpeg.log.20140517

burek burek021 at gmail.com
Sun May 18 02:05:01 CEST 2014

[03:41] <decci> I have ffmpeg configured under /usr/local/bin/fmpeg. My web application is unable to run this ffmpeg due to permission issue
[03:41] <decci> As I installed ffmpeg through root
[03:42] <decci> My web application is running through normal user and so unable to run this command through PHP script
[03:42] <c_14> What are the file permissions of /usr/local/bin/ffmpeg ?
[03:42] <decci> c_14:  ls -la /usr/local/bin/ffmpeg -rwxr-xr-x 1 root upeoapp2 19581640 May 16 07:59 /usr/local/bin/ffmpeg*
[03:43] <decci> I tried modifying it with chown command but still not accessible
[03:43] <c_14> Is /usr/local/bin/ in $PATH ?
[03:44] <decci> c_14: echo $PATH /usr/local/jdk/bin:/usr/lib64/qt-3.3/bin:/bin:/usr/bin:/usr/local/bin:/sbin:/usr/sbin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin:/root/bin
[03:44] <decci> c_14: Yes its there
[03:45] <c_14> Can your user execute the binary?
[03:45] <decci> c_14: How to ensure that
[03:45] <c_14> ffmpeg -version
[03:46] <decci> c_14: http://paste.ubuntu.com/7475966/
[03:47] <decci> c_14: I ran it as root
[03:47] <c_14> I'm guessing the path php is using isn't correct, have you tried running /usr/local/bin/ffmpeg from the script instead?
[03:48] <decci> c_14: When I run as upeoapp2 user http://paste.ubuntu.com/7475970/
[03:48] <decci> c_14: If I run it as root user, it works
[03:48] <c_14> If you run the php script as root user?
[03:49] <decci> c_14:
[03:49] <decci> c_14: This is what I am trying to build
[03:49] <c_14> The file permissions are correct, and the user you install it as shouldn't prevent you from running ffmpeg. What error does it give you?
[03:49] <decci> c_14: Try uploading any media video file and try to change the format..you will see that it shows http://paste.ubuntu.com/7475973/
[03:50] <decci> c_14: See this -i /home/upeoapp2/public_html/ffmpegtest/video/upload/testr.AVI -vcodec libx264 -maxrate 1024k -bufsize 1024k -f mp4 -strict -2 -y /home/upeoapp2/public_html
[03:50] <decci> c_14: Its not showing /usr/local/bin/ffmpeg here
[03:51] <decci> c_14: If I run it manually through root it works http://paste.ubuntu.com/7475981/
[03:52] <c_14> Do you have/can I see the php script?
[03:52] <decci> c_14: Wait..I can show u its permission issue..confirmed
[03:53] <decci> c_14: When I am running the command manually through root user it works but through upeoapp2 user it shows permission issue http://paste.ubuntu.com/7475984/
[03:53] <decci> c_14: The command is /usr/local/bin/ffmpeg -i /home/upeoapp2/public_html/ffmpegtest/video/upload/testr.AVI -vcodec libx264 -maxrate 1024k -bufsize 1024k -f mp4 -strict -2 -y /home/upeoapp2/public_html/ffmpegtest/video/converted/testr.mp4
[03:54] <c_14> It seems the user doesn't have write permission to the output directory.
[03:54] <decci> c_14: How to fix it
[03:55] <decci> c_14: -rw-r--r-- 1 root     root     134453 May 16 08:08 retrer.mp4 -rw-r--r-- 1 root     root     134453 May 16 20:51 testr.mp4
[03:55] <c_14> The upeoapp2 user needs to have execute permissions to all the directories above converted and write permissions in converted. And the user will also need write permissions to the output file if it already exists.
[03:55] <decci> c_14: This is what it holds as I ran it through root user earlier
[03:56] <decci> c_14: But it actually has upeoapp2 permission drwxrwxr-x 2 upeoapp2 upeoapp2 4096 May 16 20:51 converted/ drwxrwxr-x 2 upeoapp2 upeoapp2 4096 May 16 20:50 upload/
[03:56] <c_14> The folder yes, but not to the file and since the file already exists, it can't overwrite it, probably.
[03:57] <decci> c_14: Do i just need chown -R upeoapp2:upeoapp2 * under  pwd /home/upeoapp2/public_html/ffmpegtest/video
[03:57] <decci> c_14: TRied but not working still
[03:58] <c_14> same error?
[03:58] <decci> Yes
[03:59] <c_14> Can that user create files in that folder? try touch /home/upeoapp2/public_html/ffmpegtest/video/converted/test as that user
[04:00] <decci> c_14: Yes
[04:00] <decci> c_14: touch /home/upeoapp2/public_html/ffmpegtest/video/converted/test
[04:00] <decci> c_14: /video/converted]# ls ./  ../  retrer.mp4  test  testr.mp4
[04:00] <decci> c_14: I su to upeoapp2 and ran that command
[04:01] <decci> c_14: Ohh...I am able to run ffmpeg command manually
[04:01] <decci> c_14: http://paste.ubuntu.com/7476019/
[04:02] <decci> c_14: But I wonder if web is using other user
[04:02] <sacarasc> It's not upeoapp2 running the command, it's your httpd user.
[04:02] <decci> sacarasc: Oops
[04:02] <decci> sacarasc: How shall I enable httpd if thats the case
[04:03] <sacarasc> Look on `ps aux` for your httpd, check the user, su to that user, check the path.
[04:03] <sacarasc> Or try to run the command.
[04:04] <decci> sacarasc: http://paste.ubuntu.com/7476025/
[04:04] <sacarasc> So: nobody, I guess.
[04:04] <decci> sacarasc: :(
[04:04] <sacarasc> The user is called "nobody".
[04:05] <decci> sacarasc: ok
[04:05] <decci> sacarasc: how to fix it
[04:06] <c_14> either chown the dir to user nobody, or find a way to run the httpd/php script as the usomething user
[04:06] <decci> sacarasc: Do we need to provide write access to user nobody
[04:06] <c_14> that would work too
[04:06] <decci> sacarasc: chown -R root:nobody *
[04:07] <c_14> You'll have to make sure that the dir has group write permissions
[04:08] <decci> sacarasc: drwxrwxr-x 2 upeoapp2 nobody   4096 May 16 20:59 converted/ drwxrwxr-x 2 upeoapp2 nobody   4096 May 16 21:07 upload/
[04:08] <decci> sacarasc: drwxrwxrwx 2 upeoapp2 nobody   4096 May 16 20:59 converted/ drwxrwxrwx 2 upeoapp2 nobody   4096 May 16 21:07 upload/
[04:09] <decci> sacarasc: Still not working
[04:12] <decci> sacarasc: I dont see ffmpeg working here
[04:12] <clever> you also need +x on every directory above the one your writting to
[04:12] <clever> and possibly +r
[04:13] <decci> clever: /home/upeoapp2/public_html/ffmpegtest/video/converted is the one i changed the permission
[04:13] <decci> clever: Where do i need +x
[04:14] <clever>  /, /home, /home/upeoapp2, /home/upeoapp2/public_html, /home/upeoapp2/public_html/ffmpegtest, /home/upeoapp2/public_html/ffmpegtest/video
[04:14] <clever> all of those
[04:14] <clever> if you lack +x at any point, you cant cd into that directory, and it cant go any deeper
[04:16] <clever> and if you just give it 777, you leave yourself wide open for various kinds of abuse, dont leave it like that
[04:16] <decci> clever: I have made chmod -R +x * below public_html directory
[04:17] <decci> clever: but still its not working
[04:17] <clever> -R and * shouldnt be mixed
[04:17] <clever> -R defeats the entire point of *
[04:17] <clever> and * wont get everyhting
[04:17] <clever> also, dont just blindly +x everything in sight, test each directory to verify where the issue is
[04:18] <clever> as the target user, try to cd into the directory, one level at a time
[04:18] <clever> and verify if you can get into converted
[04:18] <decci> clever:http://paste.ubuntu.com/7476065/
[04:18] <clever> if you can, then +x is already in place
[04:19] <clever> switch over to the upeoapp2 user, and just try to cd  /home/upeoapp2/public_html/ffmpegtest/video
[04:19] <clever> does that work?
[04:20] <decci> clever: yes
[04:20] <clever> then you have +x on the required directories already
[04:20] <clever> what is the actual error?
[04:20] <decci> clever:  id uid=504(upeoapp2) gid=502(upeoapp2) groups=502(upeoapp2) upeoapp2 at upeoapp.com [~/public_html/ffmpegtest/video]# cd  /home/upeoapp2/public_html/ffmpegtest/video upeoapp2 at upeoapp.com [~/public_html/ffmpegtest/video]#
[04:21] <decci> clever: Go to
[04:21] <clever> does the php script run as upeoapp2 though
[04:21] <clever> modify the php script to run id, and paste that output
[04:21] <clever> <?php passthru('id'); ?>
[04:24] <decci> clever: I added the entry into test.php
[04:24] <decci> clever: Its running as upeoapp2 user
[04:25] <clever> ah, good
[04:25] <clever> <?php passthru('stat /home/upeoapp2/public_html/ffmpegtest/video/converted'); ?>
[04:25] <clever> try this one
[04:26] <decci> clever:
[04:26] <decci> clever: nothing it shows
[04:27] <clever> it may wind up printing errors to the server error log
[04:27] <clever> <?php passthru('stat /home/upeoapp2/public_html/ffmpegtest/video/converted 2>&1'); ?>
[04:27] <clever> this should redirect errors to the webpage
[04:28] <decci> clever:
[04:28] <decci> clever: sh: stat: command not found
[04:28] <clever> yep, may need an absolute path
[04:28] <decci> clever: But while I run it manually on console it works
[04:28] <clever> /usr/bin/stat
[04:28] <clever> PATH wasnt setup fully for the php env
[04:29] <decci> clever: whereis stat stat: /usr/bin/stat /usr/share/man/man1/stat.1.gz /usr/share/man/man3p/stat.3p.gz /usr/share/man/man2/stat.2.gz
[04:29] <decci> clever: But this fails
[04:29] <clever> any chance the server is setup with chroot stuff at play?
[04:30] <decci> clever: How to ensure that
[04:30] <clever> <?php passthru('ls /'); ?>
[04:30] <decci> clever:
[04:30] <decci> clever: Z bin chroot dev etc home lib lib64 mysubdir tmp usr var
[04:31] <clever> and do you have the same files when you ls / under a shell?
[04:31] <decci> clever: http://paste.ubuntu.com/7476109/
[04:32] <clever> that was not 'ls /'
[04:32] <decci> clever: http://paste.ubuntu.com/7476111/
[04:32] <decci> clever: sorry
[04:32] <decci> clever: http://paste.ubuntu.com/7476111/
[04:32] <clever> so the answer is no, you dont have Z or mysubdir
[04:32] <decci> clever: okay
[04:33] <clever> so / under the real system is not the same as / under the php script
[04:33] <clever> figure out what / maps to, maybe search for that 'mysubdir' thing, and then repeat everything under that
[04:36] <decci> clever: You mean path issue
[04:36] <decci> clever: $ffmpeg = trim(shell_exec('type -P ffmpeg'));
[04:36] <decci> clever:  type -P ffmpeg /usr/local/bin/ffmpeg
[04:38] <decci> clever: When I am running this command under upeoapp2 user its working
[04:38] <decci> clever: http://paste.ubuntu.com/7476128/
[04:39] <decci> clever: Shall I install ffmpeg under /home/upeoapp2
[04:39] <clever> where is 'mysubdir' on your system?
[04:39] <decci> clever: whats that
[04:40] <clever> a directory in / under php
[04:40] <clever> 2014-05-16 23:33:25 < clever> figure out what / maps to, maybe search for that 'mysubdir' thing, and then repeat everything under that
[09:19] <decci> I am able to run which ffmpeg through upeoapp2 user in shell prompt but with PHP script it dint work
[09:19] <decci> What could be the issue
[09:20] <decci> http://paste.ubuntu.com/7476924/
[09:22] <pzich> what do you see when you `which ffmpeg` on your shell?
[09:23] <decci> pzich: # id uid=504(upeoapp2) gid=502(upeoapp2) groups=502(upeoapp2) upeoapp2 at upeoapp.com [/usr/local/bin]# which ffmpeg /usr/local/bin/ffmpeg upeoapp2 at upeoapp.com [/usr/local/bin]#
[09:24] <decci> pzich: Tell me one thing . Is directly logging into as upeoapp2 user same as logging into root > and then su upeoapp2
[09:24] <decci> Looks like permission issue
[09:28] <decci> pzich: What u say?
[09:29] <pzich> could be permissions, also /usr/local/bin/ isn't in your $_SERVER['PATH']
[09:29] <decci> pzich: echo $PATH /usr/local/jdk/bin:/usr/lib64/qt-3.3/bin:/bin:/usr/bin:/usr/local/bin:/sbin:/usr/sbin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin:/root/bin
[09:29] <decci> It is
[09:29] <pzich> that's your shell
[09:29] <pzich> open and search for _SERVER["PATH"]
[09:31] <decci> pzich: Oops..how to fix it
[09:31] <pzich> well, the easiest thing would be to run ffmpeg by calling /usr/local/bin/ffmpeg directly
[09:33] <decci> pzich: What if I want to use from script as shown: //Path To your FFMPEG         //$ffmpeg = 'ffmpeg';         // $ffmpeg = trim(shell_exec('which ffmpeg')); // or better yet:         $ffmpeg = trim(shell_exec('type -P ffmpeg'));          //$ffmpeg = '/home/upeoapp2/bin/ffmpeg';
[09:33] <decci> pzich: I really need this to work
[09:33] <decci> pzich: or do i need to install ffmpeg under /usr/bin
[09:34] <pzich> that would also work
[09:34] <pzich> third option is to add it to your $_SERVER['PATH'], I'm not just not sure if you can just append it in your code
[09:34] <decci> pzich: How to add that
[09:35] <decci> pzich: I will rather add to the PATH if you can help me how to do it
[09:35] <pzich> well, you can try $_SERVER['PATH'] .= ':/usr/local/bin' at the top of your script
[09:38] <decci> pzich: You mean like this : <?php       2 $_SERVER['PATH'] .= ':/usr/local/bin'       3 echo 'name => '.$_FILES["upload_file"]['name']."<br/>";       4 echo 'type => ' .$_FILES["upload_file"]['type']."<br/>";       5 echo 'tmp_name => '.$_FILES["upload_file"]['tmp_name']."<br/>";       6 echo 'error => '.$_FILES["upload_file"]['error']."<br/>";       7 echo 'size => '.$_FILES["upload_file"]['size']."<br/>";       8 echo "<hr/>";
[09:39] <pzich> you need to use a paste website
[09:39] <decci> pzich: http://paste.ubuntu.com/7476969/
[09:39] <decci> pzich: Do i need to put it within <?php  or outside
[09:39] <decci> pzich: I see some error after I put it at the top
[09:39] <pzich> definitely within if you want it to actualyl work
[09:40] <pzich> also maybe on the test.php instead?
[09:40] <decci> Parse error: syntax error, unexpected T_ECHO in /home/upeoapp2/public_html/ffmpegtest/upload_processor.php on line 3
[09:40] <pzich> or in addition
[09:40] <pzich> well, yeah, you need to add a semicolon...
[09:40] <decci> pzich: Just saw that..my bad
[09:40] <pzich> how familiar are you with PHP, and coding in general?
[09:41] <decci> pzich: Just a tired body
[09:41] <decci> pzich: Oops..dint work
[09:41] <decci> pzich: http://paste.ubuntu.com/7476975/
[09:42] <decci> pzich: See the second last line...it is not taking /usr/local/bin/ffmpeg
[09:42] <decci> pzich: -i /home/upeoapp2/public_html/ffmpegtest/video/upload/apha.AVI -vcodec libx264 -maxrate 1024k -bufsize 1024k -f mp4 -strict -2 -y /home
[09:43] <decci> pzich:
[09:43] <pzich> can you just put "/usr/local/bin/" before the "ffmpeg"? that should make it work, if your PHP user can execute ffmpeg and read and write those file paths
[09:43] <decci> pzich: I did try it but not working
[09:43] <decci> pzich: It takes it as a string
[09:45] <pzich> it should still work, are you sure that user can execute ffmpeg?
[09:45] <decci> pzich: Here it shows : id uid=504(upeoapp2) gid=502(upeoapp2) groups=502(upeoapp2) upeoapp2 at upeoapp.com [~]# which ffmpeg /usr/local/bin/ffmpeg upeoapp2 at upeoapp.com [~]#
[09:46] <decci> pzich: ffmpeg ffmpeg version git-2014-05-16-bac08cf Copyright (c) 2000-2014 the FFmpeg developers   built on May 16 2014 07:59:25 with gcc 4.4.7 (GCC) 20120313 (Red Hat 4.4.7-4)   configuration: --prefix=/usr/local//ffmpeg_build --extra-cflags=-I/usr/local//ffmpeg_build/include --extra-ldflags=-L/usr/local//ffmpeg_build/lib --bindir=/usr/local//bin --extra-libs=-ldl --enable-gpl
[09:46] <decci> pzich: Logged in as upeoapp2 user I can run ffmpeg but thats not working when on PHP
[09:49] <decci> pzich: What shall I need to make it run through /usr/bin
[09:49] <decci> pzich: Do i need to install it from start or just point it out
[09:49] <Reventlov> Anyone for https://trac.ffmpeg.org/ticket/3630 ?
[09:53] <pzich> I'm not seeing ffmpeg in your /usr/local/bin
[09:54] <decci> pzich: I tried ln -s /usr/local/bin/ffmpeg /usr/bin
[09:54] <decci> pzich: But still the problem
[10:01] <decci> pzich: Tried putting it under /usr/bin..dint work
[10:01] <decci> pzich:
[10:05] <pzich> do `ls /usr/local/bin/`, where is ffmpeg?
[10:10] <decci> pzich: let me add that to test.php script
[10:10] <decci> pzich: 1 sec
[10:10] <pzich> wait, where is ffmpeg? it's not on that computer
[10:11] <pzich> take a look at
[10:12] <pzich> if you search for "ffmpeg", it's not there
[10:13] <decci>
[10:14] <decci> pzich: Yes
[10:14] <decci> pzich: I think thats the issue
[10:14] <pzich> no, it absolutely is
[10:15] <decci> pzich: So what u say
[10:15] <pzich> ffmpeg isn't there, therefore you can't run ffmpeg
[10:15] <decci> pzich: But its displayed when I run in shell
[10:15] <pzich> are you sure that shell is on the same computer?
[10:15] <decci> pzich: ls /usr/local/bin/ ./              findrule*      lwp-mirror*   phpize*          srs* ../             gpgmailtunl*   lwp-request*  pwhich*          srsc* bdf2gdfont.pl*  graph-easy*    lwp-rget*     sa-awl*          srsd* chartex*        imgsize*       oscartest*    sa-check_spamd*  stty.pl* cpandb*         ip2cc*         pear*         sa-compile*      tpage* crc32*          ipcount*       peardev*      sa-learn*        ttree* d
[10:15] <decci> pzich: Yes
[10:16] <pzich> well, search for /usr/local/bin/ on , you can see it's not there
[10:17] <decci> pzich: How did youi get this ile
[10:17] <decci> file
[10:17] <pzich> it's just there, just like
[10:18] <decci> pzich: hmm
[10:18] <decci> pzich: Does it mean its not accessible by upeoapp2 user
[10:18] <decci> pzich:  Its strange
[10:18] <pzich> well it should at least be able to see the folder
[10:19] <decci> pzich: What does ffmpeg* mean
[10:19] <decci> pzich: Linked?
[10:19] <pzich> I think executable in this case
[10:19] <decci> pzich: -rwxr-xr-x  1 upeoapp2 upeoapp2 19581640 May 16 07:59 ffmpeg*
[10:19] <pzich> try chmod 777 /usr/local/bin/ffmpeg
[10:19] <pzich> hmm, that should be ok
[10:21] <decci> pzich: No not working still
[10:21] <pzich> well PHP still can't see it
[10:21] <decci> pzich:  chmod 777 /usr/local/bin/ffmpeg root at serv01 [~]# chmod 777 /usr/bin/ffmpeg
[10:21] <decci> pzich: I am frustrated
[10:22] <decci> pzich: What to do
[10:22] <decci> pzich: I ran ln -s /usr/local/bin/ffmpeg /usr/bin/ffmpeg..
[10:22] <decci> pzich: Will it affect
[10:23] <decci> pzich: I ran it 10 min back
[10:24] <decci> pzich:  [/usr/bin]# ls -la ffmpeg lrwxrwxrwx 1 root root 21 May 17 02:52 ffmpeg -> /usr/local/bin/ffmpeg*c
[10:25] <decci> pzich: Wil this affect
[10:34] <pzich> here, look at this:
[10:34] <pzich> it's not seeing it in /usr/local/bin, but it is seeing it in ../../bin
[10:34] <pzich> and it shows as being executable for everyone
[10:35] <pzich> but when you run it with -version it still doesn't wokr
[10:36] <decci> pzich: So what could be the issue
[10:36] <decci> pzich: Is it server issue
[10:36] <pzich> well, PHP probably can't access the actual executable, probably because of chroot or something
[10:37] <decci> pzich: Will RPM based installation will fix this
[10:37] <pzich> no idea
[10:37] <pzich> but maybe try cp /usr/local/bin/ffmpeg /home/upeoapp2/public_html/
[10:38] <decci> pzich: Lemme try
[10:40] <decci> pzich: Not workig still
[10:43] <decci> pzich: What to do
[10:44] <pzich> hang on, I'm trying to fix it
[10:45] <decci> pzich: k
[10:47] <decci> pzich: How are you creating those files?
[10:48] <pzich> which files?
[10:48] <decci> pzich: test2.php
[10:48] <pzich> that wasn't just there?
[10:48] <decci> pzich: ok
[10:50] <decci> pzich: carry on
[10:50] <pzich> so, I think the problem is that PHP still isn't allowed to execute ffmpeg for some reason
[10:50] <decci> pzich: It loook like so
[10:51] <decci> pzich: I wonder what might be preventing it
[10:52] <pzich> take a look at
[12:42] <t4nk015> flame me back if necessary... but what the is the deal with removing drm on m4v's from the iTunes store... obviously some apps out in the world do it, costing a pretty penny, I just want to be able to play stuff on my tv and not my laptop, hell it's not like I couldn't find a copy on a torrent, but I really do like well encoded video and I don't mind paying for it, but not being able to watch it on my TV, or 30" Apple Cinema Display th
[15:41] <bencc> what file can save vp8 packets?
[16:03] <t4nk015> test
[16:07] <diesel420> hi, i try to capture a dvb-t stream via mencoder so i receive a growing *ts file, i want to stream it live via network with ffmpeg. i had problesm so i tried to stream it "local" first. here is my ffmpeg command and output:
[16:08] <diesel420> http://pastebin.com/skxiSizd
[16:09] <diesel420> i trird to open int with mpv and vlc, but it seems it does not work, i got no video and no audio either
[17:01] <c_14> diesel420: your command works just fine for me
[18:25] <SuperNoob> hi is it possible to concatenate videos with different nitrates?
[18:25] <SuperNoob> bitrates?
[18:25] <c_14> https://trac.ffmpeg.org/wiki/How%20to%20concatenate%20(join,%20merge)%20media%20files#differentcodec
[18:25] <SuperNoob> thanks c_14 I've read that but I am confuse
[18:25] <c_14> What about?
[18:27] <SuperNoob> so I have a video I made out of After Effects rendered and set FPS at 60, I then have a video I captured on my screen using Quicktime I am trying to join them but I always get an issue with the audio the recorded video when joined produces no sound, out of sync etc.
[18:28] <SuperNoob> I have checked the codecs and they are the same
[18:28] <SuperNoob> bitrate for audio's are the same
[18:28] <SuperNoob> Is there any doc I can read about Bit Rates? both Audio and Video?
[18:29] <SuperNoob> I will do that
[18:29] <SuperNoob> give me a minute
[18:29] <c_14> The bitrate is just how many bits of data you have every second, there's not a whole lot to know.
[18:30] <SuperNoob> I will show what media info says about the video I am trying to concat
[18:32] <SuperNoob> what is the significance of sample rate in both Audio and Video?
[18:32] <SuperNoob> can there be issues with joining if the input has different sample rate?
[18:33] <c_14> It might be, but you should be able to downsample one of the audio tracks so that both have the same sample rate.
[18:37] <SuperNoob> I am joining mov files any clue what -bsf:a aac_adtstoasc is for? is that a codec or something? I can't find details about it on the web
[18:39] <c_14> https://www.ffmpeg.org/ffmpeg-bitstream-filters.html#aac_005fadtstoasc
[18:42] <SuperNoob> ?
[18:42] <SuperNoob> hi again here's the video I am trying to join http://pastebin.com/rPvgDKvC
[18:44] <c_14> Frog what I can see, you should be able to merge them, can I see the ffmpeg command you tried using?
[18:46] <SuperNoob> ffmpeg -f concat -i mylist.txt -c copy output
[18:47] <SuperNoob> ffmpeg -f concat -i mylist.txt -c copy final.mov
[18:48] <c_14> you might want to try the concat filter instead of the concat demuxer
[18:50] <SuperNoob> what's the significance of doing that? if the codec, bit rate etc. are the the same?
[18:59] <c_14> It gives you more control of what's happening.
[20:06] <diesel420> c_14, thanks, yeah i needed just to install some video codecs or such =)
[23:30] <chealy> Hi all, is this an appropriate place to discuss usage of libavformat functionality for an application I am writing?
[23:31] <chealy> I'm trying to stream transport stream data using av_init_packet and av_write_frame as RTP and I'm having some difficulties.
[00:00] --- Sun May 18 2014

More information about the Ffmpeg-devel-irc mailing list