[Ffmpeg-devel-irc] ffmpeg.log.20140520

burek burek021 at gmail.com
Wed May 21 02:05:01 CEST 2014

[00:36] <mjuszczak> I'm having trouble re-using a ./configure line I've used in the past.  It's failing on --disable-ss.  Is that no longer a valid configuration option?  When was it removed?
[00:38] <c_14> It's not listed in ./configure --help so I'm pretty sure it isn't valid. As to when it was removed, I have no idea. You might want to look at the git commit messages pertaining to the configure script.
[00:39] <llogan> i don't remember a --disable-ss
[00:39] <c_14> You might be thinking of --disable-sse ?
[00:42] <mjuszczak> http://pastebin.com/yDxfRRX8
[00:42] <mjuszczak> A literal copy of the output of $(ffmpeg)
[00:43] <mjuszczak> unless that's a truncated ./configure :(
[00:43] <mjuszczak> I'm trying to replicate a compilation and I only have the binary
[00:44] <klaxa> do you remember what --disable-ss is supposed to be? otherwise check out the old source-tree and check ./configure --help
[00:44] <klaxa> when i doubt, omit it and don't worry about it
[00:45] <c_14> Judging by the opts around it, I'm guessing it's either --disable-sse or the sse3,sse4 variation thereof.
[00:46] <mjuszczak> c_14: OK.  IS there a chance other things got cut off as well?
[00:46] <klaxa> probably
[00:47] <mjuszczak> I don't suppose there's a way to take a binary of ffmpeg and know what options were configured into it, is there?
[00:47] <klaxa> well... everything is in the paste you posted, but the options changed
[00:48] <mjuszczak> I'm trying to recompile that exact version
[00:49] <klaxa> if you want to compile that exact version you have to get the exact same source-tree
[00:49] <klaxa> then the exact same configure options should work
[00:50] <mjuszczak> I have it, but --disable-ss is failing.
[00:52] <mjuszczak> Well, I lied.  That's 0.10.2 and I'm trying to compile a later version of 0.10.x, because Icouldn't find 0.10.2.
[00:52] <mjuszczak> But I didn't think configure options would change in a minor release
[00:52] <llogan> why are you trying to compile the 0.10 branch?
[00:52] <mjuszczak> legacy application, moving to a different OS, trying to reduce variables
[00:53] <llogan> there is no --disable-ss, and there never was. c_14 already mentioned what it is probably supposed to be, but I see few reasons to actually disable SSE
[00:53] <llogan> are you really compiling on/for AMD barcelona?
[00:53] <mjuszczak> no
[00:54] <mjuszczak> Just trying to keep things exactly as they were on the old setup :(
[00:54] <mjuszczak> I'm not sure why the previous "guy" chose the flags he did, but he did.... many years ago.
[00:55] <llogan> i recommend not doing what he did and just use a simple, sane configuration.
[00:56] <mjuszczak> OK.
[00:56] <mjuszczak> Thank yu
[00:56] <mjuszczak> you*
[00:57] <llogan> like: --enable-gpl --enable-libmp3lame --enable-libvorbis --enable-libx264
[00:58] <llogan> and whatever other useful external libraries you may need.
[01:16] <mithodin> Hi guys. Can someone tell me why this creates a video with no audio output: http://bpaste.net/show/288236/ but when I leave out line 6, I get video with audio output?
[01:18] <c_14> If you leave line 6 in you have 2 implicit outputs and ffmpeg will only use one if you don't name them explicitly and map them.
[01:18] <mithodin> oh
[01:18] <c_14> try adding an [a] at the end of line 6, an [v] at the end of line 10 and a -map '[a]' -map '[v]' somewhere before the output filename
[01:19] <mithodin> does it matter if before or after -t ?
[01:19] <c_14> Doesn't matter.
[01:25] <mithodin> so this should work, right: http://bpaste.net/show/288243/ ?
[01:25] <mithodin> because it does not
[01:30] <c_14> From what I can see, it should work.
[01:30] <c_14> hmm
[01:32] <mithodin> http://pastebin.com/PemDjqwM this is Part of the output, maybe that helps?
[01:36] <c_14> Do you get audio when you put [audio] in the map instead of [audio1] ?
[01:36] <c_14> If that's the case it might be the afade muting all the audio for some reason.
[01:37] <mithodin> yes, that works
[01:38] <c_14> Maybe try sequentially adding the afade filters, start out with just the first one and so on?
[01:38] <mithodin> I'm currently rewriting it so I afade before concatting
[01:40] <mithodin> okay, for some reason, this works: http://bpaste.net/show/288268/
[01:41] <c_14> I guess the afades were fighting with each other and muted everything?
[01:41] <mithodin> possibly...
[01:42] <mithodin> I have a lot to learn about ffmpeg ^^
[01:42] <mithodin> thanks though
[01:42] <c_14> np
[01:42] <c_14> Not that I did much.
[01:42] <mithodin> good night (or whatever time of day it is for you) :-)
[02:53] <GEEGEEGEE> Anyone know what woudl cause this error in ffserver?  stream number does not match registered feed
[03:02] <Shurtagul> How do you use ffmpeg to change the resolution of a video?
[03:04] <llogan> Shurtagul: http://ffmpeg.org/ffmpeg-filters.html#scale
[03:04] <llogan> ffmpeg -i input -vf scale=640:-2 output
[03:04] <llogan> ffmpeg -i input -vf scale=1280:720 -acodec copy output
[03:04] <llogan> etc
[03:07] <Shurtagul> Thank you :)
[03:07] <azk> GEEGEEGEE: Iirc I have gotten that error when trying to hardcode subtitles on the fly for ffserver.
[03:07] <azk> Instead it sends two streams to ffserver and it doesn't recognize one of them.
[03:07] <azk> GEEGEEGEE: Getting actual logs instead of a single line would make it easier for people to debug.
[03:08] <GEEGEEGEE> i cant find where the logs are saved :/
[03:10] <azk> run your commands and pipe their output to a file?
[03:21] <dumdidum> hello, i have a vob/mpeg-1/2 file with broken time index. it runs without problems just the time is wrong. vlc shows a length of around 35 minutes but is about 2 hours. when playing the current time goes up to until 1:30 hour than the current time gets zero and goes up again to 35 minutes. than the video is over. how can i fix this?
[03:57] <ScottSteiner-> How can I make ffmpeg use a subtitle's timestamps when i seek before the input file is loaded?  ie ffmpeg -ss 00:01:00 clip.mkv -vf "ass=subtitle.ass" output.mkv
[03:59] <sacarasc> So, if you seek to 1 minute, and a sub is meant to be up from like 58 to 1:02, you want it to show?
[04:00] <ScottSteiner-> yes.  if i seek to 1 minute and do a 10 second clip, it tries to show the subtitles for 00:00:00 through 00:00:10 instead
[04:00] <sacarasc> Oh, that's weird.
[04:00] <sacarasc> I don't know, then.
[04:00] <relaxed> you'll probably have to edit subtitle.ass
[07:28] <sim590> I'm creating a video with sound by merging an audio file and a video file. when I start the process, it seems to take alot of time. Do I always have to wait the length of media to wait for it to complete or what ? It seems that if I have a file that is 1 minute long, I have to wait 1 minute for it to process through ffmpeg... ?
[08:34] <pagioss> hi all, is there an executable that install ffmpeg on windows just like a normal software?
[08:45] <pzich> what do you mean like normal software? you mean not using the prompt to run it?
[09:14] <pagioss> pzich: yes
[10:19] <sim590> why doesn't ffmpeg stop at t=73 seconds when I do this : ffmpeg -t 73 -i out.mkv -ss "00:27:33" -i ~/Musique/Écoute/gaming/The\ Legend\ of\ Zelda\ Ocarina\ of\ Time\ Soundtrack-ZzwvItK3JPI.mp3 -af "afade=t=out:st=69:d=3" out_son.mkv
[10:30] <blippyp> maybe the track is shorter than a 1 minute and 40.33 seconds?
[10:30] <blippyp> I normally put the -t near the end, not sure if that makes a difference..??
[10:31] <blippyp> what are you trying to do - you have two inputs and your -t and -ss are at the beginning?
[12:45] <intracube> hello. is there any way to make the deshake filter more aggressive?
[13:14] <TheMechanist> hi all
[13:15] <TheMechanist> Does anyone of you know a way to compare to video files in a player? In essence I have two files that I want to play simultaneously and flip back and forth between their display to see the (subjective) quality difference between them....
[13:57] <Sairon> I'm trying encode a png sequence with libx265, when I run 'ffmpeg.exe -r 59.94 -f image2 -i Intro_2%04d.png -strict experimental -c:v libx265 -preset slow test.mp4' I get '[libx265 @ 04825940] 4:4:4 support is not fully defined for HEVC yet. Set -strict experimental to encode anyway.', if I do I get a blank output as result. 4:4:4 seems to indicate some kind of chroma sub sampling, from my
[13:57] <Sairon> understanding the problem is on the output end ( output stream is stated as yuv444p ). If that's likely the case, how do I change the output pixel format passed to libx265?
[14:11] <intracube> Sairon: -pix_fmt yuv420p
[14:12] <intracube> to show all available pixel formats: ffmpeg -pix_fmts
[14:12] <Sairon> awesome, that seems to do the trick :)
[14:12] <Sairon> thanks a lot
[14:13] <intracube> not sure if yuv420p is optimum for you but it's what I always default to
[14:19] <iive> 4:4:4 means that there is no chroma sub sampling, that is you have 3 full components for each pixel in yuv mode.
[14:20] <iive> 4:2:0 means that color differential chroma components (UV) are at half resolution (Vertically and Horizontally, so totally quarter the size)
[14:22] <iive> the lower resolution means data loss, that's why when converting from rgb yuv444 is picked. However most broadcast quality video is at the tv format 420
[14:22] <Sairon> ah
[14:30] <Berra> I built ffmpeg from git and lost libavresample. How do I go about getting it back?
[14:31] <Berra> http://sprunge.us/TbGa Is any of these the same thing in practice?
[14:34] <excalibr> Hi! When you do direct copy from a video, is it possible to copy multiple timecode ranges in one go?
[14:34] <excalibr> eg 10-60sec, 120-300sec
[14:52] <c_14> ye, if you want one output file you'll need a filter_complex and the trim/concat filters. If you want them split to separate files, just use -ss and -t/-to before each individual output file.
[14:53] <c_14> Berra: recompile?
[14:54] <Berra> I updated my mpv to mpv-git and did not need that lib anymore.
[14:57] <c_14> I'm confused. How did you lose the libavresample? Did you delete it?
[15:00] <Berra> I installed the git version instead. Well now everything works anyway
[15:07] <c_14> Well, long as it works.
[16:18] <Keestu> hello, avcodec_decode_video2 (), does it have an impact on thread_count value on Codec Context ?
[16:24] <Neppy> hm for issues with ffmpegsource, should i ask here, in #avisynth or where else?
[16:29] <DeadSix27> Neppy, the owner of the repo is in this channel, and i cant see him anywhere else
[16:29] <DeadSix27> so i assume yes, here?
[16:36] <Neppy> ah
[16:39] <Neppy> well trying to open a mkv file (others i've tried in the past worked fine, just not this one) with ffvideosource/ffaudiosource; ffvideosource just complains there is no video track though :o when i extract the videotrack with mkvcutter and use the extracted .h264 file with ffvideosource it goes on without error but still errors at the ffaudiosource (which also tries to use the mkv file) which
[16:39] <Neppy> suggests either avs or ffmpegsource for some reason has an issue reading this mkv file.. i tried using track=0 and track=00 on ffvideosource (since mkvcutter adds _Track00 to the extracted filename) but then it says videotrack has no frames..
[16:39] <Neppy> using 32-bit avs with 32-bit (x86) ffms2 2.18 rc1.7 (windows 7 64-bit if that matters)
[16:39] <Neppy> well that got a bit long ^^"
[16:42] <DeadSix27> Neppy, that wasnt meant in the evil way btw, im not sure either, never had to ask for support yet.
[16:42] <DeadSix27> (for that piece of software i mean)
[16:44] <JEEB> Neppy, can you cut a small sample of that file to see how borked it is? You can use dd or something simple like that in most cases to cut off first 10-50MB
[16:44] <JEEB> also generally you should be using as new as possible ffms2 builds
[16:44] <JEEB> argh, this was not #avisynth
[16:45] <JEEB> goddamnit for you posting it on multiple channels :P
[16:45] <Neppy> haha
[16:45] <JEEB> libav* are used by ffms2, but on #ffmpeg in general it isn't on-topic. esp. since the matroska parser isn't lavf's
[16:46] <Neppy> ah
[16:46] <muken> optionally, you can use lavf's though
[17:51] <gneekd> how could i create a stream for ios devices from a number of different video files?  programatically...
[20:56] <voip_> hello guys
[20:56] <voip_> i am copy video stream
[20:56] <voip_> whats mean [flv @ 0x30cea20] pts (-74) < dts (40) in stream 0
[20:56] <voip_> av_interleaved_write_frame(): Invalid argument ?
[20:57] <voip_> ok
[21:01] <voip_> http://pastebin.com/Pg7wnFLv
[21:06] <voip_> fflogger, llogan http://pastebin.com/Pg7wnFLv
[21:16] <llogan> voip_: fflogger is a bot
[21:17] <llogan> -preset does nothing when you are re-encoding
[21:17] <llogan> s/re-encoding/stream copying
[21:30] <voip_> llogan, s/re-encoding/stream copying ?
[21:32] <llogan>  -preset does nothing when you are stream copying
[21:32] <llogan> not that this info helps you
[21:37] <voip_> ok, i am runing witout preset, some error
[21:45] <voip_> llogan, ffmpeg -i rtmp:// -acodec copy -vcodec copy -f flv rtmp://  same error
[21:59] <llogan> voip_: i don't know. try the ffmpeg-user mailing list.
[00:00] --- Wed May 21 2014

More information about the Ffmpeg-devel-irc mailing list