[Ffmpeg-devel-irc] ffmpeg.log.20140525

burek burek021 at gmail.com
Mon May 26 02:05:01 CEST 2014

[02:37] <Logicgate> is there a way I can resize a video and add black padding at the same time
[02:37] <Logicgate> example a video that's 856x480, I want it to keep its aspect ratio and become 480x480
[02:37] <Logicgate> and add black padding
[02:41] <klaxa> use scale and pad, see: http://www.ffmpeg.org/ffmpeg-filters.html#pad
[02:41] <Logicgate> http://puu.sh/8ZR07.png
[02:42] <Logicgate> this is what I get though
[02:42] <klaxa> your command string would clear up a lot
[02:43] <Logicgate> ffmpeg -i tmp2/1.mp4  -ss 00:00:00 -t 00:00:05.972639 -vf scale=480:-1  -vf 'pad=480:480:0:106:black' -c:v libx264 -c:v libfaac -ac 2 -deinterlace -b:a 96k -c:v libx264 -preset:v slow -profile:v baseline -level 3 -maxrate 10000000 -bufsize 10000000 -b:v 1200k -f mp4 -threads 0 -strict experimental -movflags faststart -vsync 2 -pix_fmt yuv420p tmp2/test.mp4
[02:43] <sacarasc> Try -vf scale=480:-1,pad=480:480:0:106:black
[02:44] <Logicgate> :D
[02:44] <Logicgate> it's twerking!
[02:45] <Logicgate> why does that work?
[02:45] <Logicgate> because it's in one statement
[02:46] <sacarasc> It works because it is one statement.
[02:46] <sacarasc> It only takes one -vf string, so you have to chain them.
[02:49] <Logicgate> awesome
[02:50] <Logicgate> -pix_fmt, will it fail if video is 4:4:4?
[08:34] <decci> Hi
[08:34] <decci> http://paste.ubuntu.com/7514089/
[08:34] <decci> I am try running the ffmpeg command but get converter with 0 byte
[08:35] <decci> How to fix it
[08:58] <wizbit> i want clients to be able to stream webcam using ffmpeg to a remote server running ffserver, then the output of ffserver embedded into a webpage using <video> or something like jplayer, is that possible?
[09:29] <decci> I encountered broken ffmpeg default settings detected issue while running ffmpeg
[09:29] <decci> Adding -vpre hq or vpre max solved this issue. May I know what it means
[09:30] <decci> I followed https://code.google.com/p/winff/issues/detail?id=89
[09:30] <relaxed> decci: read https://trac.ffmpeg.org/wiki/x264EncodingGuide
[09:30] <JEEB> if you have a new enough ffmpeg you shouldn't get that unless  you force a lot of retarded options
[09:30] <JEEB> if you have an old old ffmpeg then you're not gonna get much help :P
[09:31] <JEEB> because that stuff has gotten a /lot/ less retarded within the last three years
[09:32] <decci> relaxed: If I run without vpre it throws the error http://paste.ubuntu.com/7514294/
[09:32] <decci> relaxed: If I run putting vpre hq or max it runs well
[09:32] <decci> relaxed: Can you brief what was the issue
[09:33] <decci> JEEB: ffmpeg FFmpeg version 0.6.5, Copyright (c) 2000-2010 the FFmpeg developers   built on Jan 29 2012
[09:33] <relaxed> you're version is way out of date.
[09:33] <relaxed> your*
[09:33] <decci> JEEB: is that old..i just installed ffmpeg through yum
[09:33] <decci> relaxed: How to install newer version of ffmpeg
[09:33] <JEEB> yes, that version is from 2010 :)
[09:34] <decci> JEEB: May I know the link which talks about latest version
[09:34] <relaxed> decci: uname -a
[09:34] <decci> JEEB: I would prefer yum based installation
[09:34] <decci> relaxed:  uname -a Linux serv01.m2170.sgded.com 2.6.32-279.22.1.el6.x86_64 #1 SMP Wed Feb 6 03:10:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux root at serv01 [~]#
[09:35] <relaxed> http://johnvansickle.com/ffmpeg/
[09:35] <JEEB> decci, you'd have to find a repository then, which is something I think you wouldn't be able to find easily
[09:35] <relaxed> then follow the wiki guide I gave you earlier
[09:36] <decci> JEEB: let me check if newer repository is available
[09:36] <JEEB> static compiles and/or compiling yourself just happens to be much simpler than finding someone packaging it for you
[09:37] <decci> JEEB: May I know what version is latest
[09:37] <decci> JEEB: I will search with that version
[09:38] <JEEB> 2.2.2
[09:39] <decci> JEEB: http://dl.atrpms.net/el6-x86_64/atrpms/stable/ffmpeg-2.2.1-65.el6.x86_64.rpm
[09:40] <wizbit> im coming to the conclusion that its impossible to stream mp4 so iphones and android devices can play it
[09:40] <wizbit> mp4 is not a streamable format :(
[09:47] <JEEB> decci, well if that random repository is fine enough for you, then it's fine. Although it seems like it's already behind :P
[09:47] <JEEB> people often do one-offs or so
[09:47] <JEEB> wizbit, both true and untrue
[09:48] <JEEB> untrue because you can use movie fragments that will let a parser that supports them start playing right away
[09:48] <JEEB> true because I have no idea if android or iOS supports fragments :P
[11:38] <wizbit> JEEB: can ffserver stream mp4 files? i managed to get my webcam to stream in .swf format but not .mp4
[11:38] <JEEB> no idea about ffserver :P
[11:52] <klaxa> mp4 is not made for live-streaming anyway, is it?
[11:53] <JEEB> <JEEB> wizbit, both true and untrue
[11:53] <JEEB> <JEEB> untrue because you can use movie fragments that will let a parser that supports them start playing right away
[11:53] <JEEB> <JEEB> true because I have no idea if android or iOS supports fragments :P
[11:54] <JEEB> it's not the most straightforward thing you could be using for streaming
[11:54] <JEEB> but it isn't impossible
[12:12] <klaxa> ah
[12:18] <DelphiWorld> hi ffmpegsters
[12:18] <DelphiWorld> please, please. i'm stuck for weeks on an issue with hls
[12:18] <DelphiWorld> i cant include multiple audio track
[12:18] <DelphiWorld> if i do -map 0:1 -map 0:2 i get them when probing but i dont see the language
[12:19] <DelphiWorld> ffmpeg -re -i udp://@ -map 0:0 -map 0:8 -map 0:2 -c:v libx264 -crf 18 -profile:v baseline -maxrate 400k -bufsize 1835k -pix_fmt yuv420p -flags -global_header -bsf:v h264_mp4toannexb -r 30 -ab 32k -f segment -segment_time 10 -segment_list /tmp/hls/eu.m3u8 -initial_offset 10 segment_%05d.ts
[12:19] <decci> I am facing
[12:19] <decci> I am facing an issue
[12:20] <decci> When I upload any image I got error:-1
[12:30] <decci> Hello Guys
[12:32] <decci> While I try to upload a file through
[12:32] <DelphiWorld> guys...
[12:32] <decci> It doesnt work
[12:32] <decci> It reports error:1
[12:38] <DelphiWorld> relaxed ?
[12:39] <DelphiWorld> anyone do hls here?
[12:59] <DelphiWorld> hi iive
[13:00] <DelphiWorld> iimay you be able to help me with a small hls problem?
[13:00] <DelphiWorld> iive:   maybe you be able to help me with a small hls problem?
[13:01] <iive> i know nothing of http live stream
[13:01] <DelphiWorld> iive: its not a hls issue but i belieuv its a ts issue, may i explain?
[13:01] <iive> ask and be patient. somebody may know
[13:03] <DelphiWorld> ffmpeg command:
[13:03] <DelphiWorld> ffmpeg -re -i udp://@ -map 0:0 -map 0:2 -map 0:8 -c:v libx264 -vb 512k -c:a libfdk_aac -profile:a aac_he_v2 -b:a 32k -ac 2 -ar 44100 -f mp4 eu.mp4
[13:03] <DelphiWorld> this one give multi audio track on a mp4
[13:03] <DelphiWorld> work perfectly
[13:03] <DelphiWorld> but
[13:03] <DelphiWorld> if i segmant it into hls ansd not mp4...
[13:04] <DelphiWorld> when i probe i see the tracks but dont see the audio language describtion
[13:04] <DelphiWorld> like fr or en or ara
[13:04] <DelphiWorld> that's my problem
[13:07] <iive> just a wild guess. could this be related to not processing metadata? there was something about it...
[13:07] <DelphiWorld> iive: yeah, but why if i use .mp4 i see the tracks?
[13:07] <DelphiWorld> iive: you want a video?
[13:07] <iive> no, i can't do anything with it.
[13:08] <DelphiWorld> iive: you may just probe it online:P
[13:08] <iive> does mp4 have proper track description, like language?
[13:08] <DelphiWorld> yeah iive but ts is not doing that
[13:08] <decci> DelphiWorld: Can you please take care of your spellings
[13:09] <DelphiWorld> decci: yeah, if you give me your eyes :D
[13:09] <DelphiWorld> decci: i am blind but using tts:)
[13:10] <iive> decci: you are not helping.
[13:10] <decci> iive: I am aware
[13:10] <decci> iive: Sorry
[13:11] <DelphiWorld> iive: to be sure, i made a mp4 and now i'm hlsing it
[13:12] <DelphiWorld> ok, confirmed
[13:13] <DelphiWorld> -f mp4 ...test.mp4 give the track describtion
[13:13] <DelphiWorld> but -f hls or -f mpegts wont
[13:16] <iive> DelphiWorld:  could you put the text output of ffmpeg in some pastebin site. first with output to mp4 and second time with output to hls.
[13:16] <DelphiWorld> iive: the entire log?
[13:17] <iive> it shouldn't be more than one page. and yes, that is why i'm asking you to paste it to a pastebin website.
[13:17] <iive> if it is too much trouble for you, don't bother.
[13:18] <DelphiWorld> iive: no, i must
[13:18] <DelphiWorld> iive: you want it during encoding?
[13:18] <iive> but I wonder if it would say something different about metadata
[13:18] <DelphiWorld> iive: i'lle provide now
[13:20] <iive> I don't know about hls, but mpeg-ts dvb standard supports language codes. No idea about the libavformat muxer.
[13:21] <iive> e.g. from 'man ffmpeg' I found this example:
[13:21] <iive> To set the language of the first audio stream: ffmpeg -i INPUT -metadata:s:a:1 language=eng OUTPUT
[13:22] <DelphiWorld> iive: mp4 output: http://paste.debian.net/101670/
[13:28] <DelphiWorld> ffmpeg -re -i udp://@ -map 0:0 -map 0:8 -map 0:2 -c:v libx264 -vb 512k -c:a libfdk_aac -profile:a aac_he_v2 -b:a 32k -ac 2 -ar 44100 -f  hls -metadata:s:a:1 language=ara -metadata:s:a:1 language=eng /tmp/hls/eu.m3u8
[13:28] <DelphiWorld> this one provide also a ts, but... still metadata is not comming
[13:33] <iive> :s specifies it is about subtitles :a specifies it is (also) about audio and :1 specifies that it is about second stream.
[13:34] <iive> but it should have specified at least one of the streams.
[13:34] <DelphiWorld> iive: i'lle provide you ts output now
[13:35] <DelphiWorld> iive,   http://paste.debian.net/101671/
[13:39] <iive> both text outputs are almost identical. I'm out of ideas.
[13:39] <DelphiWorld> yeah...
[13:39] <iive> try moving the metadata command after the output
[13:39] <DelphiWorld> evean with the idea you gave me there's still no metadata
[13:40] <DelphiWorld> after the filename?
[13:40] <iive> yes
[13:40] <DelphiWorld> hold on
[13:40] <iive> the position of the options does matter.
[13:40] <DelphiWorld> i see
[13:42] <DelphiWorld> lol, same problem...
[13:46] <DelphiWorld> ffmpeg -re -i udp://@ -map 0:0 -map 0:8 -map 0:2 -c:v libx264 -vb 512k -c:a libfdk_aac -profile:a aac_he_v2 -b:a 32k -ac 2 -ar 44100 -f  hls  ./test.m3u8 -metadata:s:a:1 language=ara -metadata:s:a:2 language=eng
[13:52] <DelphiWorld> back
[13:52] <DelphiWorld> iive, fyi. the issue is not only a problem of metadata
[13:52] <DelphiWorld> but i dont evean see the tracks listed in client SIDE!
[13:53] <iive> as I said, I know nothing of hls. or libavformat muxers.
[13:53] <DelphiWorld> any way of getting it live except of hls?
[13:53] <iive> i hope somebody here would be able to help you.
[13:53] <iive> c_14 seems to know a lot, but he is away atm. probably asleep.
[13:53] <DelphiWorld> ;)
[13:54] <decci> Hi
[13:54] Action: DelphiWorld would be probably c_13 :P
[13:54] <decci> I need help with
[13:54] <DelphiWorld> Hi decci
[13:54] <dloo> hello
[13:55] <dloo> i'm trying to record v4l2 input, so i try : ffmpeg -f alsa -i hw:0,1 -f v4l2 -channel 1 -i /dev/video0 -vcodec libx264 -b 2500k -acodec copy test.mkv
[13:55] <dloo> i get this : http://i.imgur.com/2el9tub.png
[13:55] <dloo> what's wrong? :(
[13:56] <decci> DelphiWorld: While I run http://paste.ubuntu.com/7515147/ it runs well as upeoapp2 user
[13:56] <DelphiWorld> decci: i realy know nothing about this upload
[13:56] <decci> DelphiWorld: But whenever I run from web it throws error : -1
[13:58] <decci> DelphiWorld: Ok
[14:35] <dloo> nobody can help me?
[14:42] <iive> dloo: are you able to view normal image with any other program.
[14:42] <iive> dloo: is the channel 1 an composite input, not RF modulated one?
[14:43] <iive> sorry gtg
[14:47] <dloo> http://pastie.org/private/ml0o7tu2c6jdq2ryljhsbw
[14:47] <dloo> igitoor: yes, with vlc
[14:47] <dloo> damn
[14:54] <sacarasc> You missed the second part of what fflogger asked. :(
[14:55] <dloo> wait.. i think i got it :)
[16:25] <DelphiWorld> c_14: alive?
[19:43] <pqatsi> About ffserver, its possible to ffserver act just as a streaming relay, w/o re-encoding anything and being just a proxy?
[21:12] <satanist> wo krig ich jetzt ne maus her
[21:13] <satanist> ich will doch nur sauerbraten spielen
[21:38] <Tylertwo> Hey, anyone with experience streaming to twitch?
[21:40] Action: DelphiWorld back
[22:01] <Tylertwo> I'm trying to do so. Using the command "avconv -f x11grab -s 200x200 -r 15 -i :0.0 -c:v libx264 -pre fast -pix_fmt yuv420p -s 640x480 -threads 0 -f flv "rtmp://live.twitch.tv/app/live_<myPrivateKey>"" I get the error from twitch that "Audio codec must be set to MP3 or AAC (it is currently "unknown")". Any idea about fixing this?
[22:01] <c_14> -c:a $codec
[22:02] <c_14> This channel, however, does not provide support for avconv.
[22:02] <c_14> That would be #libav
[22:56] <Tylertwo> ok, thanks
[23:06] <dloo> hi
[23:06] <dloo> why this [harold at 855a-0d8d-2-53-k8vsed ~]$ ffmpeg -t 00:00:01 -f alsa -i hw:0,1 -f v4l2 -channel 1 -i /dev/video0 -standard 3 -vcodec libx264 -b 2500k -acodec copy  /run/media/harold/52F82754F827361F/k7/le_college_c_est_pas_sorcier.mkv  does not stop the record after 1 sec?
[23:07] <rsdrsdrsdrsd> Hi, I have a small question about filtering
[23:07] <c_14> dloo: -t isn't an input option, it's an output option
[23:07] <c_14> rsdrsdrsdrsd: ask, if someone can help you they will
[23:07] <dloo> c_14: i('ve tried to put it at the end of the command, it do the same
[23:07] <rsdrsdrsdrsd> ok that would be great
[23:07] <rsdrsdrsdrsd> thank you
[23:07] <rsdrsdrsdrsd> Here it comes
[23:08] <c_14> dloo: it should be right before output.mkv
[23:09] <rsdrsdrsdrsd> If I have the following filter -vf "crop=720:384:0:48,scale=trunc(480*dar/2)*2:480,setsar=1" the black border are chopped of but it looks like the dar in the scale filter isn't changed properly after the crop
[23:10] <dloo> c_14: thanks you, it is working :)
[23:11] <rsdrsdrsdrsd> if I remove the crop part and compare the videos the one with the crop part seems a bit more stretched than without the crop
[23:11] <rsdrsdrsdrsd> I would assume that with or without black borders the video should have the same aspect ratio
[23:12] <rsdrsdrsdrsd> but due to the cropping something goes wrong
[23:12] <c_14> try crop=720:384:0:48:1
[23:20] <rsdrsdrsdrsd> Hmm, that option removes the complete sar info
[23:26] <c_14> what exactly are you trying to do?
[23:27] <rsdrsdrsdrsd> I have a bunch of videos some with none square pixels I want to crop the bar and encode to fixed height
[23:27] <rsdrsdrsdrsd> and to square pixels
[23:28] <rsdrsdrsdrsd> I first run a crop detect command to check for the black bars
[23:29] <rsdrsdrsdrsd> and insert the outcome in the filter
[23:37] <rsdrsdrsdrsd> I am using ffmpeg version N-39361-g1524b0f
[23:45] <c_14> Why are you assuming that the video should have the same aspect ratio after cropping? Unless the bars are equidistant on all sides.
[23:47] <rsdrsdrsdrsd> I found out that without the 1 in the crop the frame size is changes as expected and the dar is also changed, the sar is kept the same
[23:47] <rsdrsdrsdrsd> that is ok
[23:47] <rsdrsdrsdrsd> buit after that someting goes wrong
[23:54] <rsdrsdrsdrsd> hmm, while comparing, cropping removes some 6x extra on both sides, that makes the difference
[00:00] --- Mon May 26 2014

More information about the Ffmpeg-devel-irc mailing list