[Ffmpeg-devel-irc] ffmpeg.log.20140526

burek burek021 at gmail.com
Tue May 27 02:05:01 CEST 2014

[00:22] <rsdrsdrsdrsd> it was the default division by 16 of the crop that made the difference in frame sizes ;-)
[00:47] <Trouffman> hey :)
[00:51] <Trouffman> I've been wondering if ffmpeg on linux is able to use the h264 stream from an UVC Webcam (C920 / C930 logitech) and send it over the network (without having to decode + re-encode as it is already encoded). The webcam can be setted to output the h264 strema with V4l2-ctl
[00:51] <c_14> https://trac.ffmpeg.org/wiki/How%20to%20capture%20a%20webcam%20input
[00:51] <c_14> -codec copy
[00:54] <Trouffman> thanks c_14 was actually lookign at the man pag to look a bit more in deep
[01:27] <Trouffman> I had to specify -vcodec h264 (before my device name) then -vcodec copy after , otherwise it was always reseting to the defaulf YUY2 (even if set with v4l2-ctl) I guess ffmpeg redifine the settigns when you donèt specify the right codec
[03:17] <Trouffman> finally got all i needed...
[03:18] <Trouffman> now having issue for streaming my input :/ : Goal Send the stream to wirecast (or VLC for now on.) using RTP or RTSP :/
[08:56] <woof-woof> is this a bug?
[08:56] <woof-woof> http://pastebin.com/4btUNtmT
[10:13] <DelphiWorld> hi ffmpegsters
[10:13] <DelphiWorld> so anyone on my hls issue?
[11:48] <allengreen> Can I transcode two file in two separated thread?
[11:49] <allengreen> cause there are a lot of global variables
[11:52] <_julian> anyone around who was involced in dca armv6 asm optimisation?
[11:52] <_julian> I'm wondering if some of them might be used in ac3 decoder as well?
[12:08] <DelphiWorld> anyone have a recomanded cdn for stream distribution?
[12:53] <peterparker> @ods15
[12:54] <peterparker> can you help Compile FFmpeg (the configure options have to be on one line)
[12:54] <peterparker> @od15
[12:54] <peterparker> @superdump
[12:54] <peterparker> @ubitux
[12:54] <peterparker> @'md
[12:54] <ubitux> peterparker: stop it now or i kick you
[12:54] <DelphiWorld> lol
[12:54] <peterparker> yeah hi
[12:55] <peterparker> can you help me compile ?
[12:55] <peterparker> I am following http://wiki.razuna.com/display/ecp/FFMpeg+Installation+on+CentOS+and+RedHat
[12:55] <peterparker> everything went smooth but got stuck on Compile FFmpeg (the configure options have to be on one line)
[12:55] <ubitux> official wiki is here: http://trac.ffmpeg.org/wiki/CompilationGuide
[12:55] <ubitux> use pastebin to paste your configure line and config.log if you have an issue
[12:55] <ubitux> and please stop hilighting random people
[12:57] <peterparker> will a image works here ?
[12:57] <peterparker> like this http://prntscr.com/3mpezs
[12:57] <DelphiWorld> peterparker: no, use pastebin
[12:57] <peterparker> ok
[12:57] <ubitux> also, just read the first sentence of that output
[12:59] <DelphiWorld> ubitux: any clue about my yesterday's AAC audio metadata issue?
[12:59] <ubitux> i have to go
[13:00] <DelphiWorld> okay
[13:00] <peterparker> I am pating it
[13:01] <peterparker> here http://pastebin.com/6P18n8wq DelphiWorld
[13:03] <DelphiWorld> what OS are you using
[13:04] <peterparker> CentOS 6.5
[13:04] <DelphiWorld> first of all SuckOs
[13:04] <DelphiWorld> i never has this issue in debian
[13:04] <peterparker> cpanel works on that only
[13:04] <DelphiWorld> you should create a tmp directory somewhere else
[13:04] <peterparker> I also love ubuntu
[13:04] <DelphiWorld> and specify the TMPDIR as a variable and point it to it
[13:05] <DelphiWorld> peterparker: you're not obligated to run cpanel on same server as ffmpeg...
[13:05] <peterparker> why spend more on a different server
[13:05] <peterparker> I am trying to run ffmpeg on the server for a test project
[13:06] <DelphiWorld> peterparker: ok ask tata to host you :-P
[13:06] <peterparker> so I ahve to create a tmp directory anywhere in the server and then edit configure file and mention the path
[13:06] <DelphiWorld> no need to edit configure file
[13:06] <DelphiWorld> montion the path in shell
[13:06] <DelphiWorld> in bash
[13:06] <peterparker> ok
[13:06] <peterparker> allrite be there
[13:06] <DelphiWorld> if i remember corectly export TMPDIR=/DIR
[13:07] <peterparker> by tata are you refering to my ISP ?
[13:07] <DelphiWorld> peterparker: to your country generaly lol
[13:07] <peterparker> heheheh
[13:12] <peterparker> same error everytime
[13:12] <peterparker> i have changed the path
[13:13] <peterparker> anyways thanks for help I gota go now will come back later
[13:13] <peterparker> DelphiWorld
[13:13] <DelphiWorld> ok
[13:17] <jkli> hi
[13:17] <DelphiWorld> hi
[13:18] <jkli> does it make sense to include deadzone settings if you already use crf?
[13:19] <jkli> err deblocking
[13:19] <jkli> not crf
[13:20] Action: DelphiWorld is not H.264 aware ;)
[13:20] <jkli> ah
[13:21] <jkli> well i see that a lot of encodings have problems with near black / dark backgrounds
[13:21] <jkli> they tend to fuse them together into one big area
[13:21] <jkli> it looks bad on films with lots of night scenes
[13:27] <iive> there are some x264 developers around, they know more stuff.
[13:29] <iive> i think deblocking settings control the loopfilter that is part of the decoding. aka frame is decoded then deblocked and the resulting image is used as reference for next frames.
[18:14] <xjunior> Hey guys& sorry to ask that, but I've been struggling with ffmpeg command line tool for a while now, getting many sorts of errors& I need to get a video, then 2 different input images and add them as an overlay, but at the same place, just different video time
[18:14] <xjunior> one for the first half of the video, the other for the second half
[18:14] <xjunior> Is that possible? Can someone gimme a light on how to do that?
[18:20] <c_14> I'd probably use a complex filter to split the source stream into two copies, trim the first one to the length you want overlay a to display, trim the second one to where you want overlay b to display, apply the overlay to each stream and then concat the video streams again.
[18:22] <klaxa> *filter complex
[18:26] <woof-woof> is this a bug? > http://pastebin.com/kKPp8kh9
[18:27] <klaxa> maybe
[18:27] <klaxa> include ffmpeg's output
[18:27] <woof-woof> Ok..
[18:37] <woof-woof> Here: http://pastebin.com/WTc43npX
[18:39] <spaam> and the when that does not work?
[18:40] <woof-woof> ?
[18:45] <woof-woof> It never works.
[18:49] <c_14> I'm not sure %ld is a valid filename pattern.
[18:51] <klaxa> it's %1d though
[18:51] <klaxa> hmm... is that valid?
[18:51] <c_14> I dislike fonts where I can't tell the 1 from an l...
[18:53] <woof-woof> %1d worked with bmp why not with jpg?
[18:53] <woof-woof> I think it means start with 1 digit?
[18:53] <woof-woof> Or no?
[18:56] <c_14> `ffmpeg -f image2 -i out%1d.jpg -vf interlace interlace%1d.png' works fine for me
[19:00] <woof-woof> Didn't work here...
[19:01] <c_14> Are the files named 1.jpg and 2.jpg ?
[19:01] <woof-woof> Tried that also, originally name 0, 1.jpg...
[19:04] <woof-woof> I don't have libopenjpeg... if that matters.
[19:08] <c_14> I don't have it either and it works for me.
[19:08] <c_14> Try it with a different source maybe?
[19:11] <c_14> ie if you have a video somewhere, ffmpeg -ss x -i video -frames:v 2 %1d.jpg; ffmpeg -f image2 -i %1d.jpg -vf interlace int%1d.png
[19:12] <woof-woof> Well, I want to interlace images.. Not videos.
[19:13] <woof-woof> that will happen if the source is JPEG... output as JPEG should work fine
[19:13] <c_14> I know, that command would have given you two jpegs that you could have tested with.
[19:15] <woof-woof> My jpegs were converted using ffmpeg... But it didn't work as well.
[19:17] <c_14> It's working for me, so I thought it might be a problem with the source so I asked if you had a different source you could test with and how you could create such a source.
[19:18] <woof-woof> ffmpeg bmp > jpeg
[19:21] <woof-woof> I have a statically compiled version here that it's not working as well... If could test with it
[19:23] <woof-woof> I am downloading another, maybe the problem is here.
[19:24] <c_14> I'm downloading the latest static as well, will test with it.
[19:26] <c_14> static build works for me as well
[19:30] <woof-woof> It worked for when I converted bmp > jpeg with it... I guess the version I was using was generating bad jpegs.
[19:30] <woof-woof> or I don't know.
[19:33] <woof-woof> c_14: the newer version is not working with some jpeg I have here...
[19:33] <woof-woof> if you could test with the same JPEG...
[19:37] <c_14> The jpegs I've been generating work, I'd need access to the ones you're using to test with them.
[19:38] <woof-woof> I'm uploading..
[19:41] <woof-woof> Here: woof-woof.site11.com/files/JPEG.tar
[19:43] <gouessej> Hi. I have a problem with all videos I recorded with a Samsung S3, it uses 3gp4 as a container format. The picture freezes but the audio continues in VLC. I've just tried to remux one of them with ffmpeg but it doesn't solve my problem.
[19:44] <woof-woof> gouessej, did you try playing it with ffplay?
[19:44] <c_14> woof-woof: Those 2 jpegs have different pixel_formats
[19:45] <c_14> 1 is yuvj402p and 2 is yuvj444p
[19:45] <woof-woof> that is the problem then?
[19:45] <gouessej> yes, it's the same
[19:45] <c_14> *420
[19:45] <c_14> I would guess so.
[19:45] <gouessej> Duration: 00:06:22.98, start: 0.000000, bitrate: 17149 kb/s     Stream #0:0(eng): Video: h264 (High) (avc1 / 0x31637661), yuv420p, 1920x1080, 17021 kb/s, 30.04 fps, 30.08 tbr, 90k tbn, 180k tbc     Metadata:       creation_time   : 2014-05-24 13:35:39       handler_name    : VideoHandle     Stream #0:1(eng): Audio: aac (mp4a / 0x6134706D), 48000 Hz, stereo, fltp, 123 kb/s     Metadata:       creation_time   : 2014-05-24 13:35:39    
[19:46] <c_14> woof-woof: Ye, I converted 2.jpg to yuvj420p and then tried interlacing again and it worked.
[19:46] <c_14> gouessej: next time pastebin, it's less spammy and you can keep the formatting to make it easier to read
[19:47] <gouessej> oops, sorry
[19:47] <c_14> gouessej: can you upload a sample video somewhere?
[19:48] <gouessej> yes
[19:48] <gouessej> I can put it onto my SFTP
[19:49] <DeadSix27> anyone can tell me what "v410" is?
[19:49] <DeadSix27> in the context, that it shows up as videoformat: v410
[19:49] <DeadSix27> probably uncompressed?
[19:50] <woof-woof> c_14: Yea, that was the problem actually.
[19:51] <c_14> DeadSix27: v410                 Uncompressed 4:4:4 10-bit
[19:51] <DeadSix27> ah kk
[19:52] <DeadSix27> hx.
[19:52] <DeadSix27> +t
[20:08] <gouessej> Done: http://tuer.sourceforge.net/videos/Video20140524_152907_remuxed.mp4
[20:13] <gouessej> woof-woof, does it play correctly on your computer?
[20:15] <woof-woof> I will check it
[20:16] <gouessej> thanks
[20:16] <woof-woof> Downloading.. 59MB will take few minutes here.
[20:18] <c_14> gouessej: all 28 seconds play fine here
[20:21] <gouessej> thanks c_14. My machine is quite old, it was bought in 2005
[20:22] <gouessej> I'm under Mageia Linux 3, 32 bits.
[20:22] <gouessej> AMD Sempron 2600+
[20:23] <gouessej> I fear my version of ffmpeg is obsolete
[20:23] <gouessej> 1.1.8
[20:23] <c_14> That is rather old.
[20:26] <gouessej> Mageia Linux 4 uses ffmpeg 2.0.3. I have to upgrade. I hope it will solve my problem.
[20:44] <woof-woof> it plays fine here.
[00:00] --- Tue May 27 2014

More information about the Ffmpeg-devel-irc mailing list