[Ffmpeg-devel-irc] ffmpeg.log.20140530

burek burek021 at gmail.com
Sat May 31 02:05:01 CEST 2014

[00:17] <llogan> c_14: the -t input documentation was added only a few days ago
[00:23] <bencc> I like to follow the recent trends and fashion :)
[00:23] <bencc> it could be ince to have "-to" work for input as well
[00:46] <FVG> llogan: it seems to not be crackling now after i purged every package related to pulse except libpulse0 (because mpv depended on it)
[00:50] <llogan> FVG: strange.
[03:09] <FVG> when i'm outputting to an flv rtmp stream, i always receive alsa buffer xrun at the start, and this causes the audio to lag behind the video by 1-2 seconds. doesn't happen if i output to a file
[03:09] <FVG> can anyone help?
[03:18] <FVG> if i hack the alsa_buffer_size_max value in the header and rebuild ffmpeg would it cause any problems?
[03:20] <relaxed> FVG: Are you using a recent version?
[03:21] <FVG> yeah
[03:24] <relaxed> FVG: did you see http://trac.ffmpeg.org/ticket/615 ?
[03:28] <FVG> looks like one person says it helped and another it didnt
[03:28] <FVG> i'll try streaming just audio to rtmp and see if it happens
[03:28] <relaxed> at the end it was solved by lowering the frame rate or frame size
[03:29] <relaxed> you could also try using pulse, but I have no idea if that will change anything.
[03:31] <FVG> when i used pulse it gave me crackly audio
[03:37] <IRCMonkey> So I'm trying to help a friend with streaming with ffmpeg
[03:38] <IRCMonkey> he's compiled it with librtmp
[03:38] <IRCMonkey> He's having issues with the framerate
[03:38] <IRCMonkey> This is what he said about it http://pastebin.com/yiaVEPUV
[03:39] <IRCMonkey> Pretty much it would encode the frames and send them faster than what mogulus would play I think? even though the frame rate is suppose to be much much lower
[03:39] <klaxa> maybe your friend should join freenode and #ffmpeg
[03:40] <klaxa> also pastebin the complete output including command (excluding API keys for twitch, etc.)
[03:40] <IRCMonkey> Probably but he's reading man pages
[03:40] <IRCMonkey> or went to bed
[03:40] <klaxa> he can come back tomorrow
[03:40] <IRCMonkey> wanted to see what we could get done before that
[03:40] <klaxa> without most of the information requested we can only guess things
[03:41] <FVG> i raised the buffer value and rebuilt it, and also tried streaming audio only to rtmp at a very low bitrate, and it still gives me one alsa buffer xrun at the start
[03:41] <klaxa> try setting -r value, try setting -vf "fps=value"
[03:41] <klaxa> maybe the error is located somewhere else entirely
[03:42] <FVG> -r 0, -r 1, -r 10 didn't change anything
[03:43] <klaxa> oh that wasn't directed at you...
[03:43] <klaxa> i have no idea about alsa, i had those xruns too back when i used alsa with dmix, after switching to pulse i had no issues anymore
[03:44] <IRCMonkey> http://pastebin.com/8wVfhANT
[03:44] <FVG> oh
[03:44] <IRCMonkey> That's what my guy was trying to use
[03:44] <IRCMonkey> well, I replaced the channel name and put *** for login/password
[03:46] <klaxa> i don't know, doesn't seem wrong at first glance
[03:46] <klaxa> but definitely lacks ffmpeg's output
[03:47] <IRCMonkey> Yeah, I don't think he gave me much of that
[03:47] <IRCMonkey> other than that line he gave me in the other pastebin
[03:50] <IRCMonkey> Guessing you can't render any more help on the subject unless I somehow get the output logs?
[03:50] <klaxa> oh wait
[03:50] <klaxa> i think i know what he wants
[03:51] <klaxa> use the -re flag
[03:51] <klaxa> it will read the file in real-time
[03:51] <klaxa> IRCMonkey: http://ffmpeg.org/ffmpeg.html search for "-re"
[04:04] <FVG> there's still a desync between audio and video with pulse, but it doesn't give that xrun message anymore
[04:07] <GEEGEEGEE> Is there a way to make ffmpeg use new video streams instead of stopping? It says "New video stream 0:3 at pos:3609684600 and DTS:24197.8s" and "New audio stream 0:2 at pos:3609667492 and DTS:24197.5s" and stops outputting video at the moment
[04:12] <erisco> I have already constructed AVCodec and AVCodecContext ... I am encoding frames to a buffer with avcodec_encode_video
[04:12] <erisco> how do I now write the encoded data to a file using some video format? I know I need to use avformat but the examples I can find are unclear on what to do in my case
[06:18] <erisco> I want to write to a file. What does my AVIOContext need to be?
[06:20] <tcwandrew> hello
[06:30] <erisco> what is the easiest way to make an empty options object? AVDictionary **
[07:38] <erisco> avformat_write_header returns -22, which means invalid argument. what are potential causes of this?
[07:50] <FVG> if anyone remembers, just wanted to say my ffmpeg streaming problem was fixed by removing the -r switch and changing my .asoundrc. don't even need pulse now and there's no more a/v desync :D
[10:20] <Syffs> Hello, I'm trying to understand why when I burn srt subtitle into a mkv, the subtitle codec then appears as text instead of subrip or srt: Stream #0:2(eng): Subtitle: text (default)
[10:21] <ubitux> "burn"?
[10:21] <ubitux> you mean mux?
[10:21] <ubitux> burn=hardsub, onto the video
[10:21] <Syffs> yes
[10:22] <Syffs> mux
[10:22] <Syffs> See http://pastebin.com/httVhkYw
[10:23] <ubitux> wow, 0.10
[10:23] <ubitux> blast from the past ;)
[10:23] <Syffs> is that why ?
[10:23] <ubitux>     Stream #0:1: Subtitle: subrip (default)
[10:23] <ubitux> this is what i get here with a recent versionb
[10:23] <ubitux> -b
[10:24] <Syffs> arf
[10:24] <Syffs> so I should rebuild ffmpeg from sources
[10:25] <ubitux> 0.10 was initially release in january 2012
[10:25] <ubitux> it's not even on the ffmpeg download page anymore
[10:26] <ubitux> i don't know, there are several ways of getting ffmpeg, depends on your needs
[10:26] <Syffs> yeah, honestly I simply installed it from centos yum repo
[10:26] <ubitux> btw, you should be able to -c:s copy
[10:27] <Syffs> I did that as well
[10:27] <Syffs> but same result
[10:27] <Syffs> I simply forced the codec hoping it would appear as expected
[10:27] <ubitux> it's probably just a hint btw
[10:28] <ubitux> i mean, it shouldn't hurt
[10:28] <ubitux> markup is probably in anyway
[10:28] <ubitux> like, with a recent ffmpeg with that exact same output file you have here, it will probably displays "subrip"
[10:29] <Syffs> well, text subtitles could mean anything not necessarily subrip
[10:29] <ubitux> there is no distinction in matroska
[10:29] <Syffs> and in my case ffmpeg is used as a third party, so my main application sees text as a unknown codec
[10:30] <ubitux> subrip is just random text with random shitty html tags sometimes
[10:30] <ubitux> can't you force the subrip decoder?
[10:31] <ubitux> well anyway, you'd better upgrade
[10:31] <Syffs> of course, I think it might be a limitation from my main application, expecting a newer ffmpeg output
[10:31] <Syffs> thanks a lot for your help
[10:32] <Syffs> do you know if there's some ffmpeg dedicated yum repos which could avoid me from building it from the sources to get a newer version?
[10:35] <ubitux> no idea, but there are static built you could try
[10:35] <ubitux> but that won't provide you the libraries
[10:35] <ubitux> so not sure how you'll deal with it within your application
[10:37] <Syffs> ok thx, I'l try to find such a repo
[10:37] <Syffs> then i ll build it from scratch from the sources, if I don't find any
[10:39] <ubitux> if you don't need any library, builtin from sources is pretty straightforward
[10:39] <ubitux> building*
[10:39] <ubitux> any external libraries i mean
[10:40] <vovcia> hi)
[10:40] <Syffs> I need to dig into this, but I thk I do need some external libraries :P
[10:40] <vovcia> i have strange effect with ffplay: im trying to play raw stream ffplay -video_size 1280x360 -f rawvideo -
[10:41] <vovcia> the image is moved to right, and few cm of the right part is on the left
[10:41] <vovcia> and it freezes))
[10:41] <vovcia> what did i forgot?
[10:42] <ubitux> the pixel format?
[10:42] <ubitux> wrong dimensions?
[10:42] <vovcia> dimensions are right
[10:42] <vovcia> i was trying to change pixel format and image was messed up, but it was at least moving
[10:43] <vovcia> w8 ill past whole command
[10:44] <vovcia> http://pastebin.com/4RAGmnEf
[15:50] <ahtapot> hey i have old pc so its get too excited when im trying to capture my desktop with audio
[15:51] <ahtapot> is there any way to doit not on the fly encoding
[15:51] <bZalok> hi
[15:51] <ahtapot> hello
[15:51] <bZalok> I'd like to know more about channel to stream
[15:52] <bZalok> because I'm trying to get a volumedetect out of each channel
[15:52] <bZalok> of an audio stream and I get the same histogram for each channel of a 7.1 sound, and I guess that can't be right
[15:53] <ahtapot> c_14, fflogger http://pastebin.com/LfuPyY1H this is the script i found on the net that worked for me
[15:54] <ahtapot> but like i said computer was overheating and ready to fly to the moon
[15:56] <c_14> ahtapot: try using a -c:v rawvideo instead of -vcodec libx264 -preset ultrafast, should use less cpu but filesize will bloat very quickly.
[15:56] <ahtapot> cheers mate ill give it try now
[15:58] <bZalok> http://pastie.org/private/mwydqattykkep9w8qc7imw
[16:02] <bZalok> even though I think that I'm splitting each channel into a stream, then do a volumedetect, that can't be right
[16:03] <ahtapot> even though i slowed down the rate its better than before but not good enogh cause im also doing latex compiling on the video
[16:07] <c_14> bZalok: I'm not sure -af takes stream options, you'll have to put the -af volumedetect after ever map_channel part, and every map channel part needs an output file or it's going to complain, use something like -f matroska /dev/null
[16:07] <bZalok> yeah, there was a -f null
[16:08] <bZalok> my cli string was too long and was clipped
[16:09] <karika200> hi
[16:09] <bZalok> so I need to do a -map -map_channel -af "volumedetect" -f null NUL on each of the channels?
[16:09] <c_14> bZalok: I'd try that, yes
[16:10] <karika200> I set up an ffmpeg+ffserver combo and the stream works, I have image and sound, but my input source is an RTSP stream and I get constantly this messages: RTP: missed 2 packets
[16:10] <karika200> and my video is freezing
[16:11] <karika200> What can cause the packet loss? My network is ok I think it's an ffmpeg error
[16:18] <bZalok> it doesn't change a thing http://pastie.org/private/myqphbouemzc6bglfoiqa
[16:18] <bZalok> ...it still gets me a perfectly identical result
[16:19] <bZalok> could I do a -af{channel information} "volumedetect" without all the mapping?
[16:24] <c_14> You could try it.
[16:27] <bZalok> I trie doing -af:0.1.0 "volumedetect" -af:0.1.7 "volumedetect" and now, I have a sigle volumedetect output
[16:28] <bZalok> which is the same as those mapped outputs anyway
[16:30] <c_14> I just checked my 5.1 file with different channel mappings and volumedetect and both gave me the same output so it might just be normal that volumedetect provides the same output for all the channels of multichannel streams.
[16:30] <c_14> Also checked a stereo file, same thing.
[16:31] <bZalok> so I would have to export each channel and do a volumedetect on each seperate file?
[16:31] <bZalok> is there some way to chain the pan command to volumedetect?
[16:32] <bZalok> I've tried with a MXF file with multiple audio streams and I get different volumedetect values
[16:32] <c_14> you can use a simple filterchain -af pan,volumedetect
[16:40] <bZalok> ok, is there any documentation on chains
[16:41] <bZalok> examples to help me get how to do my command
[16:41] <c_14> https://ffmpeg.org/ffmpeg-filters.html#Filtergraph-description
[16:42] <c_14> https://trac.ffmpeg.org/wiki/FilteringGuide
[16:47] <bZalok> great, that second wiki entry is far clearer for me
[16:55] <bZalok> but then, would I do a pan c:0=a:0 to split in streams using pan?
[16:59] <bZalok> but I guess it would be a dead end anyway: http://pastie.org/private/hwxzs5wifkzpzqiblkocg
[17:00] <c_14> use a comma, not a semicolon
[17:02] <bZalok> yeah, I saw that as well, but when I did it with a comma, it did only one soundvolume
[17:03] <bZalok> another dead end, then.
[17:05] <bZalok> but perhaps my pan is wrong, as in the output section, I get a video and an audio, not 8 streams http://pastie.org/private/t7ujscfdcedylu5bkem5w
[17:08] <bZalok> my final option would be to mute every channel except one, do a volumedetect
[17:09] <bZalok> but that would be much slower, I guess
[17:09] <c_14> You're getting the video because of the implicit map. And the pan doesn't do streams, only channels.
[17:10] <c_14> I would probably try the muting thing.
[17:10] <bZalok> is there some way to make it all in a single command or I'll have to do multiple calls?
[17:12] <c_14> ye, use multiple outputs and do pan="mono:c1=c1" out1 -af pan="mono:c2=c1" out2 etc then volumedetect them or try adding the volumedetect into the filterchain
[17:18] <bZalok> I get a Invalid out channel name "c7=c"
[17:18] <c_14> c7=c1
[17:19] <bZalok> yep, I know... look: http://pastie.org/private/bnmuifzhlpuli1qb3tub8a
[17:21] <c_14> pretty sure that pipe should be a :
[17:21] <bZalok> yeah, without the typo, it still does this http://pastie.org/private/id6gnotp5rsdvmjtyzilg
[17:22] <c_14> try c0=c7
[17:23] <c_14> I think I messed up earlier, 0 indexed and out=in
[17:23] <c_14> Not 1-indexed and in=out
[17:26] <bZalok> that seems to be working chained for one channel
[17:27] <bZalok> and yes, it does work
[17:27] <bZalok> but I seem to have video on both outputs
[17:27] <bZalok> and -vn did not seem to make any difference
[17:28] <c_14> -map -0:v maybe?
[17:29] <bZalok> -map -0:v matches no streams, it would seem
[17:30] <c_14> Then there shouldn't be video...
[17:30] <bZalok> well, it's in the stream mapping : http://pastie.org/private/gdsj2arx1a2h6gccm18za#32,56-60
[17:31] <c_14> -vn is an output option, not an input option
[17:31] <c_14> You have to specify it in front of each output
[17:32] <bZalok> oh
[17:33] <bZalok> great, it works at last!
[17:35] <bZalok> thanks a lot
[17:36] <c_14> np
[18:20] <DelphiWorld> hi Kingdom of FFMPEG:P
[18:21] <DelphiWorld> i have a .mp4 file with H.264/AAC
[18:21] <DelphiWorld> how to remove the video track?
[18:21] <c_14> ffmpeg -i $file -vn -codec copy outfile
[18:21] <DelphiWorld> oh vn
[18:21] <DelphiWorld> now i remember -vn:)
[18:22] <francogrex> I amtrying to hardsub a movie.avi with ass subs. The subtitles are fine if I play the movie separately it reads ok from the movie.ass subs
[18:23] <c_14> francogrex: https://trac.ffmpeg.org/wiki/HowToBurnSubtitlesIntoVideo
[18:23] <francogrex> but doing this : ffmpeg -ss 300 -i movie.avi  -r 25 -vf "ass=movie.ass" -t 30 movie-subs.mp4 doesn't add any subs into movie-subs.mp4 ?
[18:23] <francogrex> c_14: ^
[18:23] <c_14> If you use -ss as an input option with subtitles stuff happens, use it as an output option. It'll take longer but will work.
[18:23] <c_14> If you want I can explain why.
[18:24] <DelphiWorld> c_14: for output (audio) no need to specify a container?
[18:24] <francogrex> c_14: NOT NECESSARY BUT AN EXAMPLE OULD BE NICE
[18:24] <francogrex> sorry
[18:24] <francogrex> erreor upcase
[18:24] <c_14> francogrex: ffmpeg -i movie.avi -ss 300 -r 25 -vf "ass=movie.ass" -t 30 movie-subs.mp4
[18:24] <francogrex> ok
[18:25] <c_14> DelphiWorld: depends
[18:25] <DelphiWorld> c_14: mp3 or aac
[18:25] <c_14> DelphiWorld: just use file.mp3 or file.aac as output file
[18:26] <DelphiWorld> awesome
[18:28] <DelphiWorld> c_14: ogg look nice;)
[18:28] <francogrex> c_14: thanks works fine now :)
[18:30] <DelphiWorld> ogg give flac audio
[18:31] <c_14> The file extension for flac is .flac
[18:31] <DelphiWorld> yeah but .ogg give flac audio inside
[18:32] <c_14> ogg should default to vorbis
[18:33] <DelphiWorld> c_14: this is not a issue, i will pb you so maybe its a ffmpeg bug
[18:33] <francogrex> ffmpeg -i movie.avi -ss 300 -r 25 -vf "ass=movie.ass" -t 30 movie-subs.mp4
[18:33] <DelphiWorld> c_14: i'm using mp3 regardless:)
[18:33] <francogrex> mp4 extension works better for some reason but it's ok
[20:04] <asherawelan> can i ask a avconv question here as well?
[20:04] <c_14> avconv support is in #libav, tried asking there?
[20:05] <asherawelan> thanks - will fo
[20:05] <asherawelan> *do
[20:15] <asherawelan> No real help there....
[20:16] <asherawelan> this is my question:
[20:16] <asherawelan> Hello, Im using avconv to proxy an rtsp feed, but get this error - can someone point me in the right direction& [mpeg1video @ 0x8d06e20] Error, Invalid timestamp=0, last=0
[20:38] <Mista_D> the gmane server is broken for now. Can anyone help with filter complex concat? I want to add a bumper to a video file, while inverse-telecine'ing the video file but not bumper. All in one run?... -i ${BUMPER}.mp4 -i ${VIDEO1} -filter_complex '[0:0] [0:1] [1:0] [1:1] concat=n=2:v=1:a=1 [v] [a],  -map [v] -map [a]"
[23:29] <c_14> Mista_D: try -filter_complex '[1:0]pullup[tmp];[0:0][0:1][tmp][1:1]concat=n=2:v=1:a=1[v][a]' -map '[v]' -map '[a]'
[23:47] <Mista_D> c_14: Thanks!
[00:00] --- Sat May 31 2014

More information about the Ffmpeg-devel-irc mailing list