[Ffmpeg-devel-irc] ffmpeg.log.20150809

burek burek021 at gmail.com
Mon Aug 10 02:05:01 CEST 2015

[05:24:44 CEST] <mrboc> greetings
[05:31:35 CEST] <mrboc> Is anyone familiar with using ffmpeg for transcoding to uPnP clients?
[09:19:56 CEST] <chungy> With the concat protocol, can you escape ' characters in file names?
[09:20:11 CEST] <chungy> I've tried both \' and '' without luck.
[09:24:07 CEST] <mrboc> have you tried double quotes
[09:44:47 CEST] <chungy> Just did, doesn't work, only single quotes are valid (and it would just shift the problem to escaping double quotes in file names, too... :/)
[16:56:37 CEST] <Stalkr_> Any idea why `-t hh:mm:ss` is getting ignored? It just keeps going past the duration. `-t s` works fine though
[16:58:45 CEST] <Stalkr_> I have tried `ffmpeg -ss 00:03:55 -t 00:04:00 -i INPUT -c:v libx264 -c:a libfdk_aac OUT.mp4` and `ffmpeg -ss 00:03:55 -i INPUT -c:v libx264 -c:a libfdk_aac -t 00:04:00 OUT.mp4` without success
[17:47:50 CEST] <durandal_1707> Stalkr_: it worked before?
[17:48:12 CEST] <Stalkr_> durandal_1707: First time I try
[18:25:11 CEST] <c_14> Stalkr_: are you confusing -t and -to ?
[18:39:32 CEST] <Stalkr_> c_14: I think I was. Found out the difference. It had to do with specifying -ss before the input file though, helped to move it after the input. However I am trying to do "re-encode"-free cutting with -c copy, but this causes the output file to initially freeze. Any idea why that is?
[18:40:09 CEST] <Stalkr_> The first second or so freezes
[18:40:15 CEST] <c_14> While cutting or while playing the output file?
[18:40:43 CEST] <Stalkr_> Playing it
[18:40:59 CEST] <c_14> Maybe your player doesn't like negative timestamps.
[18:42:17 CEST] <Stalkr_> Does seem to be happening in VLC but not MPlayerX
[18:42:20 CEST] <Stalkr_> Can it be fixed?
[18:42:53 CEST] <Stalkr_> Just doing: ffmpeg -i rm.mkv -ss 00:10:00 -t 12 -c copy out.mkv
[18:43:02 CEST] <c_14> Either fix the player or reencode the video while cutting.
[18:43:16 CEST] <c_14> When you copy the video codec you have to cut at the nearest I-frame.
[18:43:42 CEST] <c_14> If that frame is before the seek point you want ffmpeg gives those frames a negative timestamp so that players won't play them.
[18:44:00 CEST] <Stalkr_> Should I just enable -accurate_seek?
[18:44:27 CEST] <Stalkr_> "When doing stream copy or when -noaccurate_seek is used, it will be preserved"
[18:44:33 CEST] <Stalkr_> I assume that's what I am doing
[18:45:14 CEST] <c_14> It's enabled by default.
[18:45:29 CEST] <c_14> It just doesn't work with codec copy
[18:45:59 CEST] <Stalkr_> So it can't be enabled with codec copy?
[18:46:29 CEST] <Stalkr_> Sounds like the easiest is just to re-encode (unfortunately)
[00:00:00 CEST] --- Mon Aug 10 2015

More information about the Ffmpeg-devel-irc mailing list