[Ffmpeg-devel-irc] ffmpeg.log.20150810

burek burek021 at gmail.com
Tue Aug 11 02:05:01 CEST 2015

[00:14:04 CEST] <puzzles> Hello all, I'm having a problem encoding a PPM stream piped from another program stops encoding after exactly 360 frames. There is no error, ffmpeg just gracefully stops.
[00:14:42 CEST] <puzzles> ffmpeg version 2.7.2-1
[00:16:18 CEST] <puzzles> c_14: http://0a5cf807cb72f95a.paste.se/
[00:17:39 CEST] <c_14> Get rid of the -t 6
[00:19:43 CEST] <puzzles> c_14: Thanks. I managed to push past 360 frames, at least. I take it multithreading is still experimental?
[00:20:57 CEST] <c_14> -t isn't short for threads
[00:21:27 CEST] <c_14> https://ffmpeg.org/ffmpeg.html#Main-options
[00:21:31 CEST] Action: puzzles facepalms
[00:24:29 CEST] <puzzles> c_14: Thanks. I had tried it without the -t option before, but was missing some other options which gave a similar problem.
[05:36:15 CEST] <eijin> i have a h264 file encoded with x264.exe. im trying to use ffmpeg to convert it to mp4, the output mp4 ends up being variable frame rate mode but the source is contant frame rate
[05:36:24 CEST] <eijin> ffmpeg -i file.h264 -r 29.970 -vcodec copy file.mp4
[05:36:35 CEST] <eijin> i even specified the frame rate with -r. any idea what im doing wrong?
[08:31:53 CEST] <relaxed> eijin: ffmpeg -r 30000/1001 -i file.h264 -c copy output.mp4
[08:54:07 CEST] <eijin> relaxed doesn't seem to work
[08:54:10 CEST] <eijin> ffmpeg -r 30000/1001 -i file.h264 -c copy output.mp4
[08:54:10 CEST] <eijin> mediainfo output.mp4
[08:54:10 CEST] <eijin> Frame rate mode                          : Variable
[08:54:10 CEST] <eijin> Frame rate                               : 29.970 fps
[08:54:10 CEST] <eijin> Minimum frame rate                       : 25.000 fps
[09:23:20 CEST] <relaxed> eijin: oh, try ffmpeg -framerate 30000/1001 -i file.h264 -c copy output.mp4
[09:26:22 CEST] <relaxed> ffmpeg -h demuxer=h264
[09:26:58 CEST] <durandal_1707> how you expect to framerate change if you use copy and trust mediainfo output
[09:33:11 CEST] <relaxed> it works with stream copying
[10:04:37 CEST] <satinder> Hi , How I can use ffmpeg libraries in my own c code ?? please help .
[10:09:49 CEST] <JEEB> there are examples in the source tree
[10:10:01 CEST] <JEEB> https://github.com/FFmpeg/FFmpeg/tree/master/doc/examples
[10:13:39 CEST] <satinder> I want make a c program using ffmpeg library for detect the vocals from any mp4 song
[10:14:05 CEST] <satinder> is that possible with ffmpeg library ?? please help .
[10:33:35 CEST] <eijin> relaxed> eijin: oh, try ffmpeg -framerate 30000/1001 -i file.h264 -c copy output.mp4
[10:33:38 CEST] <eijin> why did that work :p
[10:33:58 CEST] <eijin> i tried -r initially shouldnt -r be the same as -framerate?
[10:55:55 CEST] <eijin> even viewing ffmpeg -h long i dont see -framerate just -r
[10:58:48 CEST] <JEEB> framerate is an muxer-specific option IIRC
[10:58:52 CEST] <JEEB> *a
[10:59:19 CEST] <JEEB> uhh, also I meant *demuxer-specific
[10:59:25 CEST] <JEEB> usually it should only work with screen capture inputs, at least that's where I've seen it being used
[11:00:12 CEST] <eijin> no this is just a regular video file i encoded to h264. nothing screen related :p
[11:00:50 CEST] <eijin> i was just surprised it finally gave me a constant frame rate with ffmpeg cause everywhere i looked only found '-r' and it always resulted in variable despite fact source is constant
[11:01:26 CEST] <relaxed> it works with raw inputs too
[11:02:04 CEST] <eijin> but i heard from a few ppl its a known ffmpeg bug.. well when muxing in m4a audio encoded variably, ffmpeg will mangle the header somehow and make it appear constant (diff bug)
[11:08:13 CEST] <eijin> any ideas on how to mux in aac audio (variable) with mp4 file (video only) and have the resultant mp4 audio stay variable? ffmpeg makes it 'constant' somehow. not sure if there's a workaround for that
[11:08:43 CEST] <relaxed> what happens if you copy the stream?
[11:13:18 CEST] <elmargol> Is there a Clapperboard detection in ffmpeg?
[11:27:32 CEST] <eijin> relaxed like this? ffmpeg -i out.mp4 -i out.m4a -c:v copy -c:a copy result.mp4
[11:28:18 CEST] <eijin> i cancelled it because of how slowly it was going but it seemed to preserve the fact audio was encoded variably. is there a faster way to do that? just mux aac audio with video already in mp4 container?
[11:28:47 CEST] <elmargol> eijin, can't you use mkv?
[11:29:25 CEST] <eijin> well i can but i wanted to keep it in a mp4 container
[11:29:43 CEST] <elmargol> If you don't mind mkv https://www.bunkus.org/videotools/mkvtoolnix/doc/mkvmerge.html
[11:29:52 CEST] <eijin> i copy 770 fps with that command which is kind of odd since it's a cached ssd disk
[11:30:42 CEST] <eijin> i decided to use mp4box instead which does it in like a few seconds. i dont see why ffmpeg cant mux just as quickly though
[11:30:47 CEST] <elmargol> eijin, you can try https://trac.ffmpeg.org/wiki/Concatenate
[11:31:35 CEST] <elmargol> does not work for all codecs
[11:33:45 CEST] <BtbN> concat != merging an audio and a video file
[11:35:27 CEST] <eijin> so the way is the only only way to mux video and audio together no (copy and not transcode)?
[11:35:33 CEST] <eijin> so the way i mentioned*
[11:36:40 CEST] <BtbN> some -map parameters might be usefull, but in general, yes, that's how it works.
[12:15:05 CEST] <atzorvas> in order to hide mouse from the recording I have to do draw_mouse 0 right?
[12:41:32 CEST] <satinder> how I can create shared library of ffmpeg
[12:41:45 CEST] <satinder> anybody can help
[12:44:11 CEST] <ened> Hi! Given a MKV file has no language header set for a track, will ffmpeg auto-set the tracks language to 'eng' (English)?
[12:45:26 CEST] <JEEB> I think no language info is implicitly English, you'd have to set unk or whatever to note that it's unknown. Or that might have been how mkvmerge does it.
[12:52:15 CEST] <ened> JEEB: Yes, you are correct. I've been chatting with the #matroska folks as well, ffmpeg does the right thing. Thank you!
[12:53:55 CEST] <ened> JEEB: As in "eng" is the default. http://www.matroska.org/technical/specs/index.html
[14:12:49 CEST] <seeit> if I'm trying to live transcode a stream say from mkv to mp4 using -c copy to an apple tv should I use ffserver in that process? the problem is if the initial stream starts to buffer the output stream terminates on the apple tv
[14:37:59 CEST] <BtbN> seeit, mp4 can't be live-streamed.
[15:22:21 CEST] <seeit> sorry, we have a streamer in node.js and there's a module that allow us to pipe ffmpegs output directly to a http response, our problem with all approaches taken so far is that if the input stream buffers ffmpeg hits basically an EOF and kills our output stream. One idea I've had is to lie in the http header of our streamer of with an approximation of what the file converted to mp4 will be
[15:24:53 CEST] <seeit> BtbN is ffmpeg aware and is there possible output to track the conversion percentage of a stream with fixed time length?
[15:32:41 CEST] <DHE> I'm looking for something like ffserver but without transcoding. Basically take whatever I give it via .ffm and it just serves it to anybody who connects using only the equiv of "-codec copy" is that possible and I'm just not interpreting the docs right?
[18:22:42 CEST] <ebail> Hi guys, I just post a question about RTCP infos extraction on mailing list (http://ffmpeg.org/pipermail/ffmpeg-user/2015-August/027924.html). IRC exchange might be easier. Thanks
[18:24:27 CEST] <Timster> Hello, I am having trouble with concatenating multiple (some hour long) video files. Audio and video is getting out of sync more and more when it changes between them, but the files itself are perfectly fine. Does anybody have a clue on how to fix it?
[20:46:58 CEST] <kyleogrg> hi
[20:47:08 CEST] <kyleogrg> this should be a simple question for yall
[20:47:23 CEST] <kyleogrg> I'm doing a cross-compile from linux for windows
[20:47:36 CEST] <kyleogrg> using a build helper script
[20:47:47 CEST] <kyleogrg> so i run the command: ./cross_compile_ffmpeg.sh
[20:48:08 CEST] <kyleogrg> this works.  now I want to customize the build by adding --high_bitdepth=y.  can I add this to the above command?
[20:49:31 CEST] <JEEB> that doesn't sound like an ffmpeg configure option
[20:49:41 CEST] <kyleogrg> When I try this, I get an error: ./cross_compile_ffmpeg.sh --high_bitdepth=y.  I know i'm missing something obvious
[20:49:54 CEST] <JEEB> you should actually read the cross compilation script :P
[20:49:56 CEST] <kyleogrg> it's an option in the .sh file
[20:50:36 CEST] <JEEB> well I have no idea what the damn script you're using and so forth. so I'm not at all sure how this relates to ffmpeg
[20:50:59 CEST] <JEEB> not to mention that there is no such high bit depth option in ffmpeg's own configure either
[20:51:11 CEST] <JEEB> so it's most probably an option you give to one of the libraries used by ffmpeg
[20:51:38 CEST] <kyleogrg> right.  well, the problem probably is that i'm new to this and thus tend to miss some of the obvious steps
[20:52:56 CEST] <kyleogrg> pastebin.com/dSr2LFgB
[20:53:51 CEST] <kyleogrg> hmm, it's working now that I replaced the underscore with a hyphen.
[22:00:55 CEST] <kyleogrg> how can I put two ffmpeg commands into one command line?
[22:01:53 CEST] <Nolski> kyleogrg: you can put it into a shell script?
[22:02:07 CEST] <llogan> ffmpeg && ffmpeg. ...depending on your shell, and how you want it to handle failures, etc
[22:02:52 CEST] <kyleogrg> perhaps this will help: http://pastebin.com/7knM4gJC
[22:03:11 CEST] <kyleogrg> i want to know if this is formatted correctly (for windows)
[22:03:24 CEST] <kyleogrg> llogan: in windows cmd?
[22:03:33 CEST] <llogan> FIIK
[22:04:44 CEST] <ChocolateArmpits> Putting on one command line won't make them execute parallel
[22:05:51 CEST] <kyleogrg> no... it's just that my current method (see pastebin) didn't seem to be working
[22:06:13 CEST] <llogan> might want to ask in a powershell (or whatever) channel
[22:06:31 CEST] <ChocolateArmpits> you need to use the bracket ^ at the end of the line
[22:06:33 CEST] <ChocolateArmpits> http://stackoverflow.com/questions/69068/long-commands-split-over-multiple-lines-in-vista-dos-batch-bat-file
[22:06:56 CEST] <ChocolateArmpits> if you want to split a command line
[22:07:16 CEST] <kyleogrg> okay.  but is this used to combine independent commands?
[22:07:36 CEST] <DHE> Is there an option to copy keyframes from input to output? That is, if frame number X in the input is a keyframe, then frame number X will also be a keyframe in the output
[22:08:24 CEST] <ChocolateArmpits> kyleogrg: commands are combined by either using && or &
[22:09:00 CEST] <ChocolateArmpits> ^ simply allows to separate a continous single command line over multiple lines for easier management
[22:09:07 CEST] <kyleogrg> ChocolateArmpits: okay... so i just tried &.  in ffmpeg cmd, i get the message" file NUL already exists.  exiting.
[22:09:21 CEST] <ChocolateArmpits> you need -y parameter
[22:09:29 CEST] <ChocolateArmpits> NUL is a an empty file
[22:09:37 CEST] <edoceo> I have a source media that ffprobe reports a Video stream, but when I convert to mp4 that stream is gone.
[22:09:47 CEST] <edoceo> Playing the source webm with VLC there is no video.
[22:09:52 CEST] <ChocolateArmpits> -y forces ffmpeg to overwrite it, even when it's an empty file
[22:10:04 CEST] <edoceo> But how can I make ffmpeg realise that the video is missing and then just make a blank video stream?
[22:10:37 CEST] <kyleogrg> ChocolateArmpits: i will try that
[22:10:42 CEST] <ChocolateArmpits> edoceo: does the stream contain any bytes ?
[22:10:54 CEST] <edoceo> I don't think it does, I cannot tell
[22:11:03 CEST] <edoceo> Or, I don't know how to tell
[22:12:11 CEST] <kyleogrg> ChocolateArmpits: it works, thanks a lot
[22:12:18 CEST] <ChocolateArmpits> kyleogrg: np
[22:13:30 CEST] <ChocolateArmpits> edoceo: I think your situation is too specific to give a general answer, we need something to judge if the stream is viable or not
[22:13:49 CEST] <edoceo> Oh, when I play it I see nothing
[22:13:52 CEST] <kyleogrg> ChocolateArmpits: but then, i cannot use -n to skip already-encoding files, can i?
[22:14:01 CEST] <kyleogrg> already-encoded*
[22:14:05 CEST] <edoceo> What if I have a webm with crappy video and then just want to replace it with like lavfi or something?
[22:15:15 CEST] <ChocolateArmpits> kyleogrg: write a batch script that checks if the file exists, if the bytes are no longer being written and then skip encoding
[22:15:37 CEST] <kyleogrg> ChocolateArmpits: yeah.  thanks
[22:15:45 CEST] <ChocolateArmpits> kyleogrg: other way would be to create a temporary variable to signify that encoding has completed
[22:15:54 CEST] <ChocolateArmpits> and then check that variable upon starting another encoding
[22:16:00 CEST] <kyleogrg> ok
[22:16:22 CEST] <ChocolateArmpits> I feel like I got somewhat rusty with batch over the last months that I started using Powershell
[22:16:27 CEST] <llogan> ffmpeg -f lavfi -i testsrc=d=5 -f rawvideo -pix_fmt yuv420p - | ffmpeg -f rawvideo -video_size 320x240 -framerate 25 -pixel_format yuv420p16le -i - -c:v rawvideo -f nut - | ffplay -i -
[22:17:17 CEST] <ChocolateArmpits> edoceo: You mean blank black video ?
[22:41:30 CEST] <kyleogrg> okay, so when two-pass encoding, ffmpeg makes a log file: ffmpeg2pass-0.log
[22:41:40 CEST] <kyleogrg> can i choose where this temporary file is saved?
[22:47:35 CEST] <c_14> -passlogfile
[22:47:36 CEST] <c_14> iirc
[22:55:49 CEST] <kyleogrg> c_14: how can it be used in a two-pass command, for example
[22:55:51 CEST] <kyleogrg> ?
[22:58:53 CEST] <c_14> ffmpeg -i video -c:v libx264 -pass 1 -b:v 9001k -passlogfile rtfm out.mkv
[23:00:59 CEST] <kyleogrg> ok thx
[23:57:34 CEST] <Platonides> hello
[23:57:35 CEST] <Platonides> I'm trying to cut a video fragment with avconv version 0.8.17-6:0.8.17-1 by providing -ss (start time) -t (duration).
[23:57:43 CEST] <Platonides> I tried both before and after -i inputfile.avi buy it starts the new one from the beginning nonetheless (ie. it seems to ignore -ss)
[23:57:57 CEST] <Platonides> am I missing anything obvious?
[23:59:32 CEST] <klaxa> well first of all this is #ffmpeg, for avconv support there is #libav also your version is old (ancient)
[00:00:00 CEST] --- Tue Aug 11 2015

More information about the Ffmpeg-devel-irc mailing list