[Ffmpeg-devel-irc] ffmpeg.log.20150812

burek burek021 at gmail.com
Thu Aug 13 02:05:01 CEST 2015

[00:03:02 CEST] <LRUB1> Problem in compilation.
[00:04:39 CEST] <LRUB1> Typing "./configure --enable-shared" and "make && make check" generate erros before typing "make check".
[00:06:20 CEST] <LRUB1> I can do better. There is only one error and has a log file. Shall I send this?
[00:06:46 CEST] <c_14> send what you think is helpful
[00:07:07 CEST] <c_14> Just make sure you put it on a pastebin site and don't spam the channel with the output
[00:08:01 CEST] <LRUB1> http://pastebin.com/bneJZbjx
[00:09:32 CEST] <c_14> try recompiling with --enable-pic
[00:10:40 CEST] <LRUB1> That's what I did.
[00:11:25 CEST] <c_14> Can you give me the complete config.log ?
[00:12:01 CEST] <c_14> Do you have a system version of ffmpeg currently installed?
[00:12:15 CEST] <c_14> Are you sure the binary is linking against the correct libraries during runtime?
[00:13:20 CEST] <LRUB1> FFMPEG lasted version and my OS is Linux Debian 8 Jessie.
[00:13:22 CEST] <LRUB1> http://pastebin.com/ceX2JLcE
[00:13:45 CEST] <LRUB1> Installed all dep.
[00:14:18 CEST] <c_14> What I meant was, do you have a version of ffmpeg installed in /usr?
[00:15:28 CEST] <c_14> You can usually check with something like `which ffmpeg' to check if you have the binary somewhere though in this case the libraries are of more interest.
[00:15:52 CEST] <LRUB1>    No. Installation "from scratch".
[00:16:46 CEST] <c_14> Can you run `ldd ffmpeg' while in the ffmpeg git tree? (where you ran make)
[00:18:41 CEST] <LRUB1> You asked if I can run the command? Yes! I can.
[00:18:51 CEST] <c_14> Can you pastebin the output?
[00:18:52 CEST] <LRUB1> Sorry. My english is bad.
[00:20:35 CEST] <LRUB1> I typed "make clean" then apareace "No such file or directory".
[00:21:01 CEST] <LRUB1> **appears
[00:22:23 CEST] <c_14> Yes, you need to do it after the `make'
[00:23:40 CEST] <LRUB1> Okay. Wait a few minutes.
[00:38:30 CEST] <LRUB1> http://pastebin.com/6DA4dR9g
[00:39:22 CEST] <LRUB1> This ldd log.
[00:39:53 CEST] <c_14> If you want to run make check with a dynamic build you'll probably have to install the libraries somewhere and then make sure it's in your LD_LIBRARY_PATH (or put it in your LD_RUN_PATH while compiling).
[00:40:08 CEST] <c_14> It seems that the ffmpeg binary is linking against a version of ffmpeg installed in /usr
[00:42:13 CEST] <LRUB1> "./configure --prefix=/usr"?
[00:42:34 CEST] <LRUB1> Sorry. I'am noob.
[00:43:09 CEST] <c_14> It defaults to /usr/local which is usually fine. If you put it in /usr it might clobber the system installed version of ffmpeg which may break things
[00:45:25 CEST] <ATField> (sorry for lagging with response) Directly converting to webm worked. I have no idea why they were advising to convert it to .raw first (I shouldve read the whole thing through first). Thanks for help, llogan.
[00:45:29 CEST] <LRUB1> But there's another version installed. Just this.
[00:46:10 CEST] <c_14> according to your ldd output there's a version of the libraries in /usr/lib/x86_64-linux-gnu/
[00:46:25 CEST] <LRUB1> But does not have another version installed. Just this.
[00:46:30 CEST] <LRUB1> *
[00:46:42 CEST] <c_14> If you're sure, then you can set --prefix=/usr
[01:03:43 CEST] <LRUB1> I'm running some tests. Anything, II will contact.
[01:22:48 CEST] <LRUB1> Both with "--prefix = / usr 'or' --prefix = / usr / local" appears the same error after entering "make check". And though you can install anyway, I'm afraid iso harms some important library as the last time I did that. Although the problem in this case is the "FLAC". And I do not use that much. Unless the "H.264" need of flac, maybe I can use FFmpeg without problems.
[01:22:48 CEST] <LRUB1>  What do you think?
[01:27:35 CEST] <LRUB1> ?
[01:35:52 CEST] <LRUB1> Hello!
[01:36:44 CEST] <c_14> h264 doesn't need flac
[01:36:48 CEST] <c_14> flac is an audio codec
[01:36:55 CEST] <c_14> the error shouldn't be happening though
[01:38:40 CEST] <LRUB1> Ok. So it does not affect other libraries if I make the installation?
[01:39:48 CEST] <c_14> I don't know your system.
[01:40:10 CEST] <chungy> LRUB1: use either "--prefix=/usr" or "--prefix /usr" don't add extra spaces.
[01:40:50 CEST] <LRUB1> I don't add spaces.
[01:41:38 CEST] <LRUB1> Linux Debian 8 Jessie
[01:41:52 CEST] <LRUB1> I mentioned before.
[01:41:57 CEST] <chungy> <LRUB1> Both with "--prefix = / usr 'or' --prefix = / usr / local"
[01:41:58 CEST] <chungy> heh
[01:43:06 CEST] <c_14> LRUB1: I meant, I don't know what's on your system or if it'll overwrite something. If you build with LD_RUN_PATH=/usr/local/lib and then install with the default prefix of /usr/local it should normally be safe.
[01:46:28 CEST] <LRUB1> I'll try.   But I think the error will persist.
[01:55:13 CEST] <LRUB1> I did what I thought was the correct and installed FFmpeg. I hope I have great inconvenience. Anything I do I contact.
[01:55:28 CEST] <LRUB1> Thanks for helping.
[03:24:49 CEST] <diffuse> I am looking at the best way to take a buffer of pcm data and write it to a wave format.
[03:24:57 CEST] <diffuse> via the FFmpeg C api
[03:30:25 CEST] <diffuse> which API is the best place to start
[03:38:18 CEST] <klaxa> sounds like you want to mux stuff
[03:38:40 CEST] <klaxa> so i guess avformat?
[03:38:47 CEST] <klaxa> maybe have a look at doc/examples/muxing.c
[03:38:54 CEST] <klaxa> diffuse: ^
[03:39:09 CEST] <diffuse> i looked at that
[03:39:14 CEST] <diffuse> perhaps i am missing something
[03:39:23 CEST] <diffuse> how do i indicate to generate a wave file?
[03:40:46 CEST] <klaxa> tell it avformat_alloc_output_context2()?
[03:41:10 CEST] <klaxa> https://ffmpeg.org/doxygen/trunk/avformat_8h.html#a6ddf3d982feb45fa5081420ee911f5d5
[03:58:37 CEST] <diffuse> klaxa: what should avoutputformat be?
[03:59:28 CEST] <kyleogrg> i'm doing a bit of searching over an ffmpeg question.  perhaps you can point me in the right direction.  I want to concatenate two DV-AVI files without reencoding.
[03:59:53 CEST] <kyleogrg> so i have: -c:v copy -c:a copy output.avi
[04:00:37 CEST] <kyleogrg> is this still a "dv" avi, or does it lose some container info?
[04:01:56 CEST] <klaxa> diffuse: probably "wav"?
[04:06:32 CEST] <LanDi> ffmpeg -f pulse -ac 2 -ar 44100 -i alsa_output.pci-0000_00_1b.0.analog-stereo.monitor -filter_complex amix=inputs=1 -ar 44100 -q:a 1 luta.wav | fmpeg -f x11grab -r 60 -s 1050x590 -i :0.0+0,0 -vcodec libx264 -preset veryfast -crf 18 -pix_fmt yuv420p luta.mkv
[04:06:45 CEST] <LanDi> why these two commands are not executed at the same time?
[04:09:14 CEST] <klaxa> kyleogrg: have just tried it out?
[04:09:49 CEST] <klaxa> LanDi: because you are piping them, also you could put both in the same command and even the same file
[04:10:07 CEST] <LanDi> klaxa, I tried
[04:10:11 CEST] <LanDi> didnt worked
[04:10:23 CEST] <LanDi> how can I fix that?
[04:10:50 CEST] <kyleogrg> klaxa: the problem was that i concatenated several DV scenes into one video, but the resulting video duration was much shorter
[04:11:15 CEST] <kyleogrg> now i just tried it with video only, no audio, and it looks like it worked
[04:11:36 CEST] <kyleogrg> it may be because the different clips have different audio sample rates
[04:11:45 CEST] <klaxa> that may very well be
[04:12:01 CEST] <klaxa> different sample rates have messed up concat for me too
[04:12:07 CEST] <kyleogrg> although when i did concat, i stream copied video and *converted* audio to 41000 wav
[04:12:25 CEST] <bornpilot1> LanDi did you try the concat script?
[04:12:39 CEST] <kyleogrg> i wonder why this didn't work.  maybe i will try video and audio separately and then mux them
[04:12:51 CEST] <klaxa> LanDi: ffmpeg -f x11grab -framerate -s 1050x590 -i :0.0 -f pulse -ac 2 -ar 44100 -i alsa_output.pci-0000_00_1b.0.analog-stereo.monitor -filter_complex amix=inputs=1 -ar 44100 -q:a 1 -c:v libx264 -preset veryfast -crf 18 luta.mkv
[04:12:55 CEST] <LanDi> klaxa, https://bpaste.net/show/13145b7723ce
[04:13:13 CEST] <LanDi> klaxa, ohh, I see
[04:13:16 CEST] <klaxa> kyleogrg: you will probably have to re-encode the audio if it has different sampling rates
[04:13:29 CEST] <klaxa> ah whoops
[04:13:34 CEST] <klaxa> -framerate 60
[04:13:46 CEST] <klaxa> you have to use -framerate 60 instead of -r 60 btw
[04:13:55 CEST] <LanDi> klaxa, :0.0: Protocol not found
[04:14:18 CEST] <kyleogrg> klaxa: right.  but what i'm saying is that i stream-copied video & re-encoded audio, all at once -- and it didn't work.  but i'll try them separately
[04:14:41 CEST] <klaxa> ah, hmm... that's weird
[04:14:53 CEST] <klaxa> LanDi: can you pastebin your command with complete output?
[04:15:19 CEST] <LanDi> klaxa, too late :(
[05:27:09 CEST] <LanDi> klaxa, sorry man, I was recording a live stream
[05:27:27 CEST] <LanDi> anyways, the problem was I miss the "f" at the seconf ffmpeg command
[05:27:38 CEST] <LanDi> it was fmpeg... instead of ffmpeg
[05:27:42 CEST] <LanDi> thanks dude
[08:50:45 CEST] <fooba> Hi all! I have a folder with images which I want to convert to a video(slideshow). Each image is named as the time in millisecond at which it was taken. Can I convert these images to video using ffmpeg so that images are displayed at correct time?
[13:04:43 CEST] <techtopia> hello
[13:04:52 CEST] <techtopia> can i use ffmpeg for commercial projects?
[13:05:35 CEST] <KarlFranz> I suppose that depends on what you compile in it.
[13:05:51 CEST] <techtopia> no i mean videos encoded with it
[13:05:55 CEST] <KarlFranz> It is easy to create non-distributable binaries if you compile certain codecs in it.
[13:06:03 CEST] <techtopia> i want to set up a streaming platform
[13:06:18 CEST] <KarlFranz> That depends on the codec the video is serving.
[13:06:24 CEST] <techtopia> ahh
[13:06:29 CEST] <KarlFranz> h264 is most likely a no-go.
[13:06:34 CEST] <KarlFranz> Unless you pay $$$$
[13:06:45 CEST] <KarlFranz> to the consortium behind h264
[13:06:45 CEST] <techtopia> i see
[13:07:11 CEST] <KarlFranz> If you wanna go hassle free you can go with vp8 video, vorbis audio and webm or mkv containers.
[13:18:49 CEST] <xerox> KarlFranz: so sites using HLS are paying the consortium for the use of H.264?
[13:19:36 CEST] <sfan5> wasn't HLS recently patented?
[13:19:50 CEST] <sfan5> or plans announced to have usage fees?
[13:20:06 CEST] <xerox> wow, I wonder what that amounts to ($$$) for twitch
[13:20:16 CEST] <Mavrik> xerox, no
[13:20:32 CEST] <Mavrik> H.264 internet videos that are free to view are exempt from patent fees
[13:20:38 CEST] <Mavrik> On August 26, 2010, MPEG LA announced that H.264 encoded internet video that is free to end users will never be charged royalties.[18] All other royalties remain in place, such as royalties for products that decode and encode H.264 video as well as to operators of free television and subscription channels.[19] The license terms are updated in 5-year blocks.[20]
[13:20:44 CEST] <KarlFranz> xerox: There are limitations depending on what you do with the videos.
[13:21:00 CEST] <xerox> that makes a lot of sense, I was stunned if that would have been the case for free to view videos as well
[13:21:49 CEST] <Mavrik> xerox, also note that you only have to give a damn about that if you're in a country where software patents can be upheld in court
[13:22:11 CEST] <sfan5> does that mean only in the US?
[13:22:54 CEST] <Mavrik> That's a question for your lawyer :)
[13:23:11 CEST] <Mavrik> (Question being - just how much can you be pushed from US if you're a non-US company)
[13:23:19 CEST] <sfan5> *googles*
[13:24:19 CEST] <xerox> I'm going to assume Mavrik just gave me legal counsel in case anything goes wrong
[13:24:57 CEST] <Mavrik> You can do so :P
[13:25:02 CEST] <xerox> lol
[13:25:05 CEST] <KarlFranz> Or you can go webm route :-)
[13:25:24 CEST] <Mavrik> The route of killing users batteries with stuttery video? :)
[13:25:34 CEST] <Mavrik> VP8 encoder is essentially abandoned
[13:25:40 CEST] <KarlFranz> Fuck users, make a deal with batery sellers.
[13:25:42 CEST] <Mavrik> VP9 just eats through CPU like nothing else when decoding.
[13:31:55 CEST] <techtopia> it would be h264 and the content would be charged for so looks like i need to look into licensing
[13:32:03 CEST] <techtopia> which might make the whole idea un feasable heh
[13:32:47 CEST] <KarlFranz> Or just jump codec.
[13:36:13 CEST] <iive> you can make deal with Tesla, at least it have huge battery
[13:44:01 CEST] <JEEB> Mavrik: I think the VP9 decoder, especially lavc is actually fast
[13:47:30 CEST] <JEEB> it's the encoding that really lörps it up
[13:51:15 CEST] <KarlFranz> Yes, encoding takes a pair :-)
[13:53:14 CEST] <Mavrik> JEEB, at higher resolutions using the CPU really kills a lot of devices
[13:53:27 CEST] <Mavrik> And you don't get the benefit of HW decoding you get for H.264
[13:54:02 CEST] <Mavrik> VP9 might be fast in comparison with H.264 on CPU but at the end of the day, VP9 will turn your laptop into screaming useless mess while H.264 wont
[13:55:31 CEST] <Mavrik> On mobile it's a bit worse since a lot of those CPUs just don't have enough horsepower to decode it
[14:00:51 CEST] <JEEB> sure, if you are talking about the possibility of HW decoding
[14:01:08 CEST] <JEEB> I was just thinking of VP9 vs HEVC on software decoding level
[14:01:16 CEST] <JEEB> since those are of the same generation
[14:01:29 CEST] <JEEB> not sure if lavc AVC is slower or faster than lavc VP9
[14:01:35 CEST] <JEEB> haven't been able to make a proper test
[14:01:48 CEST] <JEEB> but BBB sure loved a lot of asm into the VP9 decoder since it's his baby
[14:01:58 CEST] <JEEB> (he used to work on the VP9 team at G)
[14:37:02 CEST] <eiji> how do i join 2 .ts files with ffmpeg into a single .ts?
[14:37:28 CEST] <BtbN> cat file1.ts file2.ts > file.ts
[14:37:37 CEST] <eiji> no need to use ffmpeg?
[14:37:44 CEST] <BtbN> If the files are similar enough, no
[14:37:54 CEST] <eiji> i created them with ffmpeg and yeah identical specs
[14:38:04 CEST] <eiji> how would you do it with ffmpeg j/w?
[14:38:17 CEST] <BtbN> concat demuxer
[14:40:40 CEST] <eiji> you mean like this: ffmpeg -i "concat:1.ts|2.ts" -c copy out.ts
[14:41:34 CEST] <BtbN> That's the concat protocol.
[14:41:44 CEST] <BtbN> It basicaly does the same as cat does.
[14:42:08 CEST] <BtbN> The concat demuxer is way better and works with more formats.
[14:42:11 CEST] <eiji> ah
[14:43:34 CEST] <eiji> looking at concat demuxer the syntax looks the same as what i used: https://trac.ffmpeg.org/wiki/Concatenate
[14:44:06 CEST] <eiji> do you mean the concat protocol instead?
[14:44:59 CEST] <BtbN> I think you should read that page again
[14:46:38 CEST] <eiji> they use a text file is the difference unless i misunderstand
[14:46:49 CEST] <BtbN> It's on the demuxer level instead of on the file level.
[14:47:18 CEST] <BtbN> The differences are explained at the very top of that page.
[14:49:11 CEST] <eiji> you said works with more formats, the concat demuxer can be used to join mp4 files into a single mp4 file (same encode specs)?
[14:49:50 CEST] <BtbN> you can even mix diffrent containers, as long as the content matches.
[15:13:40 CEST] <eiji> so you can use ffmpeg demuxer to go from h264 to mp4 too?
[15:14:02 CEST] <BtbN> h264 is a codec, mp4 is a container. It's not something you convert between.
[15:14:40 CEST] <eiji> got it
[15:15:00 CEST] <eiji> the .h264 file i figured is in some sort of container, a h264 container :P
[15:15:17 CEST] <Mavrik> It's just raw dumped H.264 stream
[15:15:25 CEST] <Mavrik> Which is fun fun because it's not wrapped in a container :P
[15:17:12 CEST] <eiji> so the only way to do so with ffmpeg to go from h264 to mp4 with ffmpeg is h264->ts->mp4
[15:17:26 CEST] <Mavrik> Nah, you can go directly
[15:17:44 CEST] <Mavrik> You'll probably have to manually set FPS and some other things for ffmpeg to get things right and keep video in sync
[15:17:56 CEST] <eiji> ffmpeg -i 1.h264 -c copy 1.mp4 ?
[15:18:28 CEST] <Mavrik> Hmm, try it :)
[15:18:31 CEST] <eiji> ah ok maybe easier to just stick it in a container. only thing i would set is the FPS
[15:18:42 CEST] <Mavrik> Just stick it into a .TS rather
[15:18:47 CEST] <eiji> alright
[15:18:50 CEST] <Mavrik> It's a concatable streamamble format and it'll hurt you less
[15:19:04 CEST] <Mavrik> You'll live through the 5% size penalty :P
[15:26:47 CEST] <Timster> Mavrik, for terms of concatenation - you would recommend .ts over .mkv or .flv?
[15:55:19 CEST] <Mavrik> Neither MKV nor FLV are really concatenable by themselves - you have to remux.
[15:55:37 CEST] <Mavrik> I'd recommend remuxing in any case since that usually fixes timestamps, pids and other structures
[15:57:55 CEST] <stephenmac7> I have a question: on the front page of the website it says: "Converting videos and audios has never been so easy." If I'm not mistaken, "audios" should be "audio."
[15:58:04 CEST] <stephenmac7> *"audio".
[16:02:19 CEST] <saste> stephenmac7, indeed
[16:02:57 CEST] <saste> but people are lazy and they never fix it
[16:02:59 CEST] <stephenmac7> It's kind of obvious, so I guess you all probably already know that, but just haven't gotten around to fixing it.
[16:03:13 CEST] <stephenmac7> But I just wanted to make sure.
[16:08:03 CEST] <stephenmac7> saste: Okay, thanks anyway.
[16:09:58 CEST] <saste> bah, email sent
[17:01:24 CEST] <td_> Hey.  I am using ffmpeg to convert a series of png files into a video.  It works just fine. But if I add an overlay using -filter_complex ffmpeg encodes the video but hangs forever afterwards
[17:01:33 CEST] <td_> full commands: http://dpaste.com/3ZJ23Z8
[17:30:38 CEST] <tellendil> Hello ! I'm trying to test security-related compiler optimizations against mainstream softwares, and ffmpeg is a great subject for this. For this I try to trigger old CVE's published by ffmpeg (once the patch is removed), but I've got quite a lot of trouble to find inputs that would actually trigger the bug. Does somebody has an idea where I could look or who I could ask ? Thanks a lot !
[17:33:34 CEST] <JEEB> a lot of the stuff from f.ex. big G never comes with a sample
[17:33:51 CEST] <JEEB> so there's a patch and a possible CVE number, but nothing else
[17:34:06 CEST] <JEEB> although I'm not sure if those G things even come with a CVE
[17:35:01 CEST] <JEEB> for the rest there might be stuff in the related trac or whatever tickets
[17:35:11 CEST] <JEEB> other samples have to be private but are given to developers
[17:35:49 CEST] <tellendil> Would it be possible to access these samples once the CVE is patched ?
[17:58:43 CEST] <JEEB> tellendil: depends on a whole lot of things
[17:59:05 CEST] <JEEB> 1) if there was a sample provided at all
[17:59:23 CEST] <JEEB> 2) was the sample provided privately
[18:00:09 CEST] <JEEB> anyways you should probably poke either the users or devel mailing list
[18:00:33 CEST] <tellendil> JEEB: yeah I understand. Ok, I will ask on the users mailing list then, thanks a lot !
[18:02:02 CEST] <JEEB> the privately thing is mostly related to rights issues or privacy related concerns
[18:45:12 CEST] <explodes_> Does the h.264 decoder require --enable-gpl ?
[19:06:59 CEST] <DHE> explodes_: it does. x264 has its own GPL modes, but those aren't related to ffmpeg
[19:09:27 CEST] <durandal_170> Op asked decoder and not encoder
[19:10:21 CEST] <BtbN> The ffmpeg native h264 decoder is LGPL 2.1 iirc
[19:11:48 CEST] <DHE> oops, my bad...
[19:11:57 CEST] <DHE> yeah because x264 requires --enable-gpl
[21:32:02 CEST] <maisre> I have requirements to develop a teleoperation video solution with sub 200ms of latency over a wireless network (possibly mesh) using H264 encoded video streams, is this even possible?
[21:32:58 CEST] <Mavrik> Possible, but not really with off-the-shelf components
[21:34:07 CEST] <maisre> I have Axis security cameras and software is all up to me, what would you recommend to make this work?
[22:37:28 CEST] <explodes_> mp4 isn't an encoding type right, it's just a container format?
[22:37:34 CEST] <explodes_> afaik*
[22:37:44 CEST] <chungy> correct
[22:40:59 CEST] <Mavrik> Indeed :)
[23:06:11 CEST] <occupant> it's often used interchangibly with x264 though
[23:06:25 CEST] <occupant> so sometimes it's important to nail down exactly what someone is talking about
[23:09:19 CEST] <occupant> And technically it is MPEG4
[23:09:53 CEST] <chungy> x264 is one implementation of H.264, which is the actual codec :P
[23:10:10 CEST] <chungy> likewise x265 is an implementation of HEVC, previously known as H.265.
[23:10:22 CEST] <tab1293> I have installed ffmpeg from source into a user directory ~/ffmpeg_build as the build instructions said. How can I include and link ffmpeg in a makefile now?
[23:11:06 CEST] <tab1293> this is what my make file looks like right now http://pastebin.ca/3101404
[00:00:00 CEST] --- Thu Aug 13 2015

More information about the Ffmpeg-devel-irc mailing list