[Ffmpeg-devel-irc] ffmpeg.log.20150816

burek burek021 at gmail.com
Mon Aug 17 02:05:01 CEST 2015

[04:02:36 CEST] <jim_>  Hi I have an issue with avcodec_open2() [18:56] <jim_> Please see the attached code. It works fine for  AVRational{1,30} but gives an error for AVRational{1,31} [18:57] <jim_> Any ides?
[04:02:53 CEST] <jim_> http://pastebin.com/jSysGtj7
[07:51:19 CEST] <TikityTik> what encoding options should i use for making gifs?
[07:51:34 CEST] <TikityTik> I'm only changing the resolution and framerate.
[08:01:22 CEST] <relaxed> TikityTik: http://blog.pkh.me/p/21-high-quality-gif-with-ffmpeg.html
[08:08:02 CEST] <TikityTik> ok i'm using palettegen but ffmpeg is still working and the time isn't increasing
[08:11:39 CEST] <TikityTik> relaxed: do you know why?
[08:12:00 CEST] <TikityTik> does -ss, -t, and fps interfere?
[08:15:53 CEST] <TikityTik> oh, it's just really slow
[08:31:18 CEST] <TikityTik> https://www.ffmpeg.org/ffmpeg-scaler.html
[08:31:23 CEST] <TikityTik> https://ffmpeg.org/ffmpeg-filters.html#scale-1
[08:31:42 CEST] <TikityTik> the 2nd link doesn't describe the sws_dither option for the scale filter
[08:37:22 CEST] <TikityTik> what's the difference between -lavfi and -vf?
[10:54:49 CEST] <TikityTik> I'm having issues with the overlay filter
[10:55:25 CEST] <TikityTik> ffmpeg -ss 21:20 -t 1:30 -i in.mkv -i in.jpg -map_metadata -1 -c:v libvpx -c:a libvorbis -bufsize 2M -crf 10 -qmax 50 -b:v 316k -ac 1 -q:a 0 -ar 22050 -filter_complex "[0:v] [1:v]overlay=enable='between(t,0,1)',scale=-1:300:flags=lanczos" -sn -cpu-used 0 -quality good -threads 4 -y out.webm
[10:55:29 CEST] <TikityTik> this is what i have so far
[10:55:43 CEST] <TikityTik> but the video is glitching out
[11:17:24 CEST] <TikityTik> apparently i needed -fmt_pix yuv420p
[12:31:16 CEST] <silverfox> Hello, I am having a problem compiling ffmpeg using MSYS2, as prescribed here under section 4.1: https://www.ffmpeg.org/platform.html#Windows .  I am running on a laptop with Windows 8.1, Intel Core i5-3337U (2 core).
[12:33:47 CEST] <silverfox> I have followed all of the instructions in setting up MSYS2 according to these instructions, however ommitting the stuff about Microsoft Visual Studio, YASM, and the gas-preprocessor; https://trac.ffmpeg.org/wiki/CompilationGuide/WinRT
[12:36:54 CEST] <silverfox> I start up MSYS2, type:  cd /c/ffmpeg-master  Followed by:  ./configure --disable-network && make && make install
[12:38:18 CEST] <silverfox> And I get the error:    Unknown OS 'msys_nt-6.3'.
[12:49:05 CEST] <silverfox> Additionally, I am trying to compile 64bit ffplay using MSYS2 and MinGW-w64, as it says you can in section 4.1 of https://www.ffmpeg.org/platform.html#Windows.
[12:52:05 CEST] <silverfox> When typing simply make && make install, a bunch of stuff flashes past the screen (no idea where it is saving this stuff to). However if I use ./compile [options] it gives the  'Unknown OS  'msys_nt-6.3'  error
[13:01:17 CEST] <curmudgeon> Hi. I am trying to convert a .ts that I downloaded to a .mkv (without reencoding, of course). Can anyone tell me why this is not working (and if there is some way to fix it): http://pastebin.com/ZpwvW3sT
[13:04:58 CEST] <BtbN> Looks like the input file is damaged. You could try increasing the analyze duration, maybe it managed to find the extra data.
[13:06:19 CEST] <curmudgeon> Do you recommendation for what duration to use?
[13:07:24 CEST] <curmudgeon> Don't see that option in the man page.
[13:08:25 CEST] <curmudgeon> It plays perfectly as a .ts (but that is not compatible with certain devices).
[13:12:18 CEST] <jim__> Hi guys. I have an issue with avcodecContext time base.
[13:12:24 CEST] <jim__> Please check out the code
[13:12:30 CEST] <jim__> http://pastebin.com/jSysGtj7
[13:12:43 CEST] <jim__> it works for 30 fps but not for 31
[13:12:48 CEST] <jim__> am I missing somethnig
[13:12:49 CEST] <jim__> ?
[13:25:59 CEST] <jim__> Where can I find information about the valid tmiebase values for MPEG1codec
[13:52:19 CEST] <buu> Hey, if I'm using ffmpeg -i foo.mp4 -r 30 "rtmp://foo" to attempt to stream a file to an rtmp server, shouldn't the -r set the fps to 30?
[13:52:29 CEST] <buu> Why would the statu output of ffmpeg say 95+ fps?
[13:55:08 CEST] <klaxa> -r 30 sets the framerate for the file, not the framerate for encoding
[13:55:13 CEST] <klaxa> you probably want to look at the -re flag
[13:56:31 CEST] <klaxa> buu: ^
[13:57:43 CEST] <buu> To force the frame rate of the output file to 24 fps:
[13:57:43 CEST] <buu> ffmpeg -i input.avi -r 24 output.avi
[13:57:50 CEST] <buu> klaxa: What does that mean then?
[13:58:23 CEST] <klaxa> it means that when you play back the file, it will be played back at 24 fps
[13:58:52 CEST] <buu> ohhh
[13:58:54 CEST] <klaxa> or do you mean the -re flag? that means ffmpeg will read the file at "real-time" speed, i.e. as fast as it would be played back
[13:59:09 CEST] <buu> Yeah, the -re flag seems to work great
[14:11:54 CEST] <pauled> Hello, I am getting this "Error parsing AAC extradata, unable to determine samplerate." with this command: livestreamer twitch.tv/mathiaslager high -O | %ffmpeg% -i - -c:v copy -vcodec copy -c:a copy mathiaslager-%ldt%.mkv
[14:13:05 CEST] <buu> pauled: Have you tried explicitly setting an audio bit rate?
[14:13:22 CEST] <pauled> buu, nope, wanting to copy
[14:13:30 CEST] <buu> Might be worth a try
[14:22:13 CEST] <pauled> still working now
[14:22:30 CEST] <pauled> with "-f mpegts" livestreamer twitch.tv/mathiaslager high -O | %ffmpeg% -i - -c:v copy -vcodec copy -c:a copy -f mpegts mathiaslager-%ldt%.mkv
[14:22:47 CEST] <pauled> buu still working now
[14:23:08 CEST] <buu> Hrm. This is peculiar. I'm doing basically: ffmpeg -re -i foo.mp4 "rtmp://steam"; and it works perfectly, but if I change to: while read i; do ffmpeg ... -i "$i" ...; done < filellist
[14:23:32 CEST] <buu> It works fine if "filelist" has one line/file in it, but if it has, say, 10 lines, ffmpeg explodes and dies
[14:26:27 CEST] <buu> Is this confusing ffmpeg's stdin/out?
[14:28:48 CEST] <buu> wtf
[14:32:40 CEST] <pauled> you are trying to transcode multiple stream in same time?
[14:33:09 CEST] <pauled> or one after one in a batch?
[14:33:13 CEST] <pauled> buu ^
[14:35:58 CEST] <buu> pauled: one after the other
[14:36:03 CEST] <buu> a playlist
[14:41:12 CEST] <pauled> -i inputs.txt
[14:44:50 CEST] <pauled> buu ^
[14:45:01 CEST] <buu> pauled: Well, ok, but why does my way blow up ffmpeg?
[14:45:04 CEST] <pauled> or you can try http://stackoverflow.com/questions/10929453/bash-scripting-read-file-line-by-line
[14:45:27 CEST] <buu> pauled: You realize the stackoverflow is what I did right?
[14:45:38 CEST] <pauled> probably while IFS='' read -r line || [[ -n "$line" ]]; do
[14:45:44 CEST] <buu> "There is a caveat with this method. If anything inside the while loop is interactive (e.g. reads from stdin), then it will take its input from $1. You will not be given a chance to enter data manually.   carpie Jan 16 '14 at 16:25
[14:46:00 CEST] <buu> So ffmpeg is trying to read the file also
[14:46:08 CEST] <buu> Pesky.
[14:52:26 CEST] <buu> So -nostdin fixes it
[14:52:33 CEST] <buu> That seems.. wrong.
[14:54:01 CEST] <jim__> Hi, How do I check valid timbase values for avcodeccontext?
[14:54:07 CEST] <jim__> I am using MPEG1 codec
[14:54:30 CEST] <Fjorgynn> so
[14:54:31 CEST] <jim__> I am trying 31 fps but it gives an error
[14:57:36 CEST] <Mavrik> jim__, you can't have 31 fps with MPEG-1
[14:57:40 CEST] <Mavrik> because it doesn't support that.
[14:58:26 CEST] <jim__> Thanks Mavrik. How can I find supported values?
[14:58:36 CEST] <Mavrik> MPEG-1 standard I guess.
[14:58:55 CEST] <Mavrik> I doubt you get much more than 25, 30 and 29.97
[14:59:39 CEST] <jim__> I works for 50 as well
[14:59:51 CEST] <jim__> I have tested it
[15:00:04 CEST] <Mavrik> Which is interlaced rate for 25.
[15:00:16 CEST] <Mavrik> Also, why the heck MPEG-1 :)
[15:00:21 CEST] <Mavrik> That's like 1990 tech
[15:01:04 CEST] <jim__> I know :) just stuck with it for the moment :)
[15:01:59 CEST] <jim__> Any recommendation which encoder should I use in order to keep the output file as small as possible? sorry for a stupid question but I am new to this.
[15:03:18 CEST] <Mavrik> jim__, http://ffmpeg.org/doxygen/trunk/mpeg12data_8c_source.html#l00308
[15:03:25 CEST] <Mavrik> jim__, libx264 with slowest of presets
[15:03:40 CEST] <Mavrik> it's orders of magnitude more efficient thatn MPEG-1
[15:03:55 CEST] <Mavrik> H.265 would work too, but that's not as widely supported
[15:04:25 CEST] <jim__> wow. Thanks a lot. Really appreciate it :)
[15:07:10 CEST] <jim__> By the way I am storing file on the disk in near real time which means encoding should be fast as well.
[15:11:38 CEST] <pauled> jim__: use a GUI to find the right compromise between size and speed, is much simpler.
[15:12:05 CEST] <jim__> Thanks paul, will try so.
[15:12:16 CEST] <pauled> handbrake is good GUI to find the good preset
[15:13:07 CEST] <pauled> jim__: experiment with a small file.
[15:18:49 CEST] <jim__> great :)
[15:33:01 CEST] <DHE> besides /dev/null, is there an output target that discards the output? (for use with two-pass mode)
[15:39:32 CEST] <iive> you can use it multiple times :)
[16:25:17 CEST] <diq3> anyone any idea about that error here? https://pastebin.mozilla.org/8842899
[16:25:28 CEST] <diq3> ERROR: ffmpeg[7F37077FE700]: [mpeg2video] ac-tex damaged at 11 4
[16:25:32 CEST] <diq3> what does that mean?
[16:26:12 CEST] <diq3> its an error when playing a dvd in openelec. same dvd on same pc works perfectly fine with linux mint
[16:42:53 CEST] <iive> diq3: the error means that when decoding idct coefficient it had reached an impossible state. that happens on bitstream errors.
[16:43:36 CEST] <iive> if you get only errors and no image, then it might be encrypted stream.
[16:44:48 CEST] <diq3> iive: this is a strange problem i get on most recent version of openelec when playing one exact dvd. Openelec is an entertainment system based on kodi. I dont get such an error and everything is working fine on linux mint 17.2 and dvd playback in vlc. i also dont get that error in kodibuntu
[16:45:39 CEST] <diq3> iive: the unencryption is been done by libdvdcss2 and works fine by default without the need to install anything on the two named systems
[16:52:25 CEST] <iive> there are many reason you can get damaged bitstream...
[16:56:47 CEST] <diq3> iive: so you dont have out of your head an idea what i could tell the deveoper from you (the ffmpeg developer)
[17:15:29 CEST] <silverfox> Hi. I am new to msys and mingw. I am trying to compile ffplay 64bit, using msys2  and mingw-w64 using a windows 8.1 machine. I have msys2 setup, however when I use ./compile [options] i get 'Unknown OS  msys_nt-6.3'.
[17:20:44 CEST] <intracube> is there a way to blur in only one direction?
[17:22:19 CEST] <intracube> i.e. vertical only
[17:23:55 CEST] <intracube> I could scale the video height to 1/4 size, then back up
[17:24:51 CEST] <intracube> which would have a similar effect
[17:54:32 CEST] <oreWizard> mLINK : fatal error LNK1117: syntax error in option ''
[17:54:33 CEST] <oreWizard> C compiler test failed.
[17:54:37 CEST] <oreWizard> someone can helpme?
[18:43:52 CEST] <TikityTik> when I use -pass 1, when do i have to use it again if i change an encoding option?
[18:43:57 CEST] <TikityTik> on filters? on bitrate?
[18:45:03 CEST] <TikityTik> did someone say my name?
[18:45:57 CEST] <TikityTik> can you PM me because I think i'm not getting any chat through this channel
[18:46:46 CEST] <oreWizard> fatal error LNK1181: cannot open input file 'WindowsPhoneCore.lib'
[18:47:05 CEST] <oreWizard> i am getting this error on try to compile
[18:48:28 CEST] <TikityTik> can't say i know how to fix that
[18:49:01 CEST] <TikityTik> maybe you're not using the right build script?
[19:13:15 CEST] <oreWizard> idk
[19:19:00 CEST] <TikityTik> I'm guessing you wouldn't use two-pass for a lossless h.264 encoding?
[19:20:40 CEST] <BtbN> two-pass makes no sense for lossless encoding.
[19:20:53 CEST] <BtbN> It's only use is to target a specific output file size
[19:21:00 CEST] <TikityTik> i see
[19:21:06 CEST] <BtbN> with the best possible overall quality
[19:21:12 CEST] <TikityTik> and you only need a preset and -qp 0 to make it lossless right?
[19:21:36 CEST] <TikityTik> also how can i make vorbis lossless? I find using -q:a 10 makes it even bigger than before
[19:23:22 CEST] <klaxa> vorbis cannot be lossless
[19:23:33 CEST] <klaxa> you can use flac for lossless audio
[19:23:33 CEST] <TikityTik> klaxa: what do you suggest? flac?
[19:23:36 CEST] <TikityTik> i see
[19:23:45 CEST] <TikityTik> Also I'm using this, ffmpeg -ss 22:50 -i in.mkv -t 1:30 -map_metadata -1 -c:v libx264 -preset veryslow -qp 0 -c:a libvorbis -q:a 5 -threads 4 out.mkv
[19:24:04 CEST] <TikityTik> and the output file is broken, it freezes at the start
[19:24:21 CEST] <klaxa> you probably have to move/split your -ss parameter
[19:24:30 CEST] <klaxa> see: https://trac.ffmpeg.org/wiki/Seeking
[19:24:51 CEST] <TikityTik> in what manner? I noticed on other files that input seeking works better than output seeking as it makes the start freeze
[19:25:04 CEST] <TikityTik> but now input seeking is freezing for this encoding
[19:26:32 CEST] <TikityTik> couldn't find any google results on that issue
[19:27:54 CEST] <klaxa> for starters you can move -ss 22:50 after -i in.mkv to see if that fixes it at all
[19:28:10 CEST] <TikityTik> yeah it did the trick
[19:31:08 CEST] <TikityTik> but i'm not sure why both of them would glitch for different files
[19:45:21 CEST] <klaxa> what do you mean with "both of them"?
[19:45:32 CEST] <klaxa> using -ss after -i should never glitch anything
[20:01:06 CEST] <TikityTik> sorry for the late response
[20:01:30 CEST] <TikityTik> yeah i think it glitched hard when I used -ss both before and after -i, so combined seeking
[20:02:01 CEST] <TikityTik> But I think that's when I was using -codec copy
[20:07:55 CEST] <klaxa> oh yeah, codec copy only works on keyframes
[20:08:13 CEST] <klaxa> that's the only case when -ss can "glitch"
[20:11:45 CEST] <TikityTik> should i use the subtitles filter before or after the scale filter?
[20:11:56 CEST] <TikityTik> I would assume after
[20:12:29 CEST] <klaxa> use -t 10, try both, use the one that looks better?
[20:14:02 CEST] <jim__> Hi Guys. Please have a look at the code http://pastebin.com/STguMPJg
[20:14:33 CEST] <jim__> I am configuring the codeccontext with 100 fps but when I play in the VLC it is played at 25fps
[20:14:40 CEST] <jim__> any idea what is going on?
[20:14:51 CEST] <jim__> I am using AV_CODEC_ID_MPEG2VIDEO
[20:20:16 CEST] <Koyhaku> Hey, I'm completely new to ffmpeg, I'm looking at the documentation and I can't seem to find out how to actually use it from the command line. Could someone help me out? I can take it from there once I know how to get to it with the command prompt > Using windows 10, 64bit
[20:20:54 CEST] <TikityTik> depends what codecs you're using
[20:21:26 CEST] <Koyhaku> I've just downloaded the windows build from the website
[20:21:57 CEST] <Koyhaku> I think it was this one, "Latest Zeranoe FFmpeg Build Version: git-767d780 (2015-08-16)"
[20:22:00 CEST] <TikityTik> do you know anything about codecs?
[20:22:11 CEST] <Koyhaku> Nothing, I just want to convert my videos.
[20:22:17 CEST] <TikityTik> to what?
[20:22:23 CEST] <Koyhaku> mp4 to webm
[20:22:39 CEST] <c_14> Koyhaku: https://ffmpeg.org/ffmpeg.html
[20:22:48 CEST] <Koyhaku> I tried using Miro but it converted that to a webmhd file which wouldn't play in firefox.
[20:22:55 CEST] <TikityTik> Koyhaku: https://boards.4chan.org/wsg/thread/700091
[20:23:06 CEST] <klaxa> when you downloaded ffmpeg as a 7z/rar/zip or whatever archive files are used, you navigate your command shell to the directory where you extracted it and just run: ffmpeg.exe -i in.mp4 out.webm
[20:23:10 CEST] <klaxa> for example
[20:23:14 CEST] <TikityTik> Koyhaku: someone wrote a pretty good guide on how to make webms there
[20:23:55 CEST] <Koyhaku> Thank you both for your very quick and timely help.
[20:29:47 CEST] <TikityTik> speaking of webms
[20:30:13 CEST] <TikityTik> I'm having significant differences in filesize encoding when i'm encoding 1:30 webms
[20:30:54 CEST] <TikityTik> the motion is similar but the videos that i'm encoding from are different. Possibly using the subtitles filter also increases filesize.
[20:31:06 CEST] <TikityTik> what's up with that
[20:31:33 CEST] <TikityTik> I'm using the same -crf and bitrates for audio and video
[20:31:50 CEST] <TikityTik> And I compensate with -qmax and scale
[20:34:11 CEST] <TikityTik> so i'm wondering, what source encoding can affect output encoding filesize?
[20:40:47 CEST] <TikityTik> also these videos have almost the same types of motion
[20:52:01 CEST] <silverfox> Hi. I am new to msys and mingw. I am trying to compile ffplay 64bit, using msys2  and mingw-w64 using a windows 8.1 machine. I have msys2 setup, however when I use ./compile [options] i get 'Unknown OS  msys_nt-6.3'.
[20:56:49 CEST] <TikityTik> did you use the configure command? Not that I know if it has one.
[20:57:59 CEST] <silverfox> when i use ./configure --some-option   it gives that error
[20:58:30 CEST] <silverfox> if i just type make or make install, a bunch of stuff flashes, that i have no idea where it puts
[20:59:08 CEST] <silverfox> but the point is, i only want ffplay, so i need to be able to do ./configure --enable-ffplay (which i assume disables the others, since --enable-ffplay was not in the --help)
[20:59:42 CEST] <silverfox> i just saw someone do --enable-ffplay in a post somewhere.
[21:00:22 CEST] <silverfox> i was hoping that i was simply making an obvious rookie mistake..
[21:23:17 CEST] <TikityTik> silverfox: why not just download an already compiled version for windows?
[22:15:32 CEST] <Fyr> guys, how to convert with ffmpeg preserving directory structure?
[22:17:20 CEST] <retard> i don't understand the question
[22:17:27 CEST] <Fyr> haha
[22:17:42 CEST] <Fyr> your nick explains why.
[22:17:57 CEST] <retard> ffmpeg converts content
[22:18:05 CEST] <retard> directories are a matter of organization
[22:18:19 CEST] <Fyr> agreed
[22:18:31 CEST] <Fyr> what is the method to keep the directory structure?
[22:18:49 CEST] <retard> entirely unrelated to ffmpeg?
[22:19:00 CEST] <retard> also, it clearly depends on the directory structure
[22:20:55 CEST] <c_14> Fyr: what you're looking for is a scripting language
[22:21:00 CEST] <Fyr> yes
[22:21:17 CEST] <Fyr> somebody speaking English
[22:24:00 CEST] <Fyr> actually, I expected a GUI or something. =)
[22:25:08 CEST] <Mavrik> O.o
[22:25:19 CEST] <Mavrik> Do you usually insult people trying to help you?
[22:26:07 CEST] <Fyr> I don't insult no one. =)
[22:26:55 CEST] <Fyr> Cartman is my favorite character, though.
[22:27:12 CEST] <retard> you come to ffmpeg expecting a gui
[22:28:39 CEST] <Fyr> yeah, what am I, a retard?
[22:30:28 CEST] <ln-> Fyr: please speak proper English yourself if you demand it from others.
[22:33:14 CEST] <retard> i'm retard
[22:33:33 CEST] <Fyr> alright, I don't have an excuse.
[22:33:44 CEST] <pauled> Fyr, there is no structure in a container, all are in one file
[22:33:55 CEST] <retard> i routinely and happily assist people with creating scripts and whatnot
[22:34:06 CEST] <retard> for some reason i don't feel motivated right now though
[22:34:16 CEST] <pauled> if you mean subltitles, language etc of a dvd
[22:36:13 CEST] <Fyr> I meant branchy structure of audio files. =/
[22:36:34 CEST] <pauled> just google convert dvd to mkv, mp4,
[22:37:40 CEST] <pauled> all audio and other stuff are converted into a container like MKV, MP4 AVI ETC
[22:39:27 CEST] <pauled> just google ffmpeg + dvd convert
[22:39:59 CEST] <pauled> also there are many GUI that use ffmpeg todo that
[22:41:26 CEST] <chungy> you should be able to modify this script for your purpose: https://gist.github.com/chungy/4a9e70c8b034d5b41aa6
[22:42:27 CEST] <Fyr> I'm using Windows. ='(
[22:43:24 CEST] <chungy> Hmm, I'm sorry to hear
[22:43:29 CEST] <chungy> It'd probably work in Cygwin though
[22:47:36 CEST] <Fyr> conscience of feeling embarrassed when you're saying that you're using Windows might change the world. =)
[23:24:31 CEST] <TikityTik> I'm having issues making this webm
[23:24:51 CEST] <TikityTik> I'm trying everything I can to make a webm from an image and an mp3.
[23:24:52 CEST] <TikityTik> ffmpeg -i in.jpg -i in.mp3 -map_metadata -1 -loop 1 -r 1 -c:v libvpx -crf 10 -qmax 35 -qmin 5 -b:v 1M -s 640x480 -c:a libvorbis -ac 2 -q:a 1 -threads 4 -shortest out.webm
[23:25:21 CEST] <TikityTik> but the video only ends up as 1 second long, and when I take out -shortest, the image doesn't show and the sound doesn't play
[23:31:45 CEST] <TikityTik> finally got it working. Had to put -loop 1 RIGHT AFTER FFMPEG
[23:35:08 CEST] <TikityTik> also why is it that mpc-hc shows greenbars on my webm, but that's not the case for firefox?
[23:40:34 CEST] <JEEB> depends on the version and used DShow filters
[23:42:30 CEST] <TikityTik> JEEB: what do you mean DShow filter? Also is it not a problem with my encoding?
[23:43:10 CEST] <JEEB> mpc-hc is a directshow (aka DShow) player, it uses dshow filters to form the chain from [file] to [something shown on the screen]
[23:43:39 CEST] <JEEB> you have one filter that reads the file, another that handles the container, another that decodes the video and so forth and so forth
[23:44:22 CEST] <TikityTik> which one do you recommend?
[23:44:41 CEST] <JEEB> in what sense?
[23:45:32 CEST] <JEEB> I'm just telling you to check what version your player is, and check if the vendor has a newer version available. if that doesn't help, you would have to start checking out your filter chain
[23:46:42 CEST] <TikityTik> MPC-HC 1.7.9, it's the newest.
[23:49:08 CEST] <JEEB> ok, now you can pastebin what's under play->filters when you right-click the player window
[23:49:41 CEST] <JEEB> of course this doesn't have much to do with ffmpeg any more
[23:50:02 CEST] <JEEB> we can move towards #mpc-hc with this issue
[23:50:21 CEST] <jim444> HI. I am trying to store video stream as MPEG2 file. I have set frame rate in Avcodeccontext to 100 fps but the file generated shows a frame rate of 25fps when I play it with VLC.
[23:50:25 CEST] <jim444> Here is the code
[23:50:32 CEST] <jim444> http://pastebin.com/STguMPJg
[23:50:36 CEST] <jim444> Any idea please?
[23:50:56 CEST] <JEEB> ok, you are setting the time base, are you also setting the PTS?
[23:51:05 CEST] <JEEB> + I hope you are actually storing video in a container
[23:51:17 CEST] <JEEB> because raw video rather rarely has timestamps
[23:51:45 CEST] <jim444> yes. I have timestamp configured as   mFrame->pts=++mFrameCounter;
[23:52:14 CEST] <jim444> and storing the encoded frames as .mpg
[23:52:45 CEST] <JEEB> i hope that means you are using a container?
[23:52:53 CEST] <JEEB> an extension doesn't yet mean anything
[23:53:17 CEST] <JEEB> and if you are using a container, which is it? MPEG-PS?
[23:53:55 CEST] <jim444> http://pastebin.com/tcU0HxUs
[23:54:09 CEST] <jim444> Here is how I am writing it in .mpg file.
[23:54:16 CEST] <jim444> sorry, I am very new to this.
[23:55:04 CEST] <JEEB> so you are writing raw mpeg-2 video packets into a file
[23:55:12 CEST] <jim444> yes.
[23:55:17 CEST] <JEEB> that will not have any timestamps
[23:55:28 CEST] <JEEB> 25fps is a default in the standard
[23:55:36 CEST] <JEEB> you will most probably want to stick a libavformat muxer after that
[23:55:48 CEST] <jim444> but when I set fps as 50, the vidoe is played at 50 fps
[23:56:15 CEST] <jim444> how can I use a muxer? Any example/documentation please?
[23:56:30 CEST] <JEEB> see the muxing example under the examples dir under doc
[23:56:40 CEST] <JEEB> or I think there are multiple
[23:57:20 CEST] <JEEB> there's plenty of viable containers and you just choose something that matches your use case
[23:58:57 CEST] <jim444> The only difference between my code and the example muxer.c is ret = av_interleaved_write_frame(oc, &pkt); after calling avcodec_encode_video2()
[00:00:00 CEST] --- Mon Aug 17 2015

More information about the Ffmpeg-devel-irc mailing list