[Ffmpeg-devel-irc] ffmpeg.log.20150817

burek burek021 at gmail.com
Tue Aug 18 02:05:01 CEST 2015

[00:00:55 CEST] <JEEB> that is because there's an avformatcontext set with the required stuff
[00:01:03 CEST] <JEEB> and then that packet can be written
[00:01:42 CEST] <jim444> I see.
[00:02:29 CEST] <jim444> Thaks. Is it enough to set pts and dts for AVFrame or I have to do it for AVPacket as well?
[00:05:00 CEST] <JEEB> don't remember, I think it's most important to set the timestamps correctly when encoding
[00:05:12 CEST] <JEEB> it should then have timestamp information according to that in the packet
[00:05:29 CEST] <JEEB> anyways, skimmed through the muxing example, it seems pretty good
[00:05:34 CEST] <JEEB> you should get up to speed with it
[00:05:53 CEST] <jim444> Thanks JEEB.
[00:06:03 CEST] <jim444> I will try to go through it :)
[00:11:11 CEST] <TikityTik> JEEB: How can I lower the size of the video stream when it's just a still image?
[00:11:20 CEST] <TikityTik> ffmpeg -loop 1 -i in.jpg -i in.mp3 -c:v libvpx -r 1 -crf 5 -filter_complex format=yuv420p -force_key_frames expr:gte(t,n_forced*10) -s 400:400 -c:a libvorbis -ac 2 -q:a 1 -metadata title="Floating Cloud - Flower
[00:11:20 CEST] <TikityTik>  Village 4/4" -threads 4 -shortest out.webm
[00:12:22 CEST] <chungy> -s needs to be in the form of 400x400
[00:13:13 CEST] <TikityTik> this 39 kB picture is making a videostream the size of 1603 kB
[00:13:38 CEST] <JEEB> that is because you are recoding it with libvpx with the settings you have set
[00:14:06 CEST] <TikityTik> what settings should i change to make it high quality but low size?
[00:14:15 CEST] <TikityTik> I assumed it would be somewhat automatic with crf
[00:14:24 CEST] <JEEB> uhh
[00:14:39 CEST] <JEEB> it's onyl automatic in the way that you find the highest crf value that still looks good
[00:14:51 CEST] <JEEB> also you are seemingly forcing keyframes every ten frames
[00:15:09 CEST] <JEEB> or I have no idea what n_forced is
[00:15:24 CEST] <JEEB> also you do have an audio stream there
[00:15:24 CEST] <TikityTik> yeah, for better seeking
[00:15:37 CEST] <TikityTik> the audio stream is ok, but the video stream size is too large
[00:15:41 CEST] <JEEB> well you are basically forcing the encoder to COMPLETELY code the picture again
[00:15:47 CEST] <JEEB> every ten frames
[00:16:10 CEST] <JEEB> you a) play with the CRF value or b) lengthen the GOP length
[00:16:23 CEST] <TikityTik> JEEB: and avoid using -b:v ?
[00:17:05 CEST] <TikityTik> yeah the forced key frames really messed with it
[00:17:13 CEST] <JEEB> they are two separate rate control modes (albeit libvpx has some brainfuck related to VBV+CRF)
[00:17:25 CEST] <TikityTik> am i able to have it seek better but not create the same issue?
[00:17:48 CEST] <JEEB> if the players you are aiming for suck dongs, then you can guess
[00:17:59 CEST] <JEEB> or if you otherwise have strict requirements
[00:18:22 CEST] <JEEB> if you require the encoder to code a full picture completely every ten frames, that will be done
[00:18:32 CEST] <JEEB> I noted you the two ways how to improve your situation
[00:18:46 CEST] <JEEB> pick one or two of them and see how far you get
[00:22:45 CEST] <TikityTik> yeah the size is good, just wished the seeking wasn't so bad lol
[00:24:49 CEST] <Agrajag-> g'day, i have a webcam that i can get an rtsp stream from, i would like to downscale it and output to a new rtsp stream, can ffmpeg do this?
[00:29:16 CEST] <TikityTik> I personally like VBV+CRF
[00:29:55 CEST] <JEEB> (that means maxrate+bufsize and crf, btw :P)
[00:29:57 CEST] <JEEB> and yes, it's good
[00:30:06 CEST] <JEEB> just that with libvpx there's some batshit insane shit there
[00:30:32 CEST] <JEEB> like, requiring a video bit rate also to be set although it is just pants-on-head retarded
[00:30:37 CEST] <JEEB> you have a maxrate and a bufsize
[00:30:47 CEST] <JEEB> and you have your primary way of rate control
[00:31:30 CEST] <JEEB> for whatever unfathomable reason the libvpx encoder wrapper (and possibly libvpx itself?) also requires a bit rate to be set in addition
[00:32:02 CEST] <TikityTik> Agrajag-: you probably can do so
[00:32:24 CEST] <TikityTik> But i might be confusing that with vlc, i'm not sure.
[00:34:30 CEST] <TikityTik> Agrajag-: https://trac.ffmpeg.org/wiki/StreamingGuide
[00:35:16 CEST] <TikityTik> and try to use -i "<your stream>" for the input
[00:49:58 CEST] <Guiri> Can someone explain how `trunc(ow/a/2)*2` works?  I use it to avoid ffmpeg quitting when scaling weird resolutions with `-1`
[00:51:22 CEST] <pzich> it appears to be dividing the output width by the aspec ratio, dividing it by 2, flooring (truncating) it, then multiplying by two to assure it's a multiple of two
[00:52:20 CEST] <Guiri> Ah ow = output width.  So, fi wanted to scale something to 480p, "scale=trunc(oh/a/2)*2:480"?
[00:52:46 CEST] <pzich> I think you'd need to multiply the aspect ratio instead
[00:53:56 CEST] <TikityTik> how can I do -pass 1 and -pass 2 right after another in Windows? Does ffmpeg have a function to do that for me?
[00:54:01 CEST] <TikityTik> Cannot use a bashscript.
[00:54:29 CEST] <Guiri> Ah, thanks pzich.  I get it now
[00:54:36 CEST] <pzich> TikityTik: not 100% sure about DOS, but can't you put two commands after each other with a semicolon
[00:54:52 CEST] <TikityTik> It's even a pain to copy paste in DOS
[00:55:08 CEST] <TikityTik> it's block highlighting and not inline highlighting
[00:55:33 CEST] <ScottSteiner> I'm trying to make a recording of my desktop but when doing "ffmpeg -f x11grab -i :1 -t 1 test.webm" all I get is a black box. I'm trying to do it over vnc so I'm not sure if that is the correct display.  How can I tell?  thanks
[00:55:40 CEST] <cbsrobot> Guiri: use -2
[00:55:59 CEST] <pzich> it looks like you cant use & in DOS
[00:56:07 CEST] <pzich> err, -t, you *can* use
[00:56:13 CEST] <pzich> terrible typo
[00:56:18 CEST] <Guiri> cbsrobot: Can you explain a bit more?  I was using 640:-1, but discovered it would break with odd integer resolutions
[00:56:32 CEST] <cbsrobot> Guiri: so try 640:-2
[00:56:58 CEST] <TikityTik> Is it bad to use 2-pass on low bitrates like 252 kbps?
[00:57:04 CEST] <TikityTik> when should i avoid 2-pass?
[00:57:23 CEST] <pzich> depends on the codec, I've been told it's basically never worth it for x264
[00:57:27 CEST] <TikityTik> I assume it only does good, althrough with larger filesize
[00:57:33 CEST] <TikityTik> for libvpx?
[00:58:08 CEST] <pzich> generally go 2-pass when you are aiming for best quality and looking for a target file size, but I'm not an expert
[00:59:03 CEST] <pzich> I haven't done much with vpx but it looks like most people 2-pass
[01:06:12 CEST] <JEEB> yes, if you want a *specific* file size, then 2pass average bit rate
[01:09:00 CEST] <Guiri> Cool, that works, cbsrobot. Thx
[01:10:00 CEST] <cbsrobot> Guiri: if you wonder, rtfm on https://ffmpeg.org/ffmpeg-filters.html#Options-1 the sentence starting with  "If one of the values is -n with n > 1,"
[01:10:32 CEST] <tab1293> anyone know where I can find a simple sample of how to implement a video player with libavcodec? the dranger tutorials segfault and ffplay is a little to complex for learning
[02:37:43 CEST] <korain> say i want to recusively convert and clone a director tree from flac to opus what would be the best way to do that?
[03:09:50 CEST] <ted-E> using a provided binary, trying to make a video out of a string of jpgs
[03:09:52 CEST] <ted-E> http://pastebin.com/Lj5dTscQ
[03:10:15 CEST] <ted-E> it keeps wanting to overwrite the next image in the sequence, but I don't know why when there is an outfile
[03:13:39 CEST] <ted-E> i've simplified it to just the IMG*.JPG and the out file with the same issue
[03:15:16 CEST] <ScottSteiner> While trying to record the screen from within a vnc connection, I keep getting a black screen. What could be causing this?
[06:10:00 CEST] <Mister_D> cant figure out amerge problem. Trying to add music track to a video file and it works while processing without video -  both audio tracks are in. While encoding with video get constant warnings Error while decoding stream #0:1: Cannot allocate memory while playing it back the audio stutters after 10 sec and then stops completely at 12 sec mark. Using Big buck bunny video with creative common MP3 file.
[06:10:00 CEST] <Mister_D> http://pastebin.ca/3110018
[06:14:05 CEST] <oreWizard> can someone helpme?
[06:14:09 CEST] <oreWizard> i am getting this error
[06:14:09 CEST] <oreWizard> cl is unable to create an executable file.
[06:14:09 CEST] <oreWizard> C compiler test failed.
[06:14:24 CEST] <oreWizard> i am tryign to compile for windows phone
[06:16:58 CEST] <Mister_D> same command without video processign executes fine. http://pastebin.ca/3110027
[06:25:34 CEST] <buu> Hey, where should I start reading to learn how to modify the output of ffmpeg to add things like text/graphics/etc on top of a video?
[06:27:18 CEST] <c_14> buu: https://ffmpeg.org/ffmpeg-filters.html especially drawtext and overlay
[06:27:44 CEST] <buu> thanks
[06:28:41 CEST] <c_14> Mister_D: have you tried without the scale?
[06:31:25 CEST] <c_14> Mister_D: that message is only thrown on malloc failures though
[06:31:50 CEST] <Mister_D> without scale, when using -map 0:v:0 -c:v copy it works.
[06:32:38 CEST] <c_14> ie: your OS is refusing to allocate memory
[06:33:44 CEST] <c_14> Do you have plenty of free RAM?
[06:35:45 CEST] <Mister_D> yes, its Amazon EC2 t2.micro with a Gig of RAM
[06:36:13 CEST] <c_14> And how much of that is free when ffmpeg is running the command?
[06:36:19 CEST] <c_14> (you can check with free -m)
[06:36:19 CEST] <Mister_D> 750
[06:36:31 CEST] <Mister_D> 742236 avail Mem
[06:37:46 CEST] <c_14> While ffmpeg is executing the command?
[06:38:03 CEST] <Mister_D> before it runs.
[06:38:29 CEST] <c_14> And while it runs?
[06:38:48 CEST] <c_14> I wouldn't be all that surprised if ffmpeg needs more than that.
[06:38:59 CEST] <fling> Is not it still possible to skip parts of videos not containing any movement?
[06:39:07 CEST] <fling> I have a bunch of footage from a security camera.
[06:39:19 CEST] <fling> I want to only keep parts containing motion on the video.
[06:40:49 CEST] <Mister_D> c_14: will check memory usage while it runs
[06:42:06 CEST] <c_14> fling: I don't think ffmpeg has a filter that detects motion
[06:42:49 CEST] <fling> c_14: Is there something external I could try?
[06:46:19 CEST] <Mister_D> c_14: its not RAM, its stays at ~705MB whil executing the command
[06:48:18 CEST] <c_14> fling: none I know of
[06:49:15 CEST] <fling> c_14: stupid solution would be splitting the video into frames and remove frames non containing any move with my script or imagemagick and then combining frames back into the video.
[06:49:34 CEST] <fling> c_14: but I will loose sound this way.
[06:49:56 CEST] Action: fling will probably use this method for silent videos btw.
[06:52:28 CEST] <c_14> Mister_D: Well, your libc is failing to allocate memory for some reason.
[06:53:03 CEST] <Mister_D> c_14: building 2.6.4 just to test&
[06:53:46 CEST] <fling> c_14: is 2.7.2 good to use btw?
[06:54:05 CEST] <c_14> fling: You could always write a filter for ffmpeg that does motion detection and then drops audio/video frames without motion. It'll be a lot of work though. Other than that I can only refer you to google for other solutions.
[06:54:23 CEST] <c_14> fling: It's fine, we prefer you use git builds when possible because they contain bugfixes not in the release versions.
[06:54:27 CEST] <c_14> *not yet
[06:54:45 CEST] Action: fling will update from git prior the next ffmpeg workload.
[08:44:54 CEST] <Taniey>  I import fonts from windows to centos 6.5,and use ttmkfdir to reload the windows fonts, so  I can use the windows fonts. but the filter 'drawtext' to draw some Korean or some other characters of not in ansii table can`t correctly draw or auto select correct fonts to draw the video ,how can I resolve this question?
[08:45:15 CEST] <Taniey> the ffmpeg commend like this:
[08:46:02 CEST] <Taniey> ffmpeg -y -i input.mkv -filter_complex "drawtext=textfile=\'drawtext.txt\':font=\'arial\':fontsize=48:fontcolor=00ffff:x=50:y=200" -sn -codec:v h264 -codec:a aac -strict -2 out.mkv
[08:47:15 CEST] <Taniey> the content of drawtext.txt contain : Korean , Arabic, English etc.
[08:57:12 CEST] <kode54> Taniey: is it a UTF-8 encoded text file?
[08:58:11 CEST] <Taniey> yes
[09:16:31 CEST] <Taniey> how can I use filter drawtext's font paramater get bold fonts?
[09:23:05 CEST] <durandal_1707> read docs
[09:35:29 CEST] <Taniey> I can't find dos about how bold fonts from ffmpeg docment?
[12:37:41 CEST] <Ecco> Hi everyone!
[12:38:13 CEST] <Ecco> I have a series of JPEG image that would make sense as a movie (it's a timelapse)
[12:38:30 CEST] <Ecco> I'd like to "pack" them in a single file, for *archiving*
[12:38:37 CEST] <Ecco> (I could zip them up, but it's tedious to read)
[12:39:01 CEST] <Ecco> Is it possible to pack them as a movie file *without* degrading the movie quality using ffmpeg?
[12:40:14 CEST] <JEEB> you could use mov or matroska and just copy the JPEGs as a "MJPEG" stream
[12:40:27 CEST] <JEEB> I wonder if that would just work with -c copy
[12:40:41 CEST] <Ecco> Nice
[12:40:47 CEST] <Ecco> ok, mov would be perfect
[12:40:51 CEST] <Ecco> Lemme give this a try
[12:44:36 CEST] <JEEB> because in theory MJPEG is just video where every picture is a separate JPEG :)
[12:45:16 CEST] <JEEB> yeah, it seems like people have done it at least with matroska, and I wouldn't be surprised about MOV either
[12:49:13 CEST] <Ecco> Sweet
[12:49:19 CEST] <Ecco> (I'm still fighting with the CLI syntax)
[12:52:04 CEST] <Ecco> Will it keep all the EXIF meta?
[12:52:53 CEST] <Ecco> I guess I'll try to unpack and see if the files are exactly the same
[12:53:48 CEST] <Ecco> Yay, it seems to be working
[12:54:40 CEST] <Ecco> Excellent
[12:54:42 CEST] <Ecco> same MD5
[12:54:44 CEST] <Ecco> perfect
[12:54:47 CEST] <Ecco> thanks a lot JEEB !
[12:54:50 CEST] <JEEB> np :)
[14:03:48 CEST] <oreWizard> pkg-config not found, library detection may fail.
[14:03:54 CEST] <oreWizard> someone can help me with this?
[14:08:26 CEST] <uvx3> I think you need the pkg-config to be installed.
[14:11:36 CEST] <oreWizard> ok
[14:11:48 CEST] <oreWizard> i need to write some paths on itw
[14:18:24 CEST] <oreWizard> ?
[14:51:22 CEST] <oreWizard> someone knows how to create pkg-config for compiling?
[14:56:18 CEST] <iive> oreWizard: most programs include files that pkg-config  can parse and return stuff used for compilation
[15:07:34 CEST] <oreWizard> iive thkx
[16:19:22 CEST] <livingBEEF> Any idea if -start_at_zero is the opposite of -copyts? The description in documentation is very confusing...
[16:30:02 CEST] <livingBEEF> well, I'll probably just encode the audio separately, copyts seems to mess it up all the time
[16:38:25 CEST] <oreWizard> why i cant find swresample.h
[16:38:33 CEST] <oreWizard> ?
[16:39:20 CEST] <CalimeroTeknik> /usr/include/libswresample/swresample.h
[16:39:56 CEST] <CalimeroTeknik> I'm trying to burn subs into a video and pad it at the same time, but only the last -vf argument works!
[16:42:19 CEST] <oreWizard> Error	C1083	Cannot open include file: 'libswresample/swresample.h': No such file or directory (
[16:42:22 CEST] <oreWizard> idk
[16:52:02 CEST] <c_14> CalimeroTeknik: either combine the two filterchains into one filterchain, or use -filter_complex and a filtergraph
[16:52:21 CEST] <c_14> Having more than one -vf isn't supported
[16:52:29 CEST] <c_14> oreWizard: does the file exist?
[17:01:32 CEST] <CalimeroTeknik> c_14, it appears that a comma did the trick!
[18:35:57 CEST] <kyleogrg> is there a way to automatically find the IVTC pulldown pattern for a video?
[18:42:16 CEST] <kyleogrg> i've recorded an HD show off TV onto a 29.97i DV AVI.  now I want to detelecine, but i can't find the exact pattern
[18:43:30 CEST] <durandal_170> use fieldmatch or pullup
[18:44:57 CEST] <kyleogrg> if i recorded it off tv, does that suggest that it doesn't have a consistent pattern throughout the recording?
[18:49:16 CEST] <durandal_170> maybe, maybe not
[18:50:24 CEST] <JEEB> with ads most probably not
[18:50:55 CEST] <JEEB> in most cases you should be able to do it with fieldmatch (?) methinks, since that should look up the most probable matches
[18:51:06 CEST] <JEEB> it does always require some eye-checking
[18:54:18 CEST] <kyleogrg> JEEB: okay.  so i'll try fieldmatch + yadif + decimate.  so i want yadif to "Output one frame for each frame" right?
[18:55:47 CEST] <JEEB> yeah
[18:58:01 CEST] <kyleogrg> ok, thanks
[18:58:24 CEST] <kyleogrg> i guess i could do yadif + mcdeint with this?
[19:35:54 CEST] <kyleogrg> does AAC have a lossless mode?
[19:39:35 CEST] <JEEB> kyleogrg: no
[19:40:20 CEST] <kyleogrg> JEEB: well, i'm experimenting with lossless x264 in an MP4 container, and I also want to try a (compatible) lossless audio codec.
[19:40:49 CEST] <JEEB> almost none uses the MPEG-4 lossless audio thing
[19:40:53 CEST] <JEEB> *no-one
[19:40:58 CEST] <JEEB> but I think ffmpeg has support for it
[19:41:11 CEST] <c_14> You mean alac?
[19:41:20 CEST] <JEEB> no
[19:41:23 CEST] <JEEB> that's apple's thing
[19:41:49 CEST] <JEEB> ALS
[19:41:53 CEST] <JEEB> https://en.wikipedia.org/wiki/Audio_Lossless_Coding
[19:42:26 CEST] <kyleogrg> JEEB: but lossless quality shouldn't be any less compatible than lossy, right?
[19:42:35 CEST] <kyleogrg> why would crf 0 be less compatible than crf 18?
[19:42:56 CEST] <JEEB> because it uses a different profile and a different, lossless DCT?
[19:43:32 CEST] <JEEB> (among other things, read the specification for the gritty details on the lossless profile)
[19:43:39 CEST] <kyleogrg> hmm okay
[19:44:03 CEST] <JEEB> nvidia seems to have implemented it recently for AVC encoding, possibly decoding too... not sure though
[19:44:44 CEST] <JEEB> but in general lossless kills any sort of end-user hardware decoding, as well as all of the software decoders that are payware except for coreavc (which is by now dead as wood)
[19:45:17 CEST] <JEEB> also man, now that I look at it MPEG-4 Part 3 contains a whole truckload of audio formats
[19:45:36 CEST] <JEEB> everything from CELP to AAC/TwinVQ to TTSI to ALS/SLS
[19:46:04 CEST] <JEEB> https://en.wikipedia.org/wiki/MPEG-4_Part_3#Subparts
[19:46:19 CEST] <JEEB> ALS is the one supported by ffmpeg that is lossless
[19:59:38 CEST] <Oleg_> guys, when I type this command: ffmpeg -f v4l2 -framerate 25 -video_size 640x480 -i /dev/video0 output.mkv
[19:59:46 CEST] <Oleg_> it only records video
[19:59:54 CEST] <c_14> yep
[19:59:56 CEST] <c_14> that's intended
[20:00:05 CEST] <Oleg_> but how can I record audio with webcam's microphone, assuming it's /dev/dsp3?
[20:00:25 CEST] <c_14> alsa?
[20:00:27 CEST] <c_14> pulse?
[20:00:37 CEST] <Oleg_> alsa
[20:00:43 CEST] <Oleg_> what about oss?
[20:00:57 CEST] <Oleg_> can I record it with oss?
[20:01:17 CEST] <c_14> https://www.ffmpeg.org/ffmpeg-devices.html#oss
[20:06:33 CEST] <Oleg_> c_14, well, it looks like it tries to record audio with libvorbis, and it causes video/audio desynchronisation
[20:08:39 CEST] <Oleg_> I typed this:
[20:08:42 CEST] <Oleg_> ffmpeg -f v4l2 -framerate 25 -video_size 640x480 -i /dev/video0 -f oss -i /dev/dsp3 output.mkv
[20:17:19 CEST] <Oleg_> c_14, I wanna record audio with pcm_s16le, instead of vorbis
[20:17:27 CEST] <c_14> -c:a pcm_s16le
[20:17:37 CEST] <c_14> Not sure why it is desync though
[20:29:20 CEST] <Oleg_> c_14, okay, pcm_s16le also causes desynchronization, but what if I try recording with mp3lame?
[20:29:34 CEST] <Oleg_> c_14, can you please tell me how to record sound with mp3lame?
[20:30:36 CEST] <c_14> -c:a libmp3lame
[20:37:35 CEST] <Oleg_> c_14, if I record just audio, then I have no problems
[20:56:23 CEST] <Oleg_> c_14, how can I transcode audio to a lower bitrate?
[20:56:34 CEST] <c_14> -b:a your-bitrate-here
[21:08:28 CEST] <Oleg_> c_14, do you see anything odd in this output: http://pastebin.com/FqXM0Y0h ?
[21:09:14 CEST] <c_14> A lot of warnings
[21:09:19 CEST] <c_14> Nothing obvious though
[21:09:39 CEST] <LanDi> hey guys, I have a 1080 mkv video... my problem is: its file size is 10GB, I want to make it smaller... can someone help me or send me a link where I can lear how to do tha?
[21:09:55 CEST] <LanDi> learn*
[21:10:09 CEST] <c_14> https://trac.ffmpeg.org/wiki/Encode/H.264
[21:12:54 CEST] <LanDi> c_14, thanks
[22:17:07 CEST] <Fyr> guys, is it possible to make ffmpeg embed cover art automatically? all my files contain cover art, but ffmpeg when converts it, doesn't extract the art from input file and embed to the output.
[22:29:15 CEST] <uvx3> Have you tried using '-map 0:0 -map 0:1' or so?
[22:30:11 CEST] <bbert> Anyone know about ffmpeg's handling of mxf containers?  Do you have access to either the System Item or the Data Item of Content Packages?
[22:30:39 CEST] <bbert> assuming you're using libav* from your own code
[22:41:33 CEST] <jim44> Hi Guys. How can I set h264 preset with ffmpeg api?
[22:41:49 CEST] <jim44> I am storing video in real time and I would like it to be as fast as possible.
[22:43:21 CEST] <JEEB> you set an avoption for the libx264 encoder in which you set the preset
[22:43:22 CEST] <jim44> I have tried using av_dict_set(&m_dictionary, "preset","veryslow",0); and av_opt_set(mCodecContext->priv_data, "preset", "ultrafast", 0);
[22:43:24 CEST] <uvx3> '-preset ultrafast'
[22:43:29 CEST] <jim44> but the encoding time does not change
[22:43:33 CEST] <uvx3> Read more here: https://trac.ffmpeg.org/wiki/Encode/H.264
[22:43:39 CEST] <JEEB> uvx3: he was talking about the API
[22:43:44 CEST] <JEEB> not command line
[22:43:54 CEST] <uvx3> Oh, sorry :)
[22:43:57 CEST] <JEEB> :)
[22:44:02 CEST] <jim44> no problem :)
[22:44:27 CEST] <jim44> so any ideas? :)
[22:45:27 CEST] <jim44> Here is a part of the code
[22:45:28 CEST] <jim44> http://pastebin.com/1UMpDp55
[22:47:38 CEST] <jim44> and I am using libavcodec
[22:48:45 CEST] <JEEB> while I would probably prefer setting x264opts or so, I can see that there's a thing called preset in libx264.c's avoptions
[22:51:22 CEST] <JEEB> or I guess it's this https://github.com/FFmpeg/FFmpeg/blob/master/libavcodec/libx264.c#L878
[22:53:08 CEST] <jim44> Thanks JEEB. I will check it out.
[22:54:42 CEST] <JEEB> yeah, it seems like I haven't set avoptions myself
[22:54:43 CEST] <JEEB> https://github.com/jeeb/matroska_thumbnails/blob/master/src/matroska_thumbnailer.cpp#L178
[22:54:57 CEST] <JEEB> I've only opened a decoder with an avdict
[22:56:16 CEST] <jim44> I have tried both av_opt_set and av_dict_set but there is no change in encoding time.
[22:59:01 CEST] <JEEB> are you sure you're getting the right encoder set? libx264 outputs the used parameters to standard error output, check if those change. could it be that you have a bottleneck somewhere else or that the thing you're running this thing on is just slow as molasses
[23:01:31 CEST] <jim44> Good point. How can I output the used parameters? sorry, I am quite new at ffmpeg api
[23:05:26 CEST] <JEEB> it should output to stderr always
[23:05:34 CEST] <JEEB> unless you are making lavc be completely silent
[23:09:15 CEST] <jim44> Thanks. Let me try.
[23:58:18 CEST] <Tom012> Hello everybody. Is there an option to tell ffmpeg to ignore vob files?
[00:00:00 CEST] --- Tue Aug 18 2015

More information about the Ffmpeg-devel-irc mailing list