[Ffmpeg-devel-irc] ffmpeg.log.20150818

burek burek021 at gmail.com
Wed Aug 19 02:05:01 CEST 2015

[00:08:52 CEST] <techtopia> just don't open the vob file?
[00:09:07 CEST] <techtopia> ffmpeg -i somefile.notvob etc...
[00:09:45 CEST] <techtopia> or if the vob file is a track of somthing you can omit it with -map
[00:09:55 CEST] <techtopia> but i can't see that ever being the case
[00:52:57 CEST] <JohnnyonFlame> Hello. I'm trying to run 'moonlight' on a CI20 running Debian 7 wheezy w/ non-free+backports, however I'm getting "Error: Invalid data found when processing input" from libavcodec, and I'm unsure on how to debug this.
[00:53:06 CEST] <JohnnyonFlame> any ideas? Thanks.
[00:54:52 CEST] <JohnnyonFlame> oh, and the error code comes from "avcodec_decode_video2"
[01:01:37 CEST] <silverfox> Does anyone on here known how to use MSYS2?
[01:06:23 CEST] <silverfox> I am trying to compile ffmpeg but get error: "Unknown OS msys_nt-6.3'
[06:11:57 CEST] <nanoEng> is it normal that when compiling there are a ton of   Warning: -fPIC ignored for target (all code is position independent)  ?
[06:56:47 CEST] <DHE> depends on the CPU type, but it could happen sure. everything would get -fPIC by default
[09:44:51 CEST] <nanoEng> how do i get SDL installed in msys2?
[09:45:38 CEST] <nanoEng> i used pacman -S mingw64/mingw-w64-x86_64-SDL
[09:45:43 CEST] <nanoEng> i used pacman -S mingw64/mingw-w64-x86_64-SDL2
[09:46:49 CEST] <nanoEng> i used pacman -S mingw32/mingw-w64-i686-SDL
[09:47:05 CEST] <nanoEng> it says they are all installed when doing   pacman -Ss sdl
[09:47:44 CEST] <nanoEng> and yet when i try to compile ffmpeg using ./configure enable-sdl     I get    Error: SDL not found.
[09:48:15 CEST] <nanoEng> someone care to explain?
[09:51:56 CEST] <JEEB> 1) are you sure you are using the mingw-w64 32bit or 64bit cross-compiler (since "native" for msys2 is, of course, msys2)
[09:52:02 CEST] <JEEB> 2) see config.log
[09:52:16 CEST] <JEEB> also if there are any development packages for those SDLs, you probably want those
[09:52:49 CEST] <nanoEng> let me check
[09:54:09 CEST] <nanoEng> well when you type    pacman -Ss sdl  you get the entries listed here: http://sourceforge.net/p/msys2/wiki/Packages/
[09:59:16 CEST] <nanoEng> Are you saying that I should also install the    SDL_gfx   and  SDL _ttf   packages?
[09:59:46 CEST] <nanoEng> And I need SDL-1.2 for ffmpeg, correct?   As according to here: http://trac.ffmpeg.org/wiki/CompilationGuide/MinGW  ?
[10:04:20 CEST] <JEEB> you should install the packages containing the development libraries for the SDL you are planning to use
[10:04:30 CEST] <JEEB> I don't know if there is SDL2 support yet :P
[10:04:50 CEST] <nanoEng> well as it says on http://sourceforge.net/p/msys2/wiki/Packages/
[10:05:14 CEST] <nanoEng> MSYS2 lets you download and install SDL2
[10:05:20 CEST] <nanoEng> oh.. you meant for FFmpeg
[10:05:53 CEST] <nanoEng> i'm just trying to compile ffplay
[10:06:41 CEST] <JEEB> basically look at what ffmpeg's configure is looking for by staring at what is written into config.log
[10:06:50 CEST] <nanoEng> and it has turned into a @*#%& nightmare (i'm not very experienced with compiling; I'm self-taught in Python, that's about it, took a C++ class and wrote Hello World stuff a long time ago)
[10:07:20 CEST] <JEEB> also make sure you are using either i686-w64-mingw32-* tools or x86_64-w64-mingw32-* tools depending on if you want a 32bit or 64bit mingw-w64 compile :P
[10:07:33 CEST] <JEEB> because the default for msys2 is msys2, which you probably don't want
[10:08:37 CEST] <nanoEng> not sure what you mean by that last statement
[10:08:48 CEST] <nanoEng> default for what is msys2?
[10:09:10 CEST] <nanoEng> Also, i'm trying to make a 64bit compile
[10:10:27 CEST] <nanoEng> but installing the 64bit SDL-1.2 didn't work, and that site says you need SDL-1.2, so i thought maybe install the i686 one, even though that went against common sense to me, and sure enough, installing it still turned up Error: SDL not found.
[10:15:15 CEST] <nanoEng> When you say, the SDL i'm planning to use,... don't you mean SDL-1.2 ? since http://trac.ffmpeg.org/wiki/CompilationGuide/MinGW   says you have to???
[10:16:49 CEST] <JEEB> nanoEng: well first of all check from config.log or otherwise if you're even trying to configure with the right tools
[10:17:11 CEST] <JEEB> as I said, msys2 by default has the tools aimed for the "msys2" OS
[10:17:36 CEST] <JEEB> the mingw-w64 tools usually have the cross-prefix of i686-w64-mingw32 or x86_64-w64-mingw32
[10:19:47 CEST] <nanoEng> hmm.. well MSYS2 has a MSYS shell and a MinGW-w64 shell;  Are you saying I should use the MinGW-w64 shell?
[10:22:14 CEST] <nanoEng> ffs... now it's telling me it doesn't like --arch=AMD64, well it didn't like --arch=win32 or --arch=win64.... . EVEN THOUGH typing   env   gives     PROCESSOR_ARCHITECTURE=AMD64
[10:22:41 CEST] <nanoEng> well wtf are my choices then???
[10:23:00 CEST] <nanoEng> ./configure --help   doesn't tell me jack
[10:23:58 CEST] <nanoEng> and when i did --arch=x86_64... it said after doing ./configure  that arch=x86  ...... wtf?
[10:27:42 CEST] <nanoEng> Also, i just deleted and re=ran ./configure with my settings.
[10:27:57 CEST] <nanoEng> Here is the config.log, if you can make any sense of it:  http://pastebin.com/jV9S9a3M
[10:33:24 CEST] <goht> Hi. I'm looking for ffplay statistics parameters (A-V fd aq vq sq f) description. Docs didn't help me.
[10:35:11 CEST] <nanoEng> hi goht
[10:35:17 CEST] <nanoEng> are you able to compile ffplay?
[10:36:56 CEST] <goht> yes, but I use precompiled windows package
[10:38:43 CEST] <nanoEng> How did you compile it?
[10:38:50 CEST] <nanoEng> msys2?
[10:38:58 CEST] <nanoEng> or well, msys2 shell?
[10:39:22 CEST] <nanoEng> by anychance, or are you on linux?
[10:40:50 CEST] <nanoEng> btw, this isn't what your looking for is it: http://linux.die.net/man/1/ffplay ?
[10:43:05 CEST] <goht> I've alrady seen it. so I'm looking for 37.79 A-V: -0.016 fd=  13 aq=   10KB vq=   51KB sq=    0B f=0/0 parameters description
[10:43:44 CEST] <nanoEng> what's 37.79 A-V ?
[10:44:19 CEST] <goht> it is the ffplay process console output
[10:44:30 CEST] <nanoEng> I ask since it might be useful, since i'm trying to modify ffplay, but i can't even get it to compile.
[10:44:58 CEST] <nanoEng> output after inputting what?
[10:45:29 CEST] <nanoEng> ah.............. i think i see what your saying
[10:45:37 CEST] <nanoEng> that's what you're trying to figure out
[10:45:53 CEST] <goht> Maybe I'm too bad english speaker.
[10:46:08 CEST] <goht> sorry
[10:46:11 CEST] <nanoEng> I'm not used to compiling, I taught myself Python.
[10:46:21 CEST] <nanoEng> Python has very good documentation.
[10:46:44 CEST] <nanoEng> Try to use anything else, and you will be disappointed with the documentation of anything else.
[10:46:58 CEST] <nanoEng> (after using python)
[10:47:00 CEST] <BtbN> Sounds like you haven't used anything else yet.
[10:47:07 CEST] <nanoEng> yup
[10:47:19 CEST] <nanoEng> well, like i said earlier, i took a C++ class a long time ago.
[10:47:49 CEST] <nanoEng> all we did was Hello World stuff though. Print one * then print ** on the next line, then ***, etc. upto 8 *'s.
[10:48:17 CEST] <nanoEng> silly stuff that i could write code for in python in 3 lines.
[10:48:50 CEST] <nanoEng> How are you BtbN?
[10:49:44 CEST] <nanoEng> your a bit of a celebrity here, arn't you BtbN?
[10:49:50 CEST] <nanoEng> I know you from: http://lists.ffmpeg.org/pipermail/ffmpeg-devel-irc/2015-June/002873.html
[10:50:08 CEST] <nanoEng> :P
[10:51:37 CEST] <nanoEng> In any case, I wanted to strengthen my C language muscles (or grow some) and I thought modifying ffplay would make for a fun project.
[10:52:06 CEST] <nanoEng> Unfortunatly, I can't even get it to compile.
[10:52:15 CEST] <BtbN> It's propably easier to just setup a linux somewhere.
[10:52:51 CEST] <nanoEng> Yeah.. i don't have an extra computer laying around to install linux on, unfortunatly..... elsei woulda done that ages ago.
[10:53:04 CEST] <BtbN> virtual machines do exist
[10:53:10 CEST] <nanoEng> true..
[10:53:33 CEST] <nanoEng> but if i wanted to installl a vertual machine and an entire operating system....
[10:53:50 CEST] <nanoEng> i would have just downloaded Microsoft Visual Studio
[10:54:07 CEST] <nanoEng> and followed the FFmpeg compilation instructions for MSVC
[10:54:11 CEST] <BtbN> which doesn't help you at all with your problem.
[10:54:26 CEST] <BtbN> building ffmpeg with MSVC only makes things even more complicated any annoying.
[10:54:32 CEST] <BtbN> *and
[10:54:32 CEST] <nanoEng> but when i saw MSVC is 4 GB, i said f that.
[10:55:04 CEST] <nanoEng> hmm..
[10:56:09 CEST] <nanoEng> That's not what it says here
[10:56:10 CEST] <nanoEng> http://trac.ffmpeg.org/wiki/CompilationGuide
[10:56:30 CEST] <nanoEng> "Compiling FFmpeg using MSVC is easy; follow the instructions on the main page or CompilationGuide/MSVC for more details. "
[10:58:03 CEST] <nanoEng> yet, if you follow that link, you'll see something siding more with your statement... serveral lines of instructions, instread, (section 4.1)  is only 7 lines... unfortunatly, it explains jack-S.
[10:58:45 CEST] <nanoEng> " In order to compile FFplay, you must have the MinGW development library of SDL and pkg-config installed. "
[10:59:18 CEST] <nanoEng> Yeah, thanks for not explaining how to go about doing any of that.
[10:59:39 CEST] <nanoEng> By some miracle, i finally got the damn  pkg-config  thing to work.
[11:00:36 CEST] <nanoEng> and before that I couldn't get anything, it was just telling me Unknown OS: msys_nt-6.3... then i think by doing  ./configure --disable-d3d11va    or   --disable-dxva2  finally fixed that
[11:01:45 CEST] <nanoEng> which i got from the http://trac.ffmpeg.org/wiki/CompilationGuide/WinRT for compiling for Windows 8.1 64bit  (which is what i'm running)
[11:02:03 CEST] <nanoEng> but those instructions are assuming you have MSVC
[11:02:34 CEST] <nanoEng> but i just stole the config settings of d3d11va and dxva2
[11:02:57 CEST] <nanoEng> why the f did that fix it not recognizing the OS, i haven't a clue.
[11:03:24 CEST] <nanoEng> hi orewizard, abandon all hope.
[11:03:28 CEST] <oreWizard> ?
[11:03:41 CEST] <oreWizard> i did compile ffmpeg
[11:03:45 CEST] <nanoEng> Yee have entered the land of the damned.
[11:03:47 CEST] <oreWizard> but idk how to use it on vs2015
[11:04:33 CEST] <nanoEng> i'm trying to compile it w/o VS
[11:04:47 CEST] <nanoEng> what did you compile it with?
[11:05:29 CEST] <nanoEng> msys2?
[11:05:30 CEST] <oreWizard> ms2015 msys2 yasm gas-processor
[11:05:34 CEST] <oreWizard> yes
[11:05:43 CEST] <nanoEng> ah, you were using: http://trac.ffmpeg.org/wiki/CompilationGuide/WinRT  ??
[11:05:53 CEST] <oreWizard> yes
[11:06:00 CEST] <oreWizard> but i got errror on pkg-config
[11:06:06 CEST] <nanoEng> Ah!
[11:06:09 CEST] <nanoEng> i had same problem
[11:06:15 CEST] <nanoEng> i spent last 6 hours working on that
[11:06:18 CEST] <oreWizard> but i made an install ok
[11:06:22 CEST] <nanoEng> finally fixed it
[11:06:27 CEST] <nanoEng> oh...
[11:06:29 CEST] <nanoEng> well anyway
[11:06:35 CEST] <oreWizard> the interop
[11:06:36 CEST] <nanoEng> if you wanted to fix the pkg-config thing
[11:06:45 CEST] <nanoEng> you use MSYS2 shell
[11:06:46 CEST] <oreWizard> its not working for me th einterop
[11:07:05 CEST] <nanoEng> and type   pacman -S msys/pkg-config
[11:07:16 CEST] <oreWizard> yes true
[11:07:48 CEST] <oreWizard> i will try to compile again
[11:07:50 CEST] <oreWizard> thanks
[11:07:58 CEST] <oreWizard> are u using it on vs?
[11:08:41 CEST] <nanoEng> do NOT use   pacman -S mingw64/mingw-w64-x86_64-pkg-config
[11:08:54 CEST] <nanoEng> no
[11:09:00 CEST] <nanoEng> vs is like 4 GB
[11:09:14 CEST] <nanoEng> i'm trying to compile it w/o having to download vs
[11:09:29 CEST] <nanoEng> i mean, if i was a computer programer, i wouldn't mind having vs on my computer
[11:09:57 CEST] <nanoEng> but since i'm just doing this for fun, nothing extreem, just editing ffplay.c  is what i want to do
[11:10:37 CEST] <nanoEng> maybe add a menu dialog pop=up window for some user input... have to learn how to do that.  but that's it.
[11:10:54 CEST] <nanoEng> So i don't think i need a 4 GB IDE just for that.
[11:11:04 CEST] <oreWizard> i dont use it for working so?
[11:11:07 CEST] <oreWizard> u*
[11:11:35 CEST] <nanoEng> I'm from the old days, back when 4 GB is huge.
[11:11:46 CEST] <oreWizard> i seee
[11:11:48 CEST] <nanoEng> I know 4 GB is small to you young people.
[11:11:55 CEST] <oreWizard> i am making some app for windows phone
[11:12:03 CEST] <oreWizard> i have 30 yo =)
[11:12:12 CEST] <nanoEng> But it still bothers me, why the hell i should need a 4 GB IDE.
[11:12:20 CEST] <oreWizard> i see
[11:12:29 CEST] <nanoEng> you are 30 yr old, or you have a 30 year old son  or daughter?
[11:12:39 CEST] <oreWizard> lol
[11:12:42 CEST] <oreWizard> i dont have kids
[11:12:45 CEST] <oreWizard> i have only 30
[11:12:48 CEST] <oreWizard> :)
[11:12:54 CEST] <nanoEng> oh, you said you have a 30 year old
[11:13:01 CEST] <nanoEng> you mean you ARE 30 years old.
[11:13:05 CEST] <oreWizard> sory
[11:13:13 CEST] <nanoEng> people might get confused., just fyi
[11:13:13 CEST] <oreWizard> need pratice for writting text
[11:13:19 CEST] <oreWizard> in english
[11:13:22 CEST] <nanoEng> no worries
[11:13:29 CEST] <oreWizard> not my native language
[11:13:31 CEST] <nanoEng> i am turning 30 in a few days -_-
[11:13:40 CEST] <oreWizard> congratz
[11:13:48 CEST] <oreWizard> 30 is the best age so far =)
[11:13:53 CEST] <nanoEng> my last days being in my 20s and this is how i am spending them -_-
[11:14:00 CEST] <nanoEng> lol
[11:14:06 CEST] <oreWizard> in my 30 yo birhday
[11:14:09 CEST] <oreWizard> i spend 30 dolares
[11:14:17 CEST] <oreWizard> on a virtual striper
[11:14:18 CEST] <oreWizard> show
[11:14:21 CEST] <nanoEng> on what? hookers and booz?
[11:14:21 CEST] <oreWizard> lol
[11:14:29 CEST] <nanoEng> lol
[11:14:37 CEST] <nanoEng> virtual? not even a real one? :p
[11:14:40 CEST] <oreWizard> i donnt like hoojer
[11:14:43 CEST] <oreWizard> for sex
[11:14:52 CEST] <nanoEng> i wouldn't know myself.
[11:14:54 CEST] <oreWizard> i never did it wiht one
[11:15:11 CEST] <nanoEng> keep ur peter clean
[11:15:22 CEST] <oreWizard> yes
[11:15:37 CEST] <nanoEng> anyway, what happened to the geniuses on here?
[11:15:40 CEST] <oreWizard> the clubs around arent the best place to be in it
[11:15:45 CEST] <nanoEng> i can't even spell geniuses
[11:15:50 CEST] <nanoEng> lets ask google
[11:15:50 CEST] <oreWizard> idk here is 6.0 am
[11:15:58 CEST] <oreWizard> geniuses?
[11:16:01 CEST] <oreWizard> ops
[11:16:17 CEST] <oreWizard> nanoEng
[11:16:19 CEST] <nanoEng> geniuses
[11:16:19 CEST] <oreWizard> greate news
[11:16:26 CEST] <oreWizard> no error again on pkg-config
[11:16:32 CEST] <nanoEng> ta da! you win
[11:16:36 CEST] <oreWizard> sucessful msys2 download
[11:16:40 CEST] <oreWizard> thx man!
[11:16:41 CEST] <nanoEng> hey, i win too! i'm also a genius!
[11:16:50 CEST] <oreWizard> cool we can be 40 now
[11:17:06 CEST] <nanoEng> lol
[11:17:24 CEST] <nanoEng> ah, the msys/pkg-config  thing worked?
[11:17:42 CEST] <oreWizard> pacman -S pkg-config
[11:17:48 CEST] <nanoEng> ?
[11:17:56 CEST] <nanoEng> oh you don't need the part in front? hmm
[11:17:57 CEST] <oreWizard> pacman -S msys/pkg-config
[11:18:04 CEST] <nanoEng> ah.
[11:18:05 CEST] <nanoEng> yeah
[11:18:11 CEST] <nanoEng> with msys
[11:18:29 CEST] <oreWizard> nanoEng thank you again, i going out for breakfest
[11:18:32 CEST] <oreWizard> see you later
[11:18:35 CEST] <nanoEng> not   mingw64/mingw-w64.blahblabh
[11:18:43 CEST] <nanoEng> ok c ya man
[11:18:57 CEST] <nanoEng> glad i could help
[11:20:26 CEST] <nanoEng> BtbN you wouldn't happen to know how to get MSYS to say     SDL          yes                        in that list you get after doing ./config [blahblah]       would you?
[11:20:35 CEST] <nanoEng> MSYS2 that is.
[11:21:25 CEST] <BtbN> I have no idea about the various linux-simulators that are available for windows.
[11:22:08 CEST] <nanoEng> various?
[11:22:21 CEST] <BtbN> i can think of at least 5 right away.
[11:22:23 CEST] <nanoEng> mingw and msys are the defacto
[11:22:29 CEST] <nanoEng> i thought anyway
[11:22:32 CEST] <BtbN> mingw, msys, msys2, cygwin, ...
[11:22:37 CEST] <nanoEng> yeah
[11:22:43 CEST] <nanoEng> those are all releated to each other
[11:22:47 CEST] <nanoEng> first was cygwin
[11:22:53 CEST] <nanoEng> then mingw was an offshoot of that
[11:23:04 CEST] <nanoEng> i forgot how msys comes into the picture
[11:23:49 CEST] <nanoEng> and then msys2 was to integrate 64bit capability, and rewrite the headers or something-arother, better less pain in the ass than regular msys
[11:24:06 CEST] <nanoEng> the end.
[11:24:46 CEST] <nanoEng> so i decided to try and use the less-pain-in-the-butt one, msys2, the latest and greatest.
[11:24:58 CEST] <nanoEng> seemed like it would have the smallest learning-curve
[11:25:31 CEST] <nanoEng> unfortunatly, being newest, it has the least documentation/stack-overflow posts.
[11:27:49 CEST] <nanoEng> However, i wanted to build a 64bit build of ffplay
[11:28:31 CEST] <nanoEng> so i went with msys2 since it uses mingw-w64.
[11:28:51 CEST] <nanoEng> And besides that's the FFmpeg website says to use.
[11:29:18 CEST] <nanoEng> And then the FFmpeg website says to:  In order to compile FFplay, you must have the MinGW development library of SDL and pkg-config installed.
[11:29:54 CEST] <nanoEng> But doesn't tell you how to install that, even though the link above that tells you explicitly how to get msys/mingw-w64  up and running.
[11:30:20 CEST] <nanoEng> then they just give you a link to libsdl.org and that's it.
[11:30:22 CEST] <BtbN> How to install stuff just changes way too frequently. It's not the job of ffmpeg to document how to use your package manager.
[11:30:45 CEST] <eightfold> howdy
[11:30:50 CEST] <nanoEng> Its not mine
[11:31:00 CEST] <nanoEng> its the one THEY told me to use.
[11:31:18 CEST] <eightfold> i have a ts file that should contain an AAC stream and an H.264 stream according to ffprobe
[11:31:42 CEST] <eightfold> i want to put the data in a MKV container instead, mostly because VLC wont play the TS
[11:32:19 CEST] <eightfold> so i use:
[11:32:22 CEST] <eightfold> ffmpeg -i input.ts -vcodec copy -acodec copy -f matroska output.mkv
[11:32:55 CEST] <eightfold> however, with that i get error messages (although the file converts)
[11:32:55 CEST] <BtbN> replace the middle with -c copy, those options are deprecated.
[11:33:17 CEST] <BtbN> you also don't need -f, the .mkv extension is enough.
[11:33:52 CEST] <nanoEng> let me guess.... lack of good documentation...
[11:33:59 CEST] <eightfold> heres the output: https://gist.github.com/anonymous/46903af82d569ae20c7d
[11:34:04 CEST] <nanoEng> ... or any..
[11:34:05 CEST] <eightfold> BtbN: ok!
[11:34:19 CEST] <BtbN> No just tons of years of outdated examples everywhere on the internet.
[11:34:43 CEST] <nanoEng> exactly, which no one would look at, if there was good documentation too look at instread.
[11:34:54 CEST] <nanoEng> why are people even looking at all those outdated examples?
[11:35:01 CEST] <nanoEng> Because there's nothing else to look at!
[11:35:02 CEST] <BtbN> Because google lists them first.
[11:35:07 CEST] <eightfold> so both vcodec and acodec should be replaced with -c copy?
[11:35:18 CEST] <BtbN> -c copy is enough
[11:35:30 CEST] <BtbN> it matches all streams
[11:35:36 CEST] <eightfold> Error parsing AAC extradata, unable to determine samplerate.
[11:35:53 CEST] <BtbN> Your file is propably corrupted then
[11:35:57 CEST] <eightfold> ffprobe shows 94 kb/s
[11:36:00 CEST] <BtbN> try increasing the analyze duration
[11:36:08 CEST] <eightfold> i dont think its corrupt
[11:36:22 CEST] <eightfold> every file that this program outputs gets the same message
[11:36:33 CEST] <eightfold> of course every file could be corrupt, but what do i know
[11:36:57 CEST] <eightfold> ffprobe shows: Audio: aac ([15][0][0][0] / 0x000F), 48000 Hz, stereo, fltp, 94 kb/s
[11:36:58 CEST] <eightfold> to be exact
[11:37:26 CEST] <nanoEng> is there a way to test for corruption?
[11:37:51 CEST] <eightfold> what is a good length for -analyzeduration to try?
[11:38:53 CEST] <BtbN> just try something very high first, and if it works, reduce it step by step
[11:39:11 CEST] <BtbN> It's in microseconds iirc., so it needs big numbers
[11:39:11 CEST] <eightfold> -analyzeduration 1000000000
[11:39:25 CEST] <eightfold> sitll [matroska @ 0x7f9af4806000] Error parsing AAC extradata, unable to determine samplerate
[11:39:42 CEST] <nanoEng> And if that doesn't work, do a Fourier transform on it.
[11:40:00 CEST] <BtbN> Almost looks like the aac extradata is ineeded corrupted
[11:40:00 CEST] <eightfold> nanoEng: i dont know how to do that
[11:40:16 CEST] <nanoEng> (eightfold neither do i)
[11:40:32 CEST] <BtbN> You could try re-encoding the audio, maybe ffmpeg is able to understand it still
[11:40:34 CEST] <eightfold> BtbN: the file converts/remuxes and audio works
[11:40:35 CEST] <nanoEng> i'm just kidding, ignore me, i don't know i'm talking about
[11:40:45 CEST] <nanoEng> <--sleep deprived
[11:40:54 CEST] <eightfold> i just want to be sure that the audio is not transcoded
[11:40:57 CEST] <eightfold> that is very important to me
[11:41:48 CEST] <nanoEng> transcoded=re-encoded?
[11:41:56 CEST] <eightfold> yes
[11:42:08 CEST] <eightfold> i just want to move the streams into a new container
[11:42:33 CEST] <eightfold> the process takes some time and shows something like this:
[11:42:35 CEST] <eightfold> frame=26587 fps=8859 q=-1.0 size=  363577kB time=00:17:43.46 bitrate=2800.7kbits/s
[11:42:47 CEST] <eightfold> so im a bit afraid its being re-encoded
[11:42:49 CEST] <eightfold> is it?
[11:44:00 CEST] <nanoEng> AviDemux ?
[11:44:35 CEST] <eightfold> not the best on os x i believe
[11:44:56 CEST] <nanoEng> oh :\
[11:45:15 CEST] <nanoEng> and that's why i don't trust apple....
[11:45:44 CEST] <eightfold> also, i have an srt file that id like to get into the MKV in this process
[11:45:47 CEST] <nanoEng> then again, i wouldn't be here if i didn't trust MS either...
[11:45:49 CEST] <eightfold> how would i do that?
[11:46:08 CEST] <nanoEng> you can do that?
[11:46:27 CEST] <eightfold> yeah, i should be able to
[11:46:37 CEST] <eightfold> seems you should specify srt as -i
[11:46:38 CEST] <eightfold> too
[11:46:43 CEST] <eightfold> but that doesnt seem to work
[11:50:07 CEST] <nanoEng> In file included from /usr/include/SDL/SDL_stdinc.h:30:0,                  from /usr/include/SDL/SDL_main.h:26,                  from /usr/include/SDL/SDL.h:30,                  from libavdevice/sdl.c:26: /usr/include/SDL/SDL_config.h:42:32: fatal error: SDL_config_minimal.h: No such file or directory  #include "SDL_config_minimal.h"                                 ^ compilation terminated. common.mak:57: recipe for target 'libavdevic
[11:50:33 CEST] <nanoEng> hmmm, no multi-line, huh?
[11:51:59 CEST] <nanoEng> Anyone understand this? pastebin.com/RjPQ3jMC   ??
[11:52:35 CEST] <nanoEng> error after running  $ make
[11:53:19 CEST] <nanoEng> what happend to link. try again: pastebin.com/RjPQ3jMC
[11:53:25 CEST] <nanoEng> hm...  http://pastebin.com/RjPQ3jMC
[11:53:27 CEST] <nanoEng> there we go
[13:11:29 CEST] <claz> hey, i want to modify the fps of a file and i'm using the setpts filter like so : "ffmpeg -i src.mp4 -vf 'setpts=N/(25*TB)' out.mp4' but my problem is about 3/4 of the frames are dropped
[13:11:35 CEST] <claz> is there any way to not drop frames?
[13:12:59 CEST] <Mavrik> O.o
[13:13:11 CEST] <BtbN> What output fps does ffmpeg think the file is?
[13:13:23 CEST] <BtbN> Maybe it tries to adjust from the 25 you are generating with setpts
[13:15:03 CEST] <claz> googled some more and turns out i need to also use the -r 25 option
[13:15:14 CEST] <claz> otherwise output file has same fps as input
[13:15:19 CEST] <claz> which was 6fps
[13:15:29 CEST] <claz> all good now, thanks :)
[13:15:56 CEST] <BtbN> you also might want to increase the encoding quality, the default is usualy quite bad.
[13:16:17 CEST] <claz> yep, just wanted to see if i can fix the fluidity first
[15:10:28 CEST] <satiender> Hi there have any which is develop ffmpeg for android
[15:11:02 CEST] <satiender> actually I want try to compile ffmpeg for android but there have multiple errors
[15:11:29 CEST] <satiender> So, There have anybody which compile the ffmpeg library for android
[15:11:36 CEST] <satiender> please help
[16:30:02 CEST] <luks> hi, can somebody help me how to set these options when using ffmpeg as a library? https://www.ffmpeg.org/ffmpeg-protocols.html#http
[16:30:23 CEST] <luks> I guess I need to use av_opt_set, but I don't know what object to call it on
[17:12:34 CEST] <Oleg_> I still want to find out why sound eventually disappears from the video that I am trying to encode using these parameters:
[17:13:02 CEST] <Oleg_> ffmpeg -f oss -i /dev/dsp3 -f v4l2 -i /dev/video0 output.mkv
[17:16:17 CEST] <pzich> eventually disappears? like a few days later?
[17:17:18 CEST] <Oleg_> the video has these parameters: http://pastebin.com/ZxR63PmF
[17:18:05 CEST] <Oleg_> pzich, when the video starts, I can hear sound coming from it, but it disappears a few seconds later
[17:19:14 CEST] <pzich> have you tried recording them separately?
[17:20:46 CEST] <Oleg_> pzich, if I do that, how will I be able to put both video and audio into one file and make sure they are in sync with one another?
[17:24:22 CEST] <Oleg_> pzich, these are the encoder settings that are used: http://pastebin.com/V6PUraaN
[17:25:41 CEST] <Oleg_> c_14, sup
[17:25:57 CEST] <prelude2004c> hello everyone. Question. I would like to create a playlist with playout DB. I don't want to loose any time between shows.. Eg... I have a playlist , play 1, play2 play3, etc etc... I want ffmpeg to open play 1 , then play 2, then play 3 but dynamic. Eg.. If someone in the DB changes what comes in after 2 and say go to 4, then after every file it checks whats next and plays what is next. THe only thing is.. i dont want to have any delay be
[17:26:08 CEST] <prelude2004c> millisecond... i dont want to start loosing time
[17:26:54 CEST] <prelude2004c> any ideas on what tis the best approach ? eg.. is there some way to have ffmpeg pickup a file... load it get ready to play and only play file at the exact moment the other file ends ? I am going to be outputing to UDP so i dont want to loose any frames between one file to another
[17:37:54 CEST] <prelude2004c> anyone?
[18:15:51 CEST] <Oleg_> please help!!!!
[18:21:19 CEST] <jasom> ffmpeg 2.9.3 on gentoo, I get messages like: frame=258747 fps=162 q=23.0 size=  474149kB time=02:23:52.45 bitrate= 450.0kbits[Parsed_overlay_0 @ 0x25ba530] [framesync @ 0x22c9a68] Buffer queue overflow, dropping.
[18:21:59 CEST] <jasom> input is from a DVD, so mpeg-2 TS with dvd subs
[18:22:35 CEST] <jasom> There are multiple subtitle streams I want simultaneously displayed so I'm using multiple overlay filters in the filter graph
[18:23:10 CEST] <jasom> sorry should be 2.6.3 not 2.9.3
[18:33:57 CEST] <Oleg_> guys, how do I mux audio and video into one file?
[18:34:24 CEST] <KarlFranz> Which sort of file?
[18:34:31 CEST] <Oleg_> mkv
[18:34:43 CEST] <Oleg_> I want audio and video to be in sync with one another
[18:34:50 CEST] <JEEB> ffmpeg -i video -i audio -c copy out.mkv
[18:34:53 CEST] <JEEB> uhh
[18:35:03 CEST] <JEEB> with more tracks etc you might also want map
[18:35:11 CEST] <JEEB> like -map 0:v and -map 0:a
[18:35:15 CEST] <JEEB> *-map 1:a
[18:36:14 CEST] <Oleg_> JEEB, audio is the name of a file in your example?
[18:37:08 CEST] <JEEB> yes
[18:37:53 CEST] <Oleg_> and will audio and video be in sync in the new file?
[18:43:27 CEST] <jasom> Oleg_: only if they are in sync in the separate files.
[18:49:00 CEST] <Oleg_> JEEB, I need audio and video to be in sync
[18:51:18 CEST] <pzich> if the input files aren't already in sync, you can try following something like http://alien.slackbook.org/blog/fixing-audio-sync-with-ffmpeg/
[18:53:31 CEST] <Oleg_> pzich, if video and audio files are recorded separately, then, of course they will be out of sync
[18:55:03 CEST] <Oleg_> pzich, because they are different in the first place
[18:55:24 CEST] <Oleg_> pzich, I wanna record the video of myself talking using my webcam
[18:58:14 CEST] <Oleg_> please tell me what to do
[19:00:49 CEST] <Oleg_> JEEB?
[19:01:23 CEST] <Oleg_> is there something wrong with this command:
[19:01:26 CEST] <Oleg_> ffmpeg -f oss -i /dev/dsp3 -f v4l2 -i /dev/video0 output.mkv
[19:01:27 CEST] <Oleg_> ?
[19:06:22 CEST] <Oleg_> HELLO!!!!
[19:26:12 CEST] <phr3ak> how could I play audio file on text console?
[19:27:00 CEST] <iive> try -vn option
[19:28:25 CEST] <phr3ak> I tried already
[19:28:29 CEST] <phr3ak> Could not initialize SDL - No available video device
[19:28:29 CEST] <phr3ak> (Did you set the DISPLAY variable?)
[19:29:04 CEST] <phr3ak> I tried with ffplay
[19:29:57 CEST] <llogan> ffmpeg -i INPUT -f alsa default
[19:30:00 CEST] <phr3ak> thanks
[19:30:09 CEST] <phr3ak> ffmpeg -i V0099601.wav -vn -f alsa hw:0
[19:30:22 CEST] <phr3ak> default is also good thanks
[19:31:29 CEST] <phr3ak> is it possible to seek in the audio with keyboard?
[19:31:47 CEST] <llogan> im not sure. give it a try
[19:32:01 CEST] <llogan> i doubt it though
[19:32:32 CEST] <llogan> nevermind, i was thinking you were using ffplay, although i just gave a ffmpeg command
[19:33:46 CEST] <llogan> or you could try ffplay with -nodisp
[19:39:59 CEST] <Oleg_> phr3ak, /dev/dsp3 corresponds to what alsa node?
[19:40:25 CEST] <Oleg_> phr3ak, maybe with alsa, I won't have sound issues?
[19:43:14 CEST] <Oleg_> people!!!
[19:43:25 CEST] <Oleg_> -f oss -i /dev/dsp3 corresponds to what alsa node?
[19:43:33 CEST] <Oleg_> hw:3,3?
[19:43:34 CEST] <Oleg_> or what?
[19:45:11 CEST] <Oleg_> PEOPLE!!!!
[19:48:56 CEST] <Mavrik> Oleg_, stop yelling.
[19:49:07 CEST] <Mavrik> OSS and ALSA nodes don't correspond.
[19:49:24 CEST] <Mavrik> So you'll have to use alsa tools to figure out which input is the one you're looking for.
[19:50:19 CEST] <Oleg_> Mavrik, do you see anything that might cause issues if I execute this command:
[19:50:33 CEST] <Oleg_> ffmpeg -f oss -i /dev/dsp3 -f v4l2 -i /dev/video0 output.mkv
[19:50:57 CEST] <Mavrik> You're not setting codecs or quality.
[19:51:04 CEST] <Mavrik> Also not sure if OSS still works on modern distros?
[19:51:36 CEST] <Oleg_> Marvik: please tell me how to set codecs and quality
[20:19:04 CEST] <Oleg_> so, I uploaded this video: https://www.youtube.com/watch?v=Ye3FLXMKv1U , so you would be able to see what kind of problems I have with the sound
[20:19:52 CEST] <Oleg_> as you can see, the sound is either absent or not absent from the video
[20:20:01 CEST] <Oleg_> any idea what causes this issue?
[20:20:27 CEST] <Oleg_> as I said, this video was recorded with the command: "ffmpeg -f v4l2 -i /dev/video0 -f oss -i /dev/dsp3 output.mkv
[20:20:29 CEST] <Oleg_> "
[20:21:31 CEST] <Oleg_> folks?
[20:23:14 CEST] <Oleg_> Mavrik, can you take a look at this please: https://www.youtube.com/watch?v=Ye3FLXMKv1U ?
[20:28:01 CEST] <Oleg_> FOLKS!!!!
[20:29:40 CEST] <durandal_170> what you use for audio recording?
[20:30:28 CEST] <Oleg_> durandal_170, the microphone which is inside the webcam
[20:31:27 CEST] <durandal_170> and why you use oss?
[20:32:11 CEST] <Oleg_> durandal_170, you think that if I try using alsa, it might fix this problem?
[20:33:04 CEST] <durandal_170> dunno
[20:47:25 CEST] <Fjorgynn> :D
[23:26:51 CEST] <tonsofpcs> who should I report GPL violations (against ffmpeg) to?
[23:29:37 CEST] <KarlFranz> Hasn't the project's site a contact link?
[23:30:14 CEST] <tonsofpcs> I suppose the proper legal response is "I can't say for sure since the package I received did not include any license or contact information"
[23:32:23 CEST] <tonsofpcs> amyway, the contact page on the site just points to mailing lists and IRC
[23:36:02 CEST] <KarlFranz> I was checking that
[23:37:49 CEST] <KarlFranz> I suppose you could check who is the copyright holder in the license, if you have it.
[23:37:52 CEST] Action: KarlFranz checks
[23:38:42 CEST] <KarlFranz> I gpt something.
[23:38:54 CEST] <c_14> tonsofpcs: you can report license violations on trac
[23:39:06 CEST] <tonsofpcs> c_14: is trac public postable or do accounts need auth?
[23:39:25 CEST] <llogan> you need to register to make a bug report
[23:39:34 CEST] <llogan> but tickets are public visable
[23:40:06 CEST] <KarlFranz> It does not look very discrete to me.
[23:40:18 CEST] <KarlFranz> There is a document with the list of maintainers
[23:40:36 CEST] <llogan> https://trac.ffmpeg.org/query?status=new&status=open&status=reopened&type=license+violation&col=id&col=summary&col=status&col=type&col=priority&col=component&col=version&order=priority
[23:40:42 CEST] <KarlFranz> And I found a list of gpg fingerprints for maintainers and contributors. I suppose you could get the keys and look at the addresses.-
[23:40:50 CEST] <tonsofpcs> oh, I could directly e-mail most of the maintainers but I don't know if maybe someone is nominally handling them
[23:41:06 CEST] <llogan> making a bug report is the best method
[23:41:34 CEST] <llogan> allows potential follow-up by the violator and the public shame is a good motivator
[23:41:39 CEST] <KarlFranz> There is a communication team.
[23:41:52 CEST] <KarlFranz> But yes, if you don t need secrecy, a bug report is probably better
[23:42:06 CEST] <tonsofpcs> llogan: generally you don't publicly shame someone unless they've been given a chance to rectify in private first...
[23:42:17 CEST] <Nolski> ^
[23:42:20 CEST] <Nolski> Agreed
[23:42:58 CEST] <Nolski> The Software Freedom Concervancy worked with VMware for 4 years before going public about the GPL violation
[23:42:59 CEST] <KarlFranz> Alexander Strasser, Michael Niedermayer, Carl Eugen Hoyos, Lou Logan <- Trac communication team.
[23:43:00 CEST] <llogan> then feel free to contact the violator and do it yourself
[23:43:08 CEST] <llogan> privately
[23:43:20 CEST] <KarlFranz> https://paste.debian.net/297544/ <- List of gpg keys
[23:43:27 CEST] <KarlFranz> I'd say that should suffice.
[23:43:50 CEST] <llogan> if you email me then i'll tell you to post it on trac.
[23:44:07 CEST] <tonsofpcs> KarlFranz: llogan is right here...
[23:44:20 CEST] <KarlFranz> heh, ok
[23:45:05 CEST] <llogan> if they violate then they can be listed. it's that simple. if they fix the issue (often it is simple misunderstanding) then it can get fixed.
[23:47:08 CEST] <llogan> if you prefer to pursue it via private communication between yourself and the violator then feel free to do so
[00:00:00 CEST] --- Wed Aug 19 2015

More information about the Ffmpeg-devel-irc mailing list