[Ffmpeg-devel-irc] ffmpeg.log.20150819

burek burek021 at gmail.com
Thu Aug 20 02:05:01 CEST 2015

[00:13:41 CEST] <TikityTik> What's the point of deinterlacing?
[00:14:38 CEST] <KarlFranz> Progressive video looks better on some screens.
[00:14:57 CEST] <KarlFranz> non-progressive supposedly looks better on some TV sets.
[00:15:56 CEST] <KarlFranz> When I am playing non progressive on my computer, I run a deinterlacing filter at playback time. I don t encode for appying deinterlacing
[00:19:13 CEST] <DHE> eyes want to see progressive. only use interlacing if going to an interlacing-aware device (eg: television)
[00:29:08 CEST] <TikityTik> KarlFranz: why on TV sets?
[00:29:16 CEST] <TikityTik> Aren't TV sets basically like PC monitors now?
[00:33:14 CEST] <KarlFranz> That is why I didn't say every TV set :-)
[00:33:37 CEST] <KarlFranz> My own sets are old and I don  watch TV, actually.
[00:34:07 CEST] <KarlFranz> I am dettached of the current state of thinngs with TV technology
[01:34:01 CEST] <jasom> ffmpeg 2.6.3 on gentoo, dvd source, overlaying subitles, I get messages like: frame=258747 fps=162 q=23.0 size=  474149kB time=02:23:52.45 bitrate= 450.0kbits[Parsed_overlay_0 @ 0x25ba530] [framesync @ 0x22c9a68] Buffer queue overflow, dropping.
[02:11:29 CEST] <nanoEng> Can anyone help me with a compile error?
[02:13:00 CEST] <nanoEng> http://pastebin.com/RYYpeCqU
[02:18:44 CEST] <deivor> Hi, I'd like to know if there's any way to set the 'strength' of the highpass/lowpass audio filters. Audacity has this feature and I have to use audacity only for that some times
[02:19:01 CEST] <llogan> nanoEng: how do we reproduce the issue?
[02:24:51 CEST] <deivor> I meant "rolloff" not strength
[02:27:30 CEST] <nanoEng> Anyone know how I can enable 64bit compile? I keep getting http://pastebin.com/RYYpeCqU
[02:30:35 CEST] <llogan> nanoEng: how can we reproduce the issue?
[02:30:59 CEST] <nanoEng> compiling using windows 8.1,
[02:31:12 CEST] <nanoEng> ./configure --host-os=x86_64 --enable-sdl --disable-programs --disable-encoders --enable-ffplay --disable-d3d11va --disable-dxva2 --arch=x86_64 --disable-shared --target-os=win32 --enable-static --disable-doc --prefix=TEST2 --disable-ffmpeg --disable-ffprobe --disable-ffserver --disable-network --enable-gpl --enable-swscale --enable-memalign-hack --enable-yasm --disable-mmx --disable-mmxext
[02:31:27 CEST] <nanoEng> using MSYS2 and mingw-w64
[02:31:33 CEST] <deivor> do you need host-os / arch if compiling native?
[02:31:48 CEST] Action: llogan becomes comatose at mention of "windows 8.1"
[02:31:59 CEST] <nanoEng> yeah, so do i
[02:32:35 CEST] <nanoEng> I get ARCH=x86 (general)
[02:32:40 CEST] <nanoEng> after ./configure
[02:32:57 CEST] <nanoEng> i am now thinking my problem is --target-os=win32
[02:33:16 CEST] <nanoEng> but there's no such thing as --target-os=win64
[02:35:14 CEST] <nanoEng> I must include --tagrget-os
[02:35:35 CEST] <nanoEng> If I do not, I get      Unknown OS 'msys_nt-6.3'.
[02:37:14 CEST] <nanoEng> If you think configure made a mistake, make sure you are using the latest version from Git.  If the latest version fails, report the problem to the ffmpeg-user at ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net. Include the log file "config.log" produced by configure as this will help solve the problem.
[02:37:45 CEST] <nanoEng> would you like the config.log ?
[02:47:15 CEST] <c_14> nanoEng: Have you tried the zeranoe forums? There might be someone there who has experience compiling for Windows 8.1
[02:52:15 CEST] <nanoEng> c_14 zeranoe is useless, that is for compiling for Windows, but using Debian.
[02:54:27 CEST] <c_14> Have you tried asking on the user mailing list?
[02:54:32 CEST] <c_14> Might reach someone that way.
[02:57:47 CEST] <nanoEng> hmm
[02:58:35 CEST] <nanoEng> alright c_14, thanks
[02:58:44 CEST] <nanoEng> i'll keep checking here and see about the mailing list
[03:12:05 CEST] <occupant> so I tried compiling with static x264 and it complains about a missing .so when I execute, which seems to defeat the purpose of having it statically compiled. I'm guessing I did something wrong?
[03:12:28 CEST] <c_14> Which .so is missing?
[03:12:37 CEST] <occupant> even though I'm on the same box where I built it, so it should know where to find the path regardless
[03:12:48 CEST] <c_14> What was your configure line?
[03:13:24 CEST] <occupant> libx264.so.148, used --enable-libx264 and --pkg-config-flags=--static
[03:14:05 CEST] <c_14> --enable-static --disable-shared
[03:15:12 CEST] <occupant> ah crap, I did not do --enable-static
[03:15:19 CEST] <occupant> did do --disable-shared though
[03:30:35 CEST] <occupant> c_14: still complaining of missing .so. my full config: --enable-runtime-cpudetect --enable-static --disable-debug --disable-ffserver --disable-ffplay --disable-shared --enable-libfaac --enable-libmp3lame --enable-libx264 --enable-libxvid --enable-gpl --enable-nonfree --pkg-config-flags=--static
[03:31:18 CEST] <occupant> whoah, how did --enable-gpl creep in there
[03:31:58 CEST] <llogan> because you wanted libx264
[03:32:58 CEST] <occupant> so I'm guessing I still got some option wrong relating to static
[03:40:12 CEST] <c_14> Do you have a libx264.a?
[03:42:08 CEST] <occupant> yeah I made it from source just now, but it doesn't seem like it's being baked into the build properly.
[03:42:20 CEST] <occupant> the configure script found it and built against it
[03:42:27 CEST] <c_14> Where is it?
[03:42:46 CEST] <occupant> /usr/local/lib
[03:43:14 CEST] <c_14> Is that in your PKG_CONFIG_PATH ?
[03:43:31 CEST] <c_14> Well, /usr/local/lib/pkgconfig in that case
[03:47:32 CEST] <occupant> yeah, there's a pc file for it
[03:47:45 CEST] <c_14> Yes, but is it in your PKG_CONFIG_PATH ?
[03:48:00 CEST] <c_14> export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/lib/pkgconfig
[03:48:18 CEST] <c_14> The other order might be better though
[03:49:37 CEST] <c_14> This is under the assumption that you have another x264.pc file flying around somewhere
[03:51:33 CEST] <occupant> it isn't, but the fact that the binary knows about the specfic revision of the .so makes me think it found it okay, but that's not an environment variable I'm used to twiddling.
[03:52:05 CEST] <c_14> It just tells pkg-config where to look for .pc files
[03:53:00 CEST] <occupant> and didn't the .pc file tell it about the specific .so.148?
[03:53:11 CEST] <occupant> so the fact that it's complaining about its absence means that it was initially found
[03:53:59 CEST] <occupant> maybe I'm entirely misunderstanding this though
[03:59:30 CEST] <c_14> I'm pretty sure pkg-config doesn't set the rpath, so even if it links it could still fail on runtime because the so isn't in one of the default paths
[04:00:58 CEST] <c_14> Or rather, isn't used to set the rpath. It can't set it itself.
[04:06:05 CEST] <occupant> yeah, if I set my ld_library_path to include /usr/local/lib and run ldconfig, it works fine. so the problem is that it's never being statically linked to begin with
[04:06:36 CEST] <c_14> Well, if it were statically linked it wouldn't ask for a .so
[04:08:02 CEST] <occupant> yeah that IS entirely sensible, but why wasn't it? I had static options in my config but apparently I didn't do 'em right.
[04:16:58 CEST] <c_14> What does pkg-config --static --libs --cflags x264 output?
[04:34:30 CEST] <occupant> c_14: alright, I shouldn't have doubted when I didn't really understand. I thought that configure picking up the location meant everything was good, but pkg_config_path was indeed necessary. binary is fully portable. thanks for the nudge.
[05:43:25 CEST] <k_sze> Would somebody be explain to me what's the deal with YUVJ vs YUV?
[05:43:35 CEST] <k_sze> *be able to
[05:44:48 CEST] <k_sze> I have some video files on hand with yuvj422p pixel format. When I decode using PyAV (a wrapper over the ffmpeg libraries in Python), I get a deprecated pixel format warning.
[05:48:32 CEST] <haole> my ffmpeg install says that the filter "mp" doesn't exist... I wanted to increase the brightness with -vf mp=eq2=1:1:0.3:1:1:1:1
[05:48:36 CEST] <haole> what dependency am I missing?
[05:52:26 CEST] <c_14> haole: the mp filters were all ported recently. the filter you want is now called 'eq'
[05:55:21 CEST] <haole> c_14: thanks
[05:56:33 CEST] <haole> c_14: do you know how to do a passthrough with the audio? don't want to lose time transcoding it
[05:56:38 CEST] <c_14> -c:a copy
[05:56:49 CEST] <haole> or is this already happening:   Stream #0:1 -> #0:1 (aac (native) -> aac (libfaac))
[05:56:54 CEST] <haole> thanks
[05:56:55 CEST] <c_14> No, that's reencoding.
[05:57:01 CEST] <c_14> It'll say copy if it's copying it
[05:57:53 CEST] <haole> I want to increase the brightness, but it's so slow for x264
[05:57:54 CEST] <haole>   Stream #0:0 -> #0:0 (h264 (native) -> h264 (libx264))
[05:58:07 CEST] <c_14> -preset ultrafast
[05:58:09 CEST] <haole> is there a way to make this faster? or my computer simply sucks for this? :D
[05:58:11 CEST] <haole> ha!
[05:58:14 CEST] <haole> :)
[05:58:18 CEST] <c_14> (there's also veryfast and faster)
[05:58:33 CEST] <c_14> Note, with crf encoding (the default) they will make the output bigger
[05:59:03 CEST] <haole> sweet! 5x speed boost
[05:59:06 CEST] <haole> thanks a lot :)
[05:59:33 CEST] <haole> chromecast is stupid, so I'm making some scripts to automagically convert my files to play in my TV and look good
[06:00:02 CEST] <haole> chromecast usually gets very dark there and increasing the TV brightness will give me "gray" areas instead of black ones
[06:00:07 CEST] <haole> must be related to gamma, don't know
[06:01:04 CEST] <c_14> k_sze: yuvj is full-range yuv (ie 0-255), while yuv is limited range (16-240 iirc). The deprecation message occurs afaik because the "yuvj*" formats were deprecated in favor of "yuv*" with color_range jpeg
[06:03:29 CEST] <c_14> haole: I don't know much about chromecast, but that shouldn't happen. Unless the colors on your TV are weird
[06:03:43 CEST] <buu> What would be the correct set of options to force keyframes every 2 seconds?
[06:04:56 CEST] <c_14> Either -g [fps * 2] (the preferred method) or -force_key_frames expr:gte(t,n_forced*2)
[06:05:27 CEST] <buu> Oh
[06:05:31 CEST] <buu> Is that actually in the man page?
[06:05:52 CEST] <c_14> yes
[06:06:33 CEST] <buu> it totally isn't!
[06:06:37 CEST] <buu> I just checked, there's no -g option
[06:07:13 CEST] <buu> It's mentioned in a couple of examples
[06:07:23 CEST] <pzich> yeah, look at tips
[06:07:59 CEST] <buu> That's not really documented
[06:08:16 CEST] <buu> Anyway, what if the fps is like, 29.whatever
[06:08:32 CEST] <pzich> then pass in 30000/1001
[06:08:52 CEST] <buu> !
[06:09:10 CEST] <buu> -g expr:3000.. ?
[06:10:13 CEST] <c_14> buu: https://www.ffmpeg.org/ffmpeg-codecs.html#libx264_002c-libx264rgb
[06:10:39 CEST] <c_14> The third option listed there under options
[06:12:10 CEST] <c_14> The gop is always codec specific so it'll be lited under the options for the specific codec.
[06:12:16 CEST] <c_14> *listed
[06:12:53 CEST] <buu> Nifty
[06:46:13 CEST] <FunkyELF> where can I get static builds?  I thought there used to be a link from the ffmpeg.org site
[07:01:14 CEST] <relaxed> FunkyELF: there still is, http://johnvansickle.com/ffmpeg/
[07:01:44 CEST] <relaxed> (or mouse over your OS)
[07:01:54 CEST] <FunkyELF> relaxed: yeah... I guess it was a little better before when ffmpeg linked there.  Now its just some guy's website with binaries to download
[07:03:07 CEST] <relaxed> I'm that some guy. How was it better in the past?
[07:05:03 CEST] <pzich> I think I've used those before, thanks!
[11:21:41 CEST] <qFox> hi. is there a trick to merging two audio tracks at different volumes? whatever I  try it seems the result has the same volume.
[11:22:11 CEST] <qFox> i've tried pan=stereo|c0=c0*0.1+c2|... when amerge or amixing but that doesn't seem to help
[11:22:24 CEST] <qFox> i've tried applying individual volume filters, same result
[11:23:54 CEST] <qFox> i was getting to that :) https://gist.github.com/qfox/9951355d38da548136ee
[11:23:55 CEST] <c_14> (for the record I've had it work with volume filters followed by amix)
[11:24:31 CEST] <qFox> well it seems whatever i try, the end result has the same volume levels
[11:24:45 CEST] <qFox> so i'm very likely to be missing a key element in the process :)
[11:28:25 CEST] <c_14> works for me
[11:28:31 CEST] <c_14> What version of ffmpeg are you using?
[11:28:47 CEST] <qFox> ultimately the whole thing was one mkv to start with. it has a video track and three audio tracks; 0=everything, 1=background only, 2=microphone only. i'm trying to produce a new mkv with a single audio track and specific volume levels of the second and third audio track, something like this: https://gist.github.com/qfox/37a7f36e60bd8d7e8f82
[11:29:01 CEST] <qFox> ffmpeg version 2.5.8-0ubuntu0.15.04.1
[11:29:24 CEST] <c_14> update
[11:29:26 CEST] <c_14> preferably to git
[11:29:32 CEST] <qFox> oh :/
[11:29:32 CEST] <c_14> You can use a static build to try
[11:29:34 CEST] <c_14> http://johnvansickle.com/ffmpeg/
[11:32:23 CEST] <qFox> ok. no change in the mkv (the last gist)
[11:32:35 CEST] <qFox> trying the mp3 only one
[11:33:29 CEST] <qFox> same. meh
[11:34:49 CEST] <c_14> hmm, I tried with flac instead of mp3, but that shouldn't be it
[11:38:36 CEST] <qFox> may have found the problem. for some reason this video also had the background recorded into the mic track
[11:39:12 CEST] <qFox> well either that or I messed it up in post processing somehow. regardless, that would explain a lot for me.
[11:40:06 CEST] <c_14> It works now?
[11:40:31 CEST] <qFox> and the video recorded after this one also has that "problem". must have screwed something up in the recording software config.
[11:40:43 CEST] <qFox> well it wont work on that file since i no longer have a mic-only track
[11:41:08 CEST] <c_14> You can test with this command: ffmpeg -f lavfi -i aevalsrc="sin(440*2*PI*t):s=48000:c=stereo" -f lavfi -i aevalsrc="sin(800*2*PI*t):s=48000:c=stereo" -filter_complex '[0][1]amerge,pan=stereo|c0=0.1*c0+c2|c1=0.1*c1+c3' -t 10 out.flac
[11:41:10 CEST] <qFox> i was under the assumption i had a background-only and a mic-only track, as most of my videos do.
[11:41:14 CEST] <c_14> to rule out any file-specific issues
[11:41:46 CEST] <qFox> thanks
[11:42:14 CEST] <c_14> (note, sine waves are very annoying)
[11:42:23 CEST] <qFox> yep
[11:43:25 CEST] <qFox> meh. recording software is indeed set to record the background music into all tracks. probably a default setting it used when switching audio inputs. well that blows :/
[11:43:51 CEST] <qFox> anyways. guess it can't be helped for this video. thanks for the help :)
[11:44:14 CEST] <c_14> np
[12:27:25 CEST] <satiender> Hi how we can use ffmpeg for android OS
[12:27:31 CEST] <satiender> please help ??
[14:35:05 CEST] <satiender> hi anybody compile ffmpeg for android
[17:08:14 CEST] <barbek> Hi guys! I'm trying to create desktop streaming solution on Wondiws using ffmpeg and Qt. I've managed to make it using ffmpeg and ffplay commands  http://pastebin.com/aVRQJEdQ .
[17:09:20 CEST] <barbek> I have few question: 1. what output formats I can choose or where can I find this info? I tried to use matroska instead of mpegts but ffplay doesn't play that. I fairly new to ffmpeg so my question might sound silly.
[17:10:23 CEST] <barbek> 2. How can I change grabbing quality? Currently it looks awful at full-screen resolution and I don't know why
[17:11:51 CEST] <barbek> 3. ffplay start to play stream from the moment stream was launched, to from the moment ffplay was launched. Looks like ffmpeg has internal queue - how can I disable it in order to play see only live image?
[17:19:39 CEST] <Oleg_> c_14, are you there?
[17:51:26 CEST] <tab1293> Can anyone explain what the read, write, and seek callback functions are supposed to do in avio_alloc_context http://ffmpeg.org/doxygen/trunk/avio_8h.html#a853f5149136a27ffba3207d8520172a5
[18:42:35 CEST] <klaxa> tab1293: those are functions called by avio_read/write/seek
[18:53:41 CEST] <Laurenceb> hi
[18:53:53 CEST] <Laurenceb> how can i extract all frames over a specific timerange?
[18:54:10 CEST] <Laurenceb> ffmpeg -i GOPR0080.MP4 -r 240 -f image2 -ss 9 image%d.jpg
[18:54:14 CEST] <Laurenceb> this is failing
[18:54:16 CEST] <Laurenceb> no outpuit
[19:02:04 CEST] <klaxa> try moving -ss before -f image2
[19:03:49 CEST] <Laurenceb> aha thanks
[23:24:05 CEST] <newtoFFmpeg> hello
[23:25:33 CEST] <newtoFFmpeg> Hello All,
[23:27:27 CEST] <newtoFFmpeg> ffserver allows delivering content using http and rtsp. I want to know if this means client is streaming or progressively downloading the media. Can someone elaborate?
[23:39:40 CEST] <newtoFFmpeg> Another question, does ffserver support adaptive streaming?
[00:00:00 CEST] --- Thu Aug 20 2015

More information about the Ffmpeg-devel-irc mailing list