[Ffmpeg-devel-irc] ffmpeg.log.20150820

burek burek021 at gmail.com
Fri Aug 21 02:05:01 CEST 2015

[01:21:48 CEST] <nanoEng> Can someone help me with an error I am getting while trying to compile FFmpeg?      http://pastebin.com/BF2Pv5Gk
[01:22:12 CEST] <nanoEng> It occurs when doing the  make  command
[01:22:48 CEST] <nanoEng> For my configure, I am using:
[01:22:51 CEST] <nanoEng> ./configure --target-os=win64 --enable-sdl --disable-programs --disable-encoders --enable-ffplay --disable-d3d11va --disable-dxva2 --disable-shared --enable-static --disable-doc --prefix=TEST2 --disable-ffmpeg --disable-ffprobe --disable-ffserver --disable-network --enable-gpl --enable-swscale --enable-memalign-hack --enable-yasm --disable-mmx --disable-mmxext
[01:23:45 CEST] <nanoEng> Am I to understand this is a problem with YASM?
[01:54:44 CEST] <nanoEng> can someone tell me why I am getting this error on compile: http://pastebin.com/BF2Pv5Gk  ??
[01:57:45 CEST] <nanoEng> ./configure --target-os=win64 --enable-sdl --disable-programs --disable-encoders --enable-ffplay --disable-d3d11va --disable-dxva2 --disable-shared --enable-static --disable-doc --prefix=TEST2 --disable-ffmpeg --disable-ffprobe --disable-ffserver --disable-network --enable-gpl --enable-swscale --enable-memalign-hack --enable-yasm --disable-mmx --disable-mmxext
[01:58:13 CEST] <nanoEng> says that                 arch          x86 (general)           ????
[01:58:51 CEST] <nanoEng> after running ./configure
[01:59:12 CEST] <nanoEng> yet when i type   arch   it says  x86_64
[01:59:28 CEST] <nanoEng> so why when i try to build does it set it to x86 ?
[02:00:03 CEST] <nanoEng> hence why i get error        libavfilter/x86/af_volume.asm:45: warning: `rdx' is a register in 64-bit mode        ???
[02:00:18 CEST] <nanoEng> Or is something else the cause of the error?
[02:00:47 CEST] <nanoEng> The error occurs after  the outputline:   YASM    libavfilter/x86/af_volume.o
[02:01:31 CEST] <klaxa> wow that's quite the error
[02:01:49 CEST] <klaxa> sorry, but i have no idea about that
[02:02:14 CEST] <nanoEng> :(
[02:02:21 CEST] <nanoEng> damnit
[02:03:31 CEST] <relaxed> the error is from undefined symbols, but you can try disabling that filter to see if it will compile without it
[02:04:00 CEST] <nanoEng> how do i disable it?
[02:04:20 CEST] <nanoEng> Is it indeed coming from yasm, hence --disable-yasm
[02:04:23 CEST] <nanoEng> ?
[02:05:00 CEST] <relaxed> --disable-filter=volume
[02:05:01 CEST] <nanoEng> I'll try it right now with that
[02:05:04 CEST] <nanoEng> oh...
[02:05:18 CEST] <nanoEng> and leave yasm alone then?
[02:05:34 CEST] <relaxed> yes, unless you want super slow decoding
[02:05:53 CEST] <nanoEng> ah, ok
[02:06:05 CEST] <relaxed> maybe you should state what you're trying to achieve
[02:06:09 CEST] <nanoEng> its just that i read here http://gopherproxy.meulie.net/sdf.org/0/users/wisdomc0/article_assembly/assembly_style_for_64_bit_architecture
[02:06:19 CEST] <nanoEng> i'm just trying to compile ffplay
[02:06:29 CEST] <nanoEng> 64bit
[02:07:02 CEST] <relaxed> you can download ffplay builds from http://ffmpeg.zeranoe.com/builds/
[02:07:40 CEST] <nanoEng> on that site, it says  "some of 64 bit registers are:  - rdx (edx)    - rsi (esi)  , ..."
[02:07:48 CEST] <nanoEng> so i thought the error had to do with yasm.
[02:08:17 CEST] <relaxed> could be
[02:08:51 CEST] <nanoEng> i'm trying    make  right now with --disable-yasm
[02:09:05 CEST] <nanoEng> after that fails to solve the problem, i'll try it with   --disable-filter=volume   as you suggested
[02:10:11 CEST] <relaxed> I suggest you download the binary from the above url :)
[02:10:43 CEST] <nanoEng> zeranoe is for compiling for windows using Debian
[02:10:55 CEST] <nanoEng> I'm not using Debian, or other linux.
[02:11:23 CEST] <relaxed> Did you even look? They're windows binaries
[02:11:34 CEST] <nanoEng> And i'm trying to customize ffplay. I've already downloaded builds of ffplay; I want to modify the program.
[02:11:50 CEST] <nanoEng> But first i want to see if i can just do a test compile; and i can't...
[02:12:52 CEST] <nanoEng> You are right though, the binary from Zeranoe works great.
[02:12:55 CEST] <relaxed> nanoEng: try adding --arch=x86_64 to your configure line.
[02:13:11 CEST] <relaxed> and keep --enable-yasm
[02:13:37 CEST] <nanoEng> relaxed:  I tried that already  :\  still tells me   arch     x86 (general)   when i do that.
[02:13:52 CEST] <relaxed> that's normal
[02:14:16 CEST] <nanoEng> oh, x86 (general)  means the it will make a 64bit program?
[02:14:37 CEST] <chungy> x86 can be 32-bit or 64-bit
[02:15:16 CEST] <nanoEng> ah
[02:15:18 CEST] <chungy> can also be 16-bit but that's not very relevant in this channel :P
[02:15:26 CEST] <nanoEng> i thought x86_64  could be 32 or 64-bit.
[02:15:42 CEST] <nanoEng> and x86 was strictly 32-bit.
[02:15:49 CEST] <chungy> x86_64 is the 64-bit variant specifically (likewise x86_32 for 32-bit, but more often called IA32)
[02:17:53 CEST] <nanoEng> hmm... so when it says the arch  is set to  x86 (general)  i can expect a 64-bit program to be output?
[02:18:41 CEST] <nanoEng> Well,  using --disable-yasm  didn't give the error i've been having... although, it is Still compiling....
[02:18:43 CEST] <relaxed> which compiler are you using?
[02:19:06 CEST] <nanoEng> I read the breif wikipeida on yasm (just says it is the replacement of nasm) ...
[02:19:59 CEST] <nanoEng> needless to say, i'm new to the world of compiling stuff (I'm only self taught in Python, and took a C++ hello world level programing class a long time ago).
[02:20:49 CEST] <nanoEng> So, my concern is, will compiling w/o yasm result in a lower-performance program than with it?
[02:21:05 CEST] <relaxed> yes
[02:21:20 CEST] <nanoEng> damnit
[02:21:47 CEST] <nanoEng> ..... hmm.. maybe i should just terminate the compile right now then... and try your --disable-filter-volume    method.
[02:22:14 CEST] <relaxed> which compiler are you using?
[02:22:34 CEST] <nanoEng> still, i'm curious to see if it will actually do it. If it does it will be the first successful compile of ffplay after about 36 hours of trying to get a successful compile.
[02:22:44 CEST] <nanoEng> msys2/mingw-w64
[02:23:12 CEST] <nanoEng> using the msys2 shell to emulate linux
[02:24:16 CEST] <nanoEng> i've already resolved many other issues i was  having, now it seems i've finally gotten  ./configure settled. now i'm on to getting  make  to work.
[02:24:40 CEST] <nanoEng> yay it finished, f***, it crapped out
[02:24:55 CEST] <nanoEng> CC      ffplay.o
[02:25:04 CEST] <nanoEng> <command-line>:0:6: error: no previous prototype for SDL_main [-Werror=missing-prototypes]
[02:25:12 CEST] <nanoEng> ffplay.c:3678:5: note: in expansion of macro main
[02:25:24 CEST] <nanoEng>  int main(int argc, char **argv)
[02:25:28 CEST] <nanoEng>      ^
[02:25:34 CEST] <nanoEng> cc1: some warnings being treated as errors
[02:25:39 CEST] <nanoEng> common.mak:57: recipe for target 'ffplay.o' failed
[02:25:44 CEST] <nanoEng> make: *** [ffplay.o] Error 1
[02:25:52 CEST] <relaxed> this is not pastebin.com
[02:25:57 CEST] <nanoEng>   then it just returns me to prompt...
[02:26:17 CEST] <nanoEng> yeah, but it was only 6 lines, so i figured give pastebin servers a rest.
[02:28:22 CEST] <llogan> the mingw guide in the wiki is ugly.
[02:28:46 CEST] <llogan> "rogerdpack". well, that explains it.
[02:29:20 CEST] <llogan> "stream of consciousness" guide writing
[02:29:30 CEST] <nanoEng> ?
[02:29:38 CEST] <llogan> https://trac.ffmpeg.org/wiki/CompilationGuide/MinGW
[02:30:10 CEST] <nanoEng> rogerdpack ?
[02:30:21 CEST] <llogan> view history
[02:30:27 CEST] <nanoEng> that string does not occur in that website
[02:30:46 CEST] <llogan> no, i was simply bitching about it
[02:31:05 CEST] <relaxed> nanoEng: oh, did you download the 32bit version of yasm.exe ?
[02:31:20 CEST] <nanoEng> no i don't think so.
[02:31:29 CEST] <nanoEng> i'm quite certain i did not
[02:31:58 CEST] Action: relaxed is glad he doesn't have to compile things on windows
[02:31:58 CEST] <nanoEng> i renamed  yasm-1.3.0-win64  to yasm.exe as instructed, and put it in msys64/usr/bin
[02:32:40 CEST] <nanoEng> i also tried  pacman -Ss yasm
[02:32:53 CEST] <nanoEng> then installed both  pacman -S msys/yasm
[02:33:14 CEST] <nanoEng> and pacman - S mingw64/mingw-w64-x86_64-yasm
[02:34:05 CEST] <nanoEng> I am now trying it with --disable-filter-volume  and yasm turned back on.
[02:35:07 CEST] <nanoEng> the yasm msys2's pacman service gives seems to be from April 2015, and the one i was using was from.. just gives the date i downloaded it.. so dont know., but it was from yasm website, so latest i suppose.
[02:35:54 CEST] <nanoEng> tho file sizes are different, i'll use the one msys2 gives me, since it wasn't happy when i used SDL i downloaded myself
[02:36:09 CEST] <nanoEng> and using pacman -S       fixed the SDL issue i was having
[02:36:16 CEST] <nanoEng> thought it might fix the yasm..
[02:36:29 CEST] <nanoEng> oh lame
[02:36:51 CEST] <nanoEng> --disable-filter-volume  makes the  orignal error i posted worse
[02:37:22 CEST] <nanoEng> now i have waaayy more   'is a register in 64-bit mode'    warnings
[02:39:06 CEST] <nanoEng> http://pastebin.com/TUbi9Qr9
[02:39:58 CEST] <nanoEng> hi relaxed
[02:41:10 CEST] <nanoEng> relaxed: your --disable-filter-volume  suggestion didn't work. In fact, i got even more 'is a register in 64-bit mode' warnings:  http://pastebin.com/TUbi9Qr9
[02:46:56 CEST] <relaxed> looks like your yasm and gcc are trying different bit modes, 32 vs 64
[02:47:33 CEST] <nanoEng> hmm... what tips you off to that, and how do I go about resolving it?
[02:47:57 CEST] <nanoEng> That last pastebin is with --disable-yasm
[02:48:10 CEST] <nanoEng> hmm then why did it show up...
[02:48:14 CEST] <relaxed> it's clearly using yasm
[02:48:31 CEST] <nanoEng> oh crud, i think i had both --enable-yasm and --disable-yasm  >.<
[02:48:34 CEST] <relaxed> --yasmexe=/path/to/64bit/yasm.exe
[02:52:23 CEST] <nanoEng> hmm ok then
[02:52:31 CEST] <DHE> libav* question. I want to be able to check frames of an H264 (probably no other codecs) to determine whether a frame is IDR or not. preferably without doing a full decode or else this is liable to kill my CPU... pointers?
[03:18:40 CEST] <nanoEng> Anyone know why I am getting this compile error:   http://pastebin.com/BF2Pv5Gk   ??
[03:19:02 CEST] <nanoEng> ./configure --target-os=win64 --enable-sdl --disable-programs --disable-encoders --enable-ffplay --disable-d3d11va --disable-dxva2 --disable-shared --enable-static --disable-doc --prefix=TEST2 --disable-ffmpeg --disable-ffprobe --disable-ffserver --disable-network --enable-gpl --enable-swscale --enable-memalign-hack --enable-yasm --disable-mmx --disable-mmxext
[03:24:41 CEST] <voltagex> I'm trying to follow the instructions for building with MSVC but when launching msys2_shell.bat from the Developer Tools prompt, it closes.
[03:25:40 CEST] <nanoEng> hmmm
[03:25:53 CEST] <nanoEng> i have no idea.
[03:44:48 CEST] <occupant> hrm I noticed that a binary I recently compiled from latest stable didn't report the configure flags anymore. there's a place for it, just blank. did something change in that respect?
[06:58:38 CEST] <jasom> Encoding from a dvd with subtitles, (stream 3 is dvd subtitles) I get: Application provided invalid, non monotonically increasing dts to muxer in stream 3: 397316401 >= 388567824 is there anything I can do about this?
[08:15:50 CEST] <buu> What determines the default bitrate when transcoding a file?
[08:57:47 CEST] <rcombs> buu: default rate control settings are up to the encoder
[10:26:38 CEST] <theeboat> Hi. is there anybody that could advise me on using the -probesize flag within ffmpeg? I have been using it and it doesn't seem to have the intended effect
[10:27:52 CEST] <Fyr> guys, how resampling influences on audio quality?
[10:28:28 CEST] <ln-> in english you need to use the auxiliary verb 'do' in questions like that.
[10:28:40 CEST] <Fyr> =)
[10:28:43 CEST] <Fyr> alright
[10:29:12 CEST] <Fyr> I'll tattoo it on my hand.
[10:29:19 CEST] <ln-> great
[10:31:20 CEST] <Fyr> opusenc resamles file into 48 kHz, I want to know if resampling has an effect on output quality.
[10:31:53 CEST] <Mavrik> Of course it does.
[10:32:02 CEST] <Fyr> how?
[10:32:06 CEST] <Fyr> ln-, do you know that or you just grammar nazying people on the channel?
[10:32:36 CEST] <JEEB> opus is special regarding sample rates
[10:32:54 CEST] <JEEB> also you already are losing plenty of quality during the lossy encoding phase
[10:33:20 CEST] <JEEB> so if you are only bothered by the fact that opus seems to be doing something different to others, I wouldn't put too much issue into that
[10:33:29 CEST] <Fyr> my library has files with sampling rate from 22 kHz to 192 kHz, but opusenc sets only 48 kHz.
[10:33:32 CEST] <JEEB> otherwise, keep resampling to a minimum
[10:33:59 CEST] <JEEB> yes, and I'm telling you that if you're just wondering about opusenc then just don't think too much about it. it's how opus works :P
[10:34:25 CEST] <JEEB> you can ask the opus folks about it if you really want to :)
[10:34:50 CEST] <Fyr> =)
[13:18:30 CEST] <satiender> Hi how I can run binary of ffmpeg on android
[13:18:32 CEST] <satiender> ??
[13:19:25 CEST] <Sefid_par> satiender: Of course this is an android development question I think
[13:19:38 CEST] <Sefid_par> How can I get better quality form desktop capturing?
[13:19:48 CEST] <Sefid_par> Here is the details: http://www.linuxquestions.org/questions/showthread.php?p=5408355
[13:21:33 CEST] <satiender> ok
[14:37:52 CEST] <barneygale_> Hi all. How can I overlay black bars on the left/right of the video. I don't want to do any scaling or moving of the video, only an overlay
[14:41:39 CEST] <DHE> sounds like you want the 'pad' filter
[14:53:19 CEST] <barneygale_> sorted, thanks :)
[16:17:07 CEST] <PlanC> a guy has sent me 121 audio files from lectures
[16:17:22 CEST] <PlanC> the audio files were originally extracted from videos
[16:17:44 CEST] <PlanC> (a guy is classmate, just to make it clear)
[16:18:15 CEST] <PlanC> I noticed that he's set the bitrate of all of them to 256 kbps
[16:18:52 CEST] <PlanC> I checked the video on a few of the videos and the audio quality in the videos were at around 128 kbps
[16:19:05 CEST] <PlanC> that's double the size and it's taking up a lot of space on my computer
[16:19:28 CEST] <PlanC> (each audio file is at least an hour long)
[16:19:55 CEST] <PlanC> is there a way to optimize the audio files and have FFmpeg automatically decrease the quality of the files?
[16:20:24 CEST] <PlanC> so if the audio file is using a bitrate that's too high, then it'll simply decrease and save it
[16:25:04 CEST] <DHE> it doesn't work that way. he probably transcoded them to 256k rather than just ripping the audio out of the video files
[16:25:19 CEST] <PlanC> DHE: yeah, that's exactly what he did
[16:25:33 CEST] <DHE> you can transcode them yourself. there's a quality loss, obviously.
[16:25:51 CEST] <PlanC> the result is that they're in a higher bitrate even if the video originally had an audio of let's say 96k
[16:27:42 CEST] <PlanC> but, will there really be a quality loss if I decrease it from 256k to 192k even if the original video had an audio bitrate of 96k?
[16:32:34 CEST] <DHE> transcoding a transcoding will try to preserve the audio degredation of the original. it's always assumed to be worse than the original
[16:58:40 CEST] <PlanC> is there a way to change the ID3 without having to transcode the entire file?
[17:05:00 CEST] <janemba> hi
[17:05:41 CEST] <janemba> I'm trying to convert a mkv file to a mp4 file with subtitles. I extract subtitles from the mkv file and I use the following command -> http://pastebin.com/MnMPDYdN
[17:06:08 CEST] <janemba> I compiled ffmpeg with libass do you know how to resolv that ?
[18:00:02 CEST] <podman> Does anyone have an idea as to why -map_metadata -1 wouldn't remove a menu metadata?
[18:16:36 CEST] <Fyr> is ffmpeg.org working?
[18:19:12 CEST] <klaxa> yes
[18:22:09 CEST] <Fyr> it looks like down to me. =(
[18:23:50 CEST] <Fyr> I meant http://its.ffmpeg.org
[18:24:10 CEST] <Fyr> http://ffmpeg.org is working, http://its.ffmpeg.org is down.
[18:24:17 CEST] <jasom> Fyr: proper upsampling of audio has no effect on quality
[18:24:49 CEST] <Fyr> jasom, but every resampling reduces it, right?
[18:25:17 CEST] <jasom> Fyr: not if you do it properly and the frequencies are all within Nyquist
[18:27:22 CEST] <jasom> Downsampling from 192 to 48 will have a tiny effect on quality, as you will need to low-pass the signal first, and that will change the signal, but that one time loss is essentially zero compared to running the signal through speakers (which would have to low-pass anyway) and unless you have a 192kHz DAC you'll be doing the identical transform at playback
[18:28:02 CEST] <jasom> A good 24 kHz low-pass shouldn't have an audible effect on the frequencies the human ear can hear anyway
[18:28:46 CEST] <jasom> lastly pretty much all lossy codecs operate in the frequency domain, so resampling happens implicitly even when not converting the sampling rate.
[20:21:37 CEST] <circ-user-daFNu> If I'm trying to convert a png sequence to dnhd 175, what should my qmax be? I've tried everything from 1 to 1000 but I keep getting errors to increase qmax, but 1100 gives me errors
[20:21:58 CEST] <circ-user-daFNu> dnxhd*
[20:27:33 CEST] <antiatom> Hi all, trying to encode a VP8 stream here, but it turns out looking TERRIBLE with the following settings:
[20:27:36 CEST] <antiatom> vcodec=libvpx vb=8000 crf=9 g=120 bf=2 threads=0 rc_lookahead=16 quality=good speed=1 vprofile=0 qmax=51 qmin=11 slices=4 arnr_max_frames=7 arnr_strength=5 arnr_type=3
[20:29:20 CEST] <KarlFranz> There mist be something wrong in there.
[20:29:30 CEST] <KarlFranz> qmin is over your crf
[20:32:02 CEST] <antiatom> I just deleted it and tried simply
[20:32:04 CEST] <antiatom> vcodec=libvpx vb=8000 crf=9 g=120 bf=2 threads=8
[20:32:07 CEST] <antiatom> But it looks WORSE
[20:34:18 CEST] <KarlFranz> 8 threads???
[20:34:41 CEST] <buu> What's wrong with 8?
[20:35:08 CEST] <KarlFranz> Multithreading is good for speed, but it can mess with the result, or so I have been told.
[20:35:21 CEST] <buu> That's disturbing
[20:35:23 CEST] <KarlFranz> I suppose you won't notice anything bad with just 2.
[20:35:43 CEST] <KarlFranz> The reason is that you break the video in many parts that are compressed independently.
[20:35:53 CEST] <antiatom> So does 2 work worse than 1?
[20:36:12 CEST] <KarlFranz> Supposedly. But I doubt that is the problem
[20:36:21 CEST] <KarlFranz> crf is designed to run in multipas, by the way.
[20:36:47 CEST] <KarlFranz> I would not expect crf to look very well in single pass.
[20:37:26 CEST] <antiatom> ok
[20:45:42 CEST] <Anonaly> Hi, I run Ubuntu 12.04,   and also I use from time to time  WinFF   to convert multimedia files
[20:46:03 CEST] <Anonaly> however I am getting  a codec error about libfaac
[20:53:39 CEST] <Anonaly> The ffmpeg program is only provided for script compatibility and will be removed
[20:53:39 CEST] <Anonaly> in a future release. It has been deprecated in the Libav project to allow for
[20:53:39 CEST] <Anonaly> incompatible command line syntax improvements in its replacement called avconv
[20:53:39 CEST] <Anonaly> (see Changelog for details). Please use avconv instead.
[20:54:39 CEST] <durandal_1707> you are using ffmpeg from libav and not from ffmpeg
[20:56:18 CEST] <Anonaly> ok hmm how can I fix this ?
[20:56:23 CEST] <Anonaly> remove libav ?
[20:57:58 CEST] <Anonaly> durandal_1707, ?
[20:59:00 CEST] <durandal_1707> or ask for help on libav channel
[21:01:36 CEST] <Anonaly> thank you
[21:01:52 CEST] <Anonaly> putting this PPA in right now https://launchpad.net/~mc3man/+archive/ubuntu/trusty-media
[21:03:09 CEST] <Anonaly> of course..  doesn't work
[21:03:11 CEST] <Anonaly> damn ppa'
[21:03:13 CEST] <Anonaly> s
[21:03:55 CEST] <iive> ffmpeg is in debian and soon it should be in ubuntu too...
[21:04:07 CEST] <iive> but you are with LTS version, aren't you?
[21:04:20 CEST] <Anonaly> yes
[21:04:29 CEST] <Anonaly> Ubuntu 12.04 LTS
[21:05:40 CEST] <Anonaly> I guess I will just have to compile it
[21:16:03 CEST] <Fyr> guys, kick the maintainers, its.ffmpeg.org still isn't working.
[21:23:54 CEST] <iive> "its" ?
[21:24:38 CEST] <Fyr> http://its.ffmpeg.org/wiki
[21:26:58 CEST] <Fyr> it's down.
[21:34:29 CEST] <iive> Fyr, what does "its" stand for... where did you get that url?
[21:34:36 CEST] <iive> the wiki is in trac.ffmpeg/org
[21:34:48 CEST] <Fyr> oops
[21:36:05 CEST] <Fyr> one of the first links in google on mp3 tags ffmpeg.
[21:36:27 CEST] <Fyr> I thought that "its" refers to ffmpeg's wiki.
[21:37:14 CEST] <Fyr> if it's not ffmpeg's, then whose is it?
[22:24:09 CEST] <llogan> never seen that url before
[23:22:34 CEST] <oscarpal> hello everyone how to hardsub to an mpeg dvd compliant file
[23:30:25 CEST] <llogan> oscarpal: see subtitles filter and use -target option with appropriate value
[00:00:00 CEST] --- Fri Aug 21 2015

More information about the Ffmpeg-devel-irc mailing list