[Ffmpeg-devel-irc] ffmpeg.log.20150824

burek burek021 at gmail.com
Tue Aug 25 02:05:01 CEST 2015

[00:24:44 CEST] <ChazNunz> Hi.  I'm look for some help with an FFMPEG issue.  I am using it to concat several small clips.  I'm receiving lots of "DTS/PTS invalid dropping" statements in the output.  The duration of the resulting video is off and some of the clips have faster playback speed.   Pastebin can't handle full output because the 'invalid dropping' message take up go on for 8,000 lines.  Here's the link to abbreviated pastebin.  http://pastebin.com/303d3MTU  I ran
[00:24:44 CEST] <ChazNunz> ffprobe on input videos and that output is included first.
[00:49:22 CEST] <cbsrobot> ChazNunz: you have some pretty wired fps on those clips
[00:49:44 CEST] <cbsrobot> concating them together will surely get you into some sync problem
[00:50:47 CEST] <ChazNunz> cbsrobot - can you give me more detail.  What do you mean by 'wired'?
[00:51:03 CEST] <cbsrobot> 30.14 fps
[00:51:09 CEST] <cbsrobot> 30.15 fps
[00:51:19 CEST] <cbsrobot>  25 fps
[00:51:28 CEST] <cbsrobot> 30 fps
[00:51:35 CEST] <cbsrobot> 30.13 fps
[00:51:38 CEST] <cbsrobot> anyways
[00:52:02 CEST] <cbsrobot> try to set the fps to a sane number
[00:52:46 CEST] <ChazNunz> Yeah, i noticed that.  We have two parts here.  First part is that we are recording (with FFMPEG) an RTSP stream of multiple clips.  We are only trying to get 15 sec durations.
[00:53:07 CEST] <ChazNunz> Sometimes the recording of the RTSP stream seams to produce slightly different FPS.
[00:53:40 CEST] <ChazNunz> Then we are doing some postprocessing (rotate, scale, etc) and finally concat.
[00:54:05 CEST] <ChazNunz> When recording RTSP is it usual that FPS varies?
[00:54:15 CEST] <cbsrobot> can you specify a fixed framerate somewhere in this chain ?
[00:54:32 CEST] <cbsrobot> maybe before the concat happens ?
[00:55:42 CEST] <ChazNunz> I don't see why not.  How do i do that? ;)
[00:56:00 CEST] <cbsrobot> set the -r option
[00:56:07 CEST] <cbsrobot> f.ex. -r 30
[00:56:23 CEST] <ChazNunz> ok.  Thanks cbsrobot.  I'll have a go with that.
[00:56:35 CEST] <cbsrobot> you'll still get a lot of "DTS/PTS invalid dropping"
[00:57:09 CEST] <ChazNunz> What does that mean - invalid dropping?
[00:57:22 CEST] <cbsrobot> but at least after concating the speed should not vary too much (in theroy)
[00:57:30 CEST] <ChazNunz> I was wondering if this was related to this bug:  http://trac.ffmpeg.org/ticket/4769
[00:58:09 CEST] <cbsrobot> it's not invalid droping, it's rather: PTS/DTS invalid ... so droping the frame
[00:58:30 CEST] <ChazNunz> What is PTS and DTS?   is this a timestamp?
[00:58:51 CEST] <cbsrobot> presentation and decoding ts
[00:59:33 CEST] <ChazNunz> OK.  I need to learn more about this.  Let me go read and I'll be back if i'm still stuck.  Thanks for putting me on track.
[00:59:43 CEST] <cbsrobot> np
[01:00:25 CEST] <cbsrobot> and read the forst part of https://ffmpeg.org/ffmpeg-formats.html#concat
[01:00:42 CEST] <cbsrobot> quote: All files must have the same streams (same codecs, same time base, etc.).
[02:54:14 CEST] <ChazNunz> cbsrobot:  You around?
[04:53:58 CEST] <jazo> can someone help me download and convert an m3u8 file to mp4. i'm getting a errors "could not find corresponding trex". url: http://a126.phobos.apple.com/us/r30/PurpleVideo1/v4/27/e0/fe/27e0feb3-6f4b-4445-9aa0-35ca9c90a7ce/P37213012_default.m3u8
[06:20:00 CEST] Last message repeated 1 time(s).
[06:33:35 CEST] <thecoolguy> anyone here ?
[06:34:44 CEST] <tommd> Yes, many people.
[08:25:51 CEST] <solrize_> are there known problems with the webm encoder?  i keep getting weird error messages like "Queue input is backward in time"
[08:26:05 CEST] <solrize_> and then the video doesn't play properly in firefox
[08:49:29 CEST] <solrize_> durandal_1707, thanks, will do
[08:52:36 CEST] <solrize_> http://lpaste.net/139551  i used downloaded creative commons movie as test input
[08:53:42 CEST] <hestra> Hi, I'm trying to find out how to remove last second of a video with ffmpeg, can only find documentation on how to remove first part of a video or specify length, anyone able to help solve todays problem?
[09:50:31 CEST] <durandal_1707> solrize_: what about -c:a copy instead of transcoding audio?
[09:51:05 CEST] <solrize_> hmm you think the audio is the problem?  ok i'll try that
[09:52:37 CEST] <solrize_> hmm no errors so far
[09:53:15 CEST] <solrize_> thanks!  it looks like this is working... the transcode will take about an hour
[09:54:35 CEST] <solrize_> i'm not actually trying to transcode this movie except as a test, i'm actually trying to icecast a live meeting and am having trouble figuring out the webm encode settings and hit similar errors encoding from x11grab
[10:00:15 CEST] <solrize_> anyway though i'll go to bed now and try to icecast this webm in the morning and see if it works any better than the last one... thanks!
[11:04:26 CEST] <rayanamukami> When defining streams for a single feed in 'etc/ffserver.conf', should 'NoAudio' and 'NoVideo' propagate to the streams configured below it? It seems so when testing and on stat.html.
[11:47:37 CEST] <cbreak> is ffmpeg still not supposed to work with correctly sized memory?
[12:14:18 CEST] <cbreak> http://coliru.stacked-crooked.com/a/46f3e4f1b6570429 crashes due to sws_scale not adhering to the object boundaries
[12:15:01 CEST] <cbreak> the crash happens deep inside lum_convert
[12:15:25 CEST] <cbreak> the offending instruction is  vmovdqu 0xc(%rsi), %xmm2
[12:16:33 CEST] <cbreak> stop reason = EXC_BAD_ACCESS (code=1, address=0x1003e1000)
[12:16:43 CEST] <cbreak> Input Start: 0x100300000, End: 0x1003e1000
[12:27:07 CEST] <durandal_1707> code you linked looks wrong
[12:28:21 CEST] <baadf00d> Hi, can i make a proprietary application that has a button "save with ffmpeg" which start a process that uses ffmpeg to save a video. Then package this software with ffmpeg and it's source code but not mine.
[12:30:23 CEST] <baadf00d> reading through gpl i think this is allowed, i would have no problem paying for things but it's not quite possible or easy.
[12:31:52 CEST] <chungy> if you stick with LGPL (don't use --enable-gpl), you should be fine. Still need to provide corresponding source code for ffmpeg.
[12:42:12 CEST] <baadf00d> Just to clarify a bit more. What I'm doing from my software is just using ffmpeg via command line. This doesn't change anything?
[12:42:52 CEST] <baadf00d> someone here says differently
[12:42:53 CEST] <baadf00d> http://programmers.stackexchange.com/questions/110380/call-gpl-software-from-non-gpl-software
[12:43:11 CEST] <baadf00d> But i wanted to ask around a bit more, since i want to be sure.
[12:43:23 CEST] <baadf00d> is that person on stackexchange wrong?
[12:45:09 CEST] <baadf00d> "if you distribute it (as opposed to having users obtain it from another source), you are responsible for providing a copy of the GPL to users, making it clear to them that the command-line program is under the GPL (even if the GUI wrapper isn't)"
[12:45:37 CEST] <baadf00d> seems quite specific
[12:59:40 CEST] <baadf00d> hmm, maybe this is the wrong place to ask since nobody here wrote the gpl license
[12:59:57 CEST] <baadf00d> mayb?
[13:21:46 CEST] <KarlFranz> I have not been following the discussion, let me read.
[13:23:42 CEST] <KarlFranz> baadf00d: If you distribute a GPL piece of software, you need to give the user the license and the means to get the source code. Regardless of any other consideration.
[13:23:59 CEST] <cbreak> durandal_1707: which part?
[13:24:42 CEST] <KarlFranz> If you distribute a tool that uses ffmpeg but does not use ffmpeg, chances are that you don't have to license it under any specific model.
[13:24:44 CEST] <cbreak> durandal_1707: the original code is bigger, this is just a minimal extracted example that reproduces the issue
[13:27:35 CEST] <cbreak> the original is also clean C++, in this crude C code I didn't bother with proper destruction
[13:28:01 CEST] <cbreak> but the error happens before that anyway
[13:28:18 CEST] <cbreak> I think it is related to avx optimized code that is buggy
[13:32:42 CEST] <cbreak> durandal_1707: it uses PIX_FMT instead of the new AV_PIX_FMT, but that shouldn't matter
[13:33:29 CEST] <cbreak> one would expect line 33 to crash (or worse) since it does an out of bounds memory access, which is UB.
[13:33:44 CEST] <durandal_1707> the input needs padded lines
[13:33:51 CEST] <cbreak> but the program crashes earlier, accessing the same out of bounds byte in sws_scale
[13:34:27 CEST] <cbreak> durandal_1707: the lines are padded to 16 bytes
[13:34:44 CEST] <durandal_1707> 32 is needed iirc
[13:34:58 CEST] <cbreak> (they are padded to 1920 bytes, because the width is 640 pixel * 3 bytes per pixel)
[13:37:19 CEST] <baadf00d> KarlFranz: Thank you for the response. It's not a simplified example. I will literally have a button in my software that calls ffmpeg via command line in it's own process. Another button is given to send a quit command to ffmpeg, to stop recording.
[13:37:35 CEST] <baadf00d> so i'm fine as long as i distribute ffmpeg source code along with it?
[13:42:43 CEST] <KarlFranz> If your program is just a front end trhat does not incorporate code of ffmpeg
[13:42:51 CEST] <KarlFranz> or uses its functions or whatever
[13:42:58 CEST] <KarlFranz> and only passes command line options to it
[13:43:08 CEST] <KarlFranz> well, then I think there is no problem.
[13:43:43 CEST] <KarlFranz> HOw are you licensing your program?
[13:44:27 CEST] <KarlFranz> Really, you just should read the license itself.
[13:45:25 CEST] <baadf00d> I'm reading it, but i'm a bit lazy :)
[13:47:53 CEST] <baadf00d> It's a commercial program.
[13:50:05 CEST] <baadf00d> This is just a small part of it, I tried looking into buying a h264 encoder from videolan, but it got very complicated fast when our legal didn't approve their NDA
[13:52:45 CEST] <baadf00d> license for the encoder anyway
[13:53:27 CEST] <KarlFranz> Oh. Then you have other problems.
[13:53:42 CEST] <baadf00d> ?
[13:54:02 CEST] <KarlFranz> Because the h264 codec is patented and is free to use for personal use, but if you use it for commertial applications you need to pay $$$$
[13:54:49 CEST] <KarlFranz> Remember that codec licensing != application licensing.
[13:55:01 CEST] <baadf00d> Good call, i need to check something
[13:55:02 CEST] <KarlFranz> Also remember that patent laws don't apply the same way in different countries.
[13:56:01 CEST] <KarlFranz> If you have a legal team you could be asking them :-)
[13:56:04 CEST] <baadf00d> Hmm, i only use -v:c copy
[13:56:19 CEST] <baadf00d> maybe i'm fine with lgpl
[13:57:43 CEST] <baadf00d> But I can't use the zeranoe build for windows since it's GPL and has libx264, right?
[13:58:06 CEST] <KarlFranz> First thing first.
[13:58:29 CEST] <KarlFranz> Are you selling the application to average consumers?
[13:58:32 CEST] <baadf00d> no
[13:58:37 CEST] <baadf00d> you can't buy it
[13:58:47 CEST] <KarlFranz> Ok, so what is the business model?
[13:59:09 CEST] <KarlFranz> If you are not distributing, licenses might now apply.
[13:59:16 CEST] <baadf00d> Damn, I don't know how much I can say...
[13:59:25 CEST] <KarlFranz> That is damn important :-)
[13:59:28 CEST] <baadf00d> A regular guy can't buy it
[13:59:49 CEST] <baadf00d> some nations can't even buy it
[14:00:13 CEST] <KarlFranz> If it is a webapp you host, you are not distributing, hence you don't need to gpl it or give source code or whatever.
[14:00:26 CEST] <KarlFranz> But you will have to check the patent conditions.
[14:00:39 CEST] <KarlFranz> Even if you onñy do -v:c copy
[14:01:37 CEST] <baadf00d> Should i disable as much as possible from the build?
[14:01:43 CEST] <baadf00d> so LGPL is not safe to use either?
[14:03:14 CEST] <KarlFranz> The first problem is you are making comertial use of a patented codec, it does not matter what application you use behind it.
[14:03:25 CEST] <KarlFranz> And I don't know the terms of the LGPL well enough
[14:03:47 CEST] <baadf00d> Just copying h264 is enough?
[14:03:58 CEST] <baadf00d> there's no audio, at least as much as i'm aware
[14:04:03 CEST] <KarlFranz> If you are serving the video, it does not matter that you are just copying the stream.
[14:04:20 CEST] <baadf00d> it's just being saved to a file
[14:05:02 CEST] <KarlFranz> Are those files to be served to subscriptors or something?
[14:06:04 CEST] <baadf00d> So the issue is still with libx264? So we need to pay for a license?
[14:06:19 CEST] <KarlFranz> That depends on what your business model is.
[14:06:19 CEST] <baadf00d> even if i just copy
[14:06:46 CEST] <baadf00d> well, the files are on the machine and the user can view them
[14:07:05 CEST] <baadf00d> but nothing more
[14:07:19 CEST] <KarlFranz> Ok, so I take it is a private encoder for personal use?
[14:09:11 CEST] <baadf00d> I think the way here is that i will get our legal to agree to the NDA and actually pay for the encoder.
[14:09:31 CEST] <KarlFranz> (Or use free codecs and save $$$$)
[14:11:33 CEST] <baadf00d> from what i'v experienced, libx264 seems quite good
[14:15:03 CEST] <baadf00d> thanks for the help, i'd send you a beer if there was a way to send it over the internet
[14:15:32 CEST] <KarlFranz> I am not into alcohol, but you can donate a carrot to a random horse and that will make me happy :-)
[14:35:20 CEST] <Arwalk> Hmm, hey guys. I have to use ffmpeg in a C program, sadly i don't have a lot of time for this school project, and i dont have any previous knowledge about video processing. I found the examples in the doc, but i'm still kinda lost as their pretty cryptic for someone that doesnt have any starting point like me. So, is there anyone willing to spare some time
[14:35:20 CEST] <Arwalk> with me about this, and help me learning?
[15:23:55 CEST] <baadf00d> Arwalk, try looking through the ffplay source code, it should be somewhat understandable
[15:29:00 CEST] <LigH> Hi.
[15:38:59 CEST] <cbreak> Arwalk: good luck...
[15:39:19 CEST] <cbreak> Arwalk: ffmpeg is like a gigantic bowl of spaghetti
[15:39:25 CEST] <Arwalk> Yeah....
[15:40:35 CEST] <Arwalk> Basically the project is about scaling a video in a cluster using mpi, openmp and ffmpeg.
[15:41:29 CEST] <Arwalk> i don't have any problem (i think) with mpi and openmp, but ffmpeg looks nightmarish
[15:41:49 CEST] <Arwalk> and i'm supposed to that in my spare time while working in a full-time internship.
[15:42:19 CEST] <cbreak> no problem with OpenMP? You're ... very optimistic :)
[15:42:35 CEST] <Arwalk> well, at least i had courses on openmp.
[15:42:53 CEST] <cbreak> I wrote a wrapper for ffmpeg for easier usage from C++
[15:42:58 CEST] <cbreak> took me ages...
[15:43:06 CEST] <Arwalk> :s
[15:43:11 CEST] <cbreak> the documentation of ffmpeg is quite lacking, and usually out of date
[15:43:18 CEST] <Arwalk> there's simple no doc.
[15:43:21 CEST] <Arwalk> simply
[15:43:30 CEST] <cbreak> well, I consider doxygen comments documentation :)
[15:43:37 CEST] <Arwalk> i dont :s
[15:43:37 CEST] <cbreak> (and examples also count)
[15:43:41 CEST] <cbreak> there are plenty of both
[15:44:11 CEST] <cbreak> but ffmpeg is a weird C api, so common sense doesn't apply, unfortunately
[15:44:21 CEST] <cbreak> you should really read the comments :)
[15:44:48 CEST] <Arwalk> yeah, but, as i said, i dont have any idea about video processing, so i'm really lost. And the examples feels a bit strange sometimes.
[15:44:58 CEST] <cbreak> well, they're C
[15:45:01 CEST] <Arwalk> I do read them, they dont bring much information for someone that doesnt know anything :s
[15:45:38 CEST] <cbreak> the general idea is that you have a container containing streams (decoded with avformat), inside that there is a video stream (in the case of a video), decoded with avcodec
[15:45:48 CEST] <cbreak> and you have to call a dozen or so functions to do that
[15:46:27 CEST] <Arwalk> know what, these two lines brought me more information than anything i read so far. ffmpeg suppose you knows that beforehand.
[15:47:31 CEST] <LigH> A question regarding FFV1 and FFVH: ffdshow uses an older ffmpeg API, therefore may not contain current version of these codecs in its ffvfw module. LAV Filters should use a recent API, but does not support VfW, only DirectShow codecs (which hardly any software can use). So is there any other project for "inline" use of these codecs (in contrast to "offline" compression via ffmpeg), e.g. for analogue capturing (yes, some still do)?
[15:51:07 CEST] <cbreak> Arwalk: do you want to decode or encode?
[15:52:09 CEST] <Arwalk> both, i suppose? I need to open a video file and scale it to another resolution. As i said, i'm completely clueless.
[15:52:45 CEST] <LigH> decode; filter; encode
[15:52:59 CEST] <solrize> Arwalk, you mean from a C program?
[15:53:04 CEST] <Arwalk> y
[15:53:28 CEST] <cbreak> for decoding I use avformat_open_input to open the file, avformat_find_stream_info, av_find_best_stream, avcodec_open2 to initialize the decoding
[15:53:31 CEST] <Arwalk> and the treatment (filter, so, if i understand well), should be balanced in a cluster using mpi/openmp
[15:53:32 CEST] <solrize> shell out to ffmpeg command line?
[15:53:41 CEST] <Arwalk> solrize: cant.
[15:53:41 CEST] <cbreak> av_frame_alloc to get some temp frame
[15:53:59 CEST] <cbreak> sws_getCachedContext to get a context for color conversion (or scaling)
[15:54:13 CEST] <cbreak> everything has its own free function too that you have to call
[15:54:27 CEST] <cbreak> and there are no exceptions, so you have to check if something broke after every function call yourself
[15:55:27 CEST] <cbreak> for encoding I use avformat_alloc_output_context2, avio_open, avformat_write_header and av_write_trailer
[15:55:42 CEST] <cbreak> and a ton of other calls
[15:55:52 CEST] <cbreak> I don't even remember why I did all this stuff
[15:56:12 CEST] <cbreak> Arwalk: ffmpeg is unfortunately a very low level API, which gives you a lot of power, but even more responsibilities
[15:57:17 CEST] <Arwalk> Yeah. But i suppose is low level part is necessary when the point of the project is using mpi/openmp. But i just wish my project's main difficulty was about the subject of the course associated, being indeed mpi/openmp. And not ffmpeg.
[15:57:53 CEST] <Arwalk> Thank you, i'll go look at all these functions, it's gonna give me a few starting points
[16:00:10 CEST] <Arwalk> This is gonna be such a nightmare.
[16:00:42 CEST] <cbreak> Arwalk: why do you want to use openmp?
[16:00:47 CEST] <cbreak> ffmpeg is already multithreaded
[16:01:29 CEST] <Arwalk> I have to use it. It's the project's rules. I never said it was clever nor useful.
[16:01:35 CEST] <solrize> Arwalk what's the application?
[16:02:10 CEST] <Arwalk> solrize: school project. C, use mpi,openmp and ffmpeg to scale a video in a cluster environment.
[16:02:32 CEST] <Arwalk> (i'm pretty sure the teacher himself doesnt know much about ffmpeg)
[16:02:33 CEST] <solrize> scale one video?
[16:02:37 CEST] <Arwalk> y
[16:05:22 CEST] <cbreak> at the end you can make benchmarks and find out if it really is as slow as it sounds :)
[16:06:21 CEST] <Arwalk> and do more useless work than necessary? nope.
[16:07:54 CEST] <solrize> divide video into chunks, run separate processes to scale each chunk, use mpi to read scaler output from the different processes and write them to temp files, then combine the temp files?
[16:07:54 CEST] <solrize> this doesn't sound like an mpi problem to be sure
[16:10:00 CEST] <Arwalk> well, this is the kind of theory i had right when i read the project, but i didnt know ffmpeg was such a.. Terrible.. undocumented.. cryptic.. mess.. for someone that never dwelled into video processing.
[16:11:40 CEST] <cbreak> Arwalk: as far as APIs go, ffmpeg is one of the better documented ones
[16:11:56 CEST] <cbreak> the doxygen comments are not very detailed, but at least usually somewhat up to date
[16:12:09 CEST] <cbreak> I've seen much worse...
[16:12:22 CEST] <Arwalk> i really can't find anything useful in the doxygen so far. But i sadly believe you..
[16:12:39 CEST] <cbreak> Arwalk: I just read the header source code
[16:12:44 CEST] <cbreak> (and the examples)
[16:12:55 CEST] <cbreak> that was enough to somewhat reliably decode stuff... sometimes.
[16:14:11 CEST] <Arwalk> yeah but i'm kinda retarded. And when you already did some code all day for your work, and you're supposed to do that on your free time, it really isnt good for your health :s
[16:15:26 CEST] <cbreak> working on free time is never good.
[16:17:00 CEST] <Arwalk> I'm not going to answer this, or i'm gonna start complaining again and start to be annoying. Thanks for all the help so far. Sadly expect me to ak things again in the next month.
[16:20:52 CEST] <gchristensen> Hi, I have a flac file which is 6m15s long (according to audacity) but ffprobe reports duration is N/A. any ideas on what might be happening, and how to get the desired duration of 6m15s
[16:25:31 CEST] <DHE> what version? My build (only a month old now) detects an hour-long FLAC just fine
[16:25:41 CEST] <DHE> (I follow git though)
[16:25:52 CEST] <gchristensen> well most flacs it does fine, but this flac it doeesn't
[16:29:03 CEST] <rayanamukami> Configuring 'NoAudio' and 'NoVideo' in ffserver streams seems to apply to the streams defined  below those lines as well. Is this normal?
[16:45:18 CEST] <durandal_1707> gchristensen: could you upload it somewhere?
[16:46:05 CEST] <gchristensen> durandal_1707: I can't authorize it to be saved and used in tests or published anywhere, but I'd be okay sharing it for inspection
[16:50:33 CEST] <durandal_1707> ok
[16:51:23 CEST] <gchristensen> durandal_1707: do you mind if I PM the media url to you?
[16:53:11 CEST] <durandal_1707> its fine
[17:05:52 CEST] <durandal_1707> ffmpeg by default do not parse all packets to find duration
[17:41:20 CEST] <deivior> Hi, I'm having a slight problem when recording with ffmpeg
[17:42:07 CEST] <deivior> I keep getting 'clipping' on my log messages when recording audio. I'm using alsa->fdk_aac with afterburner 1 and highpass/lowpass filters.
[17:42:51 CEST] <deivior> [...] -c:a libfdk_aac -afterburner 1 -async 2 -ac 1 -ab 64k \ -af "highpass=f=120, lowpass=f=2500, aresample=async=1000
[18:13:48 CEST] <durandal_1707> deivior: what you are recording is very loud?
[18:14:46 CEST] <FlorianBd> anyone knows how to configure fdk_aac before compilation? (from this git: https://github.com/mstorsjo/fdk-aac )
[18:15:11 CEST] <FlorianBd> it's not very clear to me how we define the prefix and other things
[18:18:55 CEST] <FlorianBd> ah it's ok I got the tgz from sourforge
[18:36:37 CEST] <skllz> hi guys, i have a problem!! How do configure my ffmpeg to capture black magic!? I try ./configure --enable-gpl and etc... but when i run ffmpeg -list_devices true -f dshow -i dummy i receive  "Unrecognized option 'list_devices'.". Any ideas?
[18:39:56 CEST] <DHE> ffmpeg -devices   # shows "dshow" ?
[18:40:25 CEST] <skllz> w8
[18:40:45 CEST] <skllz> DE alsa            ALSA audio output
[18:40:45 CEST] <skllz>  D  dv1394          DV1394 A/V grab
[18:40:45 CEST] <skllz>  DE fbdev           Linux framebuffer
[18:40:45 CEST] <skllz>  D  lavfi           Libavfilter virtual input device
[18:40:45 CEST] <skllz>  DE oss             OSS (Open Sound System) playback
[18:40:46 CEST] <skllz>   E sdl             SDL output device
[18:40:46 CEST] <skllz>   E v4l2            Video4Linux2 output device
[18:40:47 CEST] <skllz>  D  video4linux2,v4l2 Video4Linux2 device grab
[18:40:47 CEST] <skllz>  D  x11grab         X11 screen capture, using XCB
[18:41:21 CEST] <skllz> Black Magic using x11grab or what? You know?
[18:41:23 CEST] <skllz> thanks
[18:43:19 CEST] <skllz> sorry my poor english! lol
[19:25:03 CEST] <c_14> skllz: are you on linux?
[19:38:08 CEST] <skllz> yes ubuntu 14.04
[19:38:42 CEST] <c_14> Then you won't have dshow...
[19:38:57 CEST] <c_14> You can try seeing if your device is detected under v4l2
[19:40:55 CEST] <skllz> if my device is installed correctly, how i capture my black magic for input?
[19:58:08 CEST] <c_14> If it works with v4l2, use that. Otherwise you're probably sol
[20:04:56 CEST] <skllz> my v4l2 status is: E v4l2            Video4Linux2 output device
[20:05:07 CEST] <skllz> it's fine?
[20:12:42 CEST] <c_14> try v4l2ctl --list-devices (or some similar option)
[20:36:39 CEST] <skllz> ffmpeg v4l2ctl --list-devices
[20:36:39 CEST] <skllz> my output:
[20:36:45 CEST] <skllz> Unrecognized option '-list-devices'.
[20:36:45 CEST] <skllz> Error splitting the argument list: Option not found
[20:37:30 CEST] <tommd> skllz: Most ffmpeg commands I see take a single hypen, not two.  Try '-list-devices'
[20:38:04 CEST] <tommd> skllz: OTOH, v4l2-ctl is its own tool, not a command of ffmpeg...
[20:40:10 CEST] <skllz> same error @tommd
[20:40:27 CEST] <tommd> Did you consider my second message?
[20:40:37 CEST] <skllz> ffmpeg -list-devices
[20:40:38 CEST] <skllz>  ffmpeg -list-devices
[20:40:38 CEST] <skllz> ffmpeg -list-devices response: Unrecognized option 'list-devices'.
[20:40:38 CEST] <skllz> Error splitting the argument list: Option not found
[20:40:56 CEST] <tommd> Oh, so no then.
[20:49:03 CEST] <skllz> and now!? i'm lost !! :DD
[20:53:41 CEST] <c_14> skllz: https://trac.ffmpeg.org/wiki/Capture/Webcam#Linux
[20:55:06 CEST] <skllz> capture black magic is same capture webcam @c_14 ?
[20:55:15 CEST] <c_14> should be close enough
[20:56:15 CEST] <skllz> ok's i'll try
[00:00:00 CEST] --- Tue Aug 25 2015

More information about the Ffmpeg-devel-irc mailing list