[Ffmpeg-devel-irc] ffmpeg.log.20150826

burek burek021 at gmail.com
Thu Aug 27 02:05:01 CEST 2015

[07:57:05 CEST] <fling> How to encode different parts of video with different quality?
[08:05:56 CEST] <pzich> fling: split it into pieces, encode, then stitch them together?
[08:06:17 CEST] <fling> pzich: good idea!
[08:06:36 CEST] <fling> pzich: how to split based on the amount of movement on the video?
[08:07:55 CEST] <pzich> no idea, but I think ffmpeg has a few stabilization filters, they might be able to tell you how much motion is at different parts of the video
[08:10:02 CEST] <fling> I have a bunch of videos from a security camera and I wanted to only keep parts containing movement&
[08:10:25 CEST] <fling> pzich: another question is how to deal with a really desynced video? The video looks running much faster than audio there.
[10:25:58 CEST] <k_sze> Does ffmpeg/libav rearrange memory of "expired" frames under the hood?
[10:28:51 CEST] <k_sze> I mean, if I'm demuxing and decoding frames(), without setting AVCodecContext.refcounted_frames, does ffmpeg have a background thread that rearranges the memory of any frame except the current one, such that the content of the buffer of those old frames can change spontaneously from my application's perspective?
[10:46:35 CEST] <TikityTik> Is there a way to have ffmpeg stream and interactively play,pause, and choose what files play?
[11:58:59 CEST] <amol> hello
[12:03:55 CEST] <durandal_1707> hello
[12:25:53 CEST] <amol> Binary file of ffplay is not created after compiling ffmpeg source code. I download source from official site & did, 1)./configure 2)make 3) make install. Also SDL library is also installed. help me out this..
[12:26:48 CEST] <c_14> Is SDL 1 installed or SDL2 ?
[12:28:30 CEST] <amol> SDL-1_2-0
[12:30:29 CEST] <c_14> Can you pastebin your config.log ?
[12:32:30 CEST] <amol> ok but it's more than 10,000 lines
[12:33:51 CEST] <c_14> It tends to do that, yeah.
[13:42:17 CEST] <turlando> Hello everyone
[13:45:35 CEST] <turlando> I'm trying to transode a flac file to ogg vorbis using libvorbis but ffmpeg segfaults leaving me with a 0 byte file. here you can find a full log http://sprunge.us/jJjB
[13:46:08 CEST] <turlando> In that paste you'll find the version and the configure options too
[13:46:44 CEST] <c_14> I'm assuming you meant -ar and not -ab
[13:46:59 CEST] <c_14> Does it still segfault if you change that?
[13:47:57 CEST] <turlando> c_14, yes, it still does that
[13:48:17 CEST] <turlando> I tried to do a flac->flac conversion but the generated flac still segfaults ffmpeg converting to vorbis
[13:48:48 CEST] <c_14> Can you either upload the input file, the core dump, or a backtrace from the coredump?
[13:49:17 CEST] <turlando> c_14, is strace <command> fine for the purpose?
[13:50:14 CEST] <c_14> Could be useful, but that doesn't tell me where in the code it segfaults.
[13:50:22 CEST] <tinpl> Hi guys& I'm trying to build project using ffmpeg, but stucked on linker errors: http://pastebin.com/h6QBwrwk
[13:50:39 CEST] <tinpl> could anyone tell me where I could make a mistake?
[13:50:40 CEST] <turlando> How do I get a core dump? Do I need to recompile ffmpeg with some debug symbols?
[13:51:03 CEST] <c_14> ulimit -c unlimited; then rerun the command
[13:51:53 CEST] <c_14> The core dump itself shouldn't require the symbols, they should only be necessary when running gdb to check the contents of the dump (iirc)
[13:53:02 CEST] <turlando> Here you go c_14 http://sprunge.us/BjGO
[13:53:47 CEST] <c_14> turlando: there should be a file called `core' in your cwd now
[13:54:31 CEST] <turlando> Strange, there isn't... let me try again
[13:55:17 CEST] <c_14> Did you run ulimit -c unlimited before?
[13:55:23 CEST] <turlando> Yes, I did
[13:55:50 CEST] <turlando> It doens't show up: ls: cannot access core: No such file or directory
[13:56:07 CEST] <c_14> you can use `ulimit -c' to check that it set it correctly
[13:56:41 CEST] <turlando> It returns unlimited
[13:56:44 CEST] <c_14> hmm
[13:57:34 CEST] <c_14> Can you check /proc/sys/kernel/core_pattern ?
[13:58:18 CEST] <turlando> It returns |/usr/lib/systemd/systemd-coredump %p %u %g %s %t %e
[13:58:27 CEST] <c_14> geh
[13:58:29 CEST] <c_14> eeeeh
[13:58:37 CEST] <turlando> lol
[13:58:48 CEST] <c_14> You can either change it to "core" or try and find out what systemd does with coredumps
[13:58:52 CEST] <c_14> (probably in the journal somewhere)
[13:59:18 CEST] <turlando> Does it redirects the core file to the journalctl maybe?
[13:59:32 CEST] <c_14> >/var/lib/systemd/coredump, or directly in the journal.
[13:59:35 CEST] <c_14> according to the manpage
[13:59:55 CEST] <c_14> Ah, you can use coredumpctl to extract them
[14:00:15 CEST] <c_14> coredumpctl dump /path/to/ffmpeg
[14:00:24 CEST] <turlando> last two lines of journalctl http://sprunge.us/fgbd
[14:01:22 CEST] <turlando> maybe I found that, I'm uploading it
[14:03:35 CEST] <c_14> tinpl: no clue. configure was successful?
[14:04:13 CEST] <turlando> c_14 at coselosche.org/~tancredi/ffmpeg you'll find the trace. The flac file is still uploading
[14:06:05 CEST] <tinpl> A_14 seems so, and produced all libs fine. at least there were only some warnings
[14:07:03 CEST] <c_14> Is this when compiling ffmpeg or when linking against it?
[14:07:48 CEST] <tinpl> when linking
[14:07:53 CEST] <tinpl> compile went fine
[14:08:04 CEST] <tinpl> as I told it produced all .a objects
[14:08:19 CEST] <tinpl> with no errors
[14:10:26 CEST] <turlando> c_14 the flac finished uploading by the way
[14:10:43 CEST] <c_14> turlando: did you compress the coredump somehow? file can't figure out what it is and lz4 is telling me the header's wrong
[14:11:34 CEST] <turlando> c_14, it is how I found it in my coredump directory...
[14:14:08 CEST] <turlando> c_14, sorry, I never used coredumpctl, here should be what you want http://sprunge.us/aVKi
[14:14:42 CEST] <c_14> yeah, I can reproduce it here
[14:15:56 CEST] <c_14> That's definitely a bug.
[14:16:22 CEST] <turlando> How do we say if it is on libvorbis or ffmpeg handing it?
[14:16:55 CEST] <c_14> It's ffmpeg.
[14:17:07 CEST] <c_14> It's when writing the tags for the ogg container, not when encoding the stream.
[14:17:13 CEST] <c_14> You can reproduce the crash with libopus
[14:18:08 CEST] <c_14> Probably time for a bugreport: https://ffmpeg.org/bugreports.html
[14:18:22 CEST] Action: c_14 is just going to test with a newer git version to see if it's still in master
[14:18:36 CEST] <turlando> I thought it was because of the album art embedded as a video stream, so I gave it -map 0:a as you have seen
[14:18:58 CEST] <turlando> Thank you very much for trying the git version for me
[14:19:27 CEST] <turlando> Meanwhile I'll try to strip out the tags from the flac files and try the transcode again
[14:27:49 CEST] <c_14> turlando: crash also occurs in git. You can attach the information from here: http://pb.c-14.de/t/kng.DhAqnj to the bugreport if you don't feel like reproducing it yourself. (either directly in the description of the bugreport or as an attachment)
[14:29:27 CEST] <turlando> Thank you very much c_14. Stripping the vorbis comments resulted in a successfull transcode
[14:29:39 CEST] <turlando> I'll file the bug report right now
[14:32:00 CEST] <turlando> c_14 do I need to attach a media sample too?
[14:33:05 CEST] <durandal_1707> yes
[14:33:15 CEST] <c_14> It's usually helpful. Allows devs to reproduce the issue and make sure the patch fixes it. The flac is probably too large to attach so you can upload it to the ftp.
[14:36:16 CEST] <turlando> Will dd preserve the file structure in order to reproduce the bug?
[14:37:12 CEST] <c_14> Are you talking about trimming the file?
[14:39:07 CEST] <turlando> Yes, I do
[14:39:12 CEST] <turlando> I am*
[14:39:29 CEST] <c_14> Try it out, then rerun the ffmpeg command and see if it still segfaults
[14:40:20 CEST] <turlando> Of couse I will
[14:41:20 CEST] <turlando> Is "I'm trying to transcode this flac file to libvorbis but ffmpeg will just segfault while creating the metadata structure." okay as text file to upload to the ftp alongside the flac?
[14:42:10 CEST] <c_14> should be ok as long as you also attach the ffmpeg output stuff I uploaded earlier
[14:42:50 CEST] <c_14> And truncating the flac appears to work (it still segfaults after I truncated the input to 2M)
[14:43:51 CEST] <turlando> c_14, I supposed I should attach it to the bug tracker
[14:44:00 CEST] <c_14> yes
[14:45:24 CEST] <turlando> So it doens't need to go to the ftp
[14:45:46 CEST] <turlando> Sorry for the bunch of questions but it is my very first ffmpeg bug report
[14:45:59 CEST] <turlando> And I would like to help the devs as much as I can
[14:46:43 CEST] <c_14> If it's small enough that you can upload it to trac, put it there.
[14:47:48 CEST] <turlando> Is 2MB fine for the trac?
[14:48:22 CEST] <c_14> I think the limit is 5MiB, but I'm not sure
[14:52:48 CEST] <tinpl> guys, I'm using this configure, is it OK? PATH="$HOME/bin:$PATH" PKG_CONFIG_PATH="$HOME/ffmpeg_build/lib/pkgconfig" ./configure --prefix="$HOME/ffmpeg_build" --pkg-config-flags="--static" --extra-cflags="-I$HOME/ffmpeg_build/include" --extra-ldflags="-L$HOME/ffmpeg_build/lib" --bindir="$HOME/bin" --enable-gpl --enable-libass --enable-libtheora --enable-libvorbis --enable-libx264 --enable-avresample
[15:01:56 CEST] <turlando> c_14, it is afflicting avcodec, right?
[15:08:18 CEST] <c_14> avformat
[15:09:45 CEST] <turlando> Thank you
[15:10:06 CEST] <turlando> May I CC you to the bug report c_14?
[15:12:56 CEST] <c_14> I'll add myself later.
[15:13:20 CEST] <Hero6666> Hi there
[15:15:59 CEST] <Hero6666> I need your help. First compiling FFmpeg on Win64. Thereis my config.log : rob9.net/tmp/config.log
[15:18:09 CEST] <turlando> c_14 you'll find the bug report here https://trac.ffmpeg.org/ticket/4806
[15:25:49 CEST] <idi0tically> Hi everyone.
[15:28:15 CEST] <Hero6666> Anyone an idea, why my compiler cannot find libaries I try to compile with ffmpeg?
[15:29:02 CEST] <maksimka> hello
[15:29:47 CEST] <maksimka> how can i set duration for every image i want to use in video (I have 30 images and I will to view every image of them for variable number of milliseconds)
[15:30:19 CEST] <idi0tically> I've got a weird matroska muxing problem... a few days ago a I transcoded a file (matroska container, 03:48:11 duration, h264 video, 1 dts-hd ma master audio stream and 4 directors commentaries in stereo ac3 + pgs subtitles) down to hevc/opus in a matroska container
[15:31:26 CEST] <idi0tically> That worked fine, but after doing a similar transcode for another file, I decided I wanted a higher bitrate for  6.1 master audio track (up from 448 to 896kbps), so i transcoded the audio from the source again seperately
[15:31:39 CEST] <Hero6666> @maksimka: -delay should work
[15:32:51 CEST] <idi0tically> Now I'm using the command line "ffmpeg -i FOTR-lowspec.mkv -i newaudio.opus -map 0:v -map 1:a:0 -map 0:a:1 -map 0:a:2 -map 0:a:3 -map 0:a:4 -map 0:s -c:v copy -c:a copy -c:s copy FOTR-lowspec2.mkv" to try and mux the streams together; but when I do I get no master audio stream in the output (directors commentaries work fine tho)
[15:34:53 CEST] <idi0tically> I also get a bunch of warnings from the matroska muxer like "Starting new cluster due to timestamp"
[15:35:57 CEST] <maksimka> Hero6666: could you point to an example please? couldn't find any for -delay..
[15:43:20 CEST] <Hero6666> @maksimka: http://ffmpeg.org/ffmpeg-all.html#toc-Examples-115
[15:56:54 CEST] <idi0tically> This really odd though.. if I extract the audio out from my file (with mkvextract) it's perfectly fine, but it doesn't playback in mplayer, kodi or ffplay (the last of which defaults to ignore the master audio stream and playback the 1st directors commentary)
[16:28:43 CEST] <thecoolguy> Hello
[16:29:16 CEST] <thecoolguy> Anyone here ?
[16:37:51 CEST] <klaxa|work> thecoolguy: no (yes)
[16:38:48 CEST] <thecoolguy> trying to transcode form a url but i get http://pastie.org/private/mtwuwnnvurmx1ptxp2uw
[16:39:49 CEST] <klaxa|work> it says you are trying to encode 0 audio channels
[16:40:48 CEST] <klaxa|work> what command did you run?
[16:41:31 CEST] <thecoolguy> ffmpeg -i myurl -b:a 32k output.mp4
[16:42:33 CEST] <klaxa|work> that's pretty weird, that should work
[16:43:30 CEST] <klaxa|work> what ffmpeg version do you have?
[16:43:54 CEST] <thecoolguy> how do i check ?
[16:44:22 CEST] <klaxa|work> when you run ffmpeg it tells you at the beginning
[16:44:32 CEST] <thecoolguy> http://pastie.org/private/fhocvwt9z7zamdgkajmh4w
[16:45:56 CEST] <thecoolguy> [libvo_aacenc @ 0000000004ddc920] Unable to set encoding parameters
[16:46:02 CEST] <thecoolguy> why would that occur ?
[16:46:12 CEST] <klaxa|work> hmm dunno not using aacenc
[16:46:24 CEST] <klaxa|work> libfdk-aac is better
[16:46:48 CEST] <klaxa|work> i can imagine that some downmixing stuff is responsible
[16:47:09 CEST] <klaxa|work> your input has 6 channels, not sure how that is dealt with
[16:47:17 CEST] <thecoolguy> how do i specify that as a parameter ?
[16:47:40 CEST] <klaxa|work> -ac 6 maybe?
[16:47:49 CEST] <klaxa|work> that tells ffmpeg to use 6 audio channels
[16:47:58 CEST] <klaxa|work> but i'm not sure if that will work
[16:48:29 CEST] <thecoolguy> no i mean to use the other encode you mentioned
[16:48:50 CEST] <klaxa|work> ah, try adding -c:a libfdk_aac
[16:53:09 CEST] <thecoolguy> ugh missing
[16:53:53 CEST] <thecoolguy> are there any others i can use that come with ffmpeg
[16:53:59 CEST] <c_14> -c:a aac
[16:55:06 CEST] <klaxa|work> doesn't that use libvo_aacenc?
[16:55:20 CEST] <c_14> No, that's the name of the internal aac encoder
[16:55:20 CEST] <klaxa|work> well it really shouldn't mess with channel layout should it?
[16:55:24 CEST] <klaxa|work> ah right
[16:56:21 CEST] <thecoolguy>  The encoder 'aac' is experimental but experimental codecs are not enabled, add '-strict -2' if you want to use it.
[16:56:53 CEST] <thecoolguy> o got it now
[16:57:44 CEST] <thecoolguy> Yup it seems to be orking
[16:58:37 CEST] <thecoolguy> is there a codecs that uses nvenc?
[16:59:11 CEST] <klaxa|work> for audio? i don't think so, i think the only ones supported are h264 and h265 and i'm not even sure about h265
[16:59:31 CEST] <klaxa|work> according to wikipedia h264
[16:59:33 CEST] <c_14> There is nvenc_hevc
[16:59:36 CEST] <c_14> and nvenc_h264
[16:59:40 CEST] <klaxa|work> oh?
[16:59:42 CEST] <klaxa|work> https://en.wikipedia.org/wiki/Nvidia_NVENC
[16:59:44 CEST] <thecoolguy> :o
[17:00:10 CEST] <klaxa|work> >Introduced with the second-generation Maxwell architecture, third generation NVENC implements the video compression algorithm High Efficiency Video Coding (aka. HEVC, H.265) [...]
[17:00:20 CEST] Action: c_14 even tried it out once
[17:00:27 CEST] <klaxa|work> is it any good?
[17:00:33 CEST] <thecoolguy> Was it reasonable faster ? i have a gtx970
[17:00:42 CEST] <thecoolguy> reasonably*
[17:00:49 CEST] <c_14> For h264 or h265?
[17:00:54 CEST] <klaxa|work> both
[17:01:12 CEST] <c_14> It's much faster for h265, but neither is better than x264 --preset ultrafast
[17:01:17 CEST] <c_14> When it comes to speed/quality
[17:01:29 CEST] <c_14> (at least not yet)
[17:02:58 CEST] <thecoolguy> Really,  thought it converting is signigicantly faster using gpu accelration
[17:55:45 CEST] <thecoolguy> klaxa stil lthere ?
[17:56:21 CEST] <thecoolguy> how would i do ffmpeg->vlc->http?
[18:02:51 CEST] <klaxa> thecoolguy: dunno maybe named pipes and multiple processes?
[18:03:05 CEST] <klaxa> or use (cough) ffserver
[18:05:12 CEST] <thecoolguy> ok just donwloaded it what would be the command line for say an mp4 stream  given my starting command is. ffmpeg -i myurl -ac 6 -strict -2 -c:a aac -f mp4 output.mp4
[18:06:38 CEST] <thecoolguy> aya it doesn't exist on windows :/
[18:06:41 CEST] <thecoolguy> yay*
[18:07:15 CEST] <klaxa> ah i thought you were on linux
[18:07:36 CEST] <klaxa> shouldn't you be able to just give the url to vlc?
[18:07:49 CEST] <klaxa> vlc also has some transcoding options
[18:08:30 CEST] <thecoolguy> i tried something like
[18:08:31 CEST] <thecoolguy> vlc myurl :sout=#transcode{vcodec=hevc,acodec=mpga,ab=128,channels=2,samplerate=44100} :sout-keep
[18:08:42 CEST] <thecoolguy> with vlc but it doesn't even connect to my url :/
[18:10:17 CEST] <klaxa> sorry i have no experience with vlc regarding that
[18:11:02 CEST] <thecoolguy> god windows 10 is an abombination x.x
[18:12:06 CEST] <thecoolguy> what about with icecast?
[18:21:48 CEST] <thecoolguy> klaxa how would i fix the error  muxer does not support non seekable output
[18:22:06 CEST] <klaxa> use a different container
[18:22:48 CEST] <thecoolguy> or is my command wrong?
[18:23:28 CEST] <thecoolguy> doing
[18:23:33 CEST] <thecoolguy> ffmpeg -i url -ac 6 -strict -2 -c:a aac icecast://user:pass@localhost:8000/earth:video.mp4
[18:32:18 CEST] <JEEB> so if I need to generate silent audio, I guess it'd be aevalsrc, or is there a shorthand for it?
[18:33:39 CEST] Action: c_14 always uses aevalsrc=0, not sure if there's something better. you could also read pcm from /dev/zero
[18:39:52 CEST] <durandal_1707> anullsrc?
[18:46:58 CEST] <thecoolguy> ok klaxa
[18:47:26 CEST] <thecoolguy> I'm doing ffmpeg -i url -ac 6 -strict -2 -c:a aac -g 10 -f mp4 "icecast://source:hackme@localhost:8000/stream"
[18:47:33 CEST] <thecoolguy> and getting  muxer does not support non seekable output
[18:47:39 CEST] <c_14> thecoolguy: you can't stream mp4
[18:47:59 CEST] <thecoolguy> what can i stream that would be ios compatible ?
[18:51:11 CEST] <thecoolguy> c_14 ?
[18:52:30 CEST] <c_14> hls
[18:52:46 CEST] <c_14> That won't work via icecast though.
[19:00:48 CEST] <thecoolguy> hm
[19:04:57 CEST] <thecoolguy> do you know anything that does
[20:29:54 CEST] <iulhk> how can i use ffmpeg to convert m4a file to wav 8000 khz?
[20:30:26 CEST] <thecoolguy> anyone ever use nginx ?
[20:30:58 CEST] <c_14> iulhk: ffmpeg -i m4a -ar 8000k out.wav
[20:31:08 CEST] <c_14> Though, you probably didn't mean 8000 kiloherz...
[20:45:03 CEST] <iulhk> <c_14>: i need 8khz , the upper command is not working for me
[20:45:56 CEST] <c_14> just use 8000
[20:46:31 CEST] <iulhk> <c_14>: not even without khz ,
[20:52:12 CEST] <chungy> unrelated, but why do you want 8kHz? o.O
[20:53:39 CEST] <retard> thecoolguy someone sometime used nginx
[20:54:36 CEST] <iulhk> <fflogger>: http://pastie.org/10377653
[20:55:07 CEST] <iulhk> <chungy>: where i required its only support 8000 khz mono audio
[20:55:34 CEST] <c_14> iulhk: if you want mono add -ac 1
[20:57:17 CEST] <iulhk> <c_14>: getting error this way "ffmpeg -i myfile.m4a -ac -ar 8000 1440606849.wav"?
[20:57:24 CEST] <c_14> -ac 1
[20:59:51 CEST] <iulhk> <c_14>: Thanks buddy :) its working now
[21:01:26 CEST] <chungy> "8k" also works as an alternative to 8000
[22:17:35 CEST] <tommd> I'm seeing odd error numbers, could someone give me a hint?  For example, -1330794744 on avformat_open_input
[22:22:29 CEST] <tommd> Ahh, protocol not found.
[22:22:45 CEST] <tommd> so.. I don't know what that means yet though if anyone wants to chime in.
[22:23:23 CEST] <klaxa> post some code then
[22:24:16 CEST] <tommd> Is there no small set of things "protocol not found" refers to?
[22:24:37 CEST] <tommd> I could extract some C from my Haskell bindings if needed, but it might be quicker if I slog along a little longer in that case.
[22:26:37 CEST] <klaxa> why not just paste the haskell code?
[22:26:47 CEST] <klaxa> or is it too far from the C api?
[22:29:16 CEST] <tommd> OK, it's from ffurl_alloc, which is the only function that returns protocol not found and is reachable from avformat_open_input.
[22:29:34 CEST] <klaxa> what are you passing ffurl_alloc?
[22:29:43 CEST] <tommd> klaxa: I could have!  It's just: imageReader "0:0"
[22:29:55 CEST] <klaxa> haha ok
[22:30:08 CEST] <tommd> So I use ffmpeg-light and call `imageReader "0:0"` hoping the a/v format is parsed correctly.
[22:30:26 CEST] <tommd> So... I learned that, while it might be parsed correctly, my notion of 'correct' is wrong.
[22:30:36 CEST] <klaxa> what is "0:0" ? is it a file?
[22:30:54 CEST] <tommd> klaxa: No, it is my lame attempt to open my camera via avfoundation
[22:31:29 CEST] <tommd> I think "video=???" might work, so hints a few pages, but I can't get anything going and don't have time for looking over avio.c right now.
[22:31:46 CEST] <tommd> Do you have a hint?
[22:34:49 CEST] <klaxa> hmm...
[22:46:08 CEST] <JEEB> durandal_1707: so anullsrc works just like that? nice
[22:48:34 CEST] <durandal_1707> maybe you can get random noise but do not...
[22:54:41 CEST] <JEEB> what?
[22:57:19 CEST] <JEEB> yeah, decoding the stream makes it long and enough and it seems zero'd?
[22:57:23 CEST] <JEEB> cheers, m8
[00:00:00 CEST] --- Thu Aug 27 2015

More information about the Ffmpeg-devel-irc mailing list