[Ffmpeg-devel-irc] ffmpeg.log.20150829

burek burek021 at gmail.com
Sun Aug 30 02:05:02 CEST 2015

[01:04:28 CEST] <AlexanderSh> Can anyone help me? I'm trying to read udp multicast stream. I have tried this chain: avformat_open_input->avformat_find_stream_info->avcodec_find_decoder->avcodec_open2->decode_loop, where decode_loop - while(av_read_frame != mystream) -> do(avcodec_decode_video2 until got_picture or no luck). But ffmpeg tell me that ffmpeg illegal short term buffer state detected h264. The stream from hardware decoder 1080i, MPEG4, H.264.HD
[01:05:49 CEST] <AlexanderSh> ffpay is playing the stream without problems.
[01:06:45 CEST] <AlexanderSh> Tried set buffer_size from url - no luck.
[01:19:31 CEST] <AlexanderSh> ff: missing reference picture. default is <number>
[01:25:33 CEST] <DHE> just guessing (i have no API experience) but are you trying too hard to decode what you get once you join? with multicast there's no promise that you start with a keyframe, so you need to tolerate a few codec errors until it finds a GOP start
[01:32:11 CEST] <AlexanderSh> GOP settings (from hardware encoder) IBBP, I frame every 6 frames, GOP is closed. when i'm using ffplay it start decodef normal after 1-2 seconds of errors. But when I use my code errors fall without stop. from console: Missing reference picture is 66055 (9 times) afer Illegal short term buffer state detected (1 time) and then all repeted again. Missing pictures are 66055..66061..66067. Distance between missing pictures always equals to 6. Likes I am
[01:32:11 CEST] <AlexanderSh> not getting I-frame. But ffplay play without triubles.
[01:48:10 CEST] <AlexanderSh> I'm compare the output from av_dump_format from my code and ffplay.
[01:48:15 CEST] <AlexanderSh> ffplay:
[01:48:19 CEST] <AlexanderSh> Stream #0:0[0x1000] Video h264 (High) ([27][0][0][0]/0x001B), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 25 fps,25 tbr, 90k tbn, 50 tbc
[01:48:23 CEST] <AlexanderSh> my code:
[01:48:28 CEST] <AlexanderSh> Stream #0:0[0x1000] Video h264 ([27][0][0][0]/0x001B), none, 25 fps, 25 tbr, 90k tbn, 180k tbc
[01:48:36 CEST] <AlexanderSh> And i'
[01:49:40 CEST] <AlexanderSh> And I have got another error:could not find codec parameters for stream 0: unspecified size. Consider incresing the value form 'analyzeduration' and 'probesize' options.
[01:51:19 CEST] <AlexanderSh> in my code, ffmpeg doesn't identify stream correctly. No frame format (missing yuv420p and frame size).
[01:56:38 CEST] <AlexanderSh> Set AVFormatContext.max_analyze_duration2 and AVFormatContext.probesize2. Now outputs from av_dump_format are the same.
[01:57:23 CEST] <AlexanderSh> but avcodec_decode_video2 still output mising reference picture. default is ....
[03:40:47 CEST] <AlexanderSh> Solved and got frame. Changed read_packaet/decode loop, and set probe size and analyzeduration larger.
[03:41:46 CEST] <AlexanderSh> how to reduce latency? if I set decoder info directly is latence get smaller?
[06:33:05 CEST] <solrize> i'm trying to upload to icecast from x11grab interface... it worked before but now crashes with av_interleaved_write_frame(): connection reset by peer
[06:33:11 CEST] <solrize> web search finds some useless hits about that
[06:33:13 CEST] <solrize> any idea?
[06:37:45 CEST] <tommd> How do I get an AVFormatContext that represents a particular format?  I'm trying to get a context for avfoundation for use in avformat_open_input().
[06:38:22 CEST] <tommd> However, I can't find where in the API I could get an AVFormatContext.
[06:49:51 CEST] <kyleogrg> hello
[06:50:21 CEST] <kyleogrg> forgive the simple question, but i am having trouble knowing the way to search for the solution
[06:50:55 CEST] <kyleogrg> in windows cmd, how can i break up a long command line for ffmpeg?  a tutorial suggested using a backslash, but it is not working for me...
[07:21:50 CEST] <solrize> backslash is for linux shell
[10:05:29 CEST] <uvx3> Hi! How can I convert FLAC to lossy WavPack?
[12:08:55 CEST] <_Crash_> I'm about to compile the latest version off ffmpeg from git, and when I've come to ./configure, I'm getting a warning saying "WARNING: Option --enable-decoder=liba52 did not match anything". Any ideas?
[12:12:28 CEST] <_Crash_> Is it necessary to include it in the ./configure?
[12:15:28 CEST] <jookiyaya> what version of h265 does ffmpeg support
[12:19:21 CEST] <Guest65363> While stitching images to video, ffmpeg exits if the filename of the first image has an index greater than 4.
[12:19:35 CEST] <Guest65363> Why does it have this limitation?
[13:45:58 CEST] <Polochon1street> Hi! I'm decoding an audio file, by using a while(av_read_frame()) loop. I have some memory leaks, and someone on the mailing told me to « flush the codec by passing a NULL packet to it »
[13:46:20 CEST] <Polochon1street> Am I doing it right? http://pastebin.archlinux.fr/1484142
[16:41:33 CEST] <utack> Hi. I was wondering if H265 decode speed developed from 2.6 to 2.7 and if there is any chance for it to get faster in the future? (not hoping for miracles here, but my machine runs some low bitrate x265 encoded movies and some with higher bitrate are just a tiny bit too slow with ffmpeg 2.6 in kodi)
[16:51:44 CEST] <c_14> I only found one explicit optimization between 2.6 and 2.7.2, if you can use recent git there's now support for both vdpau and vaapi accelerated hevc decoding if your system supports either of those.
[16:54:28 CEST] <utack> i heard about that, but it definitly can not. mabe i will add a gpu for that later if things do not work on the cpu
[16:54:29 CEST] <utack> thanks
[18:33:55 CEST] <solrize> anyone suggest how to get vp8 bit rate lower?  we're having network probs.  command i'm using right now is http://lpaste.net/3145526325515649024   INRES=640x480 OUTRES=540x270 FPS=15
[18:34:10 CEST] <solrize> and i think i tried FPS=10
[18:34:16 CEST] <solrize> GOP=5 since we're streaming to browsers
[19:07:21 CEST] <BtbN> a goplength of 5 is terrible, something like 2x or 4x FPS is usualy a good value
[19:20:26 CEST] <solrize> BtbN i'm told i have to use gop < 10 in order to stream to browsers.  bigger gop failed pretty badly though it worked in mplayer and vlc.
[19:32:04 CEST] <BtbN> That's basicaly IFrame only mode, you need a realy high bitrate for that to look any good.
[20:43:18 CEST] <tommd> ANsewring my own question: av_input_video_device_next is the magic I was missing.  You can construct an AVFormatContext from priitives plus this global list of supported formats.
[22:35:12 CEST] <techtopia> hello, getting an error i have never seen before when encoding
[22:35:23 CEST] <techtopia> codec for video requires global header but does not contain global headers
[22:35:38 CEST] <techtopia> and errors out without starting the encode
[22:37:05 CEST] <Mavrik> :)
[22:37:25 CEST] <techtopia> ok i was doing it remotely via teamviewer
[22:37:37 CEST] <techtopia> getting the source video now so will be able to pb it in a few mins
[22:38:00 CEST] <BtbN> Why would using ffmpeg remotely change anything about pasting the output
[22:39:10 CEST] <techtopia> because im not longer connected to his box to grab the log
[22:39:18 CEST] <techtopia> he is uploading the video so i can have a look locally
[22:39:25 CEST] <techtopia> and when he does then i can get the log :p
[22:41:07 CEST] <fred1807> I need raw h264 videos for my raspberry, I am converting like:  ffmpeg -i source.mp4 desti.h264  but I am having problems with timecode... some videos are not played entirely by raspberry video player (hello_video.bin)
[22:42:31 CEST] <techtopia> the mp4 could contain a .h264 track
[22:42:41 CEST] <BtbN> raw h264 bitstream does not carry any timestamps.
[22:42:45 CEST] <techtopia> might be an idea to just try demux it
[22:42:49 CEST] <BtbN> also, you might want to add -c copy
[22:44:49 CEST] <fred1807> this is raspberry native hardware raw h264 player: https://github.com/adafruit/pi_hello_video/blob/master/hello_video/video.c   There must be something I am missing because some videos play 100% , while some freeze in the middle.  All of them I created with "ffmpeg -i source.mp4 dest.h264"  but they came  from different sources (vimeo, youtube, cam...)
[22:45:12 CEST] <fred1807> this player only plays .h264 without audio
[22:45:18 CEST] <fred1807> no container
[22:46:51 CEST] <fred1807> could the source of these videos be the cause? Or after the moment I convert with "ffmpeg -i s.mp4 d.h264" they are all the same??
[22:49:18 CEST] <techtopia> the documentation says it will only play the first 15 seconds of a video
[22:49:36 CEST] <techtopia> https://www.raspberrypi.org/documentation/usage/demos/hello-video.md
[22:49:40 CEST] <techtopia> "This will play a 15 second long full HD 1080p video clip with no sound. The intention here is to demonstrate video decode and playback capability. Youll see that the video is very smooth!"
[22:51:19 CEST] <fred1807> actually it plays way more
[22:51:48 CEST] <techtopia> not sure whats up then
[22:51:58 CEST] <techtopia> it does sound like kinda alpha software atm
[22:52:00 CEST] <fred1807> 15 seconds is the lengh of that demo
[22:52:03 CEST] <fred1807> bug bunny
[22:52:25 CEST] <fred1807> ok, my question is about ffmpeg actually
[22:52:32 CEST] <fred1807> and movie encoding in general..
[22:52:44 CEST] <fred1807> are all raw h264 video the same?
[22:52:53 CEST] <techtopia> no
[22:53:13 CEST] <techtopia> they can be diffrent resolutions, diffrent frame rates, and so on
[22:53:23 CEST] <techtopia> you can though encode them all to one standard
[22:53:37 CEST] <fred1807> ok... my stantard for raspberry is 720p
[22:53:41 CEST] <techtopia> like find a video that works, see what resolution the video is, see what frame rate it is
[22:53:48 CEST] <c_14> fred1807: compare the output of ffprobe -show_format -show_streams for a working and a non-working file
[22:53:48 CEST] <techtopia> then encode all future videos to that spec
[22:54:11 CEST] <fred1807> resolution, frame rate, what else counts for h264?
[22:54:29 CEST] <fred1807> is there any timelenght information on file?
[22:56:23 CEST] <fred1807> Hmmm.. Analysing files with mediainfo.. I can see that a always working file has a tag for fram rate
[22:56:26 CEST] <fred1807> frame rate
[22:56:38 CEST] <fred1807> while some of the freezing files dont have this tag at all
[22:56:50 CEST] <fred1807> how can I force frace rate calculation and tag when converting with ffmpeg ??
[22:57:10 CEST] <techtopia> you can add -r whatever, before -i to specify the source inputs frame rate
[22:57:15 CEST] <techtopia> like
[22:57:24 CEST] <techtopia> ffmpeg -r 25 -i blah blah blah
[22:57:58 CEST] <fred1807> btw, this working video frame rate is: Frame rate  118.437 fps   isnt that too much?
[22:58:13 CEST] <techtopia> yup heh
[22:58:18 CEST] <Mavrik> unless it's a 120fps camera
[22:58:24 CEST] <Mavrik> it's probably misdetected
[23:06:21 CEST] <fred1807> hmm the same video, with -r 25 (now with frame rate tag) is double the size...   (ffmpeg -r 25 -i old.h264 new.h264)
[23:10:49 CEST] <fred1807> Strangely as it may seem, (ffmpeg -r 25 -i old.h264 new.h264)  did NOT added a frame rate tag to the new movie
[23:13:50 CEST] <Donald_ET3> Is it possible to get a quality image out of the jpeg2000 or libopenjpeg encoders? My jpeg2000 output has very bad blocking artifacts, while libopenjpeg adds horizontal lines and so much discoloration it might as well be a black and white video.
[23:14:19 CEST] <Donald_ET3> Are there quality control commands for these encoders?
[23:15:33 CEST] <Donald_ET3> Or is this just the state of things at the moment?
[23:15:58 CEST] <techtopia> Mavrik http://pastebin.com/7nXr0dVX
[23:17:08 CEST] <Mavrik> The error seems descriptive enough :)
[23:17:30 CEST] <Donald_ET3> JPEG2000 looks like a very interesting format, but I can't find a way to encode images in the format.
[23:17:46 CEST] <Donald_ET3> With reasonable quality.
[23:19:59 CEST] <fred1807> not black magic will add a frame rate information to some h264 files :/
[23:20:16 CEST] <fred1807> what else can I try?
[23:21:48 CEST] <techtopia> it crashes out after encoding a few frames
[23:22:08 CEST] <techtopia> if i omit the "-acodec copy"
[23:22:22 CEST] <techtopia> it still errors out after the first few frames
[23:24:23 CEST] <techtopia> im not really fussed about the audio just the video
[23:25:51 CEST] <kyleogrg> so in linux, when i have a long ffmpeg command, i can break it up with \.  how about windows?
[23:26:18 CEST] <Mavrik> techtopia, same error?
[23:26:56 CEST] <Mavrik> fred1807, h264 raw file cannot carry that information, mux it into a proper container.
[23:27:58 CEST] <fred1807> Mavrik: I have raw h264 files here that mediainfo can show a frame rate tag, and they are exactly the files that plays fines. btw this raspberry tool only plays raw h264 video
[23:28:19 CEST] <fred1807> there is something possible to be done in ffmpeg, or mp4box, that makes all those videos the same
[23:32:57 CEST] <techtopia> mavrik http://pastebin.com/0Zh0gADf
[23:33:00 CEST] <techtopia> not the same error no
[23:33:18 CEST] <techtopia> but the encoded output only plays like the first five frames on repeat
[23:33:22 CEST] <techtopia> it just glitches out
[23:34:14 CEST] <Mavrik> techtopia, hrmf, that's strange, since I don't really see anything wrong in the output or the command
[23:34:20 CEST] <Mavrik> input is playable I guess?
[23:34:49 CEST] <Mavrik> techtopia, btw, you're heavily duplicating frames, is that expected?
[23:36:49 CEST] <techtopia> no
[23:36:54 CEST] <techtopia> frames should be unique
[23:37:13 CEST] <techtopia> input plays back ok
[23:42:11 CEST] <Mavrik> techtopia, since you're first deinterlacing and then forcing fps back to 50
[23:42:20 CEST] <Mavrik> that will duplicate all your deinterlaced frames
[23:48:24 CEST] <techtopia> it bob deinterlacing though
[23:50:07 CEST] <techtopia> yeah the frames are unique at 50fps
[23:50:50 CEST] <eiji> hei :P
[23:54:14 CEST] <techtopia> o/
[00:00:00 CEST] --- Sun Aug 30 2015

More information about the Ffmpeg-devel-irc mailing list