[Ffmpeg-devel-irc] ffmpeg.log.20150704

burek burek021 at gmail.com
Sun Jul 5 02:05:02 CEST 2015

[02:07:30 CEST] <joltman> I'm following the compiliation guide for Ubuntu here:  https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu
[02:08:15 CEST] <joltman> and I'm running into an issue where ffmpeg's ./configure line is telling me "ERROR: libx264 not found"
[02:08:41 CEST] <c_14> Did you install libx264?
[02:08:48 CEST] <joltman> I'm pasting the entire output of config.log to pastie in a moment
[02:08:51 CEST] <joltman> c_14, yes i did
[02:08:57 CEST] <joltman> matter of fact, i re-ran it just to be sure
[02:09:17 CEST] <joltman> i can see libx264.a in the ~/ffmpeg_build folder
[02:09:32 CEST] <c_14> Can you see an x264.pc as well?
[02:09:35 CEST] <joltman> i can see libx264.a in the ~/ffmpeg_build/lib folder
[02:09:38 CEST] <joltman> hmm
[02:09:45 CEST] <c_14> should be in lib/pkgconfig
[02:09:51 CEST] <joltman> no i can't...interesting
[02:10:00 CEST] <joltman> ah
[02:10:12 CEST] <joltman> that's in the ~/ffmpeg_build/lib/pkgconfig folder
[02:10:17 CEST] <joltman> so yeah, it's there
[02:10:43 CEST] <c_14> Did you export PKG_CONFIG_PATH=$HOME/ffmpeg_build/lib/pkgconfig ?
[02:11:10 CEST] <joltman> as i said, i ran the exact command that's listed on that page.
[02:11:12 CEST] <heap__> hi
[02:11:18 CEST] <heap__> is there any 2.7 package for raspbian?
[02:11:31 CEST] <joltman> this is the ./configure command i ran:  PATH="$HOME/bin:$PATH" PKG_CONFIG_PATH="$HOME/ffmpeg_build/lib/pkgconfig" ./configure   --prefix="$HOME/ffmpeg_build"   --pkg-config-flags="--static"   --extra-cflags="-I$HOME/ffmpeg_build/include"   --extra-ldflags="-L$HOME/ffmpeg_build/lib"   --bindir="$HOME/bin"   --enable-gpl   --enable-libass   --enable-libfdk-aac   --enable-libfreetype   --enable-libmp3lame   --enable-libopus   --enable-libtheora
[02:11:31 CEST] <joltman> --enable-libvorbis   --enable-libvpx   --enable-libx264   --enable-libx265   --enable-nonfree   --enable-x11grab
[02:12:59 CEST] <c_14> joltman: I'll probably need to see the config.log
[02:13:05 CEST] <joltman> ok
[02:13:13 CEST] <c_14> heap__: none I know of, never checked though
[02:13:14 CEST] <joltman> what is the preferred method of getting it to you?  Pastie?
[02:13:19 CEST] <heap__> c_14: ; /
[02:13:35 CEST] <heap__> what is the module for hw accelaration i have to enable during compliation on rpi2 ?
[02:14:02 CEST] <c_14> joltman: any pastebin service'll work. Some might have length limits though.
[02:14:20 CEST] <joltman> yeah, pastie doesn't like anything greater than 64k
[02:14:40 CEST] <c_14> You can probably cut the middle portion.
[02:14:48 CEST] <c_14> just denote the part you cut with [..] or something
[02:15:00 CEST] <heap__> RROR: gnutls not found using pkg-config
[02:15:04 CEST] <c_14> The interesting bits are usually at the beginning or end.
[02:15:05 CEST] <joltman> http://pastebin.com/NnG9LERa
[02:15:34 CEST] <heap__> i installed gnutls
[02:15:37 CEST] <c_14> heap__: you probably need gnutls-dev or something
[02:15:55 CEST] <heap__> both
[02:15:57 CEST] <heap__> installed
[02:16:45 CEST] <c_14> heap__: what does pkg-config --exists --print-errors return?
[02:16:47 CEST] <c_14> eh
[02:16:49 CEST] <heap__> no
[02:16:50 CEST] <heap__> wait
[02:16:57 CEST] <c_14> pkg-config --exists --print-errors gnutls that is
[02:17:49 CEST] <heap__> what about that HW accelaration?
[02:18:56 CEST] <c_14> heap__: what are you looking for? hw instruction sets or something like vdpau
[02:19:18 CEST] <c_14> joltman: you downloaded a recent git snapshot of ffmpeg, right?
[02:19:25 CEST] <joltman> when i compile z264, i get this error:  Warning: gpac is too old, update to 2007-06-21 UTC or later
[02:19:26 CEST] <joltman> c_
[02:19:34 CEST] <joltman> c_14, yes, i grabbed today's version
[02:19:38 CEST] <heap__> http://emby.media/community/index.php?/topic/16869-mediabrowser-server-switch-from-ffmpeg-to-gstreamer/
[02:19:51 CEST] <heap__> ppl mentioned there is some hw acceleration in ffmpeg on rpi2
[02:20:01 CEST] <c_14> joltman: what's the output of ./version.sh (in the source directory of ffmpeg). Also, you can ignore that gpac error
[02:20:47 CEST] <heap__> wi35
[02:21:05 CEST] <joltman> hmmmmm
[02:21:08 CEST] <joltman> 2.3.git
[02:21:10 CEST] <joltman> so it's very old
[02:21:16 CEST] <joltman> lemme try removing that directory
[02:23:01 CEST] <joltman> i removed the ffmpeg source directory, re-grabbed the ffmpeg-snapshot.tar.bz2, decompressed and ran the same ./configure
[02:23:03 CEST] <joltman> same issue
[02:23:07 CEST] <heap__> c_14: ?:)idea?
[02:23:19 CEST] <joltman> still showing 2.3.git as the version.
[02:24:01 CEST] <c_14> heap__: try --enable-mmal
[02:25:51 CEST] <c_14> joltman: I just downloaded the snapshot and it shows the correct version for me (N-73399-g866404d
[02:25:53 CEST] <c_14> )
[02:26:44 CEST] <heap__> thanks
[02:36:34 CEST] <heap__> c_14: whats that mmal?
[02:36:41 CEST] <heap__> gpu hw acceleration?
[02:38:49 CEST] <c_14> heap__: h264 hardware decoding using whatever mmal is
[02:39:50 CEST] <heap__> ?:)
[02:41:16 CEST] <joltman> then what the heck am i doing wrong
[02:41:17 CEST] <joltman> hmmm
[02:41:22 CEST] <heap__> c_14: cant get it
[02:41:44 CEST] <c_14> heap__: can't get what?
[02:42:10 CEST] <joltman> i'm an idiot
[02:42:24 CEST] <joltman> i deleted the folder, but forgot to delete the old tar.bz
[02:42:26 CEST] <joltman> running again
[02:42:52 CEST] <joltman> miraculously, it works
[02:42:59 CEST] <joltman> thanks for helping me through my dumbness
[02:43:10 CEST] <c_14> heap__: mmal is the hardware accel thing for rpi2 though, just cross-referenced with the ml
[02:47:21 CEST] <heap__> ok
[02:47:23 CEST] <heap__> thx
[02:53:52 CEST] <heap__> so on rpi2 should i configure it with -arch=armel  ?
[03:00:06 CEST] <klaxa> if you compile it on the pi itself the architecture should be autodetected afaik
[03:04:27 CEST] <heap__> ok
[03:20:06 CEST] <joltman> c_14, it built correctly.  Thanks again!
[03:29:27 CEST] <spl33n_> hello, i come back, i use ffmpeg to convert video to hight quality gif, durandal_1707 suggest me to use palettegen and paletteuse, i look this here http://blog.pkh.me/p/21-high-quality-gif-with-ffmpeg.html but not work i have this error [AVFilterGraph @ 0x80a431040] No such filter: 'palettegen'
[03:33:57 CEST] <prelude2004c> hello everyone
[03:34:17 CEST] <prelude2004c> anyone know why ffmpeg would be so slow to start -i < input > and then -f flv rtmp...out
[03:34:31 CEST] <prelude2004c> when is tart ffmpeg, it takes a few seconds to get stream and then it starts very slow.. and speeds up
[03:34:35 CEST] <prelude2004c> very odd behavior
[03:34:43 CEST] <prelude2004c> when i play the input with vlc it works right away
[03:34:47 CEST] <prelude2004c> no slow downs to start at all
[04:45:16 CEST] <pandb> I'm trying to apply a filter to a frame with av_buffersrc_write_frame() and av_buffersink_get_frame(), but av_frame_ref(), which is called by ..._get_frame() fails because ->buf[0] is null in the AVFrame* I've passed to ..._get_frame()
[04:45:27 CEST] <pandb> however, the AVFrame* in question is perfectly fine when I encode it and write it to output
[04:45:38 CEST] <pandb> this frame was generated with sws_scale()
[04:46:07 CEST] <pandb> also, many of the attributes of this frame are uninitialized, like height, width, format and others.
[04:46:37 CEST] <pandb> is there a function I should have called before or after sws_scale() (and sws_getContext()) that would take care of all or most of these things?
[04:46:54 CEST] <pandb> The actual video resulting from these sws_scale'd frames displays perfectly fine, however.
[04:47:56 CEST] <pandb> (I posted this exact same sequence of questions to #libav, I hope that's acceptable, since it seems well within the purview of both of these channels)
[06:33:12 CEST] <durandal_1707> spl33n_: compile your own ffmpeg
[11:10:20 CEST] <emk-> hello
[11:10:57 CEST] <emk-> is it possible to recode variable frame rate -> constant frame rate correctly with ffmpeg?
[11:11:38 CEST] <emk-> I've done it using mencoder, but no success using ffmpeg
[11:12:23 CEST] <durandal_1707> what you tried?
[11:13:33 CEST] <emk-> i've tried -vsync 1/2
[11:13:54 CEST] <emk-> but ffmpeg doesn't duplicate frames when the video goes to low framerate
[11:14:39 CEST] <emk-> basically -vsync 1 should duplicate frames, but it just passes them, as normal framerate
[11:17:32 CEST] <durandal_1707> ask on user mailing list
[13:12:10 CEST] <user01> ffmpeg 2.6.3 on debian -- the only way i could get a upside down video to flip that had metadata for 180 was to so 2 operations of transpose=1 . . . was there a more elegant solution like removing the 180?
[13:12:24 CEST] <user01> s/so/do
[13:13:52 CEST] <user01> i had tried this but it didnt work: ffmpeg -i 20150702_223047.mp4 -c -metadata:s:v:0 rotate=0 output.mp4
[13:14:32 CEST] <user01> tried this and it didnt work:  ffmpeg -i 20150702_223047.mp4 -vf "transpose=2,transpose=2,format=yuv420p" -metadata:s:v rotate=0 -codec:v libx264 -codec:a copy output.mp4
[13:15:31 CEST] <user01> tried this and it didnt work: ffmpeg -i 20150702_223047.mp4 -vf vflip,hflip out.mp4
[19:30:20 CEST] <Seylerius> I'm trying to convert an mp4 (ffmpeg info: http://sprunge.us/LciO) into something that Lightworks will accept (http://lightworks.wikidot.com/formats). I'm on ArchLinux. Any recommendations?
[19:38:00 CEST] <Seylerius> Lightworks can't see any video in the output of `ffmpeg -i 20150628_101238_01.mp4 -codec:v mpeg2video -codec:a aac 20150628_101238_01.avi`
[19:38:23 CEST] <Seylerius> Maintaining quality is good, although there are some mild space concerns.
[19:39:13 CEST] <Seylerius> I have 7.3G of mp4 video like that, and about 70G of free space.
[19:58:56 CEST] <DHE> I thought quicktime H.264 was what your input file already is...
[20:00:01 CEST] <DHE> oh, never mind me then
[20:06:22 CEST] <BtbN> What the hell is this webcam doing. Non-monotonous DTS, tons of them.
[20:17:43 CEST] <relaxed> Seylerius: try, ffmpeg -i input.mk4 -c:v mpeg2video -q:v 2 -c:a pcm_s16le output.avi
[20:18:03 CEST] <relaxed> mp4*
[20:19:55 CEST] <relaxed> Seylerius: also try stream copying to .mov
[20:37:18 CEST] <Seylerius> relaxed: Stream copying being changing to mov with codecs set to copy?
[20:39:28 CEST] <Seylerius> relaxed: The line you suggested produced an avi, but Lightworks again didn't detect that it contained video, only audio.
[20:39:34 CEST] <Seylerius> relaxed: trying stream-copy
[20:42:21 CEST] <Seylerius> relaxed: that didn't work either.
[20:42:32 CEST] <Seylerius> Complained about codecs lacking global headers
[20:53:41 CEST] <relaxed> Seylerius: they list ffmpeg, but don't give a single example :/
[21:09:38 CEST] <Seylerius> relaxed: It was ffmpeg that complained with the stream-copy.
[21:10:02 CEST] <Seylerius> I did this: `ffmpeg -i 20150628_101238_01.mp4 -codec copy 20150628_101238_01.mov`
[21:38:59 CEST] <BtbN> Is there a way to just throw away timestamps(dts) when stream copying, and make up new ones? This webcam is realy bad with its timestamps aparently
[21:53:04 CEST] <asimas> When concatenating files I'm receiving an errror saying that SAR values must be equal. The values are 1:1 and 65536:655536. As I understand these are equivalent. Is there any way to quietly avoid this error or do I need to setsar?
[22:23:01 CEST] <edoceo> Hey, I've got a matroska/webm file that I cannot decode, I get a " Read error at pos. 37"
[22:23:25 CEST] <edoceo> So, is it possible to get ffmpeg to ignore this somehow and proceed through the rest of the file?
[22:24:23 CEST] <edoceo> Here's my full command & output: http://edoceo.io/paste?p=OBy2nu
[22:25:01 CEST] <edoceo> Oddly, these .webm files play in VLC, just w/o sound
[22:27:01 CEST] <smo_> hi
[22:35:22 CEST] <smo_> i open some youtube videos wih commands line like : http://pastebin.com/SPHfXSXj
[22:35:55 CEST] <smo_> 2 youtube links (video/audio) But it takes aaaaaaaaggges to start the streaming .... how can i speed it up please?
[22:36:12 CEST] <smo_> links opened in the browser are opened very fast
[22:36:37 CEST] <sfan5> why not just use youtube-dl
[22:36:46 CEST] <sfan5> youtube-dl does exactly what you want
[22:36:52 CEST] <sfan5> download video & audio and mux it into 1 file
[22:37:19 CEST] <sfan5> also using -preset ultrafast or -deinterlace with -c:v copy won't do a thing
[22:37:56 CEST] <sfan5> "copy" just copies the video data
[22:38:06 CEST] <sfan5> without re-encoding you can't do deinterlacing
[22:38:30 CEST] <sfan5> and without encoding specifying a preset doesn't make sense
[22:40:53 CEST] <smo_> i know... but in stream it in live in my app
[22:41:01 CEST] <smo_> just use ffmpeg to merge the 2 files
[22:41:23 CEST] <smo_> then pipe results thru nodejs in my video player in live
[22:41:37 CEST] <smo_> just take too long to start the stream
[22:58:16 CEST] <sfan5> smo_: this is a little hacky but starts doing something in about 3 seconds http://pastebin.com/M42e6t9d
[23:00:57 CEST] <smo_> very nice sfan5 but don t think i can do it thru nodejs
[00:00:00 CEST] --- Sun Jul  5 2015

More information about the Ffmpeg-devel-irc mailing list