[Ffmpeg-devel-irc] ffmpeg.log.20150705

burek burek021 at gmail.com
Mon Jul 6 02:05:01 CEST 2015

[00:05:13 CEST] <Seylerius> So, I'm trying to figure out how to produce any of these formats with ffmpeg, so I can easily import some things into Lightworks: http://lightworks.wikidot.com/formats
[00:05:14 CEST] <polyphagia> why not smo_
[00:05:26 CEST] <Seylerius> I've got these: http://sprunge.us/LciO
[00:05:57 CEST] <Seylerius> avi with mpeg2video is registering as audio-only to lightworks.
[00:06:17 CEST] <Seylerius> Perhaps this is because some additional option would be necessary to make it mpeg2 with i-frame
[00:06:25 CEST] <Seylerius> I'd appreciate any suggestions.
[00:06:55 CEST] <Seylerius> Also, for the sake of limited processing power on the machine running lightworks, I'd prefer to get out of h.264.
[00:07:08 CEST] <user> hello :)
[00:07:13 CEST] <user> anybody here? :)
[00:07:44 CEST] <Guest86769> ^^'
[00:07:57 CEST] <Guest86769> can i ask just a small question ?
[00:08:35 CEST] <klaxa> don't ask to ask, just ask
[00:08:39 CEST] <Guest86769> xD
[00:09:00 CEST] <Guest86769> well i successfully compiled following this guide ffmpeg on centos https://trac.ffmpeg.org/wiki/CompilationGuide/Centos
[00:09:04 CEST] <Guest86769> i followed all the guide
[00:09:23 CEST] <Guest86769> there's any chance i can produce also a windows x64 executable ?
[00:10:19 CEST] <emk-> Guest86769: you'd need cross-compilation toolchain installed.
[00:10:42 CEST] <Guest86769> emk-: do you have a guide i can follow?
[00:10:46 CEST] <klaxa> https://trac.ffmpeg.org/wiki/CompilationGuide/CrossCompilingForWindows
[00:11:08 CEST] <Guest86769> klaxa: thank you ;)
[00:11:12 CEST] <klaxa> it might be easier to compile it on a windows machine since i'm pretty sure that if you compiled all the libraries for linux you can't build a windows executable from them
[00:11:13 CEST] <Guest86769> i will try
[00:11:50 CEST] <Guest86769> klaxa: so if i use that guide it will not work?
[00:11:56 CEST] <Guest86769> i'm using centos as alternative
[00:12:08 CEST] <Guest86769> because i'm having some problems with mingw
[00:12:51 CEST] <klaxa> i don't know if it will fail
[00:13:02 CEST] <klaxa> you can give it a try though
[00:13:27 CEST] <Guest86769> i will try because at least till now on centos nothing failed :D
[00:21:27 CEST] <Compress0r> Hi guys. I have an issue with converting my Canon EOS 700D h264 movies anything else. I always get washed out colors in the result.
[00:22:17 CEST] <Compress0r> I first thought its an issue with libx264 output, but even using huffyuv I see the same washed out colors. Specifing color_range, pix_fmt didn't help either.
[00:22:51 CEST] <emk-> Compress0r: can you give ffprobe output of one of the movies?
[00:23:06 CEST] <Compress0r> VLC is playing the video in shiny colors, but anything that went thought ffmpeg just looks washed out.
[00:23:10 CEST] <Seylerius> I'm trying to put 1080x1920 into dvvideo, but it's complaining about lacking a DV profile. Which one should I use (to preserve quality), and how do I specify it?
[00:23:12 CEST] <Compress0r> sure give me a sec
[00:23:39 CEST] <Seylerius> Current iteration of the command is `20150628_101238_01.mp4 -codec:v dvvideo -codec:a pcm_s16le 20150628_101238_01.avi`
[00:23:50 CEST] <Compress0r> Relevant part should be thing, right? Video: h264 (Constrained Baseline) (avc1 / 0x31637661), yuv420p(pc, bt709/bt470bg/bt709), 1920x1080, 44656 kb/s, 25 fps, 25 tbr, 25k tbn, 50k tbc (default)
[00:24:03 CEST] <Compress0r> yuv420p(pc, bt709/bt470bg/bt709)
[00:25:43 CEST] <Compress0r> sorry...actual output is this: Video: h264 (Constrained Baseline) (avc1 / 0x31637661), yuvj420p(pc, bt709), 1920x1080, 44656 kb/s, 25 fps, 25 tbr, 25k tbn, 50k tbc (default)
[00:26:05 CEST] <Compress0r> i messed around in the coding already to force full range and different color profiles.
[00:26:14 CEST] <emk-> Compress0r: shenanigans with bt709 color space :(
[00:26:19 CEST] <Compress0r> nothing helped
[00:26:57 CEST] <Compress0r> yes I also think that this has to do with bt709 color space
[00:27:05 CEST] <emk-> did you try -x264opts colorprim=bt709:transfer=bt709:colormatrix=bt709:fullrange=off ?
[00:27:32 CEST] <Compress0r> yes i think i found this on some mailing list already...let me try again
[00:28:02 CEST] <Compress0r> funny thing is its happening with huffyuv output...so i guess x264opts are just for output right?
[00:28:29 CEST] <emk-> yep
[00:28:48 CEST] <Compress0r> with huffyuv ALSO, so I have tried anything like converting it to rgb24...
[00:28:59 CEST] <Compress0r> i really think that the input gets messed up really early
[00:29:02 CEST] <emk-> probably huffyuv also does colorspace conversions...
[00:29:27 CEST] <emk-> or maybe the video is not really bt709, and hence weird results
[00:29:52 CEST] <emk-> colorspace conversions are performed when they shouldn't
[00:30:25 CEST] <Compress0r> which AVColorSpace i could try to force?
[00:30:31 CEST] <Compress0r> AVCOL_SPC_RGB?
[00:31:05 CEST] <Compress0r> i just force it libavcodec/h264_slice.c
[00:31:52 CEST] <Compress0r> but rgb doesn't sound right, and I can't find anything in AVColorSpace that sounds like "don't mess with my colors"
[00:31:57 CEST] <emk-> Compress0r: did you mess with all the combinations of https://ffmpeg.org/ffmpeg-filters.html#colormatrix on input?
[00:32:20 CEST] <Compress0r> colormatrix is a -vf?
[00:32:44 CEST] <emk-> yes
[00:33:01 CEST] <Compress0r> I just feared that the video gets messed up before some filters are applied...
[00:33:22 CEST] <Compress0r> can a filter interfer with how the video is interpreted?
[00:33:39 CEST] <emk-> And how does the video look in ffplay?
[00:37:37 CEST] <Compress0r> also "washed out"
[00:38:19 CEST] <Compress0r> but actually I'm not sure if ffmpeg is correct and vlc is just "missing" the bt709 conversion and showing a way to oversaturated image...
[00:39:24 CEST] <Compress0r> maybe vlc is intepreting the video as MPEG range and ffmpeg actually does correctly see it as JPEG range?
[00:39:55 CEST] <Compress0r> I thought vlc is also using libav*
[00:40:34 CEST] <emk-> you need some kind of test board ;)
[00:40:54 CEST] <klaxa> maybe you have some filters enabled in vlc?
[00:44:23 CEST] <Compress0r> nope...double checked that :)
[00:44:51 CEST] <Compress0r> also i play both, the original and the ffmpeg edited video in vlc. so the same filter should apply then ;)
[00:44:57 CEST] <klaxa> hmm true
[00:45:10 CEST] <klaxa> what does ffprobe say about your encoded file?
[00:45:21 CEST] <klaxa> (especially regarding the pixel format and color space)
[00:45:54 CEST] <Compress0r> Video: h264 (Constrained Baseline) (avc1 / 0x31637661), yuvj420p(pc, bt709), 1920x1080, 44656 kb/s, 25 fps, 25 tbr, 25k tbn, 50k tbc (default)
[00:47:01 CEST] <klaxa> that's identical to your input file
[00:47:10 CEST] <klaxa> are you sure it's the right paste?
[00:50:35 CEST] <Compress0r> ah the encoded output...sorry
[00:54:22 CEST] <Compress0r> give me a sec. I think I'm onto smth
[01:04:22 CEST] <Compress0r> ouh...now samba was playing tricks on me and giving me old encodes over and over cause there have been open handles on the old file -.-
[01:04:59 CEST] <Compress0r> note to myself: never reuse filenames when trying something like this :)
[01:08:40 CEST] <Compress0r> actually I more and more think that VLC is wrong with its output!
[01:17:00 CEST] <Compress0r> wow...color management sucks...
[01:17:05 CEST] <Compress0r> how hard can it be...
[01:17:38 CEST] <Compress0r> so media player classic looks like encoded ffmpeg output, but the whites are slightly more blue...
[01:17:52 CEST] <Compress0r> PowerDVD is as dark as VLC
[01:18:40 CEST] <spl33n_> hey all, i convert video to gif in hight quality but video size is 4.6Mo and gif file 59Mo, how can i reduce this size without modify too much quality ?
[01:18:41 CEST] <Compress0r> but I'm not sure if the blue could be also related to color profiles of my monitor in windows
[01:19:04 CEST] <polyphagia> spl33n_: GIFs aren't for video
[01:19:07 CEST] <emk-> Compress0r: maybe some apps take your monitor Color Management settings into account if you have some...
[01:19:37 CEST] <emk-> nvm, yoe've written it above ;)
[01:24:16 CEST] <Compress0r> omg...the AMD driver also does its magic on the video output...
[01:26:14 CEST] <spl33n_> polyphagia: i don't understand
[01:26:47 CEST] <BtbN> reduce the resolution, make it shorter. That's it.
[01:27:00 CEST] <BtbN> Or reduce the framerate.
[01:27:22 CEST] <Compress0r> okay...media player classic was using the amd video driver output optimizations, vlc don't care about it...
[01:27:41 CEST] <Compress0r> this means media player classic looks exactly like ffplay output now
[01:27:55 CEST] <BtbN> Compress0r, sounds like you are fighting with limited vs. full range HDMI?
[01:28:29 CEST] <Compress0r> PowerDVD and VLC looks more saturated, but darker and whites are overexposed...
[01:28:53 CEST] <BtbN> yes, that's what full range RGB on a screen expecting limited looks like.
[01:29:02 CEST] <Compress0r> yes, looks like an limited/full range issue...I'm still not sure what my input is, limited or full range :)
[01:29:17 CEST] <BtbN> Videos don't care about that.
[01:29:29 CEST] <BtbN> It's the job of your player and graphics driver to figure that out
[01:30:28 CEST] <Compress0r> so strange thing is: original video from my canon eos played in VLC is interpreted in limited range, but after conversion in ffmpeg as full range
[01:31:08 CEST] <Compress0r> actually I guess the video coming from the cam isn't correctly interpreted by VLC and ffmpeg fixes this
[01:31:31 CEST] <BtbN> videos are usualy YUV, they don't realy care about RGB color ranges
[01:31:37 CEST] <Compress0r> thats why I think I've "lost some colors"
[01:36:00 CEST] <Compress0r> but still I think there is a bug in ffmpeg. It's a bit hard to discribe. Just encoding with -i INPUT.MOV -c:v libx264 gives this warnings: No pixel format specified, yuvj420p for H.264 encoding chosen.
[01:36:01 CEST] <Compress0r> Use -pix_fmt yuv420p for compatibility with outdated media players.
[01:36:28 CEST] <Compress0r> and output is still dark
[01:36:47 CEST] <Compress0r> actually specifing -pix_fmt yuv420p makes the output brigher
[01:36:59 CEST] <Compress0r> -color_range 1 or 2 doesn't change anything
[01:37:17 CEST] <Compress0r> that's why I'm confused
[01:37:41 CEST] <Compress0r> yuv420p with color_range 1 should be equal to yuvj420p
[01:44:44 CEST] <durandal_1707> using yuvj pixfmt output should not change anything
[01:45:26 CEST] <durandal_1707> ffplay is not perfect in displaying colors use mpv
[02:00:09 CEST] <Guest86769> :)
[02:00:21 CEST] <Guest86769> Compress0r: hello
[02:01:25 CEST] <Compress0r> hello :)
[02:01:36 CEST] <Guest86769> Compress0r: i used the following command for some conversion from screen recorders to h264 -> -c:v libx264 -pix_fmt yuvj420p -crf 24 -profile:v high444 -level 4.2 -preset fast
[02:02:04 CEST] <Guest86769> Compress0r: idk if it can help :)
[02:02:08 CEST] <Compress0r> I think I fell into an ugly VLC bug!
[02:02:13 CEST] <Guest86769> Compress0r: however yeah
[02:02:21 CEST] <Guest86769> Compress0r: is actually an nvidia cards bug
[02:02:28 CEST] <Guest86769> Compress0r: do you have a nvidia card ?
[02:03:04 CEST] <Guest86769> Compress0r: in this case just try disabling the hardware acceleration pixel format on VLC u will see the colors correctly ;)
[02:03:29 CEST] <Compress0r> If I select Direct2D or Windows GDI as Output Module I see "Full Range" output, if I select Direct3D or OpenGL i see limited range output for the original video
[02:03:36 CEST] <Guest86769> Compress0r: or u can try the trick i said u above to encode with full range yuv but is not a good way of work imho
[02:04:33 CEST] <Guest86769> Compress0r: yeah it's a mess between VLC / video card drivers and os xDD
[02:05:25 CEST] <Compress0r> I just thought its ffmpeg that is messing with my video, but this is a new level of messing around with my videos :)
[02:06:23 CEST] <Guest86769> Compress0r: i think the problems is not of ffmpeg
[02:06:31 CEST] <Guest86769> problem*
[02:06:46 CEST] <Compress0r> no its not...actually ffmpeg solves the problem :)
[02:07:23 CEST] <Compress0r> the videos coming from my Canon EOS look different for the various output modules in VLC, the encoded video looks the same on all modules
[02:09:42 CEST] <Guest86769> lol i see
[02:10:29 CEST] <Guest86769> i'm trying to build the win64 version of ffmpeg with all the libs on
[02:10:32 CEST] <Compress0r> thats what I mean with new level of messing up :)
[02:10:46 CEST] <Guest86769> cuz of this lib aac fdk :p
[02:11:11 CEST] <Guest86769> learning new things for now ^^
[02:11:56 CEST] <Guest86769> well i go sleep
[02:12:00 CEST] <Guest86769> is europe tz here
[02:12:02 CEST] <Guest86769> yawn
[02:12:04 CEST] <Guest86769> night
[02:12:37 CEST] <Guest86769> btw
[02:12:45 CEST] <Guest86769> why need of recompress eos videos?
[02:12:57 CEST] <Guest86769> they are h264 already ^^' to fix the pixel format ?
[02:12:57 CEST] <Compress0r> its too hot too sleep anyways :D
[02:13:10 CEST] <Guest86769> Compress0r: oh well i see u have my same problems xD
[02:13:16 CEST] <Guest86769> Compress0r: where u from me italy :D
[02:13:25 CEST] <Compress0r> germany :)
[02:13:42 CEST] <Guest86769> Compress0r: xD all europe is kinda 37°C
[02:13:50 CEST] <Guest86769> >.<
[02:14:12 CEST] <Compress0r> Mh...but its late. I try to get some sleep  :)
[02:14:14 CEST] <Compress0r> See you
[02:14:17 CEST] <Guest86769> same here
[02:14:19 CEST] <Guest86769> byez
[06:26:15 CEST] <benschwarz> Hi there, I'm using x11grab + ffmpeg to record my screen, but I can't get the videos to play under quicktime.
[06:26:36 CEST] <benschwarz> the command that I'm using is `ffmpeg -y -r 30 -s 1280x1024 -f x11grab -draw_mouse 0 -i :0 -g 30 -preset ultrafast -movflags +faststart -crf 0 -vcodec libx264 -pix_fmt yuv420p video.mp4`
[06:27:12 CEST] <benschwarz> I've read a whole bunch of docs about quicktime, but I still can't seem to get the command right. any pointers?
[06:31:29 CEST] <klaxa> i'm not sure crf 0 is compatible with -pix_fmt yuv420p
[06:31:50 CEST] <klaxa> check ffmpeg's output to see if pix_fmt was changed
[06:31:59 CEST] <klaxa> benschwarz: ^
[06:32:20 CEST] <benschwarz> klaxa: hmm, I'll check
[06:34:00 CEST] <relaxed> benschwarz: you want -framerate 30 instead of -r 30
[06:34:11 CEST] <benschwarz> relaxed: oh yeah? how come?
[06:34:41 CEST] <relaxed> because it's the correct option, see ffmpeg -h demuxer=x11grab
[06:34:57 CEST] <klaxa> ah right, i ran into that earlier today again too
[06:35:06 CEST] <benschwarz> relaxed: oh right !
[06:35:40 CEST] <relaxed> and maybe quicktime can't decode lossless? try -crf 16
[06:36:31 CEST] <benschwarz> anything else look wrong?
[06:36:45 CEST] <benschwarz> & is there a way to get more info from quicktime as to why the video won't open?
[06:37:32 CEST] <relaxed> looks fine otherwise
[06:37:39 CEST] <benschwarz> hey! It works now
[06:39:54 CEST] <benschwarz> Thanks relaxed && klaxa
[07:22:54 CEST] <Piedro> Hi, guys!
[07:23:47 CEST] <Piedro> Got some troubles with MPD seeing my .dts files.
[07:24:15 CEST] <Piedro> He sees one, but not another.
[07:24:51 CEST] <Piedro> FFMPEG output for .dts file visible in MPD says:
[07:25:10 CEST] <Piedro> Input #0, wav, from 'file1.dts'
[07:25:18 CEST] <Piedro> Stream #0:0: Audio: dts (DTS) ([1][0][0][0] / 0x0001), 44100 Hz, 5.1(side), fltp, 1411 kb/s
[07:25:39 CEST] <Piedro> For file not visible in MPD:
[07:25:51 CEST] <Piedro> Input #0, dts, from 'file2.dts'
[07:25:59 CEST] <Piedro> Stream #0:0: Audio: dts (DTS), 44100 Hz, 5.1(side), fltp, 1411 kb/s
[07:27:29 CEST] <Piedro> The question is what is the meaning of wav and dts in Input #0 line and how could I change it with FFMPEG?
[07:53:04 CEST] <Piedro> Still looking for an answer :3
[09:49:15 CEST] <Piedro> Anyone alive?
[09:54:17 CEST] <Fjorgynn> no
[10:19:55 CEST] <Piedro> :-(
[10:20:06 CEST] <Piedro> Anyone undead to give me some help?
[10:26:32 CEST] <durandal_1707> mpd bug?
[10:31:15 CEST] <nyuszika7h> why does reencoding a video (-c:v libx265 -c:a copy -c:s copy) change the subtitle font? (ASS)
[10:31:49 CEST] <nyuszika7h> other options (probably irrelevant): -preset veryfast -crf 23 -t 00:00:10
[10:31:55 CEST] <Nitori> possibly the fonts where embedded and not copied over?
[10:37:52 CEST] <Nitori> @nyuszika7h
[10:37:58 CEST] <nyuszika7h> maybe
[10:38:31 CEST] <Nitori> have you checked? (ffprobe and see if there are fonts embedded in source and output)
[10:44:31 CEST] <nyuszika7h> sec
[10:45:09 CEST] <nyuszika7h> input: http://dpaste.com/0JGTPS8
[10:46:34 CEST] <nyuszika7h> output doesn't have the font
[10:46:39 CEST] <Nitori> yea
[10:46:44 CEST] <Nitori> so, according to this: https://trac.ffmpeg.org/wiki/How%20to%20use%20-map%20option#Example4
[10:46:57 CEST] <Nitori> you should be able to just do: -map 0 -c copy -c:v libx265 ....
[10:47:04 CEST] <Nitori> to copy everything but reencode the video
[10:52:09 CEST] <nyuszika7h> yeah that works, thanks
[11:53:04 CEST] <nyuszika7h> is there any way to make ffmpeg x264 encode not lag my system so much? I set ffmpeg.exe to low priority in task manager but that didn't help
[11:53:57 CEST] <durandal_1707> use faster preset?
[13:01:02 CEST] <user> : 3
[13:01:25 CEST] <Guest14853> hello
[13:02:10 CEST] <Guest14853> i was wondering there's a way to get the size of single streams via ffprobe?
[13:02:34 CEST] <Guest14853> because the only size it shows is the size of whole file, is something i can actually know already with my os XD
[13:02:51 CEST] <Guest14853> instead i want to know how much the audio part for example weights
[13:03:38 CEST] <Guest14853> i could -map 0:1 stream -a:copy -> and check the size of new file but i think is something stupid to do :D
[13:37:11 CEST] <lookatmeyou> help
[13:37:41 CEST] <lookatmeyou> how to convert a raw nv21 video to bgr24 uncompressed avi?
[13:37:52 CEST] <lookatmeyou> ffmpeg -s 480x640 -pix_fmt nv21 -i video.nv21 -vcodec rawvideo -pix_fmt bgr24 video.avi
[13:38:25 CEST] <lookatmeyou> I use this command, but it prints "video.nv21: Invalid data found when processing input"
[13:38:47 CEST] <lookatmeyou> Is there anything wrong?
[13:40:26 CEST] <lookatmeyou> Hello?
[13:42:52 CEST] <Filarius> try to specify input codec too, not only pixel format
[13:43:19 CEST] <Guest14853> Filarius: hello
[13:44:38 CEST] <Filarius> add -f rawvideo
[13:45:10 CEST] <lookatmeyou> OK, let me try
[13:46:42 CEST] <Filarius> hello Guest, and I`m too noob to give direct answer. ffprobe can make json data output or else formats, try from this direction
[13:46:42 CEST] <lookatmeyou> It worked. Thank you very much!
[13:47:57 CEST] <Filarius> np
[14:26:00 CEST] <Filarius> Do anybody know nice app for Windows where I can look at graphs of rate factor, quality and bitrate, what changes during file ?
[15:01:59 CEST] <Guest14853> Filarius: hello
[15:02:11 CEST] <Guest14853> Filarius: maybe u have a solution to my question above?
[15:02:23 CEST] <Filarius> no
[15:02:24 CEST] <Guest14853> Filarius: i'm trying with ffprobe to get the size of single streams
[15:02:37 CEST] <Filarius> try to look at ffprobe json output
[15:02:45 CEST] <Guest14853> hmm
[15:02:47 CEST] <Guest14853> ok
[15:04:00 CEST] <copulator> yow
[15:04:23 CEST] <copulator> how do i mux x264 and mp3 into mp4?
[15:04:41 CEST] <Guest14853> nope
[15:04:41 CEST] <copulator> i use -acodec:copy and -vcodec:copy but it still re-encodes shit
[15:04:45 CEST] <Guest14853> it doesn't work
[15:05:43 CEST] <Guest14853> copulator: try using also -map 0:0 -map 0:1
[15:06:11 CEST] <lookatmeyou> Help, I use this command "ffmpeg -s 352x288 -f rawvideo -pix_fmt nv21 -r 15 -i Qq.nv21 -vcodec rawvideo -vframes 50 -pix_fmt bgr24 Qq4.avi"
[15:06:29 CEST] <Guest14853> and?
[15:06:44 CEST] <lookatmeyou> to convert a nv21 rawvideo to bgr24 avi uncompressed rawvideo
[15:07:21 CEST] <lookatmeyou> it works fine, except add metadata to the output file which I don't want
[15:07:51 CEST] <lookatmeyou> like metadata: encoder         : Lavf56.13.100
[15:08:39 CEST] <lookatmeyou> matlab aviread can't read this kind of video with metadata.
[15:09:07 CEST] <Guest14853> lookatmeyou: i think you could follow this:
[15:09:13 CEST] <Guest14853> lookatmeyou: http://askubuntu.com/questions/139570/how-do-i-remove-all-metadata-from-a-quicktime-movie-file
[15:09:34 CEST] <lookatmeyou> Let me see
[15:12:01 CEST] <lookatmeyou> like this command? "ffmpeg -i Qq3.avi -map_metadata -1 -vcodec copy Qq5.avi"
[15:12:30 CEST] <Guest14853> i guess simply -map_metadata -1 does the trick
[15:12:30 CEST] <lookatmeyou> No, the output Qq5.avi still has meta_data
[15:12:44 CEST] <Guest14853> lookatmeyou: try just do it in sequence
[15:12:49 CEST] <Guest14853> first encode the stuff
[15:13:09 CEST] <Guest14853> then another passage into ffmpeg with just video and audio copy and the metadata mapping out
[15:15:04 CEST] <Guest14853> i read the stuff inside that link and it seems u have to do some extra passages to wipe out all metadata
[15:16:11 CEST] <lookatmeyou> A bit of trouble, Is there a simple way?
[15:16:59 CEST] <Guest14853> i think not as always with metadata stuff
[15:17:09 CEST] <Guest14853> same for me with exiftool i had to prepare a bat myself
[15:17:32 CEST] <Guest14853> in order to copy a blank xml file preset to the images in order to wipe all out definitively
[15:17:40 CEST] <Guest14853> prepare a nice bat file and u will live happy
[15:17:51 CEST] <Guest14853> all the files u convert them are post -> nuked metadata with all the procedure
[15:19:57 CEST] <lookatmeyou> Thanks, I still want to find a simple way.
[15:27:12 CEST] <koz_> What should I add to my conversion command if I get this: Video uses a non-standard and wasteful way to store B-frames ('packed B-frames'). Consider using the mpeg4_unpack_bframes bitstream filter to fix it.
[15:28:13 CEST] <Guest14853> koz_: i suppose it suggests a filter
[15:28:22 CEST] <Guest14853> like
[15:28:33 CEST] <Guest14853> -filter:v "mpeg4_unpack_bframes"
[15:28:41 CEST] <Guest14853> try in case
[15:28:45 CEST] <Guest14853> and see if it works
[15:29:00 CEST] <koz_> Guest14853: OK. What will this supposedly do?
[15:29:20 CEST] <Guest14853> koz_: https://www.ffmpeg.org/ffmpeg-bitstream-filters.html there
[15:29:56 CEST] <koz_> Ah. So 'fix Losedows shite', got it.
[15:30:26 CEST] <Guest14853> but need to be used as that one say
[15:30:29 CEST] <Guest14853> ffmpeg -i INPUT.avi -codec copy -bsf:v mpeg4_unpack_bframes OUTPUT.avi
[15:32:15 CEST] <koz_> Thanks Guest14853!
[15:32:34 CEST] <Guest14853> koz_: u welcome
[16:19:01 CEST] <chaz321> Hello.  I have a filter_complex question.  I am using ffmpeg -drawtext with timecode.  The text is displayed as:  09:25:44:12  Is it possible to remove the frame field from the display?  We would prefer if the text was displayed as:  09:25:44
[16:32:55 CEST] <maslen> How can I rotate a video 90 degrees? If I try using vf="rotate=PI/2", it cuts off part of the video.
[16:33:19 CEST] <maslen> (chops off their heads,, so to speak)
[16:42:19 CEST] <klaxa> maslen: -vf transpose
[16:42:34 CEST] <klaxa> see: https://ffmpeg.org/ffmpeg-filters.html#transpose
[17:01:37 CEST] <maslen> Strange. So the issue I'm having is that even though VLC plays it properly (portrait), WMP plays it in landscape, which is 90 degrees off :(
[17:02:40 CEST] <maslen> Is there some metadata that I'm not aware of? Or is WMP just doing its own thing.
[17:20:18 CEST] <klaxa> it's probably wmp
[17:20:28 CEST] <maslen> So nothing I can do then. Oh well.
[18:22:55 CEST] <nashgul> hi all, how can i see the parameters of each preset for h264 codec?
[18:23:02 CEST] <nashgul> my OS is Archlinux
[18:23:30 CEST] <nashgul> i'm looking on the web (ffmpeg.org, the wiki, ...) but i don't find anything
[18:24:05 CEST] <nashgul> h264 presets: ultrafast, veryfast, medium, faster, slow, ....
[18:24:22 CEST] <JEEBsv> those are built-in things in libx264
[18:25:06 CEST] <nashgul> yes, but on the wiki appears this: To list all possible internal preset and tunes:
[18:25:07 CEST] <nashgul> ffmpeg -f lavfi -i nullsrc -c:v libx264 -preset help -f mp4 -
[18:25:27 CEST] <nashgul> i execute that command but only returns an error
[18:26:39 CEST] <JEEBsv> yes, it will
[18:26:52 CEST] <JEEBsv> and that is a hack
[18:27:04 CEST] <JEEBsv> it will list you all the presets and tunes if you set an invalid value
[18:27:10 CEST] <JEEBsv> "help" is an invalid value
[18:27:20 CEST] <nashgul> ummm
[18:27:26 CEST] <JEEBsv> so libx264 will output them, as you can see with the lines starting with [libx264]
[18:28:13 CEST] <nashgul> JEEBsv: what is the command to see the presets?
[18:28:53 CEST] <JEEBsv> that thing you just noted happens to work, just see the lines starting with [libx264
[18:31:01 CEST] <nashgul> JEEBsv: i see those lines, but what i want to know is: what are the parameters stablished for each preset?
[18:32:39 CEST] <JEEBsv> try x264 --fullhelp &> x264_settings.txt
[18:33:03 CEST] <JEEBsv> not sure how much use you will get out of the details of the presets, though
[18:33:09 CEST] <JEEBsv> they were designed relatively well
[18:36:50 CEST] <nashgul> JEEBsv: thanks, x264 shows me, more or less, what i want
[18:59:28 CEST] <lvml> Hi, I would like to instruct ffmpeg to use "libdcadec" as a decoder (rather than "dca") for decoding all DTS content. However, I found no other way to do this than by modifying the source code (registering "dca" as only an encoder in allcodecs.c). Isn't there any way to configure a decoder preference/priority with ffmpeg?
[19:04:24 CEST] <JEEBsv> there is a thing for that, although people tend to just disable the dca decoder
[19:07:40 CEST] <lvml> "Disable the dca decoder" - without source code modification? How?
[19:10:47 CEST] <JEEBsv> configure script option
[19:11:24 CEST] <JEEBsv> --disable-decoder=dca
[19:11:32 CEST] <lvml> Ok - but that also disables dca as an encoder, right, and since libdcadec can only decode, you lose the ability to encode dca then.
[19:11:49 CEST] <JEEBsv> no, that would only disable the decoder as far as I can tell :P
[19:34:51 CEST] <bmcginty> Does anyone know if there's a way to have FFMpeg determine an output extension of a file automatically? Basically, I'm downloading a file, audio or video, and I don't know what internal codec it's using. However, All I'm interested in is the audio, so I use -acodec copy, and set the output extension to what ffprobe returns. I can't run ffprobe on a downloading file as far as I know, and if I don't set FFMpeg's output ...
[19:34:57 CEST] <bmcginty> ... extension/format correctly, the audio doesn't get just copied, it gets copied and transcoded, which is slow and wasteful for my needs. I can reexplain this if it's unclear.
[19:56:10 CEST] <bmcginty> Ah! I can pipe the copied audio into the nut container format, at least with what I've tried so far. FFMPeg rocks!
[20:05:30 CEST] <klaxa> you could also try matroska
[20:05:51 CEST] <klaxa> not sure nut is implemented widely, then again if things are using libavformat, they probably support nut
[20:15:28 CEST] <Kaedenn> Can I ask questions about avconv here?
[20:17:09 CEST] <Kaedenn> Well I can use either, really. I have a bunch of pictures, frame_%04d.png, that I wish to combine into a single .avi. Initially, everything is fine, but the resulting AVI has a bunch of dithering effects and is quite low quality compared to the pngs.
[20:18:23 CEST] <Kaedenn> My command is, avconv -f image2 -i frames_0%03d.png -r 30 4_random_short.avi
[20:19:13 CEST] <Kaedenn> How do I increase the quality of the resulting AVI?
[20:19:50 CEST] <durandal_1707> use different codec and ffmpeg
[20:20:13 CEST] <Kaedenn> I thought ffmpeg was deprecated, and what codec should I use?
[20:20:43 CEST] <sfan5> either use a different codec like h264 or increase quality
[20:21:47 CEST] <BtbN> It's quite amazing this deprecated-brainwashing is still in place and works.
[20:22:16 CEST] <Kaedenn> I run ffmpeg, and it states: *** THIS PROGRAM IS DEPRECATED ***
[20:22:16 CEST] <Kaedenn> This program is only provided for compatibility and will be removed in a future release. Please use avconv instead.
[20:22:26 CEST] <sfan5> see the link posted by fflogger
[20:24:09 CEST] <Kaedenn> ...are you serious.
[20:24:10 CEST] <Kaedenn> x_x
[20:24:40 CEST] <Kaedenn> So the version of ffmpeg I have is a wrong one?
[20:25:13 CEST] <sfan5> you have Libav instead of FFmpeg installed
[20:26:54 CEST] Action: Kaedenn downloads the static build
[20:28:38 CEST] <Kaedenn> Thank you.
[20:28:46 CEST] <Kaedenn> The manpages now state how to do what I want.
[20:28:53 CEST] <Kaedenn> ffmpeg -h encoder=libx264 <rest of my args> # Yes?
[20:29:22 CEST] <sfan5> that shows the help
[20:29:26 CEST] <Kaedenn> ...oh.
[20:29:28 CEST] <Kaedenn> Duh.
[20:29:29 CEST] <Kaedenn> XD
[20:29:56 CEST] <Kaedenn> Okay so I have output/frames_%04d.png and media/Bowser.wav that I'd like to combine into a movie.
[20:30:04 CEST] <sfan5> if you want to use libx264 pass -c:v libx264 to ffmpeg
[20:30:29 CEST] <Kaedenn> Has anyone made a graphical UI to ffmpeg?
[20:30:38 CEST] <Kaedenn> For idiots like me who have difficulty wading through options.
[20:33:28 CEST] <Kaedenn> Woo, using libx264 works like a charm.
[20:34:09 CEST] <Kaedenn> How do I add a wav file to my output?
[20:37:42 CEST] <sfan5> just add -i <your wav file>
[20:39:48 CEST] <Kaedenn> ...the images are upside-down
[20:40:22 CEST] <Kaedenn> Oh that's amusing, they're upside-down in my generator too.
[20:41:36 CEST] <Kaedenn> Oh hey I think I found a bug in SDL. It's probably between the keyboard and the chair, but it's a bug!
[20:41:39 CEST] <Kaedenn> Thank you all for your help.
[21:34:12 CEST] <Kaedenn> And, lastly, how do I make the program exit after processing my input at 30fps, and not at the end of the audio track?
[21:34:47 CEST] <BtbN> -shortest
[21:46:06 CEST] <^bit> Hi, how can I force a smaller resolution when recording a live feed? This is the command I'm using currently http://pastebin.com/USvW9i0X
[22:01:35 CEST] <BtbN> you can't without re-encoding.
[22:07:04 CEST] <Guest8503> hello guys
[22:07:43 CEST] <^bit> BtbN: you can't do it in real time while recording the stream?
[22:07:48 CEST] <Guest8503> I'm trying to transcode from h264 to dnxhd
[22:08:29 CEST] <BtbN> if you have enough cpu power, of course.
[22:08:42 CEST] <Guest8503> i don't know why i'm still getting this msg:[dnxhd @ 00000000030c9800] picture could not fit ratecontrol constraints, increase qmax
[22:37:01 CEST] <^bit> BtbN: but I'm looking for the command to do that with
[22:46:24 CEST] <antiatom> Hi all, I am using Kdenlive, and I notice that the render profiles have a different syntax than FFmpeg does on the CLI.  I am trying to figure out how to best choose encoding options for x264 and Opus in MKV file for output
[22:51:00 CEST] <Chuckles32> Hello.  I have a filter_complex question.  I am using ffmpeg -drawtext with timecode.  The text is displayed as:  09:25:44:12  Is it possible to remove the frame info from the display?  We would prefer if the text was displayed as:  09:25:44
[22:57:32 CEST] <durandal_1707> Chuckles32: open feature request on bug tracker
[23:00:51 CEST] <Chuckles32> durandal_1707:  OK, so there is no native support for dropping the frame info from the timecode.  Perhaps there is another way to skin the cat....  We are just looking to timestamp videos.  We are running in a bash script and we are passing our start time to FFMPEG as timecode variables, but if there's another way to draw a clock on the video, i'd love to know....
[23:03:06 CEST] <durandal_1707> you can write into file and let drawtext read from it
[00:00:00 CEST] --- Mon Jul  6 2015

More information about the Ffmpeg-devel-irc mailing list