[Ffmpeg-devel-irc] ffmpeg.log.20150706

burek burek021 at gmail.com
Tue Jul 7 02:05:02 CEST 2015

[08:11:55 CEST] <bmcginty> klaxa: thanks for your answer earlier today. I'll try that if I run into any issues with the nut container.
[11:25:58 CEST] <BtbN> https://bpaste.net/show/54267f1d391b Anyone got an idea what's going on here? Where is that strange DTS coming from? Is it because the RPi doesn't have a propper RTC?
[11:26:11 CEST] <BtbN> The resulting rtmp stream doesn't play too well
[11:34:57 CEST] <BtbN> hm, just noticed, the setpts filter propably does nothing, as i'm not re-encoding
[11:39:02 CEST] <hash> How to convert mp42 to qt ?
[11:39:44 CEST] <hash> Need any bitstream filter ?
[12:10:29 CEST] <flying_toaster> hi there
[12:11:22 CEST] <flying_toaster> i'm trying to decode a EXR file sequence using ffmpeg, and I observe a strange behaviour
[12:12:36 CEST] <flying_toaster> using ffmpeg -i sequence%3d.exr -pix_fmt yuv420p -f rawvideo out.yuv, the decoder seems to loop over the 4/5 first images
[12:13:32 CEST] <flying_toaster> changing -threads parameter affects the loop size : -threads 1 => still image, -threads 2 => loops over 2 images, and so on
[12:14:12 CEST] <flying_toaster> Maybe a bug in the thread management of the EXR decoder ?
[12:17:47 CEST] <durandal_170> flying_toaster: what you mean by loop?
[12:18:35 CEST] <flying_toaster> my sequence is 2404 different EXR files
[12:18:57 CEST] <durandal_170> try -thread_type slice
[12:19:04 CEST] <flying_toaster> but the decoder output file1, file2, file 1, file 2, file 1, ... and so on
[12:23:13 CEST] <durandal_170> flying_toaster: what if you use slice threads?
[12:24:09 CEST] <flying_toaster> I'm trying
[12:25:24 CEST] <flying_toaster> ./ffmpeg -threads 2 -> loops over 2 frames
[12:25:33 CEST] <flying_toaster> ./ffmpeg -thread_type slice -threads 2 -> still picture
[12:25:44 CEST] <flying_toaster> so it seems to be worse
[12:28:29 CEST] <durandal_170> what ffmpeg version?
[12:29:17 CEST] <flying_toaster> 2.6.2, but I am trying the latest 2.7.1
[12:30:21 CEST] <flying_toaster> it's currently building :)
[12:35:25 CEST] <flying_toaster> oops
[12:35:37 CEST] <flying_toaster> it seems to be working in the latest version
[12:35:40 CEST] <flying_toaster> my mistake
[12:38:07 CEST] <durandal_170> flying_toaster: both frame and slice ?
[12:39:17 CEST] <flying_toaster> without any thread options, it does work
[12:39:25 CEST] <flying_toaster> i'm testing with options
[12:39:48 CEST] <flying_toaster> slice : ok
[12:40:40 CEST] <flying_toaster> frame : ok as well
[16:43:46 CEST] <Guest4514> hey guys I'm having some problems with the ffmpeg libs, when i use swr_convert to downsample,convert formats, and change channel layout I get allot of noise with some of the audio comming through. And sorry but pastebin is blocked http://pasted.co/b6ff2cd4
[16:47:48 CEST] <durandal_170> Guest4514: perhaps sample format for input is wrong
[16:52:25 CEST] <Guest4514> this works for the most part when i dont change the rate/channel_layout and AV_SAMPLE_FMT_FLTP is the output for av_decode_audio_4()
[20:29:20 CEST] <bivo123> Hello, I'm trying to compile ffmpeg as a stand alone package which can be distributed to any system running OSX 10.8.5. I'm using the following configure on a OSX system.
[20:29:22 CEST] <bivo123> ./configure --disable-gpl --disable-nonfree --enable-shared --disable-static --prefix=./ --bindir=./ --libdir=./ --enable-libmp3lame --disable-ffplay --disable-ffprobe --pkg-config=pkg-config --disable-sdl
[20:31:42 CEST] <bivo123> ffmpeg runs fine on the build system, but once I copy the build directory to a different OSX system, ffmpeg fails looking for newer version of system libraries. I tried to copy all the libraries localy to that folder and add configure the library path to look first in the flix folder, but that caused some wrong library versions to load up
[20:34:49 CEST] <bivo123> I've built ffmpeg the same way for windows and linux and it works fine. Any hints will be appreciated.
[20:46:05 CEST] <Eduardo_1> hello, i would try changing "--disable-static" for "--enable-static"
[22:23:38 CEST] <Nolski> Does anyone ever have the issue when overlaying video using the overlay filter, that the overlay video freezes on a frame?
[22:24:14 CEST] <durandal_170> no, how to reproduce?
[22:25:20 CEST] <Nolski> lemme write up a doc on pastebin
[22:30:08 CEST] <Nolski> Also, is there an encoding/container that's best to use when doing lots of re-encoding I have to use filter_complex multiple times on the same video and I'm worried that it might cause issues with the end result
[22:31:06 CEST] <durandal_170> try nut as container
[22:31:40 CEST] <Nolski> nut? I've never heard of it
[22:32:26 CEST] <durandal_170> its ffmpeg own format
[22:42:31 CEST] <heap__> hi
[22:42:32 CEST] <heap__> any idea
[22:42:33 CEST] <heap__> /usr/bin/ffmpeg: relocation error: /usr/bin/ffmpeg: symbol avformat_alloc_output_context2, version LIBAVFORMAT_56 not defined in file libavformat.so.56 with link time reference
[22:42:42 CEST] <heap__> compiled on arm
[22:48:30 CEST] <Nolski> durandal_170: here is the repro steps btw https://pastebin.mozilla.org/8838714
[22:49:27 CEST] <Nolski> holy crap. re-encoding on .nut is so much faster than .webm
[22:50:04 CEST] <kepstin-laptop> probably just has to do with the video codec chosen, libvpx (vp8) used in webm is slow to encode.
[22:50:46 CEST] <Nolski> makes sense. I am however still getting the same issue with the video freezing on the overlaid video even with .nut
[22:51:22 CEST] <kepstin-laptop> my best guess is that there's something weird about the timestamps on the input video; either a large jump or they go backwards
[22:51:28 CEST] <kepstin-laptop> I'm not sure the overlay filter handles that well
[22:51:55 CEST] <Nolski> Hm. Alright
[22:52:07 CEST] <Nolski> I'm worried that it might be because I'm overlaying multiple times
[22:52:13 CEST] <heap__> any idea?
[22:52:23 CEST] <kepstin-laptop> that might not be it tho I'd have to see the full thing. hmm.
[22:52:44 CEST] <Nolski> Yeah, it's a bit tough because the whole process is packaged in a python application
[22:52:51 CEST] <kepstin-laptop> Nolski, oh, hmm, you're using the 'enable' option on the overlay filter in your example?
[22:52:56 CEST] <Nolski> kepstin-laptop: yeah
[22:53:01 CEST] <kepstin-laptop> and that is enough to repro the issue?
[22:53:27 CEST] <kepstin-laptop> do you still get the video freeze without the enable option on the overlay filter?
[22:53:37 CEST] <Nolski> Lemme check that right now
[22:58:11 CEST] <Nolski> kepstin-laptop: if I remove enable it still freezes
[22:59:05 CEST] <Nolski> wait. Sorry, it does work. It renders the last frame over everything
[23:01:24 CEST] <kepstin-laptop> hmm. when I try that here, i'm getting a lot of non-monotonous timestamps (i.e. backwards steps in timestamps) :/
[23:01:48 CEST] <Nolski> Hmm... Do you think it has something to do with the video encoding?
[23:02:10 CEST] <kepstin-laptop> on the other hand, I do get a full 10s video output with no apparent hang in either stream
[23:04:37 CEST] <kepstin-laptop> oh, hmm. the 'face' video is 10 seconds long, the 'browser' video is 20 seconds
[23:05:00 CEST] <kepstin-laptop> so the overlay filter will, depending on other settings, keep rendering the last frame of the shorter video while the longer one plays on
[23:05:11 CEST] <kepstin-laptop> (this is configurable, see the docs)
[23:05:54 CEST] <Nolski> Hmm.. Okay, is it possible to change when the overlaid video starts playing other than enable?
[23:07:08 CEST] <kepstin-laptop> use the -ss option on one of the input videos if you want to change what point in the video it starts playing from
[23:07:54 CEST] <kepstin-laptop> (or you could play with trim or maybe setpts would work too)
[23:08:32 CEST] <kepstin-laptop> the overlay filter does its best to take frames from the two streams that have matching pts, to keep everything synced.
[23:09:42 CEST] <Nolski> Hmm interesting. So If I did -ss 00:00:06 instead of using enable='between(t,6,18)' it should have pretty much the same effect?
[23:10:04 CEST] <Nolski> I wasn't sure if you could use -ss with filters
[23:10:04 CEST] <kepstin-laptop> well, what that enable does is start the overlay at 6 seconds into the output
[23:10:18 CEST] <kepstin-laptop> i.e. it does 6 seconds of pass-through, then turns on the overlay
[23:10:23 CEST] <kepstin-laptop> i think
[23:10:29 CEST] <kepstin-laptop> haven't actually used enable on overlay before :/
[23:11:26 CEST] <Nolski> Yeah, everything I've read on enable makes it seem like an alternative to ss but Its hard to see when one should be used over the other
[23:11:45 CEST] <kepstin-laptop> you'd want to do something like ffmpeg -i face.webm -ss 6 browsing.webm -filter_complex overlay=x=289:shortest=1 out.webm
[23:11:58 CEST] <heap__> hey
[23:11:58 CEST] <heap__> ?
[23:11:59 CEST] <heap__> /usr/bin/ffmpeg: relocation error: /usr/bin/ffmpeg: symbol avformat_alloc_output_context2, version LIBAVFORMAT_56 not defined in file libavformat.so.56 with link time reference
[23:12:03 CEST] <heap__> any idea whats that?
[23:12:15 CEST] <kepstin-laptop> that should make you a 10 second video with the full face video having the seconds 6-16 of the browser video overlaid.
[23:14:04 CEST] <kepstin-laptop> (that command's missing a -i in front of browsing.webm, but I'm sure you noticed that and fixed it, right? :)
[23:15:35 CEST] <Nolski> haha right
[23:16:32 CEST] <Nolski> Okay, so not only does SS not seek to 6 seconds into the video before rendering the overlay, it renders it starting at 0, and freezes as if I were using enable
[23:16:57 CEST] <kepstin-laptop> fun. there must be something really screwy with the pts in those videos :/
[23:17:26 CEST] <kepstin-laptop> could always try throwing a 'setpts=PTS-STARTPTS' filter on each of the input videos before letting overlay see them.
[23:17:53 CEST] <kepstin-laptop> and maybe use a trim (after the setpts, before the overlay) instead of -ss if the seeking doesn't work.
[23:18:19 CEST] <kepstin-laptop> makes your filtergraph a lot more complex, but if you're script-generating them anyways...
[23:18:33 CEST] <Nolski> Yeah, the videos were fed through a "video converting service" called vidly. I'll try a couple of other containers for the original videos and there's also all of those things
[23:18:59 CEST] <Nolski> At least I still have a lot of other options :) I'll mess around for a bit more. Thanks for helping out
[23:23:25 CEST] <heap__> well
[23:23:28 CEST] <heap__> one report here bug
[23:23:33 CEST] <heap__> but apparently noone cares?
[23:24:26 CEST] <kepstin-laptop> heap__, is that an ffmpeg you built yourself?
[23:24:27 CEST] <durandal_170> report on trac there everybody care
[23:26:21 CEST] <heap__> kepstin-laptop: yes.
[23:26:25 CEST] <heap__> kepstin-laptop: why?
[23:27:20 CEST] <kepstin-laptop> well, it's a build issue, so if you hadn't built it yourself the response would be "complain to the person who built it" ;)
[23:27:44 CEST] <heap__> i built it
[23:27:48 CEST] <kepstin-laptop> but yeah, as it is, it might be best to file a ticket on trac. Include some details about your os and maybe attach the configure output.
[23:27:48 CEST] <heap__> how u know its build issue?
[23:31:47 CEST] <heap__> hm
[23:33:25 CEST] <heap__> more then helpful
[23:35:04 CEST] <Nolski> can you do multiple filters in -filter_complex?
[23:35:14 CEST] <pzich> yup
[23:35:17 CEST] <pzich> use a semicolon
[23:35:40 CEST] <kepstin-laptop> Nolski, you'll want to read the filter syntax introduction at the top of the ffmpeg-filters doc
[23:36:05 CEST] <pzich> weren't you already using multiple filters in your trim/concat thing?
[23:36:57 CEST] <Nolski> yup, sorry, just looked back and noticed right after I typed that. used ffmpeg for so many things in the last week that some of it has stuck and some of it hasn't
[23:37:20 CEST] <pzich> yeah, it can certainly get overwhelming
[23:48:05 CEST] <heap__> ok
[23:48:11 CEST] <heap__> i have 2 libs in system
[23:48:18 CEST] <heap__> /usr/lib/arm-linux-gnueabihf/libavformat.so.56.1.0
[23:48:24 CEST] <heap__> /usr/lib/libavformat.so.56.36.100
[23:48:45 CEST] <heap__> question is if i agains which one i compile ffmpeg?
[23:55:19 CEST] <heap__> ok
[23:55:31 CEST] <heap__> how should i complie ffmpeg? agains what libav library?
[00:00:00 CEST] --- Tue Jul  7 2015

More information about the Ffmpeg-devel-irc mailing list