[Ffmpeg-devel-irc] ffmpeg.log.20150715

burek burek021 at gmail.com
Thu Jul 16 02:05:01 CEST 2015

[03:05:07 CEST] <well0ne> c_14, thank you :)
[03:05:09 CEST] <well0ne> it worked!
[03:30:13 CEST] <Juzzy> can anyone assist with multicast ffmpeg: ffmpeg -f dshow -i audio="Microphone (2- High Definition Audio Device)" -acodec libmp3lame -ac 2 -ar 44100 -f rtp -ab 128k rtp://
[03:30:37 CEST] <Juzzy> returns: av_interleaved_write_frame(): Unknown error
[03:40:37 CEST] <Juzzy> think i got it
[04:18:57 CEST] <Juzzy> cant get rid of the delay
[06:32:34 CEST] <dustfinger> I am running gentoo. What use flag do I need to set to build ffmpeg with support for the huffyuv codec?
[06:34:41 CEST] <klaxa> huffyuv should be built-in by default afaik
[06:35:10 CEST] <dustfinger> Hmm. Okay, when I run ffmpeg -formats | less and search for huff I don't find anything.
[06:35:22 CEST] <klaxa> you should try ffmpeg -codecs | less
[06:36:00 CEST] <dustfinger> klaxa: Thank you. You are correct :-)
[06:36:10 CEST] <klaxa> :)
[08:10:52 CEST] <dustfinger> I see that ffmpeg does not support lagarith encoding. I am wanting to record a large amount of video from my webcam and then edit it using cinelerra. I am reading that huffyuv produces very large files because it is lossless. What is the best codec for me to use that provides a nice balance between compression and being compliant with editors?
[08:12:11 CEST] <pentanol> dustfinger I know lagarith filter and use it with IM, but codec, hm
[08:12:44 CEST] <pentanol> ops missed with lagrange
[08:16:53 CEST] <dustfinger> pentanol: What is IM? I am completely new to codecs and containers.
[08:20:12 CEST] <dustfinger> pentanol: oh I see. lagrange is the filter that you use and you were thinking that lagarith was the filter and not a codec.
[09:07:56 CEST] <tester_> I need help with ffmpeg webcam capture. I use a logitech hd c270h. When I capture video using ffmpeg, I get a lagging video in which I can slightly see trails when I move.
[09:08:34 CEST] <tester_> It is present in 720p, 480p, 360p, even in 240p modes
[09:15:29 CEST] <tester_> Can anyone help with the problem?
[09:45:38 CEST] <Quixxx> Hmm, what flags should I be adding to get better encodes with libvpx (VP8) two pass? The second pass isn't quite pegging my cores.
[10:41:10 CEST] <brontosaurusrex> Quixxx: cq mode?
[10:41:20 CEST] <brontosaurusrex> http://www.webmproject.org/docs/encoder-parameters/
[10:45:50 CEST] <brontosaurusrex> Quixxx: my extremly old droplet has this http://paste.debian.net/plain/282499
[10:46:04 CEST] <brontosaurusrex> Quixxx: I do remember wasting a lot of time to get to that
[11:04:15 CEST] <thebombzen> I have a peculiar case.
[11:04:55 CEST] <thebombzen> I have a matroska file that's got an h264 stream inside. When I play this file with ffplay, it plays fine. However, ffmpeg -i cannot read it well.
[11:06:17 CEST] <thebombzen> The h264 stream inside of the mkv has a mistake and ffmpeg -i is having trouble detecting the parameters such as the pixel format (which is yuv420p10le). Attempting -codec copy, the resulting file was incorrect and had durations jump.
[11:06:35 CEST] <thebombzen> However, for some reason ffplay is able to play the file impeccably. I don't understand the issue.
[11:15:00 CEST] <thebombzen> FFmpeg outputs - http://pastebin.com/ZZeDPRLH
[11:16:22 CEST] <thebombzen> This is the FFplay output of it playing fine - http://pastebin.com/tjJUuge7
[11:16:58 CEST] <thebombzen> Is this a known phenomenon?
[11:17:34 CEST] <chungy> looks like the pixel format isn't being detected properly. might want to contact the dev mailing list and provide a sample of a bad file
[11:17:51 CEST] <chungy> this one or any other (I imagine the program or device that generated it would repeat the behavior...)
[11:18:12 CEST] <chungy> weird that ffplay would work on you if it gives the same error message.
[11:24:13 CEST] <PeterNT> hi guys, how do i use the Intel Quick Sync function with ffmpeg under linux? seems like there is no real wiki
[11:35:20 CEST] <thebombzen> chungy: the file is too large. If I just truncate it with mundane unix tools like dd, will that be acceptable?
[11:36:05 CEST] <thebombzen> (that is, truncate it with file operations, not with any kind of specialized program like ffmpeg)
[11:36:18 CEST] <chungy> mkvmerge is probably better, it can split files codec-agnostically (matroska is designed for that)
[11:36:25 CEST] <chungy> and still output valid mkv files :P
[11:36:37 CEST] <chungy> might want to ask the mailing list first.
[11:36:44 CEST] <thebombzen> ah k.
[11:36:53 CEST] <chungy> including with a detailed report of what you've done
[11:37:02 CEST] <thebombzen> basically what's above?
[11:37:06 CEST] <chungy> yea
[12:39:48 CEST] <iomari> greetings, where can I find info on using ffmpeg with the nvidia jetson tk1? I'm particularly interested in how to use the many cores that it comes with.
[12:57:04 CEST] <AstralStorm> hello, I've a question about libswresample and its out_samples
[12:57:19 CEST] <AstralStorm> what happens if there's not enough input to produce that many samples?
[12:58:07 CEST] <PeterNT> hi guys, how do i use the Intel Quick Sync function with ffmpeg under linux? seems like there is no real wiki
[12:58:35 CEST] <BtbN> It's pre-release, so that's not too surprising.
[12:58:54 CEST] <BtbN> Basicaly get the Intel media SDK, and compile ffmpeg with mfx enabled
[12:59:27 CEST] <PeterNT> ok, i always get a "libmfx" not found with pkg
[12:59:44 CEST] <PeterNT> tought there is another way but seems there isnt
[13:24:31 CEST] <kritzikratzi> hi! i'm trying to resample from the planar s16 format to an interleaved float32 format so that i can feed data into rtAudio
[13:24:39 CEST] <kritzikratzi> but i cant even get the simplest tests to work.
[13:25:03 CEST] <kritzikratzi> ive attempted to isolate the resampling code to just boil it down to just a few lines, here is what i got so far: http://pastebin.com/nS10YYw1
[13:27:03 CEST] <hansi_also> uh, seems my irc client is crashing hard. this is still me with the resampling question :)
[13:28:31 CEST] <hansi_also> i'm wondering if i have some fundamental misunderstand with swresample, because i can't get anything useful out of it (not even a crash, really)
[13:33:41 CEST] <kritzikratzi> do i understand this correctly: swresample can convert 1)between different sample rates 2)between different channel layouts 3)between different data types 4)all of this at the same time.
[14:32:05 CEST] <benny-> hi, i have some file demuxed and got an ac3 stream which plays fine in mediaplayer and vlc, when i trie to remux it with tsremuxer, it says no stream is detected for the ac3 file. is it possible to reencode it with ffmeg (if possible lossless)
[15:14:19 CEST] <Pangas> Olá!
[15:14:46 CEST] <Pangas> Alguém aí fala português?
[15:15:36 CEST] <Pangas> Oi.
[15:17:30 CEST] <Pangas> Olá!
[15:25:00 CEST] Last message repeated 1 time(s).
[15:34:00 CEST] Last message repeated 1 time(s).
[15:34:06 CEST] <pangas> Oi.
[15:42:14 CEST] <Pangas> Olá!
[15:42:46 CEST] <Pangas> Alguém aqui fala portugiês?
[15:42:57 CEST] <Pangas> Hablas español?
[15:43:19 CEST] <Pangas> Compilation problem in Linux Debian 8.
[15:44:27 CEST] <Pangas> Configure:
[15:44:27 CEST] <Pangas> ./configure --enable-fontconfig --enable-libass --enable-nonfree  --enable-libfaac --enable-gpl --enable-x264 --enable-libspeex  --enable-x11grab
[15:44:27 CEST] <Pangas> Result:
[15:44:27 CEST] <Pangas> Ok.
[15:44:47 CEST] <Pangas> Make:
[15:44:48 CEST] <Pangas> common.mak:57: recipe for target 'libavfilter/vf_subtitles.o' failed
[15:44:48 CEST] <Pangas> make: *** [libavfilter/vf_subtitles.o] Error 1
[15:46:45 CEST] <Pangas> I'am productor!
[15:51:06 CEST] <Pangas1> Hello!
[15:58:35 CEST] <Pangas1> Olá.
[15:58:40 CEST] <Pangas1> Hello!
[16:02:01 CEST] <Pangas1> Olá!
[16:06:59 CEST] <Pangas1> Não encontrei nenhuma solução e nop google encontrei 8 páginas de links, porém a solução era para MAC.
[16:08:15 CEST] <Pangas1> Hi!
[16:08:17 CEST] <Pangas1> ...
[16:18:29 CEST] <StephenLynx> hey, I am building ffmpeg from source for production usage, how do I decide which tag is the latest stable release?
[16:18:43 CEST] <StephenLynx> I noticed there are v and n tags.
[16:19:15 CEST] <StephenLynx> would n2.7.1 be what I want?
[16:19:25 CEST] <StephenLynx> from the topic I assume so
[16:19:26 CEST] <StephenLynx> :v
[16:27:48 CEST] <Pangas1> Olá!!!!!!!!11
[16:30:20 CEST] <Pangas1> Olá!
[16:30:25 CEST] <Pangas1> Alguém?
[16:30:33 CEST] <Pangas1> Como procedo?
[16:31:07 CEST] <Pangas1> ...
[16:31:21 CEST] <AstralStorm> English please.
[16:31:49 CEST] <AstralStorm> that said, pastebin the full log
[16:32:27 CEST] <AstralStorm> ok, I've a problem myself, with avcodec_open2 documentation - it says this is not threadsafe - ... why?
[16:33:27 CEST] <Pangas1> This Problem:
[16:33:27 CEST] <Pangas1> ./configure --enable-fontconfig --enable-libass --enable-nonfree  --enable-libfaac --enable-gpl --enable-x264 --enable-libspeex  --enable-x11grab
[16:33:27 CEST] <Pangas1> Configure no problem.
[16:33:27 CEST] <Pangas1> This problem in compilation
[16:33:27 CEST] <Pangas1> Make:
[16:33:27 CEST] <Pangas1> common.mak:57: recipe for target 'libavfilter/vf_subtitles.o' failed
[16:33:28 CEST] <Pangas1> make: *** [libavfilter/vf_subtitles.o] Error 1
[16:33:34 CEST] <AstralStorm> I've seen it.
[16:33:48 CEST] <AstralStorm> Use pastebin e.g. dpaste.org with a full log
[16:34:19 CEST] <tomred> I keep on being asked to format duration as HH::SS::nn where nn is the number of frames less than a second . But every time I look into this I  hit some problem or other and I wonder "Is this really an industry standard" and if so what is the way to derive the information without having to use regexes to parse strings.
[16:34:34 CEST] <Pangas1> More information, please.
[16:35:47 CEST] <Pangas1> I'am productor. And video editor.
[16:37:14 CEST] <Pangas1> No FFMPEG, no video renderize.
[16:38:48 CEST] <Pangas1> Or... alternative solution...
[16:40:08 CEST] <Pangas1> ...
[16:44:39 CEST] <Pangas1> My work is stopped. Google generate 8 pages with links and no solution. For Mac Only. i Use Linux. Debian 8.
[16:46:37 CEST] <Pangas1> Hello, guy!
[16:49:31 CEST] <Pangas1> [b]HELLO!![/b]
[16:50:21 CEST] <Pangas1> Bye!
[16:50:58 CEST] <Pangas1> <>
[16:52:39 CEST] <AstralStorm> Pangas1: you come across as a bit pushy. Using a pastebin is easy, you go to the site, copy the error log, paste it in the browser, click send and give us the link.
[16:53:26 CEST] <Pangas1> Ok. Wait, please.
[17:00:15 CEST] <Pangas1> Ok.
[17:00:17 CEST] <Pangas1> https://dpaste.de/4jqS
[17:01:07 CEST] <Pangas1> LibASS installed.
[17:03:11 CEST] <AstralStorm> this is not a complete log, but it's close enough - you're probably missing libass-devel
[17:03:40 CEST] <AstralStorm> this would be a configure script bug
[17:11:38 CEST] <podman> hey guys, what's a good way to convert a video to use square pixels?
[17:11:50 CEST] <Pangas1> https://dpaste.de/xOUg
[17:14:31 CEST] <Pangas1> Solution?
[17:24:15 CEST] <Pangas1> LibASS is my problem?
[17:26:09 CEST] <Pangas1> ??
[17:37:45 CEST] <yviwp> I have a file (mp4,h264+aac) on this shit hardware with very high fps that is unplayable (stuttering) due to hardware (CPU) requirements. Do I have to re-encode this to get 30fps? Or is there some quicker alternative.
[17:41:55 CEST] <Pangas1> Hello!
[17:51:27 CEST] <durandal_170> podman: setsar?
[17:51:41 CEST] <podman> durandal_170: looking into that.
[17:53:37 CEST] <_Vi> How do I make FFmpeg generate output file without any streams instead of "Output file #0 does not contain any stream"?
[17:56:38 CEST] <Pangas1> Ok. No LibAss. Installed.
[17:56:39 CEST] <Pangas1> PS:X264 don't depend LibAss. Very?
[18:24:25 CEST] <Pangas1> Bye!
[21:18:28 CEST] <rgoodwin> I have a question for a metadata wizard. I'm trying to use ffmpeg to effectively copy some metadata from one video file format to another but having some issues. I think I need to override something but not sure how.
[21:20:54 CEST] <c_14> What are you trying to do?
[21:22:08 CEST] <rgoodwin> Ok this is very specific. I'm trying to take an MP4 file from one camera, and make it look like an MP4 out of a GoPro. My belief is that it is just some metadata that needs to be tweaked, because otherwise the target app I'm using (GoPro studio) DOES recognize and parse the file, it just doesn't recognize it as a GoPro file
[21:22:48 CEST] <rgoodwin> here is a valid file mediainfo dump: http://pastebin.com/GvmzDRau
[21:23:17 CEST] <rgoodwin> Here is what I want to "convert" by tweaking the meta: http://pastebin.com/yshwZFyn
[21:23:53 CEST] <c_14> Can you pastebin the ffprobe output? It'll make it easier for me to see what ffmpeg sees as the differences
[21:23:58 CEST] <rgoodwin> sure!
[21:25:23 CEST] <rgoodwin> http://pastebin.com/XsGERti7
[21:27:39 CEST] <jonascj> Hi all. Does it sound possible to add some all-black frames (maybe at a low framerate) to an MKV media file to add some length without adding much size?
[21:28:39 CEST] <rgoodwin> differences I see: compatible_brands, handler_name in each stream, encoder in vid stream...so far
[21:28:52 CEST] <rgoodwin> oh and major_brand
[21:31:30 CEST] <rgoodwin> i feel like maybe i'm missing a "force" or copying wrong or specifying streams wrong :)
[21:35:14 CEST] <rgoodwin> c_14 here's a comparison of metadata dump from the two files http://pastebin.com/nK6yP3X6
[21:53:21 CEST] <rgoodwin> c_14 getting closer...had to use stream specifiers for the -metadata option. Looking better but I'm still missing something
[21:53:42 CEST] <c_14> rgoodwin: hmm, looks like ffmpeg is refusing to create an mp4 with the avc1 tag and h264 video
[21:54:40 CEST] <rgoodwin> i think you can use copy_unknown
[21:54:50 CEST] <rgoodwin> trick is just knowing what it's looking for :)
[21:55:06 CEST] <rgoodwin> downloading a 30FPS clip to make sure i'm more apples:apples
[21:59:23 CEST] <rgoodwin> dunno if the SAR DAR aspect ratios matter, and if the FPS really matters
[22:02:41 CEST] <rgoodwin> there's also this encoder tag or pid? avc1 / 0x31637661)
[22:07:59 CEST] <rgoodwin> might help if i knew what that was called :)
[22:09:10 CEST] <rgoodwin> it's constant between streams
[22:10:38 CEST] <rgoodwin> or you might be on the right track if doing differently.
[22:15:21 CEST] <c_14> That's the FourCC
[22:17:50 CEST] <rgoodwin> ooh interesting
[22:21:11 CEST] <rgoodwin> that'd be funny if that's all it was...
[22:24:08 CEST] <rgoodwin> just not sure how to patch that in, if it will let me
[22:26:14 CEST] <rgoodwin> or is the fourcc technically avc1 with some internal stored constant that i can't override?
[22:26:23 CEST] <rgoodwin> and thank you for your help!!
[22:29:56 CEST] <rgoodwin> oh hah it's just avc1 in hex
[22:30:28 CEST] <kepstin-laptop> yeah "fourcc" literally means "four character code", and is a 32bit value of the 4 characters ascii codes.
[22:36:10 CEST] <agorman> hi, I'm trying to take a video file with 16 mono audio streams and convert it to a video file with 1 16 channel audio stream. For whatever reason I'm only getting an audio stream with 8 channels. It seems to be related to aac because if I make my acodec pcm_s16le I do get an output with 16 channels. Any ideas? http://pastebin.com/20erRS1L
[22:37:09 CEST] <rgoodwin> thanks kepstin-laptop !
[22:40:16 CEST] <rgoodwin> c_14 hmm. so if i vtag h264 it sets the fourcc proper but then ignores all the metadata changes i submit. interesting
[22:45:21 CEST] <durandal_170> agorman: aac doesn't support that many channels
[22:45:29 CEST] <rgoodwin> it's now just become the principle of the thing, i think it SHOULD work ;)
[22:48:08 CEST] <agorman> durandal_170, well shit. For some reason I thought I had read it supported more but now I'm seeing fdk aac only supports up to 8...
[22:48:17 CEST] <agorman> durandal_170, thank you. That explains it
[23:09:02 CEST] <rgoodwin> c_14: ok, i realized something dumb. I'm setting all the metadata, and it shows in the Output stream settings, but then when it does stream copy it just ends up copying the metadata over from the stream anyway
[23:09:15 CEST] <rgoodwin> so it's something about the copy that messes things up
[23:10:09 CEST] <rgoodwin> c_14 here's what i mean. http://pastebin.com/3MJWb362
[23:10:34 CEST] <rgoodwin> i thought changes were being made but i wasn't probing the file again afterwards, trusting instead what the output settings said
[23:20:13 CEST] <rgoodwin> omg i got it.
[23:31:05 CEST] <rgoodwin> oh well, I tricked the app into recognizing it, but the functionality doesn't work. fun experiment anyway :)
[00:00:00 CEST] --- Thu Jul 16 2015

More information about the Ffmpeg-devel-irc mailing list