[Ffmpeg-devel-irc] ffmpeg.log.20150718

burek burek021 at gmail.com
Sun Jul 19 02:05:01 CEST 2015

[00:24:10 CEST] <yonilevy> Perhaps someone could help me, i'm building ffmpeg and i can't seem to get the `cropdetect` filter to be included in it. I have `vf_cropdetect.c` in place, i'm compiling with `--enable-filter=cropdetect`, any ideas?
[01:13:26 CEST] <edoceo> What's the "fastest" format to work with?  That is, I have a bunch of files to process, with filter_complex, making grids and merging audio ands tuff
[01:13:56 CEST] <edoceo> So, should I take my webm sources and make into ".dv" or '.ts' or something? Does it really matter?
[01:47:05 CEST] <DHE> as a wrapper, ts is pretty easy. there's no index or need to seek
[02:19:20 CEST] <krieger-od> Sorry for spamming, guys. Here's request for paid help with H264 http://ffmpeg.org/pipermail/ffmpeg-devel/2015-July/175796.html . Urgent for me.
[02:50:18 CEST] <Demon_Fox> Anyone have a recommended set of settings for opus for 5.1 surround sound?
[07:47:03 CEST] <kecharitomene> I'm trying to convert a file using ffmpeg and I've installed 'gst-plugins-vp8', but I'm getting 'Encoder (codec vp8) not found for output stream #0.0'.
[07:48:21 CEST] <kecharitomene> http://pastebin.com/UzFnp3cF full input and output
[08:08:34 CEST] <durandal_1707>  kecharitomene : you have disable-libvpx
[08:09:22 CEST] <durandal_1707> gst is for gstreamer plugins and not ffmpeg
[08:12:15 CEST] <kecharitomene> What's disable-libvpx?
[08:12:21 CEST] <kecharitomene> A use flag?
[08:19:28 CEST] <kecharitomene> durandal_1707?
[08:20:06 CEST] <durandal_1707> in configure
[08:21:06 CEST] <kecharitomene> Config file?
[08:32:41 CEST] <durandal_1707> kecharitomene: the rules how ffmpeg is compiled
[08:38:08 CEST] <kecharitomene> So yes, the USE flag.
[08:38:16 CEST] <kecharitomene> I've just added it and recompiling now.
[08:52:32 CEST] <seeit> If I want to convert a stream to another stream with ffmpeg and ffserver  how would I go about it?
[08:53:19 CEST] <kecharitomene> Thanks, durandal_1707. It works now.
[09:22:23 CEST] <kecharitomene> Hey, I'm converting an mkv into webm and it works in mpv but when I upload it online it says it's corrupt.
[09:22:27 CEST] <kecharitomene> What could be the cause of that?
[09:23:29 CEST] <kecharitomene> Is it Firefox's fault?
[09:36:36 CEST] <durandal_1707> what you use for playback?
[09:38:12 CEST] <kecharitomene> uhh
[09:38:14 CEST] <kecharitomene> Firefox
[10:06:29 CEST] <Chinese_soup> kecharitomene: does the file contain a subtitle track by accident (or on purpose)? firefox likes to say that when there's a sub track
[10:07:21 CEST] <kecharitomene> Oh, I've deleted it now. Is there a command line option for 'no subtitle track please'?
[10:07:45 CEST] <Chinese_soup> -sn, I think?
[10:12:21 CEST] <kecharitomene> That seems to fix it, thanks.
[10:12:22 CEST] <kecharitomene> Weird.
[10:18:30 CEST] <Chinese_soup> np
[14:25:37 CEST] <justinfront> Hi really offtopic question I am trying to write an encode for gif from scratch and getting stuck on encoding gif's bigger than about 90x90, so I have the basics working, I am wondering if anyone in here might know about gif encoding since I know ffmpeg is all about encoding and decoding and might be willing to take a look?
[14:26:32 CEST] <justinfront> or suggest a suitable channel
[14:54:24 CEST] <storrgie> I've got about 400 images that I want to throw in a 'slideshow' with fade in and fade out. Is this possible easily with ffmpeg?
[16:40:32 CEST] <rgoodwin> Has anyone successfully built a static ffmpeg binary on OSX/Linux WITH fontconfig? I'm so close, just think I'm missing a path or something somewhere
[16:43:16 CEST] <DHE> under linux you need the library with the .a extension rather than the .so extension
[16:43:35 CEST] <DHE> some distributions may simply not offer it
[16:50:34 CEST] <rgoodwin> Hmm. well this is OSX. the fontconfig.pc file is in the lib folder of my prefix. interestingly, if I use the pkg-config fontconfig --libs in my prefix, this is what it returns:
[16:50:43 CEST] <rgoodwin> -L/usr/local/Cellar/fontconfig/2.11.1/lib -L/usr/local/Cellar/freetype/2.6_1/lib -lfontconfig -lfreetype
[16:50:49 CEST] <rgoodwin> which is definitely not my prefix :)
[16:56:32 CEST] <rgoodwin> I may have been calling the wrong pkg-config binary that time, so could be a red herring.
[16:59:24 CEST] <rgoodwin> Yah ok. the build script is right, it's looking in the right place. pkgconfig is /Users/richardgoodwin/Downloads/ffmpeg-build-script-plus-frei0r-freetype/workspace/bin/pkg-config and fontconfig lib is -L/Users/richardgoodwin/Downloads/ffmpeg-build-script-plus-frei0r-freetype/workspace/lib -lfontconfig -lfreetype
[16:59:32 CEST] <rgoodwin> I just wish I could make it verbose to know what it's looking for
[17:04:21 CEST] <rgoodwin> DHE hmm. do you think it's actually an xml problem? http://pastebin.com/AK1wLdJ7
[17:04:37 CEST] <rgoodwin> looks like it's actually finding the fontconfig lib, given that it references it :)
[17:27:06 CEST] <yonilevy> anyone experienced compiling vid.stab for armv7?
[17:59:40 CEST] <relaxed> yonilevy: what's the problem?
[18:02:04 CEST] <yonilevy> relaxed: hey, i'm just trying to figure it out, no experience with cmake... i suppose i need to edit its CMakeLists.txt until it generates armv7 compatible binaries, struggling with that...
[18:03:43 CEST] <relaxed> yonilevy: in the source dir do, mkdir build_tmp; cd build_tmp; cmake ..
[18:03:53 CEST] <relaxed> then make
[18:05:55 CEST] <yonilevy> relaxed: ye but then you're not cross compiling to arm, unless i'm missing something
[18:06:32 CEST] <relaxed> oh, you're cross compiling
[18:07:15 CEST] <yonilevy> ah ye i didn't mention i'm running on a mac
[18:08:47 CEST] <relaxed> Look at the output of "cmake -LA ..", I think you need to set the right gcc, etc
[18:09:45 CEST] <yonilevy> relaxed: ye i'll keep tinkering - thx!
[18:09:48 CEST] <relaxed> then, cmake -DCMAKE_C_COMPILER:FILEPATH=/path/to/arm/gcc <other options> ..
[18:13:06 CEST] <rgoodwin> ah well. so close, but about to give up. can't get past unresolved symbols in fontconfig.
[18:13:31 CEST] <yonilevy> relaxed: i think i got it, it was trying to use SSE, had to disable that :)
[18:16:44 CEST] <rgoodwin> how does one check to see if a lib exports a given symbol
[18:18:03 CEST] <relaxed> non of the mac builds static builds have what you need?
[18:18:20 CEST] <relaxed> er, none
[18:18:28 CEST] <rgoodwin> nah. it's a very specific combination :) frei0r, freetype, fontconfig, vidstab
[18:18:38 CEST] <rgoodwin> most have 2 of 4
[18:18:51 CEST] <rgoodwin> and I have everythong done in my script but fontconfig. I think it's probably some silly little detail, always is
[18:18:57 CEST] <rgoodwin> *everything :)
[18:20:35 CEST] <relaxed> oh yeah, I need to add frei0r to my static builds
[18:23:01 CEST] <rgoodwin> AFAICT it can't be built in static, so my script just builds it alongside and offers to install
[18:23:12 CEST] <rgoodwin> but if you've got fontconfig going that'd be sweet ;)
[18:23:34 CEST] <rgoodwin> here's my config.log output...iv'e just been looking at the last lines,but maybe i'm missing something. http://pastebin.com/YdCHaUMY
[18:24:08 CEST] <relaxed> they have fontconfig
[18:24:42 CEST] <relaxed> this isn't needed --extra-cflags=--static
[18:25:11 CEST] <rgoodwin> k removed
[18:25:34 CEST] <relaxed> this is a static build, correct?
[18:27:24 CEST] <rgoodwin> yup
[18:27:41 CEST] <relaxed> you need, --extra-ldflags="-L/Users/richardgoodwin/Downloads/ffmpeg-build-script-plus-frei0r-freetype/workspace/lib -static"
[18:28:06 CEST] <durandal_1707> why you need frei0r?
[18:28:21 CEST] <rgoodwin> Unknown option "-static"
[18:28:38 CEST] <rgoodwin> durandal_1707: the defish0r filter is the best for removing fisheye that I have found
[18:28:49 CEST] <rgoodwin> never could get lenscorrection to work right
[18:29:05 CEST] <relaxed> quote it
[18:29:17 CEST] <relaxed> you also need, --pkg-config-flags="--static"
[18:29:25 CEST] <durandal_1707> because they do different stuff...
[18:29:39 CEST] <rgoodwin> it is quoted, but hold
[18:30:08 CEST] <rgoodwin> durandal_1707: right, i meant that the most often described alternative to defish0r was lenscorrection, but having it not work for me, I fall back to fish0r
[18:30:17 CEST] <rgoodwin> relaxed tbc you are saying on the ffmpeg configure?
[18:30:25 CEST] <relaxed> yes
[18:31:11 CEST] <rgoodwin> --extra-ldflags="-L$WORKSPACE/lib -static" <-- so?
[18:31:14 CEST] <rgoodwin> err "like so"
[18:31:22 CEST] <relaxed> correct
[18:33:10 CEST] <rgoodwin> here's the whole script. configure won't accept the --static for pkg-config or the -static for ldflags http://pastebin.com/3kbxaMR3
[18:35:09 CEST] <rgoodwin> unless i'm quoting it wrong
[18:35:19 CEST] <rgoodwin> i do see it's not quoted in the output
[18:35:24 CEST] <rgoodwin> which would explain the complaints :)
[18:36:53 CEST] <relaxed> uh, so you're building a static ffmpeg binary that you expect to use shared libfrei0r?
[18:37:13 CEST] <rgoodwin> it does work yes, unless it wasn't truly built static before
[18:37:20 CEST] <rgoodwin> i.e. i've been using it
[18:37:29 CEST] <relaxed> I doubt it was, from looking at your configure
[18:37:52 CEST] <rgoodwin> i think because the filters themselves are external, but the library functionality is static
[18:38:00 CEST] <rgoodwin> if i understand correctly
[18:38:07 CEST] <rgoodwin> or I should say effects
[18:42:30 CEST] <rgoodwin> Note: I'm totally ok being proven wrong, or shown a different way to do it. I just thought i was so close with this method :)
[20:12:12 CEST] <rgoodwin> anyone following my travails before, apparently adding -m64 to the libxml2 build may have fixed it
[20:55:41 CEST] <yonilevy> is there a way to do video stabilization based on custom tracking points using ffmpeg/vid.stab?
[22:31:25 CEST] <ZeuZ> Hey all, I'm trying to convert a series of jpg files from a pattern photo.1.jpg where 1 goes up to 120, with this command: ffmpeg -framerate 25 -pattern_type glob -i *.jpg -s 640x480 registro.avi -y
[22:31:29 CEST] <ZeuZ> ran from the folder where the files are
[22:31:38 CEST] <ZeuZ> but it results in a one frame only file
[22:31:53 CEST] <ZeuZ> what am I doing wrong?
[22:33:57 CEST] <chungy> you need to escape the *, such as with \*.jpg or "*.jpg"
[22:34:31 CEST] <chungy> also you likely intended the -y before registro.avi.
[22:35:34 CEST] <chungy> Additionally, if you have files like photo.1.jpg and photo.120.jpg, it's likely to not result in the order you're intending
[22:35:53 CEST] <ZeuZ> how should I parse them for order to be kept?
[22:36:48 CEST] <chungy> easiest to rename them; "for i in {1..9}; do mv photo.$i.jpg photo.00$i.jpg; done; for i in {10..99}; do mv photo.$i.jpg photo.0$i.jpg; done"
[22:38:19 CEST] <ZeuZ> hm, what about undetermined amount of photos?
[22:40:27 CEST] <ZeuZ> also, what am I still missing? ffmpeg -pattern_type glob -i "*.jpg" -s 640x480 -y registro.avi --> still takes only the first image
[22:42:12 CEST] <chungy> hmm, that should work afaik
[22:44:15 CEST] <ZeuZ> output of the command: http://pastebin.com/bSksr2Dg
[22:46:47 CEST] <chungy> why sudo?
[22:47:06 CEST] <ZeuZ> because I commited the mistake of copying the files as root :P
[22:47:21 CEST] <ZeuZ> and I was lazy to correct permissions
[22:49:30 CEST] <chungy> my only other guess is to add "-f image2" right after ffmpeg. Not sure if it'd work.
[22:50:00 CEST] <ZeuZ> nope, same thing
[22:50:35 CEST] <chungy> are all the photos the same size?
[22:50:51 CEST] <ZeuZ> Yes, they are, but contents are different
[22:51:01 CEST] <ZeuZ> perhaps its ignoring them because of size_
[22:51:02 CEST] <ZeuZ> ?
[22:51:54 CEST] <chungy> I don't think it would
[22:52:19 CEST] <chungy> afaik you have everything right. Can you make a test run without "-s 640x480"?
[22:52:33 CEST] <ZeuZ> sure thing
[22:53:20 CEST] <ZeuZ> nope same thing, actually the resulting file is smaller due to the resolution of the pic
[22:56:07 CEST] <ZeuZ> wait
[22:56:11 CEST] <ZeuZ> just re checked
[22:56:15 CEST] <ZeuZ> without -s it does work
[22:56:35 CEST] <ZeuZ> there is one more thing I would like to do, and is give each pic a one second stay in screen.. how can I achieve that?
[22:58:06 CEST] <chungy> -framerate 1
[22:59:59 CEST] <ZeuZ> if it was to stay half a second then would it be -framerate 0.5 right?
[23:00:31 CEST] <chungy> 2, they're per-second
[23:00:44 CEST] <chungy> 0.5 would be for each to stay for 2 seconds
[23:04:23 CEST] <ZeuZ> chungy, thanks
[23:04:27 CEST] <ZeuZ> I owe you a beer
[23:04:58 CEST] <chungy> did you get it to work?
[23:05:36 CEST] <ZeuZ> yeah
[23:05:42 CEST] <ZeuZ> whats left to fix is the order thingy
[23:05:51 CEST] <ZeuZ> aint there a way to actually sort them correctly?
[23:06:44 CEST] <chungy> the globbing isn't the smartest, you'll have to order them so it expands correctly
[23:07:45 CEST] <ZeuZ> what about using some other pattern? I;ve seen its possible but I tried to no avail since I couldn't hit the format correctly
[23:07:57 CEST] <chungy> just "-f image2 -i photo.%d.jpg" might get what you want but I'm not sure of that
[23:09:24 CEST] <chungy> I think it will, i'm usually having to add a number before the d for zero-padded stuff
[23:09:44 CEST] <ZeuZ> le me le tries
[23:11:23 CEST] <ZeuZ> indeed it works wonders
[00:00:00 CEST] --- Sun Jul 19 2015

More information about the Ffmpeg-devel-irc mailing list