[Ffmpeg-devel-irc] ffmpeg.log.20150719

burek burek021 at gmail.com
Mon Jul 20 02:05:01 CEST 2015

[01:19:57 CEST] <FatsDT> I'm getting the warning: [swscaler @ 0x31b3b60] Warning: data is not aligned! This can lead to a speedloss
[01:23:50 CEST] <FatsDT> The internet says it has to do scaling resolutions not being multiples of 16
[01:24:05 CEST] <FatsDT> It looks like all my numbers are multples of 16
[01:30:00 CEST] <FatsDT> Input video is 720x480, which then gets cropped to 704x352 to remove black bars, then scaled to 1024x432 to square the pixels.
[01:32:29 CEST] <FatsDT> All those numbers are divisible by 16, so whats the deal?
[02:35:16 CEST] <sh45> hi developers,i have a stupid question , where can i find ffserver.exe?
[03:04:34 CEST] <sh45> pls,any one?
[03:24:49 CEST] <klaxa> sh45: did you compile from source?
[03:26:04 CEST] <sh45> no , i just wander why there no ffserver.exe in ffmpeg-win64-shared.7z etc
[03:27:27 CEST] <sh45> i am compiling now , it is slow. i will wait and see
[03:29:53 CEST] <sh45> klaxa: i why there is no ffserver.exe in .7z .
[03:30:42 CEST] <klaxa> you'll have to ask the person publishing those builds
[03:30:51 CEST] <klaxa> you have to enable ffserver during compile-time
[03:33:14 CEST] <sh45> ok ,i will consider compiling again. i downloaded https://ffmpeg.zeranoe.com/builds/win64/shared/ffmpeg-xx-win64-shared.7z . no ffserver ,crying
[05:20:05 CEST] <Demon_Fox> I know this is ffmpeg, but ffmpeg has shitty mkv support, so does someone know how to use mkvmerge and get it to exclude several audio tracks?
[05:28:03 CEST] <chungy> Demon_Fox: um. how is it "shitty"? you can select specific audio tracks easily with ffmpeg.
[05:28:32 CEST] <Demon_Fox> The timestamp bug
[05:28:42 CEST] <Demon_Fox> It has been an issue for 18 months straight
[05:28:48 CEST] <Demon_Fox> if not longer
[05:29:00 CEST] <Demon_Fox> Can't write packet with unknown timestamp
[05:29:39 CEST] <chungy> i've not seen that
[05:29:52 CEST] <Demon_Fox> av_interleaved_write_frame(): Invalid argument
[05:30:00 CEST] <Demon_Fox> Let me grab the bug report
[05:30:14 CEST] <Demon_Fox> http://trac.ffmpeg.org/ticket/3339
[05:32:49 CEST] <Demon_Fox> There are several reports on it using different formats
[05:38:26 CEST] <Demon_Fox> chungy, I'm betting you don't use ffmpeg to multiplex files.
[05:39:12 CEST] <chungy> I've got hundreds of mkv files to say otherwise. i've never seen that issue though
[05:39:28 CEST] <chungy> anyway, "mkvmerge --help" I guess... I've never used that program myself
[08:02:14 CEST] <zumba_addict> good morning guys. Which audio format should I use for an mp4 video?
[08:02:29 CEST] <zumba_addict> i don't require high quality but something good is ok too
[08:02:39 CEST] <zumba_addict> should I use aac, mp3 or m4a?
[08:16:41 CEST] <needshelp> My FFMPEG is not concatinating my files like expected - it shows an error about a source stream
[08:16:57 CEST] <needshelp> Stream specifier ':v' in filtergraph description [0:v][0:a][1:v][1:a][2:v][2:a][3:v][4:v][4:a][5:v][5:a][6:v][6:a][7:v][8:v][8:a][9:v][9:a] concat=n=10:v=1:a=1 [v] [a] matches no streams.
[08:17:16 CEST] <needshelp> The complete command and output are here: http://edoceo.io/paste?p=epadER
[08:28:20 CEST] <needshelp> It looks like concat is confused cause some of the streams I'm concatting have no audio, so I skip them in filtergraph
[09:05:59 CEST] <zumba_addict> hey guys, I used ffmpeg to build this video :D
[09:06:08 CEST] <zumba_addict> https://www.youtube.com/watch?v=-0b3CuZpHP4
[09:06:26 CEST] <zumba_addict> it's only 35 seconds, I want to hear some feedbacks
[10:19:37 CEST] <frafra> hi! I'm using -threads option for vp9 encoding, but it seems ignored
[10:47:52 CEST] <frafra> http://pastebin.com/ZvbXaa6P
[10:52:45 CEST] <durandal_170> thats not full output
[10:53:11 CEST] <frafra> sorry
[10:54:29 CEST] <frafra> http://pastebin.com/iTDxgcA6
[12:09:08 CEST] <durandal_170> frafra: IIRC for vp9 threading is used only with tiles or something like that
[12:09:55 CEST] <frafra> durandal_170, this is why I tried to set -tile-columns to 6
[12:11:42 CEST] <durandal_170> try adding another -threads before -c:v
[12:13:48 CEST] <frafra> single thread
[13:11:10 CEST] <well0ne> Hi guys, i've to report some error, never done that bevore, little help would be nice, where to report etc.  i'm using the concat proto to concenate files ex: "concat:1.ts|2.ts|3.ts" which works flawless.
[13:11:44 CEST] <well0ne> but when i set a starttime for ex -ss 00:10:00 , it seeks to the lastfile , not to the firstfile
[15:46:06 CEST] <DrSlony> Hi, when recording using ffmpeg x11grab, how do I get the audio? I'm recording a screencast of a selection of the screen on which I play two game replays through two separate wine instances. I use pulseaudio if that matters.
[15:50:54 CEST] <durandal_170> there is documentation for pulseaudio I guess
[15:52:14 CEST] <DrSlony> brilliant answer
[15:56:00 CEST] <durandal_170> There is even example
[15:57:50 CEST] <DrSlony> will try '-f alsa -ac 2 -i hw:x,y' and '-f pulse -ac 2 -i default'
[17:03:15 CEST] <DHE> anyone tried compiling ffmpeg with -flto (new option in recent versions of gcc)?  I'm getting a lot of errors
[17:15:27 CEST] <ubitux> DHE: --enable-lto?
[17:23:36 CEST] <DHE> oh, didn't see that. I was just using --extra-cflags=-flto (and so on)
[17:30:33 CEST] <DHE> better, but still doesn't build...
[18:06:38 CEST] <Dosvedanya> Hello, i have a question. Just one. I have been trying to relay a video stream to my own ffserver. However i can get the stream to write to a file, i cant get it to stream to my ffserver. I've been searching and searching on the web/forums/sites but i cant find a proper resolution. This is my command: ffmpeg -re -i url.m3u8" -c:v libx264 -c:a aac -strict -2 -absf aac_adtstoasc -movflags faststart+frag_keyframe+empty_moo
[18:06:38 CEST] <Dosvedanya> v -f h264 . What i get in return is: "av_interleaved_write_frame(): Broken pipe" and at the end "Conversion failed". The input stream is based on hls, applehttp. Is there anyone who can help me get this to work after hours of trying and searching?
[18:36:47 CEST] <zumba_addict> hey guys, did you see the youtube video i posted last night? What are your thoughts?
[18:49:23 CEST] <tp__> amazing zumba_addict
[18:49:32 CEST] <zumba_addict> thanks! :)
[18:49:46 CEST] <zumba_addict> ffmpeg is awesome!
[18:50:15 CEST] <zumba_addict> but i hate the frame at the joining part
[18:50:20 CEST] <zumba_addict> it turns green
[18:50:29 CEST] <zumba_addict> i comibined 2 mp4 files
[18:50:43 CEST] <zumba_addict> some of my videos doesn't have that green
[18:51:58 CEST] <zumba_addict> I always have issues when combining multiple mp4. Sometimes, MP4Box works, sometimes it doesn't
[18:52:10 CEST] <zumba_addict> sometimes, ffmpeg have issues with concat
[18:52:27 CEST] <zumba_addict> i can't find an excellent way of combining
[18:52:38 CEST] <zumba_addict> the other night, I converted it to .ts first
[19:10:34 CEST] <durandal_170> zumba_addict: what you used to concat?
[19:10:44 CEST] <zumba_addict> here are the commands
[19:11:19 CEST] <zumba_addict> this is what I have in my notes and I always follow it - http://pastebin.com/aKt1Kx3c
[19:11:30 CEST] <zumba_addict> I've also used MP4Box but can't get it to work this time
[19:11:42 CEST] <zumba_addict> some of my youtube videos are fine
[19:12:01 CEST] <zumba_addict> but I've seen that dreaded green for like 3 times now on my other videos
[19:12:10 CEST] <zumba_addict> there is something wrong that I'm doing
[19:19:21 CEST] <zumba_addict> any updates durandal_170?
[19:21:06 CEST] <zumba_addict> I'm seeing a difference in the 2 videos which might be the reason why MP4Box is failing to properly combine. What is this? chroma_qp_offset=4
[19:22:12 CEST] <zumba_addict> can we change that value in the command line?
[19:23:34 CEST] <durandal_170> use concat demuxer
[19:24:29 CEST] <durandal_170> The videos you concat must have same encoding parameters
[19:25:09 CEST] <durandal_170> If all fails use lossless intermediate format with concat filter
[19:25:14 CEST] <zumba_addict> yup, that's one of the issues i saw. The chroma_qp_offset have different values
[19:25:31 CEST] <zumba_addict> all other x264 opts were good
[19:25:54 CEST] <zumba_addict> what is concat demuxer? Is it different from the one I posted?
[19:27:47 CEST] <zumba_addict> i'm reading this now, https://trac.ffmpeg.org/wiki/Concatenate#demuxer
[19:30:16 CEST] <zumba_addict> i tried it and the resulting output is very bad
[19:30:31 CEST] <zumba_addict> tons of errors when I played it
[19:31:04 CEST] <zumba_addict> here are the errors during playback , http://pastebin.com/QUSHG8JP
[19:32:43 CEST] <zumba_addict> it's weird that I used the same parameters to generate the 2 mp4 files
[19:34:27 CEST] <zumba_addict> looks like it changed when I overlay my logo image
[19:35:29 CEST] <zumba_addict> this is very interesting - http://pastebin.com/YRRBy5aJ hq.mp4 and cover.mp4 are the same but when I added an image, that's when it changed
[19:38:34 CEST] <zumba_addict> reencoding hq2.mp4 is not helping, it is still showing chroma_qp_offset=-2 rather than chroma_qp_offset=4
[19:40:40 CEST] <zumba_addict> this is crazy, I added -x264opts chroma_qp_offset=4 but output is showing chroma_qp_offset=2
[20:06:23 CEST] <genio> I have an IPcam that records for 30 seconds on motion detection and FTPs the resultant video to my ftp server.  The video's in an avi container that I would like to generate mp4, ogg, and webm containers from for other purposes.  https://gist.github.com/genio/ba95abee2a1e5d56360f is what "mediainfo" shows about the file.
[20:07:11 CEST] <genio> When I try ffmpeg -i file.avi -sn -an -c copy 00test.mp4 for instance, I get lots and lots of errors and if I get any video at all in the end, it's too garbled to view.
[20:07:33 CEST] <genio> can someone point me to what I'm doing incorrectly?
[20:07:49 CEST] <zumba_addict> I fixed it by adding -pix_fmt yuv420p :(
[20:08:37 CEST] <zumba_addict> unfortunately, we cannot reupload a new video
[20:09:51 CEST] <genio> [NULL @ 0x112c5a0] missing picture in access unit with size 5255
[20:09:58 CEST] <genio> errors like that are what I'm getting
[20:10:59 CEST] <genio> VLC plays the original video fine.  handbrake seems to convert it pretty well, but ffmpeg is giving me issues (likely from my own misunderstandings)
[21:30:46 CEST] <PovAddict> hi peeps
[21:33:56 CEST] <PovAddict> I copied a video recorded by an iPhone 5s camera into the SD card of a Samsung Galaxy S4, and the Galaxy phone is unable to play it
[21:34:19 CEST] <PovAddict> here is the ffprobe output of the iPhone video, and of a video recorded by the Galaxy phone (which it obviously can play): http://pastebin.com/WAPR2Rq8
[21:35:01 CEST] <PovAddict> what could be the reason why the Galaxy can't play the video? I can't see any significant difference in the video format and codec
[21:35:17 CEST] <PovAddict> and how should I reencode the video so that the Galaxy can play it?
[23:31:06 CEST] <genio> Can someone with more knowledge than me help me figure out what's so broken about this video file and how I might be able to get ffmpeg to work with it and many others like it (from IP cam)?
[23:31:22 CEST] <genio> https://www.cwhitener.com/test.avi
[23:35:32 CEST] <DHE> AVI is a crap format. don't use it
[23:36:07 CEST] <genio> I have no say in how the files are created/saved.  It's the IPCam that does that
[23:36:12 CEST] <DHE> oh dear
[23:36:33 CEST] <genio> I'm trying to convert them to ogg, webm, and mp4
[23:36:52 CEST] <genio> yet ffmpeg barfs on them because they're pretty crappy files (although VLC seems to handle them well)
[23:38:46 CEST] <DHE>  Here's what I reconstructed
[23:39:31 CEST] <DHE> maybe I could do it in one shot, but I had mplayer dump the raw h264 video to a .264 file, then had ffmpeg assemble it into a proper .mp4. audio went to AAC because right now it's lossless
[23:40:10 CEST] <genio> odd that there's even an audio stream considering the cams don't have a mic
[23:40:24 CEST] <DHE> I didn't actually listen, I just processed it
[23:42:48 CEST] <genio> are you able to get ffmpeg to decode the original avi or is relying on mplayer about the best I can do?
[23:42:50 CEST] <DHE> an old copy of mplayer I have laying around plays the .avi correctly, wonder if that's related...
[23:43:14 CEST] <genio> win 20
[23:43:17 CEST] <genio> err
[23:43:22 CEST] <DHE> irssi
[23:43:28 CEST] <genio> yep
[23:44:42 CEST] <DHE> it does seem ffmpeg's AVI decoder disapproves, while mplayer is more tolerant...
[23:45:08 CEST] <DHE> but my local mplayer binary is timestamped October 2012 so take that with a large amount of salt
[23:46:05 CEST] <genio> I realize it's a bad file, but does this seem like a bug with ffmpeg being too strict?
[23:47:32 CEST] <DHE> I'm inclined to say yes. H264 in AVI mostly works as long as you don't use b-frames, and this video is a baseline profile.
[23:58:54 CEST] <edoceo> I'm running this command: ffmpeg -i '/tmp/tmp.cke3tJPmXe/1435957885869-head.webm' -i '/tmp/tmp.cke3tJPmXe/1435957888487-grid.webm' -i '/tmp/tmp.cke3tJPmXe/1435957909108-grid.webm' -i '/tmp/tmp.cke3tJPmXe/1435957910028-grid.webm' -filter_complex '[0:v] [0:a] [1:v] [1:a] [2:v] [2:a] [3:v] [3:a] concat=n=4:v=1:a=1 [v] [a]' -map '[v]' -map '[a]' -y '/tmp/tmp.cke3tJPmXe/composite.webm'
[23:59:13 CEST] <edoceo> And getting the message that: "[libvorbis @ 0x39f1f20] Queue input is backward in time"
[23:59:51 CEST] <edoceo> Is it cause the files input to concat are each starting with zero time and confusing concat filter?   Should I use that SETPTS thing before filter?
[00:00:00 CEST] --- Mon Jul 20 2015

More information about the Ffmpeg-devel-irc mailing list