[Ffmpeg-devel-irc] ffmpeg.log.20150720

burek burek021 at gmail.com
Tue Jul 21 02:05:01 CEST 2015

[00:03:29 CEST] <genio> DHE: thse are my only options: https://www.cwhitener.com/options.png
[00:34:08 CEST] <Surfer> hello all.. please, how can i embed subtitles in avi videos?
[00:34:44 CEST] <PovAddict> do you want them to be rendered as actual text into the video image, so they can't be turned off?
[00:35:40 CEST] <Surfer> exactly PovAddict
[00:36:12 CEST] <PovAddict> that process is called hardsub, I think ffmpeg by itself can't do it but there are many free programs that can
[00:37:10 CEST] <Surfer> PovAddict i would like to use linux command line.. i dont have a GUI there
[00:38:26 CEST] <Surfer> there is some program that i can use in a command line?
[00:38:35 CEST] <hexagon51n> ffmpeg with .avi output works for hard-rendered subtitles
[00:38:57 CEST] <hexagon51n> ffmpeg -i {video:} -c:v libx264 -preset slow -crf 18 -c:a aac -strict -2 -vf ass={subtitles:} {output:}
[00:39:06 CEST] <hexagon51n> (for example)
[00:39:06 CEST] <Surfer> really? :]
[00:39:17 CEST] <Surfer> i'll try
[00:39:24 CEST] <Surfer> wait
[00:39:48 CEST] <hexagon51n> i do it all the time.
[00:41:21 CEST] <Surfer> hexagon51n Unrecognized option 'c:v'
[00:41:29 CEST] <Surfer> i think my version is old
[00:41:42 CEST] <Surfer> FFmpeg version 0.6.5
[00:41:46 CEST] <hexagon51n> aha.  my version is bleeding-edge new
[00:41:58 CEST] <hexagon51n> ffmpeg version 2.7.1
[00:42:11 CEST] <Surfer> i'll get the lastest
[00:55:35 CEST] <Surfer> hexagon51n [ass @ 0x856d40] Could not create a libass track when reading file 'O.Fim.do.Mundo.2015.BDRip.XviD.Dual.Audio-D3M0.srt'
[00:55:59 CEST] <Surfer> do i have to convert srt to this ass format?
[00:57:44 CEST] <hexagon51n> not sure, but maybe.  I just used ass b/c it had easy native support
[00:57:59 CEST] <c_14> Use the subtitles filter
[00:58:57 CEST] <Surfer> c_14 i don't know it
[00:59:00 CEST] <hexagon51n> try ffmpeg -i video.avi -vf subtitles=subtitle.srt out.avi
[00:59:05 CEST] <Surfer> ok
[00:59:14 CEST] <hexagon51n> (from http://trac.ffmpeg.org/wiki/HowToBurnSubtitlesIntoVideo)
[00:59:48 CEST] <Surfer> No such filter: 'subtitles'
[01:00:04 CEST] <Surfer> error
[01:00:14 CEST] <c_14> try again with the static build
[01:00:16 CEST] <c_14> http://johnvansickle.com/ffmpeg/
[01:00:30 CEST] <c_14> Version either too old or not built with fontconfig/freetype
[01:00:37 CEST] <hexagon51n> see that webpage I linked -- you have to have a version of ffmpeg compiled with libass support
[01:00:59 CEST] <Surfer> ok c_14
[01:01:01 CEST] <hexagon51n> or give c_14's idea a shot
[01:05:21 CEST] <Surfer> failed
[01:05:31 CEST] <Surfer> i have to convert srt to ass
[01:05:59 CEST] <Surfer> can i convert using ffmpeg?
[01:06:04 CEST] <c_14> ffmpeg -i srt out.ass
[01:06:12 CEST] <Surfer> right
[01:06:16 CEST] <hexagon51n> boo.  FWIW, they're simple text files
[01:06:54 CEST] <c_14> Sure, but ass is quite a bit more complex than srt
[01:07:33 CEST] <hexagon51n> ah ok.
[01:07:56 CEST] <Surfer> working noww :]
[01:08:53 CEST] <Surfer> Fontconfig warning: "/etc/fonts/conf.d/45-latin.conf", line 56: Having multiple <family> in <alias> isn't supported and may not work as expected
[01:09:05 CEST] <Surfer> can i change that font later?
[01:09:41 CEST] <c_14> No, if it's "broken" now. It'll be broken forever (once you burn in the subs).
[01:09:50 CEST] <c_14> If it's causing problems, fix it. If it isn't, it's your call.
[01:10:01 CEST] <Surfer> oh, yes.. i understand
[01:10:12 CEST] <Surfer> but can i set another font next time?
[01:10:30 CEST] <c_14> Next time?
[01:10:33 CEST] <c_14> When encoding or when watching?
[01:10:54 CEST] <Surfer> enconding
[01:10:59 CEST] <c_14> sure
[01:11:04 CEST] <c_14> edit the fontstyle section of the .ass file
[01:12:01 CEST] <c_14> Should be called something like [V4+ Styles]
[01:12:11 CEST] <c_14> Then theres a Format: line that tells you where each identifier is
[01:12:33 CEST] <c_14> You can either change it in a text editor, or use something wysiwyg like aegisub
[01:14:10 CEST] <Surfer> can i just download some font and set in that line?
[01:14:44 CEST] <c_14> Put the font somewhere in your system/user fontpath, rehash the fontpath, and then just set it in that line.
[01:27:18 CEST] <Surfer> c_14 didn't work :/
[01:27:20 CEST] <Surfer>
[01:27:28 CEST] <Surfer> no subtitle
[01:31:56 CEST] <Surfer> ok
[01:40:25 CEST] <Stragonian> ffmpeg-0.6-x86_64-1_SBo ... # ffmpeg -async 30 -i concat:"00001.mts|00002.mts|00003.mts" -vcodec mpeg2video -aspect 16:9 -sameq -sws_flags lanczos+accurate_rnd+full_chroma_int+full_chroma_inp -pix_fmt yuv420p -me_method epzs -threads 4 -r 29.97 -g 15 -bf 2 -acodec mp2 -ab 256K -ac 2 -ar 48000 output.mpeg
[01:47:23 CEST] <edoceo> I convert a webm to '.ts' file, but then the duration information shows as: Duration: 00:00:00.92, start: 1.441667, bitrate: 2062 kb/s
[01:47:27 CEST] <edoceo> Why not starting at 0?
[01:49:46 CEST] <edoceo> I'm encoding with: ffmpeg -loglevel panic -i '/tmp/tmp.Oe0DuivTxr/0826f4d5-6f22-4e9d-a894-88c25a5487c3.webm' -filter_complex "setpts=PTS-STARTPTS" -c:v mpeg2video -q:v 2 -pix_fmt yuv420p -r 24 -c:a mp2 -ac 2 -f mpegts -y '/tmp/tmp.Oe0DuivTxr/0826f4d5-6f22-4e9d-a894-88c25a5487c3.ts'
[07:42:11 CEST] <Dark-knight> I need some help
[07:42:21 CEST] <Dark-knight> I just checked a file with mediainfo
[07:43:29 CEST] <Dark-knight> and apparently there is a hidden .txt file in the video
[07:43:41 CEST] <Dark-knight> how do i extract it?
[07:49:44 CEST] <Dark-knight> there are 275 people here and not one single person can answer me?
[07:49:49 CEST] <Dark-knight> wow
[08:08:33 CEST] <Dark-knight> how do I extract the .txt file from a video while leaving everything else intact
[08:08:46 CEST] <chungy> see the -map option
[08:09:02 CEST] <durandal_1707> Is it listed by ffprobe?
[08:24:06 CEST] <Dark-knight> yes it was stream 0:2
[08:24:40 CEST] <Dark-knight> i Tried exacting it by using -map 0:2
[08:24:46 CEST] <Dark-knight> but it didn't work
[08:25:00 CEST] <Dark-knight> I exported to .mkv and then renamed to .txt
[08:25:12 CEST] <Dark-knight> all i got was jiberish
[08:32:05 CEST] <Dark-knight> is there an exact command to extract a .txt file?
[08:32:37 CEST] <Dark-knight> i'd really like to know, and I'm sure there are other people who would like to know as well
[08:32:38 CEST] <chungy> umm.... why don't you export it to a *.txt?
[08:33:20 CEST] <Dark-knight> because its a VIDEO .mkv file with an hour of concert video and audio codec
[08:33:35 CEST] <Dark-knight> and one tiny little .txt attachemnt
[08:33:55 CEST] <chungy> doesn't matter. "ffmpeg -i file.mkv -c copy -map 0:2 file.txt"
[08:34:20 CEST] <chungy> i dunno off-hand if that'll work, it'd be helpful to know what you've tried so far.
[08:34:21 CEST] <Dark-knight> ya tried that, apparently ffmpeg can't export to .txt
[08:36:28 CEST] <chungy> might also be worth using mkvextract if it's an unusual kind of stream.
[08:36:50 CEST] <Dark-knight> I've tried "aot.mkv -map -0:2 file.txt" and "aot.mkv -map 0 -map -0:v -map -0:a -map -0:s file.txt"
[08:37:20 CEST] <chungy> pastebin and output please.
[08:38:05 CEST] <Dark-knight> both times it wouldn't let me convert to .txt. so I converted it to .mkv and renamed the file to .txt instead.
[08:38:07 CEST] <Dark-knight> and both times the .txt file was complete jibberish
[08:38:38 CEST] <Dark-knight> nothing but computer language
[08:38:39 CEST] <chungy> matroska files aren't text files.
[08:39:08 CEST] <Dark-knight> no but after those commands I entered, the only file left was the .txt file
[08:39:15 CEST] <Dark-knight> so it should have worked
[08:39:27 CEST] <chungy> pastebin, exact command and output.
[08:41:21 CEST] <Dark-knight> i told you the command already and the only thing left in the output is stream 0:2 which is the .txt file
[08:41:26 CEST] <Dark-knight> i checked it twice each time
[08:41:55 CEST] <chungy> still haven't pasted the output of ffmpeg.
[08:41:59 CEST] <Dark-knight> it would be so much easier if ffmpeg let me convert to txt
[08:43:45 CEST] <chungy> this is the type of thing i'm asking for (using one that I'm doing right now): http://pastebin.com/HW3jhjWf
[08:50:28 CEST] <Dark-knight> http://pastebin.com/m6xHWABA
[08:55:54 CEST] <Dark-knight> and the second command line I used http://pastebin.com/RyTpUnVJ
[08:56:25 CEST] <Dark-knight> chungy
[08:57:55 CEST] <chungy> look in the documentation for "attachment". Specifically you're looking to do "ffmpeg -dump_attachment mawen1250.txt aot.mkv -f null -"
[08:59:04 CEST] <Dark-knight> thank you
[08:59:17 CEST] <Dark-knight> can I have a link to the documentation
[08:59:19 CEST] <Dark-knight> ?
[08:59:40 CEST] <chungy> https://ffmpeg.org/ffmpeg.html
[09:01:52 CEST] <Dark-knight> that command didn't work
[09:02:00 CEST] <Dark-knight> how am I suppose to use it?
[09:02:18 CEST] <Dark-knight> i did "cmd /k ffmpeg -i ffmpeg aot.mkv -dump_attachment mawen1250.txt -f null -"
[09:02:28 CEST] <Dark-knight> oops
[09:02:34 CEST] <Dark-knight> i see my mistake now
[09:02:42 CEST] <chungy> should work I think, but I'm not familiar with Windows
[09:04:03 CEST] <Dark-knight> i should have deleted the ffmpeg after -i
[09:07:20 CEST] <Dark-knight> ok I used "ffmpeg -i aot.mkv -dump_attachment mawen1250.txt aot.mkv -f null -"
[09:07:21 CEST] <Dark-knight> and this is what I got "Option dump_attachment (extract an attachment into a file) cannot be applied to output file aot.mkv -- you are trying to apply an input option to an output file or vice versa. Move this option before the file it belongs to. Error parsing options for output file aot.mkv. Error opening output files: Invalid argument"
[09:07:57 CEST] <chungy> use the order I typed
[09:08:15 CEST] <Dark-knight> i did
[09:08:20 CEST] <Dark-knight> and it said no file found
[09:08:27 CEST] <Dark-knight> so I added the file name
[09:08:42 CEST] <chungy> oh, I made a mistake, put a "-i" before aot.mkv
[09:08:58 CEST] <Dark-knight> what do you think I did?
[09:13:31 CEST] <Dark-knight> it didn't work
[09:14:26 CEST] <Dark-knight> nvm its not worth it anymore
[09:14:50 CEST] <Dark-knight> to much work for an easter egg
[10:17:20 CEST] <IanWizard> I've got four videos, all of which play fine everywhere, except in chrome on android.  Three of them are fine, but one of them refuses to play.  Based on the output from avprobe (http://pastebin.com/SNVuDjrp), it seems like if any of them were going to fail, it would be "good1.webm".  I admitedly don't know much about the wonderful world of av encoding.  Anyone have any idea / suggestions?
[11:02:02 CEST] <AstralStorm> hello, how do I provide the equivalent to -q:a <float> option to a codec (specifically, aac)
[11:02:18 CEST] <AstralStorm> using libavcodec/libavformat of course
[11:02:38 CEST] <Mavrik> Not sure I understand the question
[11:07:07 CEST] <AstralStorm> I'm using libavcodec and libavformat to encode MPEG-4 AAC, which works
[11:07:21 CEST] <AstralStorm> setting encCtx->bit_rate puts the encoder into ABR (average bitrate) mode
[11:07:30 CEST] <AstralStorm> encCtx beinv AVCodecContext
[11:07:40 CEST] <AstralStorm> I need to set something else to get VBR mode
[11:09:09 CEST] <AstralStorm> currently I'm setting it to 75384 bps/channel which gives actual 160 kbps in ABR mode, but I'd like the VBR option too
[11:10:23 CEST] <AstralStorm> ah, never mind, the docs say VBR is likely terrible and mistuned :)
[11:10:52 CEST] <Mavrik> IIRC q:a translates to qscale parameter
[11:11:03 CEST] <Mavrik> which AAC encoder are you using? the experimental one?
[11:11:09 CEST] <AstralStorm> yes
[11:11:25 CEST] <AstralStorm> ahha, so it's qscale, thanks
[11:11:43 CEST] <Mavrik> even though, I'm not finding any references to it in the source
[11:11:44 CEST] <AstralStorm> the defaults are set to 128kbps, but result in 136 kbps :)
[11:12:03 CEST] <Mavrik> (I usually use fdk_aac since it was more stable)
[11:12:04 CEST] <AstralStorm> I suspect that is because they ignore ADTS overhead
[11:12:49 CEST] <AstralStorm> fdk_aac should be set as free nowadays, right? it's Apache 2 in AOSP
[11:12:57 CEST] <Mavrik> hmm, it doesn't look like aac in ffmpeg even has a qscale mode
[11:13:12 CEST] <AstralStorm> hm, it's mentioned on the wiki
[11:14:30 CEST] <AstralStorm> sound quality is pretty good though at those 160 kbps, I'd pit it against LAME preset standard (~192 kbps)
[11:33:01 CEST] <AstralStorm> hmm, a very slight lowpass is audible :)
[11:33:15 CEST] <AstralStorm> apparently the polyphase lowpass in LAME is mildly superior
[12:05:48 CEST] <BtbN> libfdk was re-licensed?
[12:06:44 CEST] <BtbN> https://github.com/mstorsjo/fdk-aac still has its weird custom license
[12:07:25 CEST] <BtbN> AstralStorm, make sure to enable the afterburner when testing fdk
[12:10:24 CEST] <AstralStorm> BtbN: correct, but the version in AOSP platform is Apache 2 :)
[12:10:30 CEST] <AstralStorm> afterburner?
[12:11:01 CEST] <BtbN> yes
[12:11:17 CEST] <BtbN> Well, the version in AOSP isn't available anywhere yet
[12:12:22 CEST] <AstralStorm> no, wait, I was wrong, it is a custom licence
[12:12:48 CEST] <AstralStorm> https://android.googlesource.com/platform/external/aac/+/master - this is the upstream
[12:13:13 CEST] <BtbN> yeah, same license as always
[12:13:49 CEST] <AstralStorm> point about releasing modifications is incompatible with LGPL :(
[12:14:36 CEST] <AstralStorm> the point about charging copyright licensing fees is incompatible as well
[12:15:53 CEST] <AstralStorm> likewise enforced change advertisement clauses
[12:16:23 CEST] <AstralStorm> hmmh. someone should fix ffmpeg to allow dynamically adding and removing codecs to avoid those problems
[12:17:28 CEST] <AstralStorm> I'd volunteer but I'm not yet paid to add proprietary codecs to it :) (maybe soon)
[13:37:46 CEST] <riddrs24> Fjorgynn: Can you elaborate?
[13:45:23 CEST] <kvitozev> Hey, guys! I know it's a noob question, but how can I recompile ffmpeg on Ubuntu with OpenSSL? :)
[14:10:27 CEST] <goncalomsdias> anyone has experience with ffmpeg + decklink cards?
[15:05:00 CEST] Last message repeated 1 time(s).
[16:26:03 CEST] <goncalomsdias067> Hi everyone. Has anyone ever used ffmpeg with decklink cards?
[16:34:33 CEST] <durandal_1707> goncalomsdias067: open bug report
[17:09:31 CEST] <feliwir> is anywhere an easy example on how to write a custom aviocontext?
[17:53:56 CEST] <elliotd123> Hi guys, can anyone explain what ac-tex is and what it means when it is damaged? I get that error a lot and would like a better understanding
[18:16:37 CEST] <Cryp71c> The following issue only occurs on a subset of flv videos uploaded to a web-application: http://paste2.org/XJ5wF2Pj
[18:17:40 CEST] <Cryp71c> I've "solved" this before, but if I remove -vf "pad=max(iw\,ih*(16/9)):ow/(16/9):(ow-iw)/2:(oh-ih)/2" it will work, but I believe that filter will force the video to be letterboxed (either horizontally or vertically) so that it is consistently 16:9 ratio
[18:18:03 CEST] <Cryp71c> So removing that filter isn't an ideal permanent solution, and - as I mentioned before - this isn't a problem with every uploaded video, only a subset.
[18:50:39 CEST] <Solarnum> I'm trying to encode real time video using an ffmpeg build for android. Encoding 5 seconds of video takes 20 seconds and those 20 seconds are contracted into 5 seconds of video.
[18:54:15 CEST] <pzich> It might just be that your android device isn't fast enough to do the encoding you want in real time, but I'd look into veryfast or faster encoding profiles and other realtime flags
[18:58:16 CEST] <Solarnum> pzich: im using ultrafast, -threads 0 and -tune zerolatency.
[19:02:03 CEST] <Solarnum> I am fine with low fps, but I can't find the right flags to get the output to sync with the input. If it was 1fps for example, frame 1 would start at 00:00:00, frame 2 at 00:01:00 etc.
[19:30:06 CEST] <dd> can you, please, recommend me and updated tutorial about how to compile ffmpeg 4 android with support for libvpx and libvorbis, using ubuntu 14.04?
[19:37:43 CEST] <antiatom> I am using mkvmerge to concatinate 3 MOV files to one continuous MKV file, but I get errors and can only see the resulting streams from the first video in the concatination
[19:37:57 CEST] <antiatom> The AVC video track is missing the 'CTTS' atom for frame timecode offsets. However, AVC/h.264 allows frames to have more than the traditional one (for P frames) or two (for B frames) references to other frames. The timecodes for such frames will be out-of-order, and the 'CTTS' atom is needed for getting the timecodes right. As it is missing the timecodes for this track might be wrong. You should watch the
[19:38:03 CEST] <antiatom>  resulting file and make sure that it looks like you expected it to.
[20:07:18 CEST] <antiatom> It seems like I can only mux 2 videos together at once with MkvMerge GUI
[20:08:28 CEST] <BtbN> As far as i know, mkvmerge isn't an ffmpeg related tool.
[20:08:42 CEST] <antiatom> BtbN: Sorry for asking here
[20:09:07 CEST] <BtbN> Well, it's just that likely nobody here has too much of an idea of it.
[20:13:54 CEST] <klaxa> antiatom: i use mkvmerge, what is your command?
[20:16:15 CEST] <klaxa> ah, moved to #matroska i see
[23:40:33 CEST] <edoceo> Does the -c:v or -c:a options go before or after the -f FORMAT option for output?
[23:44:21 CEST] <kepstin-laptop> edoceo, doesn't matter.
[23:44:58 CEST] <kepstin-laptop> all of the -c and -f options have to be after the input files and before the output filename, but the relative order doesn't make a difference.
[23:45:47 CEST] <edoceo> is there a codec I can use that will be "faster"?  I have a bunch of source video, that I first have to cleanup to interim format, before running through a few filters (making a grid layout)
[23:46:18 CEST] <edoceo> I've tried MKV some of my videos error  - like 1 / 30
[23:46:33 CEST] <kepstin-laptop> well, mkv is a container not a codec...
[23:47:02 CEST] <edoceo> Oh, ea - here is my command:
[23:47:16 CEST] <edoceo> http://edoceo.io/paste?p=AqJgDo
[23:47:30 CEST] <kepstin-laptop> if you have a lot of fast disk space available, you could go with a lossless codec for intermediates like ffvhuff or (maybe? it's sometimes a bit slow) ffv1
[23:48:00 CEST] <edoceo> That is me concating a bunch of 'grid' files I made before with ffmpeg - but there is an error for one of the streams: Could not find codec parameters for stream 0
[23:48:02 CEST] <kepstin-laptop> otherwise you could try playing with x264's options, maybe encode with low crf value and superfast preset
[23:48:23 CEST] <edoceo> I want to be fast, but not lose quality, I have a fast disk
[23:50:35 CEST] <kepstin-laptop> hmm, looks like there's something wrong with the file 1437005424653-grid.mkv there, how did you make that file?
[23:51:00 CEST] <edoceo> I made that with...
[23:58:53 CEST] <edoceo> /opt/dio/bin/ffmpeg -ss 7.3210 -i /tmp/tmp.oTYyirhJqU/ea07df07-9f82-456c-90f6-d8315d03e32b.mkv -ss 0.0000 -i /tmp/tmp.oTYyirhJqU/1c21f556-4fad-48d9-b4d9-17e349af47d7.mkv -to 38.0190 -filter_complex 'color=c=#101010:s=640x480:r=24[in0]; [0]fps=24,setpts=PTS-STARTPTS,scale=320:240[mv0]; [in0][mv0]overlay=0:120[in1]; [1]fps=24,setpts=PTS-STARTPTS,scale=320:240[mv1]; [in1][mv1]overlay=320:120; [0:a][1:a]amix=in
[23:58:59 CEST] <edoceo> puts=2[aout]' -map '[aout]' -c:v mpeg2video -q:v 2 -pix_fmt yuv420p -r 24 -c:a flac -ac 2 -f matroska -y '/tmp/tmp.oTYyirhJqU/1437005424653-grid.mkv'
[00:00:00 CEST] --- Tue Jul 21 2015

More information about the Ffmpeg-devel-irc mailing list