[Ffmpeg-devel-irc] ffmpeg.log.20150721

burek burek021 at gmail.com
Wed Jul 22 02:05:01 CEST 2015

[00:47:39 CEST] <antiatom> klaxa: Yes figured it out, thank you.
[01:11:10 CEST] <ZeuZ> Guys, regarding the C API, where can I find an example of something akin to invoking ffmpeg like:  -f image2 -framerate 2 -i /CAMARAS/Camara1/camara1.%d.jpg -y /CAMARAS/Camara1/registro.`echo $clips`.avi	 ?
[01:11:46 CEST] <ZeuZ> I mean, can I input something akin to camara1.%d.jpg as a filter for each image to be taken? Or should I parse them in order and add them?
[01:13:51 CEST] <ZeuZ> ups
[01:14:02 CEST] <ZeuZ> is this the wrong channel to ask this?
[03:05:03 CEST] <Zeranoe> Can FFmpeg work with 'IRD DVB/IP'?
[10:37:50 CEST] <AlicanC> I am trying to put an overlay on a video and I am getting a wierd result:
[10:37:52 CEST] <AlicanC> -i vid.webm -i overlay.png -filter_complex "[1:v]scale=320:240 [ovrl],[0:v]fps=15,scale=480:-1:flags=lanczos,[ovrl]overlay=W-w-10:H-h-10" -y out.gif
[10:39:28 CEST] <AlicanC> It was working fine until i decided to scale the overlay.
[10:55:57 CEST] <AlicanC> Not copy-pasting from stackoverflow and actually reading the documentation helps:
[10:55:58 CEST] <AlicanC> ffmpeg.exe -i vid.mp4 -i over.png -filter_complex "[1:v] scale=100:-1 [over]; [0:v] fps=15, scale=480:-1:flags=lanczos [main]; [main][over] overlay=W-w-10:H-h-10" -y out.gif
[11:18:31 CEST] <Marckov85> hello guys i need help with merging audio and video together
[11:18:58 CEST] <Marckov85> am using this command :
[11:19:11 CEST] <Marckov85> ffmpeg -i input_vid.mp4 -itsoffset 0.1 -i input_audio.mp3
[11:19:11 CEST] <Marckov85>     -vcodec copy -acodec copy output.mp4
[11:19:42 CEST] <Marckov85> anyone can give a hand?
[11:23:14 CEST] <Marckov85> olaaaaa
[11:27:20 CEST] <AlicanC> ffmpeg -i video.mp4 -i audio.mp3 -c:v copy -c:a libmp3lame out.mp4
[11:27:51 CEST] <AlicanC> Marckov85, I don't know what you are trying to achieve with "-itsoffest 0.1" but this works for me.
[11:28:14 CEST] <chungy> you can generally achieve the same thing with just "-c copy" but yea
[11:28:26 CEST] <chungy> -itsoffset is supposed to delay the audio by 0.1s I guess.
[11:29:40 CEST] <AlicanC> chungy, yeah, this is also fine: ffmpeg -i video.mp4 -i audio.mp3 -c copy out.mp4
[11:33:08 CEST] <Marckov85> mmm
[11:33:13 CEST] <Marckov85> i am getting a result
[11:33:27 CEST] <Marckov85> but the first time i play the video
[11:33:34 CEST] <Marckov85> it says not supported media on android
[11:33:40 CEST] <Marckov85> than i play it again it plays
[11:33:55 CEST] <Marckov85> i think somehting is going wrong with the first few frames
[11:38:36 CEST] <chungy> android's media support is probably extremely picky. I bet if you try it without -itsoffset, it'd work
[11:38:53 CEST] <chungy> or just install VLC on your Android device *shrugs*
[11:40:33 CEST] <Marckov85> ummm
[11:40:40 CEST] <Marckov85> i tried it wihout the offset
[11:40:43 CEST] <Marckov85> same problem
[11:40:50 CEST] <Marckov85> ffmpeg -i video.mp4 -i audio.mp3 -c copy out.mp4
[11:40:56 CEST] <Marckov85> i tried shis one
[11:41:18 CEST] <Marckov85> and without offset the song is faster than the video :(
[11:42:29 CEST] <Marckov85> on android am using the videoview player
[11:42:31 CEST] <Marckov85> by code
[11:42:40 CEST] <Marckov85> the video with no audio works fine
[11:42:44 CEST] <Marckov85> when i merge the audio
[11:42:55 CEST] <Marckov85> am having this shitty problem
[13:02:11 CEST] <Marckov85> weird only not playable on htc
[13:02:22 CEST] <Marckov85> on sumsang it is playable well
[13:02:30 CEST] <Marckov85> something with the header is wrong
[13:11:08 CEST] <goncalomsdias067> I'm trying to extract the audio from one file that has ac3 audio and convert it to pcm_s16le with this command: ffmpeg -i canalplus.ts -map 0:1 -c:a pcm_s16le cplus_converted.ts
[13:11:25 CEST] <goncalomsdias067> I got: Error while decoding stream #0:1: Invalid data found when processing input
[13:11:48 CEST] <goncalomsdias067> am I doing something wrong? :S
[13:45:21 CEST] <ridders24> is it possible to point ffmpeg at a physical disk to carve out frames from h264 streams?
[14:04:00 CEST] <AlicanC> Marckov85, you should check those devices' compatibility lists. They might have better support for webm, ogg, ogv, aac, etc.
[14:14:25 CEST] <Marckov85> okay thank youu
[15:21:48 CEST] <cleanrock> anyone here got hw accelerated HEVC video with GTX 960 on linux ? i do not get it on archlinux with mpv 0.9.2 (ffmpeg 2.7.1) with vo and hwdec set to vdpau
[15:40:49 CEST] <ffmpegDEV> hey
[16:22:12 CEST] <pingback> Hi i've got an error with ffmpeg ver. 2.7.2 with an m3u8
[16:22:21 CEST] <pingback> Invalid data found when processing input
[16:23:04 CEST] <pingback> If I try to play one of the segment in the m3u8 play fine but i need to follow the playlist
[16:59:30 CEST] <Jeffries> guys trying to resize a YUV video
[16:59:43 CEST] <Jeffries> helpppp
[17:26:05 CEST] <Jeffries> (IS ANYONE HERE)
[17:26:11 CEST] <Jeffries> urrrrrrrrkh
[17:28:35 CEST] <DHE> ...
[17:31:30 CEST] <Jeffries> DHE
[17:31:36 CEST] <Jeffries> help me resize a YUV video
[17:31:38 CEST] <Jeffries> pl0x
[17:33:40 CEST] <DHE> I don't know how
[17:34:42 CEST] <durandal_1707> Jeffries: use scale filter
[17:35:11 CEST] <Jeffries> trying, isn't working
[17:35:23 CEST] <Jeffries> ffmpeg isn't very good at handing raw yuv video operations
[17:35:46 CEST] <Jeffries> (probably because it just makes calls to codecs for these operations, and yuv has no codec and is just rawvideo)
[17:36:00 CEST] <Jeffries> I'll probably encode it to h.264 and resize it there
[17:36:04 CEST] <Jeffries> sec
[17:39:06 CEST] <Mavrik> what.
[17:39:16 CEST] <Mavrik> no :P
[17:42:10 CEST] <Jeffries> http://pastie.org/10304469
[17:44:23 CEST] <kepstin-laptop> Jeffries, scale is a filter, not a codec... Use it with the '-f' option.
[17:46:06 CEST] <kepstin-laptop> Jeffries, also, for raw video input, you have to specify the frame size (and probably also framerate) as an input option. See https://www.ffmpeg.org/ffmpeg-formats.html#rawvideo
[18:17:31 CEST] <Jeffries> ffmpeg -i akiyo.yuv -c:v libx264 -preset veryslow -qp 0 akiyo.mp4 is my command
[18:18:55 CEST] <Jeffries> http://pastie.org/10304527
[18:19:13 CEST] <Jeffries> I'm trying to encode a YUV video to h.264, what is wrong here
[18:19:29 CEST] <kepstin-laptop> Jeffries, scroll up, i've already told you what's wrong.
[18:19:36 CEST] <Mavrik> Indeed.
[18:19:48 CEST] <Mavrik> No container means that there's no way of determining basic raw parameters.
[18:19:56 CEST] <Mavrik> Probably pix format has to be specified as well
[18:20:18 CEST] <kepstin-laptop> pix fmt defaults to yuv420p, which is the most common type.
[18:20:28 CEST] <kepstin-laptop> but yeah, might be needed as well :)
[18:20:36 CEST] <Jeffries> I'm explicitly stating that format, and nothing
[18:20:47 CEST] <Jeffries> ffmpeg -i akiyo.yuv -f 1280:720 -c:v libx264 -preset veryslow -qp 0 -pix_fmt yuv420p akiyo.mp4	
[18:21:05 CEST] <Jeffries> really, I just want lossless encoding :O
[18:21:07 CEST] <kepstin-laptop> Jeffries, you need to explicitly state the video frame size and framerate as *input* options, following the syntax in the page I linked
[18:21:29 CEST] <Jeffries> k
[18:21:57 CEST] <kepstin-laptop> (and possibly also pixel format)
[18:23:23 CEST] <kepstin-laptop> (in particular, when using the 'ffmpeg' tool, input options must be before the -i filename)
[18:23:50 CEST] <Jeffries> yeah, adjusted it
[18:23:52 CEST] <Jeffries> ffmpeg -i akiyo.yuv -pixel_format yuv420p -video_size 176x144 -framerate 25  -f 1280:720 -c:v libx264 -preset veryslow -qp 0 -pix_fmt yuv420p akiyo.mp4			
[18:23:59 CEST] <Jeffries> this still doesn't seem to work
[18:24:16 CEST] <Jeffries> I wonder why this isn't working for me
[18:24:34 CEST] <kepstin-laptop> Jeffries, that '-f' option makes no sense, "1280:720" isn't a filter.
[18:25:08 CEST] <Jeffries> but you've just told m-
[18:25:31 CEST] <Jeffries> alright, level the playing field here, explain what I need to do to scale
[18:25:41 CEST] <kepstin-laptop> I said "scale is a filter, so you use it with -f"
[18:25:52 CEST] <kepstin-laptop> so the end result would be "-f scale=1280x720"
[18:26:24 CEST] <kepstin-laptop> er, wait, I'm wrong about that completely
[18:26:27 CEST] <kepstin-laptop> -0f is format :/
[18:26:41 CEST] <Jeffries> kay
[18:26:41 CEST] <kepstin-laptop> you have to use -filter instead sorry
[18:28:11 CEST] <Jeffries> it still tells me that it can't find the video size
[18:28:14 CEST] <kepstin-laptop> so "-filter scale=1280:720" should do it. Although since you're not using any other filters, you can also just do "-s 1280x720"
[18:28:22 CEST] <Jeffries> for some reason, though I'm explicitly stating it
[18:28:23 CEST] <kepstin-laptop> Jeffries, paste the current full output?
[18:28:24 CEST] <Jeffries> ffmpeg -i akiyo.yuv -video_size 176x144 -pixel_format yuv420p  -framerate 25  -filter scale=1280:720 -c:v libx264 -preset veryslow -qp 0 -pix_fmt yuv420p akiyo.mp4
[18:28:53 CEST] <kepstin-laptop> Jeffries, ok, you missed another thing I said. "(in particular, when using the 'ffmpeg' tool, input options must be before the -i filename)"
[18:29:28 CEST] <Jeffries> http://pastie.org/10304538
[18:29:39 CEST] <Jeffries> uh sorry :P
[18:31:42 CEST] <Jeffries> I'd buy you dinner if I knew you in real life
[18:31:45 CEST] <Jeffries> Thank you!
[00:00:00 CEST] --- Wed Jul 22 2015

More information about the Ffmpeg-devel-irc mailing list