[Ffmpeg-devel-irc] ffmpeg.log.20150725

burek burek021 at gmail.com
Sun Jul 26 02:05:01 CEST 2015

[00:19:39 CEST] <UKCoder> Hi all, I was wondering if there was anyone who could tell me why when I run a 30s M2TS file through ffmpeg with the flags -r 30 -g 15 (trying to set frame rate to 30fps and GOP size to 15 frames) I end up with 67 GOPs instead of 60?
[00:24:43 CEST] <c_14> Some encoders (x264 for example) also insert i-frames on scene changes.
[00:28:30 CEST] <UKCoder> c_14 : do you know if that's the case with ffmpeg and MPEG2 video and if so, is there a way to suppress that type of behavior in ffmpeg?
[00:30:20 CEST] <UKCoder> (btw - there's no scene change in the asset I'm using
[00:30:29 CEST] <c_14> try -mpv_flags strict_gop
[00:32:15 CEST] <UKCoder> c_14 : thanks for the suggestion, gave it a try, still getting 67 GOPs according to ffprobe
[00:33:46 CEST] <UKCoder> even -keying_min 15 doesn't seem to affect it either :/
[00:33:53 CEST] <UKCoder> oops -keyint_min
[00:35:38 CEST] <c_14> I'm getting exactly 60 with `ffmpeg -f lavfi -i color=black:r=30 -t 30 -c:v mpeg2video -g 15 out.mkv'
[00:37:54 CEST] <c_14> Ditto when using mandelbrot
[00:38:38 CEST] <c_14> Can you reproduce when using one of those as source? Because if you get != 67 i-frames with those sources something might be wrong with your ffmpeg version
[00:39:36 CEST] <UKCoder> c_14 : What are you using to tell you the number of GOPs? I'm using ffprobe -show_frames myfile.ts | grep 'pict_type=I' | wc -l
[00:40:14 CEST] Action: c_14 was using key_frame=1, but that should work.
[00:40:22 CEST] <c_14> Do you maybe have an audio stream in there as well?
[00:41:05 CEST] <UKCoder> c_14 : I do, but greping on pict_type=I should ignore audio right?
[00:42:02 CEST] <c_14> Should, you might want to add '-select_streams v' anyway though.
[00:45:03 CEST] <UKCoder> c_14 : in ffprobe?  I'm getting an unrecognized option for select_streams
[00:45:24 CEST] <c_14> in ffprobe
[00:47:53 CEST] <Nolski> Whenever I change my encoding from QTmuxingAppLibWebM-0.0.1 to anything else, all of the sudden none of my ffmpeg commands work T_T
[00:48:05 CEST] <Nolski> This stuff makes my brain hurt so bad
[00:54:13 CEST] <UKCoder> c_14 : bizarre, I just used squeeze to transcode and confirmed that it was generating 15 fps GOPs with 30fps video using ffprobe then ran it through ffmpeg and ffprobe shows the resultant file with 67 GOPs
[00:54:32 CEST] <UKCoder> instead of 60 (for 29.99s worth of content)
[00:56:12 CEST] <UKCoder> Mind you, I am using a very old version of ffmpeg... going to download the latest and see if it still exhibits the same behavior
[01:06:42 CEST] <UKCoder> c_14 : yup, still with the latest version of ffmpeg it's generating 67 GOPs instead of 60
[01:48:42 CEST] <c_14> Hmm, weird. No clue, sorry.
[04:37:19 CEST] <pothibo> Anyone here?
[04:39:08 CEST] <klaxa> no? (yes)
[04:39:46 CEST] <pothibo> :D
[04:40:30 CEST] <pothibo> Im wondering if its possible to get a stream from UDP (expecting h264 but it might need transcoding, not sure yet) and stream that feed to HLS within 1s latency with ffserver
[04:41:10 CEST] <pothibo> Im at the initial tryout and I got a ~10sec latency behind a RTSP feed
[04:41:43 CEST] <klaxa> i don't know about ffserver, but you can try using ffmpeg and 1 second segments
[04:42:00 CEST] <pothibo> well, ffserver receives a feed from ffmpeg
[04:42:03 CEST] <klaxa> i'm not sure how well that will work
[04:42:24 CEST] <pothibo> Thats the thing. I have no idea where that 10s comes from..
[04:42:43 CEST] <pothibo> Its all bound localhost.. so there is a treshold somewhere
[04:43:02 CEST] <pothibo> Im wondering if its not some issues with some keyframes or something
[04:43:37 CEST] <klaxa> oh that could indeed be
[04:44:32 CEST] <QQ> Hello. I'm attempting to concatenate (without reencoding) three aac files with VBR, using the concat demuxer (ffmpeg -f concat -i input.txt -c copy destination.aac). Everything works fine, except that the resulting file (destination.aac) reads the wrong duration both in Winamp and if I use ffprobe (or ffmpeg -i) on it. I even specify inside of input.txt the duration for each one of the files I'm merging, nothing changes.
[04:44:39 CEST] <QQ> For what I've seen after searching a good while on google, it seems it's a pretty common problem. Is there any way to fix that and create a file that doesn't reencode AND writes the appropriate duration to the headers at the same time? Thanks a lot for any help provided.
[07:15:13 CEST] <well0ne> hi, is it possible to run ffmpeg in daemon/background modus?
[07:15:19 CEST] <well0ne> without nohup/screen
[07:55:55 CEST] <well0ne> anyone?
[07:56:34 CEST] <Canar> well0ne: what do you expect to do with it running as a daemon
[07:56:49 CEST] <Canar> you just mean continue to encode?
[07:57:20 CEST] <well0ne> nothing special, it doesnt have to accept commands, it should just launch in background without external tools like nohup or screen
[07:57:42 CEST] <chungy> what are you trying to accomplish?
[07:57:55 CEST] <well0ne> i already told you lol
[07:57:58 CEST] <well0ne> running in background
[07:58:00 CEST] <Canar> ffmpeg -i input.mp4 output.mkv &
[07:58:10 CEST] <well0ne> no i mean real background
[07:58:25 CEST] <well0ne> if i close the session the command is dead
[07:58:29 CEST] <chungy> Can you explain more?
[07:58:39 CEST] <well0ne> well there is not mutch to explain
[07:58:49 CEST] <well0ne> i'm on  a system where i cant use nohup/screen
[07:59:02 CEST] <well0ne> and i want to pipe the ffmpeg process into background
[07:59:23 CEST] <chungy> That's pretty much the way to do it.
[07:59:27 CEST] <Canar> bash disown?
[08:00:06 CEST] <Canar> https://en.wikipedia.org/wiki/Disown_%28Unix%29
[08:00:37 CEST] <well0ne> wont work
[08:00:52 CEST] <Canar> if disown won't work, nothing else will fare better
[08:01:16 CEST] <Canar> you're dealing with some bofh sysadmins
[08:01:22 CEST] <chungy> if you can give more details about your system it might help
[08:01:25 CEST] <well0ne> well i just asked if its possible to mod ffmpeg that way or if there is a existent patch
[08:01:32 CEST] <Canar> yeah
[08:01:38 CEST] <Canar> but that cannot be fixed on the ffmpeg side
[08:01:45 CEST] <well0ne> aha?
[08:01:46 CEST] <chungy> like... it's possible to use systemd as a user instance and you could run ffmpeg through that. It's convoluted but it'd work xD
[08:01:54 CEST] <Canar> if disown won't solve the problem, there is no change that can do better
[08:02:14 CEST] <well0ne> why so?
[08:02:24 CEST] <well0ne> dont make sense to me
[08:02:32 CEST] <Canar> because your sysadmin has something set up to remove processes of the logged out user
[08:02:43 CEST] <Canar> ie. the system does not operate as a normal linux system
[08:03:03 CEST] <well0ne> i dont have the tools, and i simply dont want them too
[08:03:21 CEST] <well0ne> for example tell me how to start a ffmpeg command over php
[08:03:27 CEST] <well0ne> without screen, or any other
[08:03:32 CEST] <well0ne> which will run in background
[08:03:41 CEST] <well0ne> without killing the process/timeout for php
[08:03:41 CEST] <Canar> ugh
[08:03:44 CEST] <Canar> you don't get it
[08:03:47 CEST] <well0ne> i get it
[08:03:50 CEST] <well0ne> really
[08:03:52 CEST] <Canar> "run in backgroun" is meaningless
[08:04:01 CEST] <Canar> ffmpeg does something
[08:04:05 CEST] <Canar> what something do you want
[08:04:10 CEST] <well0ne> other tools have daemon modus too
[08:04:15 CEST] <well0ne> why ffmpeg not
[08:04:24 CEST] <well0ne> thats just my question
[08:04:28 CEST] <well0ne> i really get your point
[08:04:41 CEST] <Canar> you cannot get my question given your stated interpretations
[08:04:43 CEST] <Canar> cannot possibly
[08:04:53 CEST] <Canar> "daemon modus" does something
[08:05:06 CEST] <well0ne> yeah, as far as i know the most are waiting for commands
[08:05:14 CEST] <well0ne> but thats not what i want to accomplish
[08:05:21 CEST] <Canar> waiting for commands received how though
[08:05:28 CEST] <Canar> you talk in meaningless generalizations
[08:05:38 CEST] <Canar> no wonder you can't find answers
[08:05:46 CEST] <well0ne> huh?
[08:06:02 CEST] <Canar> your problem statement is ill-defined
[08:06:24 CEST] <well0ne> if you mean
[08:06:50 CEST] <chungy> ffmpeg runs with the operations you tell it, and then exits. It doesn't have a "daemon mode"
[08:07:33 CEST] <Canar> ^^^
[08:07:44 CEST] <well0ne> my command never ends
[08:07:47 CEST] <well0ne> its a loop
[08:07:52 CEST] <well0ne> its streaming my files 24/7
[08:07:56 CEST] <Canar> good for your command
[08:08:01 CEST] <well0ne> yeah i know
[08:08:15 CEST] <Canar> i thought you were talking about ffmpeg though
[08:08:21 CEST] <Canar> don't know why you bring your command up
[08:08:28 CEST] <well0ne> lol
[08:08:35 CEST] <well0ne> it was based on your previous talking
[08:08:42 CEST] <well0ne> it doesnt exit
[08:08:45 CEST] <well0ne> that was my point
[08:09:08 CEST] <Canar> cool story bro
[08:09:15 CEST] <well0ne> yah
[08:13:03 CEST] <Canar> so i mean like
[08:13:09 CEST] <Canar> you've got your command
[08:13:15 CEST] <Canar> it transcodes one stream to another
[08:13:20 CEST] <Canar> what's the input? what's the output?
[08:13:51 CEST] <well0ne> thats not really necessary,
[08:14:09 CEST] <well0ne> i just asked if there is a background option, a simple "no" would have been okay
[08:14:18 CEST] <Canar> k
[08:14:50 CEST] <Canar> ...but this "background option" you speak of isn't provided by processes, generally, it's provided by the os/shell
[08:15:47 CEST] <well0ne> ok
[08:16:11 CEST] <chungy> A program can double-fork and force itself to be disowned by the shell, but such an operation still doesn't make sense with ffmpeg given what the program does
[08:16:55 CEST] <well0ne> i see
[08:17:20 CEST] <chungy> hypothetically there could be a command that receives json or whatever of stuff to do and call off all the same functions that ffmpeg does, but without exiting. Doesn't exist (upstream) yet.
[08:18:24 CEST] <well0ne> ah, cool, thanks
[08:18:29 CEST] <well0ne> didnt know that
[08:18:41 CEST] <Canar> if this kind of feature is useful to you, it's about an hour or two's worth of shellscript hacking to have a working prototype
[08:18:49 CEST] <Canar> maybe quicker if you're eliter
[08:19:13 CEST] <Canar> ...but then you need details
[08:19:47 CEST] <chungy> also if your sysadmin doesn't let you keep processes running after you log out, such a command wouldn't be helpful to you anyway
[08:24:23 CEST] <well0ne> well i can try to taslk to them
[08:24:32 CEST] <well0ne> do you think disown would work in php too?
[08:25:36 CEST] <Canar> if it won't work in your shell, i can't see why php would be different, but perhaps the policies are lax enough to let that sneak through
[08:25:37 CEST] <chungy> php isn't bash. no
[08:25:40 CEST] <Canar> you'd have to run through bash
[08:26:08 CEST] <well0ne> ok, thanks for your kindness
[08:26:33 CEST] <Canar> sorry if i can be a bit autistic regarding support details heh
[08:26:57 CEST] <well0ne> its okay, my english is not the best, i have problems to explain what are my points
[08:27:56 CEST] <well0ne> what my points are ? whats right? -.- its a long time ago...
[08:31:01 CEST] <Canar> what your points are
[08:31:14 CEST] <Canar> i barely notice, chat with people with broken english all the time lol
[08:31:52 CEST] <Canar> est-ce que vous etes francais?
[08:32:08 CEST] <Canar> your grammatical mistakes remind me of francophones
[08:33:13 CEST] <well0ne> nope, i'm german
[08:33:31 CEST] <well0ne> my english is quite well sometimes
[08:33:43 CEST] <well0ne> but if i don write / speak it for some time
[08:33:50 CEST] <well0ne> i have problems with gramar
[08:34:22 CEST] <Canar> hahaha your english is still better than my french
[08:34:31 CEST] <well0ne> possible^^
[08:34:39 CEST] <Canar> and that's the only other language i can even remotely speak
[08:35:10 CEST] <well0ne> well, i think your french is better than my italian
[09:00:28 CEST] <well0ne> Canar is it possible to tell a process to disown ?
[09:00:40 CEST] <well0ne> i mean directly from itself
[09:01:55 CEST] <well0ne> i think i already know the answer
[09:36:51 CEST] <Canar> uh what
[09:37:01 CEST] <Canar> disown is a bash command that does specific thingsw
[09:37:48 CEST] <Canar> well0ne: in C, fork()
[09:39:08 CEST] <Canar> http://linux.die.net/man/2/setsid ?
[09:39:30 CEST] <Canar> http://linux.die.net/man/1/daemonize
[09:42:07 CEST] <kahtahs> durandal_1707: select='gt(scene\,0.4)' <- what exaclty is that doing? doc says something about 'first scenes', but i would want all
[09:43:10 CEST] <durandal_1707> selects depending on scene change score
[09:45:47 CEST] <kahtahs> could you enforce some min/max numbers of frames?
[09:48:55 CEST] <durandal_1707> maybe with some fu in equatition
[14:26:02 CEST] <nardev> guys, i need somebody to write me commands for converting videos i'm prepared to pay that. it should be able to process feew different formats and convert videos to a few most popular formats.. nothing which would not work out of box in ffmpeg.. and maybe some tweaking about processor usage and quality but that second part is less important. Anyone interested?
[17:06:57 CEST] <donguston> Anyone know of a good ffmpeg wrapper for C#? Needs to have progress output.
[18:31:16 CEST] <TikityTik> is there a windows build that has --enable-libass?
[18:32:11 CEST] <c_14> I think the zeranoe builds have it.
[18:32:29 CEST] <JEEB> or you just use mpv's windows builds if you want to encode stuff with subtitles rendered on top of video
[18:33:18 CEST] <TikityTik> JEEB: that's what i want
[18:33:20 CEST] <TikityTik> mpv?
[18:33:49 CEST] <JEEB> the video player which also has encoding support
[18:33:52 CEST] <TikityTik> also why isn't --enable-libass default?
[18:34:26 CEST] <JEEB> because FFmpeg has always been like that for most dependencies (zlib and bzip2 are the two exceptions I can think of)
[18:34:28 CEST] <q3cpma> Hello, I have a dvd with a pixel aspect ratio different than 1. How can I expand the video before encoding it, and get the final viewing resolution?
[18:36:02 CEST] <chungy> DVDs always have a SAR 8:9. Use the -aspect option to change the DAR (eg, -aspect 16:9 or -aspect 4:3)
[18:36:12 CEST] <TikityTik> oh i did have zeranoe's build
[18:36:20 CEST] <TikityTik> i just applied the syntax poorly
[18:36:47 CEST] <JEEB> chungy: if you are using SAR in the wikipedia definition just stop that. no-one uses SAR for that
[18:37:00 CEST] <q3cpma> i tried, but I still get 720x480 => 853x480 in the end
[18:37:01 CEST] <JEEB> also DVDs have the aspect ratio correctly flagged in the video stream
[18:37:17 CEST] <chungy> JEEB: I'm using SAR in the ffmpeg definition
[18:37:24 CEST] <q3cpma> I also tried -vf setsar=1
[18:37:29 CEST] <chungy> q3cpma: yes, because the DAR is 16:9
[18:37:46 CEST] <JEEB> chungy: most definitely not
[18:37:53 CEST] <JEEB> q3cpma: just go look at the scaling examples in either ffmpeg-all.html or the trac wiki
[18:38:09 CEST] <chungy> I didn't even look at Wikipedia, only ffmpeg.
[18:38:25 CEST] <JEEB> then you have no idea what SAR means if you say that DVDs have a SAR of 8:9
[18:38:25 CEST] <q3cpma> JEEB: I know how to scale, but I thought PAR was a different issue
[18:38:30 CEST] <chungy> NTSC DVDs always have the source pixels at 720x480, it'll scale to 640x480 or 853x480 depending on 4:3 or 16:9
[18:39:11 CEST] <JEEB> q3cpma: I thought your issue was getting the resolution not being a modulo of your chroma subsampling
[18:39:53 CEST] <q3cpma> No. I have a 720x480 video expanding to 853x480 when played, but I'd like a 853x480 video after conversion
[18:40:18 CEST] <JEEB> which is what scaling filter does... except you don't want 853x480 with 4:2:0 YCbCr
[18:40:23 CEST] <JEEB> because it's not mod2
[18:40:32 CEST] <CandyGumdrop> How do I use avdevice_list_devices in libavdevice?  The second parameter is AVDeviceInfoList **---what does this mean I need to provide / allocate?
[18:41:49 CEST] <JEEB> chungy: OK so 8:9 was to make 720x480 4:3. I stand corrected there. You do seem to know what you're talking about on some level.
[18:41:55 CEST] <q3cpma> JEEB: Sure, I would crop
[18:42:59 CEST] <anaraug> I just typed out a paragraph long question and then right before hitting enter figured out the answer for myself.
[18:43:08 CEST] <anaraug> Just letting you guys know.
[18:43:19 CEST] <anaraug> It was SO dumb.
[18:43:43 CEST] <JEEB> chungy: btw if you want to know some scary stories about what DVDs really mean with the aspect ratio flag you should know that in reality the aspect ratio means the "analogue" (BT.601) derived ones.
[18:43:52 CEST] <JEEB> This was later confirmed by the blu-ray spec
[18:44:05 CEST] <JEEB> which sets those values specifically for SD content
[18:44:12 CEST] <anaraug> I followed the instructions here https://trac.ffmpeg.org/wiki/Encode/YouTube for turning an audio file into a video with spectrograph. And was about to ask why on youtube it was in SD not HD. The answer was that youtube wasn't done processing yet. :(
[18:44:19 CEST] <q3cpma> Bluray may be shit, but at least, it doesn't have all this bullshit
[18:44:22 CEST] <kepstin> CandyGumdrop, I would expect that means you want to have a "AVDeviceInfoList *mylist;" then call avdevice_list_devices with "&mylist;"
[18:44:35 CEST] <kepstin> modulo an extra ; that snuck in there
[18:44:37 CEST] <nardev> guys, i need somebody to write me commands for converting videos i'm prepared to pay that. it should be able to process feew different formats and convert videos to a few most popular formats.. nothing which would not work out of box in ffmpeg.. and maybe some tweaking about processor usage and quality but that second part is less important. Anyone interested?
[18:44:42 CEST] <JEEB> q3cpma: it does have non-1:1 SAR just for your information :P
[18:44:50 CEST] <chungy> Blu-ray has backwards compatibility with DVD streams, heh. and likewise, DVD has backwards compatibility with VCD...
[18:44:56 CEST] <chungy> 240p videos on a Blu-ray Disc anyone? :P
[18:45:00 CEST] <JEEB> lol
[18:45:03 CEST] <JEEB> I don't think that's in the spec
[18:45:08 CEST] <JEEB> at least I don't remember seeing it
[18:45:15 CEST] <JEEB> only down to 480i/480p
[18:45:41 CEST] <kepstin> I wouldn't be surprised if 240p videos work on most bd players, even if it is out of spec :/
[18:45:52 CEST] <chungy> I'm not sure if BD allows for VCD streams, haha
[18:45:57 CEST] <q3cpma> JEEB: Well, when I play the mt2s files, ffplay doesn't tell me about any scaling
[18:46:15 CEST] <chungy> the old DVD codecs makes sense, sometimes it's easier to transfer special features straight from DVD
[18:46:42 CEST] <TikityTik> I can't seem to get the subtitles filter working
[18:46:42 CEST] <JEEB> q3cpma: that just means that you haven't stumbled on any such content yet :P
[18:46:46 CEST] <q3cpma> JEEB: scaling doesn't work. It still tells me 832x480 => 858x480.
[18:46:58 CEST] <JEEB> q3cpma: then you are using it wrong. also wtf is 832x480
[18:47:04 CEST] <q3cpma> (I cropped it to 832 width)
[18:47:08 CEST] <TikityTik> this is what i'm inputting. ffmpeg -i out.mkv -c:v libvpx -crf 23 -c:a libvorbis -ac 1 -ar 44000 -b:a 96k -vf subtitles=out.mkv out.webm
[18:47:27 CEST] <JEEB> q3cpma: also if you are very close to the SAR value but not exact, you may want to force the sar with setsar
[18:47:42 CEST] <JEEB> also man that's a whole lot of cropping :P
[18:48:12 CEST] <q3cpma> JEEB: I'll try. By the way, how do I set two variables in filters? I usually use "sws_flags=lanczos; scale=..."
[18:48:17 CEST] <CandyGumdrop> kepstin: The function seems to be returning a negative value indicating an error.  On the ML someone on a similar question suggests to use int avdevice_list_input_sources instead, and then says "But, dshow doesn't implement this API yet, so you will get an error."  Does this mean there's no way of finding a list of inputs available with dshow?
[18:48:39 CEST] <kepstin> hey, most analogue content on dvd is designed to have the edges not displayed, because analog->digital sampling is awesome...
[18:48:54 CEST] <kepstin> so it often makes sense to crop a good chunk off the horizontal
[18:49:28 CEST] <q3cpma> JEEB: forget that variable question, it's dumb
[18:50:17 CEST] <chungy> scale=853:480:flags=lanczos+another_one
[18:50:20 CEST] <JEEB> kepstin: I'm not sure about "not displayed" but yes, if you want to do it correctly and show it fullscreen on a 16:9 screen you crop 8px from both sides
[18:50:57 CEST] <JEEB> (or you just show the full picture and enjoy the black bars on top and bottom because it's wider than 16:9)
[18:51:03 CEST] <q3cpma> chungy: Thanks
[18:51:22 CEST] <JEEB> DVDs are not really supposed to have non-active content otherwise though
[18:51:40 CEST] <JEEB> also that 8px number comes from 480i DVDs
[18:52:32 CEST] <JEEB> or I'm not sure if DVDs are supposed to have any non-active content at all.
[18:53:20 CEST] <q3cpma> I tried "setsar=1, scale=853:480, crop=832:480:12:0" and it still doesn't work
[18:53:28 CEST] <kepstin> q3cpma, wrong order
[18:53:41 CEST] <kepstin> do scale=853:480, setsar=1, crop=832:480:12:0
[18:53:43 CEST] <q3cpma> Heh, I get it
[18:54:04 CEST] <kepstin> scale updates the sar so the displayed video stays the same size
[18:54:27 CEST] <kepstin> er, same aspect ratio anyways
[18:54:31 CEST] <q3cpma> Now, is there a point in doing this? (Hehe)
[18:54:53 CEST] <JEEB> only if your playback device can't handle aspect ratio correction
[18:54:54 CEST] <q3cpma> kepstin: still gets me " 832x480 => 853x480 yuv420p"
[18:55:25 CEST] <JEEB> in general when you re-encode DVDs you just crop and leave the aspect ratio to be handled by the player
[18:55:51 CEST] <kepstin> unless you're encoding for really piece of junk hardware players or something, yeah
[18:55:56 CEST] <q3cpma> JEEB: That's what I'll do in fine. Especially since I can crop to modulo 16
[18:56:12 CEST] <JEEB> mod16 cropping isn't really a thing any more
[18:56:31 CEST] <q3cpma> x264 doesn't benefit anymore from it?
[18:56:34 CEST] <JEEB> AVC and HEVC fixed the inefficiency to be so small that you just don't give a fuck.
[18:56:40 CEST] <q3cpma> I see.
[18:56:54 CEST] <q3cpma> Well, I won't use these anyway.
[18:56:57 CEST] <q3cpma> Waiting for Daala
[18:57:08 CEST] <kepstin> I mean, they had to fix it for AVC anyways because 1080p video.
[18:57:23 CEST] <q3cpma> Even mod8 isn't helpful?
[18:57:28 CEST] <JEEB> nope
[18:57:53 CEST] <JEEB> if you start limiting your mod it's usually to fix playback on some shitty device or player you're supporting
[18:57:54 CEST] <q3cpma> What about VPx? (not that I use them)
[18:58:25 CEST] <JEEB> no idea about the possible compression loss there, but I'd guess that they really don't give a damn either in compression efficiency
[18:59:49 CEST] <TikityTik> I have my ffmpeg complaining about fontconfig when I use the subtitles filter, any help?
[19:00:16 CEST] <q3cpma> TikityTik: you should try to extract your subtitle with mkvextract.
[19:00:57 CEST] <q3cpma> TikityTik: if I remember well, the subtitle filter only works with srt. You need the ass filter for, well, ssa/ass
[19:01:46 CEST] <kepstin> q3cpma, nah, that's wrong. the 'subtitles' filter loads any file format ffmpeg can read with subtitles, and renders with libass.
[19:02:22 CEST] <kepstin> in particular, it's the only way in ffmpeg to render ass subtitles with embedded fonts, which is probably where the fontconfig complaints are coming from.
[19:02:26 CEST] <q3cpma> kepstin: well, I remembered badly. Can choose the stream with this filter
[19:09:51 CEST] <TikityTik> q3cpma: I'm using the assfilter but i'm not seeing anything overlaying
[19:11:06 CEST] <q3cpma> TikityTik: No errors from ffmpeg?
[19:11:25 CEST] <TikityTik> it's giving me: Cannot load default config file
[19:11:28 CEST] <TikityTik> for fontconfig
[19:12:03 CEST] <q3cpma> TikityTik: That's strange. Could you try to edit the ass file (it's plaintext) and use a font you're sure to have installed?
[19:24:45 CEST] <TikityTik> I'm just trying to figure out why it's complaining about my fontconfig
[19:25:00 CEST] <q3cpma> TikityTik: You're using Windows?
[19:25:08 CEST] <TikityTik> yes
[19:25:25 CEST] <q3cpma> TikityTik: There are some forum post on the web about your error
[19:25:33 CEST] <TikityTik> yeah i've been reading
[19:25:50 CEST] <TikityTik> i tried making this fontconfig and setting the environment variables to point to it, but no luck
[19:25:54 CEST] <nardev> anyone?
[19:26:06 CEST] <nardev> i posted my question here: http://ffmpeg.gusari.org/viewtopic.php?f=11&t=2238
[19:27:29 CEST] <q3cpma> nardev: well, what don't you understand about ffmpeg that impeach you from doing this?
[19:27:55 CEST] <nardev> q3cpma, i just want to save some time, i'm not into that..
[19:28:03 CEST] <nardev> my requirements are not complex
[19:28:26 CEST] <nardev> i have some clips up to 100MB and under 1 minute
[19:28:32 CEST] <nardev> which i want to convert to
[19:28:44 CEST] <nardev> appropriate formats to be able to play them anywhere
[19:28:48 CEST] <nardev> the server is Debian
[19:29:03 CEST] <nardev> with multimedia repos where i gor ffmpeg
[19:29:06 CEST] <nardev> *got
[19:29:15 CEST] <BtbN> you could have already solved it yourself by now
[19:29:25 CEST] <nardev> BtbN, please help
[19:29:28 CEST] <nardev> i'll pay you for that
[19:29:38 CEST] <nardev> i'm not into that..
[19:30:43 CEST] <q3cpma> nardev: Well, except if one of those input formats isn't supported by ffmpeg, you don't care about it.
[19:31:17 CEST] <q3cpma> nardev: webm is a container. I suppose you mean vp8. Same for ogg (ogv), theora?
[19:31:18 CEST] <nardev> q3cpma, ok.. so ignore that part, just the
[19:31:21 CEST] <nardev> export
[19:31:28 CEST] <nardev> ogg
[19:31:39 CEST] <nardev> something which would play anywhere
[19:31:59 CEST] <nardev> so my goal..
[19:32:00 CEST] <q3cpma> I don't know if theora can be played everywhere
[19:32:01 CEST] <nardev> 4-5
[19:32:09 CEST] <nardev> q3cpma, i mean in total
[19:32:24 CEST] <nardev> i want to get 4-5 different versions of same clip
[19:32:35 CEST] <nardev> and that one of those versions is possible to play
[19:32:43 CEST] <nardev> where ever i need that clip
[19:32:46 CEST] <q3cpma> nardev: You just need an h264 profile/level compatibility table
[19:33:18 CEST] <nardev> q3cpma, .. ok.. would you be able to provide me with a command and the rest?
[19:33:44 CEST] <nardev> and tell me in private how much would that cost me
[19:33:44 CEST] <q3cpma> nardev: have a you a bitrate/filesize limit?
[19:34:01 CEST] <nardev> q3cpma, well if bitrate can affect playing on an iphone
[19:34:04 CEST] <q3cpma> Man, I don't want money for such a thing. It'd be shamefule for me (and for you)
[19:34:06 CEST] <nardev> yes..
[19:34:22 CEST] <nardev> q3cpma, i would be honored to pay you if it works for me..
[19:34:26 CEST] <nardev> nothing to be ashamed
[19:34:42 CEST] <nardev> you do what you are an expert for i do what i do..
[19:34:49 CEST] <q3cpma> https://developer.apple.com/library/ios/documentation/NetworkingInternet/Conceptual/StreamingMediaGuide/FrequentlyAskedQuestions/FrequentlyAskedQuestions.html
[19:35:54 CEST] <q3cpma> Apparently, high at 4.1 is supported. You need baseline at 3.1 if you want to support the ipad, the iphone 3G and the ipod touch
[19:36:44 CEST] <nardev> q3cpma, oki..
[19:37:08 CEST] <nardev> so it's double video clip version for ipphone?
[19:37:12 CEST] <nardev> it is ok..
[19:37:33 CEST] <q3cpma> double video clip? what?
[19:37:37 CEST] <nardev> is it reverse compatible if i get baseline at 3.1 would it play on newer iphone?
[19:37:49 CEST] <q3cpma> Yeah, of course.
[19:38:12 CEST] <nardev> than would only need that version with baseline at 3.1?
[19:39:19 CEST] <nardev> q3cpma, could i expect you to do it for me?
[19:40:23 CEST] <q3cpma> I don't know about your resolution or bitrate, but I'd try something like "ffmpeg -i input -c:v libx264 -profile:v baseline -level:v 3.1 -preset veryslow -crf 20 -c:a libfdk_aac -b:a -profile:a aac_he -b:a 64K -sn output.mp4é
[19:40:30 CEST] <coops> hey folks. I'm trying to stream audio to ffserver, but when I start the ffmpeg client it says: "Missing video stream which is required by this ffm". Can I either configure ffserver to allow audio-only streams, or add dummy video to the stream?
[19:40:47 CEST] <q3cpma> You'll probably need a -b:v to restrain the video bitrate, but i don't know what quality nor resolution you want and have.
[19:41:02 CEST] <q3cpma> I'd advise you to experiment with different birates
[19:41:29 CEST] <q3cpma> Oups, I mean -maxrate
[19:41:35 CEST] <q3cpma> Not -b:v
[19:42:36 CEST] <q3cpma> nardev: Also, you'll probably have to get libfdk_aac somewhere and recompile ffmpeg
[19:47:47 CEST] <nardev> q3cpma, what is libfdk_aac
[19:48:11 CEST] <q3cpma> A library to encode he-aac
[19:48:45 CEST] <nardev> which i would need why?
[19:49:25 CEST] <q3cpma> The native ffmpeg aac encoder is shit (well, it was when I tried it), and you need a low bitrate for streaming shit.
[19:49:40 CEST] <q3cpma> cf https://trac.ffmpeg.org/wiki/Encode/AAC
[19:50:04 CEST] <nardev> q3cpma, aha.. so that is only in case i need to lower bitrate so that i don't loose a lot on video quality?
[19:50:19 CEST] <q3cpma> nardev: basically
[19:50:37 CEST] <BtbN> It's not shit, it's already quite ok if you don't want to use ultra low bitrates
[19:50:50 CEST] <nardev> q3cpma, so in case my source videos are not over HD i would not have to worry about that?
[19:50:55 CEST] <BtbN> It's only AAC LC
[19:51:04 CEST] <nardev> ok
[19:51:21 CEST] Last message repeated 1 time(s).
[19:51:21 CEST] <q3cpma> nardev: it depends on what compromise you're ready to make
[19:51:27 CEST] <nardev> q3cpma, i will try without that.. and i will write down that a s i tip..
[19:51:45 CEST] <q3cpma> Ok. Maybe you'll want to scale your videos
[19:51:46 CEST] <nardev> q3cpma, right now.. it will be i ok i hope..
[19:52:06 CEST] <nardev> q3cpma, well i would scale them if ULTRA HD is
[19:52:06 CEST] <q3cpma> But you should really learn how to use ffmpeg, it's really not hard
[19:52:07 CEST] <nardev> ?
[19:52:32 CEST] <q3cpma> I mean downscale them, to reduce the bitrate requirements (then again, what the source resolution)
[19:52:41 CEST] <nardev> q3cpma, i'm into bash for many years but i don't know anything about codecs bitrates, formats etc..
[19:53:10 CEST] <q3cpma> nardev: Why don't you use a GUI if you're not into this? Handbrake is good for beginners
[19:53:11 CEST] <nardev> source resolution is what you can get from most mobile phones..
[19:53:13 CEST] <nardev> about HD
[19:53:29 CEST] <nardev> q3cpma, i have to make web interface :P
[19:53:47 CEST] <q3cpma> nardev: Ah
[19:53:52 CEST] <nardev> i already made that to work with vzaar and it's SHIT
[19:53:59 CEST] <nardev> all other services are SO EXPENSIVE...
[19:54:09 CEST] <q3cpma> What the resolution of your input file?
[19:55:06 CEST] <TikityTik> is there a way I can use -ss with the subtitles overlay?
[19:55:08 CEST] <nardev> q3cpma, usually from mobile phones
[19:55:13 CEST] <nardev> it can be HD
[19:55:17 CEST] <TikityTik> i mean with the subtitiles filter
[19:55:37 CEST] <nardev> but i some people have that nasty phones with ultra HD
[19:55:40 CEST] <q3cpma> nardev: Could you explain what service you're required to provide? It's pretty vague to me
[19:56:29 CEST] <nardev> q3cpma, basically : upload video -> with videojs play in on web, should be possible to be played on android, iphone and chrome default web browsers
[19:56:32 CEST] <nardev> that is about it..
[19:56:38 CEST] <nardev> no high traffic
[19:56:42 CEST] <nardev> very strong server
[19:56:48 CEST] <q3cpma> Users upload videos?
[19:56:54 CEST] <nardev> q3cpma, yep
[19:57:16 CEST] <q3cpma> They are to be streamed or downloaded after conversion?
[19:57:29 CEST] <nardev> streamed
[19:57:34 CEST] <nardev> just that
[19:57:40 CEST] <nardev> html5 player ...
[19:58:04 CEST] <nardev> q3cpma, so you said this would work what for me? :   "ffmpeg -i input -c:v libx264 -profile:v baseline -level:v 3.1 -preset veryslow -crf 20 -c:a libfdk_aac -b:a -profile:a aac_he -b:a 64K -sn output.mp4"
[19:58:13 CEST] <q3cpma> In this case, you'll really benefit from using libfdk_aac
[19:58:27 CEST] <nardev> q3cpma, ok i'll recompole it..
[19:58:31 CEST] <nardev> no warries
[19:58:43 CEST] <nardev> but how to get all those different formats that i got in requirements
[19:58:44 CEST] <nardev> ?
[19:59:03 CEST] <q3cpma> "ffmpeg -i input -c:v libx264 -profile:v baseline -level:v 3.1 -preset veryslow -crf 20 -maxrate 1000K -c:a libfdk_aac -b:a -profile:a aac_he -b:a 64K -sn output.mp4"
[19:59:10 CEST] <q3cpma> And you need to scale it
[19:59:17 CEST] <q3cpma> downscale it to a sane value
[19:59:18 CEST] <nardev> q3cpma, no
[19:59:22 CEST] <nardev> ig it is playable
[19:59:26 CEST] <nardev> on ay device
[19:59:33 CEST] <q3cpma> The thing is that you can't use maxrate with scaling it
[19:59:34 CEST] <nardev> i'm afraid high resolutions would no t pley
[19:59:56 CEST] <nardev> this was my guidelines.. (btw zencoder is great BUT SO EXPENSIVE!!!)
[20:00:39 CEST] <q3cpma> Well, if you play a 4K video on a 840x480 screen, it'll be useless
[20:01:36 CEST] <q3cpma> I'd use 1280x720 as output, personally
[20:02:28 CEST] <nardev> q3cpma, for all videos
[20:02:28 CEST] <nardev> ?
[20:02:34 CEST] <nardev> i would too..
[20:02:43 CEST] <q3cpma> Yeah, so you can precise a maxrate
[20:02:49 CEST] <nardev> i'm afraid smaller screens are on devices that would jam...
[20:03:04 CEST] <nardev> so.. rescaling would be enough?
[20:03:16 CEST] <nardev> is there a way to rescale only those that are bigger and to leave
[20:03:19 CEST] <nardev> others as is
[20:03:20 CEST] <nardev> ?
[20:03:26 CEST] <q3cpma> The only thing you need for device compatibility is profile and level
[20:03:37 CEST] <q3cpma> (if your device support h264 and aac, of course)
[20:04:11 CEST] <q3cpma> Also, what's the framerate?
[20:08:13 CEST] <nardev> hm :(
[20:08:16 CEST] <nardev> q3
[20:08:26 CEST] <nardev> q3cpma, wait i have to investigate :(
[20:08:56 CEST] <q3cpma> ffmpeg -i input -c:v libx264 -profile:v baseline -level:v 3.1 -preset veryslow -crf 20 -maxrate YOURRATE -r 24 -c:a libfdk_aac -b:a -profile:a aac_he -b:a 64K -sn output.mp4
[20:09:00 CEST] <q3cpma> Oups
[20:09:22 CEST] <q3cpma> ffmpeg -i input -vf scale=-1:720 -c:v libx264 -profile:v baseline -level:v 3.1 -preset veryslow -crf 20 -maxrate YOURRATE -r 24 -c:a libfdk_aac -b:a -profile:a aac_he -b:a 64K -sn output.mp4
[20:09:27 CEST] <q3cpma> It's what I'd use
[20:10:39 CEST] <nardev> q3cpma, just tell me one thing
[20:10:51 CEST] <nardev> that ffmpeg command that you wrote
[20:10:55 CEST] <nardev> would cover ll
[20:10:57 CEST] <nardev> my
[20:11:07 CEST] <nardev> all my output formats which i need ?
[20:11:15 CEST] <nardev> for all my devices?
[20:11:20 CEST] <q3cpma> Probably not. But the main platforms yes
[20:11:21 CEST] <nardev> i don't need separate files?
[20:11:53 CEST] <q3cpma> Smartphones, tablets and desktop
[20:12:01 CEST] <q3cpma> I don't know about other devices
[20:12:40 CEST] <TikityTik> for some reason when I use -t with ffmpeg, it makes the export freeze on the first frame a bit.
[20:13:33 CEST] <q3cpma> TikityTik: strange. What's your command?
[20:14:19 CEST] <nardev> q3cpma, :( phones are more important :(
[20:14:20 CEST] <TikityTik> ffmpeg -ss 1:36:38 -i eva.mkv out.mkv
[20:14:33 CEST] <TikityTik> q3cpma: I then stop it manually
[20:15:13 CEST] <q3cpma> nardev: phones or smartphones?
[20:15:19 CEST] <nardev> smartphones only
[20:15:45 CEST] <nardev> iphone 3 and above and android phones not older than 3-4 years
[20:15:47 CEST] <q3cpma> nardev: Well, I advised baseline at 3.1 because it even works on old iphones
[20:15:57 CEST] <q3cpma> TikityTik: You said you were using -t
[20:16:05 CEST] <nardev> so this would work even for that? ffmpeg -i input -vf scale=-1:720 -c:v libx264 -profile:v baseline -level:v 3.1 -preset veryslow -crf 20 -maxrate YOURRATE -r 24 -c:a libfdk_aac -b:a -profile:a aac_he -b:a 64K -sn output.mp4
[20:16:18 CEST] <TikityTik> q3cpma: ffmpeg.exe -ss 1:36:38 -i eva.mkv -t 2:07 out.mkv
[20:16:32 CEST] <TikityTik> it's freezing a bit on the first frame
[20:16:46 CEST] <q3cpma> nardev: You should check the profile/level requirement for other OSes, too.
[20:16:53 CEST] <q3cpma> TikityTik: Isn't the -t before the -i?
[20:17:35 CEST] <TikityTik> I'll give it a try
[20:17:38 CEST] <q3cpma> TikityTik: Also, you should always try to play your video with ffplay, to see if there are errors
[20:17:46 CEST] <TikityTik> oh
[20:18:29 CEST] <TikityTik> q3cpma: typing this didn't make it stop. ffmpeg.exe -ss 1:36:38 -t 2:07 -i eva.mkv out.mkv
[20:18:38 CEST] <TikityTik> it kept on encoding
[20:19:10 CEST] <q3cpma> TikityTik: Sorry, I'm dumb, the -ss after the -i, normally
[20:19:45 CEST] <q3cpma> nardev: another interesting page for you https://developer.android.com/guide/appendix/media-formats.html
[20:20:46 CEST] <TikityTik> q3cpma: I added -ss after -i and it seems to be stuck
[20:21:01 CEST] <TikityTik> where it shows frame= 0 and fps= 0.0
[20:21:06 CEST] <nardev> q3cpma, that is exactly why i was looking to pay somebody
[20:21:27 CEST] <nardev> so that i don't need to spend days going around and tuning this shit to work
[20:21:49 CEST] <q3cpma> TikityTik: It may take some time, -ss after the -i is precise seeking
[20:22:07 CEST] <TikityTik> arg, isn't there a faster way?
[20:22:43 CEST] <q3cpma> nardev: I gave you the command, and you basically only have to search for "h264 profile level OSname" to see what's the maxium profile and level you can use
[20:22:54 CEST] <q3cpma> It's only websurfing nox
[20:23:53 CEST] <nardev> q3cpma, :)
[20:24:11 CEST] <q3cpma> TikityTik: https://trac.ffmpeg.org/wiki/Seeking
[20:24:44 CEST] <q3cpma> TikityTik: there's a thing called "combined seeking" apparently
[20:26:24 CEST] <c_14> -ss before -i is both fast and accurate (with recent versions of ffmpeg)
[20:27:01 CEST] <q3cpma> c_14: yeah, but he seemd to have some problems with it
[20:27:15 CEST] <q3cpma> TikityTik: have you tried playing it with ffplay to look for errors?
[20:27:33 CEST] <TikityTik> yeah there was an error
[20:27:48 CEST] <q3cpma> TikityTik: which is?
[20:28:49 CEST] <TikityTik> SDL_OpenAudio (6 channels, 48000 Hz): DirectSound CreateSoundBuffer: Invalid parameter
[20:28:53 CEST] <TikityTik> SDL_OpenAudio (4 channels, 48000 Hz): DirectSound CreateSoundBuffer: Invalid parameter
[20:29:22 CEST] <q3cpma> TikityTik: well, that's not it. Maybe you should try with more precise number? Like 01:36:38.000
[20:32:31 CEST] <TikityTik> q3cpma: I think that did the trick
[20:32:36 CEST] <TikityTik> q3cpma: finally got what i wanted
[20:32:47 CEST] <q3cpma> TikityTik: which one did fix it?
[20:33:06 CEST] <TikityTik> making it more precise
[20:33:10 CEST] <TikityTik> or it might've been luck lol
[20:33:32 CEST] <q3cpma> TikityTik: Yeah, it seems strange to me
[20:33:38 CEST] <TikityTik> the main problem was the freezing and when i would try to encode from the export, it would giveo ut an error
[20:34:20 CEST] <q3cpma> TikityTik: What do you mean by "export"?
[20:34:55 CEST] <TikityTik> q3cpma: I would encode an out.mkv
[20:35:06 CEST] <TikityTik> then I would use the subtitles filter on out.mkv to make out2.mkv
[20:35:19 CEST] <TikityTik> because the subtitles filter would break if i used -ss
[20:35:19 CEST] <q3cpma> Wow, why would you do that?
[20:35:38 CEST] <TikityTik> q3cpma: the filter would break on -ss
[20:35:45 CEST] <TikityTik> for input seeking
[20:36:06 CEST] <q3cpma> TikityTik: Break? Like give you an error or simply not work?
[20:36:27 CEST] <TikityTik> q3cpma: it would render the subs from the beginning of the video instead of where I asked from -ss
[20:36:40 CEST] <TikityTik> not sure if that's reported
[20:36:51 CEST] <q3cpma> TikityTik: you put the vf after -ss and -t, right?
[20:36:53 CEST] <nardev> q3cpma, Unable to find a suitable output format for 'aac_he'
[20:36:56 CEST] <TikityTik> q3cpma: yeah
[20:37:18 CEST] <q3cpma> nardev: repost the command, there must be a dumb mistake somewhere
[20:37:31 CEST] <q3cpma> TikityTik: Well, that's strange
[20:38:00 CEST] <TikityTik> i would repost it but my computer crashed, as i'm overclocking
[20:38:39 CEST] <q3cpma> nardev: There's a "-b:a" before profile:a that has nothing to do here
[20:38:39 CEST] <nardev> q3cpma, ffmpeg -i misijaweb9.mp4 -vf scale=-1:720 -c:v libx264 -profile:v baseline -level:v 3.1 -preset veryslow -crf 20 -r 24 -c:a libfdk_aac -b:a -profile:a aac_he -b:a 64K -sn output.mp4
[20:38:58 CEST] <q3cpma> Remove the first -b:a
[20:39:07 CEST] <nardev> aha
[20:39:10 CEST] <nardev> works now
[20:39:37 CEST] <nardev> q3cpma, if you sent constant bitrate why to use max bitrate then?
[20:39:51 CEST] <q3cpma> nardev: What?
[20:40:19 CEST] <nardev> i see you sen -crf here and also you suggested -maxrate
[20:40:49 CEST] <q3cpma> nardev: Ah. It's because you're streaming. You need a low bitrate. -crt + -maxrate is constrained mode.
[20:41:08 CEST] <q3cpma> Try 2M, since that's what the Android page recommends
[20:41:29 CEST] <TikityTik> q3cpma: is it recommended to use both -crf and -b:v if I'm encoding in libvpx?
[20:42:03 CEST] <q3cpma> TikityTik: It's mandatory, otherwise it defaults to 250K if I remember well. I hate libvpx with passion.
[20:42:29 CEST] <TikityTik> q3cpma: why do you hate it?
[20:42:54 CEST] <q3cpma> TikityTik: Slow, stupid option (like you can see), not properly threaded and Googleware
[20:43:21 CEST] <nardev> q3cpma, i have 16 cores xeon can i tune this to get more resources?
[20:43:27 CEST] <q3cpma> libvpx-vp9 encode under 0.1FPS on my 8350, to say how it's slow
[20:43:39 CEST] <pzich> are you using -threads 16? :D
[20:43:48 CEST] <nardev> pzich, no
[20:43:51 CEST] <nardev> ok i'll try
[20:43:56 CEST] <TikityTik> q3cpma: How should I go about adjusting crf and video bitrate? Do I adjust one before the other until satisfied, and use the other to make slight adjustments?
[20:44:00 CEST] <q3cpma> nardev: normally, you have nothing to do with libx264. ffmpeg automatically uses nproc threads
[20:44:13 CEST] <JEEB> note1: you should never use both crf and b:v together
[20:44:30 CEST] <nardev> q3cpma, so -threads would not do anything?
[20:44:32 CEST] <JEEB> note2: libvpx finally got in-picture threading in the encoder a few months back
[20:44:37 CEST] <q3cpma> TikityTik: You usually use a mix of crf, qmin/qmax and b:v
[20:44:53 CEST] <q3cpma> JEEB: I tried it, but it was still going at 0.1FPS for me
[20:44:54 CEST] <TikityTik> i never used qmin and qmax, i read that qmax doesn't do much.
[20:45:05 CEST] <JEEB> q3cpma: yeh - it's slow
[20:45:09 CEST] <q3cpma> Well, with libvpx it's really useful
[20:45:25 CEST] <q3cpma> Because it has poor movement encoding
[20:45:47 CEST] <JEEB> also I would never use qmin/max together with anything :V I would only use a rate control mode (either crf or ABR) and maxrate+bufsize for keeping the stream within bandwidth constraints
[20:46:38 CEST] <q3cpma> JEEB: libvpx behaves strangely
[20:47:23 CEST] <q3cpma> TikityTik: use this page http://www.webmproject.org/docs/encoder-parameters/
[20:49:52 CEST] <TikityTik> q3cpma: where do i input --passes?
[20:49:57 CEST] <TikityTik> it's telling me option not found
[20:50:40 CEST] <q3cpma> TikityTik: It's for vpxenc, not ffmpeg
[20:50:45 CEST] <TikityTik> ah
[20:50:54 CEST] <q3cpma> For ffmpeg, it's -pass 1 or -pass 2
[20:52:18 CEST] <q3cpma> TikityTik: What's your goal? It's to post on an imageboard or something like this?
[20:52:29 CEST] <TikityTik> yeah
[20:52:33 CEST] <nardev> q3cpma, that command doesn't even work on android :(
[20:52:39 CEST] <TikityTik> 2 pass makes the file size larger?
[20:52:54 CEST] <q3cpma> nardev: Well, then the android page has problems.
[20:53:01 CEST] <nardev> :D
[20:53:06 CEST] <nardev> q3cpma, https://www.footgoll.com/videojs/demo.html
[20:53:32 CEST] <q3cpma> TikityTik: No, it makes it better for the same size when being limited
[20:53:44 CEST] <q3cpma> nardev: Why do you use HTML5 if you don't need to embed?
[20:54:03 CEST] <nardev> q3cpma, i need to embed ...
[20:54:08 CEST] <nardev> i play in browsers
[20:54:10 CEST] <TikityTik> q3cpma: this is what i got so far, trying to lower the filesize. ffmpeg -i out2.mkv -c:v libvpx -c:a libvorbis -pass 2 -crf 35 -b:v 1000k -ar 22050 -ac 1 -b:a 64k -vf scale=-1:640 out.webm
[20:54:18 CEST] <nardev> that is what i said at first place :(
[20:55:53 CEST] <q3cpma> nardev: Well, in this case, I don't know.
[20:56:03 CEST] <TikityTik> q3cpma: is it trial and error trying to get something to a certain file size?
[20:56:13 CEST] <nardev> :)_
[20:56:21 CEST] <nardev> q3cpma, thank you anyway
[20:56:24 CEST] <q3cpma> TikityTik: No, you just habe to do some math
[20:56:31 CEST] <nardev> i'm in deep shits
[20:56:40 CEST] <TikityTik> q3cpma: is it simple math at least?
[20:57:27 CEST] <q3cpma> TikityTik: Just do a script. It's easy to find the maxrate or -b:v
[20:57:57 CEST] <TikityTik> q3cpma: a script?
[20:58:23 CEST] <q3cpma> TikityTik: I mean a shell script, to calculate the bitrate based on the duration
[20:58:29 CEST] <TikityTik> ah
[20:59:17 CEST] <q3cpma> TikityTik: "-b:v $(bc <<< "($MBLIMIT * 8192) / $RUNTIME - $ARATE")K"
[21:00:26 CEST] <TikityTik> q3cpma: what about resolution?
[21:00:55 CEST] <q3cpma> TikityTik: you should downscale
[21:01:50 CEST] <TikityTik> q3cpma: I'm wondering why that calculation doesn't include resolution.
[21:02:16 CEST] <q3cpma> TikityTik: Because it has nothing to do with it when you have a filesize limit.
[21:02:47 CEST] <TikityTik> oh, I didn't realize resolution didn't affect file size
[21:02:48 CEST] <q3cpma> TikityTik: You will have to make your video use this bitrate, whatever its resolution is
[21:11:49 CEST] <TikityTik> q3cpma: does anything besides bitrate for audio affect file size?
[21:12:08 CEST] <TikityTik> q3cpma: does sampling rate affect file size?
[21:12:30 CEST] <c_14> Nothing besides bitrate affects filesize.
[21:12:45 CEST] <q3cpma> TikityTik: Yes it does, but at 22KhZ, you only have 11KhZ of maxium frequency
[21:13:04 CEST] <TikityTik> what?
[21:13:22 CEST] <q3cpma> The maxium frequency representable is sampling rate / 2
[21:13:34 CEST] <TikityTik> does qmin and qmax help a lot?
[21:13:45 CEST] <q3cpma> And the maximum (theorical) of the human ear is 19-20Khz
[21:13:50 CEST] <TikityTik> and are there any guides on compressing and file size?
[21:14:50 CEST] <pothibo> Is it possible to serve a crossdomain.xml file from ffserver? <Redirect> is not an option as any 301/302 request gets ignroed by Flash :(
[21:14:57 CEST] <q3cpma> TikityTik: I usually using qmax 55 and qmin 5. Also, you should use Opus for audio
[21:15:57 CEST] <TikityTik> why Opus?
[21:16:10 CEST] <q3cpma> Because it's the best lossy codec?
[21:16:42 CEST] <TikityTik> why?
[21:16:48 CEST] <BtbN> because it is?
[21:16:58 CEST] <BtbN> Doesn't have the best software and hardware support though
[21:17:24 CEST] <brontosaurusrex> TikityTik: becouse it sounds best at moderate bitrates (under 128kbps), but .
[21:17:29 CEST] <q3cpma> On the desktop it's okay.
[21:17:55 CEST] <q3cpma> brontosaurusrex: Actually, it beats other lossy codecs (including vorbis and musepack sv8) at every bitrate
[21:18:11 CEST] <q3cpma> The difference is just more noticeable near 32-64K
[21:18:24 CEST] <brontosaurusrex> q3cpma: ok
[21:18:47 CEST] <q3cpma> And it's libre.
[21:19:05 CEST] <q3cpma> The only problem is its shitty handling of replay gain/r128 tags
[21:19:36 CEST] <brontosaurusrex> rgain tags are generally shity idea
[21:19:40 CEST] <q3cpma> Why?
[21:20:10 CEST] <brontosaurusrex> becous you can have external file that says -13.2
[21:20:26 CEST] <q3cpma> What?
[21:20:36 CEST] <brontosaurusrex> and not trying to force that into messy metadata standards
[21:20:45 CEST] <brontosaurusrex> that
[21:20:50 CEST] <q3cpma> ogg metadata is pretty clean
[21:20:57 CEST] <brontosaurusrex> dont care
[21:21:19 CEST] <q3cpma> Metadatas are here for that
[21:21:43 CEST] <brontosaurusrex> no, that was just an idea, the reality is messy
[21:22:10 CEST] <kepstin> i've found that most software that plays opus and supports replaygain will use vorbis-style replaygain tags if present
[21:22:15 CEST] <kepstin> so i just do that :/
[21:22:37 CEST] <q3cpma> kepstin: Well, my problem is that Rockbox use r128 tags
[21:22:53 CEST] <kepstin> hmm? rockbox does *not* support opus r128gain tags...
[21:23:25 CEST] <q3cpma> Sure?
[21:23:45 CEST] <kepstin> if you use foobar2000 to replaygain your opus files, it incorrectly puts the album gain into a special header field rather than an R128_ALBUM_GAIN tag.
[21:23:46 CEST] <q3cpma> Ah yeah.
[21:23:55 CEST] <kepstin> which is then applied by rockbox
[21:24:33 CEST] <q3cpma> Another problem is the lack of r128 gain calculator
[21:25:22 CEST] <kepstin> eh, most replaygain software right now (aside from the older command line tools on linux) actually uses the r128 algorithm, with an adjusted reference point to be replaygain compatible
[21:25:26 CEST] <brontosaurusrex> q3cpma: ffmpeg got r128 for a while now
[21:25:48 CEST] <kepstin> it's a 5dB offset between the R128 and replaygain reference levels, iirc
[21:25:50 CEST] <q3cpma> brontosaurusrex: it got the scanning, but I still don't know how to put into the metadata
[21:26:21 CEST] <brontosaurusrex> maybe ffmpeg people knew that was a bad idea
[21:26:43 CEST] <q3cpma> Why? ebur128 is more efficient than replay gain algo
[21:26:58 CEST] <q3cpma> The only problem is the default loudness
[21:27:24 CEST] <kepstin> but yeah, I have a local patch hanging around that adds support for the R128_*_GAIN tags to rockbox - it works by adjusting the reference then treating it as replaygain
[21:27:36 CEST] <kepstin> just wrote it last week, should submit the patch I guess.
[21:27:39 CEST] <brontosaurusrex> i mean puting rg tags into meta
[21:28:07 CEST] <q3cpma> Why would it be a bad idea? It's useless without this function
[21:28:17 CEST] <kepstin> replaygain in meta makes perfect sense; i can just copy my music files to my rockbox ipod and they're volume leveled there without having to recalculate anything...
[21:28:33 CEST] <brontosaurusrex> ffmpeg audio.some -calc r128 > .audio.some.rg
[21:28:47 CEST] <brontosaurusrex> play audio.some with .audio.some.rg
[21:28:49 CEST] <brontosaurusrex> done
[21:28:51 CEST] <kepstin> then I have to worry about keeping hidden files around and in sync
[21:29:05 CEST] <q3cpma> brontosaurusrex: This is really that? I thought is was -af ebur128
[21:29:12 CEST] <kepstin> same reason as why it's nice to mux subs into video files rather than have video.srt files alongside every video.mp4...
[21:29:26 CEST] <brontosaurusrex> kepstin: they are not golden, if they got lost, just recalc them
[21:29:38 CEST] <q3cpma> Also, how does this work for album gain?
[21:29:42 CEST] <kepstin> but if i put some tiny metadata in the file, they won't get lost...
[21:29:59 CEST] <JEEB> I think the only issue with ebu r128 stuff is that we need standardized places to put them, not having the data in random tags
[21:30:03 CEST] <kepstin> q3cpma, you'd probably have to do it manually by running the filter over the concatenated audio
[21:30:26 CEST] <kepstin> JEEB, http://wiki.hydrogenaud.io/index.php?title=ReplayGain_2.0_specification is what most software does now.
[21:30:29 CEST] <brontosaurusrex> q3cpma: actually dont know what would be the best way to handle album rg
[21:30:52 CEST] <JEEB> kepstin: yeah but I'd rather have specified stuff in containers for it
[21:30:58 CEST] <JEEB> rather than have it in, say, bitstream itself
[21:31:11 CEST] <JEEB> which is what id3v2 tags are f.ex.
[21:31:24 CEST] <q3cpma> Well, just don't use mpleb3, in this case
[21:32:00 CEST] <kepstin> imo, it's nice to have the spec for gain calculations separate from the container spec, so making use of whatever generic metadata the format supports seems like a good idea
[21:32:15 CEST] <q3cpma> It is
[21:32:16 CEST] <JEEB> yes, naturally
[21:32:21 CEST] <JEEB> which is why you have ebu r128 and stuff
[21:32:31 CEST] <TikityTik> q3cpma: is there a way to see the supported sampling rates for a codec?
[21:32:34 CEST] <kepstin> pretty much the only container I know of which support replaygain at the container level rather than inside the bitstream is matroska, really.
[21:32:34 CEST] <JEEB> it's just how you save that information in containers
[21:32:47 CEST] <JEEB> kepstin: are you sure that is not in random tags
[21:32:51 CEST] <kepstin> but that's just because matroska actually has container-level generic metadata
[21:33:03 CEST] <q3cpma> TikityTik: Just use opus at 64 or 96K if you need size this much, mate
[21:33:27 CEST] <JEEB> because I remember mosu adding various random information into tags instead of proper container entities
[21:33:34 CEST] <JEEB> lately
[21:34:01 CEST] <JEEB> I'd much rather have the EBU R128 stuff be in a per-stream proper container entity
[21:34:25 CEST] <JEEB> maybe after they get the first version of the Matroska mindfuck spec done we can actually start properly improving the format
[21:34:29 CEST] <JEEB> like adding proper timestamps
[21:34:35 CEST] <JEEB> instead of the mess that it is right now
[21:34:57 CEST] <kepstin> well, one of the points of replaygain was that it worked with existing files without breaking playback in non-updated players.
[21:35:11 CEST] <JEEB> just adding new entities doesn't break anything
[21:35:27 CEST] <JEEB> parsers are supposed to ignore shit that they don't know
[21:36:54 CEST] <kepstin> amusingly, the original replaygain spec used a custom frame type (xing header iirc?) with binary data in mp3 rather than id3 tags, but nobody uses that any more. lame still writes them, though...
[21:37:40 CEST] <q3cpma> Really lame
[21:37:49 CEST] <JEEB> well the issue with mp3 was that it was fucking raw bitstream
[21:38:07 CEST] <JEEB> It's really nice that IIRC no other popular audio format went for that being the mainstream way of distroing it
[21:38:18 CEST] <JEEB> AAC is mostly in mpeg-4 part 12 derivatives
[21:38:32 CEST] <JEEB> Vorbis is in the oggwutlol, same for Opus
[21:38:46 CEST] <kepstin> and of course, ogg simply doesn't have any stream metadata at the container level, yeah
[21:39:10 CEST] <JEEB> depends on what you mean as metadata
[21:39:17 CEST] <q3cpma> What about musepack?
[21:39:47 CEST] <kepstin> musepack uses APEv2 tags
[21:40:01 CEST] <JEEB> also some formats just added a seeking list in them so even if it was a "raw bit stream" it would still be seekable
[21:40:19 CEST] <JEEB> mp3 is basically one of the epitomes of how not to do shit
[21:40:33 CEST] <JEEB> yet it was of course popular as hell
[21:40:46 CEST] <kepstin> well, next time you go and make a codec and container that will take the world by storm, make sure you get it right.
[21:40:51 CEST] <q3cpma> Pleb ruins everything
[21:41:04 CEST] <kepstin> in the mean time, i'll keep putting my replaygain in tags because it works.
[21:41:19 CEST] <q3cpma> Of course.
[21:42:06 CEST] <JEEB> you kind of misunderstood my issue :P anyways, matroska should be fix'able after it gets a proper spec, and mp4 might already have stuff
[21:42:20 CEST] <JEEB> I haven't looked into it in the spec or around mpeg-4 ra
[21:42:52 CEST] <kepstin> as far as i know, nothing uses the existing replaygain tags in matroska, so it shouldn't really break anything to move them to a different place where they'll still be unused :/
[21:43:36 CEST] <kepstin> apple's volume-leveling stuff in itunes is done via a tag as well, containing a bunch of undescriptive opaque numbers :/
[21:43:41 CEST] <kepstin> in aac/mp4
[21:43:52 CEST] <JEEB> yeah, there are proprietary solutions almost surely
[21:44:13 CEST] <JEEB> also I'm not sure if the thing you're speaking about is a proper entity in matroska or a tag
[21:44:23 CEST] <kepstin> it's a tag
[21:45:07 CEST] <kepstin> http://matroska.org/technical/specs/tagging/index.html ctrl-f "replaygain"
[21:45:33 CEST] <JEEB> seems so, yes
[21:46:56 CEST] <JEEB> anyways, I'm not into that stuff so my biggest beef would be to get proper timestamps into matroska (and that will break backwards compat and thus version will get one-up'd - unless the old information will be added as well)
[21:47:48 CEST] <JEEB> currently if you put 24000/1001 content into matroska you can't have monotonically rising timestamps because of the current way timestamps are done in the spec
[21:48:18 CEST] <kepstin> it doesn't support arbitrary fractional timebases?
[21:48:21 CEST] <JEEB> nope
[21:48:52 CEST] <JEEB> proper timestamps were once introduced into the changes that would have gone into matroska v4
[21:48:59 CEST] <JEEB> buut then mosu got the blues
[21:53:37 CEST] <TikityTik> q3cpma: does keyframe interval help with size as well?
[21:53:45 CEST] <TikityTik> I still can't get my clip to go under 4 MB
[21:54:05 CEST] <TikityTik> my 00:02:09 clip
[21:54:11 CEST] <kepstin> increasing keyframe interval with modern codecs generally reduces size, at the expense of making seeking slower.
[21:54:57 CEST] <TikityTik> so how would I do it? just with -g?
[21:55:29 CEST] <q3cpma> TikityTik: Did you calculate the maxrate?
[21:55:59 CEST] <TikityTik> I ended up using this http://www.dr-lex.be/info-stuff/videocalc.html
[21:56:19 CEST] <TikityTik> err 00:02:28 i meant
[21:56:30 CEST] <nardev> q3cpma, http://diveintohtml5.info/video.html
[21:56:36 CEST] <q3cpma> TikityTik: (8 * 8192 / 148) - 64
[21:56:38 CEST] <q3cpma> Not hard
[21:58:14 CEST] <TikityTik> runtime? artame?
[21:58:22 CEST] <TikityTik> err, arate*
[21:58:31 CEST] <q3cpma> Yeah, 64 is the audio bitrate
[21:58:37 CEST] <q3cpma> That gives 190
[21:58:56 CEST] <q3cpma> Whoops
[21:58:59 CEST] <TikityTik> I also noticed I got smaller sizes i think without specifying -pass 2
[21:59:40 CEST] <q3cpma> The twopass system gives more accurate sizes, that's all
[21:59:45 CEST] <q3cpma> Not bigger or smaller
[22:00:00 CEST] <TikityTik> what's runtime?
[22:00:09 CEST] <TikityTik> in that formula that you gave me
[22:00:15 CEST] <q3cpma> duration
[22:00:18 CEST] <TikityTik> oh
[22:00:20 CEST] <q3cpma> in seconds
[22:00:40 CEST] <q3cpma> It's not rocket science
[22:01:24 CEST] <TikityTik> for me it is at the moment, as I'm falling asleep in my chair lol
[22:02:00 CEST] <TikityTik> also vp8 is only available for pass 2 right?
[22:02:13 CEST] <q3cpma> Huh?
[22:02:26 CEST] <TikityTik> because i was having troubles testing pass 1
[22:02:43 CEST] <q3cpma> I don't understand anything you're saying
[22:03:02 CEST] <TikityTik> yeah, the video doesn't work with pass 1
[22:03:17 CEST] <q3cpma> Do you know how to use passes?
[22:03:32 CEST] <TikityTik> you just specify if you want pass 1 or pass 2?
[22:03:42 CEST] <q3cpma> No
[22:03:54 CEST] <q3cpma> Look for h264
[22:03:55 CEST] <q3cpma> https://trac.ffmpeg.org/wiki/Encode/H.264
[22:06:01 CEST] <TikityTik> so you shouldn't use -crf if you're using two-pass?
[22:06:31 CEST] <q3cpma> You can use crf with maxrate
[22:06:48 CEST] <TikityTik> what?
[22:07:14 CEST] <q3cpma> https://trac.ffmpeg.org/wiki/Encode/VP8
[22:07:25 CEST] <q3cpma> crf and -b:v
[22:08:00 CEST] <q3cpma> or just -minrate and -maxrate
[22:08:25 CEST] <TikityTik> which is preferred?
[22:08:43 CEST] <q3cpma> >You should use constant bitrate encoding if you need your video files to have a certain size,
[22:09:59 CEST] <TikityTik> q3cpma: but i read that you can make up for quality if you use cfr because of motion and still images and how compression works.
[22:10:09 CEST] <TikityTik> which i still don't understand
[22:10:46 CEST] <q3cpma> > This doesn't mean that every frame is encoded with the same amount of bits
[22:10:51 CEST] <kepstin> the radio of quality per overall bitrate is the same between a 2-pass and a crf encode, the difference is that with a 2-pass encode you set bitrate and it picks quality, with a crf encode you set quality and it picks bitrate
[22:10:55 CEST] <kepstin> ratio
[22:11:09 CEST] <q3cpma> It's basically like crf with qmin and qmax really near
[22:13:23 CEST] <TikityTik> alright so i specified a maxrate and minrate equaling 190
[22:13:40 CEST] <TikityTik> but it says that the bitrate is 301, i'm guessing partly from the audio?
[22:14:22 CEST] <q3cpma> 190 + 64 != 301
[22:14:27 CEST] <q3cpma> There's a problem
[22:15:54 CEST] <TikityTik> is it because i need -bufsize?
[22:16:08 CEST] <q3cpma> I don't know
[22:16:11 CEST] <q3cpma> What's your command
[22:16:30 CEST] <TikityTik> ffmpeg -i out2.mkv -c:v libvpx -c:a libopus -b:v 190k -minrate 190k -maxrate 190k -b:a 64k -ac 1 -vf scale=-1:480 -pass 2 out.webm
[22:16:59 CEST] <q3cpma> And the first pass?
[22:17:25 CEST] <TikityTik> it doesn't work, it it's not encoding the video
[22:17:31 CEST] <TikityTik> if you mean -pass 1
[22:17:46 CEST] <TikityTik> video:0kB audio:929kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 4.801717%
[22:18:52 CEST] <q3cpma> No, the command
[22:18:56 CEST] <q3cpma> It's the same, right?
[22:19:15 CEST] <TikityTik> for -pass 1?
[22:19:39 CEST] <TikityTik> ffmpeg -i out2.mkv -c:v libvpx -c:a libopus -b:v 190k -minrate 190k -maxrate 190k -b:a 64k -ac 1 -vf scale=-1:480 -pass 1 out.webm
[22:22:08 CEST] <q3cpma> And it doesn't work?
[22:22:18 CEST] <TikityTik> no
[22:22:26 CEST] <q3cpma> What's the error?
[22:23:04 CEST] <TikityTik> there's no error, it just shows that nothign is being encoded for the video part
[22:23:20 CEST] <TikityTik> i think vp8 doesn't support first pass
[22:23:29 CEST] <q3cpma> Yes it does, I'm using it right now
[22:23:46 CEST] <q3cpma> I usually put "-f webm /dev/null" instead of "out.webm" for the first pass
[22:24:34 CEST] <TikityTik> i don't have /dev/null on windows
[22:24:43 CEST] <q3cpma> It's NULL, I think
[22:25:01 CEST] <TikityTik> yeah nothing for the video
[22:25:19 CEST] <q3cpma> I'll give you my command, and you'll try with it
[22:25:52 CEST] <TikityTik> k
[22:25:57 CEST] <q3cpma> ffmpeg -ss 01:06:53.300 -i The\ End\ of\ Evangelion\ \[1004x574\]\ \[High10 at L4.1\].mkv -t 120 -c:v libvpx -quality good -slices 4 -minrate 209K -maxrate 209K -b:v 209K -c:a libopus -ac 2 -b:a 64K -sn -pass 1 -f webm /dev/null
[22:26:13 CEST] <q3cpma> Then ffmpeg -ss 01:06:53.300 -i The\ End\ of\ Evangelion\ \[1004x574\]\ \[High10 at L4.1\].mkv -t 120 -c:v libvpx -quality good -slices 4 -minrate 209K -maxrate 209K -b:v 209K -c:a libopus -ac 2 -b:a 64K -sn -pass 2 -f webm out.webm
[22:27:41 CEST] <TikityTik> i took out the -ss and -t and made it input out2.mkv, also had to change the /dev/null, there's still no video encoding
[22:27:46 CEST] <TikityTik> for the first one
[22:28:01 CEST] <q3cpma> That's normal
[22:28:09 CEST] <q3cpma> The first pass only produce a log
[22:29:12 CEST] <TikityTik> the second one is showing a bitrate of 236
[22:29:22 CEST] <TikityTik> and 270
[22:29:52 CEST] <q3cpma> During the encoding
[22:29:57 CEST] <q3cpma> You'll see at the end
[22:29:57 CEST] <TikityTik> yes
[22:30:22 CEST] <q3cpma> Mine produce a 3.9MB file, so it's perfect
[22:30:29 CEST] <q3cpma> Except that VP8 is shit, of course
[22:31:05 CEST] <TikityTik> i think you mispelled the -slices option
[22:31:13 CEST] <TikityTik> nvm
[22:31:15 CEST] <q3cpma> It works for me
[22:31:48 CEST] <TikityTik> the size ended up being 5109kB
[22:31:56 CEST] <TikityTik> bitrate of 326 kbs
[22:32:11 CEST] <q3cpma> That's kind of normal
[22:32:16 CEST] <TikityTik> my duration is 128 though
[22:32:17 CEST] <q3cpma> We don't use the same duration, right?
[22:32:23 CEST] <TikityTik> 8 seconds difference
[22:32:39 CEST] <q3cpma> Well, 326 is too high
[22:32:54 CEST] <TikityTik> but why can I not achieve CBR?
[22:32:59 CEST] <q3cpma> Hey, it's maybe because of -ac 1
[22:35:37 CEST] <TikityTik> ffmpeg -i out2.mkv -c:v libvpx -c:a libopus -b:v 190k -minrate 190k -maxrate 190k -b:a 64k -vf scale=-1:480 -bufsize 1835k -pass 2 out.webm
[22:35:47 CEST] <TikityTik> frame= 3068 fps= 30 q=-0.0 Lsize=    3979kB time=00:02:08.03 bitrate= 254.6kbits/s
[22:36:18 CEST] <q3cpma> Looks okay to me
[22:36:32 CEST] <TikityTik> but why isn't CBR happening?
[22:36:40 CEST] <q3cpma> 190 + 64 does equal 254
[22:36:47 CEST] <q3cpma> What do you mean?
[22:36:55 CEST] <TikityTik> oh...
[22:37:25 CEST] <TikityTik> i think -bufsize helped though
[22:38:13 CEST] <q3cpma> Actually, you're right
[22:38:19 CEST] <q3cpma> maxrate requires bufsize to be set
[22:38:46 CEST] <TikityTik> how do you find the optimal bufsize? trial and error?
[22:39:27 CEST] <q3cpma> The bigger the better (I think)
[22:44:08 CEST] <TikityTik> I get better quality with mono
[22:44:36 CEST] <q3cpma> Well, of course. You have 32K per channel in stereo
[22:49:12 CEST] <q3cpma> TikityTik: If you have a good CPU, I suggest you use libvpx-vp9.
[22:49:30 CEST] <TikityTik> I would, but the site doesn't allow vp9
[22:49:38 CEST] <q3cpma> What site?
[22:49:52 CEST] <TikityTik> ughh...
[22:50:10 CEST] <TikityTik> here's a hint https://i.4cdn.org/wsg/1437838366379.webm
[22:50:16 CEST] <q3cpma> >cuckchan
[22:50:40 CEST] <TikityTik> lol
[22:50:44 CEST] <q3cpma> Well, anyway, now you can do webm. We have mp4 on real chans
[22:51:05 CEST] <TikityTik> yeah vp8 hurts
[22:51:21 CEST] <q3cpma> vp9+opus or mp4+aac on 8chan
[22:51:29 CEST] <q3cpma> Maybe theora soon
[22:52:32 CEST] <TikityTik> why can I not change the sampling rate for opus anyhow?
[22:53:04 CEST] <q3cpma> Because that's how opus is made
[22:59:02 CEST] <unknown23> hi, I am writing a demuxer for a new file format, in my "read_packet" function, I want to modify the underlying data a bit, so I really can't use "av_get_packet". how do I get my modified data to fit in "pkt"?
[23:00:51 CEST] <TikityTik> q3cpma: so there isn't a way to increase quality for the scenes with motion and lower quality for the still scenes?
[23:01:32 CEST] <TikityTik> that's what i got from this: http://slhck.info/articles/crf
[23:02:08 CEST] <JEEB> unknown23: for development within lavc/lavf and friends, feel free to use #ffmpeg-devel ;)
[23:02:21 CEST] <JEEB> which reminds me I should poke my WIP demuxer as well
[23:02:37 CEST] <unknown23> JEEB, thanks, doing that now.
[23:03:02 CEST] <q3cpma> TikityTik: Like it's said in the wiki, constrained != constant
[23:03:16 CEST] <TikityTik> but it really helps with quality right?
[23:05:26 CEST] <q3cpma> TikityTik: If you have abig enough bufsize, yeah.
[23:07:10 CEST] <q3cpma> TikityTik: https://trac.ffmpeg.org/wiki/Encode/VP9 it's different with vp9
[23:07:32 CEST] <TikityTik> which i can't use
[23:07:39 CEST] <q3cpma> TikityTik: Why?
[23:07:49 CEST] <TikityTik> cuckchan doesn't allow vp9
[23:07:57 CEST] <q3cpma> Oh yeah, forgot
[23:08:00 CEST] <q3cpma> Hehe
[23:20:34 CEST] <TikityTik> q3cpma: https://i.4cdn.org/wsg/1437859220016.webm
[23:25:16 CEST] <q3cpma> TikityTik: There's no sound?
[23:26:14 CEST] <TikityTik> there is for me
[23:27:33 CEST] <q3cpma> TikityTik: Strange, it doesn't for me in the browser
[23:30:40 CEST] <h1113> Hello, did anyone ever try to use two TCP inputs at the same time?
[23:30:53 CEST] <h1113> It seems like it completely ignores the second tcp input.
[23:32:01 CEST] <h1113> ffmpeg -i tcp://localhost:15014 -i tcp://localhost:15015 out.mp4
[23:32:23 CEST] <TikityTik> q3cpma: apparently cuckchan doesn't accept opus either
[23:32:27 CEST] <TikityTik> so i had to switch to vorbis
[23:32:49 CEST] <q3cpma> TikityTik: I mean I download the webm and tried to open it in firefox and still no sound.
[23:33:48 CEST] <TikityTik> you're missing vorbis? I'm not sure
[23:34:42 CEST] <maletor> Is there a way to jump to the frame where a subtitle track is first used?
[23:39:59 CEST] <h1113> Could anyone try on their end to use two TCP connections as input?
[00:00:00 CEST] --- Sun Jul 26 2015

More information about the Ffmpeg-devel-irc mailing list