[Ffmpeg-devel-irc] ffmpeg.log.20150726

burek burek021 at gmail.com
Mon Jul 27 02:05:01 CEST 2015

[00:21:41 CEST] <dks-> hi all.. please, how can i embed subtitle in a video?
[00:22:02 CEST] <KarlFranz> Do you mean t hardburn it
[00:22:03 CEST] <KarlFranz> ?
[00:22:13 CEST] <KarlFranz> Or is softburning enough for you?
[00:22:28 CEST] <dks-> hardburn
[00:22:32 CEST] <durandal_1707> Read fine documentation
[00:22:48 CEST] <dks-> i already did
[00:22:57 CEST] <dks-> but no success
[00:23:33 CEST] <dks-> https://trac.ffmpeg.org/wiki/HowToBurnSubtitlesIntoVideo
[00:23:36 CEST] <KarlFranz> If you have tried something and it did not work, you are supposed to tell people what you tried.
[00:23:38 CEST] <dks-> i did this
[00:23:51 CEST] <dks-> yeah, sorry
[00:24:34 CEST] <dks-> i downloaded from http://johnvansickle.com/ffmpeg/
[00:25:28 CEST] <KarlFranz> What does "no success" mean? Do you get an error message?
[00:26:17 CEST] <dks-> ffmpeg starts and ends the process
[00:26:21 CEST] <dks-> no error message
[00:26:31 CEST] <dks-> but not subtitle embed
[00:27:05 CEST] <dks-> wow
[00:27:11 CEST] <dks-> i found an error:
[00:27:12 CEST] <dks-> [Parsed_subtitles_0 @ 0x3d800c0] Error decoding: Invalid data found when processing input (ignored)
[00:27:12 CEST] <dks-> [srt @ 0x3d88500] Invalid UTF-8 in decoded subtitles text; maybe missing -sub_charenc option
[01:43:15 CEST] <dks-> why my subs are skipping some lines?
[01:44:37 CEST] <h1113> never had that
[01:45:11 CEST] <h1113> copy your command line
[01:49:26 CEST] <dks-> h1113 /opt/ffmpeg/ffmpeg -i black.avi -vf subtitles=black.srt -sub_charenc ISO-8859-1 -codec:v libx264 -crf 23 -codec:a copy black-embutida.mp4
[01:51:56 CEST] <h1113> I don't get any missing lines issues, but i always use .ass format subtitles
[01:52:01 CEST] <h1113> maybe the problem is in the .srt?
[01:52:11 CEST] <dks-> maybe
[01:52:26 CEST] <dks-> how can i convert srt to ass?
[01:52:37 CEST] <dks-> can i use ffmpeg?
[01:52:59 CEST] <h1113> don't bother, i doubt that's the issue
[01:53:04 CEST] <dks-> ffmpeg -i input.srt output.ass ?
[01:53:12 CEST] <h1113> open the .srt with notepad and see if the lines are actually there
[01:53:26 CEST] <dks-> it's opened now
[01:53:36 CEST] <dks-> i was comparing
[01:54:39 CEST] <dks-> i get this error :
[01:54:39 CEST] <dks-> [srt @ 0x40f7a00] Invalid UTF-8 in decoded subtitles text; maybe missing -sub_charenc option
[01:54:40 CEST] <dks-> Error while decoding stream #0:0: Invalid data found when processing input
[01:54:44 CEST] <h1113> .srt syntax is pretty human-readable.... just look for the missing line and see if there's anything wrong with it
[01:54:57 CEST] <h1113> does it have non-english characters?
[01:55:06 CEST] <dks-> yes
[01:55:11 CEST] <dks-> brazilian portuguese
[01:55:26 CEST] <dks->
[01:55:32 CEST] <dks->
[01:59:46 CEST] <h1113> on windows?
[02:00:07 CEST] <h1113> there should be a specific option for this
[02:00:12 CEST] <h1113> but very easy workaround
[02:00:19 CEST] <h1113> open with windows notepad -> save as -> UTF-8
[02:00:27 CEST] <dks-> okay
[02:03:55 CEST] <h1113> ffmpeg -sub_charenc LATIN1 -i black.srt a.ass
[02:03:57 CEST] <h1113> that worked
[02:04:07 CEST] <h1113> im off.
[02:05:27 CEST] <dks-> Unrecognized option 'sub_charenc'.
[02:05:27 CEST] <dks-> Error splitting the argument list: Option not found
[02:06:05 CEST] <dks-> worked for you?
[02:24:33 CEST] <dks-> i found a way to run all commands in a linux box.. iconv -f iso-8859-1 -t utf-8 input.srt > output.srt
[02:24:37 CEST] <dks-> :D
[03:23:40 CEST] <WereCatf> Does anyone here use ffmpeg with nvenc? I can't find any documentation on how to actually make use of it with ffmpeg, even if I have built ffmpeg with support for it
[03:59:23 CEST] <WereCatf> I can basically get nvenc working with ffmpeg on the command-line, but I want to use HEVC. Looking at the sourcecode I need to somehow pass AV_CODEC_ID_H265 in avctx->codec->id and I just don't know how. I'm really not an expert with ffmpeg and this is really frustrating
[11:56:45 CEST] <pragomer1> what is the best / an actual ppa for ffmpeg under ubuntu 14.04 ?
[11:58:37 CEST] <BtbN> the one linked on ffmpeg.org
[12:00:00 CEST] <pragomer1> omg.. there is one on your site.. sorry.. really didnt find this.. thank you
[12:00:45 CEST] <pragomer1> do I understand it right.. that in ubuntu 14.04 ffmpeg isnt in the repos.. but mplayer1 is.... in 15.04 ffmpeg is back.. but mplayer1 is gone (and mplayer2 that isnt useful is there..) ?
[12:00:54 CEST] <BtbN> ubuntu still is using libav.
[12:01:12 CEST] <BtbN> As debian switched back to ffmpeg, ubuntu also will with the next release.
[12:02:50 CEST] <pragomer1> that really.. mm... but let me say both mplayer1 and ffmpeg are so so so important programs.. I am looking forward for both to be in the ubuntu repos instead of forked things
[12:03:17 CEST] <BtbN> mplayer is important?
[12:04:33 CEST] <pragomer1> yes.. often need the mencoder... converting videos to png mencoder is often a bit better than ffmpeg...
[12:11:07 CEST] <pragomer1> another question: I want to convert a bluray video folder (subfolder "stream" contains m2ts-files)  to mkv.. would this be the best way :
[12:11:13 CEST] <pragomer1> http://privatstrand.dirkschmidtke.de/2012/05/09/videos-verlustfrei-von-m2ts-nach-matroska-konvertieren/
[12:11:56 CEST] <pragomer1> and what does the 3rd line of these 3 mean?
[12:12:19 CEST] <JEEB> pragomer1: If you absolutely need to use mencoder for something, I recommend you make absolutely sure that you can't do it with ffmpeg or mpv's encoding thing
[12:12:39 CEST] <BtbN> I'm not sure if ffmpeg is able to decrypt a bluray.
[12:12:51 CEST] <pragomer1> its not a crypted blueray
[12:14:32 CEST] <pragomer1> BtbN: so these lines are a good way to do it?
[12:15:05 CEST] <pragomer1> JEEB: so you would prefer ffmpeg before mplayer? what do you mean by mpv's enconding thing?
[12:15:18 CEST] <BtbN> no idea, to my knowledge all blurays are full of drm and aacs encryption, never seen one that wasn't.
[12:15:31 CEST] <JEEB> BtbN: he probably already decrypted or downloaded a rip
[12:15:38 CEST] <JEEB> not like those are rare
[12:16:16 CEST] <pragomer1> its a blueray with my own videos
[12:16:35 CEST] <JEEB> pragomer1: mplayer is a pile of steaming bollocks and the less you use it the better. so yes, I would prefer ffmpeg to mencoder any day :P
[12:16:49 CEST] <JEEB> and mpv is the least retarded of the mplayer family at this point
[12:17:06 CEST] <JEEB> it has new encoding support, so if ffmpeg doesn't cut it you can look at that
[12:18:32 CEST] <pragomer1> :-) I thought mplayer and ffmpeg would be created by the same crew or parts of them.. sorry I am just a normal user and thought so.. and its my 2nd time I am using an irc chat in my life :-)
[12:19:25 CEST] <pragomer1> how could I append 2 video parts.. would I append the m2ts files or the converted mkv ?
[12:19:27 CEST] <JEEB> yes, there was a lot of incestious relationships between ffmpeg and mplayer. and that is not necessarily a good thing. like mplayer having a copy of ffmpeg within its goddamn source base and using _private_ APIs)
[12:20:19 CEST] <JEEB> also mplayer2 actually did improve on mplayer, but it did remove the godawful mencoder part. then with mpv a new encoding feature was added that was somewhat less retarded
[12:20:43 CEST] <pragomer1> ok... ffmpeg really seems more gentle :-)
[12:22:24 CEST] <pragomer1> so I will try it with ffmpeg converting m2ts to mkv.. like I wrote.. last question.. how do I append 2 files.. m2ts or mkv? and how?
[12:23:23 CEST] <JEEB> for some formats you can use the concat protocol (like MPEG-TS), but I usually use the concat filter
[12:23:58 CEST] <pragomer1> mm.. I get an error converting the first file:
[12:24:00 CEST] <pragomer1> Application provided invalid, non monotonically increasing dts to muxer in stream 2: 93052 >= 93051
[12:24:00 CEST] <pragomer1> av_interleaved_write_frame(): Invalid argument
[12:29:52 CEST] <pragomer1> that is the error: http://pastebin.com/97XPRDbF
[14:00:49 CEST] <active8> ffmpeg -i file.mp4 -filter_complex "[0:v]setpts=2.0*PTS[v];[0:a]atempo=0.5[a]" -map "[v]" -map "[a]" half-speed.mp4 wprks pretty good for half speed and doing it twice gives me quarter speed but
[14:01:12 CEST] <active8> -filter_complex "[0:v]setpts=1.5*PTS[v];[0:a]atempo=0.75[a]" -map "[v]" -map "[a]"
[14:01:52 CEST] <active8> for 3/4 speed... the video audio sync quickly comes unglued with the video lagging the audio
[14:23:41 CEST] <DHE> 0.75 is 3/4 speed, but 1.5 is 2/3 speed
[14:41:07 CEST] <active8> DHE I thought that might be the case but couldn't see where I calculated that proportion wrong
[14:49:33 CEST] <DrSlony> Hey, I have an MP3 but I need to put that into a video format so facebook will allow one to upload it. What is hte easiest way to put this MP3 into a video container?
[14:56:00 CEST] <BtbN> i don't think they will allow it without an actual video
[14:56:52 CEST] <DrSlony> yeah sohow do i use ffmpeg to generate a black video for the duration of the audio?
[15:02:08 CEST] <DrSlony> or even better - when i use ffplay on the audio i get a waveform animation thing (what is that called?), would be neat if i could have that as the video track
[15:02:38 CEST] <JEEB> you can use the filters to create that
[15:03:01 CEST] <JEEB> pretty sure if you search the trac and the documentation on it, there will be examples
[15:05:51 CEST] <DrSlony> this? http://www.ffmpeg.org/ffmpeg-filters.html#histogram
[15:06:30 CEST] <DrSlony> trying it now
[15:06:30 CEST] <JEEB> that seems to be a histogram of the video
[15:06:40 CEST] <JEEB> so if you have no video, that kind of doesn't help :D
[15:09:27 CEST] <JEEB> http://www.ffmpeg.org/ffmpeg-filters.html#avectorscope http://www.ffmpeg.org/ffmpeg-filters.html#showspectrum http://www.ffmpeg.org/ffmpeg-filters.html#showwaves
[15:09:31 CEST] <JEEB> these seem more like it
[15:28:42 CEST] <active8> So, JEEB. It doesn't mention what all can be done with that filter out, like whether it automatically goes into the chain with the audio so the output can be, say, an mp4 or if you have to multiplex the two, afterwards
[15:30:42 CEST] <active8> i don't quite get the mapping they do in the example
[15:30:56 CEST] <active8> i think it's some kinda mapping
[15:31:47 CEST] <active8> 'course you'd use ffmpeg, not ffplay
[15:36:12 CEST] <DrSlony> lost connection to my irc server
[15:36:19 CEST] <DrSlony> whoever it was who helped me, thank you
[15:37:22 CEST] <JEEB> active8: you'd create the input with lavfi and then map the output of that filter chain to be an input for encoding
[15:37:27 CEST] <JEEB> then you'd encode the video and copy over the audio
[15:38:51 CEST] <DrSlony> JEEB that sounds like advice for me
[15:53:53 CEST] <DrSlony> i have the showspectrum part working when i use ffplay, but im having no luck getting it saved into a video using ffmpeg
[15:53:56 CEST] <DrSlony> ffmpeg -lavfi amovie=foo.mp3,asplit[out0],showspectrum=mode=combined:color=intensity:slide=2:scale=cbrt[out1] /tmp/foo.mp4
[15:56:02 CEST] <DrSlony> ffmpeg -i foo.mp3 amovie=foo.mp3,asplit[out0],showspectrum=mode=combined:color=intensity:slide=2:scale=cbrt[out1] -c:v libx264 -r 24 -preset slower -crf 23 /tmp/foo.mp4
[16:09:02 CEST] <DrSlony> this seems a step closer
[16:09:04 CEST] <DrSlony> ffmpeg -f lavfi -i amovie=foo.mp3,showspectrum=mode=combined:color=intensity:slide=2:scale=cbrt -c:v libx264 -r 24 -preset fast -crf 23 /tmp/foo.mp4
[16:23:13 CEST] <DrSlony> that seems to result in a valid video being saved, but with no audio. How do I put the audio into it all in one step?
[16:25:18 CEST] <JEEB> add another -i after the amovie -i , and then set -c:a copy
[16:25:25 CEST] <JEEB> that should do it
[16:30:35 CEST] <DrSlony> i ran a quick 10 second test, seems to work! than you JEEB!
[16:30:40 CEST] <DrSlony> ffmpeg -f lavfi -i amovie=foo.mp3,showspectrum=mode=combined:color=intensity:slide=1:scale=cbrt -i foo.mp3 -c:a copy -c:v libx264 -r 24 -preset fast -crf 23 /tmp/foo.mp4
[18:00:19 CEST] <liquidee> has anyone ever used av_format_control_message?
[20:00:11 CEST] <wiak> cropping 4096x2160 to 3840x2160, what should i use? crop or cropdetect?
[20:00:54 CEST] <JEEB> cropdetect is for random automation when you don't know how big the crop will be
[20:00:58 CEST] <JEEB> crop is when you actually want to crop
[20:01:09 CEST] <JEEB> basically cropdetect outputs the information on how much it thinks you have to crop
[20:07:22 CEST] <wiak> um something like ffmpeg -i A001_C014_01217G.4k.y4m -vf "crop=3840:2160:128:128" outputgirl2.y4m
[20:07:22 CEST] <wiak> ?
[20:16:02 CEST] <wiak> JEEB was that correct? or am i doing it wrong
[20:26:57 CEST] <ChocolateArmpits> wiak: it should be 3840:2160:128:0
[20:27:11 CEST] <ChocolateArmpits> you're not cropping vertical, are you?
[20:30:48 CEST] <wiak> i just  want top remove 128 at top and bottom
[20:30:49 CEST] <ChocolateArmpits> The fourth input describes vertical offset
[20:30:54 CEST] <wiak> ooh
[20:31:18 CEST] <ChocolateArmpits> but the resolution change you described implies horizontal crop
[20:31:59 CEST] <ChocolateArmpits> Are you really sure what you're doing ?
[20:32:11 CEST] <wiak> nope
[20:34:12 CEST] <ChocolateArmpits> ok, let's figure this out, could you host a snapshot of your video to determine what and how much cropping you need ?
[20:37:10 CEST] <wiak> this is gonna take a little while uploding
[20:38:27 CEST] <wiak> ChocolateArmpits FYE: http://awesome.nwgat.ninja/misc/out.png
[20:39:56 CEST] <ChocolateArmpits> wiak: so you have to only crop horizontally, not vertically
[20:40:41 CEST] <ChocolateArmpits> Then 3840:2160:128:0, it will crop 128 pixels from the left side and 128 pixels from the right side
[20:41:48 CEST] <wiak> thanks
[20:41:49 CEST] <wiak> :)
[20:47:14 CEST] Action: wiak trows some norwegian milk chocolate @ ChocolateArmpits
[20:47:29 CEST] <ChocolateArmpits> no problem
[20:47:37 CEST] <wiak> meanwhile http://i.imgur.com/RheCUPd.png
[00:00:00 CEST] --- Mon Jul 27 2015

More information about the Ffmpeg-devel-irc mailing list