[Ffmpeg-devel-irc] ffmpeg.log.20150727

burek burek021 at gmail.com
Tue Jul 28 02:05:01 CEST 2015

[00:15:38 CEST] <TikityTik> what happens when i do ffmpeg -i thefile.mp4 out.mp4
[00:15:54 CEST] <TikityTik> does it encode at all or just copies the data as is?
[00:15:57 CEST] <c_14> encodes
[00:16:40 CEST] <TikityTik> does it try to keep the same quality and bitrate?
[00:17:08 CEST] <c_14> nope
[00:17:14 CEST] <c_14> just uses whatever the default is
[00:20:32 CEST] <well0ne> Hi
[00:20:34 CEST] <well0ne> Hey Canar
[00:20:39 CEST] <well0ne> I solved it
[00:20:46 CEST] <well0ne> with php and ffmpeg
[00:22:03 CEST] <well0ne> wanna see?
[00:28:47 CEST] <chungy> TikityTik: use -c copy if you want to copy
[00:29:13 CEST] <chungy> and by default it only does one video stream, one audio, and one subtitle. can use -map to control those further :P
[00:29:13 CEST] <TikityTik> chungy: and it will copy the quality for all channels?
[00:29:24 CEST] <chungy> "-c copy" just copies the streams, not encode
[00:29:30 CEST] <chungy> it'd be identical to the original
[00:30:11 CEST] <TikityTik> chungy: thanks so much
[00:30:21 CEST] <TikityTik> for some reason OBS doesn't make headers properly for recordings
[00:30:54 CEST] <chungy> If you have multiple video/audio/sub streams and you want them all, "-map 0" is handy too
[00:31:01 CEST] <chungy> that forces it to copy everything :P
[00:31:46 CEST] <TikityTik> chungy: it will copy attachments as well?
[00:32:21 CEST] <chungy> unsure. make a test.
[00:32:51 CEST] <c_14> not by default
[00:32:58 CEST] <c_14> if you want to map everything just use -map 0
[00:33:01 CEST] <chungy> if it's a very large file, you might try using "-t 10" to limit it to the first 10 seconds or something. Gives a good hint of how things turn out
[00:33:44 CEST] <TikityTik> what's wrong with just stopping early?
[00:34:43 CEST] <c_14> If you use q or ^C, nothing afaik.
[00:36:11 CEST] <chungy> I think two ^Cs makes it abort before a valid file is written out, but generally, same effect.
[01:09:29 CEST] <TikityTik> how do you know what bufsize to use?
[01:16:57 CEST] <c_14> https://trac.ffmpeg.org/wiki/EncodingForStreamingSites
[01:17:02 CEST] <c_14> Check the -bufsize header
[01:20:58 CEST] <TikityTik> c_14: does that apply to videos instead?
[01:23:46 CEST] <c_14> It shouldn't matter
[01:23:59 CEST] <c_14> bitrate * time_for_buffer
[01:24:11 CEST] <c_14> Though I'm not sure the bufsize option applies to audio
[02:12:30 CEST] <TikityTik> I just realized you can make gifs with ffmpeg
[02:12:34 CEST] <TikityTik> WOW
[09:21:02 CEST] <user_> Hello
[09:26:27 CEST] <user_> I have a problem with a transport stream copy (hls,applehttp). The copy is not edible with avidemux. I want only merge/cut segments and I don't want do a re-encoding. I googled already a lot but can't find a hint. http://pastebin.com/gt4AaQYi Any suggestion how to proceed to get the recording edible ?
[09:32:45 CEST] <user_> the raw copy is barely play-able with VLC. VLC lose audio after a wile
[09:37:39 CEST] <user_> I tried to remux the .ts to matrosca but the audio stream is not correct recognized. (error in the pastebin)
[09:39:29 CEST] <user_> The transport stream support of avidemux (2.6.8) is bad. No edit possible.
[09:41:53 CEST] <user_> "Error parsing AAC extradata, unable to determine samplerate" is the error when I try to remux to mkv.
[09:43:23 CEST] <user_> Any suggestion how to force the known ACC key data (sample rate, channels etc.)?
[09:45:50 CEST] <user_> http://pastebin.com/n9dQfYEZ is paste to ffmpeg.pastebin.com
[09:46:24 CEST] <user_> Would a short segment of the ts stream help ?
[09:47:17 CEST] Action: KarlFranz checks
[09:47:47 CEST] <satinder> hi , I have problem with ffmpeg when I streaming a HD video file from my pc to network . Acually I make a udp stream of recorded HD file but when I play that udp on vlc that is not playing proper . anybody help me please ??
[09:48:40 CEST] <KarlFranz> YOu are going to need to define the problem better than that.
[09:48:58 CEST] <satinder> my command is following : ffmpeg -i video_hd.ts -vcodec copy -acodec copy -f mpegts udp://@
[09:49:12 CEST] <satinder> video streaming is to much fast
[09:49:38 CEST] <satinder> due to this reason video not playing proper on the network
[09:50:26 CEST] <satinder> please help ??
[09:51:32 CEST] <user_> Come on satfinder, this is not the way to ask for help. You have to provide more details on a pastebin.
[09:52:25 CEST] <satinder> ok sir
[09:52:25 CEST] <satinder> I will
[09:53:05 CEST] <KarlFranz> user_: You are sure the original stream source is healthy, are you?
[09:53:29 CEST] <user_> Define  healthy please
[09:54:16 CEST] <user_> I can upload a couple of seconds ?
[09:55:13 CEST] <KarlFranz> I usually use mkvmerge for creating *.mkv files from streams, but I doubt it is a problem in ffmpeg's muxing in this case.
[09:56:41 CEST] <KarlFranz> user_: "Healthy; the file is not broken"
[09:57:03 CEST] <user_> Well, the goal is to get 3-4 stream segment merged and cut without re-encoding. The modification on the .ts need to be just enough to make avidemux happy
[09:59:04 CEST] <user_> The stream comes from a content distribution network (CDN) that deliver to a flash stream player application.
[09:59:20 CEST] <satinder> Actually I want receive a udp and record it and the transmit it after some delay (10 mins delay) there have any parameter in ffmpeg for receive udp with delay
[09:59:40 CEST] <user_> The frame rate is dynamic in a wide range. 5 to 30 fps.
[10:03:51 CEST] <user_> I will upload 10 seconds dropcanvas
[10:04:47 CEST] <KarlFranz> user_: Have you tried setting the sample_rate by hand? If you are sure about the sample rate of the input file it could do the trick.
[10:04:59 CEST] <KarlFranz> I think it is the -ar option for audio.
[10:05:19 CEST] <user_> the input file sample rate is variable.
[10:05:33 CEST] <KarlFranz> My bad.
[10:05:36 CEST] <user_> sorry,
[10:05:46 CEST] <user_> not the audio part
[10:11:27 CEST] <user_> Here are 20 seconds = 1.8 mb http://dropcanvas.com/um9f0
[10:16:01 CEST] <satinder> Hi but I want 10 mins delay
[10:16:15 CEST] <satinder> input to output
[10:21:38 CEST] <user_> mediainfo (output also in the pastebin) recognize the audio stream as: Format : AAC / Format version : Version 4 / Format profile : LC / Bit rate mode : Variable / Sampling rate : 16.0 KHz
[10:22:58 CEST] <KarlFranz> Damn, it is behind cloudflare. Wait a second.
[10:23:20 CEST] <user_> the tor user....
[10:26:19 CEST] <user_> mplayer output: AUDIO: 16000 Hz, 1 ch, floatle, 47.5 kbit/9.28% (ratio: 5937->64000)
[10:29:01 CEST] <user_> I think the 'floatle' is the problem.
[10:32:51 CEST] <user_> @satfinder: no delay in this dimensions without tmp storage in a file
[10:45:22 CEST] <user_> This is the avidemux error with the ffmpeg stream copy: http://ibin.co/2A3WNSLPWjvj
[10:50:17 CEST] <KarlFranz> Is the ts file supposed to show a static image while playing music? Because that is what I get.
[10:50:46 CEST] <KarlFranz> Plus there is no known duration for the file as far as my player is concerned.
[10:51:25 CEST] <user_> no, normally not. but I can't upload stuff with people in it without permissions
[10:53:02 CEST] <KarlFranz> Using mkvmerge on the ts works with no problems.
[10:53:12 CEST] <KarlFranz> I get a 21s *mkv file
[10:53:27 CEST] <KarlFranz> The tracks are jus copied with no recoding.
[10:53:44 CEST] <user_> What command line ?
[10:54:14 CEST] <KarlFranz> mkvmerge -o test.mkv test_ts.ts :-)
[10:54:45 CEST] <KarlFranz> You might want to add some metadata, like a tittle or something like that, but the basic just works for me.
[10:55:24 CEST] <KarlFranz> You might want to specify the fps of the video manually.
[10:56:08 CEST] <user_> I try this. One moment
[11:02:01 CEST] <satinder> ok , thank you for giving response
[11:02:43 CEST] <satinder> one another thing which I want discuss with
[11:03:03 CEST] <satinder> I receive udp in a temp file
[11:03:32 CEST] <satinder> after 10 mins I transmit that file with ffmpeg
[11:04:12 CEST] <satinder> but during making the udp from .ts file the transmission rate is very fast
[11:04:42 CEST] <user_> KarlFranz: cut and merge works with the "mkvmerge -o test.mkv test_ts.ts" files. PERFECT. Thank you. :-D
[11:04:43 CEST] <satinder> due to this reason my video is scattering at the receiver end
[11:06:17 CEST] <user_> So, to take home: ffmpeg's mkv muxer is buggy.
[12:03:59 CEST] <zugzwang> Is there a way to read from a named pipe in windows?
[12:04:13 CEST] <zugzwang> ffmpeg -i \\.\pipe\pipename does not work
[13:20:48 CEST] <satinder> Hi how we can calculate the bit rate of video udp on network ??
[14:20:15 CEST] <BtbN> record it for X seconds, devide size by X
[14:41:21 CEST] <DHE> I think wireshark has a statistic view you can use in the GUI...
[15:11:15 CEST] <TikityTik> having troubles with -ss and bit stream coying
[15:11:50 CEST] <TikityTik> if i try input seaking, it isn't accurate seeking. And when I use output seeking, it freezes on the first frame of the video for a second.
[15:20:01 CEST] <DHE> that does sound right if the video doesn't start with a keyframe. stream copying must start with a keyframe so you can either start with the nearest keyframe (inaccurate start) or have the video frozen for a moment (accurate start, bad codec initialization)
[15:22:36 CEST] <TikityTik> DHE: is it bad to force keyframes at every second?
[15:23:21 CEST] <DHE> that's an encoding thing. if you're starting with an existing video and not going to reencode it, you're outta luck
[15:23:47 CEST] <DHE> as for forcing keyframes, it has a negative impact on bitrate
[15:24:19 CEST] <TikityTik> DHE: how can i get the subtitles/ass video filter to work with seeking?
[15:29:09 CEST] <elmargol> I have to reencode some gopro videos. Is it safe to use -crf and a maxrate at the same time?
[15:35:38 CEST] <DHE> elmargol: those are mutually exclusive. try -crf first, it'll probably do okay for you
[15:35:56 CEST] <DHE> higher number for lower bitrate, lower number for better image quality
[15:41:03 CEST] <TikityTik> elmargol: you probably want to set -bufsize and -b:v if you're going to use -crf
[15:42:20 CEST] <TikityTik> DHE: why isn't the ass filter working?
[15:42:28 CEST] <TikityTik> is it because i'm using -to?
[15:44:37 CEST] <elmargol> DHE, for a 720p 50fps video what is a "normal" filesize / minute?
[15:44:55 CEST] <elmargol> If I use crf 23 the files are HUGE
[15:46:11 CEST] <elmargol> If I do crf 23 i get rates 10.000+ for 720p isn't that insane?
[15:46:12 CEST] <TikityTik> Greater than 1500 kbps if you're using 50 fps
[15:46:29 CEST] <TikityTik> you could try 15000 kbps
[15:52:10 CEST] <DHE> elmargol: I would ballpark 500 kilobytes/second for "looks quite good", but it will vary by content
[15:52:15 CEST] <DHE> TikityTik: dunno, I don't do subtitles
[15:52:22 CEST] <TikityTik> I got it working
[15:52:48 CEST] <TikityTik> my fontconfig was broken
[16:05:29 CEST] <Fjorgynn> must I compile my own version of ffmpeg for debian?
[16:11:35 CEST] <elmargol> Fjorgynn, I'd compile yes
[16:11:44 CEST] <elmargol> use a fresh checkout from git
[16:13:16 CEST] <Fjorgynn> any good compile instructions?
[16:20:42 CEST] <elmargol> apt-get build-dep <- to install all tools needed
[16:22:04 CEST] <elmargol> http://www.zoharbabin.com/build-and-install-ffmpeg-and-x264-on-debian-squeeze-the-dumb-guide/ <- found on google
[16:29:35 CEST] <termos> I'm trying to compile ffmpeg with support for decklink capture cards and the ffmpeg program can read from it just fine. But when I try to open it with the C api it can't find the format with av_find_input_format. Is there some linking that's wrong?
[16:43:43 CEST] <Fjorgynn> wierd
[16:49:57 CEST] <Mista-D> Problems building FFmpeg 2.7.2 with libmfx : http://pastebin.com/J0CUHpYe
[18:03:09 CEST] <wizbit> is it possible to use ffmpeg to check the integrity of mp3 / flac and ogg files?
[18:09:52 CEST] <durandal_1707> what you mean by integrity?
[18:10:22 CEST] <durandal_1707> flac have checksums others not
[18:13:53 CEST] <wizbit> i guess i could just use these tools: mp3val / flac -s -t / ogginfo -v
[18:24:29 CEST] <Nolski> Is there a way to ensure that all ffmpeg commands are run with lossless encoding?
[18:25:59 CEST] <Nolski> when I do -c:v with a lossless encoding I always get this error for opening the encoder for output stream 0:0
[18:45:20 CEST] <durandal_1707> wizbit: that can do ffmpeg too....
[21:13:15 CEST] <ocrete> in _getbuffer2(), the height in the AVFrame is not the size of the final image, but seems to include the padding (it give 1088 for a 1080p video), is there some way to get the final image's size?
[21:14:27 CEST] <JEEB> like the "width" and "height" parts of AVFrame?
[21:14:36 CEST] <JEEB> http://ffmpeg.org/doxygen/trunk/structAVFrame.html
[21:20:11 CEST] <bjvl> Is ffmpeg supporting m3u8 with mp4 fragments?
[21:20:38 CEST] <BtbN> you mean DASH?
[21:21:06 CEST] <BtbN> Is HLS with mp4 files even well defined?
[21:21:20 CEST] <JEEB> you can just look at the spec and take a wild guess
[21:22:15 CEST] <edoceo>  I've got a video that ffprobe reports as "  Duration: 3579:11:45.21, start: 0.000000, bitrate: 0 kb/s"
[21:22:24 CEST] <edoceo> I'm sure it's not that long
[21:22:39 CEST] <llogan> ffmpeg -i input -f null -
[21:22:46 CEST] <llogan> then refer to time= in console output
[21:22:55 CEST] <llogan> is it the same?
[21:23:38 CEST] <bjvl> BtbN: I've a situation with m3u8 but mp4 fragment emitted by the server instead of ts
[21:24:06 CEST] <bjvl> bjvl: but ffmpeg try to probe for mpegts
[21:24:47 CEST] <BtbN> what kind of server?
[21:25:04 CEST] <edoceo> llogan: I see this "[null @ 0x12369b0] Encoder did not produce proper pts, making some up"
[21:25:31 CEST] <edoceo> A lot of DTS / PTD invalid/dropping messages
[21:25:59 CEST] <edoceo> Then: frame=  233 fps=0.0 q=0.0 Lsize=N/A time=00:02:39.37 bitrate=N/A
[21:26:39 CEST] <edoceo> When I transcode this webm source into an mkv container, the invalid duration persists
[21:26:53 CEST] <edoceo> How can I get ffmpeg to fix it?
[21:28:26 CEST] <edoceo> the ffprobe: http://edoceo.io/paste?p=fRbHju
[21:29:27 CEST] <llogan> what about your encoding command and output?
[21:29:41 CEST] <llogan> also, try a build from current git master before doing anything.
[21:30:15 CEST] <llogan> that's quite the configure. why do gentoo users always have such an odd configure?
[21:32:26 CEST] <c_14> Because the ebuild lets you turn everything on/off and there's no setting for use whatever configure defaults to
[21:33:04 CEST] <llogan> huh. sounds dumb.
[21:33:19 CEST] <c_14> It could be much, much better.
[21:34:39 CEST] <bjvl> BtbN: The http server inside Canon legria series camcoder
[21:35:07 CEST] <blurider1> If I compile ffmpeg with --enable-neon, will it work on cpus without neon support?
[21:35:35 CEST] <edoceo> llogan: I also use the static from from John's website, same issue as my Gentoo box
[21:36:04 CEST] <BtbN> c_14, useflags are either on or off, and cause some configure setting to be enabled or disabled
[21:36:12 CEST] <BtbN> it's also trying to make the build as reproducible as possible.
[21:36:24 CEST] <BtbN> So, rule out all magic auto-detection
[21:36:41 CEST] <llogan> and non-neckbeards.
[21:38:37 CEST] <edoceo> So, Gentoo users are neckbeards?
[21:39:07 CEST] <llogan> i forgot about LFS, so I guess not.
[21:42:56 CEST] <edoceo> Here's a pastebin showing the command and output: http://edoceo.io/paste?p=W6OdWN
[21:43:12 CEST] <edoceo> Even after the processing the time is: =3579:11:44.91
[22:13:38 CEST] <edoceo> llogan: ^^^ see anything obvious in my paste?
[22:20:46 CEST] <Nolski> is there a flag i can give ffmpeg to just overwrite video files if they exist without asking?
[22:20:52 CEST] <c_14> -y
[22:25:46 CEST] <Nolski> thanks c_14 :)
[22:28:51 CEST] <z3bra> Hi
[22:29:23 CEST] <z3bra> I request your help, ô ffmpeg gurus
[22:30:03 CEST] <z3bra> chrome decided not to read my webms. Some guy working on chrome told me that's because my video has the metadata "alpha_mode" set to 1
[22:30:13 CEST] <z3bra> I'm now trying to remove it
[22:30:46 CEST] <z3bra> I already tried -metadata alpha_mode=0 and -vf il=alpha_mode=none
[22:30:50 CEST] <z3bra> both unsuccessful
[22:31:12 CEST] <c_14> Is it global metadata or stream metadata?
[22:31:21 CEST] <z3bra> stream
[22:31:36 CEST] <c_14> -metadata:s:0 alpha_mode=
[22:31:45 CEST] <c_14> 0
[22:32:44 CEST] <z3bra> nope, still set to 1
[22:33:06 CEST] <z3bra> http://sprunge.us/IdBP
[22:33:41 CEST] <z3bra> the command I used to record the webm is
[22:33:44 CEST] <z3bra> ffmpeg -f x11grab -s 1440x900 -an -i :0.0 -c:v libvpx -b:v 5M -crf 10 -quality realtime text.webm
[22:35:46 CEST] <relaxed> z3bra: it doesn't happen here, can you see if it happens using http://johnvansickle.com/ffmpeg/ ?
[22:35:59 CEST] <c_14> ^
[22:36:08 CEST] <relaxed> or build a recent version
[22:37:29 CEST] <z3bra> give me a second
[22:38:42 CEST] <z3bra> looks better
[22:40:50 CEST] <loop3r_> hello, I am trying to remove fisheye effect using ffmpeg, I was googling some time, I found that there are lenscorrection in ffmpeg and defish0r plugin, but I can't get it working, do you know where can I find working examples ?:P
[22:48:16 CEST] <z3bra> it worked well, thanks everyone!
[22:48:41 CEST] <z3bra> now I need to figure out what's wrong with my ffmpeg
[22:49:16 CEST] <relaxed> z3bra: could just be an outdated libvpx
[22:49:35 CEST] <z3bra> 1.3.0
[22:49:39 CEST] <z3bra> what's the latest?
[22:49:53 CEST] <relaxed> my builds have 1.4.0-865
[22:50:01 CEST] <z3bra> okay
[23:41:30 CEST] <DHE> ffmpeg logging to syslog... good idea? (I'd need to add it, but I can do that)
[23:43:22 CEST] <pzich> with normal ffmpeg log level? seems sorta verbose
[23:56:50 CEST] <DHE> pzich: maybe set a minimum loglevel. I would probably choose anything above the live encoder stats output
[23:57:22 CEST] <Nolski> does the overlay filter also apply to audio?
[23:58:01 CEST] <c_14> Nolski: no
[23:58:27 CEST] <Nolski> c_14: is there a way I can overlay the audio and video?
[23:58:39 CEST] <c_14> Define overlay audio
[23:58:57 CEST] <DHE> https://ffmpeg.org/ffmpeg-filters.html#amix
[23:59:00 CEST] <DHE> I'm guessing this is what you want
[23:59:28 CEST] <Nolski> so I have videoA on the bottom and videoB also has an audio track that I want the user to hear when output video is played
[23:59:58 CEST] <c_14> amix is probably what you want
[23:59:58 CEST] <explodes> Hey guys. There is no license information in this whole project: https://github.com/nxtreaming/FFmpegAndroid - I'm trying to avoid violating the GPL. Does anyone have any remarks as to whether or not my app will need to conform to the GPL if I include this library in my project?
[00:00:00 CEST] --- Tue Jul 28 2015

More information about the Ffmpeg-devel-irc mailing list