[Ffmpeg-devel-irc] ffmpeg.log.20160102

burek burek021 at gmail.com
Sun Jan 3 02:05:01 CET 2016

[00:14:10 CET] <gadgaholic> I am trying to decode an Audible file, but keep getting an error
[00:14:21 CET] <gadgaholic> "Option activation_bytes not found."
[00:14:37 CET] <gadgaholic> http://pastie.org/10664686
[00:14:46 CET] <gadgaholic> I have tried 2.8.4 and the HEAD
[00:23:33 CET] <pinPoint> so what is this CineForm HD thing that just recently happened?
[00:23:45 CET] <pinPoint> into ffmpeg... reversesd CFHD
[00:29:37 CET] <JEEB> yes, implementation for decoding based on the so-called specification (never enough to implement if coming from SMPTE), and reverse engineering the main implemenation and having samples at hand
[00:30:13 CET] <pinPoint> is CFHD even worth considering?
[00:30:29 CET] <pinPoint> when things like h264 work  so well
[00:32:24 CET] <JEEB> that question would make sense if there was an encoder in the works
[00:32:31 CET] <JEEB> but no, the support is just decoding
[00:32:35 CET] <JEEB> for already existing files :P
[00:32:43 CET] <JEEB> which pretty much always makes sense
[00:32:56 CET] <JEEB> which is why people make decoders for game formats or other obscure'ish stuff
[00:33:17 CET] <JEEB> but yeah, in this case it makes it simpler to deal with clips that came out of recent gopro cameras
[00:34:19 CET] <pinPoint> but vlc plays them back fine no?
[00:35:31 CET] <JEEB> uhh
[00:35:45 CET] <JEEB> if it's H.264, sure. if it's CFHD, nope
[00:36:11 CET] <JEEB> because yunno, VLC depends on libavcodec for most if not all of its decoding (it has interfaces to a very limited amount of non-libavcodec decoders)
[00:36:54 CET] <pinPoint> i see
[02:00:21 CET] <prelude2004c> good day everyone.. can anyone help with vdapu ?  I am still having an issue. Here goes... " Running a system with M4000 card "... ffmpeg with vdpau enabled.. i can decode mpeg2video just fine using the GPU but any source with h264 it will not use the card to decode and instead uses CPU's. Can anyone assist with this ? what could i be doing wrong ?
[03:04:25 CET] <xintox> furq: any idea where i can one on the cheap in US?
[03:15:13 CET] <_Vi> Is there some FFmpeg's container format that support all simply all codecs supported by FFmpeg? Closest things I know are nut and matroska, but the former can't save opus and the latter can't save rgb24 rawvideo.
[03:17:07 CET] <_Vi> I want `ffmpeg ... -f magicalcontainer - | ffmpeg -f magicalcontainer -i -` chain to always succeed and pass all the data (subtitles, attachments, tracks, tags) verbatim.
[03:21:35 CET] <klaxa> matroska and nut are pretty much the most flexible containers available
[03:21:37 CET] <klaxa> i don't think there are any containers supporting more codecs
[03:34:16 CET] <_6U54N0_> this library is a worse
[03:34:24 CET] <_Vi> Is there some container internal to FFmpeg where all codecs get available automatically as soon as they are implemented in FFmpeg?
[03:34:35 CET] <_6U54N0_> the acc decoder not work
[03:35:54 CET] <_Vi> Something like if serialize all AVFrames and other things with Protobuf.
[03:37:28 CET] <TD-Linux> _Vi, no, container mapping is generally not that simple
[03:37:59 CET] <TD-Linux> (also matroska has its own protobuf like thing called EBML)
[03:57:28 CET] <furq> xintox: if you need unmetered 1G then no idea
[03:57:51 CET] <furq> i only really pay attention to budget server hosts
[04:05:00 CET] <furq> generally if you see a cheap "unmetered 1gbit" offer, especially on a vps, it's either not really unmetered or it's not really 1G
[04:05:26 CET] <furq> obviously it'll be shared on a vps but i've heard of companies offering that and then capping the port speed to 50M
[04:06:42 CET] <prelude2004c> good day everyone.. can anyone help with vdapu ?  I am still having an issue. Here goes... " Running a system with M4000 card "... ffmpeg with vdpau enabled.. i can decode mpeg2video just fine using the GPU but any source with h264 it will not use the card to decode and instead uses CPU's. Can anyone assist with this ? what could i be doing wrong ?
[04:27:43 CET] <JodaZ> furq, gotta go to ovh, they gots the real stuff...
[07:10:22 CET] <xavii> i've got a ffserver running, feed is fed by ffmpeg grabbing from a UDP source. I can view the video from ffserver as avi. The issue is that when i press play, the video starts fine. When i press stop, and then press play again, the video starts from the beginning of what appears to be cached video (probably something to do with timeshifting), why doesnt it play from the current time? I've tried smplayer and vlc.
[10:03:48 CET] <xintox> hey all. i'm trying to manager a bunch off ffmpeg commands, occasionally one will die which requires me to restart all the others. Is there anything that makes this management easier?
[10:22:12 CET] <Dark-knight> hey guys got a question for you
[10:23:39 CET] <Dark-knight> c_14 and relaxed remember me right?
[10:24:28 CET] <Dark-knight> I was wondering, can I use ffmpeg's streaming ability's to stream a video onto someone else's computer
[10:24:31 CET] <Dark-knight> ?
[10:25:11 CET] <Dark-knight> like I don't want to do screen sharing, I just want to stream a video directly to their computer.
[10:25:32 CET] <Dark-knight> could ffmpeg do that?
[10:25:38 CET] <Dark-knight> if not, what could?
[10:26:01 CET] <Betablocker> you could try with google hangout
[10:26:43 CET] <Dark-knight> or maybe VLC?
[10:27:01 CET] <Dark-knight> he is across the country
[10:27:30 CET] <furq> you can use HLS or DASH if you have a webserver running locally
[10:28:19 CET] <Dark-knight> I can't just create a tunnel?
[10:29:39 CET] <furq> a tunnel to what
[10:29:40 CET] <Betablocker> https://trac.ffmpeg.org/wiki/StreamingGuide
[10:33:44 CET] <xintox> Dark-knight: what's the source of your stream?
[10:34:01 CET] <Dark-knight> ok just read that. I'm currently to tired for any of that to make sense
[10:34:27 CET] <Dark-knight> I want to stream a video I have on my computer to a friends computer across the country
[10:34:54 CET] <Dark-knight> like creating a direct tunnel or something
[10:35:36 CET] <Dark-knight> I don't care about watching it, I just want him to be able to watch it
[10:50:16 CET] <xintox> Dark-knight: you need a cheap web server.
[10:50:30 CET] <xintox> then you can stream it. if you give me the source stream I can tell you how to stream it
[10:52:01 CET] <furq> "cheap"?
[10:53:46 CET] <xintox> you can get a cheap vps that should handle streaming fine.
[10:53:50 CET] <xintox> i have a 99 cent one
[10:53:58 CET] <xintox> i just saw one today for $12/year
[10:54:03 CET] <furq> what difference does a server make if he's streaming to one person
[10:54:26 CET] <xintox> its easier
[10:54:33 CET] <xintox> or don't do it. i don't care
[11:03:27 CET] <furq> Dark-knight: you can set up an ad hoc rtsp server with VLC
[11:03:34 CET] <furq> it sounds like that's the closest match to what you want
[11:03:57 CET] <Polarbear541> Hi, I'm currently using ffmpeg to automatically record audio from a sound card using Pulse. But the output files seem to skip throughout and errors relating to a 'non-monotonous DTS timestamp' are appearing in the log. See command and output here: http://pastebin.com/GhfadNpG Any ideas?
[14:29:51 CET] <aiena> how do i copy audio stream from a seperate file and video stream from a seperate file and merge them together
[14:30:27 CET] <JEEB> ffmpeg -i video -i audio -map 0:v -map 1:a -c copy output
[14:30:39 CET] <JEEB> map stops the automatic stream selection and picks what you mention
[14:31:09 CET] <JEEB> so in that example it picks the video stream(s) from the first input (0th) and audio stream(s) from the second input (1th)
[14:31:31 CET] <JEEB> you can also add selectors after the v and a in case you have more than one audio or video track in those inputs
[14:31:49 CET] <JEEB> like 0:a:0 selecting the first audio track of the first input file
[14:36:34 CET] <aiena> JEEB: OK it seems to identify the streams properly but it churns out '[NULL @ 0xb09820] Unable to find a suitable output format for 'output.mp4'' at the end
[14:36:34 CET] <aiena>  
[14:37:49 CET] <aiena> JEEB: http://paste.opensuse.org/view/raw/08c96f53 is term output first line is terminal command
[14:37:56 CET] <aiena> I ran
[14:39:09 CET] <aiena> trying yours one sec
[14:40:35 CET] <aiena> yours also gives '[NULL @ 0x6d67e0] Unable to find a suitable output format for 'output'
[14:41:01 CET] <aiena> here 'video' and 'audio are the file paths themselves right
[14:41:12 CET] <furq> output.mp4
[14:41:12 CET] <furq> and yes
[14:41:39 CET] <aiena> furq: if i do that I get [NULL @ 0x1c627e0] Unable to find a suitable output format for 'output.mp4'
[14:42:04 CET] <aiena> and below that output.mp4: Invalid argument
[14:42:20 CET] <furq> --enable-muxer='flac,gif,image2,image2pipe,matroska,matroska_audio,null,webm'
[14:42:29 CET] <furq> that doesn't appear to contain mp4
[14:43:00 CET] <aiena> hmm
[14:43:06 CET] <aiena> ok will get another ffmpeg build then
[14:43:16 CET] <furq> is that a suse package
[14:43:38 CET] <aiena> yes
[14:43:56 CET] <furq> i guess this is why i don't use suse
[14:44:11 CET] <aiena> never had problems with it before probably because  the shift to Leap mixes entreprise with the regular
[14:44:26 CET] <aiena> anyway suse has packaman which builds a different ffmpeg
[14:44:28 CET] <aiena> let me try that
[14:44:31 CET] <furq> i can only assume they have some insane license requirements they're trying to meet
[14:44:40 CET] <furq> which aren't met by --enable-gpl
[14:48:16 CET] <aiena> packamn repos contain all the other vlc-codecs etc
[14:48:28 CET] <aiena> otherwise i am game for building ffmpeg from source too
[14:48:38 CET] <furq> http://johnvansickle.com/ffmpeg/
[14:48:44 CET] <JEEB> well for stream copy you don't need any special configuration flags either :P
[14:48:44 CET] <furq> you can just grab that if the other package doesn't work out
[14:49:10 CET] <JEEB> but sure, there are static binaries around as well
[14:49:46 CET] <furq> i'm genuinely baffled by that packaging decision
[14:49:57 CET] <aiena> yeah never had it before
[14:50:03 CET] <aiena> probably a side effect of Leap
[14:50:15 CET] <furq> i can only assume it's because it's "enterprise" and they're ultra paranoid about getting sued by MPEG-LA
[14:50:16 CET] <JEEB> I would guess it's a very specific binary, and I'm surprised opensuse packages it ata ll
[14:50:17 CET] <aiena> i an not going back to buntu though
[14:50:33 CET] <furq> or about end users getting sued, rather
[14:50:34 CET] <JEEB> furq: you won't get sued but you want to make sure you don't have to license anything
[14:50:43 CET] <furq> well you know what i mean
[14:50:47 CET] <JEEB> and no, the end users wouldn't get sued
[14:50:51 CET] <JEEB> just you since you're distroing it
[14:50:59 CET] <JEEB> (the binaries)
[14:51:07 CET] <aiena> exit
[14:51:14 CET] <JEEB> I think opensuse was similar with VLC?
[14:51:16 CET] <aiena> sorryterm commmand
[14:51:18 CET] <furq> i meant if the end user included suse in a commercial product
[14:51:22 CET] <JEEB> it only had stuff like libvpx,-theora etc
[14:51:35 CET] <furq> i assume they'd be liable then, although i'm obviously not a lawyer
[14:51:47 CET] <JEEB> if you distribute the binaries, sure
[14:51:52 CET] <aiena> yes PackMan binaries work
[14:51:59 CET] <aiena> so need to get static builds
[14:52:07 CET] <aiena> it muxed
[14:52:09 CET] <aiena> thank you
[14:52:35 CET] <furq> that's a shame
[14:52:39 CET] <JEEB> anyways, I don't dislike limited distros, it just means that I can ignore any FFmpeg packaged if at all (Fedora f.ex. doesn't package FFmpeg et al at all)
[14:52:43 CET] <furq> now i don't get to say "use debian {;-)"
[14:53:38 CET] <aiena> JEEB: probably those weird playback issues were because of suse's ffmpeg binary too which i reported earlier where mplayer cold play the audio
[14:54:14 CET] <aiena> furq: not going to debian
[14:54:18 CET] <aiena> back
[14:54:26 CET] <aiena> will build the rest
[14:54:26 CET] <furq> annoyingly if i was to recommend an OS on the basis of how good the ffmpeg packaging is, it would grudgingly be freeBSD
[14:54:39 CET] <aiena> if need be
[14:54:46 CET] <aiena> hmm never used BSD
[14:54:54 CET] <furq> i'm not actually recommending freeBSD
[14:54:54 CET] <JEEB> hah, reminds me of FreeBSD building x264 without asm enabled
[14:54:55 CET] <IntelRNG> BSD is cool.
[14:54:56 CET] <aiena> I think security wise its loads better
[14:55:14 CET] <aiena> but kernel is different dont know if linux apps will compile on it
[14:55:16 CET] <furq> occasionally ports+pkgng gets it perfect
[14:55:16 CET] <JEEB> also I think gentoo might have for whatever reason disabled asm for x264 as well
[14:55:25 CET] <furq> ffmpeg is one shining example of that
[14:55:28 CET] <JEEB> (I think for 32bit)
[14:55:32 CET] <furq> i can't think of any others right now but they probably exist!
[14:55:53 CET] <IntelRNG> aiena: FreeBSD and even OpenBSD have Linux compatibility layers in a form or another. But people prefers to run natively.
[14:55:56 CET] <JEEB> and then for a while we had folk coming to #x264 saying it's slow as molasses
[14:56:25 CET] <JEEB> I /think/ someone beat some sense into those distros but I have no idea since I don't use either
[14:56:25 CET] <furq> aiena: most linux software doesn't make use of linux-specific features
[14:56:39 CET] <furq> and even those that do can run under compat layers with varying levels of success
[14:56:50 CET] <c_14> Dark-knight: you can stream directly over udp or tcp (you might have to open some firewalls though, and you'll need the IP address of your friend or he'll need yours)
[14:56:55 CET] <aiena> ok
[14:59:31 CET] <furq> JEEB: i'm pretty sure ffmpeg on freebsd has asm enabled now
[14:59:39 CET] <furq> it certainly does if you build it from ports
[14:59:57 CET] <JEEB> I think it might have been a brainfart with only (lib)x264
[15:00:05 CET] <JEEB> and possibly only on 32bit, not sure though
[15:27:16 CET] <prelude2004c> good day everyone.. can anyone help with vdapu ?  I am still having an issue. Here goes... " Running a system with M4000 card "... ffmpeg with vdpau enabled.. i can decode mpeg2video just fine using the GPU but any source with h264 it will not use the card to decode and instead uses CPU's. Can anyone assist with this ? what could i be doing wrong ?
[15:33:01 CET] <aiena1> furq: but it was good you helped me identify the ffmpeg problem. Lots of other apps depend on it so it was really messing up other apps too
[16:12:52 CET] <volar> hi ql
[16:12:57 CET] <volar> hi all
[16:13:13 CET] <volar> happy coding or the new year
[17:45:49 CET] <micechal> does ffmpeg feature any kind of batch processing capabilities by itself?
[17:46:26 CET] <micechal> that is multiple input files into multiple corresponding output files at the same time
[17:54:16 CET] <ValdikSS> Hello guys. I can't understand how to properly re-encode vfr video with ffmpeg
[17:54:22 CET] <ValdikSS> I have the following video: http://b.1339.cf/rkszxnz.mkv
[17:55:16 CET] <ValdikSS> The first part of it is 24000/1001 fps and the opening is 30000/1001 fps. If I use ffmpeg -i file.mkv -vsync 0 it encodes without any warnings or notices, the video and audio is synced but the opening is not smooth
[18:01:22 CET] <DHE> micechal: it's not a bulk processing tool. it supports multiple inputs but usually in the context of mixing content from several sources. most people have shell scripts do the legwork there
[18:05:17 CET] <micechal> DHE: I see. I'm aware of the shell scripts. the problem I'm facing though is that I've only got ffmpeg cli without the shell, turns out I'll have to do every file by hand
[18:31:27 CET] <ValdikSS> michaelni: try GNU parallel
[18:43:24 CET] <micechal> is the libopus encoder in ffmpeg deterministic?
[18:44:01 CET] <micechal> I encoded the same file twice with the same settings and the checksums do not match
[18:44:31 CET] <micechal> could it be because of some date-related metadata?
[18:44:50 CET] <c_14> try adding -fflags +bitexact
[18:45:24 CET] <micechal> c_14: okay
[18:47:27 CET] <micechal> still doesn't match
[18:48:06 CET] <micechal> I now have four files encoded with the same settings with different checksums
[18:48:30 CET] <c_14> works for me
[18:49:21 CET] <micechal> c_14: could it be because I'm encoding on ARM?
[18:49:32 CET] <micechal> I'll post the log in a moment
[18:50:10 CET] <c_14> afaik, it shouldn't
[18:56:01 CET] <micechal> https://bpaste.net/show/471719769288
[18:58:17 CET] <micechal> I don't know what other options the ffmpeg build I'm using might be appending or prepending implicitely
[18:58:46 CET] <c_14> micechal: the fflags is an output option
[18:58:48 CET] <c_14> not an input option
[18:59:07 CET] <micechal> oh, let me try again then
[19:01:08 CET] <micechal> like "ffmpeg -i input.flac -fflags +bitexact output.opus"?
[19:01:29 CET] <c_14> yes
[19:04:17 CET] <micechal> c_14: now after three encodes, the checksum stays the same
[19:04:21 CET] <micechal> thank you
[19:04:49 CET] <micechal> but does it also create different files for you if you don't specify that flag?
[19:04:56 CET] <c_14> hmm?
[19:05:40 CET] <micechal> I mean, can you see the same behavior as me when encoding without the bitexact flag
[19:06:13 CET] <micechal> ie. the files produced are different each time
[19:06:19 CET] <c_14> ye
[19:06:56 CET] <micechal> I wonder if the standalone opusenc from opus-tools does that as well
[19:07:42 CET] <micechal> can't check that because there are no builds for Android I'm aware of, I'll have to check that the next time I'm on the pc
[19:08:38 CET] <micechal> do you think it has any impact on the quality of encodes? if so, which would give better quality? the bitexact ones?
[19:08:47 CET] <kepstin> The thing that causes changes without bitexact might just be the selection of the stream number in the ogg muxer
[19:08:57 CET] <kepstin> by default it's random so concatenating is more likely to work, iirc
[19:09:36 CET] <kepstin> in general, you should prefer non-bitexact unless you actually need identical files
[19:10:01 CET] <kepstin> not because of any quality change necessarily tho.
[19:10:54 CET] <micechal> I see. But it doesn't harm to use bitexact?
[19:11:22 CET] <kepstin> (although it can indirectly in some cases - e.g. in x264 encoding, you have to disable threads to make output bitexact, which means it's slower but also slightly higher quality)
[19:12:04 CET] <kepstin> I think in some cases, bitexact can also cause it to use slower, more precise math functions - don't know exactly which codecs do that or not.
[19:12:22 CET] <kepstin> (no real quality difference, it's just slower)
[19:13:03 CET] <kepstin> most of the time, bitexact just does silly things like not put the encoding time into file metadata
[19:13:13 CET] <kepstin> well, not silly, but simple.
[21:01:50 CET] <TD-Linux> libopus itself is deterministic. so it is indeed just container stuff that would be changing.
[21:10:33 CET] <zhuki> hi guys
[21:10:40 CET] <zhuki> can comeone please help me with a complexx_filter
[21:10:43 CET] <zhuki> for ffmpeg
[21:11:02 CET] <durandal_1707> what exactly?
[21:11:40 CET] <zhuki> i have this
[21:11:42 CET] <zhuki> ffmpeg -i http://domain.com/stream.mp4  -i /root/overlay.png -filter_complex "[0:v]drawtext=fontfile=/usr/share/fonts/truetype/msttcorefonts/Arial.ttf:textfile=/root/ontvtext.txt:reload=1:fontcolor=white at 1.0:fontsize=16:x=w-(tw+w)/25*mod(t\,25):y=h-line_h-20:enable=gt(mod(t\,25)\,0)[text]; [text][1:v]overlay[filtered]" -map "[filtered]" -map 0:a -codec:v libx264 -preset ultrafast -codec:a copy -f flv rtmp://publishpanel:8001/input/strea
[21:11:53 CET] <zhuki> there is an image and drawtext
[21:12:26 CET] <zhuki> i made it so the image is an overlay the same size of the video, and it contains the channel logo as well as a bar for text background
[21:12:38 CET] <zhuki> however the text seems to appear behind the image overaly
[21:12:56 CET] <zhuki> and is hidden by this line that is supposed to act as a background for the text
[21:13:02 CET] <zhuki> so I ned the text to be on top
[21:13:06 CET] <zhuki> need*
[21:16:45 CET] <zhuki> any ideas?
[21:24:36 CET] <zhuki> aaaaaa
[21:24:39 CET] <zhuki> finally I did it
[21:24:43 CET] <zhuki> i just changed th order
[21:24:46 CET] <durandal_1707> zhuki: change order of text and video for overlay filter
[21:24:57 CET] <zhuki> yes
[21:25:00 CET] Last message repeated 1 time(s).
[21:25:05 CET] <zhuki> took me some time to understand how it works
[21:25:10 CET] <zhuki> never used ffmpeg before
[00:00:00 CET] --- Sun Jan  3 2016

More information about the Ffmpeg-devel-irc mailing list