[Ffmpeg-devel-irc] ffmpeg.log.20160104

burek burek021 at gmail.com
Tue Jan 5 02:05:01 CET 2016

[04:36:12 CET] <Deihmos> is there a way to make ffmpeg run full speed without usinga command line?
[04:36:52 CET] <Deihmos> i am using a python script to auto convert mkv to mp4 but it takes so long to remux a video with aac
[05:07:47 CET] <Deihmos> how can i get ffmpeg to use 4 cores by default
[05:52:41 CET] <PhoenixBR> Hi everyone! Is there anyone here that worked with dummynet?
[10:23:51 CET] <C0nundrum> hello
[10:24:39 CET] <C0nundrum> When saving this stream in the flv container, i get no audio
[10:24:43 CET] <C0nundrum> http://pastebin.com/tX0seBzY
[10:29:26 CET] <relaxed> C0nundrum: pastebin the command and all output
[10:32:54 CET] <C0nundrum> ffmpeg src -vcodec copy -acodec copy -bsf:a aac_adtstoasc -f flv dest
[10:35:53 CET] <relaxed> omit -bsf:a aac_adtstoasc
[10:39:18 CET] <C0nundrum> hm ok
[11:07:50 CET] <C0nundrum> if i do that i get Malformed AAC bitstream detected: use audio bitstream filter 'aac_adtstoasc' to fix it ('-bsf:a aac_adtstoasc' option with ffmpeg)
[11:07:50 CET] <C0nundrum> av_interleaved_write_frame(): Invalid data found when processing input
[11:09:16 CET] <relaxed> odd, is the source container mp4? I tested it and it worked fine for me.
[11:13:29 CET] <C0nundrum> its f4v_aac
[11:14:23 CET] <relaxed> it really helps if you pastebin.com the complete command and and all console output
[11:22:41 CET] <C0nundrum> http://pastebin.com/UW4CVF9e
[11:26:51 CET] <relaxed> right, with this command the output container is mp4, not flv. Also your ffmpeg version is alomst 3 years old (which is ancient)
[11:32:52 CET] <relaxed> C0nundrum: latest ffmpeg version will do the correct -bsf by default.  get the latest static build here http://ffmpeg.zeranoe.com/builds/
[11:34:20 CET] <C0nundrum> ok i'll try updating
[12:06:53 CET] <C0nundrum> same problem
[12:55:10 CET] <phed> I am quite sure I could do this before; but I have a video that I want to mux with audio. I want to skip in only the audio, but not the video. Eg mux a 1 minute video with 1 minute from the audiofile, but skip the first 20 minutes.
[12:57:40 CET] <DHE> specify your options before the "-i audiofile.wav" options to have them apply to that audio file
[13:11:10 CET] <phed> DHE: ugh i thought i've tried that combination already. it kept skipping the video file, but i must have been looking wrong all the time. there's some weird heuristics where it will skip into the previous -i, but that might be only after the last input i guess
[13:11:52 CET] <phed> DHE: thanks
[14:16:56 CET] <kynlem> is there an orthodox way to split a video file into independent one-minute chunks (not for streaming)?
[14:18:34 CET] <kynlem> i just have a bunch of two-gigabyte videos from my action camera
[14:18:47 CET] <kynlem> and smaller files are easier to deal with
[14:19:28 CET] <kynlem> i want to keep them as close to the original as possible, hence they don't have to be precisely one-minute long (don't want to reencode)
[14:19:57 CET] <DHE> there is a "segment" output format you can use
[14:20:36 CET] <kynlem> yeah, tried that one, but the videos it produces seem to have "false length" when i open them in vlc
[14:20:58 CET] <kynlem> eg. the fourth video appears to be 4-minute long, and i can't navgate through it
[14:21:07 CET] <kynlem> (in reality each video is one minute long)
[16:27:09 CET] <rjp421> how do i make ffmpeg not exit when encoding to mjpg to http and the client disconnects?
[16:30:16 CET] <rjp421> 'ffmpeg -loglevel info -r 5 -s 176x144 -f video4linux2 -i /dev/video2 -listen 1 ""'
[16:32:23 CET] <claw> hello i try to get almost same encoding speed as '-preset ultrafast' of x264 but with vp8 or vp9
[16:33:17 CET] <claw> heres what i've tried '-cpu-used 0 -preset ultrafast -qmin 25 -qmax 63 -speed 8 -deadline realtime'
[16:33:22 CET] <vsibilla> dear users, can I explaine my question?
[16:34:07 CET] <vsibilla> I need to import my MXF file, created with ffmpeg, Sony Content Browser, but it doesn't work
[16:34:35 CET] <vsibilla> I tried with the last release of FFmbc and it works (please visit: https://github.com/bcoudurier/FFmbc/commit/a9cc593546280c8aba4d4340be884fc81dfd2d70)
[16:34:40 CET] <claw> vp8: ~60fps , vp9: ~70fps, x264: ~90fps
[16:34:43 CET] <vsibilla> how can help me?
[16:37:19 CET] <sfan5> claw: the webm docs say that cpu-used works the other way around: "Setting a value of 4 or 5 will turn off "rate distortion optimisation" which has a big impact on quality, but also greatly speeds up the encoder."
[16:37:32 CET] <sfan5> http://www.webmproject.org/docs/encoder-parameters/#2-encode-quality-vs-speed
[16:38:51 CET] <claw> sfan5: setting it to 5 makes it a bit slower for vp8 and vp9 aswell
[16:40:10 CET] <claw> sfan5: using -deadline realtime sets cpu-used anyway i guess
[16:41:30 CET] <sfan5> possibly
[16:43:00 CET] <vsibilla> anyone can help me?
[16:45:48 CET] <shincodex> i open up a cgi stream/http thats in mjpeg format and it says invalid data instream... Yet vlc opens it which is a layer ontop of avcodec collection and it works.
[16:46:02 CET] <shincodex> makes me think i configured and -disabled something that i shouldnt have
[16:49:30 CET] <rjp421> how do i make ffmpeg not exit when encoding to mjpg to http and the client disconnects?
[16:58:11 CET] <rjp421> i dont see it in the help
[16:58:24 CET] <shincodex> this library has a help?
[16:58:27 CET] <shincodex> holy crap
[18:10:26 CET] <BLZbubba> hi guys i have an mp4 that is missing chapters, and I have the chapter times in a text file.  what is the best way to add them?  e.g. is there a file format to use or can i run a separate command to add each chapter
[18:11:44 CET] <BLZbubba> i hope I don't have to go this route but this is a good hack: http://www.kgarner.com/blog/archives/2010/05/24/addings-chapters-to-an-existing-mp4m4v-file/
[18:29:05 CET] <BLZbubba> it worked using: MP4Box -chap chapters.txt blah.mp4
[18:29:08 CET] <BLZbubba> fyi
[21:33:04 CET] <rjp421> http://ftp.tuebingen.mpg.de/pub/kyb/towolf/raspberry-camera-streaming/
[21:33:52 CET] <Disturbed1> good day everyone...
[21:34:02 CET] <rjp421> how do i make ffmpeg not exit when encoding to mjpg to http and the client disconnects?
[21:39:23 CET] <Betablocker> you could try with this @rjp421 instead of the ftp.tuebingen link http://datarhei.github.io/restreamer/
[21:40:36 CET] <rjp421> neat ty
[21:42:08 CET] <Disturbed1> quick question.... i got nvenc to work with ffmpeg, (pulled tesla qty 4x c870 cards out of s870 chassis and replaced with 1 geforce gtx 650 ti & 1 geforce gt 640) with driver 358.09 installed... nvidia-smi shows both... (cuda sdk) deviceQuery and bandwithTest see both and work...
[21:42:23 CET] <Disturbed1> my question is, with ffmpeg i plan to use Transcoding / repeating, how do i tell ffmpeg which gpu to use???
[21:42:36 CET] <c_14> iirc the option is called -gpu
[21:43:10 CET] <Disturbed1> ka thx c_14.... will test...
[21:43:42 CET] <Disturbed1> i stole my friends geforce cards last night... muhahah
[21:53:56 CET] <Disturbed1> c_14:   yup, that was it, nice and simple... wish everything could be that way.... :)
[22:56:21 CET] <PhoenixBR> Hi everyone! Is there anybody who already worked with any network emulator (netem, dummynet) ?
[23:02:00 CET] <C0nundrum> Hi Why When saving this stream in the flv container, i get no audio http://pastebin.com/UW4CVF9e   ?
[23:15:20 CET] <waressearcher2> PhoenixBR C0nundrum hallo und herzlich willkommen
[23:18:23 CET] <llogan> C0nundrum: you're telling it to use the flv muxer, then naming it mp4.
[23:19:11 CET] <llogan> also, your build is old and unsupported
[23:23:34 CET] <C0nundrum> The same thing hapeens with the latest build and when specifying the -f i was under the assumtion that it doesn't look at the name extension ?
[23:24:21 CET] <llogan> you don't need -f
[23:25:53 CET] <C0nundrum> ok, buy it doesn't explain why the audio doesn't work in an flv container
[23:26:56 CET] <C0nundrum> I provided a pastebin which shows the input and output types O.o
[23:27:55 CET] <llogan> that was a different command and (and hopefully) different ffmpeg build
[23:28:29 CET] <squeegily> Would it be possible to add an example to the documentation for ffplay on how to select the output sink?
[23:28:57 CET] <squeegily> I see that -sources pulse will LIST the available sinks, but I can't figure out where I'm supposed to plug those in to
[23:46:10 CET] <llogan> squeegily: http://ffmpeg.org/ffmpeg-devices.html#Examples-12
[00:00:00 CET] --- Tue Jan  5 2016

More information about the Ffmpeg-devel-irc mailing list