[Ffmpeg-devel-irc] ffmpeg.log.20160108

burek burek021 at gmail.com
Sat Jan 9 02:05:01 CET 2016

[00:00:21 CET] <JakeJ> libfdk_aac, libfaac, and aac, seems to just ignore my commands and convert to either 7.1, 6, or 5 channel files
[00:47:18 CET] <Wat> Is there anyway to use a videos duration as a value for the drawtext function? Trying to generate posters with the videos duration on them, and google isn't brining up much.
[01:17:50 CET] <Pinchiukas> I know this might be a weird question for this channel but: can anyone suggest an alternative on Linux that would give me the details of an MPEG stream?
[01:25:08 CET] <JakeJ> Pinchiukas - do you mean like mediainfo details?
[01:25:21 CET] <Pinchiukas> JakeJ: Yeah, I think so. :)
[01:25:28 CET] <JakeJ> try mediainfo
[01:25:39 CET] <JakeJ> https://mediaarea.net/en/MediaInfo
[01:25:53 CET] <JakeJ> i use that for all platforms
[01:30:24 CET] <Pinchiukas> That's a nice alternative. Though it looks like it doesn't support streams which I'm doing. :)
[01:34:22 CET] <JakeJ> what type of streams? mpeg should be fine
[01:34:35 CET] <JakeJ> i haven't found a stream it doesnt get the info from yet
[01:36:54 CET] <Pinchiukas> MPEG-TS
[01:37:09 CET] <Pinchiukas> It doesn't seem it has a mechanism for streaming at all.
[01:39:30 CET] <JakeJ> oh yea
[01:39:47 CET] <JakeJ> anything for HLS / MPEG-DASH ts files i dont think it works with
[01:39:56 CET] <JakeJ> i haven't really found anything for those files yet
[01:40:11 CET] <Pinchiukas> I guess I'm kind of stuck with ffprobe...
[01:44:46 CET] <Pinchiukas> I can't make it shut up about the versions of libraries that it's using.
[01:48:25 CET] <klaxa> isn't there -hide_banner?
[01:48:43 CET] <klaxa> Pinchiukas: ^
[02:17:59 CET] <kingron> greetings
[02:18:47 CET] <kingron> I would like to convert my mpg's (no adio track) to ogv (with a silent audio track)
[02:18:57 CET] <kingron> I use: ffmpeg -ar 48000 -ac 2 -f s16le -i /dev/zero -i input.mpg -c:v libtheora -c:a libvorbis -q:v 10 -q:a 4 -shortest -strict experimental -y out.ogv
[02:20:12 CET] <kingron> but the duration of video/audio are not the same as I expected
[02:20:22 CET] <kingron> (checked with mediainfo)
[02:21:08 CET] <kingron> video: 4s 4ms, audio: 3s 947ms
[02:21:45 CET] <Pinchiukas> klaxa: seems I have an old version that pretty much sucks.
[02:25:38 CET] <waressearcher2> kingron: hallo und helzlich willkommen
[02:25:50 CET] <kingron> hi :D
[02:26:07 CET] <waressearcher2> kingron: wie geht's es dir ?
[02:26:22 CET] <TD-Linux> kingron, that's a really small mismatch, does it cause problems with playback?
[02:26:31 CET] <kingron> yes
[02:26:42 CET] <kingron> in loop it lags
[02:26:49 CET] <kingron> not nice
[02:27:21 CET] <kingron> 4s 67ms
[02:27:30 CET] <kingron> 4s 63ms
[02:27:42 CET] <kingron> is another one
[02:28:18 CET] <TD-Linux> hmm. maybe ffmpeg is not correctly putting exact vorbis sample lengths in
[02:29:34 CET] <kingron> I think it's caused by -shortest, is there anything else I could try?
[02:29:48 CET] <TD-Linux> do you need an audio track?
[02:30:28 CET] <TD-Linux> it sounds like a ffmpeg bug, what you're doing should work
[02:31:00 CET] <kingron> hmmm
[02:31:49 CET] <TD-Linux> if you don't actually need audio, browsers should play a ogv without audio (-an)
[02:32:26 CET] <kingron> well I need audio, because the game engine expect an audio track
[02:32:35 CET] <kingron> for sync purpose
[02:32:55 CET] <kingron> can I set the lenght manually?
[02:36:18 CET] <TD-Linux> you could encode the vorbis separately at the exact length and then do -c:a copy, maybe that would work
[02:41:06 CET] <c_14> Or try getting rid of -shortest and use -t <length> might work
[02:44:00 CET] <TD-Linux> yet another option is to convert video to y4m intermediate, audio to wav, and use theora_encode
[02:44:29 CET] <TD-Linux> (theora_encode can read from a pipe so the y4m can be streamed out from ffmpeg)
[02:48:05 CET] <JakeJ> anyone around that knows much about complex aac audio filters? i'm trying to make an 8 channel octagonal audio filter in aac and having issues libfdk_aac, libfaac, and aac, seems to just ignore my commands and convert to either 7.1, 6, or 5 channel files
[03:41:05 CET] <t4nk971> Hi - I am trying to use ffmpeg and pass the equivalent arguments to ffmpeg as the below in iSkysoft.
[03:41:10 CET] <t4nk971> Video Codec: H.264 Resolution: 1280*720 Frame Rate: 30 fps Bit Rate: Custom 3000 kbps  Audio Codec: AAC Channel: Smart Fit Sample Rate: Smart Fit Bit Rate: Smart Fit
[03:41:21 CET] <t4nk971> this is my first attempt
[03:41:25 CET] <t4nk971> ffmpeg -i /0001.mp4 -acodec aac -ar 48000 -ab 128k -strict -2 -coder ac -vcodec libx264 -threads 0 -deinterlace -s 1280x720 -b:v 3000k -cmp +chroma -g 250 -partitions +parti4x4+partp8x8+partb8x8 -i_qfactor 0.71 -keyint_min 25 -b_strategy 1 -r 30 -movflags faststart /0001new.mp4
[03:41:44 CET] <t4nk971> but the size of the files is about double in ffmpeg...I am hoping to find out where I am mistaken
[08:37:39 CET] <k_sze> Does ffmpeg automatically use multiple threads to decode FFV1 when possible, regardless of the slices?
[09:05:14 CET] <k_sze> And if I run ffmpeg without specifying -threads, how do I know how many threads it's actually using?
[09:07:48 CET] <pinPoint> you don't i guess but it should automagically just go.
[09:08:29 CET] <pinPoint> libvpx is the only one you have to specify and even after that it does not move fast enough.
[09:09:02 CET] <pinPoint> check your processor scaling speed on task manager or a widget that tracks cpu usage
[09:09:53 CET] <pinPoint> from my observation at least.
[09:16:41 CET] <furq> k_sze: the default is -threads auto which lets the encoder decide
[09:16:45 CET] <furq> the encoder will usually decide to use 1
[10:33:07 CET] <k_sze> And why is it that if I encode as ffv1 level 3 and then decode it, I get a whole bunch of invalid SAR 0/0 messages?
[10:33:15 CET] <k_sze> It's slightly worrying.
[10:33:55 CET] <k_sze> I mean ffv1 level 3 with 4 or more slices
[11:29:58 CET] <ealdeguer> Hi all, I'm streaming with ffmpeg a udp stream to a rtmp server, all worked fine for month, but I just receive that error, and I don't understand it : av_interleaved_write_frame() broken pipe
[11:29:58 CET] <ealdeguer> no more output streams to write to, finishing
[11:30:01 CET] <ealdeguer> can you help ? thx
[13:27:17 CET] <Zucca> Hi. I have played a bit around with VP9. Is there s switch to set the "compression level" using libvpx-vp9? I mean the same way like with libx26{4,5} -preset <preset level>. libvpx-vp9 doesn't seem to take -preset. Right?
[13:30:08 CET] <furq> Zucca: -speed
[13:30:32 CET] <furq> 4 is fastest, 0 is slowest (iirc)
[13:30:52 CET] <Zucca> furq: Ah. Thanks.
[16:58:08 CET] <Akerus> Hi there, I got a problem with ffmpeg. When I run ffmpeg (without any parameters) in the terminal, I get a segmentation fault in the ld-2.13.so library. It happens immediatly and everytime. ffprobe does not work as well... anybody can help?
[17:06:18 CET] <c_14> Distro?
[17:06:24 CET] <c_14> FFmpeg version?
[17:06:33 CET] <c_14> Did you build it yourself?
[17:07:19 CET] <Akerus> debian 7, and the ffmpeg version i can not find out... it won't tell me
[17:07:46 CET] <c_14> Where did you get it from? debian repos?
[17:08:43 CET] <Akerus> that could be... was a few years ago... it has to be an older version but it worked at some point
[17:09:37 CET] <c_14> wheezy doesn't have ffmpeg from FFmpeg. try using a static build
[17:09:39 CET] <c_14> http://johnvansickle.com/ffmpeg/
[17:10:11 CET] <Akerus> we have a second server, wheezy as well, there it works just fine
[17:10:27 CET] <c_14> sure it's the same binary?
[17:10:35 CET] <c_14> same ld version etc
[17:11:18 CET] <Akerus> it should be the same version, one is integration server and one is production server
[17:13:23 CET] <c_14> Compare the checksums of the binaries on each server
[17:13:26 CET] <c_14> check ldd output
[17:15:51 CET] <Akerus> the ffmpeg binaries have different file sizes
[17:15:57 CET] <Akerus> so they're not the same
[17:17:37 CET] <Mavrik> And you're not using new static binaries you have control over for that? :-
[17:17:39 CET] <Mavrik> :/
[17:18:55 CET] <Akerus> on production we are running 1.2.12
[17:21:32 CET] <Akerus> ok, I'm trying to get it from the same source for integration server.
[17:49:02 CET] <Akerus> Ok, reinstalled FFMPEG 1.2.12 and the libraries. Same error still happening. Any ideas?
[17:53:40 CET] <Akerus> [3656326.178705] ffmpeg[12816]: segfault at 8 ip 00007f8dbb6b0113 sp 00007fffec157650 error 4 in ld-2.13.so[7f8dbb6a5000+20000]
[17:53:50 CET] <Akerus> with gdb: Program received signal SIGSEGV, Segmentation fault. 0x00007ffff7de8113 in ?? () from /lib64/ld-linux-x86-64.so.2
[17:53:58 CET] <podman> yo
[17:57:00 CET] <fritsch> that's not even nearly a proper backtrace
[17:57:40 CET] <DHE> that's not a backtrace, it's just one line. I'd say install the debuginfo packages but as a non-debian user I'm just walking away slowly
[17:57:55 CET] <fritsch> DHE: i rather think his glibc is from stoneage
[17:57:57 CET] <fritsch> if I see this right
[17:58:06 CET] <DHE> 2.13 isn't THAT bad...
[17:58:11 CET] <Akerus> I'm just running ffmpeg without parameters... could there be anything interesting in the backtrace?
[17:58:22 CET] <fritsch> Akerus: how did you get this ffmpeg?
[17:58:35 CET] <fritsch> i can copy a whole lot of binaries that do the same on your system :-)
[17:58:48 CET] <Akerus> wheezy-backports
[17:58:55 CET] <fritsch> -> #debian
[17:59:01 CET] <fritsch> will help you
[17:59:12 CET] <fritsch> no one besides debian knows what they packaged this time
[17:59:49 CET] <Akerus> we have another server, also wheezy and ffmpeg 1.2.12 where it runs just fine...
[18:00:13 CET] <fritsch> yeah - then blame the server? :-)
[18:00:53 CET] <fritsch> Akerus: apt-get install ffmpeg-dbg
[18:00:59 CET] <fritsch> gdb /path/to/ffmpeg
[18:01:08 CET] <fritsch> set logging on mylog.txt
[18:01:09 CET] <fritsch> run
[18:01:15 CET] <fritsch> thread apply all bt
[18:01:24 CET] <fritsch> press return until no output
[18:01:25 CET] <fritsch> quit
[18:01:33 CET] <fritsch> post the mylog.txt to e.g. paste.debian.org
[18:01:45 CET] <fritsch> and provide the link
[18:03:55 CET] <Akerus> a college of mine thinks it could be a kernel problem... he currently looks into that, i have to wait
[18:04:20 CET] <Akerus> *colleague
[18:06:16 CET] <fritsch> i don't think so - for me it seems that this was a pre wheezy server before
[18:06:21 CET] <fritsch> and upgraded in a wrong way
[18:36:23 CET] <danjanz> exit
[18:40:32 CET] <Akerus> fritsch: did the gdb run: http://pastebin.com/7kRD4b0g
[18:40:42 CET] <Akerus> quite short and not very much information
[18:40:59 CET] <fritsch> you did not install ffmpeg-dbg right
[18:41:37 CET] <fritsch> though it really seems you are running an ffmpeg package not matching your libc6
[18:41:46 CET] <Akerus> what should it look like?
[18:41:55 CET] <fritsch> it should not segfault
[18:42:55 CET] <fritsch> Akerus: dpkg -l |grep ffmpeg | pastebinit
[18:42:58 CET] <relaxed_> Akerus: why not install a recent version on both servers? http://johnvansickle.com/ffmpeg/
[18:43:03 CET] <fritsch> Akerus: apt-cache show ffmpeg | pastebinit
[18:43:26 CET] <fritsch> relaxed_: yeah, that's even much better
[18:43:46 CET] <fritsch> Akerus: download what he said and put the ffmpeg binary to /usr/local/bin and stop caring
[18:44:09 CET] <Akerus> nope too much testing required for raising the ffmpeg-version
[18:44:17 CET] <Akerus> that will be the last resort
[18:46:29 CET] <relaxed_> was ffmpeg even in wheezy?
[18:46:48 CET] <furq> no
[18:48:05 CET] <furq> there's an ffmpeg package but it's libav in disguise
[18:49:23 CET] <furq> it's not in wheezy-backports either
[18:49:30 CET] <Delta706> I am trying to convert a ts file with 2.8.4 but I am getting the error "could not find codec parameters"
[18:50:05 CET] <relaxed> I hope it's not from that repo where they lost the domain name and some other party took it over.
[18:50:12 CET] <furq> https://www.deb-multimedia.org/dists/oldstable-backports/main/binary-amd64/package/ffmpeg
[18:50:15 CET] <furq> you mean this one
[18:50:19 CET] <furq> from the version number i'm going to say it is
[18:51:04 CET] <relaxed> yeah, that's scary
[18:51:42 CET] <relaxed> Delta706: pastebin.com the command and all console output
[18:52:24 CET] <furq> "Conflicts: ffprobe" what
[18:52:51 CET] <furq> oh nvm apparently that used to be a standalone package
[18:54:47 CET] <Akerus> fritsch: first command: http://pastebin.com/zmJFBxBP
[18:55:09 CET] <furq> good guess furq
[18:55:44 CET] <Akerus> fritch: and the second one: http://pastebin.com/cZ2acVBy
[18:56:34 CET] <Delta706> http://pastebin.com/xBwiNNJq
[18:58:07 CET] <relaxed> Delta706: your ffmpeg lacks libvpx support, needed for webm.  try http://johnvansickle.com/ffmpeg/ or recompile with libvpx and libvorbis support
[19:03:51 CET] <relaxed> Delta706: https://trac.ffmpeg.org/wiki/Encode/VP9
[19:06:00 CET] <Delta706> okay I am building now
[19:06:39 CET] <micechal> are "128k" and "128K" the same in ffmpeg? if so, is it 131072, or rather 128000?
[19:12:35 CET] <micechal> when used like "ffmpeg -i in.flac -c libopus -b:a 128k out.opus" it seems to resolve to 128000
[19:12:35 CET] <DHE> it uses SI/standardized units. 'k' should lower case
[19:12:51 CET] <DHE> use ki for 1024-based units
[19:13:05 CET] <micechal> as in kibibytes?
[19:14:51 CET] <micechal> do you think it could make some difference to the quality of encoding? I mean, I know 128 kib is a bit more than 128 kb, and the file will be bigger as well, but do you think the encoder could somehow do better quality-per-filesize when using powers of 10 or powers of 2?
[20:21:17 CET] <Delta706> relaxed: I have done some more experiments and it seems that my problem is an input problem. If I convert from mp4 to mkv, all is well. If I convert from ts to mkv, I get the error. I looked at the output from ./configure but cannot determine which item to include to allow me to decode ts
[20:30:29 CET] <DHE> there are some h264 differences between mp4 and ts. maybe ffmpeg doesn't  handle them right...
[20:31:54 CET] <Delta706> the error is "could not find codec" which suggests that my build of ffmpeg does not know how to handle this type at all
[20:53:10 CET] <Delta706> okay I have downloaded a ts file. and this file, it converts
[22:32:13 CET] <JakeJ> anyone around that knows much about complex aac audio filters? i'm trying to make an 8 channel octagonal audio filter in aac and having issues libfdk_aac, libfaac, and aac, seems to just ignore my commands and convert to either 7.1, 6, or 5 channel files
[22:33:36 CET] <iive> atomnuker might know something about aac... just a feeling
[22:34:00 CET] <JakeJ> help me atomnuker, you are my only hope
[22:35:40 CET] <atomnuker> yeah, non-standard channel mapping in AAC is only possible with encoders that support Programmable Channel Elements
[22:36:18 CET] <atomnuker> ours doesn't and faac doesn't and I don't think libfdk does either
[22:39:20 CET] <atomnuker> and I think only a few decoders actually support those (but I doubt they correctly map every channel)
[22:49:34 CET] <JakeJ> yea the only method i can find for getting aac to work with 8 channel audio is using afconvert on mac with an octagonal flag
[22:49:58 CET] <JakeJ> but that means hopping from linux to mac in our pipeline or dedicate our entire pipeline to mac
[22:55:06 CET] <atomnuker> JakeJ: I did find this thread: http://webcache.googleusercontent.com/search?q=cache:nVZqeYjyDn4J:forum.videohelp.com/threads/374957-Creating-Octagonal-M4a-to-embed-into-a-video+&cd=4&hl=en&ct=clnk&gl=uk
[22:58:03 CET] <JakeJ> yea thats me
[22:58:06 CET] <JakeJ> lol
[00:00:00 CET] --- Sat Jan  9 2016

More information about the Ffmpeg-devel-irc mailing list