[Ffmpeg-devel-irc] ffmpeg.log.20160109

burek burek021 at gmail.com
Sun Jan 10 02:05:01 CET 2016

[00:10:13 CET] <podman> hey guys, hopefully quick question. I'm trying to create some files that I can segment for mpeg dash delivery
[00:10:43 CET] <podman> i'm having a little bit of an issue setting up the keyframe interval. it seems like it should be the frame rate * the segment length
[00:11:27 CET] <podman> so 2 second segments * 30fps would mean a keyframe interval of 60. what happens if i have a video with a fraction frame rate, like 23.98fps? I can't set the key frame interval to a fraction
[00:15:12 CET] <TD-Linux> your segments should be slightly shorter t hen
[00:15:23 CET] <TD-Linux> the important bit is that the segments start with a keyframe.
[00:16:14 CET] <podman> TD-Linux: gotcha
[00:16:29 CET] <podman> so, basically round down?
[00:16:33 CET] <podman> or use a floor?
[00:16:46 CET] <podman> 2*23.98 = 47.96... use 47?
[00:17:08 CET] <TD-Linux> sure. your segments also don't all need to be the same # of frames
[00:17:22 CET] <podman> That's true
[00:17:42 CET] <podman> TD-Linux: I'm just going based on what the very limited number of tutorials seem to say about this
[00:17:55 CET] <podman> i can't seem to find any particularly good ones
[00:18:03 CET] <TD-Linux> there aren't any as far as I know :/
[00:19:05 CET] <podman> sad times
[00:23:13 CET] <podman> TD-Linux: alright, I'm going to try this and see if that fixes things
[00:24:55 CET] <podman> TD-Linux: thanks
[07:02:22 CET] <prelude2004c> hey everyone.. anyone know why when i record PVR my PVR STart TIME is a negative value ? something to do with -ss ? seeking ? how do i prevent it from being negative and make sure the recording always starts at 00:00:00
[07:20:02 CET] <JustinBieber> is there some filter to slow down audio without chaning its pitch ?
[07:20:43 CET] <JustinBieber> when I use mplayer there are keys: "[ and ] Decrease/increase current playback speed", but it changed its pitch so if I say slow down the voice becomes very deep, but I need to change just speed
[07:20:47 CET] <JustinBieber> or can I do it with sox ?
[07:43:14 CET] <kepstin> if it's enabled in your build, you can try http://www.ffmpeg.org/ffmpeg-filters.html#rubberband
[08:01:09 CET] <mark4o> prelude2004c: did you try setpts/asetpts? http://www.ffmpeg.org/ffmpeg-filters.html#setpts
[08:02:23 CET] <mark4o> JustinBieber: -af atempo=0.5  http://www.ffmpeg.org/ffmpeg-filters.html#atempo
[08:28:22 CET] <durandal_170> JustinBieber: rubberband
[08:52:44 CET] <prelude2004c> mark4o i dont know how to use that  :(
[08:58:07 CET] <mark4o> prelude2004c: -vf setpts=PTS-STARTPTS -af asetpts=PTS-STARTPTS
[08:59:24 CET] <mark4o> that will make both video and audio start at 0, which may not be what you want if they started at different times and that is needed for them to be in sync.  In that case figure out how much you want to adjust by and adjust them both by the same number of seconds.
[09:01:04 CET] <mark4o> e.g. -vf setpts=PTS+120/TS -af asetpts=PTS+120/TS  to adjust them both forward by 120 seconds
[09:01:58 CET] <mark4o> if you already have a -vf option then just add ,setpts=... to that, same with -af and asetpts
[09:04:51 CET] <prelude2004c> yup i did that
[09:05:06 CET] <prelude2004c> but the playback of the recorded content still starts at end of recording... the start is a negative value
[09:05:20 CET] <prelude2004c> and the playback player always starts at zero ( 0 )
[09:05:50 CET] <prelude2004c> i setpts and then i use the player for playback and it only plays the last few seconds of video and then it ends
[09:06:17 CET] <prelude2004c> not sure why it is doing that. the player guys tell me its because the PVRSTARTTIME starts with a negative value.. which is what i am trying to work around
[09:07:22 CET] <prelude2004c> i put it in like this ' -vf "field,setsar=1/1,setdar=16/9,setpts=PTS-STARTPTS" '
[09:09:05 CET] <mark4o> prelude2004c: well I don't know what PVRSTARTTIME is; that sounds like something outside of ffmpeg
[09:09:39 CET] <prelude2004c> its an HLS thing .. but the .ts files that i am encoding with ffmpeg show a negative timestamp that is the issue
[09:48:51 CET] <Betablocker> gruezie
[10:02:26 CET] <waressearcher2> Betablocker: hallo und herzlich willkommen
[10:18:20 CET] <Betablocker> hi waressearcher2
[10:18:26 CET] <Betablocker> danke dir - moin
[10:22:02 CET] <t4nk168> Hi, I am trying to merge several videos together using ffmpeg. First, I am making all the videos to black & white by using  '-vf hue=s=0 -vcodec libx264 -pix_fmt yuv420p' command & then merging it. Sometimes,Its noticed that in the final merged video, the audio&video gets out of sync when playing via Quicktime player,but is properly in sync while playing in VLC player. What could be causing this problem?
[10:23:18 CET] <t4nk168> Has it anything to do with the pixel format that I am using?(im using  -pix_fmt yuv420p ).
[10:25:14 CET] <t4nk168> Any insights will be deeply appreciated.
[10:46:40 CET] <Betablocker> someone ever dewarped 180° or 360° fisheye in realtime with ffmpeg ? VOD would be ok too& better than nothing&
[13:14:12 CET] <t4nk939> Hi, I am trying to merge several videos together using ffmpeg. First, I am making all the videos to black & white by using  '-vf hue=s=0 -vcodec libx264 -pix_fmt yuv420p' command & then merging it.   Sometimes,Its noticed that in the final merged video, the audio&video gets out of sync when playing via Quicktime player,but is properly in sync while playing in VLC player. What could be causing this problem?
[13:39:08 CET] <Pinchiukas> The command '$ ffprobe -hide_banner -show_programs -print_format json -timeout 10 rtsp://' gives me '[rtsp @ 0x9f6d140] Unable to open RTSP for listening' and 'rtsp:// Permission denied' even though that stream is really available and is there.
[13:39:54 CET] <Pinchiukas> From the server side I see that the client isn't even trying to access the stream.
[16:58:18 CET] <odinsbane> I encoded a video to webm, and the quality is not good. What options should I set to improve it?
[16:58:36 CET] <furq> could you be less specific
[17:00:00 CET] <furq> actually i guess if it's webm then you probably didn't set a bitrate or crf
[17:00:18 CET] <furq> set -b:v appropriately
[17:01:22 CET] <odinsbane> I didn't set anything. ffmpeg -i goo.avi goo.webm. Ill check the b:v option (there is now audio to this video.)
[17:20:10 CET] <odinsbane> Worked great, it was defaulting to around 200K, I put it at 32000K and it works as expected.
[17:21:07 CET] <furq> that seems needlessly high but sure
[17:22:35 CET] <furq> for 1-pass encodes you're probably better off using -b:v 0 -crf 32
[17:22:42 CET] <furq> or whatever crf value works out best
[17:23:35 CET] <odinsbane> better how?
[17:25:05 CET] <furq> crf will try to target a particular image quality
[17:25:44 CET] <furq> it should give roughly the same quality independent of video content, resolution, framerate etc
[17:26:54 CET] <furq> using a target bitrate is only recommended if you're trying to hit a certain filesize (and then only in 2-pass mode)
[17:31:25 CET] <odinsbane> It looks good this way, the file is a little larger than using an explicit bit rate. It also took longer to encode.
[17:34:46 CET] <odinsbane> hmm, the speed might have been because of different computers or different encoders.
[17:37:03 CET] <odinsbane> If I try to use a mutli-image tiff file, ffmpeg only finds one image. Is it possible to get ffmpeg to recognize the multiple frames?
[18:22:34 CET] <renegaid> I am using this script to remux mkv to mp4 with aac audio but the processor is a little too slow
[18:22:36 CET] <renegaid> conv = Converter(self.FFMPEG_PATH, self.FFPROBE_PATH).convert(inputfile, outputfile, options, timeout=None, preopts=['-fix_sub_duration'], postopts=['-threads', '4'])
[18:23:00 CET] <renegaid> the developer told me to change threads from auto to 4 but that doesn't result in any changes
[18:23:08 CET] <renegaid> the same 20% cpu use
[18:23:58 CET] <c_14> That doesn't tell us anything. Either give us the complete commandline (and consolet output) or ask whoever wrote that wrapper
[18:24:08 CET] <c_14> You might want something like -c:v copy
[18:25:39 CET] <renegaid> the video is being copied
[18:25:49 CET] <renegaid> it is not converting
[18:26:41 CET] <furq> is there some reason you're not just calling ffmpeg directly
[18:27:13 CET] <renegaid> https://github.com/mdhiggins/sickbeard_mp4_automator/blob/master/mkvtomp4.py
[18:27:32 CET] <renegaid> i don't know anything about these things
[18:28:49 CET] <renegaid> he told me to change line 579 to from auto but that didn't result in any difference.
[18:28:53 CET] <furq> https://www.ffmpeg.org/ffmpeg-all.html#Advanced-Subtitle-options
[18:28:59 CET] <furq> Note that this option will delay the output of all data until the next subtitle packet is decoded: it may increase memory consumption and latency a lot.
[18:29:04 CET] <renegaid> is converting ac3 to aac multi threaded?
[18:29:19 CET] <furq> nooh
[18:29:21 CET] <furq> oh
[18:29:22 CET] <furq> no
[18:29:30 CET] <furq> i'm good at typing
[18:29:43 CET] <renegaid> maybe that's the problem then
[18:29:53 CET] <furq> probably
[18:30:14 CET] <c_14> Converting ac3 to aac shouldn't be that difficulet.
[18:30:15 CET] <c_14> -e
[18:31:01 CET] <renegaid> it does not take long but I thought it could be faster with multi thread
[18:31:05 CET] <c_14> getting about 316fps here
[18:32:07 CET] <furq> mp4 can contain ac3 fwiw
[18:32:18 CET] <furq> i wouldn't bother converting unless you're going to stream it
[18:32:46 CET] <renegaid> I know. The ac3 is left and so is the dts but i want an aac track for comparability
[18:33:06 CET] <renegaid> compatibility
[18:33:26 CET] <c_14> What player plays aac but won't play ac3?
[18:33:31 CET] <c_14> Even tvs should play that.
[18:34:13 CET] <renegaid> ios devices for one. i don't think it can play ac3 but never checkwed
[19:27:50 CET] <Bitterblue> Hi.
[19:27:59 CET] <Bitterblue> I'm trying to extract some information from a DVD VOB, using av_parser_parse2, but the output is a bit off (by one frame). Am I doing it wrong? https://dpaste.de/8mad  https://dpaste.de/zAbf
[19:28:36 CET] <Bitterblue> Using ffmpeg 2.8.1.
[21:19:21 CET] <Bitterblue> The off-by-one issue is solved by using PARSER_FLAG_COMPLETE_FRAMES. The first frame is no longer detected as type "question mark".
[21:20:59 CET] <prelude2004c2> hey guys.. can anyone speak to this " http://pastebin.ca/3324305  "
[21:22:41 CET] <Pinchiukas> This sucks... I point ffprobe to my IPTV provider stream URLs and I get all sorts of random errors.
[22:56:48 CET] <CarlFK> https://trac.ffmpeg.org/ticket/1147            closed                 defect                 (needs_more_info)
[22:57:42 CET] <CarlFK> I seem to be having some sort of memory problem
[22:58:27 CET] <CarlFK> running this command https://github.com/voc/voctomix/blob/master/example-scripts/ffmpeg/record-mixed-ffmpeg-segmented-timestamps.sh
[22:58:42 CET] <CarlFK> both are reading from -i http://...
[22:59:12 CET] <CarlFK> I have used valgrind before, but under someone elses direction.
[23:02:10 CET] <CarlFK> the server is https://github.com/voc/voctomix/blob/master/voctocore/voctocore.py
[23:03:12 CET] <CarlFK> that is still under development, but has been used in production ... and is leaning on gstreamer so that bit should be stable
[23:10:32 CET] <CarlFK> I would like to strip away most of that command so that it just reads from the network port and then discards
[23:10:52 CET] <CarlFK> and then add back to it until it starts eating memory again
[23:11:06 CET] <CarlFK> (or maybe we will find that just reading from a network port eats memory )
[23:46:46 CET] <xintox> any hackers?
[23:47:04 CET] <xintox>  /j #h4krs
[00:00:00 CET] --- Sun Jan 10 2016

More information about the Ffmpeg-devel-irc mailing list