[Ffmpeg-devel-irc] ffmpeg.log.20160112

burek burek021 at gmail.com
Wed Jan 13 02:05:01 CET 2016

[05:03:40 CET] <thebombzen> so it appears ffmpeg has a delay when reading from a webcam. do we know why this is?
[05:03:53 CET] <c_14> buffer?
[05:22:24 CET] <thebombzen> well yes. but can I get rid of it?
[05:22:37 CET] <c_14> not really
[05:22:54 CET] <thebombzen> then why can mplayer play it without a buffer.
[05:23:09 CET] <thebombzen> if ffplay/ffmpeg can't.
[05:23:36 CET] <c_14> Well it probably could, but the buffer isn't really settable.
[05:23:46 CET] <c_14> You could try setting probesize/analyzeduration to something small
[05:24:50 CET] <thebombzen> I tried that. didn't work. also tried -avioflags direct -fflags nobuffer
[05:25:11 CET] <thebombzen> also, did anyone ever figure out the whole bitstream filter issue? I think it might actually be a bug.
[05:26:29 CET] <c_14> if you do ffmpeg <your input options> -c copy -f mjpeg out.mjpeg; and then use the bitstream filter on that file does it work?
[05:27:48 CET] <thebombzen> I just tried that. it still whines.
[05:28:14 CET] <c_14> then it might be a bug
[05:28:20 CET] <c_14> open a ticket on trac
[05:29:22 CET] <thebombzen> ah. looks like I have to compile a minimal build :P
[05:29:32 CET] <thebombzen> oh well. worth it.
[05:45:38 CET] <c_14> Oh, if you can. Can you attach a sample as well?
[05:49:31 CET] <thebombzen> Opened a bug, attached a short sample.
[06:28:45 CET] <kuroro> i want a very precise cut of a video (i.e milliseconds in duration), from 00:00:00.120 to 00:00:00.340, after reading some resources online, it seems like this is difficult as ffmpeg is "forced to only use/split on i-frames"
[06:29:00 CET] <c_14> only if you don't reencode
[06:29:10 CET] <kuroro> im interested in learning more about why it has to split on i-frames
[06:29:40 CET] <kuroro> c_14, so if i reencode, precision cutting would be possible?
[06:29:45 CET] <c_14> Because in order to correctly render P and B frames, the I frames are necessary
[06:29:47 CET] <c_14> yes
[06:30:33 CET] <kuroro> are there uncompressed video formats by the way?
[06:30:40 CET] <c_14> rawvideo
[06:30:48 CET] <kuroro> i imagine there wont be any I/P/B frames in there
[06:31:02 CET] <c_14> There are plenty of lossless video formats if you just want a lossless conversion.
[06:31:10 CET] <c_14> rawvideo is all I-frames
[06:31:20 CET] <c_14> There are other i-frame only codecs and some codecs with i-frame only modes
[06:31:29 CET] <kuroro> what's an example of rawvideo format ?
[06:31:39 CET] <c_14> rawvideo
[06:31:41 CET] <kuroro> oh, which codecs are i-frame only?
[06:32:00 CET] <c_14> ffv1 was for a while at least
[06:32:08 CET] <kuroro> i see
[06:32:14 CET] <c_14> it might have gotten P frames though, can't remember
[06:32:36 CET] <kuroro> im gonna try reencoding to see if cutting will be more precise
[06:34:10 CET] <kuroro> btw, do you have any resource recommendation for learning more about i/p/b frames (i.e from a programming standpoint ideally), and not just the MPEG standard
[06:34:40 CET] <c_14> There's probably a bunch of tech talks out there.
[06:35:06 CET] <c_14> Maybe more if you go into specially motion prediction/motion compensation.
[06:35:17 CET] <c_14> eh, no not compensation that's something else
[06:35:30 CET] <c_14> well
[06:35:35 CET] <c_14> w/e
[06:36:25 CET] <kuroro> ic. im just curious if we can remove I/P frames from a video, and have video players only play the B frames
[06:36:35 CET] <c_14> no
[06:36:35 CET] <kuroro> basically just showing the changes
[06:37:05 CET] <c_14> The P/B frames are mainly the parts of the video that completely changed along with a bunch of motion vectors.
[06:37:07 CET] <kuroro> but theoretically, would it be possible to create a custom player that plays only the b frames :)
[06:37:13 CET] <c_14> Depending on the exact changes you could display _something_
[06:37:15 CET] <c_14> sure
[06:37:17 CET] <c_14> but
[06:37:19 CET] <c_14> eh
[07:36:02 CET] <k_sze> Anybody has any idea what pixel formats are supported by Google Chrome's H.264 decoder?
[07:37:33 CET] <chungy> yuv420p and yuv444p should both work. Can always make 10-second tests :P
[07:39:02 CET] <k_sze> It looks like Firefox only supports yuv420p. :(
[08:33:43 CET] <inhahe> Do .flv files store their audio in .aac form? Why when I convert a file from .flv to .m4a using ffmpeg it's slow, indicating that it's decoding and re-encoding the data? How do I just extract the audio directly to an audio file?
[08:37:35 CET] <waressearcher2> inhahe: -c:a copy
[08:39:49 CET] <inhahe> what is "copy" in that?
[08:39:56 CET] <inhahe> is that part of the command?
[08:40:02 CET] <inhahe> or do i replace that with an output file name/
[08:41:34 CET] <waressearcher2> ffmpeg -i input.flv -c:a copy output.m4a
[08:41:45 CET] <inhahe> thank you
[08:42:21 CET] <waressearcher2> bitte
[08:59:35 CET] <inhahe> waressearcher2: woah, i noticed that when i do that the output file, the m4a, is actually larger than the flv (almost the same size)
[08:59:41 CET] <inhahe> does it include the video in the m4a?
[08:59:47 CET] <inhahe> can i use -nv with c:a copy?
[09:03:42 CET] <waressearcher2> ja
[09:09:24 CET] <xintox> waressearcher2: howdy
[09:11:05 CET] <waressearcher2> xintox: hallo, whe geht's ?
[09:13:25 CET] <inhahe> that worked (-vn)
[09:18:01 CET] <xintox> waressearcher2: howdy mate!
[09:18:06 CET] <dongs> should I be able to extract hdmv_pgs_subtitle using ffmpeg?
[09:18:25 CET] <dongs> i see https://trac.ffmpeg.org/ticket/2208 but thats a 3 years old bug, i guess it should be fixed by now?
[09:24:13 CET] <dongs> never mind, TSMuxeR handle it
[09:50:15 CET] <inhahe> waressearcher2: when using c:a copy from flv to m4a, it works but one thing that shows up is "[ipod @ 000000000051eee0] Codec for stream 0 does not use global headers but container format requires global headers" - does it automatically put those global headers in for me, or is it actually writing .aac files and not m4a? (my understanding is that m4a is aac + global headers)
[10:13:52 CET] <waressearcher2> inhahe: Äh, 'tschuldige ich habe echt keine ahnung
[10:14:46 CET] <inhahe> ok, anyone know?
[11:12:55 CET] <gilbahat> hi, quick question which I couldnt find the answer for on docs. I have built ffmpeg with vdpau (enable-vdpau shown on compile options) but I still didnt get it as a hwaccel option. what could be the reason?
[11:27:25 CET] <gilbahat> I am trying to explicitly enable them in the conf and still the printout is enabled hwaccels:  (i.e. blank)
[11:40:34 CET] <codingquark> Need some help: I encoded a video with libx264 (medium preset). Need to play it in Firefox browser. I'm able to play it with mkv container but not with mp4 container. What am I missing?
[11:41:32 CET] <furq> are you sure you've got that the right way round
[11:42:56 CET] <codingquark> furq: meaning?
[11:43:13 CET] <furq> it should be able to play mp4 but not mkv
[11:43:56 CET] <codingquark> No, this is what is happening. Should I link the video?
[11:44:13 CET] <furq> sure
[11:44:45 CET] <codingquark> videodeckassets.s3.amazonaws.com/10000/long.mkv
[11:44:56 CET] <codingquark> videodeckassets.s3.amazonaws.com/10000/long.mp4
[11:45:17 CET] <furq> yeah the mp4 plays and the mkv tries to download
[11:45:21 CET] <furq> which is exactly what i'd expect
[11:45:38 CET] <codingquark> With mp4, the browser shows 'video corrupt'
[11:45:52 CET] <codingquark> How come it plays on your Firefox?!
[11:46:12 CET] <furq> are you on the latest firefox
[11:46:14 CET] <codingquark> Also, it is noteworthy that everything plays fine on Chrome.
[11:46:20 CET] <furq> and do you have any plugins installed which would try to hijack movie playback
[11:46:25 CET] <codingquark> Firefox 43
[11:46:29 CET] <furq> i think there are VLC plugins and whatnot which do that
[11:46:56 CET] <furq> if mkv is playing in the browser then i assume it's not using firefox's builtin player
[11:46:57 CET] <codingquark> Yeah, I think mkv is being played by the VLC plugin.
[11:47:15 CET] <codingquark> Then why is mp4 video corrupt?
[11:47:24 CET] <furq> no idea, it looks fine here
[11:47:34 CET] <furq> try it again with the plugin disabled
[11:47:40 CET] <codingquark> Okay.
[11:49:24 CET] <codingquark> Now the broswer is crashing when I open the mp4 video.
[11:49:39 CET] <codingquark> So, mp4 is the right container to use?
[11:49:55 CET] <furq> yes
[11:50:10 CET] <codingquark> Okay. Seems a browser problem then.
[11:50:49 CET] <codingquark> Thanks for the help. Will check on different versions and plugin settings. If problem persists, will ask again. Thanks again!
[11:52:53 CET] <k_sze> It looks like encoding with libx264 used to be non-deterministic?
[11:53:01 CET] <k_sze> Is that still the case?
[11:56:41 CET] <furq> k_sze: iirc it's deterministic by default
[11:57:11 CET] <furq> https://mailman.videolan.org/pipermail/x264-devel/2015-April/011036.html
[12:22:21 CET] <k_sze> furq: "This is actually the intended behavior."
[12:22:29 CET] <k_sze> but it's not documented at all. wtf
[12:30:38 CET] <pgunnars> Hello, was wondering about transcoding webm videos. Is there an argument which lets me retain same quality?
[12:31:08 CET] <furq> the same quality as what
[12:32:09 CET] <pgunnars> the input file, which is of the same format
[12:32:17 CET] <pgunnars> so I'm cutting a webm to webm
[12:32:21 CET] <pgunnars> would like to retain the same quality
[12:36:00 CET] <relaxed> pgunnars: use -c copy to copy the streams
[12:37:20 CET] <pgunnars> relaxed: but -c copy isn't frame accurate (which I need)
[12:37:39 CET] <furq> if you're cutting on i-frames then that'll work fine
[12:38:03 CET] <furq> oh nvm you already said you're not
[12:38:31 CET] <furq> if you need to transcode then there's no way to automatically use the same quality
[12:39:38 CET] <pgunnars> -lossless 1?
[12:39:57 CET] <furq> that won't lose any quality but it will also result in a massive file which will probably be unplayable
[12:40:56 CET] <pgunnars> what would you recommend?
[12:41:15 CET] <furq> ffprobe the input file, make a note of the video bitrate and pass that to -b:v
[12:41:22 CET] <furq> you'll lose some quality but hopefully not too much
[12:44:12 CET] <pgunnars> use -crf as well maybe?
[12:45:20 CET] <furq> you can't use -crf as well as -b:v
[12:45:28 CET] <furq> you have to explicitly set -b:v 0 to use crf
[12:45:50 CET] <furq> crf is generally better though so if you know what that involves then go for it
[12:47:26 CET] <pgunnars> furq: don't think thats true
[12:47:27 CET] <pgunnars> https://trac.ffmpeg.org/wiki/Encode/VP9
[12:47:38 CET] <pgunnars> Constrained Quality
[13:23:31 CET] <wuqiong> hi, how to enable videotoolbox for iOS?
[15:21:20 CET] <j105rob> trying to stream to ffserver using ffmpeg and view with VLC, but not seeing any video; where do I start to figure out why this is not working?
[15:27:42 CET] <j105rob> the input is via stdin, I am using python to create the frames
[15:28:02 CET] <j105rob> so I am calling ffmpeg thru a subprocess
[15:32:12 CET] <kynlem_> c_14 bencoh are you around guys?
[15:33:39 CET] <kynlem_> i am doing this: ffmpeg -i VideoForCutting.mp4 -ss 0 -t 60.06 -an -vcodec copy ~/noaudio-chunk00.mp4
[15:34:13 CET] <kynlem_> and the durtion of the file comes out as expected: 01:00.06
[15:34:58 CET] <kynlem_> but if i copy the audio as well (-acodec copy), it is 01:00.08
[15:36:11 CET] <kynlem_> the sample rate of the audio stream is 48kHz, doesn't that make it safe to assume that there's an audio sample per each hundredth of a second?
[15:36:56 CET] <kynlem_> and if so (and no sample gets cut in the middle), why would ffmpeg pad the audio stream (or cut it at a further point than requested)?
[15:40:01 CET] <thebombzen> kynlem: because with -acodec copy it won't cut along the samples, it'll cut along the audio frames
[15:40:13 CET] <thebombzen> to get sample-based precision you'd have to reencode the audio
[15:41:05 CET] <thebombzen> kynlem_: although lossless audio (like alac in mp4) is actually a reasonable size, but don't expect great compatibility unless it's flac.
[15:41:58 CET] <thebombzen> j105rob: try testing the components separately. e.g. first, stream it to a file and see if you get what you want
[15:42:40 CET] <j105rob> @thebombzen that is where I am headed now& looks like stdin on the subprocess is not flushing
[15:42:42 CET] <j105rob> thx!
[15:43:29 CET] <kynlem_> is there a way to list the timestamps of where the audio frames start?
[15:44:52 CET] <kynlem_> for instance, with video, i'm lucky enough that in the case of my camera, each 8th frame is an i-frame -- so just had to little math to be on the safe side with where i'm cutting
[15:45:42 CET] <thebombzen> unfortunately, I have no idea how to do that. sorry
[15:45:49 CET] <kynlem_> so there's still hope that audio frames appear at fixed frequences
[15:46:01 CET] <kynlem_> is that common at all? or usually they're starting at random points?
[15:46:29 CET] <thebombzen> I think that would have to depend on the encoder or on the codec
[16:02:01 CET] <bencoh> you wont get a sample-based precision cut by just cutting/transcoding with ffmpeg
[16:02:24 CET] <bencoh> since ffmpeg will just decode audio frames, take the raw frame, pass it to the encoder, and output encoded frames
[16:03:22 CET] <bencoh> and as I told you last time, you might even run into the "last few samples" issue where it will need to pad the last frame with blank
[16:04:56 CET] <bencoh> btw, a sample is a smallest audio unit, you cant cut it. you probably meant "and no frame gets cut in the middle"
[16:05:04 CET] <bencoh> the*
[16:05:18 CET] <bencoh> kynlem_: ^
[16:12:33 CET] <kynlem_> bencoh: kudos. is there a way to list the timestamps where each frame starts?
[16:14:19 CET] <bencoh> programmatically, sure, with ffmpeg, maybe
[16:21:02 CET] <kynlem_> bencoh: how would you accomplish what i am trying to do?
[16:21:29 CET] <kynlem_> i need to cut a video into independent pieces (not segments)
[16:21:43 CET] <kynlem_> each roughly one minute long
[16:22:33 CET] <kynlem_> without sound samples padded at the end
[16:23:04 CET] <bencoh> with -c:a copy it's not padded
[16:23:46 CET] <bencoh> ffmpeg returns a different length for resulting size, probably because of dts difference between first audio and first video
[16:25:19 CET] <bencoh> (or any other reason for that matters)
[16:25:33 CET] <bencoh> what's wrong with this method btw?
[16:25:52 CET] <kynlem_> when i put these pieces one right after another in adobe premiere
[16:25:57 CET] <kynlem_> there's this popping sound
[16:26:10 CET] <bencoh> why do you want to stitch with adobe premiere ?
[16:26:24 CET] <bencoh> sounds like XY problem :)
[16:26:33 CET] <kynlem_> my whole point is to deal with small files
[16:27:02 CET] <kynlem_> for the thing i'm making, i only need a small portion of the massive amount of video i recorded
[16:27:29 CET] <bencoh> actually I suspect adobe premiere is the one padding when importing your segments
[16:27:30 CET] <kynlem_> so if i cut 2gb videos files into smaller chunks, i only need a few smaller chunks for the project
[16:28:13 CET] <kynlem_> bencoh: when i stich the videos back with ffmpeg, i don't notice any sort of popping sound
[16:28:31 CET] <bencoh> which is why I'm saying adobe is the one introducing the issue :)
[16:28:42 CET] <kynlem_> yes
[16:29:05 CET] <kynlem_> but when i put the 2gb video files (max size) that my camera produces one right after the other
[16:29:12 CET] <kynlem_> there's no such popping sound
[16:29:28 CET] <kynlem_> probably because the stream lengths match perfectly
[16:29:56 CET] <kynlem_> so i was wondering if i could somehow accomplish that
[16:40:57 CET] <bencoh> kynlem_: why dont you just cut the part you need with ffmpeg and import it in adobe?
[18:06:24 CET] <Nudin> Hi, I'm having troubles understanding the variables in the setpts-filter
[18:08:33 CET] <c_14> Which exactly?
[18:08:51 CET] <Nudin> What I would need is a value going from 0 (start of video) to 1 (end of video) – I first thought TB could be exactly this, but I'm not sure anymore…
[18:09:48 CET] <c_14> The setpts filter doesn't know the duration of the video, therefore it can't do what you want it to.
[18:11:14 CET] <hurstly> how do you go about setting the pid for the video and audio i.e from one format to another but you wanna keep the same pid if possiable?
[18:11:30 CET] <Nudin> damn, but ok, so I'll have to do the normalisation myself.
[18:12:18 CET] <Nudin> @c_14: "T" is the original playback-timepoint in seconds?
[18:12:40 CET] <c_14> yes
[18:14:55 CET] <Nudin> Ok, thanks a lot! (You just ended me of trying to read the sourcecode for 3 hours – with only minor C knowlege, so real huge thanks)
[18:16:05 CET] <kbarry> I'm looking for a recommended/Suggest OS for using FFMPEG in the *nix world.
[18:16:55 CET] <kbarry> I have had a hard time getting it to function on  centos 6.5, which is where almost all my *nix experience has been.
[18:17:08 CET] <furq> debian, of course
[18:17:19 CET] <kbarry> I'm hoping to use ffmpeg, and my mentor suggested I ask the community what OS was preffered.
[18:17:23 CET] <kepstin> yeah, that's probably just cause the dependencies are so old on centos 6
[18:17:29 CET] <c_14> If you use a static build it doesn't really matter.
[18:17:34 CET] <furq> that too
[18:17:43 CET] <furq> but if you're looking for a distro to switch to then debian is pretty good
[18:17:55 CET] <kbarry> nah, I wont be switching
[18:17:58 CET] <furq> it's hard to find one worse than centOS
[18:18:14 CET] <kbarry> my shop is 60% centos 6.5, and the rest if Windows Server 2012
[18:18:19 CET] <kbarry> Hahahaha
[18:18:25 CET] <furq> you have my condolences
[18:18:26 CET] <kepstin> if you want to stick with centos (used to rpms, whatnot), then consider switching to 7
[18:18:37 CET] <kbarry> We are looking into 7.
[18:18:44 CET] <furq> fedora has the same RHEL roots as well
[18:19:00 CET] <furq> not that i'm recommending it
[18:19:01 CET] <kbarry> Apparently the Architect hasn't had enough experience with Centos7.
[18:19:13 CET] <furq> does he demand you capitalise the word architect
[18:19:16 CET] <kbarry> so Debian?
[18:19:38 CET] <kbarry> Nah, just poor grades in grammar school.
[18:19:55 CET] <kbarry> BTW, I appreciate the help.
[18:20:01 CET] <furq> debian has ffmpeg in stable's backport repo and in testing and unstable
[18:20:11 CET] <furq> the latest version
[18:20:13 CET] <kbarry> Sweet.
[18:20:19 CET] <kbarry> I have only rarely used debian.
[18:20:35 CET] <kbarry> Any gotchas for a newbie to it, that I might want to be aware?
[18:20:37 CET] <furq> i've hardly used anything else in years
[18:20:43 CET] <furq> aside from the odd venture into freeBSD land
[18:20:56 CET] <furq> i've not used centOS recently enough to remember what's different
[19:10:15 CET] <j105rob> streaming a known working mpg file to ffserver and the WMP isnt showing the video, it appears to be connected. any hints on debugging what is wrong with the setup?
[19:31:00 CET] <pmac_> Hey guys, does anyone here have any recomendations for USB webcams theyve succesfully used with OSX & FFMPEG to live-stream to RTMP?
[20:10:06 CET] <gilbahat> Hi, I have just tested ffmpeg with hwaccel videotoolbox and it significantly decelerates decoding. since its relatively new, I cant find much in the way of documentation. can anyone help perhaps?
[20:12:15 CET] <TD-Linux> gilbahat, are you trying to decode much faster than realtime?
[20:13:34 CET] <gilbahat> at this moment I am just trying to get a synthetic benchmark running before Im going to try it on real workloads. I think I have a slight hint though: I see this when running with hwaccel:
[20:13:36 CET] <gilbahat> Input stream #0:0 frame changed from size:320x240 fmt:yuv420p to size:320x240 fmt:nv12
[20:14:17 CET] <gilbahat> I dont see it when running without hwaccel
[20:15:04 CET] <gilbahat> TD-Linux: yes, I want to decode as fast as possible, faster than realtime. this is for batch processing, not for playback.
[20:15:25 CET] <TD-Linux> yeah hwaccel needs a special pixel format
[20:15:34 CET] <TD-Linux> like what are the actual framerates you are seeing?
[20:15:52 CET] <DHE> colourspace conversion will impose a performance hit, yeah...
[20:15:59 CET] <TD-Linux> if you're aiming for over several hundred FPS I think you're going to really struggle with the hwaccel because it's not designed for that
[20:16:22 CET] <TD-Linux> you're going to run in to communication latency
[20:16:48 CET] <gilbahat> TD-Linux: atm trying to get the best out of the hardware. at least as a first goal, try to get it faster than CPU and go from there...
[20:17:56 CET] <gilbahat> without: frame=23909 fps=6889 q=-0.0 Lsize= 2689762kB time=00:13:17.76 bitrate=27620.4kbits/s with: frame=23909 fps=813 q=-0.0 Lsize= 2689762kB time=00:13:17.76 bitrate=27620.4kbits/s
[20:30:39 CET] <gilbahat> is this an ffmpeg limitation, a mac API limitation or hardware limitation?
[20:31:07 CET] <gilbahat> (i mean the input colorspace constraint)
[20:33:11 CET] <TD-Linux> gilbahat, oh yeah at 813fps I don't think you're going to get much more than that from hw
[20:33:27 CET] <TD-Linux> the pixel layout constraint is usually a hw limitation
[20:34:23 CET] <TD-Linux> hw usually requires a roundtrip to get each frame out. trying to wake up a process at more than 1khz on os x is pretty untenable
[20:36:26 CET] <gilbahat> TD-Linux: its still surprising that CPU does x8 better. cant it do blocks of frames though at least and not go frame-by-frame to avoid it?
[20:38:10 CET] <yongyung> So since youtube uses vp9 now, do you guys think it'd make sense to encode videos with libvpx for youtube instead of libx264? Is the encoder good yet?
[20:38:30 CET] <dystopia> stick with x264
[20:38:43 CET] <furq> youtube reencodes anyway so just use whichever is most convenient
[20:38:52 CET] <dystopia> in a couple of years, switch to x265, when hardware decoders are in everything
[20:39:06 CET] <furq> any upload time gains from using vp9 will be wiped out by how much longer it takes to encode
[20:39:53 CET] <yongyung> furq: Is the encoder *that* slow? I've got shit internet but an ok PC where I am atm (3570k/4.2gh, less than 1mbit upload)
[20:40:09 CET] <furq> maybe i'm doing something wrong but i can't get it to use more than about 20% cpu
[20:40:26 CET] <TD-Linux> modern libvpx, 1.4.0 and later, is reasonably fast
[20:40:51 CET] <furq> i'm using 1.5 and it's still incredibly slow
[20:41:20 CET] <furq> much slower than x265
[20:41:22 CET] <TD-Linux> the crossover point with x264 qualitywise is at like -speed 2 iirc
[20:41:52 CET] <TD-Linux> furq, at what speed levels?
[20:42:08 CET] <furq> it's still really slow at -speed 4
[20:42:12 CET] <TD-Linux> with x265 you still lose a lot of compression at anything less than -preset veryslow
[20:42:30 CET] <furq> iirc i get less than realtime at 480p with -speed 4
[20:42:35 CET] <furq> it's only using one HT core
[20:43:10 CET] <TD-Linux> you have to specify -threads and slices manually unfortunately
[20:43:16 CET] <furq> yeah that doesn't work
[20:43:31 CET] <TD-Linux> well at 480p you'll only have like one slice
[20:43:58 CET] <furq> oh?
[20:47:45 CET] <gilbahat> TD-Linux: do you know if I can get QSV in mac or is vda/videotoolbox wrapping around QSV with that regards?
[20:47:52 CET] <furq> hmm
[20:48:05 CET] <furq> it's a bit better with 720p content and -slices 4
[20:48:10 CET] <furq> still only using ~35% though
[20:48:21 CET] <bencoh> considering x265 isn't exactly "fast", much slower than x265 means ... really slow ;p
[20:48:23 CET] <furq> 20fps at -speed 4
[20:48:28 CET] <TD-Linux> 35% being two of your cores?
[20:48:37 CET] <furq> it's a quad core i7 with HT
[20:48:45 CET] <furq> so about 1.5 HT cores
[20:48:56 CET] <bencoh> HT doesn't help that much for encoding with SIMD optims
[20:49:15 CET] <TD-Linux> IIRC min slice width is 512?
[20:49:31 CET] <furq> what are recommended options for multithreading anyway
[20:49:47 CET] <bencoh> I usually don't count on HT when encoding
[20:50:24 CET] <bencoh> (so my ratio is more like 1 than 1.5)
[20:51:03 CET] <bencoh> at least for live encoding
[20:51:04 CET] <TD-Linux> -threads 8 -tile-columns 6
[20:51:10 CET] <furq> is -frame-parallel still needed
[20:51:16 CET] <TD-Linux> no
[20:52:04 CET] <furq> yeah that still sucks
[20:54:42 CET] <furq> i wonder if it's a windows issue
[21:19:51 CET] <j105rob> trying to stream a mpg to a ffserver and the client, in this case VLC shows no output at all. http://pastebin.com/nzF7Jxg4
[21:20:13 CET] <j105rob> Where do I start to look for the issues?
[21:21:12 CET] <j105rob> the ffserver out put is here: http://pastebin.com/TeX82eZi
[21:25:05 CET] <j105rob> server config is here: http://pastebin.com/RsZcQEBe
[21:26:20 CET] <llogan> ffserver is where questions go to die
[21:26:26 CET] <llogan> unfortunately
[21:27:08 CET] <j105rob> :(
[21:27:28 CET] <j105rob> how do people stream?
[21:27:35 CET] <j105rob> maybe I am using the wrong tool
[21:29:21 CET] <llogan> i don't know. i don't do streaming stuff.
[21:32:56 CET] <Betablocker> hi j105rob
[21:33:02 CET] <j105rob> hello
[21:33:27 CET] <Betablocker> maybe https://datarhei.github.io/restreamer is a solution for you
[21:34:18 CET] <j105rob> @Betablocker thx, will look at it now
[21:34:33 CET] <Betablocker> it is for livestreaming & you could stream without streaming provider. it is not for big audiences but for normal private cases it is working. you could use youtube live, ustream or smthin like that for big audiences
[21:35:26 CET] <j105rob> @Betablocker so, you can use ffmpeg to provide the source of the stream?
[21:36:02 CET] <Betablocker> it is invisibel working in the tool in the link above - but yes ist works with ffmpeg
[21:36:40 CET] <Betablocker> ffmpeg is a swiss army knife for video - you can do nearly everything with it if you could handle the shell commands
[21:37:04 CET] <Betablocker> what kind of video source do u have ? live or vod ?
[21:37:20 CET] <j105rob> I am using ffmpeg to create a stream of frames from a FIFO
[21:37:34 CET] <j105rob> then I want to send it to a live stream server
[21:38:37 CET] <Betablocker> what do you mean with fifo ?
[21:38:55 CET] <j105rob> linux FIFO pipe
[21:39:04 CET] <j105rob> here is the command I am using: $ ffmpeg -re -f rawvideo -vcodec rawvideo -s 16x16 -pix_fmt argb -r 20 -i /tmp/vid -an http://ffserver.labs.g2-inc.net:8090/feed1.ffm
[21:40:51 CET] <j105rob> the /tmp/vid is the FIFO
[21:41:13 CET] <j105rob> I am dumping ARGB data arrays into it to create the frame
[21:41:29 CET] <pmac_> any recomendations for USB webcams theyve succesfully used with OSX & FFMPEG to live-stream to RTMP?
[21:42:00 CET] <Betablocker> same again pmac_ & take al look at http://datarhei.github.io/restreamer could handel that very easy
[21:42:24 CET] <Betablocker> @j105rob i do only livestreaming the command is: fmpeg -i "rtsp://video.sour.ce.ip:554/" -map 0 -c:v copy -c:a copy -f mp4 "rtmp://des.tina.tion.ip
[21:43:10 CET] <Betablocker> thats an example &. for sending livecontent to an streaming rtmp servern - should work with vod tooif you change your source
[21:43:50 CET] <Betablocker> @pmac_ http://www.ideasonboard.org/uvc/#devices
[21:44:07 CET] <llogan> i've never found one that doesn't work on linux
[21:44:20 CET] <j105rob> thx @Betablocker , Ill try that..
[21:49:03 CET] <pmac_> @Betablocker, unfortunalty it looks like that list is out-of-date, it lists a bunch of Logitech cameras, but they appear to be discontinued
[21:50:50 CET] <Betablocker> crap - sry
[21:52:32 CET] <Betablocker> like llogan said & it is hard to find cameras that dont work with osx the big player like logitech or microsoft should all work
[21:52:52 CET] <Betablocker> the make quite good hardware for usb cameras
[22:36:20 CET] <kbarry_> I'm trying to use "tee" to produce multiple (say 2) rtmp streams.
[22:37:46 CET] <kbarry_> ffmpeg -i http://SOURCE.COM/FILE.m3u8 -ar 44100 -f flv "rtmp://DESTINATION.net/stream/file" is what I am starting with.
[23:32:07 CET] <Hfuy> Hello. I'm writing a script that reads ffmpeg's status information from stderr. It doesn't seem to include the progress info. Where does that come out?
[23:33:14 CET] <llogan> what you say !!
[23:33:59 CET] <Hfuy> Old meme is old.
[23:34:22 CET] <llogan> then you get no answer
[23:34:35 CET] <Hfuy> Sigh. Okay. I have no chance to survive.
[23:34:37 CET] Action: Hfuy makes his time, etc
[23:35:05 CET] <llogan> what i meant earlier is that i didn't quite understand your question
[23:35:27 CET] <Hfuy> Well, I've written a windows script host script to do batch processing.
[23:35:41 CET] <Hfuy> It reads the StdErr property of the process, which is where ffmpeg sends it status info.
[23:36:00 CET] <Hfuy> I get the usual preamble where it lists the configure options of the ffmpeg executable and describes the input file.
[23:36:04 CET] <Hfuy> But I don't get the progress info.
[23:37:33 CET] <Hfuy> Basically, I get everything down to "Press [q] to stop, [?] for help"
[23:38:07 CET] <Hfuy> Also it never seems to exit, even once the job is done.
[23:43:55 CET] <llogan> can you show your code?
[23:44:34 CET] <Hfuy> Sure, but unless you're familiar with windows script host, it may not help.
[23:44:44 CET] <Hfuy> Weirdly, when I redirect with 2>file.txt it works fine
[00:00:00 CET] --- Wed Jan 13 2016

More information about the Ffmpeg-devel-irc mailing list