[Ffmpeg-devel-irc] ffmpeg.log.20160113

burek burek021 at gmail.com
Thu Jan 14 02:05:01 CET 2016

[00:07:21 CET] <diginet> so, I'm using the zeranoe FFmpeg builds for windows, but the cinepak encoder doesn't show up for whatever reason. Has it been disabled? I swear I remember there being an encoder
[00:26:44 CET] <kbarry_> Currently I have a single HLS input, going to a single RTMP output.
[00:27:02 CET] <kbarry_> I read the tee documentation, but can't even see to get it to perform the same ob
[00:27:05 CET] <kbarry_> job
[00:27:28 CET] <kbarry_> ie, I have a single HLS input, wanting to go to a single RTMP endpoint
[00:28:50 CET] <yongyung> does libopus have "true" vbr or do the quality settings just correspond to a bit rate setting?
[00:29:40 CET] <TD-Linux> yongyung, by default opus has unconstrained VBR. the bitrate settings basically choose a quality that averages to that bitrate on a large corpus of music
[00:30:08 CET] <TD-Linux> you can, however, constrain the VBR in various ways or run CBR
[00:31:04 CET] <yongyung> TD-Linux: So if I'd want to encode a song or a video with libopus I'd just use whatever bitrate I want to target instead of -q:a?
[00:31:11 CET] <TD-Linux> yongyung, yup.
[00:32:35 CET] <kbarry_> http://pastebin.com/NT7PcgnF
[00:33:04 CET] <kbarry_> The first section, i am doing HLS to file, which works. Then I try HLS to file via tee, no dice
[00:33:15 CET] <kbarry_> lastly I try hls to rtmp via tee, also no dice
[00:33:53 CET] <kbarry_> Stream #0:0 -> #0:0 (aac (native) -> ? (?)) seems problemativ
[00:33:55 CET] <llogan> diginet: what makes you think it's not there?
[00:37:41 CET] <drv> (why in the world do you want to encode Cinepak in 2016?)
[00:41:21 CET] <furq> kbarry_: afaik you need to specify the output codec with the tee muxer
[00:42:59 CET] <kbarry_> i thought that is what I was doing when i used [f=flv]
[00:43:20 CET] <kbarry_> furq: apparently I am missing something else?
[00:43:46 CET] <furq> -c copy or -c:v libmp3lame (or whatever codec you want)
[00:44:45 CET] <furq> normally it will try to guess appropriate codecs for the format, but since tee uses its own format i guess that breaks it
[00:44:53 CET] <kbarry_> yeah,
[00:45:06 CET] <kbarry_> need to figure out how to translate that into the tee syntax
[00:45:19 CET] <kbarry_> [f=flv:c=libmp3lame] isnt working
[00:45:25 CET] <furq> just specify it as you would normally
[00:45:42 CET] <furq> unless you need different codecs for each output in which case you're on your own
[00:46:00 CET] <kbarry_> Ohh, lemme give it a try
[00:46:27 CET] <kbarry_> mind telling me what -c:v means?
[00:46:32 CET] <kbarry_> (This is audio only)
[00:46:41 CET] <furq> i meant -c:a
[00:47:59 CET] <kbarry_> Ooooooh, that works. But what if I DID wanna change things per output stream,
[00:48:42 CET] <kbarry_> how do ie, how do I translate -c:a libmp3lame into the tee snytax.
[00:48:49 CET] <furq> i don't know if that's even possible
[03:06:09 CET] <k_sze> I don't understand the -cpu-used option of libvpx-vp9
[03:06:24 CET] <k_sze> How does it go from -16 to 16? What does it even mean?
[03:17:37 CET] <k_sze> I don't know what I'm doing wrong, but transcoding form H.264 to vp9 is *extremely* slow on my server (32 Xeon cores)
[03:17:53 CET] <k_sze> These are the parameters I'm trying to use:
[03:18:50 CET] <k_sze> ffmpeg -i my_h264_video.nut -pix_fmt yuv420p -c:v libvpx-vp9 -threads 16 -quality realtime -cpu-used 16 -tile-columns 2 -tile-rows 2 -y output.webm
[03:19:06 CET] <k_sze> I'm getting below 10 fps transcoding speed, what the heck?
[03:19:11 CET] <k_sze> And my server is not busy.
[03:19:53 CET] <k_sze> It looks like ffmpeg fails to do multithreaded encoding of vp9.
[03:20:32 CET] <k_sze> I'm only using 100% CPU. Stuck with ffmpeg 2.5.3 at the moment because we have code that depends on it and can't freely upgrade until we can test that the newest 2.8.3 doesn't break anything.
[11:10:54 CET] <gilbahat> Hi, quick question, is there any way to peg ffmpeg to a specific GPU in a multi-gpu setup?
[11:11:34 CET] <gilbahat> I have 4 nvidia GPUs on my system and I need tight control over which GPU will be used for hwaccel
[11:15:49 CET] <gilbahat> brb
[11:19:57 CET] <ChALkeR> Hi all! Does anyone know, is the sending-local-files-to-remote-server vulnerability fixed already?
[11:49:27 CET] <ChALkeR> That's critical, and it's as public as it could be.
[11:50:13 CET] <ChALkeR> it was on the index page of http://www.alexa.com/siteinfo/habrahabr.ru (and is now on page4 of the same site), has code samples and instructions on how to build a malicious file
[13:25:55 CET] <xodmaster> Hi, I have ffmpeg for windows 32 bit, and I wonder if there is any config or envvar to make ffmpeg suppress the startup message with version, build flags etc ? Getting tiresome to see that message everytime.
[13:27:55 CET] <furq> xodmaster: -loglevel quiet -stats
[13:32:01 CET] <xodmaster> furq, thanks, but is there any config file or so to modify, or is a (bat) script front-end the only way ?
[13:32:24 CET] <xodmaster> tthe only way to not write that option down each time I mean.
[13:35:24 CET] <Mavrik> ffmpeg doesn't have config files, it's a one-off use tool
[13:37:51 CET] <xodmaster> Mavrik, I suppose it is. I suppose Iäll just create a frontend script, but it would be nice that the build itself had the quiet loglevel option as default.
[13:38:44 CET] <xodmaster> Most commandline tools I have used are quiet by default, only a few were verbose about the version/build info etc.
[13:47:23 CET] <ChALkeR> Is there a better work-around for now than building with --disable-network?
[13:48:27 CET] <ChALkeR> I filed https://bugs.archlinux.org/task/47738 with a suggestion to recompile with --disable-network for now.
[14:32:58 CET] <InTheWings> AVDISCARD_* missing from hevc ?
[14:57:01 CET] <InTheWings> no clue ?
[14:57:51 CET] <InTheWings> it should at least be able to drop non IRAP, no ?
[15:41:10 CET] <gilbahat> hi, quick question - anyone know if I can pin hwaccel to a specific GPU? I have a machine with 4 GPUs and need strict control over who/what touches which GPU
[15:42:33 CET] <gilbahat> anything, even something hackish, would do&
[16:41:17 CET] <t4nk895> hello, I am trying to stream ffmpeg from a webcam attached to a raspberry pi over the internet (not local network) to a laptop. Every network streaming guide I find seems to only apply to local networks. Can someone help?
[16:42:55 CET] <klaxa> this sounds more like a networking issue
[16:44:07 CET] <DHE> local networks is only a restriction if you're dealing with multicast or NAT. I assume the latter is the issue?
[16:45:13 CET] <t4nk895> it's entirely possible
[16:45:18 CET] <t4nk895> I'm brand new to this
[16:45:34 CET] <t4nk895> my router does have NAT settings - let me check them
[16:46:59 CET] <t4nk895> I'm using bridge mode ( devices operate transparently (no NAT or DHCP). Clients receive DHCP leases from the LAN or use static IPs. Use this for shared printers, file sharing, and wireless cameras.)
[16:47:30 CET] <t4nk895> I have a separate modem/router and access point
[16:47:57 CET] <t4nk895> I've set up port forwarding on the gateway(modem and router, but only being used as router)
[16:48:12 CET] <t4nk895> that allowed my streaming to work locally
[16:48:50 CET] <t4nk895> but I haven't found an ffmpeg command that seems to work when I'm away from home - even if I use a vpn to get around any potential port issues on my remote netwrok
[16:48:54 CET] <t4nk895> *network
[16:49:41 CET] <klaxa> how do you call ffmpeg?
[16:50:15 CET] <Betablocker> what do u mean klaxa ?
[16:50:24 CET] <Betablocker> ffmpeg is called ffmpeg :D
[16:50:41 CET] <klaxa> i mean what is the command he is using
[16:50:42 CET] <t4nk895> sudo ffmpeg -i /dev/video1 -f mpeg tcp:[remote address]:1234
[16:51:05 CET] <t4nk895> that seems to work (if i recall correctly) from the video source
[16:51:15 CET] <t4nk895> i might have used rtp instead of tcp
[16:51:24 CET] <bencoh> why do you need to run ffmpeg as root?
[16:52:05 CET] <t4nk895> i was getting issues before, so I am running as root until I find a command that works - there was some issue with permissions in opening a port (i think) at one point
[16:52:15 CET] <fritsch> bencoh: i think he had a port < 1024 in his original command
[16:52:48 CET] <klaxa> the address you are specifing should be a local ip bound to an interface or to bind to all interfaces
[16:53:14 CET] <t4nk895> @klaxa, can you explain that? not sure I follow
[16:53:28 CET] <klaxa> on the pi you want to stream the video
[16:53:56 CET] <klaxa> you don't know from where clients will connect, but you know on what ip address the packets will arrive
[16:54:00 CET] <furq> tcp://
[16:54:02 CET] <t4nk895> okay
[16:54:13 CET] <t4nk895> so the ip should be that of the pi?
[16:54:14 CET] <klaxa> for example you could only use wifi or ethernet
[16:54:25 CET] <furq> t4nk895: will listen on all available addresses
[16:54:27 CET] <klaxa> yes
[16:54:40 CET] <klaxa> if in doubt use
[16:54:41 CET] <t4nk895> on the pi?
[16:54:44 CET] <furq> yes
[16:54:49 CET] <t4nk895> hmm okay
[16:54:50 CET] <furq> then your actual lan/net ip on the client
[16:55:16 CET] <t4nk895> and that would be the address of my home network (on the client)?
[16:55:36 CET] <furq> the pi's lan ip if you're on the local network, your internet ip if you're not
[16:55:53 CET] <t4nk895> would the internet ip work  on my home network?
[16:56:02 CET] <klaxa> it should
[16:56:03 CET] <furq> it should do
[16:56:04 CET] <t4nk895> I'd like to eventually make a script that'll work anywhere
[16:56:11 CET] <t4nk895> okay, thank you so much
[16:56:19 CET] <t4nk895> I'm going to ssh into my pi and try it now
[16:56:57 CET] <t4nk895> any idea why the connection might be refused?
[16:57:37 CET] <furq> what client are you using
[16:57:53 CET] <t4nk895> terminal on a macbook
[16:58:04 CET] <furq> oh wait you mean the ssh connection?
[16:58:19 CET] <t4nk895> i'm already connected to the pi over ssh
[16:58:25 CET] <t4nk895> when I try my stream command
[16:58:34 CET] <t4nk895> the connection is refused on that ip address
[16:58:34 CET] <furq> right, what are you trying to stream it with
[16:58:35 CET] <furq> ffplay?
[16:58:39 CET] <t4nk895> yes
[16:58:55 CET] <furq> i just tested it and that works for me
[16:58:59 CET] <t4nk895> but the pi is refusing the connection, not the computer
[16:59:32 CET] <furq> pastebin the exact ffmpeg and ffplay commands
[16:59:39 CET] <t4nk895> okay
[17:00:29 CET] <furq> http://sprunge.us/jUNN
[17:00:31 CET] <furq> that works for me
[17:01:03 CET] <t4nk895> http://pastebin.com/L0Kp7DUj
[17:01:06 CET] <furq> oh wait you're using the net ip aren't you
[17:01:16 CET] <furq> er
[17:01:22 CET] <furq> you're using two different ports there
[17:01:39 CET] <t4nk895> sorry, 1234 is the port I'm using
[17:01:40 CET] <furq> also ?listen goes on the server side
[17:01:47 CET] <t4nk895> that's good to know haha
[17:01:48 CET] <t4nk895> thank you
[17:02:01 CET] <furq> and obviously you'll need to forward port 1234
[17:02:36 CET] <t4nk895> already done :)
[17:02:49 CET] <furq> also that server will only serve one client and it'll stop running as soon as the client disconnects
[17:03:03 CET] <furq> if you need something more robust you should look into a proper streaming server
[17:03:43 CET] <t4nk895> i'll try that
[17:03:44 CET] <t4nk895> thank you
[17:06:06 CET] <t4nk895> hmm I'm still getting an issue
[17:06:18 CET] <t4nk895> the client is timing out before the connection begins
[17:06:24 CET] <t4nk895> the server is streaming though! :)
[17:07:45 CET] <t4nk895> could that be an issue with the network i'm on?
[17:25:20 CET] <Taoki> Hi everyone... need a little help with something: I use a 3D animation program which outputs each frame to a png file (001.png, 002.png, 003.png, etc). But while I create test renders, I don't need such a high frame rate, so I can enable an option to skip frames. This however means that there are gaps in the numbers (001.png, 003.png, 005.png, etc). Does ffmpeg know to ignore these gaps?
[17:26:09 CET] <Taoki> So for instance, if there are normally 3 frames: 1.png, 2.png, 3.png: If 2.png is missing, ignore it and just stitch 1.png and 3.png. And so on for any number of frames.
[17:26:28 CET] <Taoki> I tried this a while ago but it didn't work for me. So maybe some parameter or another trick will do?
[17:32:58 CET] <DHE> where you put -r for setting the framerate matters. put it before the -i option to set the framerate of the source
[18:26:40 CET] <kingron> can someone help with this case? https://stackoverflow.com/questions/34772421/ffmpeg-convert-and-add-silent-audio-track-to-an-mpeg
[18:30:04 CET] <lxde_sea> kingron, Try inserting "-ss 0:00 -to 4:00" after the video input. (besides, your converted file has a higher bitrate than the original - this doesnt improve quality, just increase the size)
[18:30:29 CET] <lxde_sea> kingron, in fact, you can leave out the bitrates alltogether, ffmpeg will (usualy) get some nice ones for you
[18:30:52 CET] <lxde_sea> err, typo. ment audio input.
[18:44:59 CET] <kingron> trying ...
[18:51:13 CET] <kingron> <lxde_sea>, "-ss 0:00 -to 0:04" same results :/
[18:51:21 CET] <kingron> lxde_sea, "-ss 0:00 -to 0:04" same results :/
[18:51:44 CET] <kingron> tried also -t 4.00
[18:54:04 CET] <lxde_sea> kingron, is the source long enough? (or longer?)
[18:54:35 CET] <lxde_sea> then you might try changing the latter to: -to 0:04.003
[19:01:28 CET] <kingron> lxde_sea, no luck it stays at 3.997 or 4.23
[19:02:39 CET] <kingron> in this example it's very tiny the difference, but long mpegs have a bigger duration difference
[19:05:37 CET] <lxde_sea> kingron, sorry then, not that familar to help then :(
[19:25:07 CET] <Taoki> DHE: I currently use -framerate to specify the FPS. The problem however is I remember that ffmpeg couldn't notice missing frames, and would stop after frame 1 because it wouldn't find 2 instead of skipping to 3.\
[19:58:06 CET] <thetrueavatar> hi
[19:59:03 CET] <thetrueavatar> I'm now trying to use ffmpeg to encode in mpeg2 to make a dvd. Have some question if someone is available
[20:04:30 CET] <DHE> that's not how IRC works. ask your question to nobody in particular and you'll get your reply (eventually)
[20:05:28 CET] <thetrueavatar> ok then let's go ^^
[20:06:56 CET] <thetrueavatar> I just want to get the best mpeg2 encoding to have something nearly lossless. I found some information in the faq but was a bit surprised of the result. Has a file around 2gb for a film that last 1h37min
[20:07:39 CET] <thetrueavatar> Also don't understand if it worth making 2 pass if I set a qscale.  I would say no cause I'm targeting quality not size but saw this in faq
[20:08:41 CET] <thetrueavatar> I first used nero to do some authoriting and make him convert my source in mpeg2 and it says it used a nearly 10000Kb/s bitrate while encoding with ffmpeg show me a bitrate around 2600k.
[20:09:13 CET] <thetrueavatar> Is the nero encoder so terrible compare to ffmpeg mpge2  encoder ?
[20:10:08 CET] <thetrueavatar> My original file is a 3.5gb 1080p h264+256kbps audia
[20:11:26 CET] <DHE> when you use qscale ffmpeg will product a file whose per-frame image quality is about constant. that's potentially bad for DVD because you're supposed to adhere to the bitrate/buffer requirements. I believe the target is between 9 and 10 megabits. Nero might be going for exactly that while ffmpeg is just meeting your quality request
[20:13:11 CET] <thetrueavatar> Is there a way to be dvd compliant with mpeg ? Saw a -target pal-dvd option
[20:14:17 CET] <thetrueavatar> here is my current options: ffmpeg -i Kyrielle\ montage\ tout\ OK.avi -c:v mpeg2video -bf 2 -mbd rd -trellis 2 -cmp 2 -subcmp 2  -pix_fmt yuv420p -me_method epzs -threads 4 -vf zscale=w=720:h=406 -qscale:v 1 -c:a ac3 -b:a 320k Kyrielle-Z.mpg
[20:16:03 CET] <furq> 720*406 isn't dvd compatible
[20:16:06 CET] <DHE> The target option will basically expand into "-c:v mpeg2video -c:a ac3 ...", including the bitrate thresholds.
[20:16:20 CET] <thetrueavatar> I know standard is 720x576
[20:16:29 CET] <thetrueavatar> but tought I could keep orignal ratio
[20:16:45 CET] <furq> use -aspect 16:9
[20:16:54 CET] <DHE> the scaled image will retain the original ratio by leaving the ratio information in the source video file unless overridden
[20:17:41 CET] <thetrueavatar> os use -aspect 16:9 instead of zscale ?
[20:18:01 CET] <furq> zscale to 720*576 and then set -aspect 16:9
[20:18:15 CET] <furq> as DHE says you might not need to explicitly set -aspect but it does no harm
[20:19:06 CET] <DHE> leave aspect out unless the image looks distorted. it shouldn't. just check the output .mpg with the video player of your choice.
[20:20:11 CET] <thetrueavatar> and for the rest I keep it so ? My goal is that's readable on any dvd player
[20:21:01 CET] <thetrueavatar> if I use -target pal-dvd I have notice that it use 6000k bitrate
[20:38:05 CET] <DHE> that's the target's default. go ahead and override. the profile set allows bandwidth spikes
[20:41:09 CET] <thetrueavatar> well qscale doesn't seem to override the -b:v
[20:43:00 CET] <thetrueavatar> hum I write it to fast. Bitrate seems to be ok
[20:44:45 CET] <thetrueavatar> I'have been told that zscale with zimg was better than the default scaling
[20:44:56 CET] <thetrueavatar> will it override the -s option ?
[20:49:03 CET] <Betablocker> i have an rtsp stream&. in vlc the adress will produce a video. if i try to catch it with ffmpeg nothing happens. i am at the end of ideas what is going wrong :/ here is the error code http://pastebin.com/KCpAQQ0G
[20:59:45 CET] <klaxa> that's weird, try adding -map 0
[20:59:49 CET] <klaxa> Betablocker: ^
[21:10:15 CET] <Betablocker> ok
[23:40:28 CET] <bahoo> I did a `ffmpeg -i` on two different videos, both of which were created using the same ffmpeg command on two different machines, presumably with different codecs / libraries setup.
[23:40:47 CET] <bahoo> One video plays fine in QuickTime, the other does not. This was the one line that was different: https://dpaste.de/UFi4
[23:41:24 CET] <bahoo> Does anyone smarter than me spot anything that might trip up QuickTime there?
[23:46:02 CET] <drv> probably 4:2:0 vs 4:4:4 color space
[23:47:59 CET] <furq> apparently quicktime doesn't support hi444pp
[23:48:09 CET] <furq> by "apparently" i mean according to a comment on a stackoverflow answer
[23:48:12 CET] <furq> oh never mind
[00:00:00 CET] --- Thu Jan 14 2016

More information about the Ffmpeg-devel-irc mailing list