[Ffmpeg-devel-irc] ffmpeg.log.20160116

burek burek021 at gmail.com
Sun Jan 17 02:05:01 CET 2016

[00:10:33 CET] <an3k> is there some magic or do I have to compile x264 twice to get libav support?
[00:10:54 CET] <an3k> s/libav/lavf/
[00:14:10 CET] <J_Darnley> No.  You can do lavf then x264 and then stop there.
[00:14:43 CET] <J_Darnley> Otherwise there is an almost circular dependency.
[00:16:39 CET] <an3k> So ffmpeg always builds complete libs regardless if --enable-libx264 or not?
[00:17:05 CET] <J_Darnley> What do you mean by "complete libs"?
[00:17:19 CET] <an3k> currently I do x264 then ffmeg then x264 again and it works
[00:18:04 CET] <J_Darnley> The real dependency chain is: x264(.exe) depends on libavformat and libx264, libavformat may depend on libx264 too
[00:18:26 CET] <an3k> well, I build ffmpeg to get the libav* libs I need for x264 and l-smash
[00:18:44 CET] <J_Darnley> Last I heard that was the suggested way to get a full-featured x264.exe
[00:19:56 CET] <an3k> libx264 is build by ffmpeg?
[00:20:09 CET] <J_Darnley> no
[00:21:11 CET] <an3k> Ok, but how do I do lavf before x264 if lavf depends on libx264? :)
[00:21:27 CET] <J_Darnley> By not making it depend on libx264
[00:21:35 CET] <J_Darnley> It's optional
[00:21:42 CET] <JEEB> it only depends on it if you want to encode AVC with libx264
[00:21:46 CET] <JEEB> from within libavcodec
[00:21:55 CET] <JEEB> aka usually ffmpeg
[00:22:21 CET] <an3k> well, that means I have to build x264 twice. Once before ffmpeg/lavf and once afterwards.
[00:23:24 CET] Action: J_Darnley wonders how he got back here
[00:23:49 CET] <Zeranoe> an3k: I'm confused by your logic here. You compile x264 and link it in ffmpeg
[00:23:49 CET] Action: an3k is confused too
[00:24:26 CET] <an3k> But if I build x264 at the very beginning I don't have lavf support
[00:25:06 CET] <Zeranoe> an3k: What are you actually trying to do
[00:25:56 CET] <an3k> lavf:          no
[00:25:56 CET] <hurstly> how can i go about building ffmpeg for myself (a simple way of doing it if possile)
[00:25:59 CET] <an3k> I want a yes there
[00:26:02 CET] <drv> if you want an x264 executable with lavf input, and also ffmpeg with libx264 output, then yes, you have to build x264 twice
[00:26:22 CET] <an3k> hurstly: https://trac.ffmpeg.org/wiki/CompilationGuide
[00:26:44 CET] <drv> if you just want x264 executable with lavf input, you can build ffmpeg (with libx264 disabled) and then x264
[00:27:36 CET] <an3k> drv: a "steve carell hitting the table" thank you :)
[00:29:59 CET] <Zeranoe> hurstly: For what system?
[00:31:20 CET] <hurstly> windows
[00:31:28 CET] <hurstly> and your script is confusing.....
[00:31:53 CET] <Zeranoe> hurstly: That's because it's for cross compiling and I bet you're trying native?
[00:31:55 CET] <hurstly> or it flat out fails
[00:31:59 CET] <hurstly> nope
[00:32:07 CET] <hurstly> for windows
[00:32:16 CET] <Zeranoe> hurstly: Yes, for Windows, cross compiling
[00:32:28 CET] <Zeranoe> hurstly: How/where are you running it?
[00:33:29 CET] <hurstly> since i use windows myself i used a vm to install linux (total noob) with ubuntu x64
[00:34:15 CET] <Zeranoe> hurstly: What happens when you run it? How are you running it?
[00:34:43 CET] <hurstly> via term with sudo
[00:34:46 CET] <Zeranoe> hurstly: Also keep in mind you don't *need* my script to cross compile. Ubuntu provides mingw-w64 tools in their apt system
[00:34:56 CET] <Zeranoe> No sudo first of all
[00:35:59 CET] <hurstly> ok so how would i go about building ffmpeg like yourself ?
[00:36:38 CET] <an3k> have you checked the URL i posted? A very well guide written by ffmpeg itself
[00:37:59 CET] <hurstly> yes i did an3k most of it they "expect" a user to know what there doing than blind guessing anyways.... i did notice https://github.com/rdp/ffmpeg-windows-build-helpers however it does give me an error on line 5 on cross_compile_ffmpeg.sh
[00:38:20 CET] <Zeranoe> hurstly: win32 or win64
[00:38:27 CET] <hurstly> both
[00:38:51 CET] <Zeranoe> hurstly: Looking for LGPL?
[00:38:59 CET] <hurstly> nope
[00:39:35 CET] <Zeranoe> hurstly: Why not use the public builds then?
[00:39:44 CET] <an3k> Yeah, it's difficult for people who know what's going on to write a guide for people who don't :)
[00:40:25 CET] <hurstly> i guess i didn't fully understand your question to LGPL then if and thats the case its a yes ?
[00:41:07 CET] <Zeranoe> hurstly: sudo apt-get install binutils-mingw-w64-x86-64 gcc-mingw-w64-x86-64 g++-mingw-w64-x86-64 mingw-w64-tools
[00:41:08 CET] <hurstly> as i wouldn't mind having it built with say fdk aac or intel quicksync etc... at least thats the goal
[00:41:40 CET] <Zeranoe> hurstly: You might want to double check those libs. You want the mingw-w64 toolchain, whatever the apt package is that ubuntu uses
[00:42:31 CET] <Zeranoe> once you have i686-w64-mingw32-gcc x86_64-w64-mingw32-gcc and they both function, you're off to a good start.
[00:43:17 CET] <an3k> is --enable-nonfree and/or --enable-gpl adding any features I wouldn't have without these options?
[00:44:14 CET] <Zeranoe> an3k: --enable-gpl will. Don't use nonfree unless you have to
[00:45:12 CET] <hurstly> so should i use this script to get the ball rolling https://github.com/rdp/ffmpeg-windows-build-helpers/blob/master/cross_compile_ffmpeg.sh ?
[00:46:29 CET] <Zeranoe> hurstly: I've never used it myself so I cannot say
[00:48:19 CET] <hurstly> ok
[00:52:44 CET] <an3k> is there a shortcut to just build some libav libs? --disable-all --enable-avcodec doesn't work
[00:53:49 CET] <Zeranoe> an3k: --disable-all disables everything. Just build with the default options
[02:53:27 CET] <pyBlob> I'm using this command to combine some rendering data with a sound file, but somehow the sound gets cut into pieces, like someone is spamming play/pause (it's like removing the -r 30 for video settings)
[02:53:29 CET] <pyBlob> http://pastebin.com/RxAePqJu
[03:11:20 CET] <relaxed> pyBlob: use -framerate
[03:11:36 CET] <pyBlob> on input or on output settings?
[03:11:56 CET] <relaxed> before the rawvideo
[03:15:51 CET] <pyBlob> hmm, that didn't help :/
[03:17:04 CET] <pyBlob> interesting ... vlc creates choppy audio, but when using firefox it works nicely =)
[03:18:01 CET] <pyBlob> even when I'm not using -framerate
[04:32:57 CET] <an3k> why o I get "lavf [error]: could not open input file" when using lavf to open a RAW AVC stream? http://pastebin.com/Nda21pJy lavf support is built into x264
[05:54:46 CET] <xintox> why would ffmpeg be in S    interruptible sleep (waiting for an event to complete)
[05:54:50 CET] <xintox> for the state of the pid?
[05:55:46 CET] <xintox> weird
[05:56:02 CET] <xintox> ok, healthy ffmpeg is in S, and one that has stopped producing output is also in S
[06:09:17 CET] <ac_slater> hey all. I'm writing a libavcodec encoder. My encoder only works with YUV420P packed as YUV instead of YYYY UUUU VVVV - they call this "packed planar". Are there ffmpeg functions to convert this? Does ffmpeg know about this color/pixel format?
[06:15:59 CET] <ac_slater> I dont really mean convert as that implies sws_scale
[06:23:41 CET] <ac_slater> I guess A) I dont know what packedplanar 420p means  b) I want an efficient way to write it out as YUV420P unpacked without having to do crazy things
[06:23:47 CET] <ac_slater> might not be possible
[06:41:04 CET] <an3k> AR 1.85:1 is 1920x1040 or 1920x1038 ?
[06:43:10 CET] <an3k> nevermind. 1040 because we still can't crop 1 from top and 1 from bottom ...
[06:52:18 CET] <felixjet> hiya
[06:52:38 CET] <felixjet> can someone please tell me whats wrong with this parameters?
[06:52:39 CET] <felixjet> '-c:a:0', 'aac', '-b:a:0', '64', '-ar:a:0', '48000'
[06:52:54 CET] <felixjet> the last one is not working, -ar
[06:55:54 CET] <an3k> felixjet: is -ar before or after the output parameter?
[06:56:02 CET] <felixjet> nvm, it was a stupid comma the line before
[06:56:06 CET] <felixjet> xD
[06:56:22 CET] <an3k> :)
[06:56:48 CET] <felixjet> im also getting this "Error while decoding stream #0:1: Invalid data found when processing input"
[06:56:53 CET] <felixjet> but it works
[06:56:56 CET] <felixjet> maybe a bad frame?
[06:58:34 CET] <an3k> check the result. x264 for example runs through even when it's not able to read the input. all you get is digital noise (like this snow in analog ages)
[07:01:55 CET] <felixjet> everything looks fine
[07:03:23 CET] <an3k> then I _guess_ it's just a bad frame. others can give you more precise answers. To be honest I don't have much knowledge about ffmpeg but video/audio encoding in general so I can help just a little bit :)
[07:05:08 CET] <felixjet> np, thanks anyway
[07:28:56 CET] <felixjet> damn, i need some help :(
[07:29:33 CET] <felixjet> this is my ffmpeg command https://gist.github.com/felixsanz/82cb6363d7e043b84fe1
[07:29:46 CET] <felixjet> i use it with python but that doesn't matter
[07:30:06 CET] <felixjet> i have "file", which is a video with english audio
[07:30:20 CET] <felixjet> and i also have "01-es.aac", which is just a spanish audio
[07:30:36 CET] <felixjet> i'm trying to mix them all, i'm using copy on everything
[07:30:41 CET] <felixjet> but this doesn't work
[07:30:52 CET] <felixjet> Could not write header for output file #0 (incorrect codec parameters ?): Invalid argument
[07:35:13 CET] <mark4o> felixjet: you did not specify the output format, and there is no filename suffix so it can't even guess what format you want
[07:35:38 CET] <felixjet> sorry, output is a variable
[07:35:42 CET] <felixjet> it points to "final.mkv"
[07:36:15 CET] <mark4o> ok, what is the full output?
[07:36:41 CET] <felixjet> https://gist.github.com/felixsanz/33b88aeea6b09a65b934
[07:37:46 CET] <felixjet> also metadata seems broken in that output
[07:42:50 CET] <felixjet> any idea?
[07:43:06 CET] <mark4o> felixjet: I think you may need -bsf aac_adtstoasc for that .aac file
[07:43:38 CET] <felixjet> i generate that aac from another file
[07:43:41 CET] <felixjet> so i can do that at fly too
[07:44:20 CET] <mark4o> or just use .m4a or .mkv instead of .aac and then you shouldn't need that
[07:46:17 CET] <felixjet> when i use map
[07:46:21 CET] <felixjet> how i do target other inputs?
[07:46:25 CET] <felixjet> for example
[07:46:28 CET] <felixjet> '-map', '0:0', '-map', '0:1', '-map', '1:1',
[07:46:50 CET] <felixjet> this means "use stream 0 and 1 from source 0"
[07:46:57 CET] <felixjet> and "use stream 1 from source 1"
[07:46:58 CET] <felixjet> right?
[07:47:18 CET] <felixjet> but then, if i want to copy 0:1 and re-encode 1:1, how i do it?
[07:47:30 CET] <felixjet> '-c:a:0', 'copy' AND '-c:a:1', 'aac', '-b:a:1', '96k'
[07:47:36 CET] <felixjet> c:a:0 and c:a:1 is the way it works?
[07:47:38 CET] <felixjet> im confused
[07:49:48 CET] <felixjet> i think i got it
[07:49:52 CET] <mark4o> felixjet: -c:a:0 means output stream 0, -c:a:1 means output stream 1
[07:49:55 CET] <felixjet>   Stream #0:0 -> #0:0 (copy)
[07:49:55 CET] <felixjet>   Stream #0:1 -> #0:1 (copy)
[07:49:55 CET] <felixjet>   Stream #1:1 -> #0:2 (mp3 (native) -> aac (native))
[07:50:02 CET] <felixjet> this looks correct
[07:50:11 CET] <felixjet> but metadata is not fine
[07:50:16 CET] <mark4o> the order of the -map options determines the output stream number
[07:51:14 CET] <felixjet> take a look please https://gist.github.com/felixsanz/63b18069600e8b20ba2b
[07:51:24 CET] <felixjet> its a short paste
[07:51:39 CET] <felixjet> i want to set "english" to audio track 1
[07:51:43 CET] <felixjet> and "spanish" to audio track 2
[07:51:48 CET] <felixjet> but it doesnt seems to work right?
[07:52:12 CET] <felixjet> im using: -metadata:s:a:0 language=eng title="English" -metadata:s:a:1 language=spa title="Spanish"
[07:53:00 CET] <mark4o> You need a separate -metadata for each metadata
[07:53:17 CET] <mark4o> so -metadata:s:a:0 language=eng
[07:53:29 CET] <mark4o> then -metadata:s:a:0 title=English
[07:53:35 CET] <felixjet> ahh
[07:54:14 CET] <mark4o> also -metadata:s:a:0 is a separate argument from language=eng
[07:54:34 CET] <felixjet> what does that mean?
[07:54:39 CET] <felixjet> the separate argument thing
[07:55:31 CET] <mark4o> in your https://gist.github.com/felixsanz/82cb6363d7e043b84fe1 you have '-metadata:s:a:0:1 language=eng title="English"' but you need '-metadata:s:a:0', 'language=eng', ...
[07:55:57 CET] <felixjet> language is not part of metadata parameter'
[07:56:09 CET] <felixjet> i mean, language is not an argument of metadata parameter?
[07:56:29 CET] <mark4o> just like '-c:v', 'copy' they go together but they are separate parameters
[07:57:12 CET] <mark4o> just don't put them in the same pair of quotes
[07:57:25 CET] <felixjet> oh, i didn't know that
[07:57:31 CET] <felixjet> im used to the option=value thing
[07:57:38 CET] <felixjet> so metadata and language
[07:57:40 CET] <felixjet> are option option
[07:58:15 CET] <felixjet> '-metadata:s:a:0 title="English"', 'language=eng',
[07:58:15 CET] <felixjet> '-metadata:s:a:1 title="Spanish"', 'language=spa'
[07:58:17 CET] <felixjet> this
[07:58:34 CET] <c_14> no
[07:58:55 CET] <felixjet> U.u
[07:58:56 CET] <c_14> '-metadata:s:a:0', 'title="English"','-metadata:s:a:0', 'language=eng'
[07:59:19 CET] <mark4o> ^yes
[07:59:19 CET] <felixjet> got it
[08:00:02 CET] <felixjet> i think it works, but i can't see "language" in the output
[08:00:09 CET] <felixjet> only the title metadata
[08:01:14 CET] <c_14> The lang isn't usually written like other metadata in the output. Rather it's in () right after the stream identifier
[08:01:32 CET] <c_14> try running ffprobe on the output
[08:02:17 CET] <felixjet> ffmpeg -i file, shows it
[08:04:17 CET] <felixjet> well... i think this was a waste of time :(
[08:05:04 CET] <felixjet> i'm trying to burn a dvd for my gf with this tv show
[08:05:12 CET] <felixjet> but also trying to make it multi language
[08:05:27 CET] <felixjet> adding audio from another source
[08:05:39 CET] <felixjet> audio doesn't sync, which is what i would expect
[08:05:58 CET] <felixjet> but the weird thing is, im playing both videos (english and spanish ones) at the same time
[08:06:02 CET] <felixjet> and even the video doesn't sync
[08:06:04 CET] <felixjet> one goes faster
[08:06:23 CET] <felixjet> is this commonly when translating movies and tv shows?
[08:08:31 CET] <mark4o> if it is a 24fps movie and they are converting to 25fps sometimes they'll just speed it up and keep the frames the same, but if converting to 30fps they will usually do it correctly
[08:13:16 CET] <felixjet> source video is 23.98 fps
[08:13:33 CET] <felixjet> and the video from the audio i want to add, is rated at 25 fps
[08:14:49 CET] <felixjet> what steps should i take? (in english, no need code yet, ill do my tests)
[08:16:10 CET] <mark4o> either speed up the video with the fps filter, or slow down the audio with atempo or rubberband filter
[08:16:26 CET] <felixjet> but if i speed up the video, what will happen with its original english audio?
[08:16:33 CET] <felixjet> i will fix the spanish one but broke the other
[08:16:39 CET] <waressearcher2> felixjet: -af atempo=0.95
[08:16:57 CET] <c_14> mark4o: the fps filter won't speed up the video
[08:17:25 CET] <waressearcher2> 1/(25/23.98) = 0.9592
[08:17:35 CET] <waressearcher2> -af atempo=0.9592
[08:17:42 CET] <felixjet> im going to try it
[08:17:54 CET] <felixjet> -af:a:1 should work too right?
[08:18:00 CET] <mark4o> oh right, well I think changing the audio is better anyway
[08:18:37 CET] <c_14> felixjet: -filter_complex '[1:a]atempo=0.9592[a]' (assuming the audio is in the second input file)
[08:18:48 CET] <c_14> And then you'll have to -map '[a]' instead of -map 1:a
[08:21:46 CET] <felixjet> this? https://gist.github.com/felixsanz/98777dd632cd61ba7c22
[08:21:54 CET] <felixjet> :/
[08:22:14 CET] <felixjet> i've read the ffmpeg doc for filter complex but i didn't understand anything at all
[08:23:06 CET] <c_14> don't change the -c -b and -ar, those should all still be -c:a:1 etc
[08:35:43 CET] <felixjet> c_14, but you said "And then you'll have to -map '[a]' instead of -map 1:a"
[08:36:02 CET] <felixjet> i dont "-map 1:a", i do "-map 1:1"
[08:36:10 CET] <felixjet> its the same?
[08:37:12 CET] <c_14> assuming the file only has 1 audio stream and that stream is 1:1, yes
[08:37:24 CET] <c_14> You can use 1:1 instead of 1:a if you want to be sure
[08:38:00 CET] <felixjet> but  why [a] ?
[08:38:04 CET] <felixjet> i don't understand this
[08:38:11 CET] <felixjet> [1:a]atempo=0.9592[a]
[08:38:17 CET] <felixjet> whats [1:a] and [a] ?
[08:39:01 CET] <mark4o> [a] is just a name for your slowed-down audio, you could name it [fred] if you prefer
[08:39:56 CET] <felixjet> Filter atempo has a unconnected output
[08:40:06 CET] <felixjet> i don't know what im doing wrong
[08:40:26 CET] <mark4o> if you called it [a] then make sure you have -map '[a]'
[08:40:43 CET] <felixjet> but if i use -map [a]
[08:40:54 CET] <felixjet> how its going to know what source and file is?
[08:41:06 CET] <felixjet> using 1:1 im specifing i want file 1 source 1
[08:41:10 CET] <felixjet> map [a] makes no sense
[08:41:48 CET] <c_14> [a] is just a name
[08:42:01 CET] <c_14> you created this name by having [a] as an output pad at the end of the filter_complex
[08:42:14 CET] <c_14> you could name it [output_pad_audio_sped_up] if you really wanted to
[08:42:23 CET] <felixjet> oh, so [input]atempo..[output]
[08:42:25 CET] <felixjet> thats how it works?
[08:42:36 CET] <felixjet> and i have to use it BEFORE the maps, right?
[08:42:41 CET] <mark4o> -filter_complex '[1:a]atempo=0.9592[a]' means take input 1 audio and filter it through atempo and call the output [a].  -map '[a]' means you want it in your output file
[08:42:44 CET] <c_14> ye
[08:42:47 CET] <felixjet> i was using filter complex after maps
[08:42:56 CET] <felixjet> just like if it was an option to the audio
[08:43:17 CET] <felixjet> and also 1:a means first audio from file 1, lol
[08:43:25 CET] <felixjet> i was thinking it was related to [a]
[08:43:31 CET] <felixjet> u__u
[08:44:04 CET] <c_14> afaik 1:a actually means all audio streams from file 1
[08:44:21 CET] <felixjet>         '-filter_complex', '[1:1]atempo=0.9592[slowed_audio]',
[08:44:21 CET] <felixjet>         '-map', '0:0', '-map', '0:1', '-map', '[slowed_audio]',
[08:44:30 CET] <felixjet> now i got it
[08:45:05 CET] <mark4o> I think you want [1:a] or [1:0] though, not [1:1]
[08:45:14 CET] <felixjet> 1:0 is the video
[08:45:25 CET] <mark4o> oh ok then [1:a] or [1:1] is fine
[08:45:25 CET] <felixjet> 1:1 is the first audio (and only one, so i could use 1:a too)
[08:45:44 CET] <felixjet> but 1:1 looks more explicit
[08:48:05 CET] <felixjet> looks fine but after some time audio is not synced anymore
[08:48:19 CET] <felixjet> and i've used 0.9592, which is exact
[08:48:22 CET] <felixjet> :(
[08:55:56 CET] <felixjet> one video is lenghty than other, m e
[08:55:57 CET] <felixjet> meh
[08:56:45 CET] <waressearcher2> felixjet: 0.94 ? 0.97 ?
[08:57:20 CET] <felixjet> what do you mean?
[08:57:38 CET] <felixjet> im using 0.9592
[08:59:58 CET] <mark4o> If the content is identical except for the speed, divide the length of the shorter one by the length of the longer one to get the number to use.  If one has some extra scene, though, I guess you'll need to get out your mic and record your own audio for that :P
[09:00:40 CET] <felixjet> ahha
[09:01:11 CET] <felixjet> i think one video has some miliseconds more at the start of video
[09:01:23 CET] <felixjet> so ill try to -ss one
[09:01:30 CET] <felixjet> and skip it
[09:02:01 CET] <felixjet> what a headache
[09:02:05 CET] <felixjet> and the tv show is shit anyway
[09:02:06 CET] <felixjet> xD
[09:05:58 CET] <zap0> have all those 'security' issues been fixed?
[09:09:48 CET] <mark4o> zap0: the hls issue is fixed and 2.8.5 has been released with the fix
[09:11:15 CET] <zap0> thanks.
[09:15:05 CET] <felixjet> thanks for the help guys
[09:15:15 CET] <felixjet> im sure it will help in the future
[09:15:37 CET] <felixjet> but for now i think i'm gonna burn a single audio, since i can't mix them propertly
[09:15:40 CET] <felixjet> one goes de-sync
[09:27:51 CET] <an3k> merging 48000 Hz audio and a 44100 Hz audio into a 44100 Hz video?
[09:30:55 CET] <an3k> mark4o: When I started plenty years ago with AviSynth I was looking for a tool like diff but for audio/video. Would have helped alot.
[09:35:23 CET] <an3k> take an audio stream with 48000 Hz from a 29,976 fps video with 23:45 length and (try to) mux it into a 25 fps video with 26:02 length (=23:13 length at 29,976 fps) ... I prefer hitting myself with a woodstick hundred times :)
[09:37:51 CET] <mark4o> I think both of his audio streams are 48kHz, one from 23.98 fps video and one from 25 fps video.  Probably better to just keep the audio with the video where it came from.
[09:41:13 CET] <an3k> if that is the only issue felixjet could change that easily, speed-up with pitch-correction
[09:41:53 CET] <felixjet> i converted one audio from 44100 to 4800
[09:41:55 CET] <felixjet> 48000
[09:42:07 CET] <felixjet> one video has 44.1 audio and the other has 48
[09:42:36 CET] <an3k> whats the framerate of both videos?
[09:42:44 CET] <felixjet> 44.1 audio has 25 fps
[09:42:56 CET] <felixjet> and 48 audio has 23.9
[09:43:08 CET] <an3k> thats the issue :)
[09:43:09 CET] <felixjet> 23.98*
[09:43:25 CET] <felixjet> but im converting 44.1 to 48 also
[09:43:31 CET] <an3k> doesn't matter
[09:44:20 CET] <an3k> you can do both at the same time or do one first then the other afterwards
[09:45:51 CET] <felixjet> do what?
[09:46:44 CET] <an3k> do you have avisynth available?
[09:47:55 CET] <an3k> SSRC(48000).TimeStretch(tempo=(96.0/1.001)) will resample to 48000 and slow-down 25 to 23,976 fps with pitch correction
[09:48:52 CET] <felixjet> avxsynth
[09:50:15 CET] <an3k> that should work too. TimeStretch should be a very basic function. If SSRC is not available you can resample 44100 to 48000 with ffmpeg and then use the new file in avxsynth and just to TimeStretch
[09:51:08 CET] <felixjet> mm
[09:52:16 CET] <an3k> Just checked, avxsynth doesn't have TimeStretch https://github.com/avxsynth/avxsynth/wiki/Built-in-Functions
[09:54:03 CET] <an3k> but this one got TimeStretch http://forum.doom9.org/showthread.php?p=1643924
[09:56:16 CET] <an3k> felixjet: Do you just have ONE audio file you have to convert?
[09:56:32 CET] <mark4o> felixjet: I think he already figured out the time stretching and resampling in ffmpeg, but it still doesn't match up, maybe the two videos are not identical, some deleted scenes or something
[09:56:40 CET] <mark4o> an3k: ^
[09:57:02 CET] <felixjet> the videos doesn't have the same lenght
[09:57:15 CET] <felixjet> but its weird because i can't manage to see the difference
[09:57:41 CET] <felixjet> at the end, they are just off-sync for 2-3 seconds
[09:57:49 CET] <felixjet> which affects pretty bad to audio
[09:57:58 CET] <an3k> felixjet: So you have converted both videos to the same fps?
[10:00:12 CET] <an3k> if there is actually no difference but just at the end (credits or other "unnecessary" stuff) you could trim the longer video to the very same length of the shorter one, both audio & video at the same time so you end up with an audio stream of the correct length ;)
[10:05:26 CET] <felixjet> no, around 70% of video, the voices doesn't match the video
[10:05:32 CET] <felixjet> and both converted to 23.96
[10:05:53 CET] <felixjet> is not like the end of video i hear voices with no video
[10:05:58 CET] <felixjet> that wouldn't be a problem
[10:06:10 CET] <felixjet> the problem is the video not synced with audio around middle to the end
[10:06:20 CET] <felixjet> at start i can't find any error
[10:07:11 CET] <an3k> Oh, yeah, I know this problem.
[10:07:41 CET] <an3k> You think everything is ok because it's not async but suddenly is gets async very much like out of nowhere
[10:08:12 CET] <an3k> Actually I never solved this problem but just deleted the files.
[10:09:09 CET] <felixjet> lame tv show
[10:09:17 CET] <an3k> What you could do is to Trim the video+audio. clip1 is from the very beginning until shortly before audio gets async.
[10:09:20 CET] <felixjet> even the DVD doesn't have any other language of subtitles
[10:09:22 CET] <felixjet> xd
[10:09:43 CET] <an3k> clip2 would start where clip1 ended and would to till the end. Then maybe you have everything in sync
[10:10:10 CET] <felixjet> yea, not funny when you have 50 chapters
[10:10:11 CET] <felixjet> haah
[10:11:17 CET] <an3k> may I ask what TV Show you want to "backup"? :)
[10:11:30 CET] <felixjet> the beauty and the beast
[10:11:53 CET] <felixjet> last seasons are not even edited on dvd
[10:12:07 CET] <felixjet> so... you can just download the with torrent, or move on
[10:12:16 CET] <felixjet> the "backup" thing would solve easier going to the store
[10:12:20 CET] <felixjet> but its not for sale xD
[10:12:46 CET] <an3k> ok, well, I don't think that this show exists on Blu-ray or online as another source.
[10:12:54 CET] <felixjet> it doesn't
[10:12:57 CET] <felixjet> its a tv rip
[10:13:06 CET] <felixjet> at least in spain
[10:13:18 CET] <felixjet> but my gf is learning english
[10:13:28 CET] <felixjet> and i wanted to include the english audio and make a dvd with the show
[10:13:38 CET] <felixjet> i think she will have to watch it in spanish instead
[10:13:50 CET] <an3k> I never created a backup of The X-Files because of exactly these problems but since they released them as Blu-rays end of last year I even bought the whole Box :)
[10:14:15 CET] <felixjet> the only season that is for sale is the first
[10:14:20 CET] <felixjet> and it doesnt include english anyway
[10:14:44 CET] <an3k> yeah, nearly the same as for Criminial Intent. They want us to buy their stuff but they don't sell it ...
[10:15:10 CET] <felixjet> yea
[10:15:43 CET] <an3k> if you want you can upload both videos and I'll take a look the next days once I have some time
[10:16:02 CET] <an3k> Maybe the solution is very easy. Maybe it's an impossible task.
[10:16:04 CET] <felixjet> i also like to watch series in original version, but the ones that you can buy here doesn't usually include english
[10:16:16 CET] <felixjet> so... i go torrent and they cry in the media about piracy
[10:16:47 CET] <felixjet> (the spanish version of the mpaa)
[10:17:03 CET] <felixjet> nah, its ok man, thanks anyway
[10:17:11 CET] <felixjet> every season have a different source
[10:17:30 CET] <felixjet> and i think, if i ever fix the first season, it will not work for the second
[10:17:33 CET] <felixjet> and so on
[10:17:38 CET] <an3k> well, if you fixed one episode you can apply it onto the others too :)
[10:18:27 CET] <felixjet> ill burn the spanish version, since its a gift
[10:18:34 CET] <felixjet> and then ill ask her if she wants the english one
[10:18:38 CET] <felixjet> and thats all haha
[10:18:50 CET] <felixjet> i just wanted to make a dvd with both languages so she can choose
[10:18:56 CET] <felixjet> but no point in wasting so much time
[10:19:21 CET] <an3k> I'm currently building VapourSynth on Linux so I can backup all 10 seasons of Stargate SG-1. I'm doing a (cheap) Upscaling to 720p and the server is much faster than my PC which does the reencode with 5 fps ...
[10:19:27 CET] <felixjet> it will even easier to burn 2 dvd on spanish and 2 dvd on english
[10:19:33 CET] <felixjet> and don't waste so many hours xD
[10:19:40 CET] <an3k> true :)
[10:20:22 CET] <felixjet> stargate sg-1 should be on blu ray
[10:20:24 CET] <an3k> maybe put the spanish subtitles onto the english dvds :)
[10:20:26 CET] <felixjet> its a great show
[10:20:30 CET] <an3k> opensubtitles.org may have them
[10:20:41 CET] <felixjet> yea, off-sync probably! hah
[10:21:19 CET] <an3k> yeah, definitely. I have all silver DVD boxes here, still sealed :) and even when they weren't sealed anymore I would have downloaded them. I'm not gonna kill my DVD drive :D
[10:21:49 CET] <felixjet> or the discs :P
[10:22:22 CET] <an3k> ~50 discs
[10:22:30 CET] <an3k> ~434 GB
[10:23:35 CET] <an3k> the good thing is that even episode 1 is in 16:9 with just a little bit overscan
[10:24:29 CET] <an3k> easy to recode. Only problem is upscaling to 720p. QTGMC takes soooo damn long on my PC. That's why I'm moving onto my Linux server for that. New Xeon with plenty of power :)
[10:24:41 CET] <felixjet> lmao xD
[10:27:17 CET] <Fjorgynn> :D
[15:25:40 CET] <cousin_luigi> Greetings.
[15:26:49 CET] <waressearcher2> cousin_luigi: hallo wie geht's es dir ?
[15:27:21 CET] <cousin_luigi> ganz gut, danke
[15:28:41 CET] <cousin_luigi> Haben wir uns getroffen?
[15:32:14 CET] <waressearcher2> ich weiß nicht
[15:33:20 CET] <cousin_luigi> I have black bands on every side of my clip: how do I remove them?
[15:34:19 CET] <durandal_170> cropdetect + crop
[15:36:59 CET] <cousin_luigi> k thanks
[15:37:58 CET] <cousin_luigi> hmm, I must be doing something wrong. Only the top band was cut
[15:58:21 CET] <durandal_170> cousin_luigi: isn't there mpv script for it
[16:01:35 CET] <cousin_luigi> durandal_170: I want to reencode it, not just watch it.
[16:02:45 CET] <durandal_170> mpv can encode
[16:52:09 CET] <shadow42085> i am trying to cross compile ffmpeg for my windows machine i know there are pre-compiled bins floating around the net but i got most of the issues worked out the compiler cannot find libbass
[16:52:15 CET] <shadow42085> libass**
[16:53:10 CET] <shadow42085> its mainly when i issue the ./configure
[18:29:07 CET] <cousin_luigi> bbl
[18:55:12 CET] <an3k> ffmpeg builds h264 support into libav* only if you build ffmpeg with --enable-libx264? Is that correct?
[19:04:29 CET] <kepstin> an3k: ffmpeg has a builtin h264 decoder, you only need x264 if you want an encoder.
[19:12:06 CET] <an3k> well, I want x264 (binary) with lavf support and h264 support in libav is probably only available when ffmpeg is built with --enable-libx264
[19:12:25 CET] <an3k> I just want to be sure that I must have --enable-libx264 enabled
[19:14:42 CET] <c_14> no
[19:14:59 CET] <c_14> You do not need to build ffmpeg with --enable-libx264 to build x264 with lavf support
[19:15:14 CET] <c_14> The options are not related.
[19:15:28 CET] <an3k> well, that is true but then I can't open a H264 raw file with lavf in x264
[19:15:41 CET] <c_14> No, you can.
[19:15:50 CET] <an3k> Well, I always got "lavf [error]: could not open input file"
[19:15:52 CET] <c_14> --enable-libx264 only affects use of the libx264 _encoder_ from ffmpeg
[19:16:20 CET] <c_14> Can you open said file with ffmpeg? (using ffprobe or ffmpeg -i file -f null /dev/null)
[19:16:24 CET] <c_14> The file might just be broken
[19:16:42 CET] <c_14> What do you mean with raw H264 file? .h264 ?
[19:16:52 CET] <an3k> yes, file.264
[19:17:23 CET] <an3k> and the file is not broken. All I changed was how ffmpeg/x264 was built and after I re-enabled --enable-libx264 again I was able to open the very same file
[19:18:02 CET] <c_14> What command are you using?
[19:18:16 CET] <an3k> to build or to load the file into x264?
[19:18:22 CET] <c_14> to load
[19:19:06 CET] <an3k> x264 --level 4.0 --crf 22 --deblock -3:-3 --keyint 240 --ref 4 --chroma-qp-offset -2 --vbv-bufsize 31250 --vbv-maxrate 25000 --me umh -o /var/tmp/foobar_recode.264 /var/tmp/foobar.264
[19:20:25 CET] <c_14> Regardless, x264 should not need lavf support to decode raw h264
[19:21:03 CET] <an3k> I know but with lavf I have to specify too much details of the file, eg. input resolution, etc.
[19:21:14 CET] <c_14> You mean without?
[19:21:16 CET] <an3k> s/with/without/
[19:21:32 CET] <c_14> How did you build ffmpeg? (when it doesn't work?)
[19:22:32 CET] <an3k> ./configure --prefix="$HOME" --extra-cflags="-I$HOME/include" --extra-ldflags="-L$HOME/lib" --enable-gpl --disable-static --enable-shared --enable-avresample
[19:22:32 CET] <c_14> So that I can try reproducing
[19:24:05 CET] <an3k> or ./configure --prefix="$HOME" --extra-cflags="-I$HOME/include" --extra-ldflags="-L$HOME/lib" --enable-gpl --enable-nonfree --disable-static --enable-shared --disable-programs --disable-doc --disable-avdevice --disable-swresample --disable-postproc --disable-avfilter --enable-avresample --disable-pthreads --disable-w32threads --disable-os2threads --disable-network --disable-dct --disable-dwt
[19:24:05 CET] <an3k> --disable-error-resilience --disable-lsp --disable-lzo --disable-mdct --disable-rdft --disable-fft --disable-faan --disable-pixelutils --disable-everything
[19:24:46 CET] <c_14> ah
[19:24:47 CET] <an3k> and also without --enable-nonfree because I thought "not redistributable" may have cause the issue
[19:24:51 CET] <c_14> >--disable-everything
[19:24:59 CET] <c_14> That will disable the h264 parser and decoder
[19:25:18 CET] <c_14> You'll have to explicitly enable those
[19:27:26 CET] <an3k> Oh, good to know that works. Thanks! I didn't tried that because with --disable-all other --enable arguments are completely ignored
[19:28:55 CET] <lunchbox> I'm trying to open a device using ffplay but I'm not getting any sound  what's the parameter?
[19:29:00 CET] <an3k> I wish there were a --disable-all-but-libav argument ;)
[19:31:21 CET] <c_14> lunchbox: device as in something like v4l2?
[19:31:45 CET] <lunchbox> device as in usb capture
[19:31:57 CET] <lunchbox> gv-usb2 to be specific
[19:32:56 CET] <c_14> linux?
[19:33:33 CET] <lunchbox> nope windows
[19:34:05 CET] <c_14> What's your current command?
[19:34:19 CET] <lunchbox> ffplay -f dshow -i video="GV-USB2, Analog Capture" -vf "yadif=0:0:0, crop=644:448:36:16, unsharp=5:5:1.0:5:5:0.0"
[19:35:52 CET] <lunchbox> also is there a way to deinterlace without motion looking smudgey (if that makes sense)
[19:36:51 CET] <Mavrik> I'm pretty sure the unsharp filter, not yadif is causing the ghosting.
[19:37:10 CET] <c_14> You could try mcdeint. That's motion compensated deinterlacing. That might be it too, though.
[19:37:42 CET] <c_14> lunchbox: try adding -f dshow -i audio="GV-USB2, Analog Capture"
[19:37:57 CET] <Mavrik> it's -i video="device":audio="device" IIRC
[19:38:08 CET] <c_14> ah, right
[19:38:11 CET] <c_14> That should work too
[19:38:12 CET] <Mavrik> been awhile tho
[19:38:36 CET] <lunchbox> said it was already specified
[19:38:43 CET] <lunchbox> oh wait let me try that
[19:39:19 CET] <iive> there is "field" filter that can extract a single field.
[19:39:28 CET] <iive> see if you have ghosting with it....
[19:39:57 CET] <iive> if you have... the it is probably artifact from encoding interlaced content with progressive method
[19:39:59 CET] <lunchbox> ok that worked for the audio although it did say initially that it couldn't find it at first
[19:40:37 CET] <lunchbox> what's the equivalent of ComplementParity.SeparateFields from avisynth?
[19:40:42 CET] <lunchbox> that's what I originally used
[19:43:01 CET] <c_14> the separatefields filter
[19:43:22 CET] <c_14> If it gets the order wrong you have to use the setfield filter before it
[19:48:16 CET] <lunchbox> it worked  is there a better way of doing this? I forgot this squashes the video
[19:48:29 CET] <lunchbox> I used point resize in avisynth for this
[19:48:55 CET] <c_14> you could scale
[19:49:14 CET] <lunchbox> definitely want to use an unsharp mask to filter the video so my solution needs to work with that
[19:49:58 CET] <iive> lunchbox: you know that you have to deinterlace first, then resize
[19:51:01 CET] <lunchbox> should I use yadif?
[19:52:15 CET] <iive> lunchbox: i'm just telling you that if you resize with progressive filter, then the wrong field would bleed into the image...
[19:52:36 CET] <c_14> You can try adding a scale filter after it. Or try using one of the 10 other deinterlacing filters in ffmpeg
[20:04:33 CET] <FlorianBd> Hi there :)
[20:06:01 CET] <FlorianBd> I am experimenting with showfreqs and there are a few issues I don't understand.  the most important of them is how to limit the fps so I don't end up with 5500 fps...   the filter fps seems to be incompatible with showfreqs
[20:12:44 CET] <lunchbox> ffplay -f dshow -i video="GV-USB2, Analog Capture":audio="GV-USB2, Analog Capture" -vf "separatefields, scale=720:480:flags=neighbor, crop=640:448:42:16, scale=480:360:flags=lanczos"
[20:13:04 CET] <lunchbox> is it a hit to the performance if I resize multiple times here?
[20:14:59 CET] <c_14> depends on what the blocker is on your system, but it will use more cpu yes
[20:19:05 CET] <lunchbox> what's the best filter for downscaling to a resolution that isn't the original aspect ratio?
[20:19:53 CET] <pzich> as in stretching or cropping?
[20:20:02 CET] <lunchbox> yes
[20:20:35 CET] <pzich> which?
[20:20:44 CET] <lunchbox> stretching
[20:20:59 CET] <pzich> scale=width:height?
[20:21:07 CET] <lunchbox> I'm resizing from 640x448 to 480x360
[20:22:29 CET] <lunchbox> I think the default is bilinear
[20:22:37 CET] <lunchbox> I tried lanczos
[20:23:53 CET] <pzich> not sure which is best, but this answer looks pretty detailed: http://superuser.com/a/375726
[20:25:38 CET] <lunchbox> this is great thanks
[20:56:44 CET] <durandal_170> FlorianBd: using what params?
[21:02:14 CET] <FlorianBd> durandal_170: anything in general.. but forget it I ended up capturing Audacity spectrum instead, it much more the look I was looking for. Thanks though!
[21:20:47 CET] <durandal_170> FlorianBd: audacity only displays spectrum of single window afaik
[21:23:21 CET] <FlorianBd> durandal_170: what I do is that I play it and capture real time
[21:35:28 CET] <durandal_170> FlorianBd: how I can play it?
[21:39:54 CET] <FlorianBd> durandal_170: this is just an extension in audacity
[21:40:28 CET] <durandal_170> name?
[21:57:29 CET] <FlorianBd> durandal_170: it's just the basic visualization that comes with the player
[23:14:27 CET] <kimiko_0> allo?
[23:20:28 CET] <kimiko_0> anyone here?
[23:24:11 CET] <Betablocker> here is the party zone
[00:00:00 CET] --- Sun Jan 17 2016

More information about the Ffmpeg-devel-irc mailing list