[Ffmpeg-devel-irc] ffmpeg.log.20160118

burek burek021 at gmail.com
Tue Jan 19 02:05:01 CET 2016

[00:42:36 CET] <thebombzen> I have a question: I have an mjpeg stream (i.e. a sequence of jpeg frames) and I want to drop every third frame from the image2pipe without reencoding. doing -c copy -r 10 causes FFmpeg to ignore -r 10. What do I do?
[00:45:44 CET] <thebombzen> This should be possible, given that it's a sequence of frames without any inter-coding at all
[00:48:44 CET] <c_14> It's technically possible, but you'd probably have to write a bitstream filter for it. That or use the mjpeg2jpeg bsf, output to individual jpg frames (with -c:v copy) delete every third file and use ffmpeg with -c:v copy to mux them back into mjpeg
[04:58:48 CET] <thebombzen> c_14: I think I'll add a "wish" ticket on Trac for a bitstream filter to allow dropping video frames with -codec copy for inter-only codecs like mjpeg or png.
[04:59:01 CET] <thebombzen> I don't actually know how to write a bitstream filter like that one
[06:10:42 CET] <sling_> Hi
[06:10:51 CET] <sling_> I am facing a problem with ffmpeg concvat
[06:10:54 CET] <sling_> concat
[06:10:59 CET] <sling_> can anybody help me
[06:11:15 CET] <sling_>  /root/bin/./ffmpeg -i "concat:/home/slinguser/commands/highlight270.ts|/home/slinguser/commands/highlight271.ts|/home/slinguser/commands/highlight272.ts"  -c  copy -bsf:a aac_adtstoasc highlight27.mp4
[06:11:41 CET] <sling_> when i run above command it says "concat:/home/slinguser/commands/highlight270.ts|/home/slinguser/commands/highlight271.ts|/home/slinguser/commands/highlight272.ts": No such file or directory
[06:11:54 CET] <sling_> i am running through a java program
[06:12:53 CET] <sling_> if  i run the same command in the command prompt it works well
[07:00:21 CET] <sling_> HI
[07:00:29 CET] <sling_> can anyone help me?
[07:02:24 CET] <sling_> is this channel is junk? no one responds?
[07:02:48 CET] <waressearcher2> sling_: hallo, wie geht es dir ?
[07:03:08 CET] <sling_> hi
[07:03:19 CET] <sling_> i am facing some problem related to concat command
[07:03:45 CET] <sling_> i run concat with  /root/bin/./ffmpeg -f mpegts -i "concat:highlight270|highlight271"  -c  copy -bsf:a aac_adtstoasc highlight27.mp4
[07:03:49 CET] <sling_> and i get error
[07:04:09 CET] <waressearcher2> so süß
[07:04:13 CET] <sling_> "concat:highlight270|highlight271|highlight272": No such file or directory
[07:04:19 CET] <sling_> but they do exists
[07:04:48 CET] <sling_> @waressearcher2  can you pls reply in english
[07:05:29 CET] <waressearcher2> Äh, 'tschuldige
[07:05:31 CET] <sling_> when i do run the same command in command prompt its able to concat
[07:20:10 CET] <thebombzen> sling_: can you pastebin the full output
[07:20:54 CET] <thebombzen> also concat:highlight270|highlight271|highlight272" doesn't have the .ts extension
[07:20:57 CET] <thebombzen> maybe it's just a typo
[07:21:35 CET] <thebombzen> honestly, the concat protocol is hard to use. I'd recommend using the concat demuxer instead.
[07:24:41 CET] <Kirito> Does ffmpeg/x264 currently really offer anything in regards to GPU accelerated encoding? I know there have been potential benefits with OpenCL for lookahead operations, but I've seen mixed comments on how much of an impact it really makes.
[07:28:03 CET] <kepstin> Kirito: at the moment, the x264 devs seem to discourage use of the opencl code; it may or may not be faster than cpu, depending on hardware, and probably causes a quality drop.
[07:31:18 CET] <Kirito> I've seen mixed things on that as well, I've been told when just used for lookahead operations it shouldn't make much of a difference, but there's a lot of general mixed information. I'd trust the devs advice over anything else though. I'm curious why it's currently dischouraged though, just for the sake of knowing
[07:31:37 CET] <kepstin> also note that the "hardware encoding" on intel/amd/nvidia is actually dedicated hardware encoder blocks - they don't use gpu compute, and can't be used to accelerate a software encoder.
[07:43:18 CET] <sling_> hi initially i had given .ts extn
[07:43:26 CET] <sling_> later i removed to use pipes
[07:43:39 CET] <sling_> even in the .ts case also same error i used to get
[07:50:53 CET] <sling_> ffmpeg version N-77725-g369b161 Copyright (c) 2000-2016 the FFmpeg developers   built with gcc 4.8.5 (GCC) 20150623 (Red Hat 4.8.5-4)   configuration: --prefix=/root/ffmpeg_build --extra-cflags=-I/root/ffmpeg_build/include --extra-ldflags=-L/root/ffmpeg_build/lib --bindir=/root/bin --pkg-config-flags=--static --enable-gpl --enable-nonfree --enable-libfdk-aac --enable-libx264 --enable-libx265   libavutil      55. 12.100 / 55. 12.100   
[07:51:06 CET] <sling_> file './highlight270.ts' file './highlight271.ts' file './highlight272.ts'
[07:51:26 CET] <sling_> [NULL @ 0x227c920] Requested output format '' is not a suitable output format concat: Invalid argument
[07:54:03 CET] <sling_> can you help
[07:54:19 CET] <sling_> some other error if am going to use demuxer
[07:54:57 CET] <sling_>   /root/bin/./ffmpeg -f  concat -i mylist.txt -c  copy -bsf:a aac_adtstoasc highlight27.mp4
[08:00:55 CET] <xintox> would it be possible to recognize a clip in a video and replace it with a different clip and produce 1 video containing the new clip?
[08:10:07 CET] <Betablocker> recognize like image recognize eg. if a car red car drives bye  - or recognize like check the name in a list of clips and regocnize the name of a clip ?
[08:11:15 CET] <Betablocker> both things are possibel&.. for first thing checkout "open cv" for lost thing check out a script in your fav software language &. should be a few lines in ruby or maybe python
[08:11:22 CET] <Betablocker> lost = last
[08:34:07 CET] <xintox> Betablocker: basically i want to recognize the commercial break in a live stream
[08:34:18 CET] <xintox> its basically a giant logo with some moving background.
[08:44:12 CET] <Betablocker> check out open cv
[08:44:52 CET] <Betablocker> https://github.com/Itseez/opencv
[08:45:02 CET] <Betablocker> dont know it its possible with ffmpeg &.
[08:45:11 CET] <Betablocker> +if
[08:46:00 CET] <Betablocker> opencv is a beast - good luck !
[09:38:08 CET] <digidog> any advice how to prevent deinterlacing when reparing headers by doing -c copy of old dv avi files? it seems they are deinterlaced afterwards without asking  :/
[09:38:28 CET] <Mavrik> hrmf, that makes no sense.
[09:38:40 CET] <Mavrik> You can't make deinterlaced video from interlaced one without reencoding. :/
[09:39:00 CET] <digidog> Mavrik: thats what I thought.
[09:39:11 CET] <Mavrik> It might be just that some flag gets mucked up
[09:39:45 CET] <digidog> Mavrik: hm, you mean it isn't deinterlaced but pretends to be ?
[09:39:50 CET] <Mavrik> yep
[09:40:04 CET] Action: digidog scratches head
[09:41:01 CET] <digidog> Mavrik: thanks for your fast reply. Do you know how I can try to keep the interlaced flag intact ?
[09:41:28 CET] <Mavrik> No idea, been awhile since I've even seen AVI in the wild.
[09:41:44 CET] <Mavrik> Which video format is in it?
[09:41:50 CET] <digidog> Mavrik: heh. yeah quite old archive stuff here
[09:42:47 CET] <digidog> Mavrik: its from old  DV cassettes (dvcp) PAL 576i 4:2:0
[09:43:05 CET] <digidog> but anamorph 16:9
[09:43:25 CET] <Mavrik> Ah, can you ffprobe the input and the output?
[09:43:30 CET] <Mavrik> and pastebin it?
[09:43:53 CET] <digidog> Mavrik: sure! mom ...
[09:50:42 CET] <digidog> Mavrik: http://pastebin.com/bC8QM5UT
[09:52:43 CET] <digidog> Mavrik: first part is the archive file as is, second is the -c copy one with -flags global_header set to repair the header since NLEs won't import it without this repair
[09:53:41 CET] <digidog> Mavrik: the strange thing is, the first is 7.6 GB the second is 8.1 GB. thats why I thought it must have been really deinterlaced ...
[10:04:12 CET] <Fiacha> Hi, i am trying to dump (copy) a stream to a file using ffmpeg. It works great on windows with the zero build but on my raspberry pi (rasperian) i get the error "Could not write header for output file #0 (incorrect codec parameters ?)" and see on the stream mapping that for the h264 input it tries to map to libx264 as output... does that work for copying data?
[10:05:04 CET] <relaxed> Fiacha: pastebin.com the command and console output
[10:07:59 CET] <Fiacha> relaxed: http://pastebin.com/qr5PPxmp
[10:09:42 CET] <c_14> That's an ancient ffmpeg binary provided by libav and not actually ffmpeg from FFmpeg. Either use ffmpeg from FFmpeg or ask in #libav
[10:12:22 CET] <Fiacha> c_14: ah, thanks, i noticed now too. Is there a package that i can use to raspi? (debian/arm)
[10:13:00 CET] <Fiacha> i guess i can try to compile it
[10:13:22 CET] <c_14> You can try debian backports
[10:24:40 CET] <Fiacha> c_14: ok, thank you!
[10:24:43 CET] <relaxed> Fiacha: check http://johnvansickle.com/ffmpeg/ sometime this week and I'll add a raspberry pi build
[10:25:13 CET] <Fiacha> relaxed: wow, cool, thank you!
[10:28:19 CET] <digidog> Mavrik: was this pasty ayn helpful ?
[10:28:57 CET] <digidog> *any
[11:04:12 CET] <Mavrik> digidog, sorry, had to run out for a bit :)
[11:04:27 CET] <Mavrik> And the paste expired :(
[11:13:10 CET] <digidog> Mavrik: oh shit
[11:13:39 CET] <digidog> Mavrik: hah, god thanks I still has this tab open
[11:15:11 CET] <digidog> Mavrik: http://pastebin.com/Du7PjM3A
[11:15:38 CET] <Mavrik> hmm
[11:16:03 CET] <Mavrik> Annoying part is that I can't find a good way to set interlaced in container without reencoding.
[11:17:28 CET] <digidog> Mavrik: yeah, exactly what I was trying too
[11:18:29 CET] <digidog> Mavrik: the strange thing is, the first is 7.6 GB the second is 8.1 GB. thats why I thought it must have been really deinterlaced ... can a header flag change its size so much ?
[11:18:37 CET] <Mavrik> Nop
[11:18:46 CET] <Mavrik> No idea what ffmpeg did that there... what was your command to remux?
[11:19:12 CET] <digidog> Mavrik: ffmpeg -i 2007-03-22_14-28_09.avi -c copy -flags global_header 2007-03-22_14-28_09_header_flag.avi
[11:19:20 CET] <Mavrik> hrmf.
[11:19:29 CET] <Mavrik> I'd say that's practically bug report material.
[11:19:43 CET] <digidog> Mavrik: the output was confirming that it would only copy both streams audio/video
[11:20:09 CET] <digidog> Mavrik: yes, I am afraid it is ...
[11:23:00 CET] <digidog> Mavrik: when I compare the output of bith files I see a difference: one is dvsd, the other is dvvideo, hwo can that happen ?
[11:23:42 CET] <digidog> Mavrik: maybe I should try again with: ffmpeg -i 2007-03-22_14-28_09.avi -c:a copy -c:v copy -flags global_header 2007-03-22_14-28_09_header_flag.avi
[11:24:16 CET] <Mavrik> It's entirely possible that ffmpeg does something dumb, but I don't know all that much about DV video format.
[11:25:26 CET] <digidog> Mavrik: test runs ...
[11:30:52 CET] <digidog> Mavrik: same. and the mediainfo output is the same like ffmprobes output ... the diff between dvsd dn dvvideo, which is both DV but quite different
[11:31:27 CET] <digidog> Mavrik: I assume the reason therefor lies maybe in the fact, that ffmpeg onlyknows one type of DV and writes another dv info ?
[11:31:35 CET] <Mavrik> I guess.
[11:31:54 CET] <Mavrik> digidog, if you could prepare a small sample and add a ticket to bugtracker it would probably help with fixing :/
[11:32:54 CET] <digidog> Mavrik: ok, I'll do that. thanks for your time Mavrik. I really appreciate it.
[11:34:33 CET] <digidog> Mavrik: one more test -> -c copy without header flag to see what happens then
[11:37:23 CET] <digidog> Mavrik: btw, the ffmpeg copy command needs exactly the same time like wehn I only run cp file in terminal. WHat actually proofs that there no transcoding could have been happend
[11:39:29 CET] <digidog> Mavrik: hm, ok last info for today, the -c copy without header flag creates the same file, same problem so we can tackle it down to the DV -c copy issue only
[11:40:39 CET] <digidog> Mavrik: thanks for your time. I'll report on bugtracker and try to collect as much details as possible. cu
[11:40:45 CET] <digidog> Mavrik++
[13:43:13 CET] <digidog> Mavrik: I think it is clear now after further testing. FFmpeg interprets the material as ffdv FFmpeg DV while it is actually dvcp (DVCPRO) a quicktime version of DV. This is a huge problem because it also affects all NLE working with FFmpeg. Lightworks e.g. has trouble t import these files which is counter productive since this NLE support SD output. We need the poss. to interpret DVCPRO DV material correc
[13:43:19 CET] <digidog> tly or at least a warning message to prevent wring transcoding.
[16:13:19 CET] <Elirips> hello. Is using the ffmpeg library as easy as using the ffmpeg exe? Currently, from my app I start one or more ffmpeg-processes - everything is fine. Would it be easy to change my app to directly work with the api of ffmpeg?
[16:14:17 CET] <Elirips> or asked the other way: If I have a command-line like 'ffmpeg --foobar and all my options here' - how complicated would it be to do the same using the lib? steps like connect to a source, extrac x frames per second, convert them to something else and store them at location bar?
[16:23:45 CET] <J_Darnley> Elirips: quite a lot harder.
[16:24:12 CET] <J_Darnley> there is no "libffmpeg" that will emulate the command line for you
[16:59:12 CET] <Elirips> J_Darnley: so, basically I would have to talk to the corresponding lib to connect to the rtsp stream, get data from it, feed that to the correct de- / encoder and then write that buffer to wherevery I want?
[16:59:40 CET] <J_Darnley> yes
[17:02:16 CET] <Elirips> J_Darnley: Do you know about any sample doing something like that?
[17:02:32 CET] <J_Darnley> not really
[17:02:46 CET] <J_Darnley> perhaps what's in the examples in the source
[17:04:11 CET] <J_Darnley> oh you could perhaps try ffmpegsource, a pluign for avisynth/vapoursynth
[17:04:22 CET] <J_Darnley> I think it is supposed to make some things easier
[17:04:39 CET] <J_Darnley> but I don't know whther they provide a library you can easily use
[17:05:46 CET] <Elirips> J_Darnley: thanks, I would prefer to work directly with only libffmpg. I'm looking at the examples now to get a first impression
[19:24:05 CET] <Worf> i'm looking for ways to batch post-process mobile-phone videos. currently i have quite good results using ffmpeg with vidstabdetect/vidstabtransform, atadenoise. However, denoising could be better. I've been told about filters like BM3D, but those are not available for ffmpeg (as far as i know). Any hints/suggestions/recommendations?
[20:58:24 CET] <Prelude2004c> hey guys.. question.. so set top box vender tells me they calculate the PVR start time with something like ' calculated = start_time + current_download_seg_time - _hlsMediaSrc->getCurrentSegmentDuration() - savedDur; "
[20:58:49 CET] <Prelude2004c> is there some way to tell ffmpeg to tell the pvr to delay start by say 10 seconds.. so if someone presses record it only actually starts to record 10 seconds after
[20:59:15 CET] <Prelude2004c> it seems they add some PVRSTARTTIME param and it always shows the start time at -6 which is the duration of the first segment
[22:30:20 CET] <rynsin> hi  Im trying to write a simple C program to convert audio in various formats to raw PCM. However, when trying to read from an ALAC stored in an m4a, the `avcodec_open2` function returns an error code for invalid data found when processing input& heres my code and the console output: http://pastebin.com/E1henRDp
[22:31:18 CET] <rynsin> (not sure if this belongs in user support or development& but since Im trying to be a user I figured it went here.) nb: ffmpeg -i test.m4a test.wav works fine.
[22:35:53 CET] <rynsin> it seems that most samples on the web are outdated (they call `avcodec_open` without the 2), or seem to do the same thing I am doing..
[22:37:02 CET] <durandal_1707> there are code examples in ffmpeg source code
[22:37:55 CET] <rynsin> I went through the examples linked in the doxygen. they are similarly outdated.
[22:38:24 CET] <rynsin> as for attempting to follow what ffmpeg CLI tool does& I tried, but was pretty quickly overwhelemed. There seems ot be a whole lot going on there.
[22:38:25 CET] <JEEB> I think these should still compile? https://github.com/FFmpeg/FFmpeg/tree/master/doc/examples
[22:38:30 CET] <rynsin> but if thats the way to go, I can try it
[22:38:33 CET] <rynsin> hmm. let me check.
[22:39:29 CET] <rynsin> ah! excellent. this seems to be up to date and contains a few things Im not doing
[22:40:50 CET] <rynsin> dont know how I got linked to the old examples& they came right out of the doxygen, though.
[22:41:00 CET] <rynsin> Ill give that a try. thanks& cant believe I missed that...
[22:41:33 CET] <JEEB> btw, if you want to be real clever you can do something ffmpeg cli doesn't
[22:41:49 CET] <JEEB> if you get negative timestamps, you don't output them
[22:42:09 CET] <JEEB> that is the way encoder delay and such are marked in formats it is stored in
[22:42:42 CET] <rynsin> ah ok I was wondering about that
[22:43:20 CET] <JEEB> ffmpeg cli tries to be too clever and when you f.ex. output to wav it will notice the fact that wav doesn't support negative timestamps. and it moves zero to the point of the first timestamp
[22:43:40 CET] <JEEB> which is why everyone and their dog believe that libavformat or -codec do not export this information
[22:59:08 CET] <rynsin> ah. my mistake was inspired by the code clip here: https://www.ffmpeg.org/doxygen/trunk/group__lavc__core.html#ga11f785a188d7d9df71621001465b0f1d   it implied that I needed to pass in an AVCodecContext produced by avcodec_alloc_context3(), which is not the case  one actually needs to use the AVCodecContext from the AVFormatContext.
[22:59:59 CET] <rynsin> the apparently-famous dranger tutorial warns against this, suggesting that one should allocate a new context and then use memcpy to make it match. this no longer works, presumably because some fields were added to AVCodecContext that arent maintained via a shallow copy
[23:00:07 CET] <rynsin> mystery solved  thanks @JEE8
[23:17:29 CET] <GreatEmerald> Is there a way to force ffmpeg to read a vorbis file whose first CRC checksum is damaged?
[23:18:14 CET] <GreatEmerald> I get a "Vorbis setup header packet corrupt (codebooks)." error, and the output is just as unreadable
[23:18:37 CET] <GreatEmerald> I believe that in older versions of ffmpeg this worked fine
[00:00:00 CET] --- Tue Jan 19 2016

More information about the Ffmpeg-devel-irc mailing list